## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>3</td>
</tr>
<tr>
<td>Poser Reference Manual</td>
<td>11</td>
</tr>
<tr>
<td>Foreword</td>
<td>12</td>
</tr>
<tr>
<td>Trademark &amp; Copyright Notice</td>
<td>14</td>
</tr>
<tr>
<td>Poser Introduction</td>
<td>15</td>
</tr>
<tr>
<td>Welcome to Poser!</td>
<td>16</td>
</tr>
<tr>
<td>What’s New in Poser</td>
<td>16</td>
</tr>
<tr>
<td>Included Documentation</td>
<td>18</td>
</tr>
<tr>
<td>System Requirements</td>
<td>21</td>
</tr>
<tr>
<td>When You Have Questions</td>
<td>23</td>
</tr>
<tr>
<td>About Your Reference Manual</td>
<td>24</td>
</tr>
<tr>
<td>Installing Poser</td>
<td>26</td>
</tr>
<tr>
<td>Contacting Customer Service and Technical Support</td>
<td>26</td>
</tr>
<tr>
<td>Installing Poser</td>
<td>26</td>
</tr>
<tr>
<td>Activating Poser</td>
<td>30</td>
</tr>
<tr>
<td>Registering Poser</td>
<td>32</td>
</tr>
<tr>
<td>Upgrading From an Earlier Version of Poser</td>
<td>32</td>
</tr>
<tr>
<td>Updating Poser</td>
<td>33</td>
</tr>
<tr>
<td>Choosing a Poser Startup Scene</td>
<td>33</td>
</tr>
<tr>
<td>Setting Up the Poser Workspace</td>
<td>36</td>
</tr>
<tr>
<td>Setting Application Preferences</td>
<td>36</td>
</tr>
<tr>
<td>Setting Up Your Workspace</td>
<td>46</td>
</tr>
<tr>
<td>Using the Log Window</td>
<td>49</td>
</tr>
<tr>
<td>Building Scenes</td>
<td>52</td>
</tr>
<tr>
<td>The Pose Room</td>
<td>53</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>54</td>
</tr>
<tr>
<td>Room Tabs</td>
<td>54</td>
</tr>
<tr>
<td>Editing Tools</td>
<td>55</td>
</tr>
<tr>
<td>Light Controls</td>
<td>55</td>
</tr>
<tr>
<td>Display Controls</td>
<td>56</td>
</tr>
<tr>
<td>Memory Dots</td>
<td>56</td>
</tr>
<tr>
<td>Document Window</td>
<td>57</td>
</tr>
<tr>
<td>Showing and Hiding Windows and Palettes</td>
<td>58</td>
</tr>
<tr>
<td>Animation Controls</td>
<td>61</td>
</tr>
<tr>
<td>Using the Shortcuts Editor</td>
<td>61</td>
</tr>
<tr>
<td>Other Basic Operations</td>
<td>63</td>
</tr>
<tr>
<td>The Document Window</td>
<td>69</td>
</tr>
<tr>
<td>Preview Tab</td>
<td>69</td>
</tr>
<tr>
<td>Render Tab</td>
<td>89</td>
</tr>
<tr>
<td>The Display Controls and Menu</td>
<td>94</td>
</tr>
<tr>
<td>Display Styles</td>
<td>95</td>
</tr>
<tr>
<td>The Display Menu Commands</td>
<td>98</td>
</tr>
<tr>
<td>Bend Body Parts</td>
<td>100</td>
</tr>
<tr>
<td>Paste Onto Background</td>
<td>101</td>
</tr>
<tr>
<td>Guides</td>
<td>101</td>
</tr>
<tr>
<td>Cartoon Settings</td>
<td>106</td>
</tr>
<tr>
<td>Measurement Mode</td>
<td>110</td>
</tr>
</tbody>
</table>
The Poser Library ................................................................. 112
Displaying the Library Palette ........................................... 116
About Library Palette Categories ...................................... 121
Maintaining Your Library Palette ...................................... 143
Accessing Different Content Libraries .............................. 151
Adding Extended Details to Library Content .................... 156
Metadata Builder ............................................................. 157
Searching the Library ....................................................... 158
Favorites Tab .................................................................. 161
Purchases Tab .................................................................. 162
Posing Figures ................................................................. 166
General Posing Principles ............................................... 166
Posing a Figure ................................................................ 170
Posing Body Parts ........................................................... 171
Selecting Body Parts ....................................................... 171
The Editing Tools ............................................................. 174
The Parameters/Properties Palette .................................... 182
Posing Faces .................................................................. 201
Posing Hands .................................................................. 208
Pose Dots ...................................................................... 209
Posing Animals ............................................................... 210
Saving Poses in the Library ............................................. 211
Other Posing and Figure Aids ........................................... 211
Working with Props ......................................................... 219
About Props .................................................................. 219
Clothing ...................................................................... 220
Adding & Importing Props ............................................. 221
Creating New Props ....................................................... 221
Creating Prop Parameters ............................................. 222
Prop Parameters ............................................................ 223
Prop Properties ............................................................... 223
Replacing a Body Part with a Prop ................................. 226
Changing Figures with Replaced Geometry .................... 227
Changing a Parent .......................................................... 227
Set Figure Parent ........................................................... 229
Grouping Objects ........................................................... 229
Using Constraint Channels ............................................ 233
Creating Simulation Proxies ............................................ 237
Creating and Using Text Props ....................................... 238
Creating and Using Measurement Objects ..................... 239
Using Control Props ....................................................... 247
Using Selected Polygons for Control Props .................... 249
Cameras ..................................................................... 252
Camera Controls ............................................................ 252
Camera Views ................................................................ 254
Positioning Cameras ....................................................... 258
Changing Cameras ........................................................ 261
Creating Cameras .......................................................... 261
Camera Properties & Parameters .................................... 261
Camera Parameters ....................................................... 262
Camera Properties ........................................................ 267
Pointing & Locking Cameras .......................................... 268
Poser Reference Manual

Camera Dots ................................................................................................................. 269
Saving Camera Sets ................................................................................................. 269
Using Depth Cueing ................................................................................................. 269
Lighting .......................................................................................................................... 271
Light Types .................................................................................................................. 272
Light Properties ......................................................................................................... 275
Light Parameters ........................................................................................................ 281
Working with Lights .................................................................................................. 284
Aiming Lights ............................................................................................................. 288
Materials ...................................................................................................................... 292
The Material Room ..................................................................................................... 293
Using Objects with Multiple Materials ...................................................................... 295
Assign View ................................................................................................................ 296
Edit View ...................................................................................................................... 301
Creating Layered Materials ....................................................................................... 303
Using Layer-Only Materials ....................................................................................... 303
Wacros ......................................................................................................................... 307
Shaders ......................................................................................................................... 311
Working with Nodes .................................................................................................. 313
About Nodes ................................................................................................................ 313
The Material Room Options Menu ............................................................................ 314
Material Room Node Connections ........................................................................... 316
Expanding/Collapsing Nodes ...................................................................................... 324
Entering Node Values .................................................................................................. 324
Deleting Nodes ............................................................................................................ 325
Animating Nodes ........................................................................................................ 325
Root Nodes ................................................................................................................ 327
Root Material (PoserSurface) Node ........................................................................... 328
Physical Surface Node (PhysicalSurface) ................................................................. 331
Cycles Surface Node (CyclesSurface) ...................................................................... 337
Other Root Node Types ............................................................................................. 337
Root Node Help .......................................................................................................... 347
Material Nodes .......................................................................................................... 348
Math Nodes .................................................................................................................. 348
Lighting Nodes ............................................................................................................ 354
Variable Nodes .......................................................................................................... 371
3D Texture Nodes ....................................................................................................... 373
Ray Trace Nodes ........................................................................................................ 382
2D Texture Nodes ....................................................................................................... 386
Cycles Nodes .............................................................................................................. 395
Color ............................................................................................................................... 395
Converter ...................................................................................................................... 402
Input ............................................................................................................................... 410
Shader ............................................................................................................................ 418
Using the PrincipledBsdf Node .................................................................................. 431
Texture ........................................................................................................................... 437
Vector ............................................................................................................................. 450
Compound Nodes ...................................................................................................... 454
Creating a Compound Node ....................................................................................... 454
Editing Compound Nodes .......................................................................................... 455
Collapsing Existing Nodes into a Compound Node .................................................... 458
Renaming Nodes and Connections .......................................................................... 459
Poser Reference Manual

Expanding Compound Nodes................................................................. 460
Saving Compound Node Fragments to the Library............................... 460
PBR ................................................................................................. 462
Using PBR Maps with Poser................................................................. 462
Common PBR Texture Tools and Maps ............................................... 463
Kitty1 Base Textures-Physical.............................................................. 466
Kitty2 Base Textures-Physical.............................................................. 470
Kitty3 Base Textures-Physical.............................................................. 472
Kitty2 Metallic Map-Physical.............................................................. 473
Kitty3 Metal, Emission and Opacity-Physical......................................... 475
Kitty1 Textures-Principled................................................................. 481
Kitty2 Textures-Principled................................................................. 484
Kitty3 Textures-Principled................................................................. 487

Rendering ....................................................................................... 493
The Render Menu ............................................................................ 494
Render in Background ....................................................................... 495
Antialias Document ......................................................................... 496
Motion Blur Document ...................................................................... 496
Using 3D Motion Blur ....................................................................... 497
The Render Settings Dialog ............................................................... 500
Render Engines ............................................................................... 500
Sketch Tab ....................................................................................... 501
Preview Tab ..................................................................................... 501
Render Settings Buttons ................................................................... 506
Tips & Tricks ................................................................................... 508
Using The FireFly Render Engine ...................................................... 509
Firefly Tab: Quality Settings ............................................................. 511
Manual Settings ............................................................................... 512
Indirect Light .................................................................................. 516
FireFly Options Settings ................................................................... 519
Saving and Loading Presets .............................................................. 523
Smoothing Geometry ....................................................................... 523
Gamma Correction and Linear Rendering .......................................... 527
Gamma Correction Per Texture .......................................................... 528
Rendering Layered PSD Files ........................................................... 529
Using SuperFly ............................................................................... 536
SuperFly Render Settings .................................................................. 536
Applying Post Effects to Renders ...................................................... 544
SuperFly Limitations ....................................................................... 553
Real-time Raytrace Preview .............................................................. 554
The Sketch Designer ....................................................................... 555
Sketch Designer Tabs ....................................................................... 555
Rendering Sketches ....................................................................... 556
Exporting Painter Scripts ................................................................. 556
Sketch Parameters ......................................................................... 556
Presets ............................................................................................ 558
Queue Manager ............................................................................... 560
Installing Queue Manager ............................................................... 560
Licensing Queue Manager ............................................................... 561
Sending Jobs to the Queue Manager ............................................... 562
Using the Queue Manager ............................................................... 564

Animating ....................................................................................... 568
Poser Reference Manual

Animating with Poser .......................................................... 569
  The Animation Menu .................................................. 569
  Animation Overview .................................................. 570
  Using the Animation Controls ....................................... 572
  Keyframes View .......................................................... 579
  Using Graphs ............................................................... 587
  Layers Tab .................................................................. 591
  Animation Sets Tab ...................................................... 595
  Using the Walk Designer ............................................... 596
  Sound ......................................................................... 603
  Using the Talk Designer ................................................. 604
  Advanced Animation Techniques .................................... 608
  Saving Animations to the Library ..................................... 610

Using Bullet Physics .............................................................. 611
  Creating a Simulation .................................................... 611
  Using Live Simulation .................................................... 611
  Calculating Simulations .................................................. 612
  Object Types .................................................................. 612
  Setting Object Properties ............................................... 615
  Simulation Settings ....................................................... 617
  Object Constraints .......................................................... 618
  Deleting a Simulation ..................................................... 624
  Saving Objects with Bullet Physics ..................................... 624

Rendering Animations .......................................................... 626

Customizing Content ............................................................ 631
  The Hair Room .................................................................. 632
    Step One: Defining Hair Groups ...................................... 633
    Step Two: Growing Hair ............................................... 635
    Step Three: Styling Hair ............................................... 636
    Step Four: Setting Hair Dynamics ...................................... 641
    Hair Properties & Parameters .......................................... 643
    Hair Colors and Materials .............................................. 645
  Adding Strand-Based Hair to the Library Palette ................. 646

The Cloth Room ................................................................. 647
  Using the Cloth Room ..................................................... 647
  Conforming vs. Dynamic Cloth ........................................ 648
  Adding Dynamic Clothing ............................................... 648
  Using Dynamic Clothing without a Figure ......................... 648
  Using Dynamic Clothing with Morphs ................................. 649
  Cloth Parameters & Properties .......................................... 661
  Creating Props and Morph Targets .................................... 661
  Adding Dynamic Cloth to the Library Palette ....................... 662

The Fitting Room ................................................................. 663
  Problems and Solutions .................................................. 663
  Preparing Your Scene ........................................................ 664
  Adjust Scale, Position, and Rotation .................................... 664
  Creating a Fitting Simulation ............................................. 667
  Fitting Simulation Methods ............................................... 668
  Painting Vertex Weights .................................................. 676
  Completing the Fitting Simulation ...................................... 679

Content Creation Tools .......................................................... 682
  Using Deformers ............................................................. 683
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magnets</td>
<td>684</td>
</tr>
<tr>
<td>Using Deformers with Grouped Objects</td>
<td>709</td>
</tr>
<tr>
<td>Modifying Figures &amp; Props</td>
<td>710</td>
</tr>
<tr>
<td>Creating Morphs with the Morphing Tool</td>
<td>711</td>
</tr>
<tr>
<td>The Combine Tab</td>
<td>712</td>
</tr>
<tr>
<td>The Edit Tab</td>
<td>714</td>
</tr>
<tr>
<td>Applying Pre-Transform Morphs</td>
<td>723</td>
</tr>
<tr>
<td>Saving Morph Injection Poses</td>
<td>726</td>
</tr>
<tr>
<td>Copying Morphs Between Figures</td>
<td>727</td>
</tr>
<tr>
<td>Using the Fitting Tools</td>
<td>729</td>
</tr>
<tr>
<td>Creating Morphs in Other Applications</td>
<td>731</td>
</tr>
<tr>
<td>Combining Morphs in Poser</td>
<td>732</td>
</tr>
<tr>
<td>Loading Full Body Morphs</td>
<td>735</td>
</tr>
<tr>
<td>Deleting Full and Partial Body Morphs</td>
<td>736</td>
</tr>
<tr>
<td>Using Dependent Parameters</td>
<td>737</td>
</tr>
<tr>
<td>Value Operations</td>
<td>749</td>
</tr>
<tr>
<td>Morph Dependent Joint Centers</td>
<td>751</td>
</tr>
<tr>
<td>Manually Adjusting Animated Centers and Orientations</td>
<td>753</td>
</tr>
<tr>
<td>Managing Morphed Figures</td>
<td>755</td>
</tr>
<tr>
<td>Figure and Prop Editors</td>
<td>757</td>
</tr>
<tr>
<td>The Group Editor</td>
<td>757</td>
</tr>
<tr>
<td>About Groups</td>
<td>757</td>
</tr>
<tr>
<td>The Hierarchy Editor</td>
<td>769</td>
</tr>
<tr>
<td>The Setup Room</td>
<td>778</td>
</tr>
<tr>
<td>Creating Figures for Poser</td>
<td>779</td>
</tr>
<tr>
<td>About the Setup Room</td>
<td>779</td>
</tr>
<tr>
<td>The Setup Room Interface</td>
<td>780</td>
</tr>
<tr>
<td>Setting Up an Original Figure</td>
<td>780</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>793</td>
</tr>
<tr>
<td>Working with Joints and Weights</td>
<td>794</td>
</tr>
<tr>
<td>What are Joints?</td>
<td>794</td>
</tr>
<tr>
<td>Using the Joint Editor</td>
<td>794</td>
</tr>
<tr>
<td>Joint Attribute Types</td>
<td>799</td>
</tr>
<tr>
<td>Creating and Using Falloff Zones</td>
<td>804</td>
</tr>
<tr>
<td>Setting Joint Angles</td>
<td>811</td>
</tr>
<tr>
<td>Editing Bulge Settings</td>
<td>812</td>
</tr>
<tr>
<td>Setting Joint Orders</td>
<td>813</td>
</tr>
<tr>
<td>Adding Affected Actors</td>
<td>814</td>
</tr>
<tr>
<td>Copying and Saving Joint Settings</td>
<td>816</td>
</tr>
<tr>
<td>Weight Maps</td>
<td>816</td>
</tr>
<tr>
<td>Fixing Mismatched Scales</td>
<td>832</td>
</tr>
<tr>
<td>Copying Joints from Another Figure</td>
<td>833</td>
</tr>
<tr>
<td>Transferring Zones and Weight Maps to Clothing</td>
<td>833</td>
</tr>
<tr>
<td>Skinning and Subdivision Surfaces</td>
<td>839</td>
</tr>
<tr>
<td>Skinning Methods</td>
<td>839</td>
</tr>
<tr>
<td>Working with Subdivision Surfaces</td>
<td>840</td>
</tr>
<tr>
<td>Modeling Considerations</td>
<td>844</td>
</tr>
<tr>
<td>Creating Subdivision Level Morphs</td>
<td>846</td>
</tr>
<tr>
<td>Developing with PoserPython</td>
<td>851</td>
</tr>
<tr>
<td>Using PoserPython</td>
<td>852</td>
</tr>
<tr>
<td>Why Python?</td>
<td>853</td>
</tr>
<tr>
<td>A Word of Warning</td>
<td>853</td>
</tr>
</tbody>
</table>
Foreword

Creator:
Larry Weinberg

Poser 13 Development Team:
Jennifer Blake, Tim Choate, Hugh Deidrichs, Walter Hunt, Roy Riggs, Brian Romero, Charles Taylor, Denise Tyler

Other Contributors:
Afrodite-Ohki, Cathy Argyrou, Ethan Basham, Shania Blake, Cliff Bowman, Kenneth Dahlqvist, Ken1171 Designs, Geoff Hicks, Carolyn Hunter, Karth, Jura Kerleha, Tommy Lemon, Brian Morton, Shane Newville, George Perkins, Matthew Pinchbeck, Tana Ragsdale, RAMWorks, Jacques Roulin, Richard Rountree, Scott D. Shaver, Wim van de Bospoort, VanishingPoint, Frans Verbass

Open source components include:

- Alembic [http://www.alembic.io]
- Boost C++ [https://www.boost.org/]
- Bullet Physics
- Cycles Render Engine [http://blender.org]
- Disney BRDF [http://www.disneyanimation.com/technology/brdf.html]
- Embree [https://www.embree.org/]
- FreeImage [https://freeimage.sourceforge.io/]
- FreeType [https://www.freetype.org/]
- HDF5 [http://www.hdfgroup.org]
- k-d tree point cloud: Henrik Wann Jensen [https://pointclouds.org/documentation/group_kdtree.html]
- Henrik Wann Jensen
- libCurl [http://curl.haxx.se/libcurl/]
- libjpeg [http://www.iij.org]
- libtiff [http://simplesystems.org/libtiff/]
- numpy [http://numpy.scipy.org]
- OpenImageIO [https://sites.google.com/site/openimageio/home]
- OpenEXR [http://www.openexr.com]
- OpenSSL [http://www.openssl.org]
- pcre [http://www.pcre.org]
- pthreads [http://sourceware.org/pthreads-win32]
- Python [http://www.python.org]
- Szip
- SFMT [http://www.math.sci.hiroshima-u.ac.jp/~m-mat/math.sci.hiroshima-u.ac.jp/MT/SFMT/]
- Skia [https://skia.org]
- Szip [https://support.hdfgroup.org/doc_resource/SZIP/]
- XMLRPC++ [http://xmlrpcpp.sourceforge.net]
Technology or content provided in part by

- Singular Inversions, Inc.
- Portions of the FireFly renderer and associated shading technologies ©2002 by Pixels Digital, Inc.
- Lip Sync Technology provided by Automatic Sync Technologies (www.automaticsync.com).
- Cloth Simulation by Size8 Software, Inc.
Trademark & Copyright Notice

Poser, Poser 13, the Poser logo, and the Bondware, Inc. Logo are trademarks and or registered trademarks of Bondware, Inc. Poser copyright © 1991-2023 All Rights Reserved. COLLADA is a trademark of Sony Computer Entertainment, Inc. Used by permission by Khronos. All other product names are trademarks or registered trademarks of their respective holders.
Poser Introduction
Welcome to Poser!

Thank you for purchasing Poser®. If you’ve never used Poser before, welcome! Are you upgrading from an earlier version of Poser? Welcome back!

Poser 13 introduces many new features. The most prominent is our integrations of the Cycles render engine. We call it SuperFly. This brings not only the realism of a physics based renderer but also the speed of GPU support. That means our new render engine can harness the power of your nVIDIA graphics card to speed up renders.

Realism aside, we’ve also added powerful features for comic style renders. We’ve enhanced our already powerful comic book mode with a new Geometric Edge Lines. This gives you a new level of control over the outside “ink” lines of your image.

We’ve also added tools to make posing your scene easier. One of these is the Custom Parameter Palette. This is a persistent palette where you can add parameter dials from any part of your scene. It gives you ready access to frequently used parameters. Our new generation of figures include fully rigged faces. The rigged faces make creating compelling expressions fast and easy. Just point to the part of the face you want to affect and drag the face control to adjust the expression.

Content is critical and we’ve gone to great lengths to make Poser content more flexible, powerful and easy to use. We’ve also add several new tools to make creating content for poser easier. There is a new tool to automatically create Adaptable Rigs, rigs that adjust their proportions to match even the most drastic morphs. We added new rigging symmetry tools. We even included a tool to create distributable morph injections right from the file menu.

As Poser turns 21 you’ll find it has grown into an even more powerful tool. Even with all that power it will remain familiar to past users and easy to learn for those of you stepping into the Poser Universe for the first time. No matter what you use Poser for it is the fast, fun and easy way to bring your art to life.

What will you create?

What’s New in Poser

Poser includes the following new features:

New Features and Improvements

Content Creation
• The File > Load Full Body Morph command now allows you to import multiple full body morphs at the same time. See updates to [Loading Full Body Morphs](#).

## Import/Export

• New File > Export > Save for Sharing command gathers all or selected items in a file, and packages them in a Runtime ZIP file. See [Exporting Files for Sharing](#).

## Library

• Purchases tab now allows login using your registered email address or username when logging in to Renderosity or Poser Software stores. See [Purchases Tab](#).

## Lights

• The Light Controls palette makes it easier to create different light types. See [Working with Lights](#).
• When creating a Diffuse IBL light, you are prompted upon creation to select an IBL image and whether or not to include Ambient Occlusion. See [Working with Lights](#).

## Materials

• Material Room allows you to create a new layer-only material that can be applied above base layer or other layer materials. The new file extensions MLC (uncompressed) and MLZ (compressed) display different icons in the material library to distinguish them from standard material collections. See [Using Layer-Only Materials](#).

## PoserPython

• Access to new features accessible in Python include Match Centers to Morph, Joint Order, and Copy Morphs From.

## Rendering

• Addition of PostFX operations on renders and animation. Operations include denoising, exposure, saturation, blur, pixelate, gamma, brightness, and bloom. See [Applying Post Effects to Renders](#). Renders sent to the Queue Manager can also have PostFX applied.

## User Interface

• The Float/Dock buttons located in Poser palettes and dockable windows has been brightened to improve visibility (general application-wide change).
Included Documentation

Poser includes the following documentation:


The **Online Documentation** can be translated to your language of choice through the use of Google Translate. If you use the Chrome browser you can download the Google Translate for Chrome extension here:

- **Google Translate for Chrome**

If you do not use Chrome, you may find similar translation extensions for your browser of choice.

Using the Online Help

Poser’s online help is clean, intuitive, and easy to use. The online help initially opens to the Online Cover Page. The Table of Contents appears in the left pane.

Poser’s Online Documentation includes the following controls:

1. **Table of Contents**: Click this icon to display the Table of Contents in the left pane. You can expand or collapse the folders and topics to select the topic you want to read. Click the topic to display it in the topic window (6).

2. **Index**: Click this icon to display the Index in the left pane. For further information, see Index View.
3. **Search**: Click this icon to display the Search and Search Results in the left pane. For further information, see **Searching the Help** below.

4. **Left Pane**: The left pane displays the Table of Contents, Index, or Search Results depending on the view selected with icons described previously.

5. **Breadcrumbs**: Click any level in the breadcrumb trail to move through the topic hierarchy.

6. **Topic Window**: The topic you select displays in the topic window.

7. **Search entry**: You can enter a search term in this window to display search results in the left pane. You can also enter search terms when the Search results are displayed in the left tab. For more information see **Searching the Help** below.

8. **Remove Highlight**: When you select a page from the search window, your search term(s) will be displayed on the topic page highlighted in yellow. Click the Remove Highlight button to turn the highlighting off.

9. **Print**: Prints the page that is currently displayed in the topic window, to your selected print destination. Printers available on your computer will be listed in here. If you have a "Save as PDF" printer option you can also use that to save the current page to a PDF file.

10. **Back button**: Click the Back button to navigate to the previous topic in the manual. This button will not appear when you are on the first page of the manual.

11. **Next button**: Click the Next button to navigate to the next topic in the manual. This button will not appear when you are on the last page of the manual.

**Index View**

When you select the Index View (see #2 in **Using the Online Help**) a complete A to Z list of index topics is displayed in the left pane. Click a topic to select the topic you want to view, as shown on the left in the following figure. When topics appear on more than one page, the related topics will be displayed below the selected index entry.

You can filter the index to display index entries that contain a particular word or phrase. For example, entering the word alias will display index entries that have the letters alias, in whole or in part. as shown on the right in the following figure.
Searching the Help

You can enter a search term in any left pane view by entering your search term in the Search field at the top of the Online Help window (see #7 in Using the Online Help, above).

You can also enter a search term when the left pane displays the Search pane (#3 in Using the Online Help, above). The Search results will list up to 50 entries.

- Enter a single word to display topics that contain that word. Note that similar results will also appear in the results list. For example if you enter the word parameters, the search results will also list topics that contain the word parameter.

- Enter two or more words to display topics that contain any or all of the words listed. For example, if you enter the words parameters palette, the search results will list topics that contain either the word parameters (and its variations) or palette (and its variations).

- To search for a specific phrase, enter the search term in quotes. Entering "parameters palette" (with the quotes) will display pages that contain that specific phrase.

Select one of the search results in the left tab to display the topic. The words entered in the search term will be highlighted in yellow when the topic is displayed. You can turn highlighting off with the Remove Highlight control (see #8 in Using the Online Help, above).
System Requirements

System requirements for Poser installation are as follows:

**Windows**

- Windows 10 or later (64-bit OS required)
- 2 GHz Intel Core 2 or newer, Athlon 64 or newer (2.5 GHz or faster recommended)
- 4 GB system RAM (8 GB or more recommended)
- OpenGL enabled graphics card or chipset required for hardware accelerated preview.
- 24-bit color display, 1440 x 900 minimum resolution
- 3 GB free hard disk space (20 GB required to install all included content)
- DVD-ROM drive (physical product only)
- Internet connection for updates and required online activation.
- CUDA and OptiX enabled device recommended for hardware accelerated final rendering (2 GB RAM minimum, Compute Capability 5.0 minimum).
• OptiX-accelerated raytracing requires Nvidia RTX or Turing GPU, or newer.
• ZBrush 4 or later required for GoZ interoperability. (ZBrush 2021 recommended)

Mac

• Mac OS X 10.15 or higher (64-bit OS required)
• 2 GHz Intel Core 2 Duo processor (64-bit CPU required)
• Runs on M1 (ARM) through Rosetta.
• 4 GB system RAM (8 GB or more recommended)
• OpenGL enabled graphics card or chipset required for hardware accelerated preview.
• 24-bit color display, 1440 x 900 minimum resolution
• 3 GB free hard disk space (20 GB required to install all included content)
• DVD-ROM drive (physical product only)
• Internet connection for updates and required online activation.
• ZBrush 4 or later required for GoZ interoperability. (ZBrush 2021 recommended)

If you close Poser down on the Mac and then reopen it soon afterward, you may receive a message that another instance of Poser is already running or still shutting down. This may be due to a lock file that was left after restarting.

To remove the lock file:

1. Open Finder.
2. Go to the location where you want to see any hidden folders.
3. Click the COMMAND-SHIFT-Period shortcut combination.
When You Have Questions

As you begin using Poser for your 3D projects, you’ll undoubtedly have questions or want to network with other Poser artists. You’re not alone! There are many resources available for Poser artists. Here are just a few:

Need Help?

Poser includes the Help menu, which serves to answer most of your questions while using the application:


- **Room Help**: Selecting Help > Room Help opens an HTML help page for the room that you are currently using.

- **About Poser**: Displays the Poser version and copyright information. Macintosh users should look in the Poser Application menu, and select About Poser, to see this information. This option will be useful if you need to obtain technical support, since the Technical Support representative will need to know this information.
Poser Software Resources


---

Bondware, Inc. does not regulate content on third-party forums and their listing and order of appearance in this manual is not an endorsement.

Other Important Resources

Visit the following sites to learn about some of the applications and technology supported by Poser:

- **Python resources**: The following is a small sample of the ever-growing body of online and hardcopy information concerning the Python scripting language:
  - The basic Python interpreter (which allows you to write your own Python scripts for any desired purpose) as well as many in-depth documents and links to other online resources is available for free download at [http://www.python.org](http://www.python.org).
  - You can find additional online resources on wxPython at [http://www.wxpython.org](http://www.wxpython.org).
  - *wxPython in Action* by Noel Rappin and Robin Dunn; Manning Publications; ISBN # 1-932-39462-1

About Your Reference Manual

Bondware, Inc. strives to provide documentation that is complete, accurate, informative, and friendly. Your feedback is always welcome. Please e-mail your comments to: support@posersoftware.com.

The Poser Reference Manual is for both Macintosh and Windows. By convention, Macintosh commands precede Windows commands in the text. The Poser interface for Macintosh and Windows platforms is identical, unless otherwise specified.

For clarity, this manual uses several notational conventions to present information of special importance. Lists of items, points to consider, or procedures that do not need to be performed in a specific order appear in bullet format:

- Item 1
- Item 2

Procedures that must be followed in a specific order appear in numbered steps:

1. Perform this step first
2. Perform this step second

Specific keyboard keys are depicted in square brackets and are capitalized. For example: [ESC]. If more than one key should be pressed simultaneously, the notation appears as [KEY1]+[KEY2], for example [ALT]+[F4]. When a modifier key differs between the Macintosh and Windows platform, the Macintosh modifier is listed first followed by a slash and the Windows modifier key. For example, [COMMAND][CTRL]+[I] is equivalent to the Macintosh [COMMAND]+[I] and the Windows [CTRL]+[I].

Screen prompts, menu and window names, fields, buttons, boxes, etc. appear in **bold** type. Where you need to access a palette, command, or submenu, the syntax is **Menu > Submenu**. For example **File > Save As** means you should open the **File** pull-down menu and then select **Save As** to open the **Save As** dialog box.

Program and script code appears in standard Courier font, for example:

```
cd\letters\business\legal  [ENTER]
```

---

**Notes** detail tips, tricks, and other important information.

**Warnings** alert you to potentially harmful consequences such as data loss.
Installing Poser

When installing Poser, please take a moment to read, understand, and agree to the Poser End User License Agreement (EULA) that appears during installation. If you do not agree with the terms of the EULA, please return your entire Poser package including the unopened DVD holder to Bondware, Inc. or your place of purchase. Once you have read and accepted the EULA, you may proceed with installing Poser on your system.

The Poser Software online store will accept the return of either physical or electronically downloaded products purchased directly from PoserSoftware.com within 30 days of the date of purchase. Products purchased in retail stores must be returned to the place of purchase and meet their specific return policy terms. Bondware, Inc. reserves the right to change this policy at any time.

Contacting Customer Service and Technical Support

For Customer Service questions or problems (returns, warranty), please visit https://support.posersoftware.com

For technical support, please refer to Technical Support.

Installing Poser

You can find the most recent Poser 13 installers online at https://www.posersoftware.com/downloads. Windows and Mac installers are available.

Poser comes with several gigabytes of content that you will need to download and install separately. You will need to enter your Poser 13 serial number to download the included content. You can also download and install the included content from the Poser library.

Installing Poser is a straightforward process. Before running the installer, be sure to save any work in progress and close all running applications, including virus-checking utilities and other “background” software. Having this “clean” environment will help the installation process.
proceed smoothly and will prevent any loss of data in the highly unlikely event of a problem. To install Poser, complete the following steps:

**Poser Installation (Windows)**

1. Click on the Poser installer (Install Poser 13.exe) to start the Installer.

2. Setup displays a screen that prompts you to select the language for installation. After choosing the language, click **OK** to continue.

3. If a previous installation is detected you will be prompted to uninstall it before continuing. Choose **Yes** (recommended) to continue with uninstalling (you will be asked to confirm again, by choosing **Yes**).

   *If Poser is running while you attempt to run setup, the installer will prompt you to shut Poser down before you uninstall it.*

4. After the previous version is uninstalled choose **OK** to continue with installation.

5. The Poser End User License Agreement (EULA) appears. Select **I accept the agreement** and click **Next**.

6. The **Information** screen appears. Review the Readme file. This file contains information that was too recent to be included in this manual. Please take a moment to read this file, as the changes outlined therein may affect how you install and/or use Poser. When you have finished reading the Readme file, click **Next** to proceed with the installation.

7. The Select Destination Location screen appears. Use this screen to select the installation path for the Poser executable. Select the destination location where you want to install Poser. You can use the default location or click the **Browse** button to specify another location, click **Next** to continue.
If Poser 13 has previously been installed on your computer, setup will notify you that the default destination folder already exists on your computer. Answer Yes to install to that location anyway.

Choosing an installation location.

8. The Select Components screen appears. Choose the desired installation options from the drop-down menu:

- **Full Installation**: Most users choose the Full Installation option. This option performs the complete installation of Poser including all core content. The Queue Manager will also be installed.

- **Queue Manager Only**: Installs the Poser Queue Manager. Use this option for installing additional network rendering nodes. For more information see Installing Queue Manager.

9. Click **Next** to continue to the Select Content Location screen. Select the location for the Poser content Runtime directory. Based on the descriptions below, select the location that works best for you and click **Next**.

- **Shared Documents Directory**: This is the default installation option. Files can be shared—useful in multi-user environment or when UAC is enabled on Windows Vista or later.

- **Other Location**: Specify the directory of your choice. This option is desirable if you want to install the Poser content to a different hard drive or folder name.

10. If you selected **Other Location** in the previous step, the **Select Custom Content Location** screen appears. Use this screen to choose the installation folder for your Poser content.
By default for Window 7 and later, setup installs the content folder beneath the Users > Public > Documents folder on the C: drive; however, you can browse to or enter the folder or hard drive of your choice. Click Next after you make your choice.

11. The **Select Start Menu Folder** screen will appear. You can use the default location or click the Browse button to specify another location. When you are finished, click **Next**.

12. **Select Additional Tasks** screen will appear. Options here allow you to remove, backup or reuse existing preference files that store information such as library runtimes, interface layouts, and other preferences. You can also enable the check boxes to create desktop icons for Poser and the Queue Manager. Click **Next** after you make your choices.

13. Review your choices in the Ready to Install screen. Finally, click **Install** to install the Poser application. When they are finished installing, click **Finished**.

14. The final screen provides options to visit the Poser website and/or to launch Poser. After you make your selection, click **Finish** to exit the installer.

Some features of Poser require that you allow local network communication to operate. The features will not work if a personal firewall prevents local network communication.

### Poser Installation (Mac)

*It is recommended that you install Poser on a hard drive that is formatted with HFS+ Journaled formatting. Extended Journaled formatting can be used as long as you do not make it case-sensitive.*

1. Double-click on the Install icon.

2. The Introduction screen appears. Click **Continue**.

3. The Poser End User License Agreement (EULA) appears. Click **Continue** and then **Read License** to read the license. Click **Agree** to continue the installation.

4. The Installation Type screen appears. Click **Continue**.

5. Setup informs you how much space will be used by the installation, including the content you selected. Click **Install** to continue.

6. The Authentication window appears, and you will be asked to enter your user account password, or an account name and password with Administrator privileges, in order to proceed with the installation. After entering the information, click **Install Software** to continue.

7. When the installation is complete, click **Close**.
8. The final screen asks if you would like to move the Poser 13 installer to the trash. Click **Keep** to keep the installer, or **Move to Trash** to delete it.

### Activating Poser

After installing Poser you will need to activate within Poser’s 21 day grace period. If you do not activate Poser during the grace period, Poser will not start until activated. You will need to reactivate in order to use the product.

If you have not activated within the grace period, Poser will display a dialog that allows you to Quit (which exits the activation process), Activate Later (which allows you to run Poser if you are still in the grace period), or to Activate (which allows you to complete Automatic as described below).

*If you try to run Poser after the seven day grace period has expired without activation, the application will not run. You will need to enter your serial number again when prompted to activate the application.*
Automatic Activation and Registration

If your computer has an Internet connection, Poser can be activated and registered as follows.

Product Registration Screen.

1. Enter your **Full Name, Poser Serial Number, Previous Serial Number** (if upgrading), and **Email address** in the fields provided.

2. After you fill in other optional information, click the **OK** button to open your activated copy of Poser.

Checking the **Allow this application to send analytics information to Bondware, Inc. option will help Technical Support should you require assistance.**

If you need to activate Poser after installation, choose **Help > Registration** to bring up the Product Registration screen. Enter your Poser serial number...
Registering Poser

After installation, you can choose to register your copy of Poser via the Web. Registering Poser with Bondware, Inc. is required in order to receive technical support, free product updates and other benefits.

1. If you wish to register your copy of Poser, simply check the box on the authentication window that appears upon your initial launch of Poser, and Poser will automatically register your product for you with Bondware, Inc. If you use this method, this is the only action necessary on your part; the rest will be taken care of automatically.

An internet connection is required for trial, registration and license check.

2. Select the version of Poser that you wish to register from the drop-down list, and click the Next button to continue.

3. Enter your user information in the form that appears in your browser. Fields marked in red are required for you to register your copy of Poser. Enter your information, then click Register to complete your registration.

4. If one or more fields are missing information, a message will display specifying the incomplete fields. You will be asked to add the necessary information and resubmit your user information. Once your registration is successful, a summary screen will appear. Thank you for using Poser by Bondware, Inc.

Upgrading From an Earlier Version of Poser

When upgrading from an earlier Poser version, be sure to install Poser in a separate, empty folder, so as not to interfere with existing Poser installations. Additionally, if you have large amounts of content from your previous versions of Poser, the ideal way to add this content to your Poser installation is with the Add Runtime feature. (See Accessing Different Content Libraries for more information about the Add Runtime feature.) We do not recommend attempting to copy over or reinstall your content in other ways, as we cannot guarantee that the content will be properly transferred to Poser.
Updating Poser

Bondware, Inc. is committed to supporting all of our products by releasing frequent updates that address issues present in earlier versions and/or enhance the product’s usability or functionality. Please visit https://www.posersoftware.com/downloads to download the latest updates.

Choosing a Poser Startup Scene

The Poser Launcher screen allows you to launch Poser using one of four different launch options. Your Launch preference can either be set in the Document tab of the General Preferences dialog (see Document Preferences), or by using the Launch Options button in the Poser Launcher (described below).

If you choose any other option

When you start Poser up with the Launch to Launcher screen enabled, you are prompted to choose a startup scene. Recent scenes that you worked on are listed in the upper left portion of the startup screen. Various startup scenes are listed in the lower left portion of the startup screen. When you click a scene, a preview appears in the right portion of the startup screen.

Choosing a startup scene.

The items in the launcher are as follows:
A 300 x 300 thumbnail preview appears in the launcher when you select one of the scenes in the Recent or Startup Scenes list.

- **Recent Scenes**: Displays a list of scenes that you have recently opened and saved in Poser.

- **Startup Scenes**: Displays a list of commonly used startup scenes:
  - **preferredState**: This option appears in the Startup Scene list after you choose a preferred startup scene in Document Preferences.
  - **Alternate Construct**: Opens a scene that contains the Poser Construct, and four lights. One point light, one area light, and two spotlights are created.
  - **Developers Workspace**: Opens a scene with a flat ground plane. Six infinite lights are placed in the scene at top, bottom, front, back, left and right.
  - **Empty Scene**: Opens a completely empty scene (no ground, props, figures, or lights).
  - **Factory Scene**: Opens the Poser factory scene. This scene uses the construct and the Poser startup figure.
  - **La Femme Default Scene**: Opens a scene that contains the Poser Construct and four lights, similar to the Alternate Construct above. La Femme, hair, and the 1PC Suit are also added to the scene.
  - **Mondello Beach**: Opens the Poser environment sphere using a beach HRDI image as a background environment.
  - **Wide Street**: Opens the Poser environment sphere using a street HDRI image as a background environment.

You can find additional HDRI images for use with the Poser environment sphere at sIBL Archive.

See BG Environment for more information on how to use the BG Environment node.

- **Open Scene**: After you select one of the scenes from the Recent or Startup list, click Open Scene to open the file in Poser.

- **Browse**: Click this button to locate and open a Poser file that does not appear in either the Recent or Startup list.

- **Launch Options**: Click one of the following options to display when you open the Poser application:
  - **Launch to factory scene**: Opens the factory scene in Poser (the La Femme Default Scene), with the filename of Untitled. The launcher will not be displayed.
• **Launch to preferred scene**: Opens Poser with the Preferred State scene, as selected in Document Preferences. The file will open with the filename of Untitled. The launcher will not be displayed.

• **Launch to launcher**: Displays the launcher screen when Poser starts.

• **Launch to most recent**: Opens Poser with the scene you most recently saved in Poser. The filename saved with the file will remain. The launcher will not be displayed.

_To reopen the launcher screen from within Poser, choose File > Close to close your current scene. The launcher screen will reappear and you can choose another scene._

• **Poser Manual**: Opens the Poser Documentation in your default Web browser.

• **Renderosity Poser Forum**: Opens the Poser 12 Forum in your default Web browser.

• **Poser Technical Support**: Opens the Poser support center in your default Web browser.

• **PoserSoftware.com**: Opens PoserSoftware.com in your default Web browser.

• **Exit Poser**: Click this button to exit Poser.
Setting Up the Poser Workspace

This chapter discusses the ways in which you can customize Poser to suit your individual needs. Your preference settings will be stored on your system in the home directory for your user name. This allows different users on the same system to set up their own individual preference settings. For specific information on the location of the preference files on your system, please see Poser Default File Locations.

Setting Application Preferences

Poser’s General Preferences dialog allows you to control certain global Poser settings. Open this dialog by selecting Edit > General Preferences. The General Preferences dialog appears.

Click the OK button when finished to save your preferences and close the dialog. The following topics describe the available preferences.

Document Preferences

The Document Preferences tab contains settings specific to the Document. The Document Preference options are as follows:

- **Launch Behavior**: The Launch Behavior options allow you to specify whether Poser will open using your own custom scene, or to the default startup scene shipped with Poser.
  - **Launch to preferred scene**: If you customize the Document by changing the character or props that load when you start Poser, click the Set Preferred Scene button.

![Document Preferences](image)

**Document Preferences.**
button to save these changes as a preferred startup scene. Then verify that the Launch to Preferred Scene button is selected to open Poser with that scene.

• **Launch to factory scene**: Reverts Poser to its default (as installed) location and size whenever you launch Poser.

• **Launch to Launcher**: Choose this option to display the Poser startup screen when you start Poser. See Choosing a Poser Startup Scene for more information.

• **Launch to Most Recent**: Opens Poser with the scene that you last saved.

• **Set Preferred Scene**: Click this button after you arrange your document window the way you like. This will save it as the preferred startup scene.

  **After you click the Set Preferred Scene button, it will be listed in the Startup/Launcher as an available startup option. See Choosing a Poser Startup Scene for more information.**

• **Undo/Redo**: The Undo/Redo options allow you to specify the maximum number of levels for the Undo/Redo cache. You can reduce the level to conserve memory. Clicking the Clear cache now... button will clear the Undo/Redo cache.

• **Smoothing**: The Default Crease Angle setting allows you to specify the default Crease Angle to be used in polygon smoothing calculations. Please refer to Smoothing Geometry for more information on the Crease Angle setting.

• **Auto-save**: Options in this section enable or disable the auto-save feature, and specify intervals and other settings.

  • **Enable**: Check this option to enable auto-saving of your project.

  • **Seconds before saving**: Enter the number of seconds of idle time before a file is automatically saved.

  • **Auto-save interval (minutes)**: Enter the number of minutes in the field provided. For example, if you enter 10, your project will be auto-saved every ten minutes.

  • **Number of versions**: Enter the number of saved versions of your project that you want to keep.

  **Auto-save also works with the File > Open and File > Revert commands. When you choose File > Open, Poser will offer to open an auto-saved version of a file when it is newer than the project file you are trying to open. If you choose File > Revert, Poser allows you to revert to the last version of the file that you saved, or to any auto-saved versions.**

  **Auto-Save will be suspended while you are working in the Setup Room, and will resume when you return to the Pose Room.**
Interface Preferences

The **Interface Preferences** tab contains application-level settings for Poser’s general user interface. The Interface Preference options are as follows:

![General Preferences](image)

**Launch Behavior**: Includes the following options for Poser launch behavior:

- **Launch to preferred**: If you customize the Poser interface by adding, removing, rotating, resizing, and/or hiding different elements, or by creating your own palette arrangements in any of the Poser rooms, you can save this as your preferred launch behavior. After you finish making changes, click the **Set** button to save the UI as your preferred state.

- **Launch to previous state**: Relaunches Poser using the UI layouts that were being used the last time you exited Poser.

- **Launch to factory state**: If you want your Poser interface to revert to its default (as installed) location and size whenever you launch Poser, select the **Launch to factory state** button.

**Mouse Input**: The **Tablet Mode** option decreases the sampling rate for greater accuracy when using a graphics tablet as the input device. If your button has a scroll wheel, you can check the **Scroll to Zoom** option to zoom in and out of your scene. Uncheck the option to disable this feature.

*If you wish to operate Poser with a graphic tablet, please make sure to activate Tablet Mode in Edit -> General Preferences -> Interface -> Mouse Input.*

**Object Popup Menu**: When you use the Object Popup menu to select an actor in your scene, the menu arranges them in a series of submenus. The value entered in the **Hierarchical Threshold** field determines the maximum number of actors that are allowed to appear in a menu item before they appear in a branch beneath the previous
Object Popup menu hierarchy.

- **UI Scale:**
  - **Interface Scale Factor**: Allows you to set interface scaling values for high resolution displays, such as Mac Retina displays. UI scaling is also helpful for those who require larger font sizes. The default is 1.00 for normal resolution displays. Be careful not to use values that are excessively large or small. The changes will not take effect until you restart Poser.

- **Language**: Use the dropdown list to choose between English, German, or Japanese.

- **Display, Color Blind Accessible**: Check this option to use an interface that is designed for those who are color-blind.

- **Display Units**: Poser allows you to work with real-world units, enhancing your ability to make accurate recreations. Use the **Display units** pull-down menu to make your selection. The available choices are:
  - Poser native units
  - Inches
  - Feet
  - Millimeters
  - Centimeters
  - Meters

<table>
<thead>
<tr>
<th>Conversion Factor</th>
<th>Unit Conversion</th>
</tr>
</thead>
<tbody>
<tr>
<td>One Poser native unit is the equivalent of 8.6 feet, or 262.128 centimeters.</td>
<td></td>
</tr>
<tr>
<td>Multiply Poser units by 8.6 to convert to feet</td>
<td></td>
</tr>
<tr>
<td>Multiply Poser units by 2.62128 to convert to meters</td>
<td></td>
</tr>
<tr>
<td>Multiply Poser units by 262.128 to convert to cm</td>
<td></td>
</tr>
</tbody>
</table>
Multiply Poser units by 2621.28 to convert to mm

- **3D Mouse**: The 3D Mouse options control the behavior of a 3D input device such as 3Dconnexion’s SpaceNavigator. Checking the **Reverse Cameras** box changes the direction the main and auxiliary cameras rotate when using a 3D mouse. Checking the **Reverse Dolly Cameras** box reverses the direction the dolly cameras rotate when using a 3D mouse. Checking the **Reverse Actors** box reverses the direction actors move when controlled with a 3D mouse.

  *When using a 3D Mouse (such as SpaceNavigator or similar), by default all rotation axes and translations will be transmitted. Holding down the Shift key will filter out translations, and holding down the CTRL key (Windows) or CMD key (Mac) will filter out rotations.*

- **Shortcuts**: Press this button to open the Shortcuts Editor. For more information, see [Menu Commands and Shortcuts](#).

**Library Preferences**

The **Library Preferences** tab contains setting that are specific to the Poser Library. The Library Preference options are as follows:

- **Double-click Behavior**: The Double-click Behavior setting specifies the results of double-clicking on a Library preset. Select the appropriate radio button to choose between adding the new preset to the scene, or replacing the selected preset in the scene. Note that the first time you double-click on a Library preset, a dialog will come up allowing you to specify this setting. Your selected option will then be applied to all subsequent double-click instances, unless you change the setting in the Library Preferences tab.
• **File Search**: When an object is loaded from the Library, Poser searches for all the associated files included with that object. The File Search options allow you to configure the extent of that search. These options are:

  • **None**: Selecting None disables file searching; this option is useful for content developers in testing the accuracy of newly developed content, as it checks only the file locations that are specified in the Poser files. Referenced files will also be found next to a scene document when search policy is set to None.

  • **Shallow**: Selecting Shallow will reduce the amount of time spent searching for missing or mislabeled files, but will increase the instances of files not found. This option looks in all runtimes for the item, using the relative path and filename provided. For example, if the file specified is Runtime/geometries/FolderA/ObjectA.obj but the file actually lives in an external runtime folder named C:/MySpecialFolder/Runtime/geometries/FolderA/ObjectA.obj, then the shallow search will find it. The Shallow search will also find ObjectA.obj in any directories that are already known by Poser.

  • **Deep**: This is the default File Search setting. We recommend that you select Deep file searching, as this option initiates the most extensive searches for content file components, hence increasing the likelihood that missing or mislabeled files will be found. This performs a thorough search in all Runtime folders.

    *It is recommended that content developers set the File Search to None when testing the packaging of content that is intended for distribution. Doing so will help determine if geometry files and textures appear in the correct locations and paths as designated within the library files. Error messages will display when content files are not in their expected locations.*

    *If your Runtime folders are extremely large, resulting in Deep search results that take too long to find missing files, consider changing to a Shallow search.*

• **Indexing**: By default, Poser indexes libraries on first launch. Check the Refresh on Launch option if you want indexing to occur each time you launch the library.

**Render Preferences**

The Render Preferences tab contains settings that are specific to the FireFly render engine. The Render Preference options are as follows:
Render Preferences.

- **Number of Threads**: If you have a multi-processor and/or multi-core hardware system, you can take advantage of multi-threaded rendering by setting the Number of Threads slider to a value greater than one.

  We recommend rendering your scene with as many threads as your system possesses CPU cores. The default value for hyper-threaded CPUs is twice the number of cores that you have (because the OS sees twice as many virtual cores as there are physical cores). On CPUs that are not hyper-threaded, the OS sees only the physical cores. If you are unsatisfied with the resulting performance, or if the render fails to complete, then reduce the number of threads and/or maximum bucket size. However, if you have a single-processor and single-core system, we recommend that you set the number of threads to one, as the increased memory demand of running parallel threads may offset the performance benefits.

  For more information on multi-threaded rendering, see Using The FireFly Render Engine.

- **Cache**: The Max Cached Renders setting allows you to configure the number of renders that will be cached for access via the Render Compare feature in the Document's Render tab, or the number of thumbnails that are displayed in the Recent Renders palette. Please see Render Comparison for more information about the Render Compare feature. For more information about the Recent Renders palette, see Displaying Recent Renders.

- **Texture Caching**: Cached textures are kept in the temp location specified in General Preferences, even between sessions.

- **Persistent size (MB)**: The maximum amount of memory allocated to cached textures, in between sessions. When you re-launch Poser, textures from the previous session are still
cached on disk (unless you set the size to zero). If you re-open the scene you worked on previously (or one of the recent scenes, if the cache is large enough) the texture cache will be prepared already, allowing for a faster render start.

- **Run in Background Thread**: Loads textures into the cache while Poser is running, in preparation for the first render. Any texture that is not yet in the cache, or not yet up to date in the cache, needs to be processed. If **Run in Background Thread** is enabled, this processing happens in a separate thread in the background (on multi-core CPUs only). Chances are that by the time you are done preparing the scene for rendering, all your textures are in the cache already, and rendering will start immediately.

- **Render Cache Folder**: Specifies the location for your render cache. To change the location, click the **Change** button and select the folder of your choice. Click **Reset** to reset to the default location of Users > (user name) > Documents > Poser > 13 > Render Cache. If you change the location of the render cache, you will be notified if older renders exist in the original location. Move them to the new location if desired.

The render cache for keeping rendered images and displaying them on the Render tab of the **Document** and in the Recent Renders Palette uses the following locations to store image data:

Windows example:

C:Users\PoserUser\Documents\Poser\13\RenderCache\

Mac OS X example:

/Users/<PoserUser>/Documents/Poser/13/RenderCache/

You can enter a new location for the render cache in the Render tab of the **General Preferences** dialog. See

You can delete the files in those folders to clear the render cache. Please note that your cached renders will be lost after doing so. If you reinstall Poser and choose to back up your preferences, the render cache will be moved into its backup location along with all preferences.
**Miscellaneous Preferences**

- **Save Files**: Poser offers the following options for file saving:

  - **Use File Compression**: Poser includes the ability to save compressed runtime files and scene files using zlib compression. This compression will significantly reduce the size of your runtime directory and save valuable hard drive space. These compressed files will act identically to non-compressed runtime files when used in Poser. To enable file compression, check the **Save Compressed Files** option. Poser will open both compressed and non-compressed files, but writes compressed files using specific file extensions.

  - **Use External Binary Morph Targets**: Checking this box will enable the use of External Binary Morph Targets (EBMTs) when saving new content, or resaving legacy Poser files. Saving legacy figures to the Poser Library with this option enabled will generate new .PMD EBMT files for those figures, thus allowing you to take advantage of morph target sharing, reduced file sizes, and faster processing speeds for your legacy figures.

  *See Poser Default File Locations for a table that lists uncompressed vs compressed Poser file extensions.*

  Compressed Poser files can be opened by Poser versions running Poser 4 Pro Pack or later. Poser uses standard Z-lib compression, allowing you to use any Zlib compatible compression/decompression application (such as WinZip or 7Zip) to compress/decompress files. Zlib compression is similar to gzip and zip compression methods, and can typically be uncompressed by any utility that handles either of these formats.
All Poser files (scene, figure, pose, expression, hair, hand, prop, light, camera, material) can be compressed. Compressed Poser files have the extension *.*.Z (*.PZZ, *.CRZ, *.FCZ, etc.). Poser prop files are saved with the extension P2Z to avoid confusion with compressed scene files.

For more information on zlib, please refer to http://www.zlib.net/.

To uncompress a file, change the extension on the file you wish to access to .gz, then run your decompression utility. Alternatively, you can use the included PoserPython decompression script by launching Poser and opening the Python Scripts window.

If you plan to distribute files for use by artists with Poser 4 and earlier, please be sure to save them uncompressed. To do so, uncheck the Use File Compression option in the Misc Preferences tab.

Some advanced artists use a text editing application to directly edit Poser files. You must uncompress compressed files before editing them. To do this, you can either load a file into Poser, disable compressed file support, and save the results to a new filename or use a third-party compression utility to uncompress the file. If you use the second method, you can recompress the file when you’ve finished making edits.

- **Software Update**: Checking the Check for Updates on Launch box enables the Automatic Update Notification feature (see Updating Poser for more information about this feature). Clearing the box disables Automatic Update Notification. Clicking the Check Now button will execute an immediate update check.

- **Python**: Clicking the button next to the Editor field opens a standard Browse dialog, allowing you to select the application you wish to use to edit PoserPython scripts (such as Notepad for Windows).

- **Notifications**: Check this option to display a notification icon in the upper-right section of the Poser interface when important information appears. See Notifications for more information on this feature.

- **Temp Files**: Displays the path to temporary files created by Poser. Click the Change button to choose a folder on your system, or click Reset to change back to the default path that was initially set during your Poser installation.
Setting Up Your Workspace

The Poser workspace consists of the entire Poser screen, including controls, the Document, and other room-specific interface elements. You can customize most of these elements to suit the way you work and store your preferences for later use.

Displaying Palettes

Poser’s sleek interface is geared toward streamlining your workflow. You can dock, float, and arrange floating palettes in each of Poser’s different rooms, to set up a workspace layout that meets your needs.

The Window menu contains commands that show or hide Poser’s many palettes. If a palette is hidden, simply select the desired palette from the Window pull-down menu to display it.

The options in the Window > Room Tools submenus are enabled only when the respective room is active. For example, the commands in the Window > Room Tools > Cloth submenu will only be enabled when you are in the Cloth Room.

The upper-right corner of each palette contains a Palette Docking Control square. Click the square to open the palette docking menu, which contains commands that work as described below.

Moving, Repositioning, and Resizing Palettes

Various controls allow you to resize docked or floating palettes, or reposition them as necessary. For example:
To resize a docked palette, position the cursor over the resize handle and drag in either direction indicated by the double-arrow resize cursor.

To resize a floating palette, position your cursor over a side or corner, where it turns into a double-arrow resize cursor. Then drag to the desired size.

To reposition a palette, position the cursor in the Title area of the palette, where it turns into a hand. Reposition the palette to another area on your screen. If the area that you drag to is highlighted in blue, the palette will dock into the highlighted area of your workspace. If the area that you drag to is not highlighted, the palette will float in the new area when you release the mouse button.

Some palettes display scroll bars when they contain more information than can be displayed in the allotted space.

Some palettes (such as the Editing Tools or Display Styles palettes) display options that wrap based on the width of the palette.

Some palettes cannot be reduced beyond the minimum size required to display all of the palette options and controls. For examples, see the Camera Controls or Light Controls palettes.

When using multiple displays, undocked palettes and Python windows can be moved to a secondary screen. However, if the secondary screen is no longer connected to the system, the undocked palettes that were formerly on the secondary window are not automatically moved to the primary display. The
Enabling or Disabling Docking

To enable or disable palette docking:

- Click the Palette Docking Control square at the top-right corner of the palette. Check or uncheck Drag-Docking Enabled as appropriate. This selection is checked when docking is enabled, and not checked when disabled.

Docking Palettes

To dock a palette, use one of the following methods:

- Drag the palette toward the area in which you want to place it. When the area becomes highlighted, release the mouse. If you drag the palette into an area that is already populated by one or more palettes, the active docking area will split horizontally or vertically to provide a location for the additional palette.

- Click the control at the top-right corner of floating palette, and choose Docked from the menu. The palette will dock into the position where it was last docked.

Floating Palettes

To float a palette, use one of the following methods:

- Drag the palette out of the docked location, and toward the document window. Release the mouse when there is no highlighted dock location for the palette.

- Click the control at the top-right corner of a docked palette, and choose Floating from the menu. The palette will float in the Poser workspace.

Closing Palettes

To close an open palette, use one of the following methods:

- Click the Close icon in the upper-right corner.

- Click the control at the top-right corner of the palette and choose Close from the menu that appears.
• Choose an open palette from the Window pull-down menu to close it. Palettes that are currently open are indicated by a check mark.

UI Memory Dots

You can save up to nine interface configurations using the Memory dots (described in Memory Dots). Each Memory dot retains a separate instance of your selected interface settings. This feature is globally applicable, meaning that UI dots can be applied regardless of the specific scene or resolution.

An alternative method for saving UI settings for accessibility in any Poser scene is to modify Poser's general preferences as described in Setting Application Preferences. However, while preferences set in this manner are saved separately for each screen resolution, you can only save one UI configuration per resolution using the general preferences.

Using the Log Window

The Log window enables you to view a list of ongoing commands as you use them in Poser. You can filter these comments on various criteria (timestamp, category, application commands, group selections, warnings, and debug information). This information can be useful when you are trying to troubleshoot a problem with Technical Support.

To display the Log window, choose Window > Log, or click the Message Log widget in the upper right corner of the Poser interface.

The window can be docked or undocked to the workspace by using the palette context menu. Click the square in the upper-right corner of the palette to display the docking options.
If a crash occurs and you can’t get to the log window, you can find the recent history here:

Windows: Users\<user>\AppData\Local\Temp\Poser\12\Poser.log

Macintosh: /Users/username/Library/Group Containers/*******poser/Poser/12

Log Window.

Click the arrow in the upper right corner of the Log window to filter the types of messages that appear in the log. All categories are selected by default.

- With the Log Window open, press CTRL/CMD+C to copy all contents of the Log Window into your clipboard. Then you can paste the contents into a text editor to save the contents in the log.

- To remove all selections click Clear All. Otherwise, check or uncheck from the following types of information to include in the log: Show Timestamp; Show Category; Application commands; Group selection info; Warning; Debug; FireFly; SuperFly; Info; Purchases; Analytics.

Logging options.
Notifications

A notification icon appears in the upper right section of the Poser interface. Notifications will include items of interest to the Poser community such as product updates, content announcements, and news about interesting tutorials and blog posts.

When a notification appears, the notification icon will light up and display the number of unread notifications as shown below.

![Notification Icon](image)

Click the Notification icon to display the notification in the log window. From there you can:

- Click the trashcan icon on the right side of each notification that you want to delete; or
- Click **Clear All** to remove all notifications from the list.

![Notifications in Log Window](image)
Building Scenes
The Pose Room

The Pose room is the focal point for much of your Poser activity. This is where you add figures and props to your scene and perform your desired posing and animation. This chapter introduces you to the basic Poser interface. The following chapters will describe these interface elements in greater detail, and then will move on to discussing the other rooms in Poser.

The Pose room appears as follows at 1920 x 1080 resolution.

The number of palettes and options that you see in each room depends upon your screen resolution. At higher resolutions, the default workspaces display more palettes, while at lower resolutions you see fewer palettes.

In addition to rooms, much of Poser’s functionality is available by using floating palettes and windows within the rooms themselves. Most Poser rooms (including the Pose room) allow you to customize your Poser workspace by hiding/displaying and relocating controls anywhere you like. You can use UI dots to save up to nine different screen configurations for the entire Poser workspace.

The numbers on the image above identify the controls available in the Pose room:

1. Menu Bar
2. Room Tabs
3. Editing Tools
4. Camera Controls
5. **Light Controls**

6. **Display Controls**

7. Recent Renders Palette: Shows and hides this palette. It contains thumbnails of your most recent renders. Right-click on a thumbnail to export the image. For more information about this palette see **Displaying Recent Renders**.

8. **Memory Dots**

9. **Document Window**

10. Camera Mini-Controls: The Camera Mini-Controls appear in the upper-right corner of the document window. They function essentially the same as the most often-used controls in the Camera Controls palette. They are discussed in more detail in **Camera Mini-Controls**.

11. Parameters and Properties Palette: For information about the Parameters and **Properties** palettes, see **The Parameters/Properties Palette**

12. Animation Controls: See **Animation Controls**

13. Poser Library: Refer to **The Poser Library** for complete information about the **Library** palette.

---

Please refer to **Setting Up Your Workspace** for more information about creating and saving custom workspace layouts. The following sections provide a brief description of the labeled interface elements and references to more detailed information.

---

**Menu Bar**

The **Menu Bar** consists of a series of pull-down menus used for accessing Poser functionality. Some menus and/or submenus duplicate other on-screen interface elements. The **Menu Bar** appears as follows and is available from every Poser room.

```
File  Edit  Figure  Object  Display  Render  Animation  Window  Scripts  Help
```

**Poser’s Menu Bar**

**Room Tabs**

The **Room** tabs allow you to switch from room to room within Poser. enter a room, simply click its tab.

```
Pose  Material  Hair  Cloth  Fitting  Setup
```

**Room Tabs.**

- The **Material** room is covered in **The Material Room**
- The **Hair** room is covered in **The Hair Room**
The Editing Tools display contains the tools you use most often when posing figures/props.

By selecting a body part or prop followed by the desired Editing tool, you can pose objects in various ways such as translating (moving side to side or back and forth), rotating, twisting, etc. You can also perform other functions such as editing Inverse Kinematic (IK) chains and working with element/material groups. Each Editing tool is a little different, but their basic usage is as follows:

1. Select your desired body part or prop (referred to as an element or actor) in your scene by clicking that actor.
2. Select the desired Editing tool. You can only have one Editing tool selected at a time. The currently selected Editing tool appears yellow within the Poser interface.
3. Click and drag to perform the selected tool’s function.

You can use the Editing tools in any combination to create a virtually infinite number of still or animated poses. Please refer to The Editing Tools for more information. In addition, each tool is discussed in depth where appropriate in this manual.

Light Controls

The Light controls allow you to adjust lighting properties. Use it for such purposes as adding and removing lights, and specifying light colors and other light properties. The Light controls appear as follows.
Display Controls

The Display controls allow you to select your desired preview mode for your entire scene, a figure or prop, and/or specific elements of your currently selected figure/prop.

Memory Dots

Being able to customize your workspace wouldn’t be useful if you had no way of saving your preferences. Poser includes Memory dots that allow you to save poses, camera locations, and user interface (UI) preferences and to switch between saved items with a single mouse click.

Clicking the arrow to the left of the description allows you to choose between the Poses, Camera, and UI memory dots that you have saved.
Memory Dots options.

Please refer to the following for more information on each type of Memory dot.

- **Pose Dots**: Pose dots are described in further detail in Pose Dots.
- **Camera Dots**: Camera dots are described in further detail in Camera Dots
- **UI Dots**: UI dots are described in further detail in Setting Up Your Workspace.

### Using Memory Dots

To use Memory dots:

1. Set up your pose, cameras, and/or interface (UI) the way you want them.
2. Use the pull-down menu to select the dot type, as described above.
3. Click an empty memory dot. This dot will appear full, as shown below.

![Filled, empty, and selected Memory Dots](image)

To use a dot, simply click it. The stored settings are applied to your scene. To clear a memory dot (delete its information and make it appear empty again), press and hold [OPT]/[ALT] while clicking the memory dot you wish to erase.

### Document Window

The Document window is your viewport into the Poser workspace where you view and pose your figure and interact directly with your scene. Each view of the Document is displayed through a virtual camera, which means you can view each scene from multiple camera angles, either one at a time or from up to four angles at once.

You can position cameras to view your scene from any angle or distance and can resize the Document to suit your needs. In addition, the Document has numerous controls around its edges that you use to change the appearance of scene elements. You can also select objects within your scene by clicking them directly within the Document or by using the menus on the bottom of the window. Please refer to The Document Window for more information about the Document.
The Document Window.

Showing and Hiding Windows and Palettes

The Window menu allows you to enable and disable (show and hide) various Poser windows and palettes. The upper portion of the Window menu contains the following commands:

The palette options that are displayed in each room vary, depending on your screen resolution or upon which room you have displayed.

- **Animation Palette**: Selecting Window > Animation Palette opens the Animation palette. Please refer to Using the Animation Palette for information about the Animation palette and creating Poser animations.

- **Graph**: Selecting Window > Graph opens the Graph palette for the selected element in your scene. Please refer to Using Graphs for information about using the Graph when making Poser animations.
The lower portion of the Window menu contains commands that toggle frequently-used palettes on and off.

- **Libraries**: Selecting Window > Libraries opens the Library palette. Please refer to The Poser Library for more information about the Library palette.

- **Hierarchy Editor**: Selecting Window > Hierarchy Editor opens the Hierarchy Editor palette. Please refer to The Hierarchy Editor for more information about the Hierarchy Editor palette.

- **Joint Editor**: Selecting Window > Joint Editor opens the Joint Editor palette. Please refer to Working with Joints and Weights for more information about the Joint Editor palette.

- **Sketch Designer**: Selecting Window > Sketch Designer opens the Sketch Designer window. Please refer to The Sketch Designer for more information about the Sketch Designer renderer.

- **Walk Designer**: Selecting Window > Walk Designer opens the Walk Designer window. Please refer to Using the Walk Designer for more information about the Walk Designer window.

- **Talk Designer**: Choose Window > Talk Designer to open the Talk Designer window, described in Using the Talk Designer.

- **Python Scripts**: Selecting Window > Python Scripts opens the Python Scripts palette. Please refer to The Python Scripts Palette for more information about the Python Scripts palette.

- **Recent Renders**: Choose Window > Recent Renders to display a palette that contains thumbnails of the images that you most recently rendered. For more information, see Displaying Recent Renders.

- **Bullet Physics Controls**: Choose Window > Bullet Physics Controls to create physics simulations using Bullet Physics. See Using Bullet Physics for more information.

The lower portion of the Window menu contains commands that toggle frequently-used palettes on and off.

- **Camera Controls**: Selecting Window > Camera Controls toggles the Camera controls display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to The Camera Controls for more information about the Camera controls.
• **Preview Styles**: Selecting Window > Preview Styles toggles the Display controls display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to The Display Controls and Menu for more information about the Display controls.

• **Editing Tools**: Selecting Window > Editing Tools toggles the Editing tools display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to The Editing Tools for more information about the Editing tools.

• **Light Controls**: Selecting Window > Light Controls toggles the Light controls display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to Lighting for more information about the Light controls.

• **Memory Dots**: Selecting Window > Memory Dots toggles the Memory dots display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to Memory Dots for more information about the Memory dots.

• **Parameter Dials**: Selecting Window > Parameter Dials shows or hides the Parameters/Properties palette, which contains tabs for the Parameters palette and Properties palette. A check mark next to this option indicates that the Parameters/Properties palette is currently displayed, and vice versa. Please refer to Parameters Palette for more information about the Parameters palette, and to Properties for more information about the Properties palette.

• **Animation Controls**: Selecting Window > Animation Controls toggles the Animation controls display on and off. A check mark next to this option indicates that the controls are currently displayed, and vice versa. Please refer to Using the Animation Controls for more information about the Animation controls.

• **Log**: Choose Window > Log to open the Log Window. See Using the Log Window for further information.

• **Notifications**: Choose Window > Notifications to display the Notifications window, discussed further in Notifications.

• **Custom Parameters Palette**: Choose to display the Custom Parameters Palette, which allows you to create parameter palettes that are specific to an object in your scene. See “Creating Custom Parameter Palettes.”

• **Room Tools**: The Room Tools submenus display options that are enabled when you are using the Material, Face, Hair, or Cloth room. The options for each room are disabled until you enter the room to which they apply.

• **Material**: When you are in the Material room, a menu option allows you to show or hide the Material Palette. See The Material Room for further information about the Material Room.

• **Hair**: When you are in the Hair room, menu options allow you to show or hide the Hair Growth Groups, Growth Controls, Styling Controls, and Dynamics Controls palettes. These palettes are discussed in The Hair Room.
Animation Controls

The Animation controls allow you to preview animations and set up keyframes. You do this by posing your figure, moving to a new frame, and changing the pose. Clicking the Play button plays an animation using the keyframes. The Animation controls appear as follows:

![Animation Controls](image)

Please refer to Using the Animation Controls to learn more about the Animation controls, and to Animating with Poser for more information about creating and rendering animations using Poser.

Using the Shortcuts Editor

The Shortcuts Editor allows you to customize the keyboard shortcuts that you use in Poser. To open the Shortcuts Editor choose Edit > Preferences, and click the Edit Shortcuts button located in the Interface tab of the General Preferences dialog.
To create a shortcut, double-click the command that you want to assign as a shortcut. A dialog appears, prompting you to enter a new shortcut for the selected command.

To add the shortcut, simply enter the keyboard combination that you want to use. The keys that you press will appear in the dialog.

*On Macintosh systems, you will need to include the *Cmd* key as part of the shortcut in order for the modifiers to be recorded.*
If the shortcut that you entered already appears in the shortcut list, a red warning will appear to indicate that it is already in use, and what command uses that shortcut. Enter another keyboard shortcut if necessary. Then click **OK** to apply the new shortcut to the command.

The **Clear** command will clear out the shortcut entry field. You can also click **Cancel** to return to the main Shortcut Editor window without creating a shortcut.

After your shortcuts are complete, click **OK** to exit the Shortcut Editor.

## Other Basic Operations

### Creating a New Scene

Selecting **File > New** creates a new Poser scene. A dialog will appear if you have any unsaved changes in your previous scene. If this dialog appears:

- Selecting **Yes** opens a Save Poser Scene dialog box, allowing you to save your current Poser scene. After saving your current scene, the new scene will be created.
- Selecting **No** creates a new Poser scene without saving your unsaved changes. All unsaved changes will be lost, so use this option carefully!
- Selecting **Cancel** closes the dialog and cancels the new scene creation, leaving your current Poser scene open.

### Opening a Scene

Selecting **File > Open** opens a standard Open dialog box, allowing you to access and work on a previously saved Poser scene file. You are prompted to save any unsaved changes in your current scene, if any (see above).

### Opening a Recent File

Selecting **File > Recent Files** opens a pop-up list that displays a list of the ten most recent document files (.PZ3 or .PZZ formats) that you opened in Poser.

### Closing Your Scene

Selecting **File > Close** closes your current Poser scene while leaving the Poser application running. You are prompted to save any unsaved changes in your current scene.
Saving a Scene

Selecting File > Save saves your current Poser scene using your previously specified filename and save location. If you have not previously saved your scene, Poser will open the standard Save As dialog box, allowing you to name and save your current Poser scene (see below).

Selecting File > Save As saves your current Poser scene allowing you to select a different filename and/or save location. This feature is useful for creating different versions of work, which allows you to return to any previous stage if you decide you don’t like your progress beyond a given save point. For example, you could save myscene_1.PZ3, then save new versions as myscene_2.PZ3, myscene_3.PZ3, and so forth.

Compressed File Support

Poser allows you to compress saved figures/props/scenes to save hard drive room. To enable compression support, select Edit > General Preferences, select the Library tab, and check the Use File Compression box as described in Setting Application Preferences.

See Poser Default File Locations for a table that lists uncompressed vs compressed Poser file extensions.

Reverting Changes

Selecting File > Revert allows you to undo your changes and reopen your current scene file in its last-saved state. This is a great way to do your recent changes over, however you will lose everything you’ve done since the last time you saved your scene. This is why we recommend that you save your scene often and, if you think you may want to return to an earlier version, to save progressive versions of your work using the Save As command. Clicking Cancel returns you to Poser, and clicking Revert proceeds to load the last saved version of your current scene.

You can also enable Auto Save options, as discussed in Document Preferences.

Run Python Script

Selecting File > Run Python Script opens a standard Open dialog, allowing you to browse for your desired PoserPython script. Once you locate your script, select it and click OK to execute it.
Page Setup

Selecting File > Page Setup opens a standard Print Setup dialog box allowing you to set up your printers. Please refer to your operating system and/or printer documentation for information on setting your print preferences.

Print

Selecting File > Print sends your current scene to your selected printer. A standard Print dialog box opens allowing you to select your desired printer and general printing properties. Poser documents always print using the full page size. Please refer to your operating system documentation for information on selecting print options.

Exit

Selecting File > Exit closes Poser. You are prompted to save any unsaved changes. You can also type [COMMAND]/[CTRL]+[Q] to exit Poser.

This menu option is available for Windows only. For Macintosh, the Quit command appears on the Poser Application menu.

Undo

Selecting Edit > Undo reverses your most recent change to the actual scene. You can also press [COMMAND]/[CTRL]+[Z]. Undo applies only to alterations made within the actual scene; it is not applicable to changes made to application settings, Library content, etc.

Poser supports multiple levels of Undo. Selecting Edit > Undo repeatedly allows you to step backwards through your most recent document changes, reversing each change individually and reverting the scene to its previous state. Some operations within Poser will purge the Undo/Redo cache; a warning dialog will appear asking you to confirm before the action is implemented. Closing the file will purge the Undo/Redo cache.

You can specify the maximum size of the Undo stack. Please see Document Preferences for more information.

You can specify whether or not the Undo feature will apply to camera changes. Open the Properties palette for the currently selected camera, and check the “Remember changes for undo” checkbox in order to apply Undo to camera changes. Alternately, if you do not wish camera changes to be
Redo

Selecting **Edit > Redo** reiterates the most recently undone action, thus reverting the scene to its previous state. You can also press **[COMMAND]/[CTRL]+Shift+[Z]**. To reverse a Redo action, simply select **Edit > Undo** again.

Cut

Selecting **Edit > Cut** removes the selected element(s) and places them in the system Clipboard for later pasting. You can also press **[COMMAND]/[CTRL]+[X]**. You can do this for poses and other functions.

Copy

Selecting **Edit > Copy** copies selected elements to the Clipboard. You can use this command to copy the position of one prop to another. You can also copy transformation and rotation channel information from the selected item and paste that information into another item. For example, the following figure shows pose information pasted from one character's right shoulder rotations pasted to the right shoulder of another character.

> Copying and pasting poses from one side to the other does not mirror the poses. The same pose is applied. To mirror poses, use the **Figure > Pose Symmetry** function.

To copy and paste a body part:
1. Manipulate the body part using any tool you desire.

2. Select the body part (source), then select **Edit > Copy** or press **[COMMAND]/[CTRL]+[C]**.

3. Click to select the body part you wish to copy to (target) and select **Edit > Paste** or press **[COMMAND]/[CTRL]+[V]** (see following subsection). This copies all settings from the source to the target, including deformers.

### Paste

Selecting **Edit > Paste**, or pressing **[COMMAND]/[CTRL]+[V]**, places the item stored in the Clipboard into your current scene. If you are pasting a pose, select the element to apply the copied pose to, then make your selection.

### Copy Picture

Selecting **Edit > Copy Picture** takes a snapshot of your scene, which you can then paste into a graphics application such as Adobe Photoshop. Your scene is copied exactly as displayed in the **Document**.

> Copying and pasting images in this manner is not the same as rendering.

### Duplicate

The **Duplicate [ObjectName]** option creates an exact duplicate of the currently selected figure or prop. The duplicate object is placed within the **Document**, in the same position as the original. The duplicate object will appear in either the **Select Figure** or **Current Actor** menu, depending on whether it is a figure or a prop, and can be resized and repositioned independently from the original object.

After an object is duplicated, Poser will select the duplicated object as the current object.

### Restore

Selecting **Edit > Restore** opens a submenu allowing you to restore scene elements, which are completely restored to their Poser default states, including but not limited to position, scale, morphs, parameters, materials, parent/child relationships, etc.

> The Restore function is literally for cases when you wish to go back and start all over again. Use it with care!
The Restore submenu appears as follows:

- **Element**: Selecting Edit > Restore > Element restores the current element to its default state. An element could be a body part, prop, single camera, or single light.

- **Figure**: Selecting Edit > Restore > Figure restores the current figure to its default state.

- **Lights**: Selecting Edit > Restore > Lights restores all lights in your scene to their Poser default state.

- **Camera**: Selecting Edit > Restore > Camera restores the current camera to its default state.

- **All**: Selecting Edit > Restore > All restores all scene elements to their default states. Use this option with care!

**Memorize**

While working, you might arrive at a convenient stopping point. You know you like what you have so far and do not want to revert all the way back to the Poser default state should you need to restore one or more scene elements (or even the entire scene) at a later time. No problem. Select Edit > Memorize and the element(s) you wish to memorize (the list is the same as for the Restore submenu, above). Doing this essentially changes the default for your selected item(s), which can be undesirable in some cases. Redoing this operation saves the new default overwriting the old. If you later select Edit > Restore, your element(s) will be restored to the last memorized settings.

*It is very important when setting up new figures to use the Edit > Memorize > Figure command to preserve default poses so that Inverse Kinematics works properly.*

*Memorization works on a per-file basis, meaning that memorizing defaults in one file does not affect the defaults of other Poser files or Library entries.*
The Document Window

The Document is your portal to the Poser workspace where you view and can directly manipulate your scene and the elements within it.

The Document consists of two tabs:

- **Preview Tab**: The Preview tab is where you do the work to set up your Poser scene.
- **Render Tab**: The Render tab is where you can view the results of your renders.

## Preview Tab

Clicking on the Preview tab at the top left of the Document brings up the scene preview window, where you can manipulate figures, props, etc. to set up your Poser scene. Refer to for detailed configuration parameters for the Preview tab’s preview display window.

![Components of the Document Window.](image)

The Preview tab contains the following controls:

1. **Preview Tab**: The tab shown above.
2. **Render Tab**: See Render Tab
3. **Document Title**: The Title appears along the top of the Document, and displays the current Poser scene (such as My Scene.PZ3).
4. **Render Controls**: Refer to Render and Area Render
5. **Frame Selection/Orbit Selection**: See Frame Selected and Orbit_Selected.
6. **Camera Mini-Controls**: See [Mini-Camera Controls](#)

7. **Options Menu**: See [Options Menu](#)

8. **Select Figure menu**: See [Select Figure/Current Actor Menus](#)

9. **Current Actor menu**: See [Select Figure/Current Actor Menus](#)

10. **Current Camera**: The name of the currently selected camera view appears in the upper-left corner of the document window.

11. **Viewport Layouts**: See [Single/Multiple-View Panes](#) for more information about multiple views.

12. **Tracking Mode**: See [Tracking Mode](#)

13. **Depth Cue**: Depth Cueing adds dimension to scene elements visible in the **Document**. When Depth Cueing is enabled, elements farther away from the camera fade into the distance. See [Using Depth Cueing](#).

14. **Shadows**: See [Shadows](#)

15. **Comic Book Preview Options**: See [Cartoon Settings](#)

16. **Colors**: See [Colors](#)

17. **Measurement Controls**: See [Measurement Mode](#)

### Options Menu

Clicking on the arrow at the right side of the Title bar opens the **Document**’s **Options** menu. This menu contains the following settings and shortcuts:

![Document Window Options menu](#)

- **Render**: Clicking this option will render your entire Poser scene, using the specified in the **Render Settings** dialog, discussed in [The Render Settings Dialog](#), and the render engine specified in the Render Engine Selection menu on the Render tab. For more information on Poser’s render settings, see [Rendering](#). The render results will appear in the Render tab of the **Document**.
Collisions

A collision occurs when two objects in your scene partially or completely occupy the same 3D space. Selecting the **Collisions** menu item opens a pop-up menu that allows you to set the following collision options for your current Poser scene:

- **Collisions On**: Checking the Collisions on option prevents objects in your scene from colliding with/penetrating each other.
- **Collisions Off**: Checking the Collisions off option allows objects in your scene to collide with/penetrate each other.
- **Show Intersections**: Checking the Show intersections option displays colliding polygons in red when objects in your scene collide with/penetrate each other but does not prevent the collision.

Once you have set collision preferences for your scene, you must then enable collision detection for each of the objects for which you want to use this feature. Do this by selecting your desired objects one at a time and checking the **Collision Detection** checkbox in that object’s **Properties** palette. This feature only works between objects that have collision detection enabled. If you have one object enabled and one disabled, collision detection will not work.
Objects lose their collision detection settings when hidden.

Document Window Size

The Document is dockable and floatable. When the Document is in its floating state, you can resize it by clicking and dragging the bottom right corner of the Document to your desired size.

You can also set the document window size in the Preview Dimensions dialog, which can be opened in the following ways:

- Choose Window > Document Window Size, which opens the Preview Dimensions dialog.
- Choose Preview Dimensions from the Document Window.

![Setting Document Window size.](image)

After you click the Float Palette button, you can:

- Enter your desired scene preview window height and width (in pixels) in the appropriate fields and click OK to resize the Document.
- Click the Match Background button to match the Document to the dimensions of an imported background image or movie.
- Click the Match Production Aspect button to set the scene preview window size to the currently selected Production Frame aspect. This button is only active when the Production Frame feature is enabled (see Production_Frame).
- Clearing a checkbox disables the specified option.

To redock the document window, click the palette options menu triangle in the upper-right corner of the floating window, and choose Docked

Page 72
OpenGL Hardware Acceleration

Poser offers OpenGL hardware accelerated rendering as well as SreeD software rendering options for the scene preview display. Simply right-click (Windows) or Apple key-click (Mac) within the preview window to select hardware or software rendering for processing the scene previews. In most cases, hardware rendered previews will be faster than software rendered previews. Additionally, hardware accelerated performance is independent of the preview window size, whereas software rendering will yield a lower frame rate with larger preview window sizes.

Recent and more powerful graphics cards with OpenGL support will provide better results with the display of your Poser scene, with better texture previews and faster interaction and updating of the scene. Unfortunately, due to the vast variety of graphics hardware available, hardware acceleration may not be supported on every system. In that case please use the SreeD software rendering option. Poser should automatically detect whether or not OpenGL hardware rendering is supported for your system, and if not, should default to SreeD software rendering.

Choosing your Preview Rendering option.

Select Figure/Current Actor Menus

The top left of the Preview tab contains the Select Figure (left) and Current Actor (right) pull-down menus. The currently selected figure and item appear as labels, and those item’s properties and parameter dials are accessible in the Parameters & Properties palette. Double-clicking anywhere in the scene preview area will open the Parameters & Properties palette in the position and state in which it was last used, with the settings for the currently selected figure and/or actor displayed.
You can also select figures, props, and other scene objects by clicking on them directly in the scene preview area.

*Select Figure (left, with La Femme selected) and Current Actor (right, with Body selected).*

- **Select Figure Menu:** Use the Select Figure pull-down menu to select your desired figure. This can be helpful if you have a number of figures in your scene (particularly if you are using conforming clothing, each item of which is a Poser figure).

- **Current Actor Menu:** The Current Actor pull-down menu allows you to select scene items as follows:
  - **Body:** Selecting Current Actor > Body selects the entire body and all body parts of the currently selected figure.
  - **Body Parts:** Selecting Current Actor > Body Parts opens the list of the currently selected figure’s body parts. By using this option, you will select only the specified body part on the currently selected figure.
  - **Props:** Selecting Current Actor > Props opens the list of all props in your scene (including hair and cloth objects), allowing you to select your desired prop.
  - **Cameras:** Selecting Current Actor > Cameras opens the list of the cameras in your scene. You may select any camera from this list. Please refer to Cameras for information about Poser cameras.
  - **Lights:** Selecting Current Actor > Lights opens the list of lights in your scene. You may select any light from this list. Please refer to Lighting for information about Poser lights.

**Preview Tab Context Menus**

Right-clicking (Windows) or Apple key-clicking (Mac) within a scene will open the Context pop-up menu. The options that appear in this menu vary, depending on the type of item that you right-click over.
There are several context menus that appear when you right-click on the items in your scene. Each of the context menus gives access to common commands that pertain to that type of object.

The context menus are described in the following sections.

**Actors Context Menu**

When you right-click over a body part in a poseable figure, the context menu appears as shown below.

![Actor Context Menu](image)

The Actor context menu provides the following commands:

- The top line in the context menu displays the name of the selected item.

- **Select**: Expand the Select menu to select a part from the menu that appears to select the part that you right-click. A check mark appears beside the name of the body part when it is set as the current selection.

- **Memorize**: Equivalent to using the **Edit > Memorize** command. For more information, see Memorize.

- **Restore**: Equivalent to using the **Edit > Restore** command. For more information, see Restore.

- **Lock**: Equivalent to using the **Figure > Lock Figure** or **Object > Lock Object** commands. Allows you to lock or unlock the transformations of the selected actor or figure. The item is locked when a check mark appears beside the item. See Lock Figure and Lock Object.
**Full Figures Context Menu**

The figure circle appears around your currently selected figure in your scene, which turns white when hovered over, allowing you to select the entire figure. After the figure is selected, the figure circle is red when hovered over. To display the context menu for a full figure, right-click the selected Figure circle that appears around a poseable figure.
The Figure Circle

*If you are unable to see the figure circle, make sure that the Display > Figure Circle command is enabled.*

---

- The top line in the context menu displays the name of the selected item.
- **Select**: Expand the Select menu to select the figure from the menu that appears. A check mark appears beside the name of the body part when it is set as the current selection.
- **Memorize**: Equivalent to using the Edit > Memorize command. For more information, see [Memorize](#).
• **Restore**: Equivalent to using the **Edit > Restore** command. For more information, see [Restore](#).

• **Lock**: Equivalent to using the **Figure > Lock Figure** or **Object > Lock Object** commands. Allows you to lock or unlock the transformations of the selected actor or figure. The item is locked when a check mark appears beside the item. See [Lock Figure](#) and [Lock Object](#).

• **Hide**: Hides the actor that is right-clicked.

• **Show All Figures**: Equivalent to using the **Figure > Show All** command. “Unhides” any hidden figures or actors.

• **Frame Object**: Equivalent to using the Frame Selected camera control or the **View > Frame Selected** command. See [Frame Selected](#).

• **Object Style**: Equivalent to using the **Display > Object Style** command for the selected element. Choose the desired display style from the submenu. See [The Display Controls and Menu](#) for more information about the display styles available in Poser.

• **Duplicate Figure**: Equivalent to using the **Edit > Duplicate** command. See [Duplicate](#).

• **Change Figure (figurename) Parent to**: Equivalent to using the **Figure > Set Figure Parent** command. Allows you to select a prop, camera, or light as a figure parent. Choose **Universe** to remove the figure parent. See [Set Figure Parent](#).

• **Conform Figure (figurename)To**: Equivalent to using the **Figure > Conform To** command. Allows you to conform the figure to another figure in the scene. Choose **None** to unconform the selected figure. See [Adding Conforming Clothing: Manual Conforming](#).

• **Use Inverse Kinematics**: Equivalent to using the **Figure > Use Inverse Kinematics** command. A check mark appears beside the leg or hand when inverse kinematics is on. See [Inverse Kinematics (IK)](#).

• **Symmetry**: Equivalent to using the **Figure > Symmetry** command. Expand the menu and choose the desired symmetry. See [Pose Symmetry](#).

• **Figure Style**: Equivalent to using the **Display > Figure Style** command. Allows you to choose the display style for the figure. See [The Display Controls and Menu](#) for more information about the display styles available in Poser.

• **Camera View**: Equivalent to using the **Display > Camera View** command. Select the desired camera view from the context menu.

• **OpenGL**: Equivalent to using the **Display > Preview Drawing > OpenGL Hardware** command. See [OpenGL Hardware Acceleration](#).

• **SreeD**: Equivalent to using the **Display > Preview Drawing > SreeD Software** command. See [OpenGL Hardware Acceleration](#).

• **Cartoon Settings**: Equivalent to using the **Display > Cartoon Settings** command. Select the desired cartoon display mode from the context menu. See [Cartoon Settings](#).
Props Context Menu

- The top line in the context menu displays the name of the selected item.

- **Select**: Expand the Select menu to select the prop or another item from the menu that appears. A check mark appears beside the name of the prop when it is set as the current selection.

- **Memorize Prop**: Equivalent to using the **Edit > Memorize** command. For more information, see Memorize.

- **Restore Prop**: Equivalent to using the **Edit > Restore** command. For more information, see Restore.

- **Lock Object**: Equivalent to using the **Object > Lock Object** command. Allows you to lock or unlock the transformations of the selected prop. The item is locked when a check mark appears beside the item. See Lock Object.

- **Hide Object**: Hides the actor that is right-clicked.

- **Show All Figures**: Equivalent to using the **Figure > Show All** command. “Unhides” any hidden figures or actors.

- **Frame Object**: Equivalent to using the Frame Selected camera control or the View > Frame Selected command. See Frame Selected.

- **Object Style**: Equivalent to using the **Display > Object Style** command for the selected element. Choose the desired display style from the submenu. See The Display Controls and Menu for more information about the display styles available in Poser.

- **Duplicate**: Equivalent to using the **Edit > Duplicate** command. See Duplicate on Duplicate.

- **Change (propname) Parent to**: Equivalent to using the **Object > Change Parent** command. Allows you to select a figure, prop, camera, or light as a parent. Choose Universe to remove the figure parent. See Changing a Parent.
For information regarding commands that are specific to lights, see **Lighting**.

**Lights Context Menu**

- **Camera View**: Equivalent to using the **Display > Camera View** command. Select the desired camera view from the context menu.

- **OpenGL**: Equivalent to using the **Display > Preview Drawing > OpenGL Hardware** command. See **OpenGL Hardware Acceleration**.

- **SreeD**: Equivalent to using the **Display > Preview Drawing > SreeD Software** command. See **OpenGL Hardware Acceleration**.

- **Cartoon Settings**: Equivalent to using the **Display > Cartoon Settings** command. Select the desired cartoon display mode from the context menu. See **Cartoon Settings**.

The top line in the context menu displays the name of the selected light.

- **Select**: Expand the Select menu to select the light or another item from the menu that appears. A check mark appears beside the name of the light when it is set as the current selection.

- **Memorize Lights**: Equivalent to using the **Edit > Memorize** command. For more information, see **Memorize**.

- **Restore Lights**: Equivalent to using the **Edit > Restore** command. For more information, see **Restore**.

- **Duplicate**: Equivalent to using the **Edit > Duplicate** command. See **Duplicate**.
• **Lock Light**: Equivalent to using the **Object > Lock Object** command. Allows you to lock or unlock the transformations of the selected light. The item is locked when a check mark appears beside the item. See **Lock Object**.

• **Light On**: Turns the light on or off. A check mark appears beside the command when the light is on.

• **Casts Shadows**: Turns shadows on or off for the selected light. Shadows are on when the option is checked.

• **Light Type**: Allows you to choose the type of light. A check mark appears beside the currently selected light type.

• **Include in OpenGL Preview**: Allows the effects of the current light to display in the preview render in the document window. A check mark appears beside the light if it is included.

• **Point At**: Equivalent to using the **Object > Point At** command. See **Point At**.

• **Change (lightname) Parent to**: Equivalent to using the **Object > Change Parent** command. Allows you to select a figure, prop, camera, or light as a parent. Choose Universe to remove the parent. See **Changing a Parent**.

• **Camera View**: Equivalent to using the **Display > Camera View** command. Select the desired camera view from the context menu.

• **OpenGL**: Equivalent to using the **Display > Preview Drawing > OpenGL Hardware** command. See **OpenGL Hardware Acceleration**

• **SreeD**: Equivalent to using the **Display > Preview Drawing > SreeD Software** command. See **OpenGL Hardware Acceleration**

• **Cartoon Settings**: Equivalent to using the **Display > Cartoon Settings** command. Select the desired cartoon display mode from the context menu. See **Cartoon Settings**.

---

**Cameras Context Menu**

For information regarding commands that are specific to cameras, see **Cameras**.

---

*You will need to make the camera visible in the Properties panel before you right-click to display the camera context menu.*
Cameras Context Menu

- The top line in the context menu displays the name of the selected camera.

- **Select**: Expand the Select menu to select the camera or another item from the list. A check mark appears beside the name of the light when it is set as the current selection.

- **Memorize Cameras**: Equivalent to using the Edit > Memorize command. For more information, see Memorize.

- **Restore Cameras**: Equivalent to using the Edit > Restore command. For more information, see Restore.

- **Lock Camera**: Equivalent to using the Object > Lock Object command. Allows you to lock or unlock the transformations of the selected camera. The item is locked when a check mark appears beside the item. See Lock Object.

- **Point At**: Equivalent to using the Object > Point At command. See Point At.

- **Change (camera) Parent to**: Equivalent to using the Object > Change Parent command. Allows you to select a figure, prop, camera, or light as a parent. Choose Universe to remove the parent. See Changing a Parent.

- **Camera View**: Equivalent to using the Display > Camera View command. Select the desired camera view from the context menu.

- **OpenGL**: Equivalent to using the Display > Preview Drawing > OpenGL Hardware command. See OpenGL Hardware Acceleration.

- **SreeD**: Equivalent to using the Display > Preview Drawing > SreeD Software command. See OpenGL Hardware Acceleration.

- **Cartoon Settings**: Equivalent to using the Display > Cartoon Settings command. Select the desired cartoon display mode from the context menu. See Cartoon Settings.
Background Context Menu

Select: Expand the Select menu to select the light or another item from the submenu. A check mark appears beside the name of the light when it is set as the current selection.

Memorize: Equivalent to using the Edit > Memorize command. For more information, see Memorize.

Restore: Equivalent to using the Edit > Restore command. For more information, see Restore.

Production Frame: Equivalent to using the Display > Production Frame command. See Production Frame.

Document Style: Equivalent to using the Display > Document Style command. Allows you to choose the display style for the entire document. See The Display Controls and Menu for more information about the display styles available in Poser.

Deformers: Equivalent to using the Display > Deformers command. Allows you to show and hide the deformers in the scene. See Using Deformers.

Ground Shadows: Equivalent to using the Display > Shadows command. Turns the ground shadow on and off. See Shadows.

Figure Circle: Equivalent to using the Display > Figure Circle command. Toggles the display of the figure circle around the figure. See Full Figures Context Menu for more information.

Bend Body Parts: Equivalent to using the Display > Bend Body Parts command. Toggles bending on and off in a figure. See Bend Body Parts.
Render

The Render icon at the top of the Preview or Render tab is a shortcut to the Render > Render command. Clicking this symbol will render your entire Poser scene, using the render settings specified in the Render Settings dialog, and the render engine specified in the Render Engine Selection menu on the Render tab. For more information on Poser’s render settings, see Rendering. The render results will appear in the Render tab of the Document.

Area Render

Selecting Render > Area Render enables the Area Render feature, which allows you to select a specific region of the current image to render, thereby saving processing time.

The Area Render feature allows you to select a specific region of your scene to render, thereby allowing you to more quickly view the results of changes to one part of your scene, without having to render the entire scene each time. Area Renders appear in the Render tab overlaid on the window’s existing image at the time the Area Render was taken, so you can view the rendered area in the context of your entire scene.

Note that PostFX is disabled during Area Render, so if you have previously rendered a complete image that uses PostFX, the area render will not blend...
in. We recommend that area renders be used to check specific parts of a scene before completing your final render.

To use the Area Render feature, simply click on the Area Render icon at the top of the Preview or Render tab. The symbol will turn red, indicating that Area Render has been enabled. Then click and drag within the scene preview area to select the portion of the scene you wish to render. The results will appear in the Render tab of the Document, using the render settings specified in the Render Settings dialog, and the render engine specified in the Render Engine Selection menu on the Render tab. Poser will save the most recently rendered image in the Render tab, allowing you to toggle back and forth between the Preview and Render tabs, without losing your rendered image.

Changing Cameras within a Pane

The camera label in the upper left corner of the scene preview tab displays the currently selected camera for that pane. You can change the selected camera in each pane of the Preview tab. To do this, right-click the camera name that appears in the upper left corner of the document window, or right-click anywhere within the desired pane to open the context menu, and click on the Camera View option.

Choosing a camera view from the Current Actor menu.

To change the camera view, click your desired option. The view in the selected pane will switch to your newly selected camera.
Single/Multiple-View Panes

By default, the Preview tab consists of one pane, meaning that you can view your scene using one camera at a time. You can, however, add up to four simultaneous viewing panes (cameras) to your Document window using eight customizable layouts, which helps you visualize your scene in all dimensions.

- To select a layout, click the Document window Layout menu button in the lower left corner of the Preview tab, and select your desired layout from the pop-up menu.
- To toggle between single pane and the most recently selected multiple-pane layout, press [D].
- Press [F] to cycle through all of the available multiple-pane layouts.

You can resize panes by clicking and dragging their borders. Poser remembers pane sizes and camera selections if you switch layouts while working on a given scene, and these selections are also saved when you save your Poser scene.

- To use the same layout every time you launch Poser, select the Previous State option from the General Preferences dialog as described in . You can also save up to nine pane/camera layouts using the UI Memory dots (see ).
- Clicking anywhere in a pane makes that pane active. A red border appears around the active pane.

Tracking Mode

Tracking mode determines the type of preview Poser uses to display an object when you reposition either that object or a camera. The Tracking Mode pop-up menu in the lower left corner of the Preview tab offers three tracking mode options. From top to bottom, these are:
• **Box**: Displays scene elements (figures and props) as bounding boxes all the time, whether still or moving. This is the fastest way to preview scenes and is useful for rough blocking work.

• **Fast**: Displays figures and props in the currently selected display style while they or the camera are still and as bounding boxes when in motion. This combines an accurate scene view so you can see before and after images without waiting for each frame to fully render. Fast tracking can help save time while blocking out scenes and creating animations.

• **Full**: Displays scene elements in the currently selected **Document** display style at all times, whether still or animated. This mode is suitable for users with high-performance computers and for performing fine-tuning on previously blocked-out scenes.

![Box and Full tracking modes.](image)

**Shadows**

Items in your scene can cast shadows on the ground plane, which can help you orient them in 3D space. Disabling shadows can help speed up scene redraw time.

The **Shadows** button appears in the lower left corner of the **Document**. Clicking the **Shadows** button allows you to choose which shadows will be displayed in the preview window as you build your scene:

![Shadow display options.](image)

• **No Shadows**: Turns shadow display off. This can help improve performance on systems that have limited hardware resources.

• **Ground Shadows**: Displays shadows on the ground only as shown in the following figure.
Displaying ground and hardware shadows.

Colors

You can improve your view of your scene by altering the foreground, background, shadow, and ground colors appearing within the Document window’s Preview tab. The four dots located along the lower-right corner of the Preview tab allow you to control the following colors, respectively:

- **Hardware Shadows**: Displays more realistic shadows in relation to the lights in your scene.

  The Enable Hardware Shading option in the Preview tab of the Render Settings dialog must be enabled for hardware shadows to display.

- **Ground and Hardware Shadows**: Displays both ground and hardware shadows (if enabled).

  Interface options for foreground, background, shadow, and ground colors.
- **Foreground**: Clicking the **Foreground** button opens the Poser Color Picker and displays an eyedropper icon. Pressing `[OPT]/[ALT]` while clicking this button opens your operating system’s standard Color Picker. Position this dropper over the color you wish to select and click it. If you use the operating system’s standard Color Picker, you can alter the color using numeric values. The **Foreground** color affects the color of the Silhouette, Outline, Wireframe, and Hidden Line display modes (see *The Display Controls and Menu*).

  ![The color picker.](image)

  *To use your operating system’s Color Picker, press [OPT]/[ALT] while clicking the color or click the red-green-blue button in the top right of the Poser Color Picker.*

- **Background**: Change the **Background** color as described above. This color affects the Poser workspace background.

  *The final render will always display whatever is attached to the Color channel of the Root Background node. However, if you wish the same image to appear in the preview render, you must also attach it to the BG Picture or BG Movie node. For more information about nodes, please refer to *Root Nodes*."

- **Shadow**: Change the **Shadow** color as described above. This color affects the preview shadow displayed in the **Preview** tab (if enabled).

- **Ground**: Change this color as described above. This color affects the ground plane displayed in the **Preview** tab (if enabled).

**Render Tab**

Clicking on the Render tab at the top left of the **Document** displays the main render window, where you can see the rendered results of your Poser scene. The Render tab contains the following controls which are described in the sections that follow:
Quick-Scale

Render Window controls.

1. **Render Dimensions**: Discussed in Render Dimensions
2. **Quick-scale Menu**: See Quick-Scale
3. **Render Engine**: See Render Engine Selection
4. **PostFX**: See Applying Post Effects to Renders
5. **Render**: see Render
6. **Area Render**: See Area Render
7. **Pan**: If the image you have rendered is larger than the render window size, you can pan the image by clicking and dragging in the main render window. The Pan symbol at the top right of the Render tab activates this feature. Panning is useful as it allows you to shrink the Document as needed, such as when entering the Material room, and still have access to your entire rendered image.

![Pan icon]

8. **Render Options menu**: Click the arrow at the upper-right corner of the Render tab to view commonly-used render commands.
9. **Render Comparison Image 1**: See Render Comparison
10. **Render Comparison Image 2**: See Render Comparison
11. **Render Comparison Slider**: See Render Comparison

Quick-Scale

The Quick-Scale pop-up menu is along the top left of the Render tab. It offers quick access to three different render scale options: **Full Size**, **Half Size**, and **Quarter Size**. Note that this feature is not intended to replace the Render Dimensions menu, but rather is a tool for facilitating quick render previews, as the smaller scale render sizes require less time to calculate.
Quick Scaling options.

**Render Engine Selection**

Click on the name of the currently selected render engine, along the top of the Render tab, to display the Render Engine popup menu. This menu allows you to easily switch between the various renderers included with Poser. To modify the render settings for each render engine, open the **Render Settings** dialog by clicking on **Render > Render Settings**... in the menu bar (see **The Render Settings Dialog** for a description of this window).

Selecting a render engine.

**Render Comparison**

Poser offers convenient render comparison features, allowing you to contrast two different rendered images within the main render window. Clicking either of the two squares in the lower left corner of the Render tab brings up a pop-up menu listing the most recent renders by date and time. By default, the most recent render is set as the Main render, and is checked in the list under the black square. The second most recent render is the default Compare render, and is checked in the list under the white square. You can, however, select any render from the list as your Main and Compare renders. To compare the Main and Compare renders, use the Render Wipe slider at the bottom of the main render window. Moving the slider to the right displays the Main render, while moving it to the left displays the Compare render. The default number of recent renders listed is ten. You can configure this number in the General Preferences dialog. (See for more information about the General Preferences dialog.)
Displaying Recent Renders

You can use the Recent Renders palette to display thumbnails of your most recent rendered images. This palette can be docked or floating in the same manner as other palettes in your workspace.

To show or hide the Recent Renders palette, choose **Window > Recent Renders**. A check mark appears beside the command when the palette is visible.

From the Recent Renders palette, you can perform the following functions:

- The number of thumbnails that appear in the palette are determined by the Max Cached Renders setting in the Render tab of the General Preferences dialog. For more information on this setting see **Render Preferences**.

- Click a thumbnail in the Recent Renders palette to display the selected render in the Render window. Partially and fully completed renders appear in this palette.

- Right-click a thumbnail to display a context menu with the following commands.
  
  - **Edit Post Effects**: Click this button to open the Post Rendering Effects dialog. For further information, see .

  - **Export Image**: Opens the Export As dialog, which allows you to save the render in one of the supported image formats.

  - **Set Compare Image**: Designates the selected image as the image to compare with another thumbnail for use with the Render Wipe slider.

  - **Show in Explorer**: Navigates to the folder that contains the image, and displays it in Windows Explorer or Mac Finder.

  - **Delete**: Deletes the selected render from the render cache, and removes the thumbnail from the Recent Renders palette.
Recent Renders options.

- **Delete All**: Deletes all renders from the render cache, and removes the thumbnails from the Recent Renders palette. You must select at least one thumbnail for this command to be enabled.

- **Refresh Thumbnails**: Click this button to update the thumbnails that appear in the Recent Renders palette.
The Display Controls and Menu

Poser allows you to select 13 display styles. Selecting a different display style can help you better visualize your scene and/or add additional artistic interest to your rendered output. You can select display styles on the scene, figure/prop, or element (body part) level.

![Document Display Style controls.](image)

The Display Controls palette has adjustable width and height, and the controls auto-wrap to fit the allotted width. If additional height is needed to display all the controls, a scrollbar appears on the right side of the palette.

Clicking the title opens a pull-down menu with the following options:

![Display styles can be set for the entire document, for a single figure, or for an object.](image)

By default, the display style that you select will be applied to the entire document (Document Display Style). You can also apply different display styles to the selected figure, or the selected element.

- To change the display style for the entire document, choose **Display > Document Style > (display option)**, or choose **Document Style** from the Display controls palette and click the display style icon you want to use. This affects how all scene elements (figures and props) are displayed unless the display style of a figure or actor is overridden as described below.
Display Styles

By default, Poser renders using the Texture Shaded mode. While rendering high-resolution output using the currently selected display styles and/or depth cueing, etc. is not directly supported, you can achieve excellent results using the rendering tips discussed in .

You can apply any of the following display styles as follows:

- **Document Style**: Applies the selected display style to every item in the current scene.
- **Figure Style**: Applies the selected display style to the currently selected object.
- **Object Style**: Applies the selected display style to the currently selected prop or body part.

Whether you use the **Display > Document Style, Display > Figure Style, or Display > Object Style** menu, or the **Document Style, Figure Style, or Element Style** display control palette, there are thirteen different display styles from which to choose. They are as follows:

- **Silhouette**: displays the figure/element only as a cutout.

  ![Silhouette Display Style](image)

- **Outline**: displays the figure/element only as an outline. When either the entire scene or an entire figure is displayed in this mode, outlines appear around each actor (body part).
Outline Display Style.

- **Wireframe**: displays the figure/element as a polygonal mesh. This mode displays the actual polygons comprising the figure/element, including polygons that would normally be hidden from view (such as a figure’s back when viewed from the front).

Wireframe Display Style.

- **Hidden Line**: displays only the figure/element’s polygons that would normally be visible from the current camera. For example, if you are viewing a figure from the front, the polygons forming the back would not be visible.

Hidden Line Display Style.

- **Lit Wireframe**: displays much the same as the Wireframe display style, except that the polygons’ colors correspond to the color of the surface material.

Lit Wireframe Display Style.

- **Flat Shaded**: displays figures/elements using the surface material colors while displaying the mesh facets.

Flat Shaded Display Style.

- **Flat Lined**: same as the Flat Shaded display style, except that black mesh lines clearly denote polygon edges.
Flat Lined Display Style.

- **Cartoon**: displays the figure/element using a simulated hand-drawn style. See Cartoon Settings for more information about this shading style. Poser offers improved Cartoon display effects in conjunction with the OpenGL hardware acceleration option (see OpenGL Hardware Acceleration).

Cartoon Display Style.

- **Cartoon With Line**: same as the Cartoon display style, except that figures/elements are outlined with black lines. See Cartoon Settings for more information.

Cartoon with Line Display Style.

- **Smooth Shaded**: displays figures/elements as smooth continuous surfaces with the material colors.

Smooth Shaded Display Style.

- **Smooth Lined**: combines the Flat Lined and Smooth Shaded by displaying the polygons as a black mesh over a smooth surface.

Smooth Lined Display Style.

- **Texture Shaded**: displays figures/elements using texture maps.
The Display Menu Commands

As the name implies, the Display menu controls how items appear in your Poser workspace, specifically within the Document.

- **Camera View**: Choose Display > Camera View to select one of the cameras available in your scene. See Cameras for more information about the various camera views.

- **Camera Layout**: Choose Display > Camera Layout to select the number of different views that you want to display in the document window. See Single/Multiple-View Panes for more information about multiple views.

- **Fly Around**: This command puts the current camera in Flyaround mode. For more information, see Flyaround View.

- **Frame Selected**: The Frame Selected command fits the camera view around the currently selected actor. See Frame_Selected.

- **Orbit Selected**: The Orbit Selected command rotates the camera around the currently selected actor. See Orbit_Selected.

- **Show Camera Names**: Selecting Display > Show Camera Names displays the name of the currently selected camera in the top left corner of the Document’s scene preview area. Clicking this option again disables this feature.

- **Production Frame**: Selecting Display > Production Frame allows you to specify whether you wish the production frame to be visible in the Document’s scene preview. The size of the production frame is determined by the aspect ratio resulting from the output width and height. See Render Dimensions and Rendering Animations for more information about configuring the output dimensions for images and movies, respectively.
The Production Frame

- **Document Style, Figure Style and Object Style:** See Display Controls

- **Depth Cued:** Depth Cueing adds dimension to scene elements visible in the Document. When Depth Cueing is enabled, elements farther away from the camera fade into the distance. See Using Depth Cueing.

- **Tracking:** Selecting Display > Tracking allows you to set your desired tracking mode. Please refer to Tracking Mode for more information about tracking modes.

- **Deformers:** Shows or hides the deformers in your scene. For more information, see Using Deformers.

- **Ground Shadows:** Displays shadows on the ground only. For more information see Shadows.

- **Figure Circle:** Toggles display of a circle around your currently selected figure in your scene, which turns red depending on cursor location, allowing you to select the entire figure. Please refer to Full Figures Context Menu for more information about the Figure Circle.

- **Bend Body Parts:** When enabled, adjacent body parts blend together when bent. When disabled, body parts appear to split apart when bent. See Bend Body Parts for more information.

- **Foreground/Background Color:** Selecting Display > Foreground Color or Display > Background Color allows you to specify the Document’s foreground and background colors, respectively. You can also do this using the Color controls located next to the Document. Please refer to Colors for an explanation of foreground and background colors.

- **Show Background Picture:** If you have a background image in your scene that was placed there using either the File menu or by pasting the current figure/prop into the background, then selecting Display > Show Background Picture toggles displaying this image on and off.

- **Clear Background Picture:** Selecting Display > Clear Background Picture deletes the currently displayed background image (if any).

- **Paste Onto Background:** See Paste Onto Background
Bend Body Parts

Selecting **Display > Bend Body Parts** toggles bending on and off. All body parts are separate elements (actors). As you change their positions, Poser attempts to maintain continuity over the entire body. The arm should connect smoothly to the shoulder, etc. Poser achieves these smooth transitions by bending body parts where they join. However, the bends that work well for a body part might not work well when applied to figures created from props, or figures that have some body parts replaced by props (such as replacing a hand with a hook for a pirate character). Rendering images with bending disabled can cause figures to appear “broken.”

When the Bend Body Parts option is off, figures split at the group seams.
Paste Onto Background

You can paste the contents in your scene into your scene background: This is especially helpful for planning animation.

To do this, first hide the Ground so that your background is visible. Adjust the camera or position the item(s) as desired, then Select Display > Paste onto Background. If you do this more than once, each succeeding image supersedes the previous one. This is also true if you import a separate background image/movie.

Guides

Poser provides several guides to assist you when posing figures. Guides are particularly useful for helping you achieve a particular perspective more easily. To display a guide, select Display > Guides and select the guide you wish to display. A check mark appears next to visible guides. To hide a guide, select Display > Guides and select the guide you wish to hide. Hidden guides have no check marks next to them. The available guides are described in the following sections.

Ground Plane

The ground plane provides a basic reference of the camera’s position relative to the Poser workspace. It also helps show scene elements’ vertical positions relative to one another. You can display the ground plane using the same display style as the rest of your scene or you can give it its own display styles.
The Poser 13 background is a hemisphere (or dome) that has two material zones: Ground and Background. If you want to render an image against a transparent background, you will need to turn off the ground plane by unchecking the **Display > Guides > Ground Plane** command.

The ground plane represents the “zero” point of the scene’s height.

**Head Lengths**

This guide references the figure’s height. Most people are roughly seven “heads” tall, meaning that the average head is 1/7th the height of a person. This guide can be helpful when you are performing body shaping operations such as using morph targets.
Head lengths are represented by several parallel planes.

**Hip-Shoulder Relationship**

This guide displays the relationship between the figure’s upper and lower body. It helps you see the side-to-side, bend, and twist in the hip, abdomen, and chest. This is particularly useful when editing/viewing your figure using different cameras.
Hip and shoulder relationship guides.

**Horizon Line**

This guide references the Poser workspace’s horizon line. You can check camera orientation by selecting a camera and checking its position relative to the horizon line. The horizon line is also useful when creating perspective between two or more figures or other scene elements. For example, if the horizon line crosses the front figure’s chest, arrange all the figures so that the horizon line crosses their chests as well. This ensures that all figures are on the same plane and contributes to a viewer’s sense that all figures have their feet on the ground.
Vanishing Lines

Vanishing lines are an artistic technique for achieving realistic perspective. You can see this is real life by standing at the corner of a long building and sighting along a wall. You will see that the roof and the ground appear to converge the farther away you look until they eventually meet. This phenomenon is one of the things that give objects the appearance of depth in both real and virtual life.
Focus Distance Guide

The focus distance is the distance at which objects appear most in focus. This distance is individually configurable for each camera. The Focus Distance Guide shows you where the focus distance for the selected camera falls within the scene, to help you visualize the position of various scene elements in relationship to the focal plane. For more information on the focal plane and focus distance, see Camera Parameters.

Cartoon Settings

Display > Cartoon Settings will display the Preview as a cartoon-like image.

The Cartoon Settings command has the following subcategories:

- Shading Styles
- Comic Book Settings
- Geometric Edge Lines

The subcategories are not mutually exclusive, they can work in combination. Try working with a checkmark on one sub-category alone until you get some experience seeing the results before you try combining them. Use your own judgment to decide what combination works best for the look you are trying to achieve.
All three sub-categories can be active at the same time.

Shading Styles

The Cartoon Settings shading styles are only visible when Cartoon or Cartoon w/Line is selected as the Document Style, Figure Style, or Element Style from the Display menu. These Cartoon Settings allow you to choose between the following options for your preview:

- **One Tone, Two Tones, or Three Tones**: Presents a flat filled effect similar to posterizing an image to a level of one, two, or three grayscale values.

- **Three Tones Plus Hilights**: Presents the image in three levels of gray as above plus a highlight area.

- **Smooth Toned**: Presents a smoothly shaded preview without hard boundaries between values.

Note that these styles affect the Preview display only and will not affect the final render. The Preview image can be exported to a file. To export the Preview image, select the white triangle in the upper right corner of the Preview display and then select Export image. See Exporting Images for more information.

Click the white triangle and choose Export Image from the menu that appears.
La Femme and L'Homme have facial body chips that are displayed in the Preview window by default. To hide them during a preview render, you will find a control in the Body actor that turns off the display of the facial, breast, and buttocks control chips. Expand the Controls group in the Body actor, and set the Hide <-- Control Handles --> Show parameter to 0 (zero) to hide the chips.

Comic Book Settings

The Display > Comic Book or Display > Comic Book (Color) commands present a look similar to a comic book illustration, without the need to assign materials that have Toon IDs. There are two Comic Book preview modes: Comic Book, for a black and white result, and Comic Book (Color), for a color result.

The previews include persistent shadowing and improved outlining. Comic Book Settings work best in Texture Shaded display style but they will also work with the other display styles. Use the Cartoon display style with a Cartoon Setting checked and a Comic Book Setting checked if a combination of the two is desired.

There are several ways to enable one of the Comic Book Settings:

- Choose Display > Cartoon Settings > Comic Book or Display > Cartoon Settings > Comic Book (Color).
- Right-click in the Preview viewport, and choose Cartoon Settings > Comic Book, or Cartoon Settings > Comic Book (Color).
- See Comic Book Preview Options below for an additional option.

Geometric Edge Lines

The Display > Cartoon Settings > Geometric Edge Lines command toggles edge lines on or off. Edge Lines surround the figure, like the outline of a comic book figure. Geometric Edge Lines can be used alone or in combination with the Cartoon Settings and Comic Book Settings.

See Comic Book Preview Options for additional options for the Edge Lines.
Comic Book without (left) and with Geometric Edge lines (right).

Comic Book (Color) without (left) and with Geometric Edge lines (right).

To implement geometric edge lines, Poser draws the selected shape in black color, resizes it, and then removes the front shape to generate the edge line. Geometric edge lines cannot work with shapes that have transparencies applied to them, because anything that is transparent will show the black color behind it. Where a material has transparency set to On (such as trans-mapped hair or eyelashes), geometric edge lines are disabled.

Comic Book Preview Options

Click the Comic Style Options widget located in the Document Window taskbar as shown in the following figure.
Poser Reference Manual

Measurement Mode

Cartoon Setting options can be selected from the document window taskbar

The Comic Book Preview Options popup displays the following options:

- **Geometric Edge Lines**: Check this option if you want to give the Comic Book preview an outline.
  - **Multiplier**: You can increase or decrease the width of the geometric edge line by entering a new value in the field or moving the slider left to decrease or right to increase.
  - **Weld**: When enabled, creates smooth toon lines in geometric objects that have unwelded corners (such as a cube).

- **Comic Book Filter**:
  - **None**: Turns Comic Book preview off.
  - **Black and White**: Creates black and white Comic Book previews.
  - **Color**: Creates color Comic Book previews.
  - **Threshold**: Use the Comic Book Threshold slider, to adjust the light/dark contrast of the comic book preview.

Measurement Mode

You can use the Measurement Mode icon to create or edit one of four different measurement types. For more information on these measurement objects, see Creating and Using Measurement Objects.
Use the Measurement mode icon to create or edit a measurement object.
The Poser Library

Poser’s hierarchical Library palette provides access to all of the content that ships with Poser such as figures, props, lights, cameras, etc. It has three tabs: the Library tab that provides access to the Poser content categories, the Search tab which allows you to search your content folders for specific files, and the Favorites tab where you can gain easy access to your frequently used or favorite content items. The Library tab contains ten categories, discussed below. Each category is further divided into subcategories. You can create and remove categories and subcategories, and can add and remove content, including your existing content libraries, to/from the Library palette. See Maintaining Your Library Palette for information on maintaining your Library palette.

The Library palette consists of four tabs.

- **The Library tab** contain Poser’s Library content categories. The Categories icons allow you to access and search through all of the content available to your installation of Poser, including content included with Poser and any additional content you may have obtained. The Library tab contains categories (Figures, Props, etc.) and subcategories (Animals, New Figures, etc.) for organizing your Poser content: You can also organize your favorite content in the Favorites tab for even quicker access. Use the Library tab to add or remove elements from your Poser scenes. The vast collection of content included with Poser allows you start building scenes right away. The Library makes it easy to add existing and new content collections so that you can find and add any items to your scene. Please refer to The Poser Library for more information about the Library palette and to Changing the Library Appearance for information on how to show and hide the various elements in the Library tab.

- **The Search tab** allows you to perform keyword searches through one or all of your runtimes. Use the Search tab to perform keyword searches on one or all of your Runtime libraries. This powerful new feature makes it easier to find the content you want to use, even in large content collections. You’ll find more information in Searching the Library.

Poser ships with a wide array of content that you can use to create thousands of unique still and animated scenes. You can also use the search feature in the Library to locate and obtain even more free and for-sale content from leading 3D marketplaces! Please refer to Searching the Library for more information.

- **The Favorites tab** on the Library palette provides quick access to your favorite Poser content. For more information about adding favorites, see Favorites Tab.
The following figure shows the various controls and options that are contained in the Library palette. You can navigate through the Library list as follows:

- Use the Up and Down arrow keys to move higher or lower in your content tree.
- Use the Right and Left arrow keys to open and close folders.
- Click or select an item in the list to expand the display and view a larger preview of the content item.
The Library Window.

1. **Library Tabs**: Allows you to switch between three views in the Library palette: Library, Search, Favorites, and Purchases.

2. **Category Icons**: Allows you to select one of the ten library categories. From left to right, they are Figures, Poses, Faces, Hair, Hands, Props, Lights, Cameras, Materials and Scenes.

3. **Library Selection**: Click the Show Library selector to display all runtime folders, or to display the contents of a single selected runtime folder in the library contents window.

4. **Expanded folder**: Click the down arrow to collapse the contents of the folder. The number that appears in brackets at the beginning of the folder name designates the number of items that are contained within that folder.

5. **Collapsed folder**: Click the right arrow to expand the contents of the folder. The number that appears in brackets at the beginning of the folder name designates the number of items that are contained within that folder.

6. **Remove Library**: A Remove Library (-) icon appears to the right of the Add Library icon when you use the Show Library menu to select a Library that you added yourself through the Add Library command. See Removing Libraries for details.

7. **Add Library**: Click the Add Library (+) icon to open the Browse for Folder dialog, which allows you to select additional Library folders that you have stored on your computer.
Content that is created for Poser is typically arranged in a folder named Runtime, with subfolders beneath that for geometry, textures, and library items. For more information about creating, installing and accessing additional library folders, see Accessing Different Content Libraries.

8. **Item List Panel**: The currently selected item is highlighted in blue and displays controls to add the selected item to the scene or to display item information. If the Item List Panel is not displayed, the currently selected item displays as a larger icon in the Tree view.

9. **Extended Details Panel**: Displays a thumbnail, filename, file size, installation date, and other details about the item that is selected in the library. This information appears in the XML file that is saved in the same folder as the library content. An Extended Details editor also allows you to add or edit the metadata associated with the selected content item.

10. **Add a Folder (+)**: Appears when a folder is selected. Click this button to create a new folder or subfolder beneath the currently selected library folder.

11. **Double Check mark**: Click the double-check mark icon to add the currently selected item to your scene. The double check mark does not appear for every Library category and the purpose varies depending on the selected category. See Loading and Managing Items using the Library Icons.

12. **Single check mark**: Click the single check mark icon to replace the item that is currently selected in your scene with the item that is highlighted in the library. Functions of the single check mark button vary, depending on the Library category that is currently selected. See Loading and Managing Items using the Library Icons.

13. **Save to Library (+)**: Appears when a folder is selected. Click this button to add the item that is currently selected in your scene into the library.

14. **Delete from Library (-)**: Click this button to delete the library content item that is currently selected. Note that this button completely removes the library item from the Library, not from your scene.

15. **Add to Favorites**: Adds the item that is currently highlighted in the library to the library’s Favorites tab.

16. **Display Options Widget**: Click the Display Options widget to expand or collapse the display options in the bottom of the Library palette.

17. **Display Options**: Use the Display, Tree, List, and General display options to configure how content is displayed in the Library palette.

18. **Breadcrumb Trail**: Displays the library path to the currently selected folder or item. Use the Up arrow at the left of the breadcrumb trail to navigate up to the previous folder level.

19. **Library Display Widget**: Click this widget to show and hide the library window.

20. **Library Menu**: Click the Docking Control icon (the small arrow) in the upper-right corner to select commands that dock, undock, close, or enable/disable dragging. Refer to Enabling or Disabling Docking for further information.

21. **Search**: Enter text to search for and then click the Search button located at the right of the search field.
Displaying the Library Palette

If the Library palette is not open, select Window > Libraries.

  - Commands to dock or float the library appear in the docking options menu, accessible by clicking the Docking Control square in the upper-right corner of the Library window.
  - When the Library palette is floating, you can position and resize it however you like. Drag either side of the Library palette across your screen to the desired width. You can also move the Library palette to a second monitor if desired. For further instructions on arranging palettes, refer to Enabling or Disabling Docking.
  - You will notice a library popup widget in the upper-right corner of the Poser interface that allows you to show and hide the library window.

The Library palette allows you to display your content in a variety of ways. You can display your content in a Tree view, which displays all of the content in your libraries in a hierarchical list. The tree view appears as shown below if the Item List display is turned off.
Viewing library items in Tree view.

Alternatively, you can undock the Library palette and display content in the Item List panel.

When the Item List is open, a hierarchical tree appears in the left side of the library. When you select a folder in the tree, its content appears either in a list with a preview thumbnail for each item, or in a multi-column display of thumbnails that adjusts to fill the width of your library window as shown below.

List view displays content as a list (left), or as a grid of thumbnails (right).

The section describes how you can customize the appearance of the Library palette to suit your needs.
Changing the Library Appearance

A widget appears at the bottom of the Library palette, just beneath the library buttons shown in the previous figure. Click this widget to expand the Library palette to view the display options described in the sections that follow:

![The Library Display Options widget.](image)

**Display Options**

![Display library options.](image)

Check or uncheck the options listed below, to show or hide the various areas in the Library palette as desired. These areas are labeled in the following figure.
Breadcrumbs, Tree, Item List, and Extended Details in the Library palette.

- **Tree**: Displays a hierarchical view of the contents of your library. Check or uncheck this option to show or hide the hierarchical tree in the Library palette. If the Item List Panel is turned off, thumbnails appear in the tree.

- **Item List Panel**: Displays the folders and content thumbnails for the folder that is selected in the tree. The thumbnail display appears in multiple rows and columns that adjust to the width and height of the Library palette. Check or uncheck this option to show or hide the item list panel.

- **Extended Details Panel**: Displays information about the selected item. Check or uncheck this option to show or hide the extended details.

The Extended Details panel will display basic information such as the product name, size, the date the file was installed and last modified, and the path to the file on your computer. Additional metadata can also appear about a library item if it has been added by the author of the content. Extended details can include additional information such as author name, copyright information, usage instructions, and more. Metadata is stored in a file that ends with an XMP extension.

- **Breadcrumbs**: Displays the runtime folder path to the selected library folder. Check or uncheck this option to show or hide the breadcrumbs.
**Poser Reference Manual**

**Changing the Library Appearance**

- **Log Library Events**: Actions and selections performed in the library will appear in the event log window.

**Tree Options**

Thumbnails and additional product details appear in the Tree if you have selected to disable the Item List Panel. The options in the Tree Options section control the size of preview and selected item thumbnails, details, and other items in the Tree.

![Tree library options.](image)

- **Thumbnail Size**: Drag the slider left or right to decrease or increase the size of the preview thumbnails.
- **Selected Thumbnail Size**: Drag the slider left or right to decrease or increase the size of the thumbnail for selected library items.
- **Tree Indentation**: Drag the slider left or right to decrease or increase the amount of indentation for items and folders that appear within and beneath library folders.
- **Reopen folders**: When checked, folders will remain expanded when you select another folder. When unchecked, folder will collapse when you select another folder.
- **Show Folder Counts**: When checked, a number will appear in parentheses to indicate the number of items that are contained within that folder.

**List Options**

When the Item List is enabled, thumbnails appear in multiple columns that adjust to fit the width of the panel. Settings in the List Options section control size of the thumbnail and the placement of text around the thumbnail.

![List library options.](image)

- **Thumbnail Size**: Drag the slider left or right to decrease or increase the size of the content thumbnails.
- **Thumbnail Gap**: Adjusts the amount of horizontal space between the thumbnails
- **As Grid**: When checked, displays content in a grid of thumbnails only. When unchecked, displays contents as a list, with a thumbnail preview and details of each item.
Details Options

The Details Options tab controls the appearance of the thumbnails in the Extended Details panel.

- **Show Folder Thumbnails**: When checked, a thumbnail of the first item in the selected folder will appear on the folder. When unchecked, folders will display without a thumbnail.

- **Show Image**: Check this option to display an image of the selected library item in the Extended Details panel. Uncheck the option to remove the image display.

- **Max Image Size**: If you have images displayed in the Extended Details panel, drag the slider toward the left to reduce the size of the image, or toward the right to increase the size.

Search Options

The Search Options tab provides settings relating to library searches.

- **Autocomplete**: When checked, search terms will automatically complete after enough characters are entered to determine results that match characters that you enter. When unchecked, the word will not autocomplete. In either case, search terms that match the characters that you enter will dynamically appear beneath the search field.

About Library Palette Categories

Poser's new library allows you to quickly select categories and the items contained within them.

*If you are seeking more information related to installed third party Poser content, please look in the "ReadMe" Folder located in the Poser installed "runtime" folder. This folder is in the content location that you selected when installing Poser. There are not ReadMe's for every specific piece of content,*
The Figures Category

Figures are poseable content items that use an extension of CR2 or CRZ. The Figures category houses your poseable Poser figures. This category contains many figures to work with, including various types of males and females, children, skeletons, mannequins, stick figures, and animals. Morph values can be saved with figures if you choose the option to do so while saving them. Newer Poser figures feature fully articulated hands and feet with movable fingers and toes.
There are two main types of clothing used in Poser: conforming clothing (discussed here), and dynamic clothing, which are treated as and found in the Props library. You’ll find more information about dynamic clothing in The Cloth Room.

Poser includes two versions of both male and female human skeletons. These skeletons are found in the Additional Figures/Skeletons content folder. The human skeletons named Ryan and Alyson are designed to conform inside the Ryan or Alyson figures to create medical illustration effects. These conforming skeletons will follow the conformed figures’ poses and positions. A semi transparent version of each character’s texture is found in the Materials in the Library, so setting up a skeleton inside a figure is easy to achieve using these pre-configured material collections. The fully articulated M/F skeletons are accurate versions of the human skeleton with each bone poseable. These are not designed to conform inside the human figures, but instead work best on their own.

The Figures category stores poseable figures, such as humans and animals.

Some models are available in high- and low- resolution versions. Use high-resolution models for realism, and low-resolution models (these have very low polygon counts) when performance matters. For example, using low polygon figures instead of high polygon figures in the distance of a large scene can conserve on your computer resources.

**Replacing Figures**

If you want to replace a figure or light in your scene with one from the Library palette:

1. Select the figure you wish to replace and click the Change Figure (single check mark) button.
Adding Conforming Clothing: Automatic Conforming

2. If you are replacing a figure, the Change Figure dialog appears with the following options:

- **Keep modified geometries**: Check this option if you have modified the geometry of the figure with morphs and want to pass the modifications on to the figure that is replacing it. Props and magnets attached to the figure, and other changes such as groups changed or added and normals reversed, will be applied to the figure after replacement.

- **Keep attached props**: Check this option if you have attached props to the figure and want to attach them to the figure that is replacing it.

- **Keep attached deformers**: Check this option if you want the new object to use any deformers (magnets or wave deformers) that you have added to the object that is being replaced.

- **Keep attached figures**: When checked, any figures that are attached to the original figure will remain in the scene and will be attached to the new figure. For example, if you have Alyson wearing conforming clothing, and then you replace Alyson with Alisha, then Alisha will wear the same clothing. When this option is not checked, the clothing worn by the original figure will be removed from the scene when the replacement figure appears.

- **Keep current proportions**: To have the new figure retain the old figure’s proportions, check the Keep current proportions checkbox. Leaving this checkbox blank allows the new figure to retain its own proportions.

![Change Figure options](image)

3. After you make your selections, click **OK** to add the figure.

**Adding Conforming Clothing: Automatic Conforming**

The simplest way of clothing figures is with conforming clothing. Conforming clothing is poseable, just like a human or animal figure. This type of clothing is typically designed for a specific figure (for example, clothing designed for Alyson will not fit or conform exactly to the G2 figures). However, when conforming clothing is “attached” (or conformed) to the figure, it automatically bends and poses along with the character that wears the clothing.
Conforming clothing automatically “fits” to the character that it is designed for.

Options in the Properties dialog allow you to choose whether or not you want to include morphs and/or scaling when conforming your clothing to a figure. For further information, see Figure Properties.

Due to fundamental changes to Alyson 2 and Ryan 2 figures, conforming clothing created for the original Alyson and Ryan figures will not automatically conform.

Conforming clothing is rigged like a figure, including the same joint parameters. Some conforming clothing includes morphs that correspond with the morphs in the figure.

You will find conforming clothing in either the Figure library or the Props library.

- When found in the Figures library (as is typical for older clothing, or conforming clothing created by third-party content creators), conforming clothing will use a CR2 or CRZ extension.

- When found in the Props library (as is common for Poser 7 and later, and Poser Software’s G2 Figure clothing), conforming clothing will use a PP2 or PPZ extension.

You can drag and drop conforming clothing onto a selected figure and the clothing will automatically inherit the pose of the figure. To automatically conform clothing to your figure, follow these steps:

1. Click to select the figure in your scene that you wish to clothe. This makes it the active figure in your scene.
Adding Conforming Clothing: Manual Conforming

You can use the **Figure > Conform To** command to manually conform clothing to any figure in your scene. The process is as follows:

1. Select the figure you wish to clothe.

2. Select a conforming clothing item from the desired **Figures** or **Props** category. Clothing is often named for the figure that it is designed to fit (for example, Alyson Pants).

3. If your clothing is in the **Figures** category, click the Create New Figure button at the bottom of the **Library** palette. If the item is in the **Props** category, click the **Apply Library Preset** button. The clothing appears to the scene in its default position and pose. Alternatively, you can drag and drop from the Library to the **Document**.

4. When added to the scene, conforming clothing appears in the Select Figure menu pull-down menu (described in **Select Figure/Current Actor Menus**. Verify that the clothing item that you want to conform is currently selected.

5. Choose **Figure > Conform To**. The Conform To dialog appears, listing all of the figures in your scene. If the clothing is already conformed, it displays the name of the figure that it is conformed to.

---

You can use Ctrl+Click or Shift+Click to select more than one piece of clothing to drag and drop. After making your selection, position the mouse over one of the selected items and then drop them as a group over the figure. Release the mouse button when the status bar at the top reads "Add and conform to (figurename)." The clothing items will load and conform to the figure one at a time.

---

Some tight-fitting conforming clothing may not completely cover the base figure’s skin, particularly when the figure is animated. You might notice the base figure poking through areas of the conforming clothing. There are two ways to correct this problem. The first method is to hide the body part of the
The Poses Category

The Poses Library palette category houses poses (*.PZ2), which actually fit into several different categories.

- **Figure Poses**
- **Material (or MAT) Poses**
- **Other Pose Types**
- **Saving Poses with Animation Layers**

**Figure Poses**

Poses were originally designed as pre-defined poses (standing, sitting, working, and so on) that you could apply to your currently selected figure. Pose files store pose information for an entire figure, including its hands (see below for more information). They contain joint positions for each of the figure's joints (such as Left Elbow bend 45 degrees).
Use presets in the Pose category to pose your characters.

To add a pose to a figure:

1. Select the figure (not its clothing) to apply the pose to.
2. Open the Poses category and highlight the pose that you want to apply to the figure.
3. Choose one of the following options:
   - Click the single check mark button to apply the pose to the selected figure when the pose was created specifically for that figure.
   - Drag and drop the pose from the Library to the figure. A tooltip displays the name of the character as your mouse hovers over it. Release the mouse when the tooltip displays the correct character name.
After posing, the clothing also poses with the character.

Poses that are set-up for figures with standard rigging may not apply correctly when used with figures provided with Poser 7 and later.

Poses that were created in Poser 6 or earlier versions applied specifically to a particular figure. For example, a pose you may have created for the James figure may not work correctly when applied to the Kate figure due to the different joint setups between the two figures.

Material (or MAT) Poses

Third-party content creators sometimes use Material Poses (or MAT files for short), as an alternative to MC6 material collection files. MAT Poses apply preset textures and shaders to a selected figure or object. They are typically found in the Poses library.

If you need help with MAT files, please refer to the file creator (if you purchased or obtained a MAT file, for example) or to one of the many online resources.

Material collections, discussed in The Materials Category, are the preferred method for saving complete materials for a figure or prop to the Materials library.
Other Pose Types

Though not as common as figure and MAT poses, you will also find a mixture of other types of pose files in the Pose Room. Like MAT poses, these are generally created by third-party content creators. Other uses for Pose files include:

- Many legacy Poser characters include Specialty poses that zero a figure, add deformers, turn IK off of the legs and arms, and lock or unlock the toes. Third-party content may or may not include similar poses.

  Specialty poses perform specific functions that help with posing and fitting clothing.

- MOR poses, which apply character morphs and settings to a figure.

- INJ and REM poses, which inject or remove injected morphs into or from a figure.

When you are not certain what a pose type is used for, check the Readme file (which usually accompanies the third-party product), or contact the individual that created the product.
If you are saving a Pose set that contains Animation Layers, the Save Frames dialog will include a Select Layers button. Click this button to select the animated layers that you want to include in your scene. For more information on Animation Layers, see Layers Tab.

**Additional options for poses that have animation layers.**

### The Faces Category

The Face Library palette category houses facial expression files (*.FC2), which can be applied to your currently selected figure.

Face files contain parameter settings that activate facial morph targets (see Creating Custom Parameter Palettes for information about morph targets) to create the expression. These files are the same as if you manually adjusted each of the face dials available for your current figure, or if you use the Random Face poses in the Library, except that they apply preset values at once, saving time.

Poser Face directories contain full facial expressions (Angry, Disgust, Fear, and so on). You can also dial these individually, by facial region (eyes, lips, cheeks, and so on). To do so, you typically click on the head to find the full set of facial morphs. Any combination of these head/face morph targets will be stored in the Face category when you add a new entry.

*Facial expressions are often designed for a particular figure, since each figure can have different facial parameters available. For example, an expression file created for the Poser 6 Male figure (James) may not work on Ryan, because Ryan has far more available facial parameters.*
To add a facial expression:

1. Select the figure to apply the expression to.
2. Locate the desired facial expression in the Face library.
3. Double-click the selected facial expression, or click the **Apply Library Preset** button, or drag the selected expression from the library to the character. The facial expression on your figure changes.

Expressions for your characters are found in the Face category.
The Hair Category

The Hair Library palette category houses hair files, which can be applied to your currently selected figure. Hair created for one figure may or may not fit or work with other figures.

The Hair library stores many different types of hair for your characters.

Poser allows you to save hair in three different formats:

Conforming Hair

Conforming hair uses a CR2 extension, and is created for specific figures using the same bones and joint centers as the figure it conforms to.

To add conforming hair to your figure:

1. Select the figure to which you want to add hair. Or, if you want to replace an existing hair with another selection, select the hair you want to replace.

2. Select the desired CR2 conforming hair from the Library palette.

3. Use the single or double check-mark at the bottom of the library palette as follows:

   • If adding hair to a figure that currently does not have hair, use the single checkmark to add the hair to the figure. Or, drag and drop the hair from the library to the figure's head.

   • To replace the currently selected hair in the scene, use the single checkmark to replace the selected hair.

   • To add additional hair to the scene, use the double checkmark to add the hair from the library to the figure. Hair that was already in the scene will remain.

Conforming hair can appear in the Hair library, but older conforming hairs may appear in the Figures library.
To translate conforming hair, use the Translate dials in the Head actor of the hair. For example, the YTrans dial will transform the hair up and down.

![The YTrans dial in the hair's Head parameters will translate the hair up and down.](image)

**Prop Hair**

Prop hair is a modeled and textured OBJ file that typically uses an HR2 extension. Sometimes you can also find hair that uses a PP2 extension, which you can find in either the Hair or Props library.

Prop-based hair with an HR2 extension is a special kind of prop that automatically attaches itself to a figure’s head. You can choose from a number of styles in the Library palette. Once assigned, hair moves with the figure’s head. Some newer hair models that come with Poser are morphable, as are many third-party hair props. It is common to use Transparency Maps to improve the look of prop-based hair.

Prop hair is not poseable, but it may also include morph parameter dials in the Parameters palette (see [Prop Parameters](#)), allowing you to specify its scale and position. Some hair also includes morph target parameter dials that allow you to, for example, swing a ponytail as a character walks.

To add prop-based hair (HR2 or PP2 extension) to your figure:

1. Select the figure to which you want to add hair.
2. Select your desired hair in the Library palette.

3. Click the **Apply Library Preset** icon, or drag the hair from the library to your scene. The hair is added to the figure.

   If your figure already has prop-based hair, adding a new HR2 hair will replace the old. You can, however, use more than one PP2 hair prop at the same time on the figure.

Prop-based hair automatically attaches to a figure’s head, and is geometry-based.

While prop-based hair usually orients itself to the angle and rotation of the head, you may need to reposition the hair to precisely fit the figure’s head (especially if it was created for another figure as is the case in this example). To do this, use the Current Actor pull-down menu to select the hair, then use the hair’s Trans parameter dials as necessary in the Parameters palette.

**Strand-Based Hair**

Poser’s Hair room (see [The Hair Room](#)) allows you to create real strand-based hair. Strand-based hair uses an HR2 extension.

You can create as much or as little hair anywhere you like on any object in your scene and can even use it to add fur, lichens, grass, and many other effects. Please refer to [The Hair Room](#) for more information about strand-based hair and the **Hair** room.

Strand-based hair created in the **Hair** room cannot be saved to the **Library** palette unless it is saved with underlying geometry such as a figure or skull cap.
By default, strand-based hair requires significant computing resources, so you should be careful not to overload your system. Please see the detailed information about the Hair room for more information.

The Hands Category

This Library palette category houses hand (*.HD2) files, which can be applied to your currently selected figure. Hand files are subsets of Pose files that only contain positioning information for the hand and its children (fingers). Hand poses contain both finger positions and wrist positions.

The Hands category stores poses that affect the hands and fingers.

Not all figures hands are created using the same number of joints. Ryan and Alyson contain an additional joint at the knuckle and older hand poses may not work correctly on their hands. Additionally, Hand poses saved using Ryan or Alyson may not apply to older content correctly.

If you apply a pose file to a figure then apply a hand, only the hand positions will change. If, however, you apply a hand file to a figure followed by a pose, the pose application will override the positions specified by the hand file.

To add a hand pose to a figure:

1. Click the figure to which you want to apply the hand pose.
The Props Category

This Library palette category houses props (*.PP2), which are loosely defined as static or poseable objects that are not figures. Items such as swords, balls, canes, furniture, walls, some types of clothing (such as dynamic) and other non-conforming items fall into this category. You will also find conforming clothing items in the Props library.

Adding Props

To add a prop to your scene:

1. Open the scene to which you want to add the prop.
2. If you want to replace a prop that is already in your scene with another prop from the library, select the prop in your scene that you want to replace.
3. Choose the Props category from the Library palette.
4. From the Library palette, select the prop you want to add to the scene.
5. Click the Apply Library Preset (single check mark) button.
6. By default the prop appears in the center of the scene in its default position. You can use the **Translate** dials in the **Parameters** palette to reposition the prop to the correct spot in your workspace.

![A prop added to a scene.](image)

*If you wish to have the prop move with another scene item (such as a tennis racket moving in concert with the figure’s hand), you need to specify a parent for the racket. Please refer to **Changing a Parent** for directions on setting a parent for an object.*

**The Light Category**

This **Library** palette category houses lights (*.LT2), which includes the number, color, position, and other lighting attributes. Please refer to **Lighting** for a description of Poser lights.

![Several lighting presets can be found in the Lights category.](image)

**The Camera Category**

This **Library** palette category houses cameras (*.CM2), which includes all Poser cameras, their positions, and other attributes. Please refer to **Cameras** for information about Poser cameras.
The Camera category stores different settings to position cameras in your scene.

The Materials Category

Poser’s Material library provides an easy way to apply preset materials to the items in your scene. You can navigate through the items in your library, and then drag and drop compatible materials from the Library to the objects in your scene. As you drag your material into the scene, a tooltip displays the name of the actor in your scene. Release the mouse when the tooltip displays the correct actor name.

When saving materials to the library, Poser offers two methods for storing material definitions for an entire figure in a single file. Both of these methods can save considerable time, since they can apply colors and maps to an entire figure simply by loading them from the Library palette instead of having to add them one by one.

This Library palette category houses materials (*.MT5), which include all Poser materials and any associated shader trees created or loaded into the Material room. Materials and material collections can be dragged from the Library and dropped onto an object in your scene.

The Material Collection (MC6/MCZ) file format was designed as a fully integrated replacement for MAT pose files. Additionally, Poser includes a built-in compatibility feature, which enables you to simply change the extension of your MAT files to MC6 or MCZ, and Poser will recognize them as Material Collections.
Use the Materials category to apply different textures and materials to the items in your scene.

- Adding Materials to the Library Palette
- Adding Material Collections to the Library Palette

Adding Materials to the Library Palette

Poser offers the option of saving either single materials, or grouped material collections from a single figure, to the Library palette.

To save single material to the Library palette:

1. Open the Material room.
2. In the Library palette, select the desired Category/Subcategory that will store the new material.
3. Move the mouse into the Preview window, where it turns into an Eyedropper tool. Use the eyedropper to “pick up” the material that you want to save. The material settings appear in the Edit view in the Material room.
4. Click the Save to Library icon (+) at the bottom of the Library palette.
5. In the New Material Set dialog, select the Single Material radio button.
6. Enter a name for the Material and click OK. A square showing the single material appears in the currently selected Material library category/subcategory.

If your single material contains material layers, they will be saved with the material. To save a material layer on its own, see Using Layer-Only Materials.
Adding Material Collections to the Library Palette

Poser also allows you to save some or all of the materials for a single figure together in a **Material Collection**, in addition to saving single materials individually. Simply select the Material Collection option in the **Add to Library** dialog, as described below, and choose which materials you would like to include in the collection. Like MAT files, Material Collections provide the convenience of grouping materials in a single file, and also offer the added benefit of seamless integration into your Poser workflow. Please refer to [The Material Room](#) for information about the **Material** room.

To save Material Collection to the **Library** palette:

1. Open the **Material** room and select your desired category/subcategory.
2. Move the mouse into the Preview window, where it turns into an Eyedropper tool. Use the eyedropper to “pick up” one of the materials in the object that uses the material collection that you want to save. The single material that you clicked appears in the Edit view in the **Material** room.
3. Click the **Add to Library** icon (+) at the bottom of the **Library** palette.
4. In the **New Material Set** dialog, select the **Material Collection** radio button, and click the **Select Materials** button to open the **Select Materials** dialog.
5. Choose which materials you would like to include in your collection from the list presented in the Select Materials dialog, and click **OK**. **Select All** and **Select None** buttons are also provided to add or clear all materials in the selection set.
6. Enter a name for the Material Collection and click **OK**. A small thumbnail of the object with your material settings appears in the currently selected Material library category/subcategory.

*If your material collection contains material layers, they will be saved with the material. To save a material layer on its own, see Using Layer-Only Materials.*

**The Scene Category**

The Scene category allows you to load or save complete scenes. This is especially useful when you want to work with objects that are inter-related to each other, or which use dependent parameters to interact with each other. It also allows you to load complex scenes or a complete set design -- including lights, cameras, and props in the background -- with a single click.

- **Adding Scenes from the Library**
- **Saving Scenes to the Library**
Adding Scenes from the Library

You can use the Scene category in the library to open a scene, or to merge content from an existing scene into your current project. Follow these steps:

1. Open the Library and select the Scene category.
2. Create or navigate to the folder that stores the scene you want to use.
3. Choose one of the following:
   - Click the **Load New Scene** (single check mark) button to replace the contents of the current scene with the scene contents in the library. This is the same as using the **File > Open** command. You will be prompted to save any unsaved changes in the existing project before its contents are replaced.
   - Click the **Import Scene** (double check mark) button to add the contents of the scene in the Library to your current scene. This is the same as choosing the **File > Import > Poser Document/Prop** command. Everything from the imported scene will be added; however if a light in the existing scene is named the same as a light in the imported scene, it will be replaced with the light from the imported scene.

Saving Scenes to the Library

Saving the scene into the library allows you to easily find and reuse projects that you have previously created, and also makes it easier to share complete project settings with others.

1. Open the Library and select the Scene category.
2. Create or navigate to the folder that will store the new scene.
3. Click the **Add to Library** icon (+) at the bottom of the Library palette.
4. In the **New Set** dialog, enter a name for the new scene.
Maintaining Your Library Palette

You can maintain your Library palette by adding and removing items to and from the Library palette, as described below.

Creating Subfolders

You can create new subfolders in the library to store your content. Follow these steps:

1. Use the Show Library menu to select <All > libraries, or the library to which you want to add the folder.
2. Click the category icon that applies to the subfolder you want to create. For example, if you are using the new folder to store a Prop, select the Prop category.
3. Highlight the folder beneath which you want the new folder to appear.
4. Click the Create New Folder icon located at the bottom of the Library palette. You are prompted to enter a name for the new folder.
5. Enter a new folder name and choose OK. The folder appears in the Library palette.

Adding Items to the Library

The following section provides some notes on saving content in general.

Saving an item to the Library palette adds the appropriate item to the currently selected category/subfolder. The actual file location of your saved item will display along the bottom of the Library palette when you select the item by clicking on its preview image once it has been added to the Library. In addition, when you save content to the Library, a basic set of metadata is saved along with the object. This metadata appears in the Library’s Extended Details panel.
when it is displayed. For more information about the Extended Details panel and metadata, see Adding Extended Details to Library Content.

To add an item to the Library palette:

1. Select your desired category/subcategory.
2. Click the Save to Library icon (+) at the bottom of the Library palette.

   ![Save to Library button.](image)

3. Complete the dialog that follows (see following subtopics for information on category-specific dialogs).

4. Enter a name for the new Library palette item and click OK. You may be prompted to select a subset of actors for inclusion in the saved item, depending on the item type being saved (poses, expressions, props, lights, cameras or material collections). Please refer to the following sub-topic for information on selecting actors.

0. Depending on the Library palette category being saved to, you may be asked if you wish to save additional information.
   - When saving poseable figures to the Characters library, you will be prompted to enter a name for the library item. After entering the name you will be prompted to choose which geometry file the entry will use. Choose A new geometry file saved with the library to save the geometry file in the same folder as the CR2. The geometry OBJ file will be named the same as the library item. Choose The original figure geometry file (Content Developers Only) to reuse the OBJ reference that is already present in the file.
   - When saving Poses, you will be asked if you want to include morph channels (such as facial expressions, muscle bulges, etc.), body transformations (transformed body parts, for example), and scales.

   ![Additional information for poses.](image)

6. Saving morph channels will preserve all adjustments you might have made to any morph target parameters. You may also be asked whether you wish to save Body transformations; this option will preserve any modifications to parameters on the “Body” actor. Custom parameter palettes are discussed further in Creating Custom Parameter Palettes. Graphs are discussed in Using Graphs.
When saving content, you may be prompted for additional information to be saved.

You need to take care when saving morph channels and body transformations with poses that you will distribute to others. If your pose is designed as a regular pose that reposes the figure (for example, from standing to sitting), in most cases you do not want to include body transformations or morphs that will affect the settings of the figure that is in another user’s scene. On the other hand, if your pose is meant to set morph targets for a custom figure, you want to include morph channels in the pose set. Consider using the File > Export > Morph Injection command in Poser to save poses that inject character morphs. For more information, see Saving Morph Injection Poses.

7. Poses and Faces can save animated data (such as an animated pose like swinging a golf club). To select only the current frame, select Single Frame. To save more than one frame of animation, select Multiple Frames and enter your desired starting and ending frame numbers. If you are adding an animated pose that includes animation layers, the Select Layers button will be enabled. Clicking this button opens the Select Layers dialog, which allows you to specify which layer(s) you wish to save with the pose. Click OK when you have finished making your selections.

Poses can be saved as still poses (a single frame), or as animated poses (multiple frames).

Your new item will be added to the Library palette and will be accessible whenever Poser is running. Poser also automatically generates an editable .PNG format preview image based on Camera position. You can make a better preview image by positioning the camera to focus on the item you’re saving.

To add dynamic cloth to the Library palette, add it as you would any other prop. For strand-based hair objects, you must either save a Poser scene file.
Adding Actors to a Library Palette Entry

When you save Poses and Faces to the library, a Select Subset button appears in the New Set dialog, allowing you to specify which actors to include in the library file. This allows you to create poses that affect only a part of the figure (for example, a pose that only affects the arms and hands, rather than the entire body of a figure).

If you opt to select a subset of actors within your scene for saving to the Library palette, the Hierarchy Selection dialog appears, allowing you to specify the actors you wish to include in your new Library palette entry.

You can include or exclude specific body parts from saved poses.

The list of actors appears hierarchically, just as it does in the Hierarchy Editor window (see The Hierarchy Editor). You can expand collapsed hierarchies by clicking the right arrow next to a collapsed branch, and can collapse expanded branches by clicking the down arrow next to an expanded branch. The right and down arrows in the upper right section of the Select Objects dialog will expand or collapse the entire hierarchy tree.

To include an actor in your new Library palette entry, check the box to the left of your desired actor. Clearing an actor’s checkbox excludes it from the Library palette entry. Excluding an actor that is a parent of one or more actors excludes the children actors as well.

(PZ3) with your hair object in it or grow hair on a prop and save that prop to the Library palette.
Adding Items to the Library Palette (Manual Method)

You can also add items to the Library palette by creating folders and subfolders in the Poser hierarchy and adding your items directly to those folders. Please refer to Poser File Structure for more information about the Poser file structure.

This is an advanced feature that should only be undertaken by advanced Poser users who are familiar with creating custom content. Manually adding Library items could result in misplacing files, which could cause these Library items to be invisible and/or unusable. Bondware, Inc. cannot provide technical support for people who manually create content folders. If you purchased content and are unable to get it to appear in the Library or if it has other errors, please contact the content creator.

The library thumbnail size has been increased from 91 x 91 to 300 x 300 in Poser 13. Thumbnails will also be created if you save scenes outside of the Poser library. The Poser Launcher also uses 300 x 300 thumbnails for scene previews.

Deleting Items from the Library Palette

To delete an item from the Library palette, select it by clicking its preview image, then click the Delete from Library icon (−) at the bottom of the palette (see below for an image of the Library icons).

You can only delete content that you have added to the libraries yourself. Content installed with Poser is protected and cannot be deleted.

Deletions are permanent! Be sure you really want to delete the selected item. If you have not saved your content elsewhere (such as archiving the source
Installing Content from a Zip Archive

When you purchase Poser content, it is frequently arranged in the appropriate Runtime subfolders for you, and is packaged in ZIP file format. The File > Install from Zip Archive command allows you to unzip content from a ZIP archive. The dialog prompts you to choose any library that is currently configured in your library preferences, including external libraries. You also have the option to specify a folder that is not yet configured.

To install content from a zip archive:

1. Choose File > Install from Zip Archive.
2. Locate the ZIP file that you want to install.
3. The Install Options dialog appears, and prompts you to choose an install location:
   - **Runtime**: Use the dropdown list to select one of the Runtime folders that you have configured in your Library palette. The dropdown list also includes libraries that you have added as External Runtimes as described in Adding Libraries.
   - **Other**: After selecting the radio button, enter a path to create a folder in another location. For example, if you want to create a runtime folder named Test Folder on your D: drive, enter D:/Test Folder. Then you can add that library as an external library as described in Adding Libraries.
4. Click Install to unzip the file to the specified location. The zip file will be unzipped to the location you specified.

If you prefer, you can unzip the contents of the Zip file to your desktop (or other location). Most zips arrange the contents beneath a standard Runtime folder. Drag the Runtime and all folders beneath from the Zip to the Parent folder of your choice. For example, if you have a folder on your D: Drive named La Femme Clothing that already has a Runtime folder in it, place the zip contents (its Runtime folder and beneath) into the La Femme Clothing folder.

Keep in mind that custom-created library folders will need to be linked to the Poser library as external libraries as described in Adding Libraries.
Loading and Managing Items using the Library Icons

The Library icons appear at the bottom of the Library palette. Certain Library icons are only available for specific categories.

From left to right, these icons are:

• **Single check mark:** Clicking the single check button serves different functions as listed below:
  - **Figures Category:** Changes the selected figure.
  - **Poses Category:** Applies the pose to the figure for which it was originally designed.
  - **Faces:** Applies the selected face expression to the currently selected figure.
  - **Hair:** Adds selected hair to the scene.
  - **Hands:** Applies a hand pose to the currently selected figure. You are prompted to specify right hand or left hand.
  - **Props:** Adds the currently selected prop to the scene.
  - **Lights:** Replaces the existing lights in the scene with the currently selected light set.
  - **Cameras:** Applies the camera settings to the camera.
  - **Materials:** Applies the single material to the currently selected single material in an object; or, applies a Material Collection to all materials in the current object.
  - **Scenes:** Closes the current scene and replaces it with the scene you are adding from the library.

• **Double check mark:** The double check mark button appears for the following categories and serves the purposes listed below:
  - **Figures Category:** Creates a new figure in the scene. Typically used to add additional human characters, clothing, and other poseable figures.
  - **Poses:** Same as single check mark.
  - **Lights:** Adds the lights in the library to those already present in the scene.
  - **Materials:** Adds the selected material or material collection to the currently selected object material. You can use the double-check mark to add partial materials such as compound nodes into an existing material.
  - **Scene:** Keeps the content that is currently in your scene, and adds the additional content from the selected library item.

• **Add a Folder:** Click the Add a Folder (+) button to create a folder beneath the currently selected Library folder.
Placing/Adding Items to the Poser Workspace

In addition to using the library icons as discussed in the previous section, you can also drag an item from the library and drop it into your scene.

You can also select multiple items into the library and add them to your scene at the same time. Click to select the first item, and then press the Shift key (Windows or Mac) to select a contiguous range of thumbnails between the first and last items you selected. You can also CMD-click (Mac) or CTRL-click (Windows) to add additional items to the selection. Then drag or drop the additional items into your scene.

When you drag and drop content from the Library into your scene, an information bar will appear beneath the menu bar at the top. This information bar provides information about which target the dragged item will affect. For example, you can use the information bar to determine which character a pose will be applied to, or which character you will conform clothing to.

An information bar displays information about drag and drop targets in your scene.
Removing an Item from the Poser Workspace

To remove an item from the Poser workspace, first select the item to remove by either selecting it in the Document or using the Current Actor pull-down menu (see Select Figure/Current Actor Menus), then press [DEL].

Accessing Different Content Libraries

Poser contains two Libraries: Runtime (contains the content that shipped with your copy of Poser) and Downloads (a default folder for added third-party content).

Poser content libraries are arranged in Runtime folders, which contain many different types of components that are used in Poser. In addition to content such as figures, props, hair, and poses, Runtime folders can also contain scripts, interface files, plug-ins, and other application-critical data. The collection of different types of elements in a Runtime folder is known as a Library.

You may add as many Libraries as you wish. This feature allows you to store Poser content in different folders and/or different drives, making content management more powerful than ever. Also, should you need to reinstall Poser for any reason, you can do so without affecting your custom Libraries. You can access each of your Libraries using the Library palette.

- Adding Libraries
- Switching Libraries
- Removing Libraries

Adding Libraries

As mentioned earlier, Poser creates Runtime and Download libraries during installation, dependent upon which content you elect to install during installation. There is also a great deal of third-party content available for Poser, and if you have acquired a large collection you may find it necessary to arrange your content into multiple library folders. Then you can use the following process to make your additional folders appear in the Library palette.

Generation of thumbnails will be affected by the number of runtimes you add as external runtimes. This issue is more noticeable on Mac computers, where the number of external runtimes is limited to no more than 996.
Poser will perform top-level indexing when new Runtime libraries are added. A yellow circle appears underneath the Search icon when the library is being indexed. Searches performed during indexing may not include all results until after indexing is complete.

By default, Poser triggers indexing upon first launch. You can optionally configure Poser to refresh indexing any time you launch the library. You’ll find this setting in the Library tab of the General Preferences dialog, as described in Library Preferences.

Library indexing will also be initiated when you refresh library folders. Adding an item to the Library will also initiate indexing in the directory to which the item was added.

Runtime folders have a structure similar to the following:

Runtime
  Geometries
    (vendor or product folder)
    OBJ files for product
  Libraries
  Camera
    (vendor or product folder)
    CM2/CMZ and PNG thumbnails for cameras
  Character
    (vendor or product folder)
    CR2/CRZ and PNG thumbnails for characters
  Face
    (vendor or product folder)
    FC2/FCZ and PNG thumbnails for faces/expressions
  Hair
    (vendor or product folder)
    HR2/HRZ and PNG thumbnails for hair
  Hand
    (vendor or product folder)
    HD2/HDZ and PNG thumbnails for hands
  Light
    (vendor or product folder)
    LT2/LTZ and PNG thumbnails for lights
  Materials
    (vendor or product folder)
    MT5/MZ5 or MC6/MCZ and PNG thumbnails for materials
  Pose
    (vendor or product folder)
    PZ2/P2Z and PNG thumbnails for poses
  Props
Poser products do not always contain all of the above-mentioned folders beneath the Runtime folder. For example, if you are installing a piece of clothing, it might add files in the Geometries, Props, and Textures folders but not in the others.

As an example of creating a new Library on your hard drive, assume the following:

- You have collected dozens or hundreds of items that relate to several different figures. You want to arrange them into different libraries that make the content easier to find.
- You have an external hard drive D: that has lots of room to store content. You decide you want to install all of your content there.
- You create a Content folder to store all this content. Beneath that Content folder, you create other subfolders to store each of the content types you want to organize. The folders can be named for a specific figure (Miki 3, Terai Yuki, etc) or type of character (Monsters, Animals, etc), or even a theme (Anime, Horror, Sci Fi, etc). Arrange them in any way you like. The following example demonstrates this:

Your external runtime structure might look as follows:

D:
    Content
    Aiko
    Animals
    Anime
    La Femme
    L'Homme
    Miki
    Monsters
    Victoria
    Michael

Now you want to install all of the content that relates to one figure (such as the Miki 4 figure). You extract/install all of your Miki 4 clothing, hair, and other related content into the D:\Content\Miki folder. The ZIP file usually includes the Runtime folder and all of the associated geometry, library, and texture files. The final path to the runtime folder is D:\Content\Miki\Runtime as shown below.
To add this example Miki Library to Poser, you would proceed as follows:

1. Open the **Library** palette if it is not open.
2. Click the **Add Library** button (+) to open a standard **Browse for Folder** dialog box.

3. Select the hard drive that stores the Library files you want to add (for our example, you would choose **D:**)

4. Navigate to the folder that stores the Runtime folder and its subfolders. Do not select the Runtime subfolder, select its parent folder. For our example, you would expand the Content folder, then choose **Miki**.

5. Click **OK** to add the new Library.

---

*When adding existing Poser libraries to your Poser Library palette, you must preserve your Runtime folder name and structure (*<drive > :<folder > |<subfolder > |Runtime|<folders >*). Navigate the **Browse** dialog to your desired Runtime folder. The added Library will appear using the name of the folder containing the Runtime folder.*

*Poser allows you to create your own folders to store your own poses, material settings and other creations, or so that you can organize library items to your liking. See **Creating Subfolders**.*
Switching Libraries

To filter content between loaded Library Runtimes, click on the Show Library menu, which is located along the top of the Library tab of the Library palette. Doing so will open the Available Libraries pop-up menu, from which you can display the contents of any single Library, or of all your runtime libraries.

You can add and access external libraries from the Library palette.

Removing Libraries

The Remove Library button appears in the upper right portion of the Library tab. You cannot delete the default libraries that are installed with Poser, but can delete any external libraries that you add yourself.

Deleting libraries only severs the link between the Library folders and the Library palette. It does not remove any of the folders or content from your hard drive. This protects your data from accidental deletion and allows you to reuse Libraries at need (such as from removable drives).

Click the Remove Library icon and choose the library to remove.

To remove a library:

1. Click the Remove Library button (minus sign). This expands to display a list of the runtime folders that have been added to your library. Libraries that are grayed out are those installed with Poser, and cannot be deleted.
Adding Extended Details to Library Content

Extended details files use an XML extension, and are typically saved when you first save your content to the Poser library. The XML file will have the same filename as the library content item that was saved.

Content creators can add a variety of informative descriptions to their content. This content will appear in the Extended Details panel when an item is selected in the library tree or item list. The extended details panel also allows you to edit or add additional details to the XML file directly from Poser. If you do not have the Extended Details Panel displayed in the library, expand the Library Settings widget and check the Extended Details Panel option in the Display tab.

Enable the Extended Details Panel display in the Library Display Options panel.

Click the Edit button to add or edit existing details. You can add any or all of the following pieces of information for any library content item:

- **Tags**: Keywords that can help users find your content in Library searches.

If you want to remove the Library from your hard drive completely, you will need to do this manually by deleting the folder and contents from your hard drive. Exercise extreme caution when deleting library folders from your hard drive, as they will be irretrievably lost.

Click the Edit button to add or edit extended details for the selected content item.
Multiple entries in Extended Details fields must be separated with commas.

- **Format**: By default, adds the file extension to the library item type (CR2, PZ2, FC2, and so on).

- **Type**: The type of item (such as Conforming clothing, Dynamic clothing, Conforming Hair, Dynamic Hair, Audio File, Video File, Background Image, etc.)

- **Title**: By default, adds the name of the library item (without the extension).

- **Creator**: The name or names of the primary content creator.

- **Contributor**: The name or names of others who contributed to the creation of the content.

- **Rights**: List allowable uses or restrictions of use here.

- **Rights Holder**: List name of the person who has copyright to the item. Optional information can include contact information such as web site or email address.

- **Created**: Creation date (added by default when content is first saved to the library)

- **Has Version**: Version number of the content (such as 1.0 for first release, 1.1 for first update, etc).

- **Audience**: If content is applicable to specific audiences (Children, Adults, General, etc)

- **Instructional Method**: If you have any special directions for use of this item (other than render settings which are listed separately below) you can add them here.

- **Subject**: If content pertains to a specific theme (Sci Fi, Fantasy, Historical, etc)

- **Requires**: If there are any special requirements to use this content, such as other content purchases or figures, or other renderers, enter that information here.

- **Characteristics**:

  - **Gender**: Gender of character or clothing.

  - **Conforming**: True if conforming clothing. False if other type of content (human figure or animal, props, dynamic clothing, dynamic hair, etc).

  - **Render Settings**: Enter text for suggested render settings here.

  - **Content Category**: Enter the library category type (Figure, Prop, Hair, etc).

**Metadata Builder**

You can use the **Scripts > Metadata Builder** command to edit extended details for one file, one folder, or one runtime. Settings that you change will be applied to the current item, to all items, or to selected items. This helps you build metadata files for your content very quickly.

Metadata properties are arranged in four tabs:
Searching the Library

The Search tab in the library allows you to perform a keyword search in your local content libraries. You can perform the search in all or selected categories.

To perform a Library search, follow these steps:

1. Switch to the Search tab in the Library.
2. Enter a single keyword (such as Roxie) or a series of keywords (such as La Femme) in the Search field at the top.
3. Enable or disable options to Local, or Store by clicking the associated buttons shown below.
• **Local**: When enabled, content on your local hard drives will be displayed in the search results. When disabled, local files will not be included.

• **Renderosity**: Searches the Renderosity store for items that fit the search terms.

• **PoserSoftware**: Searches content installed with the Poser software for results that fit your search terms.
A working Internet connection is required for the Renderosity store search and preview features to function correctly.
When content is being indexed, a small yellow icon appears in the right side of the search pane.

4. Check or uncheck options as follows:

- To perform a search in specific categories in your local Library, check or uncheck **Figures**, **Pose**, **Expressions**, **Hair**, **Hands**, **Props**, **Light**, **Camera**, **Materials** or **Scene** as needed to find the content you are looking for. When you select specific categories you can exclude them again by unchecking the option, or by clicking the categories you want to exclude at the top of the search results window.

- To search through all categories, uncheck all of the Category boxes.

5. Press **Enter**, or click the Search button at the right of the search field. Poser performs a search for the content that you specified, and search results appear in the Content pane.

6. If you performed a Renderosity search, click a thumbnail in the search results to navigate to the product page on Renderosity.com.

**Favorites Tab**

The Favorites tab allows you to quickly add your favorite content to library folders that you create yourself.

To add an item to the Favorites tab:

1. Highlight the library item that you want to add to favorites.

2. Click the **Add to Favorites** button at the bottom of the **Library** palette. An **Add to Favorites** dialog appears.

3. Select an existing Favorites folder, or choose **<<New Folder >>** to create a new Favorites folder. Enter a name for your new folder and click **OK**. The new folder appears in the Favorites tab and your item appears within it.
Add a selected item to your Favorites folder.

Purchases Tab

The Purchases tab in the library displays a list of content that is included with Poser, or purchased from your Renderosity store account, or content that is installed with Poser.

When you select either the Renderosity or PoserSoftware radio button, you will be prompted to log in to your applicable account. Enter either your email address or user name, and the associated password that you use to log in to your Renderosity or PoserSoftware account.

As content files are downloaded, they will be temporarily stored in your user Downloads folder. After the download completes successfully the zip files will be removed.

Options are as follows:

- **Filter purchases**: Enter text in this field to display files that contain the word(s) in your filter.

- **Install All**: Installs all content, including gifts that you received under your Renderosity account.

If your Renderosity account has a large number of purchases, we recommend that you use the Install button for each item you want to install. Otherwise all purchases in your Renderosity account will be installed.
• **Uninstall All**: Uninstalls all content, including gifts that you received under your Renderosity account.

• **Check for New Purchases**: Click this button if you have purchased new items from Renderosity since you opened Poser. This allows you to see new purchases in the library without restarting Poser.

• **Logout**: (Renderosity content only) Click to log out of your Renderosity account.

### Installing from the Purchases Tab

To install purchases from the Purchases tab, proceed as follows:

1. Open the Library to the Purchases tab.
2. Choose the radio button for the type of content you want to install:
   
   • **Included**: Displays a list of zip files that are included with the Poser installation.
     
     • Click the **Install** button next to each item to install one item at a time. A progress bar will display as the download progresses.
     
     • Click the **Pause** button to pause downloading of a selected item. A message appears in the window when the download is paused.
     
     • Click **Resume** to resume downloading an item that has been paused.
     
     • After installing, you can reinstall the content at any time by clicking **Reinstall**.

   • **Renderosity**: When selected, you will first be prompted to log in to your Renderosity account. After logging in, the products that you have purchased from Renderosity will be displayed in the pane. Click the **Install** button for each item you want to install. The product will be downloaded and installed into the Poser 13 Content > Purchases library.

   
   If you prefer to install your Renderosity purchases to another location, log into your Renderosity account through your Web browser and download the Zip files to a location of your choice. Then follow the instructions mentioned in [Installing Content from a Zip Archive](#).

   
   ![Pausing and Resuming installers.](#)
• **PoserSoftware**: Displays a list of files that you purchased from PoserSoftware.com. You will be prompted to log in to the site before downloading.

3. Click the **Install** button next to the product you want to install.

4. The product zip files will download to your Windows or Mac **Users > username > Downloads** folder, in a parent folder named **Poser Downloads**. There will be subfolders named Included, PoserSoftware, and Renderosity, depending on the type of content you are installing.
After the ZIP files are properly installed, the ZIP files will be removed from the Poser Downloads folders shown above. The installed content can be found in the Poser 13 Content, Purchases, or Included folders in your Poser 13 Content Library.

5. If the ZIP files contain content that does not install into a typical library hierarchy location (such as templates or other content that does not fall into standard library folders), Poser will inform you that the zip files were unable to automatically install the content. The ZIP files will remain in the Poser Downloads folders mentioned in the preceding step. Click the Manually Install button and follow the steps to install the content in the location that you specify.

Manually installing ZIP files that cannot automatically install.
Posing Figures

This chapter explains how to pose figures and the tools you’ll use while doing so. Posing is the process of bending, twisting, and pulling a figure into new and fantastic positions. You can even create movies by changing poses over time.

General Posing Principles

A pose has two aspects: how the body parts move relative to the rest of the body (such as raising or lowering an arm, your shoulder, upper arm, forearm, hand, and fingers are moving relative to the rest of your body) and the figure’s position relative to the Poser workspace (such as walking around a room). Poser’s Editing tools (The Editing Tools) allow you to move body parts, figures, and props by simply clicking and dragging. It doesn’t get any easier!

When posing in Poser, you’re working in all three dimensions. Your only limitations are specific motion limits placed on joints to keep poses realistic. Enabling limits prevents, for example, a figure’s knees from bending backward or the head from twisting 360 degrees. However, you can disable limits and put your figures into any position you can imagine.

Posing and Camera Views

Most Poser figures (Version 3 and later) allow you to pose faces and hands (expressions, gestures, etc.). Poser includes Face and Hand Cameras (see ) that zoom into these areas for close-up work.

 While posing, you can switch cameras to view your work from many different angles and can even select up to four simultaneous camera views in the Document (see The Document Window). It is recommended that you select the Posing camera while working, thus saving the Main and Auxiliary cameras for your final shots, particularly if rendering animations.

The Pose Library

You can add poses you create to the Pose Library, as described in Saving Poses in the Library, or you can apply still or animated poses from the library to your currently selected figure as described in The Poses Category.
Translation

Translation moves multiple body parts by pulling them in a chain. To visualize this, imagine a person lying down with their arms out to their sides. If you were to take hold of the hand and lift it, at first only the affected arm would move. Keep moving higher, you’d lift the shoulders, chest, hips, and eventually the whole person off the ground. Poser’s Editing tools work this way. Drag any part and connected parts follow. Parts move, bend, and twist as you would expect them to.

When you pull one body part, connected parts follow.

Inverse Kinematics (IK)

Poser’s Inverse Kinematics (IK) features help you achieve realistic poses and add natural-looking motion to your animations. IK effects are most apparent when using the Editing tools.

To enable IK for your figure, select Figure > Use Inverse Kinematics and select the chain you wish to enable. You will see the chains you created as well as the standard Poser chains (if you added chains to a standard Poser figure). A check mark appears next to each enabled IK chain. To disable IK, select Figure > Use Inverse Kinematics and select the chain you wish to disable. You can also open the Hierarchy Editor and check and uncheck the boxes next to each IK chain in the list to enable and disable IK.

To demonstrate how IK works, try this:

- Create a scene and load the default character (in this case, Andy is still configured as the default).
- Use the Figure > Inverse Kinematics command to make sure that IK is on (it is on by default).
- Use the Translate/Pull tool or the YTran parameter dial to translate the hip upward on the Y Axis so that the feet move up off the floor.
With IK enabled, the feet move to the position of their IK goals whenever possible.

The purpose of IK is to make it easier to pose or animate the arms and legs of a figure. For example, when IK is on, you can translate the hip, and the legs bend to accommodate the new hip position without changing the positions of the feet. Arms behave similarly: Place a figure’s hands against an imaginary wall and move the hip forward. The arms bend while the hands remain fixed in position. For more information on IK, see Understanding IK.

You can use IK or not in your animations, however it is a global setting. If enabled on a figure’s limbs, it’s on for the duration of your animation, and vice versa. You can turn it on or off while you work, but the final state is what will “stick” in your final animation. Toggling IK on and off can affect your animation; it’s best to pick an option before starting to animate and stay with it to avoid having unexpected changes occur in your animation. Please refer to Inverse Kinematics (IK) for more information about Inverse Kinematics.

Understanding IK

Kinematics is the study of motion velocity, rotation, and position. In terms of structures such as arms and legs, kinematics is used to calculate how actions taken at a structure’s root determine the position and rotation of the other end. For example, hold your arm straight and rotate your shoulder joint. Kinematics calculates the change in position of your arm, hand, and fingers. If you know the angle by which you rotated your shoulder, you can calculate your arm’s new position.
It follows that Inverse Kinematics studies the same problem from the other end: The extremity moves, and IK determines how the objects joined to it must respond in order to support the new placement. If you raise your hand straight out to the side, your hand, arm, and shoulder must move to accommodate your hand’s new position. Or if someone was to grab your hand and push, your arm would bend while your body remains still.

Poser supports IK for the arms and legs. With IK enabled, you can translate the hands and feet and achieve appropriate arm and leg positions automatically. IK creates targets to indicate the end of the chain. When the hands or feet move, the target is set to its new position. Moving any other body part keeps the target in its original position relative to the rest of the body. Once the target is reached, the end of the chain is fixed and the other parts must bend to accommodate the hand or foot position. For example, a foot reaches its target and the knee bends.

To work effectively with IK, you need to keep the following things in mind:

- Enable (turn on) IK when you are working with the Editing tools. You can toggle Inverse kinematics (IK) on and off for the following limbs:
  - Right Foot
  - Left Foot
  - Right Hand
  - Left Hand

*Enabling IK on a pose created with IK disabled may alter your pose.*

- To toggle IK on or off for a limb, select Figure > Use Inverse Kinematics > limb, where limb is one of the four limbs. A checkbox next to a limb indicates that IK is active for that limb, and vice versa.

*You can enable or disable IK for the legs and hands.*

- The Rotate, Translate, and Twist tools may not behave as you might expect for some body parts. For example, you cannot easily rotate or translate a thigh or shin when IK is enabled for that leg because the foot’s position takes precedence. This behavior corresponds to real life: When you stand, your feet and legs support your body, meaning that you cannot arbitrarily move or rotate them. This consideration applies to both the Editing tools and the parameter dials.

- You cannot use IK and the Chain Break tool (see Chain Break) on the same limb.
Limiting Motion

Selecting Figure > Use Limits toggles parameter limits on and off. Please refer to Editing Parameter Dials for information about setting limits for parameter dials. The figures included with your copy of Poser have realistic limits applied to them, meaning that you can’t, for example, bend a knee backward. Limits are disabled when this option is toggled off.

Most recent Poser figures have limits set for each joint, which are based on typical limits that each joint bends, twists, or rotates. When you develop poses for your characters, it is generally good practice to develop your poses when Use Limits is enabled. This helps you to reproduce realistic joint positions, and aids in producing poses that are more realistic.

The Use Limits option keeps body parts within preset range limits.

The Use Limits option keeps body parts from moving beyond natural ranges of motion. The figures that come with Poser have realistic limits that were set when the figures were rigged. Third-party content may or may not have realistic joint limits. If you have questions about a particular piece of content, please contact the content’s creator or the marketplace where you purchased the content. “Natural” is a subjective definition. The limits for Poser figures are a rough guideline that may or may not look right to you. You can customize maximum and minimum limits using the methods described in Editing Parameter Dials.

Select Figure > Use Limits to toggle limits on and off. A check mark next to this option indicates that limits are being enforced, and vice versa.

Posing a Figure

The easiest way to pose a figure is to use the Editing tools as described in The Editing Tools. The part will move based on the part selected, your currently selected Editing tool, your camera angle, and whether or not IK is enabled. You can also use the parameter dials on the
Parameters palette to precisely move parts. Most poses are created using the Editing tools to get the rough position followed by the parameter dials for fine adjustments.

Posing Body Parts

Like their real-world counterparts, Poser figures are made of body parts connected by joints. Posing a figure is as simple as moving body parts to create a new position or pose. Body parts are independent, and each considered an actor in its own right. This concept holds true no matter what the figure looks like (snake, 2-legged, 8-legged, etc.). There are some special posing cases:

- Hands (see Posing Hands)
- Faces (see Posing Faces with Morphs and Posing Faces with Bones)
- Eyes (see Posing Eyes)
- Animals (see Posing Animals)

Selecting Body Parts

Before you begin posing figures, you need to know how to select the body part Actor(s) you wish to move in order to create your still or animated pose. You can select body parts using the Editing tools, the Current Actor pull-down menu, or by clicking the desired part in the Document window. Each of a figure’s body parts is a poseable element.

The selected body part is outlined when selected.

The Select tool in the Editing Tools palette allows you to select a body part without affecting the current pose. See Select.

If you right-click (Windows) or Apple key-click (Mac) within the Document window, a pop-up context menu brings up a menu listing all the body parts positioned under your mouse cursor. You can select your desired body part directly from this list, without having to interrupt your workflow or change
Using the Editing Tools

To select a body part using the Editing tools, click your desired tool then click the body part you wish to pose. The currently selected body part is highlighted in the Document and labeled in the Select Figure and Current Actor menus in the top left corner of the Document.

Click a body part with an editing tool to select it.

Using the Parameters/Properties Palette

You can also select body parts using the selection menu that appears at the top left corner of the Parameters/Properties palette. Click the arrow at the top-left corner of the palette to display the menu. Here you can select any of the following:

- Any body part for the currently selected figure.
- The Body Actor of the currently selected figure.
- Any props connected to the currently selected figure (such as hair, jewelry, articles that are parented to it, and so on).
- Any of the cameras in the scene.
- Any of the lights in the scene.
A selection menu appears at the top of the Parameters/Properties palette.

Using the Current Actor Pull-down Menu

To select a body part Actor using the pull-down menus:

1. Select the desired figure using the Select Figure pull-down menu.
2. Select your desired body part using the Current Actor Item pull-down menu.

This method can be preferable if your scene has several figures and/or detailed body parts (such as poseable fingers and toes).
The Editing Tools

The Editing tools appear as follows on your Poser workspace:

![The Editing tools]

As described in Setting Up Your Workspace, you can locate the Editing tools wherever you like on your Poser screen and can display or hide the title. The tools will auto-wrap to fit the allotted width or height of the palette. Tool tips are displayed at the top of the palette that reveal the name of the tool when you hover your mouse over it.

The Editing tools let you move body parts in many different ways. A tool’s effect can vary depending on whether or not Inverse Kinematics (IK) is enabled. Please refer to Inverse Kinematics (IK) for information about IK. Editing tools can pose an individual body part or a complete figure.

The Color, Grouping, View Magnifier, Morphing, and Direct Manipulation tools serve other purposes than posing and are discussed later in this chapter.

The Editing tools work on an entire figure, or on a body part Actor on a figure.

- To pose a body part, select it and drag.
- To pose the entire figure, use one of the following methods:
When using an Editing tool in the Document window, your cursor changes to a visual representation of the selected tool. This helps you keep track of how you’re moving the selected figure or element.

When using an Editing tool with a figure prop, you don’t need to click and drag with the cursor positioned over the affected item; you can click and drag anywhere in the Document. Also, be aware that your camera view affects how your figure or element appears. Depending on the pose you are creating, you may want to switch to a different camera. For example, if you are moving an arm in front of a figure, a side view will give you a good view of the arm’s position relative to the figure’s front, and so on. You can change Camera views as described in Select Figure/Current Actor Menus, and can even view your Poser scene from multiple cameras at once, as described in Single/Multiple-View Panes.

The Editing Tools are covered in the sections that follow:

**Select**

The Select tool allows you to select a figure or prop in your scene without accidentally translating or rotating the part. Simply click on the desired part to select it as the current figure or prop.

- Click and drag on the desired Editing tool and the entire figure will move according to the tool that has been selected.
- Select your desired Editing tool, then select the Figure Circle surrounding your desired figure and drag. The Figure Circle is highlighted when selected, indicating that you are working on the entire figure at once.

**To move an entire figure, you can:**

- Click and drag an Editing tool.
- Select and drag the Figure Circle.
- Select Body using the Select Actor pull-down menu.
- Select the figure’s hip and move it (with IK disabled).

When using an Editing tool in the Document window, your cursor changes to a visual representation of the selected tool. This helps you keep track of how you’re moving the selected figure or element.

When using an Editing tool with a figure prop, you don’t need to click and drag with the cursor positioned over the affected item; you can click and drag anywhere in the Document. Also, be aware that your camera view affects how your figure or element appears. Depending on the pose you are creating, you may want to switch to a different camera. For example, if you are moving an arm in front of a figure, a side view will give you a good view of the arm’s position relative to the figure’s front, and so on. You can change Camera views as described in Select Figure/Current Actor Menus, and can even view your Poser scene from multiple cameras at once, as described in Single/Multiple-View Panes.

The Editing Tools are covered in the sections that follow:
Rotate

The **Rotate** tool bends a body part at its joint. Rotation works in three dimensions, allowing you to make a lot of progress very quickly. To rotate a body part, select the body part you wish to rotate and drag perpendicular to the part to cause the rotation to rotate up and down (relative to your point of view). Dragging parallel to the part rotates it in and out, again relative to your point of view.

To rotate the entire figure, select it. Dragging the mouse up/down and left/right functions as a trackball and rotates the figure on its own axes based on your camera location. You can also adjust an item’s rotation using the parameter dials, as discussed in *Parameters Palette*.

![Rotate tool](image)

Translate/Pull

The **Translate/Pull** tool moves the selected figure/part/prop along the camera’s view (vertically... X and Y axes) depending how you drag. The translation may occur on the figure’s X, Y, and or Z axes depending on the position of the camera relative to the figure. You can translate body parts or figures, and can also adjust an item’s translation using the parameter dials, as discussed in *Parameters Palette*.

![Translate/Pull tool](image)

Translate In/Out

The **Translate In/Out** tool moves the selected figure/part/prop along the Camera’s Z axis (in and out). This translation may take place along the figure’s X, Y, and/or Z axes. Dragging down pulls the item towards you, and vice versa. Moving an item towards you makes that items seem larger, and vice versa. You can also adjust an item’s translation using the parameter dials, as discussed in *Parameters Palette*. 

![Translate In/Out tool](image)
The **Scale** tool allows you to scale the selected figure/part/prop along the camera's X and Y axes. The item’s affected axes will vary depending on the camera’s position relative to that item. Dragging in towards the element reduces the scale, and dragging away from the element increases the scale. To scale in two dimensions, drag laterally. Dragging vertically scales in the third dimension. The axes affected depend on your currently selected camera position. You can also press and hold Shift while using this tool to scale evenly in all three dimensions. Make a mistake? No problem. Select **Edit > Undo**, or press `[COMMAND]/[CTRL]+[Z]`.

To scale an entire figure, select the desired figure using the **Select Figure** pull-down menu in the **Document** or by clicking its Figure Circle. A figure's size is relevant only in relation to other figures and props within your scene. To pose a single figure, scaling is not necessary: You can simply zoom the camera. If you are working with two or more figures and want to give one the appearance of being in the distance, it’s best to simply move the selected figure to the background using the Translate/Pull tool (see above). You can also adjust an item’s scale using the parameter dials, as discussed in **Parameters Palette**.

**Direct Manipulation**

The **Direct Manipulation** tool allows you to directly adjust an element’s **Translate**, **Scale**, and **Rotation** parameters: You can also use this tool to adjust falloff zones when setting up joint parameters for a poseable figure.
Direct Manipulation tool.

To adjust an element, first select the Direct Manipulation tool, then select your desired element:

Clicking and dragging one of the shaded boxes above the selected element increase or decreases the element’s X, Y, or Z scale. This is the same as adjusting the xScale, yScale, and zScale parameters, respectively.

The Direct Manipulation tool makes posing easier.

You can also click and drag the red, green, and blue axis circles to rotate the selected element along its respective axis. Poser calculates the rotation by using object coordinates for optimum control. Dragging the red circle rotates about the element’s X axis. The green circle rotates about the element’s Y axis, and the blue circle rotates about the element’s Z axis. The cursor changes to indicate which transformation will occur. For example, move the cursor over the circles, the cursor changes to a rotation icon, and so forth. Elements rotate about their origins.

Clicking near the selected element’s origin translates the element as if you were using the Translate/Pull tool. Clicking away from the origin and axes/circles allows you to rotate the element as if you were using the Rotate tool.

Twist

The Twist tool rotates a figure/part/prop along its longest axis (length). You can twist an entire figure by selecting it and dragging. Most of the body’s joints don’t allow much twisting. For example, your forearm can twist almost 180 degrees while your wrist can hardly twist at all. The twist axis of the head, neck, and torso is along the spine. For the forearm, the axis lies along the arm’s length. Twisting an entire figure rotates it about its own axis. If the figure is standing, it...
spins around. If lying down, it rolls over. You can also adjust an item’s twist using the parameter dials, as discussed in Parameters Palette.

Taper

The Taper tool allows you to taper the selected figure/part/prop along the Camera's X and Y axes. The item’s affected axes will vary depending on the Camera’s position relative to that item. This only affects the end of the selected actor that is most distant from the center of the body. Dragging to the right increases the amount of taper, and dragging to the left decreases the taper, “flaring” the selected actor. You can also adjust an item’s taper using the parameter dials, as discussed in Parameters Palette.

The Taper tool only works if there is already an existing Taper parameter in the figure or prop.

Chain Break

The Chain Break tool ends the chain of parts affected by the Translate/Pull tools.

Using chain breaks on different body parts can create interesting effects. For example, to prevent the chest from moving, apply a chain break to it. You can then translate the hand freely
without moving the chest: only the hand, forearm, upper arm, and shoulder will move. You must have IK disabled on the desired limb(s) in order for this to work. Please refer to Inverse Kinematics (IK) for information about Inverse Kinematics.

To add a chain break, select the Chain Break tool and click where you want the chain broken. A Chain Break icon appears wherever you insert a break. You can insert as many breaks in your scene as needed. To remove a chain break, click the desired icon.

![Using the Chain Break tool.](image)

All figures have chain breaks at their hips. You cannot remove these breaks.

**Color**

The Color tool allows you to change a material group’s surface (diffuse) color. It opens the Color picker, which is described in Colors.

![Color tool.](image)

**Grouping**

The Grouping tool opens the Group Editor palette, which is discussed in The Group Editor.
View Magnifier

The View Magnifier tool allows you to zoom in and out to and from your desired areas of the Document without altering the position of your currently selected camera. This can be of great help when working with scenes.

To use the View Magnifier tool, select it:

- Click anywhere in the Document window or current view pane to zoom in on the selected area. Repeated clicking will continue zooming in one step per click.
- To zoom in on a specific region in the Document window, click and drag a rectangle around the area you wish to magnify. Your view will zoom in on the closest point that encompasses your selected region.
- To zoom out, press [COMMAND]/[CTRL] while clicking in the Document window.

Morphing Tool

The Morphing Tool opens the Morph Editor palette. The Morphing Tool has two operational modes: Combine and Create, which are accessed and controlled via the Morph Editor.

- The Combine mode allows you to sculpt any surface on your figure using morph targets.
- The Create mode allows you to manipulate the vertices on your model’s mesh to create new morph targets.

See Modifying Figures & Props for more information about morph targets and the Morph Editor palette.
The Parameters/Properties Palette

Poser offers an easy-to-use Parameters and Properties palette that allows you to access any scene object’s properties and parameters in one convenient location.

For clarity, each tab on this combined palette is referred to as a separate palette, either the Properties palette or the Parameters palette, as appropriate. To switch between the Properties and Parameter palettes, simply click the desired tab at the top of the palette. You can also access an object’s Properties palette by double-clicking the desired object. Once you do this, clicking the Parameters tab opens the same object’s Parameters palette. You can also access both palettes by selecting Window > Parameter Dials.

Although both properties and parameters appear in the same palette, we will treat them as separate entities throughout this manual for clarity.

- The Parameters palette contains all of an object’s parameters transformation settings, (as described in Parameters Palette) and morph targets. Each object type has specialized parameters, which are described where appropriate in this manual. Further, individual objects can have parameters unique to that object. For example, different figures have different morph targets available.

- The Properties palette contains all of an object’s properties. In addition to certain universal properties (which are described in Properties, each object type has specialized properties, which are described where appropriate in this manual.)
Properties

The Properties palette contains the properties available for the currently selected scene element. Properties for lights, cameras, props, etc. are listed in their respective sections. This section describes the properties available to figures and body parts.
The Properties palette allows you to set options for a selected item.

**Figure Properties**

Figures have the following properties:

- **Name**: The Name field displays the figure or actor name. Enter a new name in this field if you desire.

- **Visible**: Checking the Visible checkbox makes the figure visible and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene.

  You can animate visibility by clicking the Animation Toggle (key icon) next to the Visible checkbox. When animation is enabled, the icon appears white. When disabled, it appears gray.

- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the figure visible in raytraced reflections, such as if the figure is in front of a mirror. Clearing this checkbox makes the figure not appear in reflections. This option is used when raytracing.
• **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.

• **Visible in Camera**: When checked, the object is visible in the camera and render. When unchecked, the object does not render. Used in conjunction with Light Emitter, described previously, to create light-casting objects.

• **Bend**: When checked, creates smooth bending between groups in the figure. When unchecked, blending between groups is not performed and creates harder “breaks” between groups.

• **Displacement Bounds**: The Displacement Bounds property determines the figure’s displacement boundary. Please refer to *Using The FireFly Render Engine* for more information about displacement bounds.

• **When conforming**: These options allow you to choose which properties will automatically apply to clothing when it is conformed to a figure:
  
  • **Include Morphs**: When this option is checked, the conforming article will automatically adjust to fit morphs that are set in the character to which it is conformed. Note, however, that the applicable morphs must be included in the conforming article in order for this to occur. In other words, if the character has a “Big Belly” morph that is set, the conforming clothing must also have a “Big Belly” morph in order for automatic morph conforming to work properly.

  • **Include scales**: When this option is checked, the conforming article will automatically adjust to fit any scaling changes that are set in the character to which it is conformed. In other words, if you have scaled the thighs and shins of your character to 90%, the thighs and shins of the conforming clothing will automatically adjust to fit that scaling.

  • **Match end points**: In legacy content, endpoints might not match between conforming clothing and the figure to which the clothing conforms. For example, factors such as incorrect joint origin settings or extremely tight parameter limits can cause clothing to behave unexpectedly. When this option is checked, you can force the matching of endpoints for conforming figures on an as-needed basis.

  • **Follow origins**: If you are conforming a piece of clothing to a character that has animated origins (discussed in *Manually Adjusting Animated Centers and Orientations*) check this option to have the conforming item follow the animated origins. When enabled, Poser will compute the deltas of the current origin to follow the animated origins of the target figure.

  • **Include Transitions**: If body parts in the figure utilize smooth transitions to blend between translated body parts, you can check this option to apply similar translations to clothing when it is conformed.

*The accuracy of auto-scaling when conforming is dependent upon proper configuration of content. If auto-scaling does not appear to be working properly for third party-content, check the documentation furnished with the content, or contact the content developer.*
Body Part Actor Properties

Body part Actors have the following properties:

- **Compute magnets in world space**: Using World Space is better for applying magnets across the seam of a joint. Content created for Poser 10/Pro 2014 and later will automatically assume world space. Older figures (which use local space calculation) will have this option off to maintain backward compatibility.

- **Subdivision Levels**: Allows you to subdivide the selected figure. See Working with Subdivision Surfaces for more information.

- **Remove Backfacing Polygons**: Determines how backfacing polygons are displayed on the selected figure:
  - **Obey Global Setting**: Uses the setting that is configured in the Render Settings dialog.
  - **Force Show Backfacing Polys**: Backfacing Polys will always be shown in the currently selected figure.
  - **Force Hide Backfacing Polys**: Backfacing Polys will always be hidden in the currently selected figure.

- **Enable Legacy Welding**: Allows Poser to weld objects together on non-open edges. For use only with non-unimesh figures.

- **Crease Angle**: Specifies a crease angle setting for the entire figure. See Smoothing Geometry for more information about using the Crease Angle setting to apply smooth shading.
Body actor properties.

- **Internal Name**: The Internal Name field displays the body part’s internal (hidden) name, which Poser uses to track that part. You cannot edit a body part’s internal name within Poser.

- **Name**: The Name field displays the body part’s name. Enter a new name in this field if you desire.

- **Visible**: Checking the Visible checkbox makes the body part visible and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See **Figure Properties** for information on animating the Visible property.

- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the body part visible in raytraced reflections, such as if the figure is in front of a mirror. Clearing this checkbox makes the figure not appear in reflections. This option is used when raytracing.

- **Bend**: Checking the Bend checkbox enables bending for the selected body part and vice versa. Bends are discussed in **Bend Body Parts**. Remember that selecting **Display > Bend Body Parts** bends all body parts and this property only affects the currently selected body part.

- **Visible in Camera**: When checked, the object is visible in the camera and render. When unchecked, the object does not render. Used in conjunction with Light Emitter, described previously, to create light-casting objects.
• **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.

• **Casts Shadows**: Checking the Casts Shadows checkbox forces the selected body part to cast a shadow, which will be visible in your scene. Clearing this box means the selected body part casts no shadow.

• **Collision Detection**: Checking the Collision Detection checkbox enables collision detection for the currently selected body part.

• **Apply Collision Setting to Children**: Clicking the Apply Collision Setting to Children button applies the currently selected body part’s collision detection setting to that part’s children parts (if any).

• **Load Morph Target**: Clicking the Load Morph Target button displays the Load Morph Target dialog, allowing you to load a custom morph target for the selected body part (which is then editable using the Morphing Tool as described in [Creating Morphs with the Morphing Tool](#)). Please refer to [Modifying Figures & Props](#) for more information about loading morph targets.

• **Set Parent**: Click the Set Parent button to assign a parent to the currently selected prop. In the case of a figure, this button is only enabled for the active end point actor of an IK chain. If the chain is turned on, it allows you to set a parent for that endpoint actor (such as a foot), to a moving object, or to another prop or constraint.

• **Displacement Bounds**: The Displacement Bounds property determines the body part’s displacement boundary. Please refer to [Using The FireFly Render Engine](#) for more information about displacement bounds.

• **Shading Rate**: The Shading Rate allows you to specify the desired shading rate for the currently selected body part. Please refer to [Using The FireFly Render Engine](#) for more information about shading rates.

• **Smooth Polygons**: Checking the Smooth Polygons checkbox causes Poser to smooth the body part’s polygons at render time to eliminate or reduce a “faceted” appearance caused by flat polygons. This option can cause sharp corners to appear round. If the affected body part has sharp edges that you wish to preserve while applying polygon smoothing to other angles, you should specify those sharp edges using smoothing groups or the crease angle threshold, as polygon smoothing will not override these settings. See [Smoothing Geometry](#) for more information on specifying hard versus smooth edges.

• **Crease Angle**: The Crease Angle setting establishes a threshold up to which creases between adjoining polygons will be smoothed. Polygons with crease angles over this threshold will not be smoothed, and will be rendered as hard edges. See [Smoothing Geometry](#) for more information about using the Crease Angle setting to apply smooth shading.

• **Display Origin**: Checking the Display Origin checkbox displays the prop’s origin. Please refer to [The Prop Origin](#) for more information about prop origins.

• **Subdivide separately from figure**: Allows you to subdivide the selected actor. See [Working with Subdivision Surfaces](#) for more information.

• **Remove Backfacing Polygons**: Determines how backfacing polygons are displayed on the selected body part:
The Parameters palette contains all of the parameters for the currently selected scene element:

- **Obey Global Setting**: Uses the setting that is configured in the **Render Settings** dialog.
- **Obey Figure Setting**: With a body part actor selected, click the Figure Settings button to switch to the BODY actor, and set the option for the entire figure.
- **Force Show Backfacing Polys**: Backfacing Polys will always be shown in the currently selected actor.
- **Force Hide Backfacing Polys**: Backfacing Polys will always be hidden in the currently selected actor.
- **Figure Settings**: Click the Figure Settings button to display properties for the Body actor in a posable figure.

Parameters Palette

The **Parameters** palette contains all of the parameters for the currently selected scene element:

The following topics discuss the **Parameters** palette in detail:

1. **Current Actor Menu**: The **Current Actor** pull-down menu (1) functions the same as the **Current Actor** pull-down at the bottom left of the **Document**. Please refer to **Select Figure/Current Actor Menus** for more information about the **Current Actor** menu.
2. **Parameter Dial Groups**: See **Parameter Dial Groups**.
3. **Parameter Limit Indicators**: See **Limit Indicators** below.
4. **Parameter Dials**: See **Parameter Dials**
5. **Dependent Parameter**, showing Natural and Driven parameter values: When a parameter is configured as a dependent parameter (5), two values will be displayed to the
right of the parameter dial. These dials are referred to as the natural and keyed dependencies, and are explained in detail in Using Dependent Parameters.

6. **Master Parameter Indicator**: See Master Parameter Indicator.

7. **Parameter Dial Menu**. Click the arrow to display a list of options and settings for the parameter dial. See Editing Parameter Dials.

8. **Parameters Palette Options Menu**. Click the arrow to display a list of options and settings for creating new parameters and groups. See Parameters Palette Options Menu.

9. **Back** and **Next** buttons allow you to step through the history of body parts that you have already selected, in the order that you selected them (much like the browser history in a web browser). If you right-click the buttons you will get a full history of the body parts that you have visited, in the order in which they were visited.

### Limit Indicators

If a green dot or yellow arrow appears to the left of a parameter dial name, it means that the dial is set to something other than its default value.

- A green dot to the left of a parameter indicates that the dial is set to a non-zero value between the upper and lower dial limits.
- A yellow arrow pointing to the right indicates that the dial is set to its maximum limit.
- A yellow arrow pointing to the left indicates that the dial is set to its minimum limit.
- A red square to the left of a parameter dial indicates that the setting exceeds the limits of the parameter dial.

> **You can easily reset a parameter dial by clicking the green dot or yellow arrow. The parameter dial will reset to its default value (usually zero).**

> **If a dial exceeds the limits, as indicated by the red square, click the red square to reset the parameter to its limit.**
Parameter Dial Groups

Poser offers parameter dial grouping (2), which organizes parameters into easy to navigate categories.
Parameter dial groups have the following functionality:

- Clicking the + sign next to a collapsed group/subgroup expands that group/subgroup.
- Clicking the – sign next to an expanded group/subgroup collapses that group/subgroup.
- Double-clicking a group name allows you to rename that group.
- You can drag and drop groups to change their hierarchical relationship to each other. For example, a group could become a subgroup under another group, and vice versa.
- You can drag and drop parameter dials to different locations within the same group or across groups and subgroups to organize them as you see fit. To move two or more parameter dials:
  - Click the first dial you want to move.
  - Shift+Click to select each subsequent dial.
  - Then Shift+Drag the selected morph dials to the group you want them to appear in.

Parameter dial groups and subgroups are saved in your Poser scene files.
Parameter Dials

The parameter dials (4) in the Parameters palette let you pose a figure and adjust other attributes for figures, props, lights, camera, etc. using precise numerical increments. Each body part and most other elements in the scene have their own set of parameter dials. When an entire figure is selected, the displayed parameters affect the entire figure. To use a parameter dial, you can either click and drag it to the right to increase the selected value or left to decrease it. You can also click the displayed numeric value and manually enter your desired value using the text box that appears.

To restore a parameter dial’s default (or last memorized) setting, press and hold [OPT]/[ALT] while clicking the desired parameter dial. To change a parameter dial’s default value, set the dial to your desired value and either select Edit > Memorize > Object, or use the Parameter Palette menu as described in Parameters Palette Options Menu.

Each parameter dial has its own Parameter Dial menu (5), which is accessible by clicking the arrow to the right of your desired parameter dial. The Parameter Dial menu has the following options:

- **Reset**: Selecting Reset resets the parameter dial to its default or last-memorized value.
- **Settings**: Selecting Settings opens the Edit Parameter Dial dialog, described in the following topic.
- **Graph**: Selecting Graph opens the Graph palette for the selected element. Please refer to Using Graphs for more information about the Graph palette.
- **Recalculate Dynamics**: If you have a dynamic object selected (strand-based hair or dynamic cloth), selecting the Recalculate Dynamics option recalculates the dynamics for that object. Please refer to Step Four: Setting Hair Dynamics and to Step 4: Cloth.
Dynamics Controls for information about strand-based hair and cloth dynamics, respectively.

- **Edit Dependencies**: Opens the Dependent Parameters editor shown in the following figure.

- **Master Parameters**: Click to display a list of master parameters that utilize the current morph.

- **Master Synched**: In previous versions of Poser you had to switch to the Body actor to dial in a full body morph. You can now dial a full body morph from any body part. For example, you can select a figure's left shoulder and dial the Voluptuous morph, and the value you dial in to the shoulder will also affect all other body parts that are affected by the Voluptuous morph. In cases when you need to dial full body morphs in for a single actor, uncheck Master Synched. The dial on that body part will now behave separately from the others.

Uncheck Master Synched to control a body part morph separately from its full body morph.

- **Delete Morph**: Deletes the morph target. You will be asked to confirm the deletion because it is a permanent deletion (you cannot undo this operation).

- **Split Morph**: When enabled, selecting Split Morph splits the currently selected morph into left and right sides, allowing you to apply the selected morph target asymmetrically. You can use this, for example, to introduce irregularities into a figure's head, enhancing realism because no person's head is perfectly symmetrical. Or, you can use it to create separate right and left eye blinks from a morph that closes both eyes at the same time. After choosing Split morph, enter the names for the left and right morphs in the fields provided (example: lEyeBlink and rEyeBlink) and choose OK to create the new morphs. The original Blink morph will also remain. Minimum and maximum limit settings will be carried over from the original morph to the right and left split versions.

- **Match centers to morph**: Automatically adapts joint centers and orientations to figures that are heavily morphed. For a complete description, see Morph Dependent Joint Centers.
Master Parameter Indicator

The Master Parameter indicator (6) appears when the designated parameter dial is used to drive settings of other parameter dials. Click the Parameter Dial menu arrow to open the Dependent Parameter editing tool and the list of parameters controlled by that dial. For more information about master parameters, see Using Dependent Parameters.

Parameters Palette Options Menu

The Parameters palette options menu (8) contains the following options:

- **New Custom Parameters Palette**: Creates a new empty custom dial palette which allows you to drag commonly used parameter dials into it. See Creating Custom Parameter Palettes.

- **Create New Master Parameter**: Creates a new parameter dial that can be set up to drive one or more dependent parameter dials. For further information on dependent parameters, see Using Dependent Parameters.
You can edit parameter dials by double-clicking your selected parameter dial to open an Edit Parameter Dial dialog, which allows you to set the following limits:
Each parameter dial has options that you can edit.

- **Internal Name**: This line displays the internal name that is referenced in the library file. This name is not editable.

- **Name**: The Name field is the name of the dial as it appears in the Parameters Palette. You can rename the parameter by entering a new name in the Name field.

- **Value**: The Value number sets the current parameter dial value.

- **Min/Max Limit**: The Min Limit and Max Limit values define the minimum and maximum limits for the parameter, respectively. The numbers can stand for different types of values depending on the parameter you are editing. If it is a joint parameter, the value will be expressed in degrees above or below 0 (neutral). If you are adjusting a scale parameter, the number will be a percentage with 100 being normal size.

- **Sensitivity**: The Sensitivity value modifies the parameter dial’s sensitivity to clicking and dragging. A lower number decreases the sensitivity and vice versa.

- **Force Limits**: Check this option to keep the selected dial within the minimum and maximum limit settings.

- **Hidden**: Check this option to hide the selected dial in the Parameters Palette. Generally, dials are hidden when you do not want the user to inadvertently make adjustments to it. Uncheck the option to display a dial if it is hidden.

- **Animated**: Check this option if you want the selected dial to be animated, such as when you are using animated joint centers to adjust centers when a morph is applied.

- **Graph**: Clicking the Graph button opens the Graph palette for the selected element. Please refer to [Using Graphs](#) for more information about the Graph palette.

Click **OK** when you have finished making changes.

**Universal/Figure Parameters**

This topic discusses both universal parameter dials and those used for figures. Parameters for cameras, lights, and other elements are discussed in their respective sections.
Scale Parameters

Scale parameters are found in the Transform group of the Parameters palette. Their functions are as follows:

1. **Taper**: The Taper parameter dial tapers the selected body part/prop. This function is the same as using the Taper tool, described in Taper.

2. **Scale**: The Scale parameter dial enlarges or shrinks the selected body part/prop in all three axes equally. This is the same as using the Scale tool, described in Scale. Normal scale is 100%.

3. **XYZScale**: The xScale, yScale, and zScale parameter dials enlarge or shrink the selected body part/prop along the selected axis only. This allows you to squeeze or stretch items. This is the same as using the Scale tool. Normal scale is 100%.

Posing Parameters

Posing parameters appear in the Transform group of the Parameters palette, and appear in yellow text. The following parameters are available for posing: Note that the options you see for each joint vary, depending on the rotation order of the joint: Each joint will have three options, one each for X, Y, and Z rotation.

1. **Twist**: The Twist parameter dial rotates a body part along its own axis. For example, using twist on the head and neck turns the head. This is the same as using the Twist tool, described in Twist.

2. **Bend**: The Bend parameter dial rotates a body part on its major axis. Most body parts bend forward and back, except for the shoulder and hands, which bend up and down.

3. **Side-to-Side**: The Side-to-Side parameter dial rotates a body part perpendicular to its major axis. The thigh has lots of side-to-side motion, while the knee has very little.

4. **Turn**: The Turn parameter dial only appears for the feet in some characters, instead of the Twist parameter. This parameter turns the feet inward or outward.

5. **Front-Back**: The Front-Back parameter dial is used with shoulders and collars to rotate them forward or back, perpendicular to their major axis.
Body Parameter Dials

The following parameter dials are available for entire figures. Remember to select the correct figure when working with multiple figures in a scene:

- **Scale**: The Scale parameter dial enlarges or shrinks the selected body part/prop in all three axes equally. This is the same as using the Scale tool. Normal scale is 100%.

- **XYZScale**: The xScale, yScale, and zScale parameter dials enlarge or shrink the selected body part/prop along the selected axis only. This allows you to squeeze or stretch items. Normal scale is 100%.

- **XYZRotate**: The xRotate, yRotate, and zRotate parameter dials rotate a figure around the X, Y, or Z axis as appropriate.

- **XYZTran**: The xTran, yTran, and zTran parameter dials move a figure along the indicated axis.

  *The XYZTran and other positioning dials reflect the currently selected unit of measure, which is available in the General Preferences dialog. For example, if a dial is set to 12 inches and you change units to feet, the dial will now read 1 foot.*

Creating Custom Parameter Palettes

Choose **Window > Custom Dial Palette > New** to create a new custom parameter palette. A blank palette opens, named Custom Dial Palette x, where x is the next highest number than the number of palettes that you already have in your scene.
After your Custom Palette window is open, you can drag any dial from the main Parameters Palette into your custom palette. The dials that you drag in can be any combination of dials from any item in your scene.

This allows you to set up parameter dials that you frequently use together for complex poses and animations. For example, you can place all of the finger joints on one hand in a custom palette, and it will save you from having to switch between all those joints individually.

Custom palettes can include dials from the same figure, from different figures, from cameras, lights, and other elements of your scene.
Custom palettes can be saved with figures, props, hair, and smart props. When you save the content to the library, there will be an option to include the custom palette with the library content. Custom palettes will also be saved with the scene.

![Include Custom Dial Palettes](image)

*Check the Include Custom Dial Palettes option to save the custom palette with the library content.*

## Posing Faces

- [Posing Faces with Morphs](#)
- [Face Parameters](#)
- [Faces & Phonemes](#)
- [Posing Eyes](#)
- [Posing Faces with Bones](#)
- [Saving Face Poses Made with Bones](#)

### Posing Faces with Morphs

Poser’s human figures and many third-party figures have fully articulated faces, meaning you can position facial muscles such as mouth, eyebrows, cheeks, and eyes to create different facial expressions using the Parameter and/or the Morphing Tool (described in Creating Morphs with the Morphing Tool).
Faces can be enhanced with Expression morphs, which vary from figure to figure.

Different Poser and third-party figures will have different body morphs. Bondware, Inc. cannot provide support for third-party figures. Please contact the vendor where you obtained your third-party content for technical support.

Some older Poser figures do not have poseable faces.

When you select a head, a series of face-specific parameter dials appears in the Parameters palette, each dial controlling a different aspect of the face. When using face parameter dials, think of it as manipulating facial muscles to achieve the final results.

The Face camera uses the selected figure’s face as its center of rotation, allowing you to preview your face poses up close.

**Face Parameters**

Face parameters normally operate in the range of 0 to 1, with 0 being fully off and 1 being fully on. Negative values (<0) produce inverted poses, and poses greater than +/- 1 give exaggerated poses. For example, a negative Frown parameter setting produces a slight smile. Face parameters are morph targets that can be used in concert to create expressions.

Please refer to [Modifying Figures & Props](#) for information on morph targets and how they work inside Poser.
Poser Reference Manual

Faces & Phonemes

Poser figures contain an array of facial morphs and parameters that allow you to create an endless variety of faces and expressions. The list of face parameters varies by figure, and the all parameters are self-explanatory. To view the available face parameters, select the desired figure’s head and open the Parameters palette.

Alyson and Ryan figures include two levels of facial Ethnicity morphs. You will find face shaping morphs in the Parameters palette.

Faces & Phonemes

A phoneme is a linguistic term for the positions of the tongue, lips, and teeth as they make sounds. Producing certain sounds requires the mouth and tongue to be in certain positions. Stringing phonemes together is what produces speech.

Poser allows you to create the appearance of phonemes (called visemes when observed) to accurately simulate speech, a useful feature when adding sound to your scenes (such as a speech). You simulate speech by using different phonemes and keyframes to sync your figure’s mouth movements to an imported sound (see Sound). Poser’s Talk Designer can automatically generate a lipsync animation for you based upon settings that you configure in the Talk Designer palette. For more information about the Talk Designer, see Using the Talk Designer.

Phoneme morphs work with the Talk Designer.

Posing Eyes

To pose eyes, select them using either the Editing tools or the Current Actor pop-up menu and position them by clicking and dragging, or by using the parameter dials.
Many Poser figures also have additional morph dials for the eyes, which can vary the shape of the iris and pupil, or which move the eyes up, down, right, or left.

Eye morphs often size or position the Eyeball, Iris, Cornea, and Pupil.

La Femme and L’Homme also have Eye Controls in the Head actor. We suggest using these dials to pose the eyes, instead of selecting each eye and posing them individually. When using these dials, we recommend that you start with both eyes in their default (zeroed) position.

The Eye Control dials allow you to pose both eyes at the same time. The dials in the Eyes + Lids group will also pose the eyelids realistically as you pose the eyes up, down, or side to side. The dials in the Eyelids group will pose the lids by themselves, and the dials in the Eyes group will pose the eyes by themselves.
Posing Faces with Bones

The Poser 13 Male and Female (L’Homme and La Femme) utilize several bones in the face that allow you to create expressions and change facial features. You control the bones through the use of several control props which can be created and assigned in Poser (see Using Control Props). Bones and associated control props allow you to pose the following areas in the La Femme and L’Homme faces (here listed from the top of the head to the bottom):

The control props shown in the following figure and table are visible by default. You can hide them by selecting La Femme or L’Homme’s BODY actor, and expanding the Controls parameter group. Then, set the Hide <--> Control Handles --> Show parameter dial to zero to hide them, or to 1 to display them.

Facial chips for Paul and Pauline are similar to those for La Femme and L’Homme except they have no earlobe chips. The face chips are hidden in these two figures until you hover over the area that the bone controls.

<table>
<thead>
<tr>
<th>Ref No</th>
<th>Controls</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Forehead Center</td>
</tr>
<tr>
<td>2</td>
<td>Brow Center</td>
</tr>
<tr>
<td>3, 4</td>
<td>Right and Left Outer Brow</td>
</tr>
<tr>
<td>5, 6</td>
<td>Right and Left Inner Brow</td>
</tr>
<tr>
<td>7, 8</td>
<td>Right and Left Upper Eyelid</td>
</tr>
<tr>
<td>9, 10</td>
<td>Right and Left Lower Eyelid</td>
</tr>
</tbody>
</table>

Locations of facial expression control props.
Expressions made with face chips can be very expressive!

To undo your most recent change, press Ctrl/Cmd+Z. Use multiple undos to repeat as necessary to undo more than one change.

To restore a facial control prop to its default orientation, click to select the facial control prop and press Ctrl/Cmd+E. This will reset the X, Y, and Z rotate dials (Twist, Side-Side, Up-Down, etc) to zero.

Asymmetrical expressions are usually more realistic than symmetrical ones. However, if you want to use symmetry in your facial expressions, make changes to one side of the face first, and then use the Figure > Pose Symmetry > Custom commands to apply the settings to the opposite side of the face. Then add some asymmetry where needed by adjusting individual control props.

You can also use the Scale and Translate tools or parameter dials to affect the areas of the face. For example, you can scale the eyes larger or smaller, and move them farther apart or closer together, or scale the nostrils and the nose tip to create a bigger nose. Translate the nose tip to create a pert nose.
Saving Face Poses Made with Bones

The thing to remember about creating expressions with the facial control chips is that they are not morphs. They basically work the same as any other bone in the figure.

When you save face poses made with bones, select or create a folder in the Expressions library. Then click the Plus sign (Save to Library) at the bottom of the Library window.

The New Set dialog appears. Enter a name for your expression in the Set Name field. Then click the Select Subset button to display the Select Objects dialog. By default, all morph parameters and control chips in the Head will be selected.

If you want to create a partial face pose, or if you want to exclude any character-specific morphs from your facial expression, uncheck the items that you do not want to include in the expression. There are Select All or Select None buttons in the window that will check or uncheck everything in the list.

After you make your selections, choose OK to return to the New Set dialog, and then OK again to save the expression to your library.

When the Save Frames dialog appears, choose Single Frame to save only the current frame in your expression. To save an animated face pose, check Multi-Frame Animation and enter the frame numbers of the animated pose that you want to save. Then click OK to save the pose to the library. A thumbnail for the pose will automatically be generated based on the preview in the document window.
Posing Hands

Many Poser figures have fully articulated hands. When you move a finger, the appropriate knuckle(s) bend. You can pose hands for both these figures and older Poser figures without articulated hand joints by applying hand poses from the Library palette.

The Left Hand and Right Hand cameras use the hand as their centers of rotation, making it easier to create precise hand poses.

Use the Editing tools to pose hands as you would any other body part. Please refer to The Editing Tools for information on using the Editing tools. You can also apply preset hand poses to any Poser figure using the Hands category in the Library palette, just as you would any other pose.

When you select the main portion of a hand (labeled Left Hand and Right Hand in the Item Select menu) on some Poser figures, you may also see a special set of hand parameter dials in the Parameters palette. These dials are as follows:

- **Grasp**: The Grasp parameter dial controls how tightly the hand/fist is clenched.
- **Thumb**: The Thumb parameter dial moves the thumb. Higher values move the thumb in towards the hand, and vice versa.
- **Spread**: The Spread parameter dial controls the amount of hand spread. Higher values spread the hand out, and vice versa.

In addition, many Poser figures include several additional controls that provide extremely fine control over hand poses. These additional options, coupled with the extra joints in their hands, provide fine enough control to pose your hands holding chopsticks or other eating utensils: These additional dials are usually found in the Hand Controls section in the Parameters palette when you choose the hand actor for the figure.

- **Using the Hand Model**
- **Using Preset Hands**

Using the Hand Model

The Figures > Included > Additional Figures > Hands subfolder includes disembodied hands that include extra joints that allow you to create hand poses that bend in a more realistic manner. Use the Left Hand or Right Hand in this subfolder to create hand poses that are compatible with Alyson and Ryan. Then save the poses to the Hand library for future use.

*These hands do not include the metatarsal bones that are used in La Femme and L'Homme, so poses created with these hands may not appear exactly the same when applied to those figures.*
Using Preset Hands

When you’re done posing a hand, you can save it to the Hands category in the Library. Hand poses are a subset of a figure pose, meaning that figure poses include the hands but hands don’t include figures.

Use Hand poses to pose a character’s hand and fingers.

The Hands library folder includes various subcategories. When selecting preset hand poses for your figure(s), pay attention to the subcategory from which you choose them, as you can only apply specific hands to the corresponding figures. For example, you can only apply Poser 2 Fig. Hands to Poser 2 figures.

To use a preset hand pose:

1. Click a figure to select it.
2. Open the Library palette, then open the Hands category and your desired subcategory.
3. Double-click the pose you want to use. A dialog appears asking if you wish to apply the preset to the left or right hand. Make your selection and click OK.

Pose Dots

You can save up to nine pose configurations using the Memory dots (described in Memory Dots). Each Memory dot retains all of your selected figure’s pose. This feature is specific to your current scene, meaning that Pose dots cannot be transferred to different scenes.

To save pose settings and have them accessible in any Poser scene, you need to add pose sets to the Library palette.
Posing Animals

You can pose animals using the same techniques used to pose humans. Animals have their own set of IK settings, bend zones, and limits. On the Horse model, for example, moving the hip down toward the ground does not make the animal sit, unlike a human figure. Editing tools, parameter dials, menus, etc. all work the same with animals as they do with humans. Technically speaking, animals and human figures are identical, and Poser makes no distinction between them.

Animals do not work with the Walk Designer, which is primarily designed for two-legged (bipedal) figures. However, animals can work with the Talk Designer if the animal includes phoneme morphs that support it.

Animal figures are poseable as well, but do not work with the Walk Designer.

The stock animal figures shipping with Poser use the same limb names as humans, that is, front legs and paws are labeled Shoulder, Arm, Hand, etc. This means that animal figures will not work in the Walk Designer, which was created for use with two-legged figures. To animate an animal walking or running, you need to keyframe its strides manually.

Posing Animal Heads

Several animal models have fully articulated heads. For example, you can pose the dog’s mouth and ears. Use the parameter dials just as you would for a human figure. The available parameter dials for a given animal’s head will vary depending on the animal.
Saving Poses in the Library

All parameters are saved along with body part positions when you save a pose to the Library palette. To save a pose to the Library palette:

1. Open the Library palette.
2. Select the Pose category and your desired subcategory.
3. Click the + button at the bottom of the Library palette. The New Set dialog appears.
4. Enter a name for the pose in the Set Name field.
5. Check the Include Graphs option if your pose includes graphs.
6. If you only want to include specific body parts in the pose, check the Select Subset button at the bottom of the New Set dialog. Check only the parts you want to include in the pose. Then choose OK to return to the New Set dialog.
7. Choose OK to continue. You are asked if you want to include morph channels, body transformations, or scales in the saved pose. Scales is selected by default. After you choose your options, click OK.
8. The Save Frames dialog has two options:
   - Single Frame: Saves your currently selected frame as a still pose.
   - Multi-Frame Animation: Check this option to save an animated pose, and enter the start frame and end frame of the animation to save in your pose.
9. Click OK to save the pose to your library.

Other Posing and Figure Aids

Lock Object

Selecting Object > Lock Object locks the currently selected element (body part, prop, etc.). To lock your desired actor, select it, then select Object > Lock Object. The currently selected actor will be locked, meaning that it will not move relative to its parent. For example, if the elbow is bent 45 degrees relative to the upper arm, it will hold that position. Locking actors is a great way to protect your work once you’ve perfected a portion of your figure.

To unlock a locked actor, select it and Object > Lock Object. A checkbox appears next to this menu item when the selected actor is locked, and reselecting this option clears the checkbox and unlocks the actor.
Point At

You can aim body parts, cameras, props, lights, etc. at other scene elements using the Point At command. This works in numerous situations, such as having a figure’s eyes track a moving object, keeping a camera focused on the action, etc. This is different than parenting in that no hierarchical relationship is created. One object simply points at another. By contrast, parented objects retain their exact position and orientation relative to their parent actors.

To point an actor at another actor:

1. Select the element you want to aim using the Select Item pop-up menu.
2. Select Object > Point At to open a dialog box listing the actors in the scene.
3. Select the object to aim at and click OK. The selected element points at the object and a Point At parameter dial appears in that element’s Parameters palette. Selecting 1 points the element directly at its selected target, and 0 points the element away from the target.

When selecting only a single item from the Object Parent hierarchy window, you can simply double-click on that item to make your selection and close the window.

To disable pointing for an element:

1. Select the element.
2. Select Object > Point At.
3. Select None in the dialog that appears and click OK.
Auto Balance

The **Auto Balance** feature is a valuable tool for helping create realistic poses. When enabled, Poser calculates a figure’s mathematical “weight” and maintains it. In the following example, there is more weight in the figure’s hip or center portion than in the torso. As you pose a figure, Auto Balance adjusts body parts to maintain the original weight distribution, resulting in more natural-looking poses without having to use several position adjustments.

To further affect the weight distribution and compensation calculations, you can reposition the **Center of Mass Control Object** (the outlined ball) at the base of the figure. This control object is adjustable along the X and Z axes in the ground plane. Moving the Center of Mass Control Object also adjusts the Center of Mass Indicator, which appears as a shaded sphere in the XZ (ground) plane under the figure. This Indicator shows the position above which the current center of mass is located, as calculated from the body part weights and the position of the Control Object.

![Using Auto Balancing.](image)

**When using Auto Balance, use small subtle motions to achieve the best results. Large motions may create drastic results. If this occurs, use Edit > Restore to restore the figure as described Restore. You may also want to select Figure > Use Limits while working with the Auto Balance feature, to help maintain realistic body positioning.**

Selecting **Figure > Auto Balance** toggles Auto Balance on and off for the selected figure. When enabled, the Center of Mass controls will be visible at the figure’s base. A check mark appears next to this option in the menu when it’s enabled. Reselecting this option clears the check mark and disables Auto Balance for the selected figure.
**Lock Figure**

Selecting **Figure > Lock Figure** locks the figure in its current position. You cannot pose or move a locked figure. This is a great way of protecting your work in complex scenes where you have finished posing a figure and don’t want it to move accidentally. A check mark appears next to this option when the currently selected figure is locked. Reselecting this option removes the check mark and unlocks the figure.

**Lock Hand Parts**

Selecting **Figure > Lock Hand Parts** locks the selected hand in position, protecting it against accidental position changes while you pose the rest of your figure. To use this option:

1. Select the hand to lock.
2. Select **Figure > Lock Hand Parts**. The hand is now locked. This command is not available for all Poser figures.

Please refer to [Posing Hands](#) for information on posing hands.

**Drop to Floor**

You can place a figure in any position, such as in the middle of a flying leap. You can leave your figure in the air, or you can lower it to the ground depending on your needs. Selecting **Figure > Drop to Floor** brings the lowest part of the selected figure or prop into contact with the workspace floor.

> To display the floor, refer to [Ground Plane](#).

**Pose Symmetry**

The Pose Symmetry commands in Poser allow you to copy pose characteristics from one side of the body to another, which can save you time when creating scenes in the Pose room. Pose an arm and/or leg, and use this command to instantly apply the same position to the other side. You can also swap entire poses from side to side and straighten the currently selected figure’s torso.
Selecting **Figure > Pose Symmetry** opens the Symmetry menu, which contains the following options for your currently selected figure:

- **Left to Right**: Selecting Left to Right applies the position of the bones on the left side of the figure to the right side.

- **Right to Left**: Selecting Right to Left applies the position of the bones on the right side of the figure to the left side.

- **Swap Right and Left**: Selecting Swap Right and Left swaps the positions of the bones on the right and left sides of the figure.

- **Left Arm to Right Arm**: Selecting Left Arm to Right Arm positions the right arm bones in the same position as the left arm.

- **Right Arm to Left Arm**: Selecting Right Arm to Left Arm positions the left arm bones in the same position as the right arm.

- **Swap Right and Left Arms**: Selecting Swap Right and Left Arms swaps the positions of the bones on the right and left arms of the figure.

- **Left Leg to Right Leg**: Selecting Left Leg to Right Leg positions the right leg bones in the same position as the left leg.

- **Right Leg to Left Leg**: Selecting Right Leg to Left Leg positions the left leg bones in the same position as the right leg.

- **Swap Right and Left Legs**: Selecting Swap Right and Left Legs swaps the positions of the bones on the right and left legs of the figure.

- **Straighten Torso**: Selecting Straighten Torso straightens the torso area (Hip, Abdomen, Chest).

- **Custom**: Opens the Apply Custom Figure Symmetry dialog, which allows you to set up a custom symmetry configuration. See [Applying Custom Symmetry](#).

---

Symmetry also copies element settings (morph targets, deformers, parameters, etc.) from one side to the other. For example, if you scale the Left Hand to 200% and apply Left to Right symmetry, the other hand will scale as well. Do not use this command if you want to use asymmetrical settings.
Applying Custom Symmetry

Built in commands in the Pose Symmetry menu allow you to quickly apply symmetry to arms, legs, and torso. However, the built-in Symmetry commands allow you to operate on arms only, legs only, or an entire side of the body. The Custom Symmetry dialog allows you to selectively apply symmetry on any body part, and to apply symmetry across a specified number of frames in an animation.

Choose **Figure > Pose Symmetry > Custom** to open the **Apply Custom Figure Symmetry** dialog. This dialog allows you to select body parts on which symmetry can be applied. The options in the **Apply Custom Figure Symmetry** dialog are as follows:

- **Left to Right**: Choose this option to apply the values from the left side of the figure to its right side.
- **Right to Left**: Choose this option to apply the values from the right side of the figure to its left side.
- **Swap**: Swaps the values from the left side to the right side, and vice versa.

*The Figure > Rig Symmetry commands in Poser perform symmetry functions on the rig of the figure. For more information, see Positioning Bones Using Rig Symmetry.*
• **Apply Symmetry To**: Allows you to specify which frame or frames to apply the symmetry command to.

• **Current Frame**: Applies the custom symmetry settings to the frame that you are currently viewing in the document window.

• **Frame Range**: Applies the custom symmetry settings to a specified range of frames. All frames in your current project are entered by default. For a specific range of frames, enter the start frame and end frame in the fields provided.

• **Hierarchy Window**: Check or uncheck the body parts that you want to include in your Custom Symmetry action.

• **Select All**: Selects all items in the hierarchy list.

• **Select None**: Deselects all items in the hierarchy list. Allows you to ensure that all items are deselected before you select specific items to include.

• **Cancel**: Exits the Apply Custom Figure Symmetry dialog without applying the settings.

• **OK**: Click to apply your choices to the selected figure.

---

**Delete Figure**

Selecting **Figure > Delete Figure** deletes the currently selected figure. A confirmation dialog appears. Click **OK** to proceed with the deletion or **Cancel** to abort. Windows users can also delete a figure by selecting it and pressing **[DEL]**.

If your figure is wearing conforming clothing or has other attached figures, you can check the **Delete attached figures** option to delete them in addition to the figure that you are deleting.

---

**Hide Figure**

Selecting **Figure > Hide Figure** hides the currently selected figure if you have more than one figure in your scene. This is helpful when you work with complex scenes, especially where a figure is getting in your way. You can also hide a figure by selecting the figure to hide by selecting **Body** using the **Select Element** pull-down menu and clearing the **Visible** checkbox in the **Properties** palette as described in **Properties**.

*Collision detection settings do not apply to hidden objects.*

---

**Show All Figures**

Selecting **Figure > Show All Figures** makes all hidden figures in your scene visible. You can also make hidden figures visible by selecting them and checking the **Visible** checkbox in the
Properties palette. If one or more body parts are set to invisible, these will remain invisible when the selected figure is shown.
Working with Props

Poser lets you add props to your scene. Props are three-dimensional objects that your figures can interact with or that simply add interest to your scene. Props can be accessories to add to your figure's character such as a wig, a mustache, a pair of sunglasses, a cigar, or a briefcase. Or, your figure could base its pose on a prop, such as leaning on a cane, climbing a ladder, or tossing a ball. This chapter covers hair, conforming (figure-based) clothing, and miscellaneous props not fitting into these categories. Poser treats conforming clothing items like figures, however we will treat conforming clothing as props in this chapter for the sake of discussion.

About Props

You can manipulate props just as you would any other element, which is why you see the term body part/prop used throughout this manual. You can change a prop’s color, shape, deformation, material, and maps. Props can even cast shadows.

Poser’s replaceable geometry feature (see Replacing a Body Part with a Prop) lets you replace body parts with props, making the prop actually part of the figure. You can also parent a prop to a body part or another prop or scene element, such as a briefcase in a hand. Please refer to Poser Figures Hierarchy for information about hierarchies in general, and to The Hierarchy Editor for information on creating hierarchies within Poser. Props also add general interest and meaning to your scenes, such as a mushroom for a frog to perch on.

Props add interest to your scene.

You can select props from the Props category in the Library palette, or import props in a variety of popular 3D formats. You can also create your own props in your favorite 3D modeling application (provided that application exports to one or more formats supported by Poser’s Import function).

Props function like other scene elements, meaning you can use the Editing tools and parameter dials and can specify properties in the Properties palette. You can also create groups using the Group Editor palette (see The Group Editor).
Clothing

Poser’s Cloth room (see The Cloth Room) adds a whole new dimension to adding realistic clothing to your figures and cloth objects to your scenes. You can even add realistic motion to clothes that will react as the character moves (such as a skirt on a walking woman) and can be windblown using wind force fields (described in Wind Force Fields). Of course, Poser supports prop-based clothing and ships with both dynamic and conforming (figure-based) clothing.

Conforming Clothing

In addition to cloth objects, Poser includes libraries of figure-based clothing that you can use on nude figures, which are located in the Figures category of the Library palette and includes shirts, pants, shoes, dresses, skirts, etc. Conforming clothing attaches to a figure and automatically moves with the figure’s poses. See Adding Conforming Clothing: Manual Conforming and Adding Conforming Clothing: Automatic Conforming for more information on using automatic and manual conforming methods to attach clothing to your figures.

Dynamic Clothing

Please refer to Adding Dynamic Clothing for information about adding dynamic cloth to a figure or scene.
Adding & Importing Props

There are several ways to bring props into Poser. Props can be added to the document window from the Props library, or you can also import props from other 3D applications.

The Props Library

You can add props from the Library palette’s Props category as described in The Props Category.

Using 3D Objects as Props

You can import 3D objects created in other 3D applications to use as props. Poser’s Import functionality is described in Importing Content.

Poser places props in the workspace with your specified origin point. If you do not specify an origin point, the prop will appear in the center of the workspace. If you import a prop and can’t see it, the prop may be too large and/or your currently selected camera may be zoomed in too close to see it. Try zooming out and/or switching cameras. You will probably have to scale and translate props to get them where you want them in your scene, using either the Editing tools or the prop’s Parameter dials.

Creating New Props

You can use the Grouping tool to select specific polygons on a figure or prop, as discussed in The Group Editor. This feature allows you to create new props. For example, this graphic shows an example of a face mask created to fit the figure by selecting polygons in the figure’s face and creating a prop, which was then exported to a 3D modeling application for finalizing.
The Group Editor can be helpful in creating a prop (such as a mask) from a figure.

To create a prop:

1. Select the prop or body part you want to base the prop on.
2. Select the Grouping tool to open the Group Editor palette.
3. Select polygons for a new group and create and name the prop.
4. The new prop is now listed in the Current Actor pull-down menu and can be moved, shaped, and edited like any other prop.

You can save your new prop to the Library palette as described in Adding Items to the Library.

Creating Prop Parameters

You can use morph targets to create new parameters for your props. Please refer to Modifying Figures & Props for more information about morph targets.

The Prop Origin

A prop’s origin appears in the Document window as 3D crosshairs. This is the center of that prop’s rotation and scale. When you rotate a prop, it rotates about its origin. It grows or shrinks from the origin point when scaled. You can display a prop’s origin by selecting the desired prop and checking the Display Origin checkbox in the Properties palette.

You can move a prop’s origin using the originXYZ parameter dials. Moving the origin alters the prop’s rotation and scale points. When adjusting the origin parameters, remember that you are making these adjustments based on the prop’s original origin location, not its current position.
The Prop Origin (shown as 3D crosshairs) is turned on and off in the Properties palette.

Prop Parameters

Props have the following parameters:

- **Scale**: The Scale parameter dial increases or decreases the size of the prop in all axes.
- **XYZScale**: The xScale, yScale, and zScale parameter dials increase or decrease the size of the prop in the selected axis.
- **XYZRotate**: The xRotate, yRotate, and zRotate parameter dials rotate the prop around the selected axis.
- **XYZTran**: The xTran, yTran, and zTran parameter dials move the prop along the selected axis.

Prop Properties

Props have the following properties:
Prop properties.

- **Internal Name**: The Internal Name field displays the prop’s internal (hidden) name, which Poser uses to track that part. You cannot edit a prop’s internal name within Poser.

  *You can animate the prop visibility by clicking the key icon next to the Visibility option. Key will be white when animation is on, and gray when animation is off.*

- **Name**: The Name field displays the prop name. Enter a new name in this field if you desire.

- **Visible**: Checking the Visible checkbox makes the prop visible and vice versa. Invisible props are not included in any render calculations, and do not appear in the rendered scene. See Figure Properties for information on animating the Visible property.

- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the prop visible in raytraced reflections, such as if the figure is in front of a mirror. Clearing this checkbox makes the figure not appear in reflections.

- **Casts Shadows**: Checking the Casts Shadows checkbox forces the selected prop to cast a shadow, which will be visible in your scene. Clearing this box means the selected body part casts no shadow.

- **Visible in Camera**: When checked, the object is visible in the camera and render. When unchecked, the object does not render. Used in conjunction with Light Emitter, described next, to create light-casting objects.

- **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.
Collision detection: Checking the Collision Detection checkbox enables collision
detection for the currently selected prop. Please refer to Collisions for more information
about collision detection.

Apply Collision Setting to Children: Clicking the Apply Collision Setting to Children
button applies the currently selected prop’s collision detection setting to that part’s
children parts (if any).

Load Morph Target: Clicking the Load Morph Target button displays the Load Morph
Target dialog, allowing you to load a custom morph target for the selected prop (which is
then editable using the Morphing Tool). Please refer to Modifying Figures & Props for more
information about loading morph targets.

Set Parent: Clicking the Set Parent button allows you to make the prop a child of another
element in your scene. Please refer to Changing a Parent for information on setting prop
parents.

Displacement Bounds: The Displacement Bounds property determines the prop’s
displacement boundary. Please refer to Using The FireFly Render Engine for more
information about displacement bounds.

Shading Rate: The Shading Rate allows you to specify the desired shading rate for the
currently selected prop. Lowering the shading rate improves your render quality but
consumes computer resources. Please refer to Using The FireFly Render Engine for more
information about shading rates.

Smooth Polygons: Checking the Smooth Polygons checkbox causes Poser to smooth the
prop’s polygons at render time to eliminate or reduce a “faceted” appearance caused by
flat polygons. This option can cause sharp corners to appear round. If the affected prop
has sharp angles, you should experiment with disabling this option for optimum results.

Crease Angle: The Crease Angle setting establishes a threshold up to which creases
between adjoining polygons will be smoothed. Polygons with crease angles over this
threshold will not be smoothed, and will be rendered as hard edges. See Smoothing
Geometry for more information about using the Crease Angle setting to apply smooth
shading.

Display Origin: Checking the Display Origin checkbox displays the prop’s origin. Please
refer to The Prop Origin for more information about prop origins.

Subdivision Levels: Allows you to subdivide the selected prop. See Working with
Subdivision Surfaces for more information.

Remove Backfacing Polygons: Determines how backfacing polygons are displayed on
the selected prop:

  • Obey Global Setting: Uses the setting that is configured in the Render Settings
dialog.

  • Force Show Backfacing Polys: Backfacing Polys will always be shown in the
    currently selected figure.

  • Force Hide Backfacing Polys: Backfacing Polys will always be hidden in the
    currently selected figure.
Replacing a Body Part with a Prop

Poser lets you replace a body part with a prop, such as a hook on a pirate’s hand or a mask for a man’s head. This example was created by importing a model of a mask, then replacing the figure’s head with that mask.

You should replace body parts with props before posing figures to make positioning and aligning easier.

A mask prop replaces the figure’s head.

To replace a body part with a prop:

1. Add or import the desired prop.
2. Position and deform the prop as desired using the Editing tools, deformers, and/or parameter dials. Be sure that the prop’s position overlaps the body a little (in most cases) to avoid a “break” where the body meets the prop. You might also want to make the body part being replaced invisible using the Properties palette as described in Properties.
3. Select Object > Replace Body Part with Prop to open the Replace Part dialog.
4. Choose the prop to swap using the Prop pull-down menu and click OK. The prop assumes the name of the body part being replaced.

If the replaced body part doesn’t look right, try disabling bending by selecting the replaced body part and clearing the Bend checkbox in the Properties palette. You can also use the Joint Editor palette to make adjustments. This is an advanced feature and should be used with care. Please refer to Working with Joints and Weights for information on using the Joint Editor.
palette. The prop retains its material groups that are configured in the OBJ file you can apply shaders to it as you can with any other material groups in your scene.

Props turned into body parts retain their current positions relative to the figure that they had prior to being converted. Be sure to place props in their desired locations before turning them into body parts.

Changing Figures with Replaced Geometry

If you try to change a figure that has a prop for a body part using the Change function in the Library palette, a warning will appear asking if you want to keep the replaced geometry on the new figure replacing the old.

- To keep the props that have replaced body parts, check the Keep modified geometries button. To keep the props attached to their parents on the new figure, check the Keeps props attached to figure checkbox. Click OK when ready.

- To undo a geometry change and restore a figure’s default geometry, simply reload the original figure from the Library palette.

Changing a Parent

You can attach props to body parts, body parts to each other, figures to props, figures to figures, cameras to body parts, etc. Setting a parent creates a hierarchical relationship, as described in Poser Figures Hierarchy. You can even control whether parented props bend along with their parent body part. Some items like sunglasses, etc. should not bend. However, other items such as elbow pads on a roller blader should bend with the parent. You should change parent props before posing your figures, since it may be harder to align props with figures once the figures have been posed (such as a sword in a warrior’s hand).

Here’s an example of a ball parented to a figure’s right hand.

A ball follows a figure’s hand when it is parented to the hand.

You could also parent a chair to a figure’s hip and make the chair inherit the figure’s bend.
Your parenting choices are virtually unlimited. For example, how about parenting a camera to a figure’s head? This could create some interesting effects.

To set a parent for an element:

1. Select the object you wish to parent (make the child of another object).
2. If necessary, use the Editing tools, deformers, and/or parameter dials to position and shape the object. Ensure the correct positioning using either a detailed preview style (such as Lit Wireframe), zooming in close, or a test render. You can also enable Collision Detection to prevent the selected object from penetrating its parent object, or vice versa. Please refer to Collisions for more information about the Collision Detection feature.
3. Select Object > Change Parent (or click the Set Parent button in the Properties palette) to open the Object Parent dialog.

   ![Object Parent dialog]

   You choose the parent object in the Object Parent dialog.

4. Select the desired parent object (the object to which the currently selected object will be attached).
5. If you want the prop to bend like its parent, check the Inherit bends of parent checkbox.
6. Click OK.
In the preceding examples, we parented the ball to the figure’s right hand and the chair to the figure’s hip. To set parents for an entire figure, select **Figure > Set Figure Parent** as described in [Set Figure Parent](#).

**Set Figure Parent**

You can attach props to body parts, body parts to each other, figures to props, figures to figures, cameras to body parts— the list goes on and on. Setting a parent creates a hierarchical relationship, as described in [Establishing Hierarchal Relationships](#). You can parent entire figures to various other scene elements. For example, you can parent a character to the bench that it sits on, and when you move the bench to another location in the scene, the figure will go with it.

To set a parent for a figure:

1. Select the figure you wish to parent (make the child of another object).
2. Select **Figure > Set Figure Parent** to open the **Object Parent** dialog.
3. Select the desired parent object and click **OK**. To parent props, camera, etc., select **Object > Change Parent** as described in [Changing a Parent](#).

![Choosing a parent for a figure](image)

**Grouping Objects**

A grouping object is a container that can act as a parent to two or more objects. A grouping object allows you to perform the same action to more than one object at a time. For example, when several objects are assigned to the same grouping object as a parent, you will be able to...
move or rotate the grouping object to do the same to all of its children; or you could turn off visibility for all of the children of the grouping object.

To demonstrate how grouping works:

1. Create a new project.
2. Add a few primitives (a box, a ball, and a bowl are shown here).
3. Also add a Square Groundplane HR from the Props > Primitives category.
4. With the Square Groundplane selected go into the Material room and click the Add Reflection Wacro. The ground plane will turn into a reflective surface.

   *If you are starting from the default scene that ships with Poser 13, you can apply the Add Reflection Wacro to the Construct_1 ground plane to accomplish the same thing.*

5. Change the colors of the props to add more variety to the scene.

   *Four objects in a scene.*

Now, you can create the grouping. Choose **Object > Create Grouping**. A container named Grouping n (where n represents a numerical value automatically assigned by Poser) appears in the scene. It will appear at the zero position in the scene (on the floor, at the origin point of the scene). It appears as a cube in wireframe display mode, and will not be rendered in your scene.
There are several ways that you can attach children to the Grouping object:

- Select an object in your scene that you want to attach to the Grouping object. Choose **Object > Change Parent**, and use the Change Parent dialog to select the Grouping Object in the hierarchy.

- Right-click in the **Document** on the object you want to attach. A context menu appears, and included is a Change Parent to command. Expand the menu and select Groupings > Grouping n (with n being the number of the grouping you want to attach).

- Open the Hierarchy Editor, and select the item you want to attach to the grouping object. Drag and drop it on the grouping object so that it becomes its child.

Use any of the above methods to attach the box and the ball.

Leave the bowl and ground as they are (do not assign the Grouping object to them as the parent). Notice now, that when you move the grouping object, the box and ball will move, but the bowl and ground plane stay put.
Parent with the **Object > Change Parent** command (top) or with the **Document context menu** (bottom).

The Box and Ball move with the Grouping object. The bowl and ground (not attached) stay put.

A Grouping object allows you to do more than translate or rotate objects together.

For example, you can toggle the Visibility of a grouping object to show or hide all of its children at once.

> **When a Grouping object is invisible, the Hierarchy Window will display the visibility icon slightly differently for its children. A blue outline will appear around the visibility icons for children of a grouping object, indicating that they have inherited the Invisible setting from the grouping object.**

You can also toggle the **Visible in Raytracing** property of a Grouping object. Let’s say that you have several objects on a reflective surface. If **Visible in Raytracing** is turned on for the grouping object, reflections will be calculated and rendered for the child object. If **Visible in Raytracing** is turned off for the object, reflections will not be calculated. This can help speed
up rendering, but there may also be times when you intentionally want some objects to be reflected and others not.

![Grouping object Visibility off (top); Visible in Raytracing off (bottom).](image)

**Using Grouping Objects with Figures**

When you create a grouping that includes a body part on a figure, the order that you select items can affect how the figure relates to the grouping object:

- If you start by adding a figure to your scene (such as Andy, or Alyson or Ryan), and then use the **Object > Create Grouping** command, the grouping object will appear in the scene. Next, you select one of the body parts on the character (such as the right forearm) and right-click to choose **Change Figure (figure name) parent to** from the context menu that appears. The grouping object becomes a parent of the entire figure, and not just the selected body part.

- If you create your group first (for example, you assign a grouping object as a parent to a table, chair, and dishes on the table) and then you assign the figure’s hand as a parent to the grouping object, you can still have some freedom over the hand.

**Using Constraint Channels**

Constraint channels allow you to animate one object based on the position of another object. To explain, visualize a scene where a football is being tossed to a football player, and then he catches it and runs with it. If you create this type of scene in Poser, you can use a constraint channel to help with this animation. The figure’s hand can be a target for the football. You animate the pass of the football, and when the football gets close to the catcher you can set the value of the Constraint object to 1 so that the ball moves with the figure’s hand.
Here is a simple example to illustrate how this works. Create a simple scene that has three primitive props, such as a box, a bowl, and a ball (or similar).

With one of the props selected (the box in this example), choose Object > Add Constraint. The Add Constraint dialog appears and prompts you to select a constraint target. You can then select the ball as the target.

*Choose a Constraint target from the Add Constraint dialog.*

After you click OK, you will see that the box moves to the same position held by the ball, so that they are now in the same space. A Constraint dial appears in the Parameters Palette, and is set to 1. When you move this dial back toward the 0 value, you will see the box move back toward its original position.
The box moves to the same space as the ball when the Constraint dial is set to 1.

A wireframe box appears at the origin of the ball (the target), but may be hidden within the target object. This wireframe box is a container that will not render in your scene, but it assists in animation. The Hierarchy Editor will show this box as Constraint Grouping n (where n is a numerical value automatically assigned in Poser) and it will appear as a child to the ball.

Now, to see how a constraint channel works, move the Constraint parameter dial back toward 1, so that the box moves closer to the ball. Then move the ball (not the Constraint object) with the editing tools. You will notice that the box follows the ball. The amount of movement between the two objects is determined by the value set by the Constraint parameter dial.
When you move the ball, the box follows it, with the amount of movement dependent on the Constraint value.

You can add more than one constraint object. For example, you can select the box and assign the bowl as a second constrain target. An additional Constraint dial appears in the Parameters window (and also in the Hierarchy window). When an object has two Constraint targets, it works as follows:

- If both Constraint 1 and Constraint 2 for the box are set to 1, the box will be positioned according to Constraint 2.
- If Constraint 1 is set to 0, and Constraint 2 is set to 1, the box will be positioned according to Constraint 2.
- If Constraint 1 is set to 1, and Constraint 2 is set to 0, the box will be positioned according to Constraint 1.
- If both Constraint 1 and Constraint 2 are set to values other than 0 or 1, the box will be positioned in relation to both.
When an object has two constraint targets, set each to a value between 0 and 1 for both to have effect.

Creating Simulation Proxies

The **Object > Spawn Prop** from Convex Hull command allows you to quickly create lower-resolution objects that you can use as a simulation proxy. They can be used for anything, such as physics, hair, or cloth simulations. They help reduce resources when you are trying to calculate simulations and collisions against high resolution geometry. Simulation proxies are also useful when you are trying to visualize where collisions against an object will occur, and for proofing dynamics.

To create a simulation proxy, follow these steps:

1. Click the object in your scene for which you want to create a low-resolution proxy. This can be a prop in your scene, or an actor on a poseable character (such as a character’s head).

2. Choose **Object > Spawn Prop from Convex Hull**. A prop, named **hull**, appears in your scene.

   *The first simulation proxy that you create will be named hull. The second, and subsequent proxies will be named hull n, where n is a sequential number (such as 1, 2, and so on).*

3. Switch to the **Properties** palette, if desired, to assign a more descriptive name for the proxy in the Name field.
Creating and Using Text Props

You can use text props to add labels to items in your scene.

Text props can also be used as control props (discussed further in Using Control Props). Text objects do not appear in renders.

The text initially appears as a large object on the floor in the center of the scene. Use the Parameter to scale and position the text object where desired.

The text object itself is not editable. You will need to delete the text object and create a new one with the text that you want to display.

To create a text prop, follow these steps:

1. Choose Object > Create Text Prop.
2. Enter the text that you want to display as a text prop.
3. Choose OK.
4. If desired, change the name of the text prop in the Properties palette.
5. You can also scale and position the prop in the Parameters Palette, and change the color of the text prop in the Material room.
Creating and Using Measurement Objects

Measurement objects allow you to determine distances between objects, or determine measurements of objects that you might be assembling for scene reconstructions.

Measurements are a new type of prop in the scene. If you want to delete a measurement prop, you will find them listed in the Current Actor menu at the top left of the document window.

The Measurement Mode icon appears in the lower right corner of the document window. When you click this icon you’ll see a number of commands listed in two sections.

In Poser, the top section allows you to create four types of measurements: Line, Angle, Circle, and Polyline, which are described in the following sections. The bottom section displays the following additional options:
When you use the measurement tool to select a point on which to base a measurement, the tool will snap to the nearest vertex that you click and a red dot will be displayed at that point.

After you set your measurement points, you can later hover your mouse cursor over a measurement point to edit it. The cursor turns into a bullseye and you can move the measurement point to snap it to another vertex in your scene. The measurement text will update as you move the measurement points.

**Measurement Mode - Off**: Click to turn measurement mode off. The measurement text will not be displayed in your document window.

**Measurement Mode - Display**: If measurement mode is on, you can turn off the display of numbers using this command.

**Measurement Node - Edit**: Select this item if you want to edit the placement of an existing measurement point.

You can use the Figure > Copy Measurements From command in Poser to copy measurement objects from one figure to another. For example, if you create some line and polyline measurements on Rex to determine various measurements like height, shoulder width, waist measurement, and arm length, you can copy the same measurement objects to Roxie and they will be placed in similar positions on her body.

Measurements are not automatically deleted when you delete a figure to which they are attached. Select the measurement indicators by clicking them, or use the Current Actor dropdown to select the measurement you want to delete. Then click the Delete key to delete the measurement.

**Line Measurements**

A line measurement object a straight line measurement. Simply click two points in the scene to display the distance between those two points.

To create a Line Measurement object, follow these steps:

1. Choose Object > Create Measurement > Create Line, or click the Measurement Mode icon in the bottom right corner of the document window and select Create Measurement - Line. An initial measurement of zero will appear at the center of the scene.

2. The Properties palette displays the following options which can be set before or after you define your measurement points:
Line measurement properties.

- **Name**: Enter a name that describes the measurement you are creating (for example, AndyHeight). Note that if you enter a name that already exists for a figure or object in the scene, the name that you enter will be appended by a number.

- **Visible**: Turns display of the measurement indicator on or off. Keep this option checked to view the angle measurement while you are creating it.

- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the measurement object visible in raytraced reflections, such as when the figure is in front of a mirror. Clear this checkbox to make the measurement object not appear in reflections.

- **Casts Shadows**: Checking the Cast Shadows checkbox forces the selected measurement object to cast a shadow that is visible in your scene. Clear the checkbox to cast no shadow.

- **Visible in Camera**: When checked, the measurement object is visible in the camera and in the final render. When unchecked, the object does not render.

- **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.

- **Alignment**: By default, the line measurement will not be aligned to any axis (None). Options in the Alignment menu allow you to align the measurement to the X, Y, or Z axis.

- **Callout Style**: Allows you to display measurement text without a background (default), or against a black background.

- **Copy to Clipboard**: Click this button to copy the measurement dimension into your clipboard to paste into another document.

3. Click at the first point that you want to measure. For example, if you want to determine the height of a figure, click at the top of his head (point 1 in the following figure).
4. Click the second point that you want to measure. For example, if you are measuring the height of a figure, click the floor, or the lowest point of the character’s feet (point 2 in the following figure).

![Line measurement object.](image)

5. After you click the second point, the measurement will display in text beside the figure. The measurement will also appear in a tooltip in the lower left corner of the document window. You can adjust the line measurement by hovering over the measurement points as follows:

6. To adjust line measurements:

   - Hover the mouse over point 1 or point 2, and drag to place the measurement point across another vertex in the scene.

   - You can adjust the length of the extension lines by moving either of the orange points at the top or bottom of the measurement arrows, or by using the **Extension Line Scale** dial in the Parameters Palette.

   - Measurements will also change if you adjust scaling or the pose of a figure. In the case of the figure in the above example, you could scale the figure until it reaches a specific height.

## Angle Measurements

Angle measurements allow you to determine an angle between two lines that meet at a center point.

To create an angle measurement, follow these steps:

1. Choose **Object > Create Measurement > Create Angle**, or click the Measurement Mode icon in the bottom right corner of the document window and select **Create Measurement - Angle**.

2. Click the first point to set the end point of the first line in the angle (point 1 in the figure below, which picks one of the back legs of the chair).

3. Click the second point to set the point at which the two lines in the angle will connect (point 2 in the figure, which selects one of the points on the oil can).
4. Click the third point to set the end point of the second line in the angle (point 3 in the figure, which selects one of the corners of the cinder block).

![Angle measurement object.]

5. To adjust an angle measurement (reference the above figure):

- After your angle measurement is complete, the first point you clicked will be colored red, the second will be yellow, and the third will be blue.

- Hover your mouse and then drag at points 1 (red) or 3 (blue) to adjust the measurement point for each of the arms in the angle.

- Hover your mouse and then drag at point 2 (yellow) to select a new common point for the angle.

- Hover your mouse and then drag at points 4 or 5 (orange) to adjust the distance that the measurement extends from the measurement points. You can also control the scale of the extension line using the Extension Line Scale dial in the Parameters Palette.

- If you move any of the objects that contain a measurement point, the text object will update to display the new angle as you change the positions of the objects.

6. You can set the following properties for an angle measurement in the Properties palette:

![Angle measurement properties.]
Circle Measurements

The Circle measurement tool allows you to create a circle measurement in 3D space. You define three points on an object to create a circle measurement. Follow these steps:

1. Choose Object > Create Measurement > Create Circle, or click the Measurement Mode icon in the bottom right corner of the document window and select Create Measurement - Circle.

2. Click three points on an object to form a circle. The measurement point will snap to the nearest vertex that you click. All three points will lie on the circumference. The circle indicator and measurement statistics will appear after you click the third measurement point. After the measurement is complete, the first point you clicked will be red, the second yellow, and the third blue. The tooltip for a circle indicator appears in the lower left corner of the document window, and displays the circumference and radius of the circle.

Circle measurement object.
3. You can set the following properties for a circle measurement in the **Properties** palette:

![Circle measurement properties.](image)

- **Name**: Enter a name that describes the measurement you are creating.
- **Visible**: Turns display of the measurement indicator on or off. Keep this option checked to view the angle measurement while you are creating it.
- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the measurement object visible in raytraced reflections, such as when the figure is in front of a mirror. Clear this checkbox to make the measurement object not appear in reflections.
- **Casts Shadows**: Checking the Cast Shadows checkbox forces the selected measurement object to cast a shadow that is visible in your scene. Clear the checkbox to cast no shadow.
- **Visible in Camera**: When checked, the measurement object is visible in the camera and in the final render. When unchecked, the object does not render.
- **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.
- **Copy to Clipboard**: Click this button to copy the measurement dimension into your clipboard to paste into another document.

**Polyline Measurements**

The Polyline measurement tool allows you to determine precise opened or closed measurements along a straight or splined path. In particular, the Polyline measurement tool is helpful in determining and adjusting measurements of a body shape. This allows you to accurately reproduce body measurements of a character.
The following example shows how you can obtain an accurate measurement of a character’s waist:

1. Load your character into Poser.
2. Set Document Display mode to the new Lined Texture Style (the last icon in the Document Display palette). This displays the figure’s wireframe over the texture and helps you more clearly view the flow of the figure’s geometry while you draw the polyline around the waist.
3. Choose **Object > Create Measurement > Create Polyline**, or click the **Measurement Mode** icon in the bottom right corner of the document window and select **Create Measurement - Polyline**.
4. In the **Properties** palette, you can set the following options before or after you create your polyline:

   - **Name**: Enter a name that describes the measurement you are creating (for example, **WaistMeasure**). Note that if you enter a name that already exists for a figure or object in the scene, the name that you enter will be appended by a number.
   - **Visible**: Turns display of the measurement indicator on or off. Keep this option checked to view the angle measurement while you are creating it.
   - **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the measurement object visible in raytraced reflections, such as when the figure is in front of a mirror. Clear this checkbox to make the measurement object not appear in reflections.
   - **Casts Shadows**: Checking the Cast Shadows checkbox forces the selected measurement object to cast a shadow that is visible in your scene. Clear the checkbox to cast no shadow.
   - **Visible in Camera**: When checked, the measurement object is visible in the camera and in the final render. When unchecked, the object does not render.
• **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object.

• **Spline**: Check this option to create smooth curves between your polyline points. Uncheck the option to create straight lines between the polyline points.

• **Slack**: Adjusts the amount of space between the figure and the segments in the polyline.

• **Closed**: Check this option to create a closed polyline that automatically connects the current measurement point to the first point that you clicked. Uncheck the option if you want to create an open polyline. (Check this option for this example).

• **Copy to Clipboard**: Click this button to copy the measurement to the clipboard. This is basically the same information that is displayed in the tooltip in the lower portion of the screen.

5. Click to set the starting point, and then draw your polyline around the figure. The measurement points will snap to the figure, and if the Closed option is checked the current point will connect to the starting point as you work your way around the figure. As you draw your polyline you will notice a tooltip in the lower section of the document window that displays the measurement of each segment, along with the total measurement of the polyline.

6. After you set the last point, turn off the Edit Measurement mode, using one of the following methods:

   • Select another figure or object from the Current Figure/Current Actor menu on the document window.

   • Click the Measurement tool in the lower-right corner of the document window and choose Measurement Mode - Display.

7. The total polyline length will be displayed in the lower left portion of the document window. If you change the shape of the figure by dialing in a morph or changing the scale of the waist, the measurement will update automatically to reflect the change.

---

**Using Control Props**

Control props are effective for adding additional control of the character through the use of ghost bones. For example, many content creators assign the area from the hip to the hem of a
dress to the hip group, and then use control props (or body handles) to control the movement of the skirt.

Control props act as a UI proxy for another object. You can use any type of geometry as a control prop, and can also assign a text prop that help identify the area that the control prop affects. The control prop can be configured either directly over the part it is controlling, or set remotely in another part of your scene.

The following example shows how to set up a text control prop to control Roxie’s jaw. After you add Roxie to a scene, proceed as follows:

1. Choose **Object > Create Text Prop**. The Create Text Prop dialog prompts you to enter a name for your text prop. Enter RoxieJaw.

   *If you enter a name of a figure or object that already exists in your scene, Poser will append a number to the name after the object is created.*

2. The text prop initially appears in very large text in the center of your scene at ground level. You can use the Scale, Rotate, and Translate dials in the Parameters Palette to position and scale the text object as desired. Here, the text is reduced on size and moved to the side of Roxie’s head.

3. Click the RoxieJaw text prop and choose **Object > Convert Prop to Control Handle**. A dialog prompts you to select the actor to control. Drill down through the hierarchy tree until you find Roxie’s Jaw.
Using Selected Polygons for Control Props

You can also create control props that move along with the area that they control. For example, the facial control props in Paul and Pauline, and La Femme and L'Homme were created by using the Group Editor to spawn selected polygons in the face as props.

The steps below are shown for Pauline, but will be similar for Paul, La Femme, and L'Homme):

1. Add a figure that uses control chips to your scene, and open the Group Editor.
2. Create a new group, named for the control prop you want to create (for example, Jaw Prop).
3. Create a new group named for the bone you want to control.

4. Select the polygons that you want to use for the control chip. You will find it easier to select the polygons if you use one of the lined display styles, as shown below.

5. Click Spawn Props.

6. Spawn a prop to create the control chip.

5. Poser will add two props to the scene. The first prop will be named the same as the actor that you created the control chip for (Head, in this case). You can delete this prop. The second prop will be your control chip (Jaw Prop, in this case).
Two props will be created. In this case, delete the head prop, and keep the JawProp prop.

6. With your new prop selected, choose **Object > Convert Prop to Control Handle**. The Create Control Handle dialog prompts you to select the bone that you want to control. In this example, you would choose Pauline’s Jaw bone.

![Create Control Handle dialog](image)

**The JawProp is set to control Pauline’s Jaw.**

7. You’ll notice when you initially use the new JawProp to control the jaw, the JawProp itself remains in its original position. This is because the new control props are parented to UNIVERSE by default. To create a control prop that moves with bone that it is controlling, right-click the JawProp and choose Change JawProp Parent to, and drill down to select Pauline’s Jaw as the new parent.

![JawProp parented to Jaw](image)

**To create a control prop that moves with the jaw, change the parent from UNIVERSE to Pauline’s Jaw.**
Cameras

This section describes how Poser’s cameras work. As indicated previously, cameras aim at the Poser workspace from different vantage points. Switching cameras allows you to view your scene from up to four of these vantage points at once.

- Selecting Display > Camera View allows you to select one of the cameras available in your scene.
- Selecting Display > Show Camera Names displays the name of the currently selected camera in the top left corner of the Document’s scene preview area. Clicking this option again disables this feature.

The sections that follow describe how to use Poser’s cameras.

Camera Controls

The Camera controls allow you to quickly select and position cameras. Used in conjunction with the available Document layouts, they allow you to quickly navigate your scene and/or set up final shots for still or animated output. Remember that every view you see of your scene inside the Document is done using one or more cameras. You can move cameras in any direction, however positioning them can be a time-consuming process. Having multiple cameras allows you to use preset camera positions to quickly navigate your scene, while the ability to position cameras allows you to create custom still or moving shots for use either while working on your scene or during rendering.

The Camera controls allow you to select and move one or more Poser cameras. There are two types of camera controls: View and Position.
To use the Camera controls, simply click and drag your desired control. Moving a camera does not change the locations or poses of figures, props, and other elements in your scene. Please refer to Cameras for complete information about the Camera controls.

- The topmost controls are the View controls. Clicking one of these controls activates the Face, Left Hand, or Right Hand camera, as appropriate. You can also scroll through the list of available cameras.

- The controls beneath the hand controls are used to turn camera animation on or off, or to use the Flyaround camera.

- The Animation On/Off control allows you to enable or disable automatic keyframe generation when you move or change rotation of a camera.

- The Flyaround camera view provides an animated view of your scene as a camera rotates around it while pointed at the center origin.

- The Position controls appear below these controls and are used to move or rotate the currently selected camera. The Camera Plane position controls move the camera along the X, Y, and/or Z axis, while the Trackball rotates the currently selected camera without changing its location in 3D space.

- The Frame Selected button changes the camera view to fit around the currently selected actor. See Frame_Selected.

- The Orbit Selected button rotates the camera around the currently selected actor. See Orbit_Selected.

The Orbit Selected mode does not work with cameras that are already set to orbit a specific body part (such as the Face, Left Hand, and Right Hand cameras).

Camera Mini-Controls

The Mini Camera Controls located at the top right of the Preview tab contain a subset of the total available Camera controls. From left to right, these are:

- **Frame Selected Object**: Allows you to pick a body part and then frame that body part in the camera view. See Frame_Selected.

- **Orbit Selected Mode**: The Orbit Selected command rotates the camera around the currently selected actor. See Orbit_Selected.

The Orbit Selected mode does not work with cameras that are already set to orbit a specific body part (such as the Face, Left Hand, and Right Hand cameras).

- **Camera Rotation**: The Camera Rotation trackball tilts and spins the currently selected camera about all three axes.
Please refer to Cameras for detailed information about the Camera controls.

**Camera Views**

**Select Camera Control**

Clicking and dragging the cursor over the Select Camera control cycles through the available camera views and changes the Document or currently active view pane to the newly selected camera.

Just above the main Select Camera control are three shortcut buttons for specific cameras. You can replace an existing camera shortcut with your currently selected camera by pressing [OPT]/[ALT] while clicking one of the Select Camera shortcut buttons. A shortcut for your currently selected camera will replace the previously existing camera shortcut.

**The Main, Auxiliary, and Posing Cameras**

The Main, Auxiliary, and Posing cameras are revolving cameras, which means they rotate about the center of the Poser workspace. By default, figures and props are placed at the center of the workspace. Moving figures/props does not alter these camera's positions. The Auxiliary camera provides a secondary camera for your use, such as when you are deciding which shot to render and want to explore possibilities without affecting your previous camera positioning-animation work.
The Posing camera is similar to the Main and Auxiliary Cameras except that it rotates about the currently selected figure, not the workspace. If you select another figure, the Posing camera moves to that figure/prop.

Main, Auxiliary, and Posing cameras as displayed in the Camera Controls.

**The Face Camera**

The Face camera provides a close-up of the currently selected figure’s face, allowing you to precisely adjust facial expressions and see your results in detail. This camera rotates around the currently selected figure’s face and moves if you select another figure. This camera also works with animal figures. To switch to the Face camera, select your desired figure and click the Face Camera control.

The Face camera displayed in the Camera Controls.

*For the Face camera to work properly, be sure your figures’ heads have the internal name of "head" (with a small h) rather than Head (with a capital H).*

**Left and Right Hand Cameras**

Like the Face camera, you can zoom in on the left or right hand of the currently selected figure to fine-tune gestures and other hand positions. Hand cameras also focus on the currently selected figure. If the figure is an animal, the Hand cameras will focus on the feet/paws/claws as appropriate. To switch to a hand camera, click the Left hand or Right Hand icon as appropriate.
The Dolly Camera

The Dolly camera rotates about its own center independently of scene contents, meaning it can move around and between elements in the scene. If you want to emulate a motion picture camera, the Dolly camera is your best choice.

Orthographic Cameras

The Left, Right, Top, Bottom, Front, and Back cameras are orthographic cameras, meaning that they product orthographic projections. Orthographic projections makes objects appear flat (2D), without the perspective of 3D views. Orthographic cameras cannot be rotated, since they are permanently aligned to the X, Y, and Z axes in the Poser workspace. Because of this, they make excellent references for viewing your scene.

For the hand cameras to work properly, be sure your figures’ hands are all named with internal names of lHand and rHand, preceded with lower-case rather than upper-case letters.
Shadow Light Cameras

Shadow light cameras are very useful for aiming lights and creating their shadows. Each light in your scene has one Shadow Light camera. Each shadow camera shares both XYZ location and aim direction with its assigned light. Poser uses these cameras to calculate shadows cast by the objects in each light’s path. Positioning these cameras and/or adjusting their parameters/properties can affect how shadows appear in your rendered scenes. You can select these cameras using the Select Actor pull-down menu. Shadow cameras have a reduced set of properties/parameters (see Camera Properties & Parameters for more information).

If you see poor depth map shadows in a portrait shot, or if you see warping or flickering shadows in animation, you can tweak the shadow cams to adjust the field of view to the parts of the scene that really matter.

![Shadow Light cameras displayed in the Select Actor drop down menu.](image)

For more information about shadow light cameras, see .

Flyaround View

The Flyaround view places the currently selected camera on a virtual track above and away from the center of the Poser workspace and orbits around your scene, displaying all elements within view. This is an excellent way to quickly see how your scene looks in 3D space. Once activated, this view remains active until toggled off. To toggle Flyaround on and off, click the control or make the selection using the Cameras pull-down menu.
Positioning Cameras

In addition to selecting cameras, the Camera controls allow you to position your currently selected camera using one or more of the following controls. If you have more than one camera active (multiple Document view panes), these controls will only affect the currently selected camera.

Camera Plane Controls

The Camera Plane controls constrain camera motion to specific 3D planes (axes), helping you to move the camera with precision:

- **Move YZ**: The Move YZ control constrains camera motions to the up/down (Y) and front/back (Z) axes.
- **Move XY**: The Move XY control constrains camera motions to the side/side (X) and up/down (Y) axes.
- **Move XZ**: The Move XZ control constrains camera motions to the side/side (X) and front/back (Z) axes.

The Flyaround Camera control.
Rotation Trackball

The Rotation trackball tilts and spins the currently selected camera about all three axes. The Main, Auxiliary, Posing, and Dolly cameras rotate about the center of the Poser workspace. The Posing camera rotates around the currently selected figure. The Face and Hand cameras rotate about the respective actors (body parts) of the selected figure. You can also use the Rotation trackball by pressing [OPT]/[ALT] and dragging the cursor around the workspace using the Document.

Scale Control

The Scale Camera control works like a zoom lens. Click the control and drag right to zoom towards the camera’s aim point (workspace, figure, or actor, depending on the camera). Clicking and dragging left zooms out, and vice versa.

Focal Length Control

The Focal Length control increases or decreases the selected camera’s focal length. Clicking the control and dragging right increases the focal length, while clicking and dragging to the left reduces the focal length. You can also adjust the camera’s Focal Length parameter in the Parameters palette.

Roll Control

The Roll Camera control banks the camera to the left or right, tilting your view of the Poser workspace. Click the control and drag left or right to tilt the camera in the indicated direction.
Frame Selected

The Frame Selected command changes the camera view to fit around the currently selected actor. Pick a body part or actor, and then click the Frame Selected control to change the camera view to fit around the selected actor.

Orbit Selected

The Orbit Selected command rotates the camera around the currently selected actor. This command is a toggle. When toggled on, the camera will be centered on the selected object or body part and you can rotate the camera so that it is always in the center.

The Orbit Selected mode does not work with cameras that are already set to orbit a specific body part (such as the Face, Left Hand, and Right Hand cameras).
Changing Cameras

To change a camera, use any of the following methods:

- Right-click the camera label in any Document pane and choose one of the options in the Camera View sub-menu.
- Click the Face, Left Hand, or Right Hand icon in the Camera controls (see Camera Views).
- Click the Select Camera control in the Camera controls.
- Select Display > Camera View using the Menu Bar, then selecting your desired camera in the Cameras pull-down menu.

Creating Cameras

You can create new revolving or dolly cameras using the Object > Create Camera menu option.

You can specify the type of camera you wish to create by selecting either Revolving or Dolly from the Create Camera sub-menu. A revolving camera rotates about the center of the Poser workspace, regardless of the position of objects within the scene. A dolly camera rotates about its own center, and can move around and between elements in the scene.

Camera Properties & Parameters

When you select a camera, its properties and parameters will appear in the Properties and Parameters palettes, respectively. To access a camera’s properties and parameters in the appropriate palette when you do not currently have a camera selected, you can:

- Click your desired camera object if it is visible in the Document.
- Use the Current Actor pull-down menu.
See the following sections.

**Camera Parameters**

Like all parameter dials, clicking and dragging a dial to the right increases its value, and clicking and dragging to the left decreases its value. You can also click your desired parameter’s numeric value to open a text field allowing you to directly type your desired value.

**Other Parameters**

The Other Parameters section contains a variety of parameters to control the behavior of the selected camera. These parameters are as follows:

- **Focal**: The Focal parameter dial sets the camera’s focal length. Smaller numbers give wider angles and will add more stretching and distortion as they decrease. Larger numbers give results like telephoto lenses, and result in less distorted but flatter images.

- **Perspective**: The Perspective parameter shifts the current camera’s perspective without changing the camera’s location. This can give the illusion that the camera is farther or nearer to objects in your scene. The Perspective setting is hidden, because it is
interconnected with the Focal setting. If you adjust the Perspective dial, you will see a change in the Focal setting.

- **Depth of Field**: Widening the lens aperture of the camera allows you to achieve a Depth of Field effect. The farther away items are from the focal plane, the more blurred they will appear. Depth of Field can be individually configured for each camera. Poser allows you to enable or disable Depth of Field for individual renders. In order for depth of field to render, you must enable the Depth of Field option in the **Render Settings** dialog. Please refer to **Using The FireFly Render Engine** for details on how to do this using the FireFly Renderer. The following images illustrate the Depth of Field effect.

Without depth of field (left); With depth of field (right).

If the results of your Depth of Field settings are too grainy in the blurred areas, try raising the number of Pixel Samples. Doing so will result in a smoother effect, but increased render times.

- **Focus Distance**: The focus distance dial controls the cross hair so that you can position the focus. Place the cross hair at the distance at which objects appear most in focus. In Poser, focal distance for each camera is determined by a control object located within the scene. You can animate the control object like any other figure in Poser, by using keyframes to specify its change in position; Poser will interpolate the movement between keyframes for you. (For more information about animating using keyframes, please refer to **Animating with Poser**.) Enter your desired value in the camera's Focus Distance field.
The Focus Distance control, with Alyson as the point of focus, and its render.

The Focus Distance control, with the car as the point of focus, and its render.

• **F-Stop**: The F-Stop number represents a lens aperture size. The larger the number, the smaller the aperture opening. Each number is multiplied by a factor of approximately 1.4 as the scale rises, giving standard values of 1.0, 1.4, 2, 2.8, 4, 5.6, 8, 11, 16, 22, 32, etc. Each change either doubles or halves the amount of light transmitted by the lens to the film plane. Basically, f-stop is calculated from the focal length of the camera lens divided by the diameter of the bundle of light rays entering the lens and passing through the aperture in the iris diaphragm. On a physical camera, this represents the lens focal length (see next bullet) divided by the f-stop value to determine the actual aperture size. The F-Stop setting affects the depth of field in Poser, just as it would in a real camera lens. Smaller F-stops increase depth of field and narrow the point of focus. Focus on the subject, and then enter the desired value in the F-Stop field.

• **Pitch**: The Pitch parameter rotates the selected camera about its own X axis (up/down). A positive number pitches the camera up (the scene appears to pitch down), and vice versa.

• **Roll**: the Roll parameter rotates the selected camera about its own Z axis (tip left/tip right). A positive number rolls the camera to the left (the scene appears to rotate to the right), and vice versa.

• **Yaw**: The Yaw parameter rotates the selected camera about its own Y axis (rotate left/rotate right). A positive number yaws the camera to the left (scene appears to yaw to the right), and vice versa.
Camera Parameters

Pitch (Up or Down); Roll (Tilt); Yaw (Turn).

- **Shutter Open**: The Shutter Open value represents the shutter opening time in fractions of a frame, where 0.0 is the beginning of the frame and 1.0 is the end of the frame. Unlike a real camera shutter, this one opens and closes instantly with zero elapsed time. Regular camera shutters, while extremely fast, require a small time interval to travel between the closed and open positions.

- **Shutter Close**: The Shutter Close value represents the shutter closing time in fractions of a frame, where 0.0 is the beginning of the frame and 1.0 is the end of the frame. Unlike a real camera shutter, this one opens and closes instantly with zero elapsed time. Regular camera shutters, while extremely fast, require a small time interval to travel between the closed and open positions. For example, setting a beginning time of 0.0 and an ending time of 0.5 means the shutter would be open for the first half of a frame.

See Motion Blur Document for more information on using motion blur in your projects.

- **Hither**: The Hither parameter controls the distance of the near clipping plane. Objects (or portions thereof) closer to the camera than the hither distance will not appear in your view pane.

- **Yon**: The Yon parameter sets the farther range of the far clipping plane. Objects (or portions thereof) farther from the camera than the yon distance will not appear in your view. The Yon parameter is only applicable with OpenGL hardware rendering.

Transform Parameters

When a camera is selected, you can use the parameter dials on the Parameters palette to precisely adjust that camera’s position. The Dolly, Posing, Face, and Hand cameras have the standard 3D Pitch, Yaw, and Roll parameters, while the Main and Auxiliary cameras have xOrbit, yOrbit, and zOrbit parameters. These parameters are measured in degrees.

**XYZ Dolly**

The Dolly parameter dials move the selected camera along the desired axis without altering its orientation, just like a movie camera on a dolly cart, as shown below.
XYZ Scale

As mentioned above, camera scale functions like a zoom lens. The Scale control zooms the camera equally in all three axes. Using the parameter dials, however, you can scale in any amount using any combination of axes to create distorted effects. While this might give the same appearance as distorting the figures/props in your scene, scaling cameras only affects the selected camera; items in your scene are not affected. Decreasing scale values zooms in along the selected axis, and vice versa.

- **xScale**: The xScale parameter changes the camera’s horizontal scale.
- **yScale**: The yScale parameter changes the camera’s vertical scale.
- **zScale**: The zScale parameter changes the camera’s depth scale.
- **Scale**: The Scale parameter dial changes the selected camera’s scale equally along all three axes and functions in the same manner as the Scale camera control. If you have already selected unequal scales using the individual axis controls, the Scale dial/control preserves your previously selected ratios.

XYZ Orbit

The Orbit parameters orbit the selected camera around the indicated Poser workspace axis. It helps to think of the selected axis as the center of a wheel with the camera being at the edge. The camera maintains its distance from the axis and remains pointing in the same direction relative to its starting point. Setting positive degrees of rotation in the Orbit parameter dials orbits the selected camera in a counterclockwise direction around the selected axis, and vice versa.

- **xOrbit**: The xOrbit parameter orbits the selected camera using the Poser workspace’s X axis as the center of rotation.
- **yOrbit**: The yOrbit parameter orbits the selected camera using the Poser workspace’s Y axis as the center of rotation.
- **zOrbit**: The zOrbit parameter orbits the selected camera using the Poser workspace’s Z axis as the center of rotation.
Camera Properties

Cameras have the following properties, available in the Properties palette.

- **Name**: The Name field displays the camera name. Enter a new name in this field if you desire.

- **Visible**: Checking the Visible checkbox makes the camera visible in the Document, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See Figure Properties or information on animating the Visible property. When cameras are visible, you can right-click to display a context menu as described in Cameras Context Menu.

- **Animating**: Check the Animating box to have the selected camera’s movements recorded as keyframes in your animation, or clear it to disable this feature. With this feature disabled, you can still move the camera but its movements will not be recorded as keyframes in your animation. Camera animation allows camera movements to appear as part of rendered movies, allowing for such techniques as follow shots, flyaround views, etc. Please refer to Animating with Poser for more information on creating animations. To enable/disable camera animation, open the Properties palette.

```
When a camera is animated, your view of your scene changes over time, which can add realism and interest to your animation. Watch a movie and notice how often the camera moves. You can animate Poser cameras just like any other 3D object using keyframes and tween frames. Different cameras will animate differently, since they have differing centers of motion.
```

```
You can only use one camera per animation; you cannot switch cameras in mid animation. To do this, create separate clips then edit them together using video editing software.
```

- **Remember changes for Undo**: Checking the Remember changes for Undo checkbox specifies that any camera changes will be included in the Undo/Redo cache. Unchecking this checkbox means that the Undo feature will not apply to camera changes.
Pointing & Locking Cameras

As with any other object in your scene, you can use the Hierarchy Editor (see The Hierarchy Editor) to keep cameras pointed at certain other objects.

Pointing Cameras at Scene Objects

To point your camera at another scene object:

1. Select your desired camera using the Current Actor pop-up.
2. Select Object > Point At to open the Choose Actor dialog.
3. Choose your desired scene object in the list of actors (the camera can point at anything) and click OK.

The camera will point at the selected object and a Point At parameter dial will appear in the Parameters palette for that camera. Setting this parameter to 1 locks the camera on target, and 0 completely disables pointing. Intermediate values cause the camera to lag behind the object it’s pointing at. This parameter allows you to create interesting effects when creating animations.

Disabling Camera Pointing

To disable camera pointing:

1. Select your desired camera using the Current Actor pop-up.
2. Select Object > Point At to open the Choose Actor dialog.
3. Choose None in the list of actors (the camera can point at anything) and click OK.

Locking Cameras

Once you have positioned a camera to your liking, you can lock it to prevent it from being moved. To lock a camera, select it as described above, then select Object > Lock Object. Selecting this option again toggles locking off.

Memorizing and Restoring Cameras

You can use the Edit > Memorize > Camera command to memorize the settings of the current camera. If you later want to return to that camera, choose the Edit > Restore > Camera command to restore the settings back to the camera that you memorized.
Camera Dots

You can save up to nine camera configurations using the Memory dots (described in Memory Dots). Each Memory dot retains the settings for all cameras in your scene. All Memory dots are saved with the application, so your saved camera configurations will be accessible in any Poser document loaded. You can also save camera settings to the Library palette as described below, which would allow you to use your Memory dots for other settings.

Saving Camera Sets

The Cameras category in the Library palette allows you to save camera positions and access them using a few mouse clicks. Camera positions are saved relative to the Poser workspace, not figures or other scene items. Saving camera sets saves all cameras; you cannot save one camera. As with any other Library palette category, you can add subcategories to the Cameras categories. Please refer to The Poser Library for a description of the Library palette, and to Maintaining Your Library Palette for information on adding items to it.

Using Depth Cueing

The Depth Cueing button appears to the right of the Tracking Mode menu along the bottom left of the Preview tab. Selecting Display > Depth Cued also toggles depth cueing on and off.

See for material settings related to Depth Cueing.

*Depth cueing and shadows do not affect your rendered output. It is just a visual indication of the depth of your scene.*

*Depth Cue is not supported in SuperFly.*

Depth Cueing adds dimension to scene elements visible in the Document. When Depth Cueing is enabled, elements farther away from the camera fade into the distance. This provides a quick visual indication of the depth of your scene, which can be helpful if you are viewing it using a single pane. To toggle depth cueing on and off, click the Depth Cueing button in the lower left corner of the document window area.

*Depth Cueing toggle.*

Depth Cueing depends on the total depth of your scene. For example, if your scene consists of a single figure, the portions of that figure farthest from the camera will appear faded out. Adding...
another element (such as a prop) farther from the camera than the figure will cause the prop to appear faded with the figure being more visible. This is useful if you wish to control the amount of depth cueing in your scene.

Depth Cueing fades objects over distance.

To adjust the part of the image that is in focus, change the focus_Distance setting for the camera in the Parameters palette. For more information on this parameter, see Other Parameters.
Lighting

Lights add color to your scene, reveal cues in forms, enhance muscle contours, set moods, cast shadows, etc. Good lighting is a key element of getting your scene to look right when you render it. Lights work in renderings and in the Lit Wireframe and Flat Shaded preview modes (refer to The Display Controls and Menu for information about display styles). You can use as many lights as you need in your scene, with the only limitation being your system’s resources. Poser improves the OpenGL preview of lights in your scenes. It automatically selects the eight brightest lights to display in the real-time OpenGL preview. You can also manually select which eight lights to preview in the Light Properties palette (see Light Properties).

Lights can also help you create effects. For example, you could add a reflection map to an element in your scene, causing it to direct light back at the source. Please refer to Using the Group Editor or an explanation of material groups and to Materials for information on creating material shaders for your scene elements.

The Light controls appear as follows.

Each light has customizable characteristics, such as rotation and revolution positions, color, and intensity (brightness). You can turn lights on or off, adjust how the brightness diminishes as you reach the edge of a light’s range (the falloff), and specify whether or not a light casts a shadow. You can also animate lights to create effects such as lightning or flickering streetlights. As with any other Poser object, you can parent lights to scene elements to have the light move as the source element moves. By default, Poser scenes include three infinite lights.

When you add, remove, move, or adjust lights, the Document, Light controls, and the selected light’s parameter dials automatically adjust to show the light’s new position/properties, allowing you to preview your changes in real time.
Light Types

Poser allows you to create four types of lights: infinite, point, spot and image-based.

When you select a light, Poser displays a light indicator describing your selected light’s position in the Document. In some cases, viewing the indicator from a different angle can help you visualize your light’s position. You can switch Camera views and/or zoom to view light indicators from different angles. Additionally, you can adjust a light’s position by clicking and dragging the light indicator in the actual scene. The Light controls will reflect any changes you make to the light indicator’s position. Note that image-based lights have no light indicators, as they surround your entire scene.

Infinite Lights

Infinite lights are comparable to the sun or moon shining on the Earth. Rays from infinite lights are parallel as they enter your Poser workspace. If you have multiple figures and/or props in your scene, infinite lights shine on each item equally. You cannot place any scene element beyond an infinite light’s range, and no figure/prop can be lit differently than another.

An infinite light’s indicator appears as a ring surrounding the currently selected figure/prop. This ring serves as the equatorial line of an invisible globe with the light shining down on your scene from the point on the equator indicated by the arrows, as shown here.
Then viewed from oblique angles, the circle appears as an ellipse, helping show if the light is in front of or behind the figure. The light is not actually on the edge of the indicator. The indicator simply represents a larger globe encompassing the entire Poser workspace. You can click and drag a light indicator to reposition the selected light.

**Point Lights**

Point lights are similar to a light bulb, in that they emit light from a single source point outward in 360 degrees. These lights are ideal for times when you want an omnidirectional light source that can interact with objects and cast shadows in ways that an infinite light cannot. For performance reasons depth mapped shadows are not supported for point lights; point light shadows must be calculated using raytracing.

A point light’s indicator appears as a small outlined circle, depicting the light’s position in 3D space (remember, you can position point and spotlights in 3D space, unlike infinite lights), as shown here.

As point lights emit light equally in all directions, there is no direction indicator as with a spotlight.

**Spotlights**

Spotlights cast light in a specific direction, throwing light along a cone-shaped path to create a classic stage spot effect. These lights are useful for illuminating specific objects or for creating lighting effects. Spotlights can increase rendering times.

A spotlight’s indicator appears as the outline of a spotlight in your Poser workspace depicting both the light’s position in 3D space and the direction the light is pointing, as shown in this image.
Spotlight Indicators.

Clicking and dragging a spotlight’s indicator moves the light around the scene.

You may want to use orthographic views (Left, Right, Top, Bottom, Front, or Back) to move Spotlight indicators, since doing so constrains the spotlight’s motion to two dimensions (YZ if using the Left or Right views, XZ if using the Top or Bottom views, and XY if using the Front or Back views). Using perspective views can move your spotlight in oblique directions, causing unexpected lighting effects.

Diffuse Image-Based Lights (IBL)

Diffuse Image-Based Lighting (Diffuse IBL) takes a light probe, which is ideally a 360 degree light distribution map captured in a single map, and illuminates the scene using that map. In Poser, only the diffuse component of the light is defined by the light probe. As this technique is based on complete light data for a given space, the lighting results are very realistic. In order to get realistic shadows when using an image-based light, we recommend using Ambient Occlusion (see Light Properties). You must activate raytracing in the Render Settings dialog in order to render Ambient Occlusion effects.

To attach a light probe to the image-based light, press the Advanced Material Properties button on the Properties palette (see Light Properties. Once in the Material room, you have the option of attaching simply a light probe image map, or a shader tree of any complexity, to the color channel of your Diffuse IBL.

Poser has the ability to apply the full functionality of its procedural shading system to an image map used as an image-based light. See Materials for more information about the image node manipulations available using the shading system in the Material room.
Area Lights

Area lights simulate real lights more accurately. They work a lot like a photographer’s “soft box” light. You can adjust the size to control the amount of light that is emitted.

Area lights are represented by a square outline that depicts the light position in 3D space. A dotted line protruding from the light shows the direction that the light is pointing.

![Area Light Indicators](image)

Click and drag the area light indicator to reposition it in the scene. Use the Parameters palette to scale the light.

Light Properties

Light properties help you fine-tune your lighting effects. To access a light’s properties, select the light and either click the Light Properties icon in the Light controls or select Object > Properties. You can also access light properties in the Properties palette.
Light Properties.

Depending on the light type that you select, you can control some or all of the following light properties:

- **Include in OpenGL Preview**: By default, Poser displays the eight brightest lights. Users can optionally choose which eight to display. By providing real time previews of eight user-selectable lights, posing and lighting is faster and yields better results. Use this option to select each light you want to illuminate the scene preview. Mip Map support has been enabled for enhanced performance when previewing large textures. Together, these real-time preview engine enhancements let the user view larger textures and offer more complete scene previewing when setting up lights. If your scene has more than eight lights, you can check or uncheck this option to include or exclude the current light from the preview display.

- **Visible**: Checking the Visible checkbox makes the light visible in the **Document**, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See **Figure Properties** for information on animating the Visible property.

- **Animating**: Checking the Animating checkbox allows you to animate the light just as you would any other Poser object. Animated lights can also have different settings in various keyframes. For example, you could create a red spotlight on your figure’s left side that orbits overhead and turns blue. When you rendered this animation, you would see your
figure’s color changing and shadows moving with the light. You cannot animate lights that are turned off (see above).

- **On/Off**: Checking the On box turns the light on, just like flicking its switch. Clearing the checkbox turns the light off. As a shortcut, you can also press OPT/ALT while clicking a light in the **Light** controls to toggle the selected light on or off.

- **Spot/Infinite/Point/Diffuse IBL/Area Light**: Check the appropriate radio button to make your selection.

- **Shadows**: Checking the Shadows checkbox enables you to choose one of the following two options:

  - **Raytrace Shadows**: Selecting Raytrace Shadows enables raytracing of shadows. Traditionally, raytracing results in clear, hard-edged shadows. However, Poser offers a method for softening the shadow edges, thus adding more realism to your raytraced shadows. You can control this effect using the Shadow Blur Radius dial (see below).

  - **Depth Map Shadows**: Selecting Depth Map Shadows enables depth-based shadow mapping. If you are using displacement maps, we recommend you select this option rather than raytracing, for greater accuracy. Enabling this option activates both the following dials:

    - **Shadow Blur Radius**: All shadows have a blurry region around their edges. The Shadow Blur Radius parameter specifies the radius of this blurry region. By default, this dial is set to a low value. Raising the blur radius increases the soft shadow edge effect.

    - **Shadow Samples**: The Shadow Samples parameter controls the smoothness of shadows. The default value is equivalent to earlier Poser versions that used a fixed quality. Lower shadow sample settings render faster but may produce grainier shadows with a random dither. Higher shadow samples reduce the graininess that can sometimes be seen in soft raytraced shadows. As a general rule, the larger your Shadow Blur Radius setting is, the more you will need to increase the Shadow Samples to get a smooth result.

    - **Shadow Min Bias**: The Shadow Min Bias parameter specifies how far to shift samples towards the light source to prevent self-shadowing of objects.

- **Preview Shadow Map Size**: Sets the amount of detail in the shadows that are displayed by the preview render. Default is 512. Higher values will make the shadow preview more detailed and accurate but will increase usage of system resources.

- **Ambient Occlusion**: Checking the Ambient Occlusion checkbox enables Ambient Occlusion for the selected light. Ambient occlusion adds realism to your scene by approximating the way light and shadows act in real life. It helps bring out details in creases and corners. This option provides the advantage of calculating Ambient Occlusion effects on all surfaces within the scene, without having to attach an Ambient Occlusion node to every material. Enabling this option activates the following controls:

  - **Strength**: The Ambient Occlusion Strength dial specifies the degree to which Ambient Occlusion effects will darken the occluded surfaces within the scene.

  - **Ambient occlusion on lights is not supported in SuperFly.**
• **Scene AO Options**: The Scene Ambient Occlusion Options button provides access to the global set of Ambient Occlusion parameters. These parameters are described in Ambient Occlusion (Ambient_Occlusion).

![Scene Ambient Occlusion options.](image)

Atmosphere Strength control.

• **Atmosphere Strength**: The Atmosphere Strength dial and field allow you to specify the strength of atmospheric (volumetric) effects. This attribute is used in conjunction with the Root Atmosphere node, which is described in Root Atmosphere Node.

![Atmosphere Strength is not supported in SuperFly.](image)

• **Set Parent**: Clicking the Set Parent button allows you to make the light a child of another element in your scene.

• **Color**: Clicking the Color button opens the Poser Color Picker, allowing you to set the light’s color.

• **Advanced Material Properties**: Clicking the Advanced Material Properties button will automatically take you to the Material room, with the current light active in the Shader window’s Advanced tab. Please refer to Edit View for more information about the Edit view of the Shader window, and to Root Light Node for more information about the root Light node attributes.

• **Attenuation**: (Enabled for Spot lights or Point lights only): This setting controls how bright or dark a spot light or point light gets based on the distance away from the light source. Options for spot and point lights are:

  • **Constant**: Behaves the same as Poser 7 and earlier lights. This setting is predictable and controllable. The Start Distance and End Distance parameters are very useful for setting how close or far the light reaches.
Constant Attenuation.

Constant Attenuation with Tone Mapping.

- **Inverse Linear**: Use this option for lights that are more physically correct. Objects that are close to the light source are infinitely brighter (not exponentially, but linearly). In other words, if Object B is twice the distance from the light as Object A, then Object B receives half as much light as Object A. This option allows some artistic freedom without being as touchy as Inverse Square (described next).
Inverse Square: This option provides physically correct lighting that is more dramatic, and harsher than Inverse Linear. The light brightens exponentially as you get closer to the light source. If Object B is twice the distance from the light as Object A, it receives 1/4 the amount of light.
Light Parameters

Be sure to select the light you wish to work with before using the parameter dials to avoid accidentally changing settings for the wrong light. Once you’ve adjusted a light the way you
want it, you can use the Lock Object command (see Lock Object) to prevent accidental changes. Lights have the following parameters, available in the Parameters palette:

![Light Parameters.](image)

**Angle Start/End (Spotlight Only)**

The **Angle Start** and **Angle End** values allow you to specify how a spotlight’s light “falls off” as you approach the edge of the cone of light projected by the spotlight. The Angle Start parameter specifies the degree angle below which the light will be at full intensity, and the Angle End parameter specifies the point above which the light will be at zero intensity. For example, when the Angle Start is set at 30, and the Angle End is set at 100, the light will be constant from 0-30 degrees, will gradually fall off between 30-100 degrees, and will be off above 100 degrees.

**Distance Start/End (Spotlight, Point and Area Lights)**

As you know, light fades with distance from its source. The **Distance Start** and **Distance End** parameters specify the distance from the light source (in grid units) where the spotlight’s intensity begins to drop (fall off), and the distance in grid units when the spotlight is no longer casting light, respectively.
Shadow

Poser lights can cast shadows, if you enable this option using the selected light’s Cast Shadow property in the Properties palette as described above. Shadows add depth, realism, and dramatic effects to your still or animated scenes. To change the cast of a light’s shadow, move the light.

Spotlights cast shadows based on the spotlight’s angular range, meaning that tighter spotlights produce cleaner shadows. By contrast, infinite lights adjust the view to fill the screen with all objects that cast shadows. Because of this, if you render a close-up of a scene with many figures and/or props (especially widely spaced items), the shadow map will not contain much information.

Each light has a shadow camera, available using the Current Actor pull-down menu. Advanced users can aim these cameras as desired. Each light’s shadow map contains shadow information for the scene as viewed through that light’s shadow camera.

The shadow-related parameter dials are:

- **Shadow**: Use the Shadow parameter dial to specify the selected light’s shadow strength. A setting of 0 disables cast shadows for the selected light, while a setting of 100% casts a dark shadow. You can animate shadow strength over time.

- **Map Size**: The Map Size parameter dial sets the size of the selected light’s shadow map in pixels (shadow maps are square). Poser uses image maps to apply shadows to objects in the scene, and applies these shadows during rendering. Larger map sizes increase the accuracy and detail of shadow maps, but at a cost in memory and render time. For example, each 1024x1024 map requires about 4MB of space, while a 2048x2048 map requires 16MB. You cannot animate the shadow map’s size.

Red, Green, Blue

The Red, Green, and Blue dials specify the amount of each of the three primary colors to add to a light’s final color. A value of 1 means that the selected color is fully added, and 0 means that color is not included at all. Using these three primary colors to create a final color is called RGB lighting (Red, Green, Blue). Each of the three colors can have 256 values ranging from 0 to 255. This gives us 256 red, 256 green, and 256 blue shades to work with, or $256^3 = 16,777,216$ total possible colors. Parameter dial values correspond to RGB values as follows:

Parameter dial 0 = RGB color value 0 for the selected color.

Parameter dial 1 = RGB color value 255 for the selected color.
Intensity

You can control your light’s intensity using the Brightness control or the Intensity parameter dial. A setting of 0% means the light is fully off, and a setting of 100% means the light is completely on (at full brightness/intensity).

XYZ Rotation

Adjusting these dials adjusts the direction in which the light is pointing. For example, think of the sun’s path across the sky throughout the day and how it appears farther north or south with the changing of seasons. When the xRotate and yRotate dials are set to 0 degrees, the light aims at the Poser workspace from the front. ZRotate is only significant when the xRotate and yRotate settings are not 0,0 or 180, 180. In all cases, the figure is in the default position.

xRotate: The xRotate parameter rotates the selected light about the X axis.

yRotate: The yRotate parameter rotates the selected light about the Y axis.

zRotate: The zRotate parameter rotates the selected light about the Z axis.

Scale

The Scale parameter dial allows you to scale a light’s indicator. This does not affect the light itself.

xScale and yScale (Area Lights only)

Allows you to scale the area light indicator horizontally or vertically.

XYZ Translation (Spotlights, Point Lights and Area Lights)

The Translation dials allow you to specify a spotlight’s precise location in 3D space by specifying grid coordinates. As previously described, spotlights emit light from their location in 3D space, meaning that objects “behind” the light are not illuminated.

Working with Lights

Selecting Lights

You can select lights as follows:
Clicking one of the Lights in the Light Position indicator.

Using the **Current Actor** pop-up menu.

**Creating Lights**

To create a light, click the Create Light icon in the **Light** controls, or click on Create Light in the Light Options pop-up menu. You will be prompted to create a light type (**Spot**, **Infinite**, **Point**, **Diffuse IBL** or **Area**).

![The Create Light icon.](image)

Alternatively, you can choose **Object > Create Light** and select the type of light from the popup menu that appears.

![Creating a light with the Object menu commands.](image)

*Newly created lights will be created near the origin of the scene. You can move the lights to any location or orientation using the Posing tools.*

To change a light to another light type, select the new light and click the Light Properties icon (see **Light Properties** for information about light properties).
If you select the Diffuse IBL light type, the Texture Manager window will open, and you can choose an image to use for the diffuse IBL. When you select a high dynamic range format (HDR or EXR), the light's material will automatically be configured to serve as an HDRI-IBL. If the image format is any other file type, the light will be configured as a standard dynamic range IBL.

After selecting the image, choose OK. Poser will ask if you want to activate Ambient Occlusion for the light, which is only relevant to FireFly. Choose No to create the IBL light without Ambient Occlusion, or Yes to add Ambient Occlusion. The preview window will update with the lighting changes. For more information on Diffuse IBL lights, see Diffuse Image-Based Lights (IBL).

SuperFly will always calculate light based on realistic light behavior. Therefore, no ambient occlusion is necessary.

Adjusting Light Intensity

You can set a light’s intensity using the Brightness control like a dimmer switch. Click and drag the brightness indicator to the left to dim the selected light, or to the right to brighten it.

You can also set the light’s intensity using the parameter dials in the Parameters palette.
For image-based lighting, you must adjust the light intensity in the Advanced tab of the **Material** room. Take care when making these adjustments, so that your results will approximate the realism of the lighting conditions in the image map you have selected.

You can set a light’s intensity to a negative value, thereby creating a “non-light” that will actually darken the affected area(s) of your scene. You can use this feature to create interesting effects.

**Light Color**

Light colors contribute to your scene’s overall appearance and mood. Unlike paints, light colors multiply instead of mixing and adding to one another. For example, a red figure with blue lighting would appear black, not purple. If you don’t want a light to affect the color of items in your scene, set that light’s color to white or gray. Because of this relationship between scene items and lights, you might want to set your scene items’ colors before setting lighting colors. Note that with image-based lighting, you should generally use a white color, so as not to interfere with the light colors already contained within the image map.

To change a light’s color, click the Color icon in the **Light** controls to open a standard Color Picker dialog. Make your selection, and your selected light will change to its new color.

Two icons appear in the upper-right corner of the Light Color picker. The first icon opens the Material Editor, where you can add advanced material properties to the light. The other icon opens your standard system color picker.

You can also set a light’s color using the parameter dials in the **Parameters** palette. For image-based lighting, you can use the Advanced tab of the **Material** room to plug any image node into the color channel of that light. Doing so will allow you to see the effects of the image-based light on any surface in the **Material** room, which will give you an exact idea of how those surfaces will be shaded in the final render.
Delete Light

Select the light you wish to delete and click the Delete Light icon in the Light controls, or click on Delete Light in the Light Options pop-up menu.

Animating Lights

Lights can be animated like other Poser objects using keyframes and tween frames. Please see Animating with Poser for information about animating within Poser.

Saving & Loading Light Sets

You can save light sets to the Library, allowing you to reuse them in later scenes. Light sets have the file extension *.LT2 and are saved to the Lights Library. Please refer to Maintaining Your Library Palette for information about adding items to the Library palette.

Memorizing and Restoring Lights

You can use the Edit > Memorize > Lights command to memorize the settings of the lights in your scene. If you later want to return to those light settings, choose the Edit > Restore > Lights command to restore the settings back to those that you memorized. If you delete lights after you memorize light settings, the deleted light(s) will not be restored.

Aiming Lights

Spotlights, infinite lights and area lights are directional light sources, and therefore can be aimed with relation to your scene. You should finish posing your figures and positioning your props before aiming your lights. Doing this in reverse will cause your scene elements’ appearances to change as you move them. For example, rotating a figure 180 degrees causes illumination falling on its front to fall on its back. You may need to re-aim your lights to continue working. Some traditional artists place a bright light above and to the left of a figure. Using a strong single light source lets you see shading on distant and oblique surfaces, contributing to the scene’s depth and curvature. You may want to read books on lighting, including using lights in photographic studios, to give you ideas on using lights to enhance your Poser scenes.

If you import a background image or movie, you should set your lights to mimic the lighting in the background. For example, if your background image shows a strong light coming from the figure’s right, don’t light the figure from the left. This will help preserve consistency between your scene and the background and help integrate both elements together. Ideally, when working with backgrounds, you should have the background look like part of your scene. If your
scene is a room using an image of a brightly lit background visible through the windows, you should have most of your lighting streaming in through the windows to blend the room and its contents with the outside world and lend realism to your scene.

You can aim lights using any of the following methods:

- Using the Light Position control (see below).
- Moving a light’s indicator in the Document (see below).
- Using the Editing tools (Rotate and Twist for infinite lights, and Rotate, Twist, Translate/Pull and Translate In/Out for spotlights and area lights. Please refer to The Editing Tools for information on using the Editing tools).
- Using the selected light’s parameter dials in the Parameters palette.
- Using the Object > Point At (Point At) or Object > Set Parent (Changing a Parent) menus.
- Using the desired light’s Shadow camera, described below.

As discussed above, infinite lights always shine into the scene. Aiming an infinite light sets the location from which the light shines (such as setting the sun’s position in the sky). When aiming spotlights, you’re setting both the angle at which the light shines and the light’s position in 3D space.

**Using the Light Position Control**

The globe in the center of the Light Position indicator represents your Poser scene in 3D space, and the light dots represent the positions of each of the lights within your scene. These dots can be moved in two ways with respect to the globe: Rotation and Revolution. Rotation keeps the light in the same physical position relative to the scene, but adjusts its direction around its own local axis. Revolution moves the light around the globe to a new position relative to the scene, while keeping the light pointed at its parent, as shown in the figures below. You can select which positioning method you wish to use by clicking either Rotate or Revolve in the Light Options popup menu. The check mark indicates which option is currently selected. Then click and drag your selected light dot(s) to change their position and/or direction. Revolving these dots to different positions around the globe adjusts the lighting angle, as shown below.
Viewing through Shadow Light Cams

You can use one of the Shadow Cam light cameras to view your scene through a specific light. Right-click on the camera name in the upper-left corner of the document window, and choose Camera View > Shadow Cam Lite X, where X is the number of the light that you want to view the scene through.

Choosing a Shadow Cam.

When viewing the scene through a shadow camera, its light indicator will always appear in the center of the light position control. Use gentle movements to reposition the light indicator,
remembering that it always appears in the center as the view in the camera view changes. You can also use the parameter dials for the selected light to reposition the light as needed.

*Viewing through a Shadow Cam.*
Materials
The Material Room

Poser’s Material room is a very powerful tool for creating and editing procedural shaders for the content in your scene. The Material room is designed from the ground up to provide the ultimate in power, flexibility, and ease of use by artists and animators. You don’t need to be a programmer! The Material room gives you ultimate control over the appearance of your Poser scenes.

The Material room allows you to describe the material properties of your objects’ surfaces by giving you full control over every aspect of shading a surface, from the surface color to complex lighting interactions.

In this chapter we will explore the Material room’s basic building blocks. For a more detailed look at working with shaders and nodes in the Material room, please refer to Working with Nodes and Root Nodes.

Access the Material room by clicking the Material room tab at the top of the Poser workspace. The Material room appears as follows.

The Material room offers two options for working with surface materials: the Assign view and the Edit view tabs. By default, the Assign view of the Material room is displayed when you...
first start up Poser. This allows new users to get familiar with assigning Materials before diving into the Advanced settings of the Material room.

Poser’s Material room contains the following items at 1280 x 960 resolution. Less items will appear at lower resolutions, and more options will appear at higher resolutions.

1. **Eyedropper Tool**: The Eyedropper tool appears with the Editing tools. Enabling it and clicking an object in your scene opens that object’s shader tree for editing in the Shader window.


3. **Camera Controls**: Please refer to Camera Controls.

4. **Light Controls**: Please refer to Lighting for information about the Light controls.

5. **Document Display Styles**: Allows you to select one of several different display styles for the elements in your scene. See The Display Controls and Menu for more information about the various display styles.

6. **Pose, UI and Camera Dots**: Allows you to store figure poses, user interface settings, and camera settings for retrieval at any time until you close your Poser document. See Memory Dots.

7. **Animation Controls**: Please refer to Using the Animation Controls for information about the Animation controls.

8. **Assign Tab**: Click this tab to use the Assign view to copy properties from a library material or material collection to the currently selected object. For more information, see Assign View.

9. **Edit Tab**: Click this tab to edit or create advanced shaders that you can apply to your objects or save to the library. Shaders consist of a root node and as many connected nodes as you need to create a specific type of material. Please refer to Working with Nodes and Root Nodes for more information about working with shaders and nodes.

10. **Object selection**: Click the down arrow to select one of the objects in your scene.

11. **Current Material List**: The Current Materials list displays all of the material groups in the currently selected object. Poser organizes materials by figure/prop, thereby avoiding confusion when assigning materials and allowing you to, for example, assign different eye or skin colors to each figure.

12. **Material Room Help**: The (?) icon at the top right of the Shader window opens the Material room Help document. This HTML document contains information about using nodes and shaders to define surface material attributes.

13. **Options pop-up menu**: Click the white right-arrow to display the Options pop-up menu in the Advanced tab of the Shader window. This allows you to add, cut, copy, paste, select, and deselect nodes. For convenience, this can be also accessed by right-clicking within the Advanced tab. The Drag-Dock enable button, just to the right of the Options button, allows you to set the Material window to a dockable or undockable state. Undocking, for example, would allow you to move the Material window to a second monitor.

14. **Material Palette**: Drag a material or material collection from the library and drop it into the preview thumbnail area. A list of the materials will appear and you can select all or some of the different material zones to transfer to your selected object.
Using Objects with Multiple Materials

Each figure/prop has its own unique material list containing individual materials within that list. You can see this for yourself by creating a Poser scene with two or more figures/props and opening the Material room.

This sample scene has two figures. The Material room therefore displays the following selections:
As you can see, the two figures in this image each have different materials lists. Each object in a Poser scene has its own list of materials, which is different for each object.

**Assign View**

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Material Room: Assign view**
Sections in the Assign View

The Material Assignment window contains the following key areas:

1. **Assign Tab**: Click this tab to view the Assign tab in the Material Room (as discussed in this topic).
2. **Edit Tab**: Click this tab to display the Edit tab, where you can create advanced shaders and materials. The [Edit View](#) topic gives a brief overview of this tab and provides links to more advanced topics.
3. **Object Selector**: Allows you to select any character or prop or other items in your scene. The materials included in the selected object will appear in the Object Materials tab (7). You can also select an object by clicking it with the Eyedropper editing tool.
4. **Material Selector**: Allows you to choose a single material in the selected object. The materials included in the selected object will appear in the Object Materials tab (7). You can also select a material by clicking it with the Eyedropper editing tool.
5. **Help icon**: Click the Question Mark icon to display room help for the Assign tab.
7. **Material Palette** section: See [Material Palette](#), below.
8. **Apply Material** button: Select at least one material from the Material Palette column, and one material zone from the Object Material column to assign materials to the scene.

Object Materials

The **Object Materials** section (#6 above) lists the material zones that exist in the currently selected object in your scene. The changes will be applied to any or all of the materials in the list.

- To change all of the materials in your selected object, choose **ALL**.
- To change some of the materials in your selected object, check the box beside the materials you want to change.
- You can also drag and drop materials from this list onto another object in the Scene window.

Material Palette

The **Material Palette** section (#7 above) allows you to preview a material before you apply it to an object in your scene. You can also drag and drop from this column to the Object Materials, or directly to any object in the scene.

1. Use the **Object Selector** (#3 above) to choose the object that you want to assign materials to. The materials in the object display in the **Object Materials** section.
2. Drag a material from the library and drop it onto the material preview chip at the top of the **Material Palette**.

3. Check the material(s) in the **Material Palette** that you want to apply to the selected object.

4. Select the material zone(s) in the **Object Materials** section that will receive the materials you selected in Step 2.

5. Click the **Apply** button.

Several use case examples are shown below.

**Assigning Materials**

**Assigning a Single Material (MT5)**

MT5 materials are used to apply a single material to any material zone in a figure or objects. MT5 materials are often tileable, so that they can be applied to any object. This shows how to assign a single material to one material in an object.

1. Use the **Object Selector** (#3 above) to choose the object that you want to assign materials to. The materials in the object display in the **Object Materials** section.

2. Drag the new material you want to use from the library to the top of the **Material Palette** column.

3. Check one material zone in the **Material Palette** column.

4. Check one material zone in the **Object Materials** column.

5. Then click **Apply**.

![Assigning a Single Material](image-url)
Copying a MT5 Material to Multiple Zones

You can also apply MT5 materials to multiple material zones in a figure or object. This shows how to assign a single material to one material in an object. The steps are similar to the above, except that you select two or more materials to apply to in the Object Materials panel.

1. Use the Object Selector (#3 above) to choose the object that you want to assign materials to. The materials in the object display in the Object Materials section.
2. Drag the new material you want to use from the library to the top of the Material Palette column.
3. Check one material zone in the Material Palette column.
4. Check two or more material zones in the Object Materials column.
5. Then click Apply.

Assigning a Material to Multiple Zones.

Assigning a MC6 Material Collection

Material Collections (MC6) are used to combine several material zones found in a content item into one single material file. For example, a material collection can contain all of the different materials in a human character (head, torso, limbs, eyes, lashes, nails, and so on), or all material zones in a piece of clothing (blouse, sleeves, pockets, buttons, and so on). When assigning MC6 materials, you will need to use material collections that are made for that specific character (La Femme, Victoria 4), or that specific clothing or prop item.

To completely replace the material collection in the selected object:

1. Use the Object Selector (#3 above) to choose the object that you want to assign materials to. The materials in the object display in the Object Materials section.
2. Drag the material collection from the library to the top of the Material Palette column.
3. In the Material Palette column check ALL.
Assigning a Material Collection

Applying Part of a MC6 Material Collection

Sometimes you want to keep some materials in your object, but replace others. This is easy enough to do in the Assign tab. For example, if you only want to change the skin and lips on a figure, but keep the eyes, inner mouth, and nails as they are, you would proceed as follows:

1. Use the Object Selector (#3 above) to choose the object that you want to assign materials to. The materials in the object display in the Object Materials section.
2. Drag the material collection from the library to the top of the Material Palette column.
3. In the Material Palette column check only the materials you wish to apply (the skin materials and the lips).
4. In the Object Material column check the material zones you wish to apply the material to (the skin materials and the lips).
5. Click the Apply button. The materials will be applied only to zones with matching names.
Assigning Part of a Material Collection.

Edit View

The Edit view of the Material room is where you build shaders by working with nodes. Please refer to Working with Nodes and Root Nodes for more information about shader nodes and how they function within Poser.
The Edit view contains the following elements:

1. **Object menu**: The Object menu functions similarly to the **Current Actor** menu and has the following options: Props (includes strand-based hair and dynamic cloth), Lights, Figures, and Background.

2. **Material menu**: The Material pull-down menu lists all of the materials available for the currently selected actor. Poser uses Multi/Sub-object materials, which means you will only see the materials assigned to the currently selected figure/prop in this menu.

3. **Options Menu**: Clicking the arrow on the right side of the Shader menu opens the **Options** menu for the **Material** room. You can also open this menu by right-clicking in any blank area within the Shader window or by clicking any node input (see Working with Nodes and Working with Nodes).

4. **Title Bar**: You can reposition the Shader window using its title bar.

5. **Wacro Drawer**: The Wacro Drawer allows you to select from ten predefined shortcuts that cover various material setup tasks. See for specific information on these shortcuts.

6. **Root Node**: The root node for the currently selected object or material group appears on the left side of the Shader window.

7. **Nodes**: Additional nodes also appear in the Shader window.

8. **Layers**: Click to select another layer in a multiple-layered material.
Creating Layered Materials

Layered materials allow you to create advanced material shaders for SuperFly.

Layered materials will not render in Firefly.

To create a layered material,

1. Switch to the Edit material view.
2. The material layers list appears in the upper left corner of the material window. You can use this list to choose between the base layer and any additional layers that have already been created.
3. To add a layer, click the Add Layer button (+ sign) that appears to the right of the material layer list.

4. The material view will immediately switch to the new layer, which contains a PoserSurface node with no connections. You connect material nodes to this PoserSurface node in the same way you connect nodes in the base layer.
5. Verify that the SuperFly Root checkbox is checked in the top section of the Poser Surface node. Even though the FireFly Root is checked, layered materials do not render in FireFly.

Using Layer-Only Materials

Layer materials are a special type of material that adds a layer to an existing base material. Essentially, a layer-only material is a partial material file that does not have a base layer. Unlike a conventional material they never replace the material that's already loaded. A Layer material always adds another layer. This makes this type of material ideal for use as a add-on to other
Layer materials can be used to add makeup, dirt, scars, tattoos and other details to an existing material.

Layer materials can contain multiple materials in a single file the same way a Material Collection contains multiple materials. The material layer is meant to be used in conjunction with a base material but the base material is saved as a Material Collection (MC6 extension for uncompressed, and MCZ extension for compressed).

Layer-only materials will be saved to the library with a new file extension and file type icon to differentiate from a regular material collection. The MLC extension will be used for uncompressed Layer-Only materials, and the MLZ extension will be used for compressed Layer-Only materials.

Creating Layer-Only Materials

To create a Layer-Only material, follow these steps:

1. Open the Material Editor in Edit view and select the material to which you want to add a layer.

2. Click the Material Layers button at the top of the editor window. The Material Layers window opens. The Base layer, and any other existing material layers will be shown in the list.

Material layers only work with the SuperFly render engine. When rendered using FireFly they simply won’t render.

Layer-Only materials will also work in Poser 12, build 1029.

• Applying the first layer-only material to a base layer will add a layer above the base.

• Applying another layer-only material will not replace an existing one. A new layer-only material layer will be added to the existing layers.
Material Layers window.

3. Click the + (plus) button to add a new material layer. The layer will be placed above any existing base or material layers, similar to image layers in Photoshop. By default, the layer will be named Layer_x, with x being the next available layer number.

4. Click the Rename button to enter a more descriptive name for the material layer.

Renaming a material layer.

The Material Layer Editor allows you to manage layers in a material. The [+} and [-] buttons allow for adding and removing material layers. The Rename button brings up a dialog to enter a name for the selected layer. The up and down arrows move the selected layer up and down the layers.

Building the Layer-Only Layer

Use the Edit view in the Material window to build your material layer. Keep in mind that material layers work in SuperFly only, so you may prefer to use the Physical Surface root, or the Cycles Surface root with the Principled BSDF node.

In this simple example, the Physical Surface root is added for SuperFly materials.

- The Color channel is used to define the eye shadow color.
- A mask that designates the eye shadow area is attached to the Transparency input, which is set to 1.
- A Cycles > Color > Invert node is used to invert the eyeshadow mask for the Roughness input. The darker areas will appear more glossy, and the white areas will allow the
roughness from the base area to remain unaffected. The Roughness is set to .5 in the Physical Surface node.

- A 3D Textures > Spots node is used to simulate metallic flakes. A Color Math node multiplies the spots with the eyeshadow mask to only apply the spots to the eyeshadow. Then it connects to the Metallic input of the Physical Surface node, with the value set to 1.

```

Managing Material Layers

The Material Layers window also allows you to manage material layers as follows:

- Use the - (minus) button to delete the selected material layer.
- Use the up arrow to move the selected layer toward the top of the layer stack.
- Use the down arrow to move the selected layer toward the bottom of the layer stack. Layers cannot be moved below the base layer.

Saving Layer-Only Materials

To save your material layer to the library, follow these steps:
```
1. Select the figure or object that contains the materials that have layers you intend to save to the library.

2. Select the Materials category from the Poser Library.

3. Create or navigate to the folder that you want to use for your materials and material layers.

4. At the bottom of the library click the (+) button to add a library item. The New Material Set window appears.

5. Name the material layer appropriately. In this case, the name is set to Eye Shadow Light Blue.

6. Select the Material Layers radio button at the bottom of the New Material Set dialog. This option will be grayed out if the selected object has no materials.

7. By default, all of the layers in all materials of the selected object will be saved. To choose specific materials or layers, click the Select Layers button. Then check the options you want to include, and uncheck the options you want to exclude. Click OK to confirm the layer selections.

8. When you return to the New Material Set window, click OK to save the material layer to the library.

![Saving a material layer.](image)

## Wacros

Wacros are easy-to-use scripts designed to complete specific tasks within the **Material** room. The Wacro Drawer comes with ten predefined Wacros, each of which accomplishes a basic material setup task or process—often with the click of a single button. You can save time by using Wacros for some of the more common tasks you might wish to undertake in the **Material** room. Wacros all act upon the root node for the selected object or material. For more information on the various attributes on the root nodes, please see **Root Nodes**.

Poser also supports user defined Wacros, which you can write using Python scripting, and then place in the `Runtime\Python\poserScripts\Wacros\UserDefined` folder within your Poser installation folder. Your Wacros will then appear in the User Defined pop-up menu. Please see **Using PoserPython** for more information about writing Python scripts for Poser.
Material Wacros.

The following Wacros are included with your Poser installation:

- **Add Reflection**: Before clicking the Add Reflection Wacro button, make sure you have selected a material to which you want to add reflective attributes. When you click the Add Reflection button, Poser will attach the following nodes:
  - A Reflect raytrace node will be attached to the input of the Reflection_Color attribute on the root Material node. The Reflect node specifies the reflection color when raytracing. See Reflect for more information on the Reflect node’s attributes.
  - A BG Color node will be attached to the input of the Background attribute on the Reflect node.

- **Add Refraction**: Before clicking the Add Refraction Wacro button, select a material to which you want to add refraction. Refraction causes light to bend as it passes from one transparent medium (material) to another; the degree to which this occurs depends on the material’s refractive index. Note that refraction only affects transparent materials, so the material you select must be made transparent for refraction to be visible. Click the Add Refraction button. If you have selected a material that is opaque, a dialog will appear
asking whether you wish to make the material transparent and add refraction. Click Yes on this dialog to proceed. Poser will then add the following nodes:

- A Refract raytrace node will be attached to the input of the Refraction_Color attribute on the root Material node. The Refract node specifies the refraction color when raytracing. See Refract for more information on the Refract node’s attributes.

- A BG Color node will be attached to the input of the Background attribute on the Refract node.

- Set the Refraction_Value attribute on the root Material node to between zero and one in order to see the refraction effect in your rendered image.

**Refraction requires raytracing, so be sure to have raytracing selected when you render in order to see the refraction effect. We also recommend setting the number of raytrace bounces to at least two (or higher if you have reflective surfaces behind the transparent materials).**

- **Add Skin Subsurface Scattering**: Clicking the Add Skin Subsurface Scattering Wacro button will apply a Subsurface Skin node to the selected material. The node will be attached to the Alternate Diffuse input of the PoserSurface node, and the Alternate Diffuse color will be set to white.

- **Set Up Shadow Catcher**: Clicking the Set Up Shadow Catcher button will enable the ShadowCatchOnly option on the Poser Surface node of the selected material. This Wacro will turn the selected material into a shadow catcher, which means that it will become transparent except for areas that are shaded by another object, which will show only the shadow. One example of how you might use this Wacro is if you created a scene showing a figure on the stairs prop, and you wanted to hide the stairs in order to composite the figure onto a photograph of actual stairs. For more information about the ShadowCatchOnly attribute, and shadow catchers, see Root Material (PoserSurface) Node.

- **Set Up Toon Render**: The Set Up Toon Render Wacro will configure your material to appear cartoon-like when rendered. Clicking the button opens a dialog asking whether you want to have specular highlights on your toon surfaces. Click either No or Yes on this dialog to proceed. Poser will then attach the following nodes:

  - A Toon diffuse node will be attached to the input on the Alternate_Diffuse attribute of the root Material node. See Toon for more information about the Toon node’s attributes.

  - Two additional links will be created from the output on the material’s Image_Map node, to the inputs on the LightColor and DarkColor attributes on the Toon node.

  - If you clicked Yes on the initial dialog, a Glossy specular node will be attached to the input on the Alternate_Specular attribute of the root Material node. See Glossy for more information on the Glossy node’s attributes.

- **Create Atmosphere**: In order to view the effects of the Create Atmosphere Wacro, you need to have something in the background of your scene, such as a background plane or additional figures or props. Then, select Atmosphere from the Object menu at the top of the Shader window. Clicking the Create Atmosphere button opens the Choose an
Atmosphere dialog. Select the type of atmosphere you wish to create, from the following options: Fog, Smoke, SmokeyRoom, Depth_Cue. Then click OK. Poser will add the appropriate nodes to create the atmosphere you have selected. If you wish to know more about any of the specific nodes added, see Root Atmosphere Node. Render your scene to view the atmosphere effects.

- **Set Up Light Style**: The Set Up Light Style Wacro allows you to specify the style of light you wish to apply to a particular light. First, select the light you wish to configure from the Object menu at the top of the Shader window. Then click the Set Up Light Style button. The Select a light style dialog will appear, asking you to select a light style from the following options: diffuse only, specular only, white only. When you have made your selection, click OK. You will see a message confirming that the light(s) you had selected have been set to the light style you specified. Depending on the light style you selected, you will see the following effects:
  
  - If you selected diffuse only, the Diffuse attribute on the root Light node will be set to white, and the Specular attribute will be set to black.
  
  - If you selected specular only, the Specular attribute on the root Light node will be set to white, and the Diffuse attribute will be set to black.
  
  - If you selected white only, the Color, Diffuse and Specular attributes on the root Light node will all be set to white.

- **Set Up Ambient Occlusion**: Clicking the Set Up Ambient Occlusion button will create an Ambient_Occlusion raytrace node, the output of which is attached to the inputs of the Diffuse_Value and Specular_Value attributes on the root Material node. See Ambient Occlusion (Ambient_Occlusion) for more information on the Ambient_Occlusion node’s attributes.

- **IBL (Image Based Lighting)**: The IBL Wacro can only act upon lights, so make sure you have selected a light from the Object menu at the top of the Shader window, before using this Wacro. Clicking the IBL button will open the Texture Manager, which asks you to select a texture for the Image_Map node.

  Poser allows you to connect shader trees of any level of complexity to your Image Based Light; the IBL Wacro, however, is set up to use a single light probe image as an image map. Light probes are panoramic images that can record light levels from a 360 degree perspective, and are typically created by taking a high-dynamic range image of a mirrored sphere. Once you have selected your light probe image in the Texture Manager, click OK. Poser will attach an Image_Map node using your light probe to the input of the Color attribute on the root Light node. For more information on the Image_Map node’s attributes, see Image Map (Image_Map). For information about Image Based Lighting and light probes, see Diffuse Image-Based Lights (IBL).

  To maximize your Image Based Lighting effects, we recommend using Ambient Occlusion. See Light Properties for information on activating Ambient Occlusion for the selected light.

- **Remove Detached Nodes**: Clicking the Remove Detached Nodes button will clear away any nodes on the currently selected material group whose outputs are not attached to at least one other node. This Wacro is particularly useful for cleaning up complex shader
Shaders

A shader is a combination of nodes working together to create the final desired color, pattern, and texture -- in short, the look for your 3D objects. Every shader consists of a root node with a different number of attributes depending on the type of root node (Background, Material/Hair, Light or Atmosphere) being used. Each of these attributes can have one or more linked nodes that dynamically controls that attribute’s value or color. You can either create materials from scratch or load a pre-made material. Saving a material saves that materials’ shader tree, and loading a material also loads its shader tree. Also, if you load a pre-made material, you can modify it at will to create a whole new look. Please refer to Root Nodes for a detailed description of the root nodes.
Using nodes to build a shader.
Working with Nodes

This chapter describes how to perform various operations with nodes in the Shader window of the Material room. For a description of the Material room itself, please refer to The Material Room.

About Nodes

A node is the basic building block used to construct simple or complex procedural shaders (also called shaders). All nodes have the following elements except where noted:

1. **Output**: After accepting and processing any inputs plus its own values, the end result is passed to the output for connection to another node’s input. Root nodes do not have this function.

2. **Node Name**: This is the name of the node. By default, a number will appear when you have two or more of the same node in your shader, for example Clouds_2, Clouds_3, and so forth. You can double-click the name of the node to enter a new name if desired.

3. **Show/Hide Values Button**: Clicking the Values button toggles displaying the node values (6) on and off.

4. **Show/Hide Preview Button**: Clicking the Preview button toggles displaying the node preview (9) on and off. Enabling previews gives you a great idea of how each step in your shader tree is contributing to the overall look, however this can increase required computing resources.

5. **Node Values**: This area shows the values that you can specify for the particular node.
6. **Value Input**: You can either input values directly in a node or connect one or more nodes to an input to modify the selected value.

7. **Animation Toggle**: Clicking the Animation control toggles animation on and off for the selected value. Click on the Key icon and choose **Animated** to enable animation for the property. The key turns white when animation is enabled.

```
When you specify Animated for a material node, a group named ShaderNode will be placed in the figure or prop's Parameters palette and you can use parameter dials in that group to change the values from one frame to another.
```

8. **Preview**: This displays a preview of the node’s output if the Show/Hide Preview button (#4) is enabled.

```
If you are running OpenGL hardware acceleration, you may be able to view the results of your procedural shaders in the Document's Preview tab, to give you a better sense of how your rendered scene will appear. For more information previewing procedural shaders, please see Preview Tab.
```

---

**The Material Room Options Menu**

You can access the **Options** menu in one of four ways:

- Clicking the **Options** menu arrow at the top right corner of the Shader window.
- Clicking either mouse button on a node’s input. In this case, the **Options** menu will only have the **New node** option available and may (depending on the input) have quick access options for appropriate nodes to connect to the selected input.
- Clicking either mouse button on a node’s output.
- Right-clicking any blank area in the Shader window.

The **Options** menu, which varies depending on how it was accessed, has the following options:
Node options.

- **New node**: Selecting New node creates a new node. Please refer to the following section for more information about creating nodes.

- **Cut**: Selecting Cut places a copy of the selected node(s) into the Clipboard and deletes the originals from the Shader window along with any existing links between the cut nodes and others. This preserves any links that exist between the copied nodes.

- **Copy**: Use the Shift key to select multiple nodes and/or the full rote node to copy into the clipboard. Selecting Copy places a copy of the selected node(s) into the Clipboard without removing the originals from the Shader window without altering their relationships with other nodes. This preserves any links that exist between the copied nodes but does not copy links between the copied nodes and other nodes. In conjunction with the Paste command (see below), this is a great way to propagate your shader trees (or any portions you like) from shader to shader, thereby allowing you to save time by leveraging previous work.

- **Paste**: Selecting Paste places a copy of the node(s) stored in the Clipboard into the Shader window.

- **Replace**: This is typically used to replace selected nodes in a material with nodes that you have copied into your clipboard. For example, if you create a new shader tree for one material and then want to paste it into another material in your scene, first Select All nodes from the material you want to copy. Then select the material you want to replace. Select All in that material, and then choose Replace.

- **Delete**: Selecting Delete selected nodes deletes all selected node(s). Any links to or from deleted nodes are also lost, meaning you will need to reestablish broken connections. Please refer to [Linking Nodes](#) for information on linking/de-linking nodes.

- **Apply to all**: Selecting Apply to all... applies all selected nodes to all materials groups in the current object. This overrides existing connections in affected material groups but does not delete any nodes.

- **Collapse to compound node**: Combines the selected nodes into a compound node. For more information see [Collapsing Existing Nodes into a Compound Node](#).

- **Expand compound node**: Expands the selected compound node back into its individual node components. For more information, see [Expanding Compound Nodes](#).

- **Select All**: Selecting Select All selects all nodes in your shader, including the root node.
• **Invert Selection**: Selecting Invert Selection selects all unselected nodes and deselects all selected nodes. In essence, this function reverses your selection.

### Material Room Node Connections

The Edit view of the **Material** room uses a plug system to connect nodes together. Node inputs typically appear on the right side of a node’s palette, and the node output typically appears in the upper-left corner of the node palette.

![Node inputs and outputs.](image)

You can link nodes to other nodes, thereby controlling one node’s input with another node’s output. This interaction between nodes is at the heart of the **Material** room’s functionality and provides nearly infinite flexibility. Node interaction works by plugging values or colors from one node into another. Although only one node’s output can be connected to another node’s input at the same time, there is no theoretical limit to how deep these interactions can go. Available memory and CPU speed will play a role in setting practical limits.
Selecting Nodes

To select a node, simply click any blank area within the desired node. To select multiple nodes, press and hold Shift while making your selections.

To remove a node from a selection, press the Alt (Windows) or Option (Mac) key while clicking a node to deselect it.

Creating Nodes

Creating additional nodes is the first step to creating your own shader tree (remember that all shaders have at least a root node).

To create a node, use one of the following methods:

- To create a new node anywhere in the Edit material view, right click in an empty area in the material view (1) then expand the node menu (2) to choose New Node > Category > Subcategory > Node. Then connect the new node to the locations you desire.
Creating a new material node.

- To create a node from the Material room Options menu, click the arrow in the upper right corner of the Material room and select New Node > Category > Subcategory > Node. Connect the new node as desired.

Node options menu.

- To create a new node that is automatically connected to a node input, click the desired node input to display the Options menu. Alternatively, you can drag from a node’s input to an open area in the view will pop up the new node menu. Your new node will appear with its output already linked to your current node’s input. If you access the Options menu in any other manner (see above), the new node will not be linked.

Click a connection to display the New Node menu, then select the desired node.
Renaming Nodes

After you create a new node, you can double-click the name field to change the name of the node to something more descriptive. Press Enter/Return to apply the new name.

![Image of node renaming](image)

*Double-click a node name to rename it (top); After renaming (bottom).*

Linking Nodes

Inputs are black when there is no connection. They are white when another node is plugged in. Also, when your material contains more than two different types of surface root nodes (such as a PoserSurface node and a Physical Surface node), connections will gray out when you try to connect a node type that is “invalid” for that input.

![Image of node linking](image)

*Input connections will become dimmed when you try to connect a node to an input that is not valid.*

After creating a node, you may need to link it to an input on another node. This is accomplished in one of three ways:

- **Direct Link:** Click the output of the node you wish to link (1) and drag the cursor over the node or shader input you wish to link to (2). Release the mouse button to complete the link.
Attaching a new node to the root node.

- **Moving Existing Links**: To move a link from one node to another, click the input you want to unlink (1) and drag the cursor off the node. Place the cursor over the new node you wish to link (2) and release the mouse button.

Relinking nodes.

- **Clicking and dragging**: Click the input you wish to connect to (1) and drag. A node connection line follows your cursor. When you release the mouse button, the New Node menu appears (2), allowing you to create a new node whose output is pre-connected to your selected input.

Adding a new node to a root node input.

You can link a node to as many other nodes as you wish and each node input can be linked to as many input nodes as you wish.
Identifying Illegal Node Connections

The FireFly renderer isn’t as particular about node connections as is SuperFly. You may encounter some materials that appear black in the Preview window, and one of the reasons for this is because you might have encountered or created a material that contains node connections that are illegal for either (or both) the FireFly or SuperFly renderers.

Materials that contain illegal node connections may appear black in the Preview renderer.

Poser provides a few ways that you can determine where the illegal connections are, and why the shader will not preview or render properly.

The Log Window

If you have the log window open when you are working on materials, the message log displays messages when you make an illegal connection. For example, if you try to connect the output of a Scatter node (Lighting > Special > Scatter) to the Diffuse Color input of the PoserSurface node, the Log window will display a Heap Check message as shown in the following figure.
The Log window displays error messages when illegal node connections are encountered or attempted.

**Wire Connections**

If you prefer not to have the Log window open, there is also an easy way to determine illegal connections in the **Edit** material view. Illegal connections will be displayed as dotted wires when connections between the output of a node are illegal when connected to a root node. For example, if the output of a lighting node is connected to a root node that accepts a “non-closure” input, the connecting wire will appear dotted to indicate that it will not work in Poser. The figure shown below shows the illegal connection between the Scatter node and the Diffuse Color input of the **PoserSurface** node. You'll notice, however, that when you connect the Scatter node to the AltDiffuse input, the connection is not illegal, and the material previews and renders as expected.

Illegal node connections are displayed with dotted wires.
Connection Sockets

Indicators also happen in real-time while you are making your connections. For example, if you try to connect the output of a Scatter node into the PoserSurface node, you will notice that some of the connection inputs dim out to a gray color. When you see this happening, that gives you a visual indication not to create a connection there. On the other hand, when you see connectors that are solid black or solid white, that serves as an indication that connections to those inputs will be legal.

Illegal connection inputs are grayed out when you drag the output of a material node into the inputs of a root node.

De-Linking Nodes

To break the link between two nodes, click the input you want to unlink (1) and select Disconnect in the Options menu (2).

Adding a new node to a root node input.
Moving Nodes

You can move and arrange nodes to suit your particular work style. A node’s position has no effect on the shader’s function or appearance. To move a node or nodes:

1. Click or Shift-click the node(s) you want to move as described above.
2. Hold the mouse button down and drag the node(s) to the desired position. Release the mouse button to complete the move.

Expanding/Collapsing Nodes

You can expand and collapse a node’s values and/or material preview separately, by clicking the icons that appear in the upper right corner of the node.

Entering Node Values

To enter a value for a node, click the desired value to open a small window with a value field and a parameter dial. Here, you can enter a numeric value in the field and/or move the parameter dial using the mouse. You can also link one or more nodes to the desired value (see below), which will make the appropriate adjustments.

Some node values are pull-down menus. Use these as you would any other pull-down menu.
Node options can be displayed in a pull-down menu.

Also, clicking a color within a node opens a standard Color Picker, which you can use to quickly select your desired color.

**Deleting Nodes**

To delete a node, select the node you wish to delete and either press `[DEL]` or select **Node > Delete**.

**Animating Nodes**

You can animate node attributes by clicking the Animation Toggle (key icon) for the attribute you wish to animate. When animation is enabled, the icon appears white. When disabled, it appears gray. Clicking the Animation Toggle opens a pull-down menu with the following options:
Turn the Animation Toggle on (white) to animate a material.

- **Animated**: Selecting the Animation option toggles animation for the current attribute on or off. A check mark appears next to this menu item when animation is enabled, and vice-versa.

- **Info**: Each animated attribute has one or more Info options depending on the attribute. For example, a numerical node will have one Info option for its numeric value, while a color node will have three Info options (one each for red, green, and blue). Selecting one of these options allows you to set the current value, maximum and minimum limits, name, and sensitivity. This dialog is exactly the same as the Edit Parameter Dial dialog, which is discussed in [Editing Parameter Dials](#).

- **Graph**: For each Info option that appears above, you will see a Graph option. Selecting a Graph option opens the Graph palette for the selected channel. Please refer to [Using Graphs](#) for more information about the Graph palette.

Once animation is enabled, you can animate the attribute’s value using any combination of the following methods:

- **Keyframes**: Move to a frame and set a value, then move to a different frame and set a new value.

- **Graph Palette**: Use the Graph palette to animate the node.

- **Other nodes**: Connect other nodes to control how the attribute changes over time.

Please refer to [Animating with Poser](#) for more information about animating within Poser.
Root Nodes

Poser includes the following nodes, which, combined and linked to root nodes, can create virtually any shader you can imagine. Nodes are divided into several groups: **Math**, **Lighting**, **Variables**, **3D Textures**, and **2D Textures**. Each group and its shaders are discussed in this chapter.

All shaders include a root node, which can be modified using added nodes that modify the root node. Thus, the root node is itself a complete shader. The **Material** room has four root nodes: Material, Background, Light, and Atmosphere. Let’s examine these nodes further.

Poser provides three different types of material root nodes that work with the FireFly and SuperFly renderers. By default, each material initially uses a **PoserSurface** node for a new material, in order to maintain backward compatibility to legacy content. The **PoserSurface** node is initially designated to be sent to both the FireFly and SuperFly renderers.

*The PoserSurface node is initially sent to both the FireFly and SuperFly renderers.*

When you use the **New Node > Root > PhysicalSurface** or **CyclesSurface** command to add a second material root node, you will be able to designate which of the two material root nodes is sent to which renderer. Though each of the three material root nodes can work with either renderer, the most common choice will be to have the **PoserSurface** node sent to the FireFly renderer, and the **PhysicalSurface** or **CyclesSurface** sent to the SuperFly renderer.

*When you add a second material root node you can direct each material root node to either the FireFly or SuperFly renderer.*
Root Material (PoserSurface) Node

The PoserSurface node contains all of the attributes required to create a complete shader for almost every material group in your scene (figures, props, hair).

- **Firefly Root**: Choose this option if you want the output of this root node to be sent to the FireFly Renderer.

- **Superfly Root**: Choose this option if you want the output of this root node to be sent to the SuperFly Renderer.

- **Diffuse Color**: The Diffuse_Color attribute is the surface color that is multiplied through any light striking the object.

- **Diffuse Value**: The Diffuse_Value attribute defines the strength of the diffuse color, where 1=100%.

- **Specular Color**: The Specular_Color attribute defines the color of the object’s highlight.

- **Specular Value**: The Specular_Value attribute defines the strength of the specular color, where 1=100%.

- **Highlight Size**: The Highlight_Size attribute defines the quantity of micro-facets on the object surface. Micro-facets are tiny imperfections that are invisible to the human eye, yet effect the way light is reflected off the surface. Very smooth surfaces (such as glass) have very few imperfections and produce a very sharp specular highlight. Surfaces such as paper have extremely high numbers of imperfections in their surface and thus produce subtler specular highlights.
**Ambient Color**: The Ambient_Color attribute defines the color that a surface has when it receives no light. This can be used to simulate overall ambient light or to create self-illuminating surfaces. Note that the ambient color of a surface will also bounce off other surfaces when rendering with indirect light enabled.

**Ambient Value**: The Ambient_Value attribute defines the strength of the ambient color, where 1=100%.

**Transparency**: The Transparency attribute defines the object's opacity, where 1=fully transparent.

**Transparency Edge**: The Transparency_Edge attribute defines the object's transparency at its edges. For example, a glass appears opaque at its edges.

**Transparency Falloff**: The Transparency_Falloff attribute defines how the transparency changes as it moves towards the object edge. Smaller values create a sharper edge and vice versa.

**Translucence Color**: The Translucence_Color attribute is the color of light passing through the object.

**Translucence Value**: The Translucence_Value attribute defines the strength of the translucent color, where 1=100%.

**Reflection Color**: The Reflection_Color attribute allows you to specify a reflective color. This is a good input for connecting other nodes to control reflections.

**Reflection Value**: The Reflection_Value attribute defines the strength of the reflective color, where 1=100%.

**Refraction Color**: The Refraction_Color attribute defines the color of light refracted by the current object.

**Refraction Value**: The Refraction_Value attribute defines the strength of the refraction color, where 1=100%.

**Bump**: The Bump attribute defines the amount of bump in the material.

**Displacement**: The Displacement attribute defines the amount of displacement in the material.

**Alternate Diffuse**: The AlternateDiffuse attribute provides an alternate input for diffuse lighting. Use this channel for strand-based hair and anytime you wish to use custom diffuse lighting.

**Alternate Specular**: The AlternateSpecular attribute provides an alternate input for specular lighting. Use this channel for strand-based hair and anytime you wish to use custom specular lighting.

**Reflection Lite Mult**: Checking the ReflectionLiteMult checkbox multiplies the total color through the amount of diffuse lighting hitting each point on the surface. This automatically darkens reflections in areas not seen by lights. On by default.

**Reflection Kd Mult**: Checking the ReflectionKdMult checkbox automatically tints the reflection color by the surface’s diffuse color value. Off by default.
In SuperFly, Reflection Lite Mult or Reflection Kd Mult will disable any lighting nodes plugged into the Reflection channel.

- **Gradient Bump**: Previous versions of Poser used a proprietary file format for bump maps (*.BUM). If you want to use these older file types in Poser, connect an image map node to the Gradient_Bump attribute and load your desired *.BUM file into that node (see Image Map (Image_Map) for information on loading images). You cannot use *.BUM files with the FireFly renderer. The Gradient Mode option also allows you to select one of two types of normal maps.

- **Gradient Mode**:
  - **Gradient Bump**: Choose this option to use with a grayscale bump map image.
  - **Tangent Space Normal Map**: Tangent space normal maps have a mostly blue appearance. The normals in a tangent space map are always considered “up” even if it is not true in world space.
  - **Object Space Normal Map**: Object space normal maps are rainbow-colored in appearance. The normals are pointing in their actual directions.

- **ShadowCatchOnly** : Checking the ShadowCatchOnly checkbox allows transparent surfaces to catch shadows, as opposed to letting the shadows appear on the opaque surface behind them. In other words, this option will treat transparent surfaces as opaque, only in terms of their interaction with shadows. A prime use of this feature would be if you wish to render only a figure and its shadow; you could set up the floor as a transparent surface by using the ShadowCatchOnly feature to show your figure's shadow on the transparent floor, and render (without the background). The floor will be invisible except for the shadow laying on it, so the only things in your rendered scene will be the figure and its shadow.

- **ToonID**: By default, selecting the Toon Outline option causes an outline to appear around each separate material on the figure or object. Depending on how the figure is setup, this may lead to too many outlines. In such a case, you can adjust the Toon ID assignment on the root node of the material, to reduce the number of outlines drawn. Assigning the same ID to multiple materials means that the render engine will not draw separating outlines between those materials.

- **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Light for indirect lighting (IDL) is also cast in the direction of the normals. Use this option to avoid shading artifacts on double-sided polygons.

Toon outlines are not supported in SuperFly.

The Shadow Catch Only option only works in FireFly. It will not work in the SuperFly renderer.
• **Custom Outputs**: Use the `Custom_Output_1`, `Custom_Output_2` and `Custom_Output_3` connectors to define material properties that you want to output to Photoshop layers. If there is no connection to these inputs in the Poser Surface node, the output to a layered PSD file will be Diffuse only, Specular only, and Shadow only, respectively for Custom Output 1, 2, and 3. For more information, see [Rendering Layered PSD Files](#).

• **Volume**: Input from the Volume node, discussed in [Volume](#).

• **Geometric Edge**: Allows you to set the width of a geometric edge line for the current material.

• **Geometric Edge Color**: Allows you to set the color of a geometric edge line for the current material.

**Physical Surface Node (PhysicalSurface)**

The Physical Surface node provides standardized connections that are typical of those used by physical based renderers (such as Cycles) and texture generating utilities (such as Quixel Suite or Substance Designer/Painter).

![Physical Surface Node](#)

**Render Engine Selection:**

• **Firefly Root**: If the material also contains a PoserSurface Node or Cycles Surface Node, choose this option if you want the output of this root node to be sent to the FireFly Renderer.
**Superfly Root:** If the material also contains a PoserSurface Node or Cycles Surface Node, choose this option if you want the output of this root node to be sent to the SuperFly Renderer.

**Color**

The Diffuse color is the primary surface color of the current figure or prop. When creating PBR textures in programs such as Quixel or Substance, color textures may also be referred to as Albedo maps, and are typically flat colors with no baked in shadows or highlights.

To change the Diffuse color, click on the Color chip. This will bring up the Poser Color Picker, where you can select your desired color. If you wish to access the system Color Picker, simply click on the RGB bar at the top right corner of the Poser Color Picker.

- If not using a diffuse or albedo texture, set the Color chip to the color that you want to assign.
- Since the Physical Surface node is designed for use with PBR textures, you will get the best results if your color map does not contain baked in highlights and shadows. Those effects will come from other maps described below.
- When using a Diffuse/Albedo map, set the Color chip in the Physical Surface node to white, unless you want to tint the texture map with a different color.
- The Gamma value in the Texture Manager for the Color map should be set to **Use Gamma Value from Render Settings** (which is set to 2.2 by default).

![Use Color input to define the color of the object.](image)

**Transparency**

Transparency allows light to pass through a figure or object, so you can see through it. The higher a transparency value, the more of the surrounding environment is visible through the object’s surface. If no light is reflected on an object, 100% Transparency and Edge settings make it invisible.

When a Transparency map is applied to an object, its texture interferes with the transparency of the object. For example, a checkerboard map results in an object that is alternately transparent and solid. You can thus use textures as Transparency maps.
• Enter a value between 0 (fully opaque) to 1 (fully transparent), or attach a black and white or grayscale transparency map to the input. Set mode to **Transparency**.

• If using a transparency map that uses black for transparent areas and white for opaque areas (typical for transparency maps in Poser), set **Transparency value** to 1, and set **Transparency mode** to **Opacity**.

• Gamma value in the Texture Manager for the Transparency Map should be set to **Custom Gamma Value** of **1**.

• If transparency is not used, set **Transparency setting** to 0.

> Set the Transparency value to 1 if you are using a transparency map. The amount of transparency will be determined by the black, gray, and white areas in your map.

*Transparency 0% - 25% - 50% - 75% - 100%.*

• Choose one of the following Transparency Mode options:
  
  - **Opacity**: Choose Opacity if your map uses black for transparent areas and white for opaque areas. (Typical for maps used in Poser)
  
  - **Transparency**: Choose Transparency if your map uses white for transparent areas and black for opaque areas.
  
  - **Colored Transparency**: If you have a color map attached to the Color input of the material, checking this option will enhance the transparency with color. This is good for items such as stained glass windows.

**Roughness**

• **Roughness**: Input that defines the glossiness or roughness of a material. Can be used to add scratches to a surface.

  • Enter a value between 0 (very glossy) or 1 (more flat)
  
  • If using a grayscale map for roughness, darker areas in the map will appear more glossy, and lighter areas in the map will appear rough or flat.
  
  • Gamma value in the Texture Manager for the Roughness texture should be set to **Custom Gamma Value** of **1**.

> Roughness maps are usually used in conjunction with Metallic maps in PBR textures, in lieu of Specular and Gloss maps.

Page 333
Roughness 0% - 25% - 50% - 75% - 100%.

Specular

- **Specular**: The Specular setting controls the highlights in your object. They appear as sharp bright spots in an object. The value you enter controls the amount of specularity. You can also attach a map to the input to control color or brightness.

Specular 0% - 25% - 50% - 75% - 100%.

Metallic

- **Metallic**: The Metallic property controls whether or not a material is made of metal. A value of zero is fully non-metallic, and a value of 1 is fully metallic.

- Metallic maps

Metallic 0% - 25% - 50% - 75% - 100%.

Metallic maps are usually used in conjunction with Roughness maps in PBR textures, in lieu of Specular and Gloss maps.

Emission

- **Emission**: Defines the color of light that is emitted from the object. This color is independent of the object color.

- **Emission Strength**: Controls the strength of the emission effect. A value of 0 (or black in a map) indicates no emission. A value of 1 (or white in a map) indicates full emission strength.
Bump

A Bump map is a special image, wrapped around the object, that works with the scene lighting to give the appearance of 3D texture on an otherwise smooth object. Bump maps can be used on individual objects or parts of a figure to emulate any manner of textures, from wrinkles and pores in skin, to raised patterns in clothing or props, to cracks and bumps in stone.

Bump maps are typically grayscale maps, with darker areas being more recessed and lighter values appearing to be raised. They do not alter the geometry. As a result, the effect is more pronounced in areas that directly face the camera, and show little effect when the geometry is perpendicular to the camera. In other words, if you apply a Bump map to a sphere, the surface will seem rough while the edges remain smooth.

- This connection uses grayscale bump maps. For normal maps, see the following topic. Old style Poser BUM maps should not be connected to the bump input.
- Gamma value in the Texture Manager for the BumpMap should be set to Custom Gamma Value of 1.
- If Bump map is not used, set Bump setting to 0.
- The strength of bump and displacement maps is expressed in real world units (whichever unit is set under Edit > General Preferences). Please note that with the default unit of Feet very small values already yield a strong bump or displacement effect.

Normal Map

A normal map is an image, wrapped around the object that works with the scene lighting to give the appearance of 3D texture on an otherwise smooth object. Normal maps can be used on individual objects or parts of a figure to emulate any manner of textures, from wrinkles and pores in skin, to raised patterns in clothing or props, to cracks and bumps in stone.
• The Normal map input of the Physical Surface node expects a tangent space normal map (which is mostly shades of blue). World or Object Space normal maps should not be used.

• To load a Normal Map, from the Material Room > Material Palette, Advanced tab, connect the Image Node containing a normal map to the Normal channel on the Physical Surface Node.

• Leave the Strength value set to 1.

• Gamma value in the Texture Manager for the Normal Map should be set to Custom Gamma Value of 1.

![Normal map examples](image)

No normal map - Tangent Space normal map.

Displacement

• **Displacement**: As the displacement value increases, geometry is displaced farther from the actual shape of a model. In a displacement map, dark values generate lower displacement, and lighter values generate more displacement.

![Displacement examples](image)

Displacement 0% - 5% - 10% - 15% - 20%, level 0 subdivision.

Displacement 5%, at level 0, 1, 2, 3, and 4 subdivision.

Volume

• **Volume**: Input from the Volume node, discussed in .
Examples of Volume Absorption, Scatter, and Emission colors.

**Scatter**

- **Scatter Dist R**, **Scatter Dist G**, and **Scatter Dist B**: Scatter distance is the average distance into the object that a ray will travel before it scatters. Skin is typically 3 to 5 mm. Chicken soup would be something like 15 to 20 mm.

- **Scatter IOR**: Enter an Index of Refraction value for the selected material.

- **Scatter Scale**: Enter a scale factor for the SSS. The default is set to .01.

- **Scatter Anisotropy**: Controls the directionality of subsurface scattering.

- **Scatter Group**: Scatter groups are used to prevent objects from bleeding through each other. For example, brightly colored lipstick might bleed into surrounding lips, so you should set the lips to a different scatter group than the rest of the head.

- **Subsurface Method**: Choices are **Burley**, **Walk**, and **Walk Fixed**. **Walk** is recommended for most cases.

**Cycles Surface Node (CyclesSurface)**

The **Cycles Surface** Node replicates the surface node that is used in Blender’s Cycles renderer. This can be used in conjunction with the Cycles nodes (discussed in [Cycles Nodes](#)) to create materials similar to those created in Blender. Consult the Blender documentation for further information on usage of Cycles surface and material nodes.

**Other Root Node Types**

In addition to the three types of Material root nodes, Poser also offers root nodes that are specific to the background, lights, or atmosphere in your scene. These root nodes are described in the following sections.
Root Background Node

To display the root background node, choose the Background object from the Object selection menu in the material room Edit view.

The root Background node contains all of the attributes required to create a complete shader for your scene’s background and has the following attributes:

- **Color**: The Color attribute allows you to choose the background’s base color.
- **Diffuse Color**: The Diffuse_Color attribute is the surface color that is multiplied through any light striking the object.
- **Specular Color**: The Specular_Color attribute defines the color of the object’s highlight.
- **Highlight Size**: The Highlight_Size attribute defines the size of the highlight.
- **Bump**: The Bump attribute defines the amount of bump in the material.
- **Cast Light**: Check this option to allow the background to cast light (SuperFly renderer only)

Background Diffuse_Color, Specular_Color and Bump are not supported in SuperFly.

The final render will always display whatever is attached to the Color channel of the Root Background node. However, if you wish the same image or color to appear in the preview render, you must also attach it to the BG Picture or BG Movie node.

The Root Background node initially has five additional node types that are specifically designed to work with the Background root node.
BG Color

BG Color Node.

- **Color**: The Color attribute allows you to choose the background’s base color.

BG Environment

The BG Environment node is used to light your scene using an environment map image file as a texture. This node is the same as the Cycles > Texture > Environment Texture node discussed in [EnvironmentTexture](#).

BG Environment Node.

- **Color**: RGB Color output, connect to the Color input of the Background root node.
- **Alpha**: Alpha output from the image. If the image has no alpha channel, output is white.
- **Vector**: Texture coordinate for texture look-up. If this socket is left unconnected, the image is mapped as environment with the Z axis as up.
- **Projection**: Choose **Equirectangular** (projects from an equi-rectangular photo) or **Mirror Ball** (projects from an orthographic photo or mirror ball).
- **Image**: Click to select your image source.

To see an example of this node in use, open either the Mondello Beach or Wide Street scene from the startup launcher. These scenes use the BG Environment node to project an image on to an environment sphere.

When the environment sphere is included in the scene, open the material editor and choose the Background object in the Material Editor. The preview window will display the HDRI image mapped onto the inside of the environment sphere. The following nodes are connected to the Background root:

- Add a Cycles > Input > TextureCoordinate node.
- Add a Cycles > Vector > Mapping node.
• Connect the Generated output from the TextureCoordinate node to the Vector input of the Mapping node.

• Set the Rotation value in the Mapping node to 0.000000, -1.570000, 0.000000

• Set the Scale value in the Mapping node to -1.000000, 1.000000, 1.000000

• Connect the Vector output from the Mapping node to the Vector input of the BG Environment node.

• Connect the Color output from the BG Environment node to the Color input of the Background root node.

Next, select the Environment Preview from the object menu in the Material room. The same image used in the Background is added to its default material to cast light into the scene. For this, you use an image map node with the same HDRI image assigned. The Color output of the image map is connected to the Emission connection in the Physical Surface root node.

![Diagram showing the connections and settings for the BG Environment node, TextureCoordinate node, and Mapping node with the generated output from each node connected appropriately.](image-url)

*Environment sphere background shader.*
Finally, select the Preview Light object from the Object menu in the material room. This is the third place where the HDRI image is referenced. The HDRI image map node is connected to the Color input of a root light node. Color is set to white, and Diffuse and Specular are set to black on the root light node.
Because the HDRI image is referenced in three places for the envirosphere, the easiest way to change the image used in this HDRI environment is as follows:

1. Switch to the material room and select the Background from the list of objects at the top of the Material Editor.
2. On the BG Environment node click the texture to open the Texture editor.
3. Click the Browse button and select any HDR Image you want to use as an environment.
4. Click the "Replace all identical maps" button at the bottom of the Texture manager.
5. Choose to replace all identical maps in the Scene.

**BG Movie**

- **Video Source**: Select the video source you want to use in the background.
- **Auto Fit**: Check this option if your video source is rectangular (non-square). The video will be stretched to match the aspect ratio of the movie you selected. The image will be scaled from its center.
- **U Scale**: Enter a scale factor for the width of the video. For example, if the width of the video is 20% wider than it is high (landscape style), enter 1.2 for the U scale value. The left side of the image remains in its original position, and the image will be scaled toward the right. If Auto Fit (above) is checked, you can leave this at its default value of 1.
- **V Scale**: Enter a scale factor for the height of the video. For example, if the height of the video is 20% higher than it is wide (portrait style), enter 1.2 for the V scale value. The bottom of the image remains in its original position, and the image will be scaled toward the top. If Auto Fit (above) is checked, you can leave this at its default value of 1.
- **U Offset**: Enter an offset, in percentage, to position the movie lower (negative value) or higher (positive value).
• **V Offset**: Enter an offset, in percentage, to position the movie leftward (negative value) or rightward (positive value).

> Importing movies with the File > Import > Background Movie command will automatically connect the BG Movie node to the Color output of the Background root node, and adjust the UV Scale and UV Offset settings as needed. to display the background movie at the correct aspect ratio.

• **Texture Coords**: Available texture coordinates are **UV**, **VU**, **XY**, **XZ**, **ZY**, and **Mapper**.

• **Image Mapped**: Available options are **None**, **Alpha**, **Clamped**, and **Tile**.

• **Background**: Click to choose a background color that will show through invisible (alpha) areas.

• **Global Coordinates**:
  - **Mirror U**:
  - **Mirror V**:

• **Texture Strength**: Click to specify the strength of the movie source. The default value is 1 which will be fully opaque. Values lower than 1 will be partially transparent, and rendered over the Color as set in the Background root node.

• **Frame Number**:

• **Loop Movie**: Check this option to restart playback of the movie from the beginning after it reaches the end. Uncheck the option to stop playback once it reaches the end.

**BG Picture**

![BG Picture Node](image)

• **Image Source**: Select the image source that you want to use for the background.
• **Auto Fit:** Check this option if your image source is rectangular (non-square). The image will be stretched to match the aspect ratio of the image you selected.

• **U Scale:** Enter a scale factor for the width of the image. For example, if the width of the image is 20% wider than it is high (landscape style), enter 1.2 for the U scale value. If Auto Fit (above) is checked, you can leave this at its default value of 1.

• **V Scale:** Enter a scale factor for the height of the image. For example, if the height of the image is 20% higher than it is wide (portrait style), enter 1.2 for the V scale value. If Auto Fit (above) is checked, you can leave this at its default value of 1.

• **U Offset:** Enter an offset, in percentage, to position the image lower (negative value) or higher (positive value).

• **V Offset:** Enter an offset, in percentage, to position the image leftward (negative value) or rightward (positive value).

Importing images with the File > Import > Background Picture command will automatically connect the BG Picture node to the Color output of the Background root node, and adjust the UV Scale and UV Offset settings as needed to display the image at the correct aspect ratio.

• **Texture Coords:** Available texture coordinates are **UV, VU, XY, XZ, ZY,** and **Mapper.**

• **Image Mapped:** Available options are **None, Alpha, Clamped,** and **Tile.**

• **Background:** Click to choose a background color that will show through invisible (alpha) areas.

• **Global Coordinates:**

  • **Mirror U:**

  • **Mirror V:**

• **Texture Strength:** Click to specify the strength of the image source. The default value is 1 which will be fully opaque. Values lower than 1 will be partially transparent, and rendered over the Color as set in the Background root node.

• **Filtering:** The Filtering attribute allows you to select one of three options for texture filtering on the selected image map. These options are: **None**--no texture filtering; **Fast**--high-speed texture filtering; **Quality**--high-quality texture filtering; **Crisp**--provides more aliasing for increased crispness.

**Black**

*Black Node.*
• **Color:** The Color attribute allows you to choose the background’s base color.

### Root Light Node

A root Light node appears whenever you have a light selected. Each light in your scene has its own root Light node, which has the following attributes:

- **Color:** The Color attribute allows you to choose the light’s base color.
- **Intensity:** The Intensity attribute defines the light’s brightness.
- **Angle Start:** The AngleStart attribute defines the start of the light cone (in degrees) for spotlights.
- **Angle End:** The AngleEnd attribute defines the end of the light cone (in degrees) for spotlights.
- **Angle Expo:** The AngleExpo attribute controls how the light fades towards the edge of the light cone (falloff).
- **Diffuse:** The Diffuse attribute allows you to create lights that use only a diffuse component to light the scene.
- **Specular:** The Specular attribute allows you to create lights that use only a specular component to light the scene. You can create specular only lights by setting the color in the specular channel to black. You can also create a negative light source (a light source that darkens or negates certain colors in the areas of the scene lit by this light) by setting the Specular value to zero (i.e., black) and setting the light’s Intensity to -1. Then the Color and Diffuse channels can be adjusted to reduce certain aspects of light.

Light Diffuse Color and Specular Color are not supported in SuperFly.

- **Image Resolution:** The Image Resolution attribute specifies the width and height of the light probe to be sampled. You can attach a light probe of any size, and then adjust the resolution to suit your needs. Note that higher resolutions require more processing time, whereas with extremely low resolutions you will lose image quality. 256 is a reasonable default resolution for most light probe images.
Poser Reference Manual

Other Root Node Types

- **IBL Contrast**: The IBL Contrast attribute allows you to modify the level of contrast in the incoming light probe image. The default value of 3 for this attribute is intended for use with Low Dynamic Range (LDR) images. For High Dynamic Range (HDR) images, the best IBL Contrast setting would be 1.

You must have a light selected in order to see its root node.

Root Atmosphere Node

The Root Atmosphere node contains all of the attributes required to create realistic atmospheric effects such as fog, haze, etc. in your scenes.

![Root Atmosphere Node](image)

**Root Atmosphere Node.**

- **DepthCue_On**: Checking the DepthCue_On checkbox enables depth cueing, which varies all surface material colors from their original lit colors to the specified depth cue color (see below). This gives an effect similar to enabling the Depth Cueing option in the Document as described in Using Depth Cueing.

Depth Cue is not supported in SuperFly.

- **Volume_On**: Checking the Volume_On checkbox enables volumetric effects. You can enable depth cueing and/or volumetric effects individually.

- **DepthCue_Color**: The DepthCue_Color attribute specifies the color to use when applying the depth cueing.

- **DepthCue_StartDist**: The DepthCue_StartDist attribute specifies the distance from the current camera at which the depth cueing effect begins. This distance is not necessarily displayed in Poser distance units.

- **DepthCue_EndDist**: The DepthCue_EndDist attribute specifies the distance from the current camera at which the depth cueing effect ends. This distance is not necessarily displayed in Poser distance units.

- **Volume_Color**: The Volume_Color attribute specifies the color of the volumetric effect. This color is multiplied with the color of the lights in your scene. To use the lights’ colors for the volume, set this color to white.
You can connect nodes to the color and density attributes for more complex effects.

Without volumetric rendering (no fog) on left; With volumetric rendering (with fog) on right.

Bright infinite lights can wash out volumetric effects unless you use a very low density. Volumetric effects are most successfully used with both spotlights and carefully controlled density numbers. Also, Volumetric lighting effects only appear over a rendered object. They do not appear over an empty background, even when a background shader is in place. You need at least one object in on screen in order for volumetric lighting effects to be visible.

Root Node Help

Some node attributes have a question mark (?) icon next to them. Clicking this icon opens help for that channel. This help is also available by navigating the Material room help window (available by clicking on the (?) icon at the top right of the Shader window.

For example, if you click the question mark that appears in the Alternate Diffuse channel in the PoserSurface node, it opens a Room Help file that explains more about the Alternate Diffuse nodes.
Material Nodes

Math Nodes

These are the math nodes included with Poser. You will find them in the New Node > Math submenu. Unless specified otherwise, the list of attributes for each node is listed from top to bottom.

Blender

The Blender node blends two colors using a value attribute as an alpha mask. It has the following attributes:

- Input 1: The Input_1 attribute defines the first blend color. Clicking this attribute opens the standard Color Picker.
- Input 2: The Input_2 attribute defines the second blend color. Clicking this attribute opens the standard Color Picker.
- Blending: The Blending attribute is used to determine the amount of blending. Valid values are from 0 (Input 1 color only) to 1 (Input 2 color only).

Color Math (Color_Math)

The Color Math node performs the selected mathematical operation with two colors. It has the following attributes:
The Color Ramp node takes four colors and creates a spline color map (gradient) with them. You can feed grayscale output from other nodes (turbulence, wood, etc.) into this node to create interesting still or animated effects using the grayscale values as lookups into the color spline, providing a colorized version of the original grayscale image. It has the following attributes:

- **Color 1** through **Color 4**: The Color_1 through Color_4 attributes allow you to input colors for the color spline. Clicking them opens the standard Color Picker.
- **Input**: The Input attribute is the grayscale value to lookup into the color spline. This is where you should plug in your grayscale images.

**Component (Comp)**

The Component node is useful for extracting the red, green, or blue components from an input color. It has the following attributes:
Edge Blend (Edge_Blend)

The Edge Blend node blends color nodes based on surface and camera angles. It has the following attributes:

- **Component**: The Component attribute specifies the color to extract. 0=red, 1=green, and 2=blue.

- **Color**: The Color attribute provides an input for another node, whose output will be processed according to the Component attribute setting.

- **Point**: The Point attribute provides an input for a point node whose output will be processed according to the Component attribute setting.

**Fresnel Blend (Fresnel_Blend)**

The Fresnel Blend node has the following attributes:

- **Outer Color**: The Outer Color attribute defines the color of surfaces facing away from the camera. Clicking it opens the standard Color Picker.

- **Inner Color**: The Inner Color attribute defines the color of surfaces facing towards the camera. Clicking it opens the standard Color Picker.

- **Attenuation**: The Attenuation attribute defines the power curve used for transitioning between the inner and outer colors.

- **Index of Refraction**: The index of refraction of the material. Light hitting the surface will be reflected or transmitted dependent on the incident angle based on the index of refraction.
**Gamma**

The Gamma node allows you to incorporate Gamma settings into the currently selected material. The Gamma node provides the following settings:

![Gamma Node](image)

- **Color**: Allows you to specify a solid color, or to input other nodes as a source of color.
- **Inverse**: Used as a shortcut that applies the specified gamma value in reverse. For example, if Gamma value is set to 2.2, checking the Inverse option will result in a Gamma setting of 1/2.2 (or .4545).
- **Use Custom Gamma**: Check this option to pass the custom gamma settings to the node that is connected to the output.
- **Gamma**: Sets the desired gamma value.

**HSV/HSV2**

The HSV and HSV2 nodes allow you to adjust the Hue, Saturation, and/or Value of the Color input. This HSV node scales (ie: multiplies) hue according to the value on the input.

There are two HSV nodes to choose from:

- **HSV** multiplies Hue, Saturation, and Value with their respective channel values to produce the output color.
- **HSV2** adds the Hue value to the channel value, and multiplies Saturation and Value with their respective channel values to produce the output color.
 HSV2 is the recommended choice for users that expect Hue to be shifted, as in a circle of colors on a color wheel.

HSV Node.

HSV2 Node.

- **Color**: Allows you to specify the color source that you want to adjust.

- **Hue**: This attribute allows you to adjust the Hue of the Color input. A setting of 1 represents no adjustment. Increase or decrease the setting to offset the original hue.

- **Saturation**: This attribute allows you to adjust the Saturation of the Color input. A setting of 1 represents no adjustment. Increase or decrease the setting to offset the original saturation.

- **Value**: This attribute allows you to adjust the Value of the Color input. A setting of 1 represents no adjustment. Increase or decrease the setting to offset the original value.

Math Functions (Math_Functions)

The Math Functions node is useful for mathematically merging values, nodes, and other parameters and can be used to create patterns. It has the following attributes:

Math Functions Node.

- **Math Argument**: This pull-down menu defines the math function to be used. Your options are:
  - **Add**: Selecting Add returns Value 1 plus Value 2.
  - **Subtract**: Selecting Subtract returns Value 1 minus Value 2.
• **Multiply**: Selecting Multiply returns Value 1 times Value 2.

• **Divide**: Selecting Divide returns Value 1 divided by Value 2.

• **Sine**: Selecting Sin returns the sine of Value 1. Value 2 is ignored.

• **Cosine**: Selecting Cos returns the cosine of Value 1. Value 2 is ignored.

• **Tangent**: Selecting Tan returns the tangent of Value 1. Value 2 is ignored.

• **Square Root**: Selecting Sqrt returns the square root of Value 1. Value 2 is ignored.

• **Power**: Selecting Pow returns the Value 1 to the Value 2 power (such as 3^3).

• **Exponential**: Selecting Exp returns e to the exponent Value 1, Value 2 is ignored (such as e^V1).

• **Logarithm**: Selecting Log returns the natural log of Value 1, Value 2 is ignored.

• **Modulus**: Selecting Mod returns the modulus (remainder) of Value 1 divided by Value 2.

• **Absolute**: Selecting Abs returns the absolute value of Value 1. Value 2 is ignored.

• **Sign**: Selecting Sign returns –1 if Value 1 is less than zero, and 1 if Value 1 is greater than or equal to zero. Value 2 is ignored.

• **Minimum**: Selecting Min returns Value 1 if Value 1 is less than Value 2, otherwise Value 2 is returned.

• **Maximum**: Selecting Max returns Value 1 if Value 1 is greater than Value 2, otherwise Value 2 is returned.

• **Clamp**: Selecting Clamp returns Value 1 unless Value 1 is less than 0 or greater than 1. If Value 1 < 0, 0 is returned. If Value 1 > 1, 1 is returned. Value 2 is ignored.

• **Ceiling**: Selecting Ceil returns Value 1 rounded up to the next whole number. Value 2 is ignored.

• **Floor**: Selecting Floor returns Value 1 rounded down to the last whole number. Value 2 is ignored.

• **Round**: Selecting Round returns Value 1 rounded to the nearest whole number. Value 2 is ignored.

• **Step**: Selecting Step returns 1 if Value 1 is less than or equal to Value 2, and 0 if Value 1 is greater than Value 2.

• **Smooth Step**: Selecting Smoothstep returns Value 1 bicubically smoothed. Value 2 is ignored.

• **Bias**: Selecting Bias adjusts the bias of Value 1 by Value 2.

• **Gain**: Selecting Gain adjusts the gain of Value 1 by Value 2.

• **Value 1**: The Value_1 value defines the first value in the math equation.

• **Value 2**: The Value_2 value defines the second value in the math equation.
Simple Color (Simple_COLOR)

The Simple Color node allows you to access a color picker to select a color. Clicking the color (Color attribute) opens the Poser Color Picker. To use your operating system’s Color Picker, press [OPT]/[ALT] while clicking the color or click the red-green-blue button in the top right of the Poser Color Picker.

User Defined (User_DEFINED)

The User Defined node allows you to define a custom color. The Color Mode (bottom) attribute is a pull-down menu allowing you to specify your desired color model. You can choose RGB, HSV, or HSL modes and enter the appropriate attributes in the three fields above, as follows:

- **Red**: This attribute allows you to specify the first value: Red (RGB) or Hue (HSV or HSL).
- **Green**: This attribute allows you to specify the second value: Green (RGB) or Saturation (HSV or HSL).
- **Blue**: This attribute allows you to specify the third value: Blue (RGB) or Value (HSV) or Lightness (HSL).
- **Color Mode**: This attribute allows you to specify the color mode that applies to the Red, Green, and Blue setting. Choices are RGB (Red, Green, Blue), HSV (Hue, Saturation, Value) or HSL (Hue, Saturation, Lightness).

Lighting Nodes

These are the light nodes included with the Material room. Unless specified otherwise, the list of attributes for each node is listed from top to bottom. The Light menu item has several submenus, each containing one or more nodes.
Diffuse Nodes

Clay

The Clay node applies a clay-like lighting model to the selected material. It has the following attributes:

- **Color**: The Color attribute specifies the clay color. Clicking the color opens a Color Picker.
- **Kd**: The Kd attribute specifies the strength of the color, where 1=100%.
- **Roughness**: The Roughness attribute defines the size of highlights.

Diffuse

The Diffuse node allows you to use the standard diffuse lighting model. It has the following attributes:

- **Diffuse_Color**: The Diffuse_Color attribute specifies the diffuse color.
- **Diffuse_Value**: The Diffuse_Value attribute defines the strength of the diffuse color, where 1=100%.
- **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.
ProbeLight

The ProbeLight node takes an irradiance environment map, which is a 360 degree light distribution contained within a single image map, and applies it to your material. It has the following attributes, as well as nine coefficients:

![Probe Light node.](image)

- **Exposure**: The Exposure attribute specifies the brightness, or exposure level, of the irradiance map.
- **Saturation**: The Saturation attribute specifies the degree of color saturation within the irradiance map.
- **SurfaceColor**: The SurfaceColor attribute allows you to select a color tint by which the irradiance map will be multiplied. For more realistic results, you should multiply with white.

If your intention is to create an image based light, you can do so by simply adding a diffuse image Based light to your scene in the lighting controls. See Lighting for more information about adding and configuring lights.

Toon

The Toon node gives your material a cartoon-like look. It has the following attributes:

![Toon node.](image)


- **Light Color**: The LightColor attribute specifies the light color.
- **Dark Color**: The DarkColor attribute specifies the dark color.
- **Ink Color**: The InkColor attribute specifies the ink color.
- **Spread**: The Spread attribute defines the sharpness/softness of edges between colors.
- **Line Width**: the LineWidth attribute specifies the width of the ink color.
- **Normals_Foward**: Checking the Normals_Foward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.
- **Outline Mode**: Specify the type of toon outline that you want to use.
  - **Original**: Uses the version that was initially shipped. Provided for backward compatibility with existing toon shaders.
  - **Improved**: Uses the improved outline method.

\[\text{The FireFly renderer gives better results for toon rendering.}\]

**Environment Map Nodes**

**Sphere Map (Sphere_Map)**

The Sphere Map node is a lighting node for performing spherical reflections. Attach this node to a materials’ reflection input (or as a raytrace reflection mode’s color attribute) to create spherical reflections. This node has the following attributes:

- **Color**: The Color attribute specifies the map’s color. Clicking the color opens a Color Picker.
- **Rotation**: The Rotation attribute specifies the maps, rotation along the X, Y, and Z values.
Special Nodes

Custom Scatter (Custom_Scatter)

This node exposes subsurface scattering with the raw parameters available to the user, as opposed to the measured presets in the plain Scatter node.

![Custom Scatter node.]

The Custom Scatter node has the following attributes:

- **Surface Color**: The overall color of the surface. Applied post-scattering, so textures applied to this input will remain sharp.

- **Scatter Color**: The color of the light that gets scattered in the material.

- **Mean Free Path**: The mean distance that light travels in the surface before it scatters. Larger values result in a more translucent effect. Note that regardless of the settings in the preferences, this parameter’s units are always in millimeters, due to the small size of typical values.

- **IOR** (Index of Refraction): The index of refraction of the material. Light hitting the surface will be reflected or transmitted dependent on the incident angle based on the index of refraction. Range is 0.0001 – 3.4.

- **Pre-Scatter Color**: The incoming light on the surface will be modulated by this color before it scatters in the material.

- **Pre-Scatter Ambient**: The amount of self-illumination of the material. This is being applied before scattering, so the illumination generated here will be scattered around in the material.

- **Max Error**: Same parameter as in the other two subsurface scattering nodes, this one is a speed vs. quality trade-off parameter. Lower values equal a more precise calculation at the expense of render time, higher values render faster but may show artifacts. Range is 0.0 – 1.0.

- **Scatter Group**: Materials with the same scatter group will appear as one surface to scattering. Materials in separate scatter groups are considered separated. See sample render under Scatter.

- **Subsurface Method**: Selects the type of microfacet distribution to use for the material:
• **Burley**: Is an approximation to physically-based volume scattering.

• **Walk**: Provides the most accurate results for thin and curved objects. This comes at the cost of increased render time or noise for more dense media like skin, but also better geometry detail preservation. Random Walk uses true volumetric scattering inside the mesh, which means that it works best for closed mesh.

• **Walk Fixed**: Provides accurate results for thin and curved objects. Uses true volumetric scattering inside the mesh. Works best for closed meshes. Overlapping faces and holes in the mesh can cause problems.

**FastScatter**

The FastScatter node offers an easy application of subsurface scattering (SSS) effects. The results of the FastScatter calculation approximate true Subsurface Scattering.

*Fast Scatter node.*

*Subsurface scattering simulates the interaction of light with translucent materials, whereby the light interacts to some degree with the material below the surface level. The FastScatter node is a legacy node that was introduced prior to the implementation of true Subsurface Scattering. This node should be phased out by content developers and replaced with one of the true Subsurface Scattering nodes: *Subsurface Skin* or *Scatter.*

**Hair**

The Hair node allows you to color your characters’ or props’ strand-based hair. Hair generated in Poser’s *Hair* room uses this node. It has the following attributes:
**Scatter**

The Scatter node offers another way to render scattering effects in various objects, including skin. A number of presets that use real-world material properties are included in this node.

The Scatter node is depreciated and may be dropped in future versions of Poser. It uses an outdated scatter model. It's been revised as much as possible to produce similar results to previous versions for Poser 13. The Scatter node may not produce expected results using the "Walk" and "Walk Fixed" Subsurface methods. It's recommended to use the scatter setting in the Physical Root node or the Custom Scatter node instead.

The Scatter node offers the following settings:

- **Root Color**: The Root_Color attribute selects the color for the root of the hair. Clicking this attribute opens a standard Color Picker.

- **Tip Color**: The Tip_Color attribute selects the color for the tip of the hair. Clicking this attribute opens a standard Color Picker.

- **Specular Color**: The Specular_Color attribute selects the hair’s highlight color. Clicking this attribute opens a standard Color Picker.

- **Highlight Size**: Allows you to determine the size and intensity of the highlights in the hair.

- **Root Softness**: The Root_Softness attribute controls the root’s transparency, which helps hair blend into the scalp.

To create realistic hair shaders, connect this node to the root node’s Alternate Diffuse attribute.

- **Opaque in Shadow**: Check this option to create solid shadows beneath hair strands. This allows you to create hair that looks more full without having to increase the number of hairs on the head (thereby requiring less computer resources).

Opaque in Shadow is not supported in SuperFly.
Select node.

- **Material**: The Material selector includes several presets that emulate the scatter effects of real-world materials.

Material options.

- **Use Material Color**: Check this option if you want to use color from the Material property.

- **Texture Detail**: Represents the ratio of the use of the texture for post-scatter versus pre-scatter. The range is from 0-1.0. A value of 1 will apply 100% of texture at post-scatter, yielding more texture details. A value 0 uses none of texture at post-scatter, applying all of that texture for pre-scatter calculations, and yields very low texture detail. A value of .5 is a reasonable point to start experimenting.

- **Scale**: Each of the Scatter materials are based on physical measurements. The Scale setting decreases or increases the physical scale to adjust appropriately for your geometry in the event that it is smaller or larger than it would be in real life.

- **MaxError**: This setting is a quality-speed trade-off. When set to a low value, you will get higher precision in the subsurface scattering, but rendering will be more slow. When set to a higher value, you will get better rendering speeds, but less precision in the subsurface scattering.

- **Color**: Determines the base color for the material. The Scatter effect is added to this color. By default it is set to white. You can choose another color or add an image map or other node to the input.

- **Scatter Group**: Materials with the same scatter group will appear as one surface to scattering. Materials in separate scatter groups are considered separated. In the image
that follows, the two spheres on the left are in the same scatter group. The sphere on the right is a different scatter group.

**Subsurface Method:** Selects the type of microfacet distribution to use for the material:

- **Burley:** Is an approximation to physically-based volume scattering.
- **Walk:** Provides the most accurate results for thin and curved objects. This comes at the cost of increased render time or noise for more dense media like skin, but also better geometry detail preservation. Random Walk uses true volumetric scattering inside the mesh, which means that it works best for closed mesh.
- **Walk Fixed:** Provides accurate results for thin and curved objects. Uses true volumetric scattering inside the mesh. Works best for closed meshes. Overlapping faces and holes in the mesh can cause problems.

![Scatter Groups](image)

*It is beneficial to place teeth or eyeballs in a different scatter group than the skin on the face. This prevents light from scattering between them.*

**Skin**

The Skin node allows you to create realistic skin. It has the following attributes:
Subsurface Skin node.

- **Skin Color**: The SkinColor attribute selects the skin’s base color. Clicking this attribute opens a standard Color Picker.

- **Sheen Color**: The SheenColor attribute is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

- **Ka**: The Ka attribute controls the ambient light strength, where 1=100%.

- **Kd**: The Kd attribute controls the diffuse light strength, where 1=100%.

- **Ks**: The Ks attribute controls the specular light strength, where 1=100%.

- **Thickness**: The Thickness attribute controls the thickness of the top, translucent skin layer.

- **ETA**: The ETA attribute controls the density of the top, translucent skin layer.

**Subsurface Skin**

The Subsurface Skin node offers more realistic skin effects than the Skin node. It adds subsurface scattering effects that give the skin more luminescence and sheen. This node has the following settings:

- **Color**: Determines the base color for the material. The Subsurface Skin effect is added to this color. By default it is set to white. You can choose another color, or attach an image map or another node to the input.

- **Texture Detail**: Represents the ratio of the use of the texture for post-scatter versus pre-scatter. The range is from 0-1.0. A value of 1 will apply 100% of texture at post-scatter, yielding more texture details. A value 0 uses none of texture at post-scatter, applying all of that texture for pre-scatter calculations, and yields very low texture detail. A value of .5 is a reasonable point to start experimenting.

- **Specularity**: When set to 1, this setting approximates the physical specular behavior of human skin. Increase or decrease the setting for your desired effect.

- **Highlight Size**: Determines the size of the highlight, similar to the way that Highlight Size works in the Root node.
In order to use the Subsurface Skin node, the Subsurface Scattering option must be turned on in Firefly's Render Settings tab.

Go to the Material room and select the Head material. Right-click in an empty area in the Edit material view and choose New Node > Lighting > Special > Subsurface Skin.

Plug the output of the image map into the Color input of the new node. Then, plug the output of the new node into the Alternate Diffuse input of the PoserSurface root node. Finally, set the Diffuse Value setting in the root node to 0, so that Poser only uses the ALT Diffuse setting.
Material Settings for the Subsurface Skin node.

When you render the new material in FireFly, Poser will first render a pre-pass to calculate light all over the surface (including the back side). During the second pass, it calculates the scattering. The figure above shows results rendered in SuperFly.

**Velvet**

The Velvet node allows you to create the appearance of realistic velvety fabric. It has the following attributes:

- **Velvet Color**: The Velvet_Color attribute selects the color. Clicking this attribute opens a standard Color Picker.

- **Velvet Sheen**: The Velvet_Sheen attribute is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.
• **Ka**: The Ka attribute controls the ambient light strength, where 1=100%.

• **Kd**: The Kd attribute controls the diffuse light strength, where 1=100%.

• **Ks**: The Ks attribute controls the specular light strength, where 1=100%.

• **Roughness**: The Roughness attribute controls the thickness of the velvet.

• **Edginess**: This attribute controls the horizon scatter of the velvet.

• **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

**Volume**

![](image)

*Volume node.*

• **Absorption Color**: The color of the light that is absorbed by the volume material.

• **Absorption Density**: How much of the light interacts with absorption.

![](image)

*Absorption Color example.*

• **Scatter Color**: The color of the light that is scattered from the volume material.

• **Scatter Density**: How much of the light interacts with volume scattering.

• **Scatter Anisotropy**: The direction in which the light is most likely to scatter.
Specular Nodes

Specular nodes provide different models for calculating highlights on objects.

Anisotropic

The Anisotropic node allows you to create irregularly shaped highlights. It has the following attributes:

- **Emission Color**: The color of light that is emitted from the volume.
- **Emission Strength**: The strength of the emission color.

Scatter Color example.

Emission Color example.
Specular Nodes

Anisotropic node.

- **Specular Color**: The Specular_Color is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

- **Specular Value**: The Specular_Value is the amount of influence the specular color has on the shader. A higher value will create larger, more distinct highlights and vice versa.

- **U Highlight Size**: The U_Highlight_Size attribute is the highlight’s size in the U direction.

- **V Highlight Size**: The V_Highlight_Size attribute is the highlight’s size in the V direction.

- **Rotation**: Specify the rotation of the specular node.

- **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

Blinn

The Blinn node defines a model for calculating highlights. It has the following attributes:

Blinn node.

- **Specular Color**: The Specular_Color is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

- **Eccentricity**: The Blinn formula models the microfacets (microscopic imperfections) of the surface as ellipsoids of revolution. The Eccentricity attribute controls the size and variation of the imperfections. Use 0 for very shiny surfaces and 1 for very diffuse surfaces.
**Specular Roll Off**: The SpecularRollOff attribute controls the highlight's sharpness.

**Reflectivity**: The Reflectivity attribute controls the amount of light reflected back to the eye.

**Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

### Glossy

The Glossy node defines a model for calculating highlights. It has the following attributes:

- **Specular Color**: The Specular_Color is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

- **Ks**: The Ks attribute defines the strength of the specular color, where 1 = 100%.

- **Roughness**: The Roughness attribute defines the size of highlights.

- **Sharpness**: The Sharpness attribute defines the sharpness of the highlight’s edge.

- **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

### ks Microfacet (ks_microfacet)

The KS-Microfacet node is a node that is a physically-based specular node that uses specularity calculations similar to those used in the Subsurface Skin and Scatter nodes.

The settings are as follows:
• **Specular Color**: The Specular Color is the color of any highlight that appears on the object surface. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

• **Roughness**: The Roughness attribute defines the size of highlights. Lower values create smaller, sharper highlights. Higher values create larger, more diffused highlights.

• **Ks**: The Ks attribute controls the specular light strength, where 1=100%.

### Phong

The Phong node defines a model for calculating highlights. It has the following attributes:

• **Specular Color**: The Specular Color is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

• **Specular Value**: The Specular Value is the amount of influence the specular color has on the shader. A higher value will create larger, more distinct highlights and vice versa.

• **Size**: The Size attribute specifies the size of the highlight.

• **Normals_Foward**: Checking the Normals_Foward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

### Specular

The Specular node defines a model for calculating highlights. It has the same attributes as the Phong node, which is discussed below.
Specular node.

- **Specular Color**: The Specular_Color is the color of any highlight that appears on the object surface. Highlights lend the illusion of shininess. For example, a piece of wood displays no highlight, while a piece of polished metal has one or more distinct highlights. This color is generally the same as that of the direct lighting falling on the affected surface but does not have to be.

- **Specular Value**: The Specular_Value is the amount of influence the specular color has on the shader. A higher value will create larger, more distinct highlights and vice versa.

- **Roughness**: The Roughness attribute defines the size of highlights.

- **Normals_Forward**: Checking the Normals_Forward checkbox will flip the surface normal to point towards the camera (or towards the ray in case of raytracing). Use this option to avoid shading artifacts on double-sided polygons.

### Variable Nodes

These are the value nodes included with Poser. Unless specified otherwise, the list of attributes for each node is listed from top to bottom.

#### dNdu

The dNdu node represents the derivative of the surface normal in the 'U' direction. In other words, it defines the rate of change of the surface normal along 'U'.

#### dNdv

The dNdv node represents the derivative of the surface normal in the 'V' direction. In other words, it defines the rate of change of the surface normal along 'V'.

#### dPdu

The dPdu node represents a varying point surface shader variable. It is a vector perpendicular to the surface normal in the 'U' direction. Specifically, it indicates the derivative of the surface position along 'U'. It has no user-definable attributes.
**dPdv**

The dPdv node represents a varying point surface shader variable. It is a vector perpendicular to the surface normal in the 'V' direction. Specifically, it indicates the derivative of the surface position along 'V'. It has no user-definable attributes.

**Du**

The dU node defines the rate of change of surface parameters as pertains to the current pixel’s location in S space. The ‘d’ indicates a derivative of the ‘U’ parameter.

**Dv**

The dV node defines the rate of change of surface parameters as pertains to the current pixel’s location in T space. The ‘d’ indicates a derivative of the ‘V’ parameter.

**Frame Number (frame_number)**

The Frame Number node returns the current frame number. It has no user-definable attributes.

**N**

The N node returns the normal at the specified point. It has the following attributes:

![N Node](image)

- X: The X attribute is the normal vector’s X component.
- Y: The Y attribute is the normal vector’s Y component.
- Z: The Z attribute is the normal vector’s Z component.
Visualizes direction of surface normal.

**P**

The P node defines a point in space. It has the following attributes:

![P Node](image)

- **X**: The X attribute is the point’s X location.
- **Y**: The Y attribute is the point’s Y location.
- **Z**: The Z attribute is the point’s Z location.

**U Texture Coordinate (u)**

The U node returns the S coordinate in texture space of the pixel currently being rendered. It has no user-definable attributes.

**V Texture Coordinate (v)**

The V node returns the T coordinate in texture space of the pixel currently being rendered. It has no user-definable attributes.

**3D Texture Nodes**

These are the color nodes included with the Material room. Unless specified otherwise, the list of attributes for each node is listed from top to bottom.
### Cellular

The Cellular node is used to create mosaic or cubic tiles. It has the following attributes:

![Cellular node](image)

- **Color1**: The Color1 attribute specifies the cell color.
- **Intensity1**: The Intensity1 attribute determines the degree of dominance between the cells and the cusps.
- **Color2**: The Color2 attribute specifies the color of the borders between the cells.
- **Intensity2**: The Intensity2 attribute determines the degree of dominance between the cells and the cusps.
- **ScaleX**: The ScaleX attribute controls the size of the tiles along the x axis.
- **ScaleY**: The ScaleY attribute controls the size of the tiles along the y axis.
- **ScaleZ**: The ScaleZ attribute controls the size of the tiles along the z axis.
- **RandomColor**: Enabling the RandomColor attribute specifies that the color of each cell will be randomly determined.
- **CellMode**: The CellMode attribute determines the type and shape of the cells. It has the following options:
  - **Mode 1**: This option creates 3D tiles. You can increase the Intensity1 value to make the tiles more prominent.
  - **Mode 2**: This option emphasizes the cracks between the cells. Set the Intensity1 value relatively high to maximize this effect.
  - **Mode 3**: This option creates a spider-web effect. The Color1 attribute defines the color of the web strands. Set the Intensity1 value relatively high to maximize this effect.
  - **Mode 4**: This option is similar to that of Mode 3, but it includes an additional dimension.
  - **Mode 5**: This option creates a quilt-style cell pattern when the RandomColor attribute is enabled.
• **Jitter**: The Jitter attribute controls the irregularity of the cell sizes.

• **Turbulence**: The Turbulence attribute controls the irregularity of the cell boundaries.

• **GlobalCoordinates**: When the GlobalCoordinates attribute is enabled, the object will use the global coordinates.

• **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

### Clouds

The Clouds node simulates cloud patterns. It has the following attributes:

![Clouds node](image)

- **Sky Color**: The Sky_Color attribute defines the areas behind the clouds. Clicking it opens the standard Color Picker.

- **Cloud Color**: The Cloud_Color attribute defines the clouds. Clicking it opens the standard Color Picker.

- **Scale**: The Scale attribute defines the size of the clouds.

- **Complexity**: The Complexity attribute defines the complexity of the cloud patterns.

- **Bottom**: The Bottom attribute controls the bottom color level or floor.

- **Bias**: The Bias attribute specifies how far to shift samples towards the light source to prevent self-shadowing of objects.

- **Gain**: The Gain attribute controls the balance between light and dark colors.

- **Global Coordinates**: Use the Global_Coordinates pull-down menu to select ON or OFF. When on, the texture is computed using world space instead of object space and vice versa. If this option is on while the object is moving in any way, the texture will appear to “slide” through the object when rendered.

- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.
• **Offset X, Y, or Z**: Enter the amount of offset desired from default X, Y, and Z position, for animation of 3D texture node.

### fBm

The fBm node is a multi-fractal function. It has the following attributes:

![fBm node](image)

- **Signed**: Checking the Signed checkbox returns values in the range –1 to 1. If unchecked, values less than 0 will be returned unsigned, e.g. –25 will be returned as 25.

- **Fractal Increment**: The Fractal_Increment attribute controls noise. Lower values result in a smoother noise gradient.

- **Frequency Gap**: The Frequency_Gap attribute controls fractal size. Higher values produce larger fractals.

- **Octaves**: The Octaves attribute defines the number of iterations for the fractal function. Higher values produce more detailed fractals but may increase render time.

- **X Scale**: The scale of the property along the X (horizontal) axis.

- **Y Scale**: The scale of the property along the Y (vertical) axis.

- **Z Scale**: The scale of the property along the Z (depth) axis.

- **Bottom**: The Bottom attribute controls the bottom color level or floor.

- **Bias**: The Bias attribute specifies how far to shift samples towards the light source to prevent self-shadowing of objects.

- **Gain**: The Gain attribute controls the balance between light and dark colors.

- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

- **Offset X, Y, or Z**: Enter the amount of offset desired from default X, Y, and Z position, for animation of 3D texture node.
Fractal Sum (Fractal_Sum)

The Fractal Sum node is a fractal function that returns values between –1 and 1. It has the following attributes:

- **X Scale**: The scale of the property along the X (horizontal) axis
- **Y Scale**: The scale of the property along the Y (vertical) axis.
- **Z Scale**: The scale of the property along the Z (depth) axis.
- **Octaves**: The Octaves attribute defines the number of iterations for the fractal function. Higher values produce more detailed fractals but may increase render time.
- **Bottom**: The Bottom attribute controls the bottom color level or floor.
- **Bias**: The Bias attribute specifies how far to shift samples towards the light source to prevent self-shadowing of objects.
- **Gain**: The Gain attribute controls the balance between light and dark colors.
- **Offset X, Y, or Z**: Enter the amount of offset desired from default X, Y, and Z position, for animation of 3D texture node.

Granite

The Granite node is a 3D simulation of speckled granite textures. It has the following attributes:
The Marble node is a 3D simulation of marble or other stone patterns. It has the following attributes:

- **Base Color**: The Base_Color attribute defines the base color. Clicking it opens the standard Color Picker.
- **Spot Color**: The Spot_Color attribute defines the spot color. Clicking it opens the standard Color Picker.
- **Scale**: The Scale attribute defines the size of the speckles (spots).
- **Shades**: The Shades attribute defines the number of shades used for the texture between and including the base and spot colors.
- **Balance**: The Balance attribute defines the lean towards the base or spot color. Values close to 0 favor the spot color while values closer to 1 favor the base color.
- **Global Coordinates**: Use the Global_Coordinates pull-down menu to select ON or OFF. When on, the texture is computed using world space instead of object space and vice versa. If this option is on while the object is moving in any way, the texture will appear to “slide” through the object when rendered.
- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

**Marble**

The Marble node is a 3D simulation of marble or other stone patterns. It has the following attributes:

- **Base Color**: The Base_Color attribute defines the base color. Clicking it opens the standard Color Picker.
- **Veins**: The Veins attribute defines the vein color. Clicking it opens the standard Color Picker.
- **Scale**: The Scale attribute defines the size of the veins.
- **Turbulence**: The Turbulence attribute defines the low-frequency randomness of the brick pattern.
- **Global Coordinates**: Use the Global_Coordinates pull-down menu to select ON or OFF. When on, the texture is computed using world space instead of object space and vice versa. If this option is on while the object is moving in any way, the texture will appear to “slide” through the object when rendered.
Noise

The Noise node adds random “static” or “snow” effects. It has the following attributes:

- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

Spots

The Spots node consists of a 3D texture composed of random spots. It has the following attributes:

- **Base Color**: The Base_Color attribute defines the base color. Clicking it opens the standard Color Picker.
- **Spot Color**: The Spot_Color attribute defines the spot color. Clicking it opens the standard Color Picker.
• **Spot Size**: The Spot_Size attribute defines the size of the spots.

• **Softness**: The Softness attribute determines the transition from the spot to the base color.

• **Threshold**: The Threshold attribute defines the lean towards the base or spot color. Values close to 0 favor the base color while values closer to 1 favor the spot color.

• **Global Coordinates**: Use the Global_Coordinates pull-down menu to select ON or OFF. When on, the texture is computes using world space instead of object space and vice versa. If this option is on while the object is moving in any way, the texture will appear to “slide” through the object when rendered.

• **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

### Turbulence

The Turbulence node is an unsigned fractal function. It has the following attributes:

- **X Scale**: The scale of the property along the X (horizontal) axis
- **Y Scale**: The scale of the property along the Y (vertical) axis.
- **Z Scale**: The scale of the property along the Z (depth) axis.
- **Octaves**: The Octaves attribute defines the number of iterations for the fractal function. Higher values produce more detailed fractals but may increase render time.
- **Bottom**: The Bottom attribute controls the bottom color level or floor.
- **Bias**: The Bias attribute specifies how far to shift samples towards the light source to prevent self-shadowing of objects.
- **Gain**: The Gain attribute controls the balance between light and dark colors.
- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.
Wave3D

The Wave3D node implements a three-dimensional sin / cos trigonometric function, resulting in a three-dimensional wave effect.

Wood

The Wood node provides a 3D texture that simulates wood patterns. It has the following attributes:

- **Light Wood**: The Light_Wood attribute defines the base wood color. Clicking it opens the standard Color Picker.
- **Dark Wood**: The Dark_Wood attribute defines the wood grain color. Clicking it opens the standard Color Picker.
- **Scale**: The Scale attribute determines the size of the wood grain.
- **Turbulence**: The Turbulence attribute determines the amount of randomness of the wood grain.
- **Global Coordinates**: Use the Global_Coordinates pull-down menu to select ON or OFF. When on, the texture is computed using world space instead of object space and vice versa. If this option is on while the object is moving in any way, the texture will appear to “slide” through the object when rendered.
- **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.
Ray Trace Nodes

To use the raytracing nodes, you must have raytracing enabled in the Render Settings dialog, as described in The Render Settings Dialog.

Ambient Occlusion (Ambient_Occlusion)

The Ambient Occlusion node uses raytracing to calculate the degree to which other objects within a scene mask (or occlude) the ambient light of a surface at a given point. Surfaces with greater occlusion ratios will be rendered as darker than surfaces with little or no occlusion. This node has the following attributes:

- **Samples**: The Samples attribute determines the number of rays projected. Too few samples will result in a grainy appearance in the darker areas of the scene. Higher sample rates yield higher quality darkened areas, but take longer to render.

- **MaxDist**: The MaxDist attribute allows you to control the maximum distance that the rays will travel through the scene, thus limiting the amount of data collected.

- **RayBias**: The RayBias attribute helps to prevent false shadows and other artifacts that may occur as a result of using raytracing techniques in conjunction with displacement maps. RayBias offsets the starting point of the rays above the geometry of the surface, so as to avoid the displacement geometry in the raytracing calculation. Be aware that if your RayBias setting is too high, your shadows will migrate in the scene.

  Ray Bias parameter is not supported in SuperFly.

- **Strength**: The Strength attribute controls the degree to which the Ambient Occlusion node will darken the occluded surfaces within the scene.

- **Evaluate in IDL**: Check this option if you want Poser to consider ambient occlusion settings during an indirect lighting pass.
Fresnel (fresnel)

The Fresnel node is used for surfaces that are both refractive and reflective (also known as dielectrics). Such surfaces tend to reflect more when the observer to surface angle is high, and refract more when the observer to surface angle is low. Most surfaces that are transparent (refractive) are also reflective.

To use the Fresnel node with a surface node, plug it into the surface node’s refraction_color channel. Set the Diffuse values low, and Transparency to 0. The Fresnel node has the following attributes:

- **Background**: The Background attribute selects the background color to be used for raytracing. Clicking this attribute opens a standard Color Picker.

- **Index of Refraction**: The Index of Refraction attribute controls how much light bends when passing through the object.

- **Quality**: The Quality attribute controls how many rays are spawned by hitting a surface. Increasing this value increases the realism of reflections but consumes computing resources.

  *Quality parameter is not supported in SuperFly.*

- **Softness**: The Softness attribute controls how sharp or smooth refracted light appears after passing through an object.
Gather

The Gather node uses raytracing to collect color and light information from the surfaces within a specific area, which when combined with an infinite light source adds a realistic “outdoor” lighting effect. This effect also adds some color bleeding to the rendered scene. The Gather sampling area, or cone, is defined by the following attributes:

- **Samples**: The Samples attribute determines the number of Gather rays projected. Higher sample rates yield more realistic results, but take longer to render.

- **MaxDist**: The MaxDist attribute allows you to control the maximum distance that the Gather rays will travel through the scene, thus limiting the amount of data collected.

- **RayBias**: The RayBias attribute helps to prevent false shadows and other artifacts that may occur as a result of using raytracing techniques in conjunction with displacement maps. RayBias offsets the starting point of the Gather rays above the geometry of the surface, so as to avoid the displacement geometry in the raytracing calculation. Be aware that if your RayBias setting is too high, your shadows will migrate in the scene.

  *Ray Bias parameter is not supported in SuperFly.*

- **Angle**: The Angle attribute sets the angle of the cone in which the Gather rays will be projected. A wider angle will result in a greater area and hence more data. More data will give you more realistic results, but longer render times.

  *Without Gather/no color bleeding (left); With Gather/color bleeding (right).*

Reflect

The Reflect node specifies the reflection color when raytracing. It has the following attributes:
Reflect node.

- **Background**: The Background attribute selects the background color to be used for raytracing. Clicking this attribute opens a standard Color Picker.

- **Quality**: The Quality attribute controls how many rays are spawned by hitting a surface. Increasing this value increases the realism of reflections but consumes computing resources.

- **Softness**: The Softness attribute controls the randomness of the directions of reflected rays.

- **RayBias**: The RayBias attribute helps to prevent false shadows and other artifacts that may occur as a result of using raytracing techniques in conjunction with displacement maps. RayBias offsets the starting point of the rays above the geometry of the surface, so as to avoid the displacement geometry in the raytracing calculation. Be aware that if your RayBias setting is too high, your shadows will migrate in the scene.

  
  *Quality and Ray Bias parameters are not supported in SuperFly.*

**Refraction**

The Refract node specifies the refraction color when raytracing. It has the following attributes:

- **Background**: The Background attribute selects the background color to be used for raytracing. Clicking this attribute opens a standard Color Picker.

- **Index of Refraction**: The Index of Refraction attribute controls how much light bends when passing through the object.

- **Quality**: The Quality attribute controls how many rays are spawned by hitting a surface. Increasing this value increases the realism of reflections but consumes computing resources.

- **Softness**: The Softness attribute controls how sharp or smooth refracted light appears after passing through an object.
2D Texture Nodes

These are the color nodes included with the Material room. Unless specified otherwise, the list of attributes for each node is listed from top to bottom.

Brick

The Brick node simulates brick or stone wall patterns. It has the following attributes:

- **RayBias**: The RayBias attribute helps to prevent false shadows and other artifacts that may occur as a result of using raytracing techniques in conjunction with displacement maps. RayBias offsets the starting point of the rays above the geometry of the surface, so as to avoid the displacement geometry in the raytracing calculation. Be aware that if your RayBias setting is too high, your shadows will migrate in the scene.

  Quality and Ray Bias parameters are not supported in SuperFly.

- **Brick Color**: The Brick_Color attribute defines the brick color. Clicking it opens the standard Color Picker.

- **Mortar Color**: The Mortar_Color attribute defines the mortar color. Clicking it opens the standard Color Picker.

- **Brick Width**: The Brick_Width attribute determines the horizontal scale of the bricks.

- **Brick Height**: The Brick_Height attribute determines the vertical scale of the bricks.

- **Mortar Width**: The Mortar_Width attribute determines the spacing between bricks.

- **Turbulence**: The Turbulence attribute defines the low frequency randomness of the brick pattern.

- **Softness**: The Softness attribute defines how softly the brick blends into the mortar.

- **Noise**: The Noise attribute defines the high frequency randomness of the brick pattern.
The Image Map node allows you to specify an image to use as a map (texture, reflection, transparency, bump, displacement, etc.). You can use any image as a map. However, if you want to use a map designed for the particular figure/prop, you must use an image that has been set up to work that way. This node has the following attributes:

- **Image Map (Image_Map)**

Poser supports texture resolutions up to 8192 x 8192 pixels. Note, however, that high resolution textures consume a greater amount of system resources.

- **Image Source**: Displays the currently loaded image. Clicking the Image Source attribute opens the Texture Manager dialog. To load an image map, either select the path from the drop-down list or click the Browse button to open a standard Open dialog and select the image you wish to load. A preview of your selected image should appear in the preview window. You can also select to use a global gamma value as set in the Render Settings dialog, or enter a specific gamma value that is unique to the selected texture. Click **OK** to implement your changes or **Cancel** to abort.
When creating PBR-type shaders, Diffuse textures typically use the gamma value from Render Settings. All other image types (bump, height, specular, transparency, normal, metal, and roughness) use a Custom Gamma value of 1. Poser tries to automatically assign a custom gamma value of 1 to images when they are dragged and dropped into the material room, based on a recognized suffix in the filename. For example, if the filename ends in \_normal or \_n, it will detect that it is a normal map and automatically assign a gamma value of 1.

This function recognizes the following words in the filenames, preceded by an underscore character:

\_albedo or \_a
\_bump or \_b
\_color, \_col, or \_c
\_diffuse or \_d
\_emissive or \_e
\_height or \_h
\_normal or \_n
\_roughness, \_rough, or \_r
\_specular, \_spec, or \_s
\_transparency, \_trans, or \_t

Choosing a texture map.

- **Auto_Fit**: Check this option to automatically fit the texture map to the currently selected material without tiling.

- **U Scale**: The U_Scale attribute sets the U scale factor to apply to the texture map when using UV or VU mapping. When using a projection map method (see below), this is one of the two attributes used to define the world space size of the texture map being projected onto the surface.

- **V Scale**: The V_Scale attribute sets the V scale factor to apply to the texture map when using UV or VU mapping. When using a projection map method (see below), this is one of the two attributes used to define the world space size of the texture map being projected onto the surface.
• **U Offset**: The U_Offset attribute defines the U position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection "screen" in grid units.

• **V Offset**: The V_Offset attribute defines the V position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection "screen" in grid units.

• **Texture Coordinates**: The Texture_Coordinates pull-down menu offers the following choices:

  • **UV**: The UV option behaves like rubber wallpaper that can stretch over the object surface; the image file is made to correspond with set positions on the object's surface, making any distortion caused by the stretching seem more natural. This is the most versatile mapping method.

  • **VU**: The VU option is identical to UV mapping, except that the image map is rotated 90 degrees.

  • **XY**: The XY option works like a slide projector in that the "screen" being projected onto is the XY plane whose size and position are determined using the U_Scale, V_Scale, U_Offset, and V_Offset parameters. Any surface not oriented with the selected viewing plane will distort the texture at render time.

  • **XZ**: Same as above but uses the XZ plane.

  • **ZY**: Same as above but uses the ZY plane.

• **Image Mapped**: The Image_Mapped pull-down menu offers the following choices:

  • **None**: The background color will be used for all areas of the object not covered by the texture map.

  • **Alpha**: The background color will be used for all areas of the object not covered by the texture map. The background color will also be blended with the texture map based on the alpha channel of the texture map.

  • **Clamped**: The edge pixels of the texture map are repeated to cover any area of the object that the texture map does not cover.

  • **Tile**: The texture map will be tiled to ensure total coverage. Tiling is controlled using the Mirror U and Mirror V attributes, below.

• **Background**: The Background attribute specifies the background color. Clicking this attribute opens a standard Color Picker. Global_Coordinates button forces projected maps to use global instead of local coordinates.

• **Global Coordinates**: This option is unused.

• **Mirror U**: Enabling the Mirror_U option can help hide the seams between texture cells when tiling textures.

• **Mirror V**: Enabling the Mirror_V option can help hide the seams between texture cells when tiling textures.

• **Texture Strength**: The Texture_Strength attribute defines the strength of the texture map, where 1=100%.
• **Filtering**: The Filtering attribute allows you to select one of three options for texture filtering on the selected image map. These options are: **None**—no texture filtering; **Fast**—high-speed texture filtering; **Quality**—high-quality texture filtering; **Crisp**—provides more aliasing for increased crispness.

*The Texture Filtering option defaults to the Crisp option.*

If you view seams in your textures during preview or rendering, the cause is usually that the textures don't extend very far past the template boundary line. While it has been suggested that changing from Crisp to Quality filtering can help this situation, it is not really an optimal solution, especially when you intend to use the texture maps in other 3D applications in addition to Poser. Instead, content creators are recommended to create "bleed areas" in the texture maps that extend beyond the template boundary.

Usually a bleed of about 10-12 pixels for a 2K texture, and 20-25 pixels for a 4K texture will be sufficient enough to prevent visible seams at UV boundaries in most applications. An example of a bleed for a 4K head texture is shown in the following figure. The blue grid is the UV template for the head, and the actual head texture extends outward by 20 pixels in this example. Popular texturing programs such as Substance Painter and ZBrush allow you to configure the amount of bleed in their export settings.

![Extended Texture Example](image-url)

*Extend textures out beyond the template area to prevent seams from showing during previews and renders.*

**Movie**

The Movie node allows you to add animations to materials. Supported formats are AVI, MPG, and WMV. This node has the following attributes:
Movie node.

- **Video Source**: The Video_Source attribute specifies the path containing the selected animation.

- **U_Scale**: The U_Scale attribute defines the size of the animation in the U direction.

- **V_Scale**: The V_Scale attribute defines the size of the animation in the V direction.

- **U_Offset**: The U_Offset attribute defines the U position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection “screen” in grid units.

- **V_Offset**: The V_Offset attribute defines the V position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection “screen” in grid units.

- **Texture Coordinates**: The Texture_Coordinates pull-down menu offers the following choices:
  - **UV**: The UV option behaves like rubber wallpaper that can stretch over the object surface; the PICT file is made to correspond with set positions on the object’s surface, making any distortion caused by the stretching seem more natural. This is the most versatile mapping method.
  - **VU**: The VU option is identical to UV mapping, except that the image map is rotated 90 degrees.
  - **XY**: The XY option works like a slide projector in that the “screen” being projected onto is the XY plane whose size and position are determined using the U_Scale, V_Scale, U_Offset, and V_Offset parameters. Any surface not oriented with the selected viewing plane will distort the texture at render time.
  - **XZ**: Same as above but uses the XZ plane.
  - **ZY**: Same as above but uses the ZY plane.

- **Image Mapped**: The Image_Mapped pull-down menu offers the following choices:
- **None**: The background color will be used for all areas of the object not covered by the texture map.

- **Alpha**: The background color will be used for all areas of the object not covered by the texture map. The background color will also be blended with the texture map based on the alpha channel of the texture map.

- **Clamped**: The edge pixels of the texture map are repeated to cover any area of the object not which the texture map does not cover.

- **Tile**: The texture map will be tiled to ensure total coverage. Tiling is controlled using the Mirror U and Mirror V attributes, below.

- **Background**: The Background attribute specifies the background color.

- **Global Coordinates**: Checking the Global_Coordinates button forces projected maps to use global instead of local coordinates.

- **Mirror U**: Enabling the Mirror_U option can help hide the seams between texture cells when tiling textures.

- **Mirror V**: Enabling the Mirror_V option can help hide the seams between texture cells when tiling textures.

- **Texture Strength**: The Texture_Strength attribute defines the strength of the animated texture map, where 1=100%.

- **Frame Number**: The Frame Number attribute functions primarily as an input for other nodes (such as math and variable nodes), and allows you to retime the animation controlled by this node.

- **Loop Movie**: Checking the Loop Movie checkbox loops the animation.

**Tile**

The Tile node is a 2D texture that simulates tile patterns. It has the following attributes:

![Tile node](image-url)
• **Tile 1**: The Tile_1 attribute defines the first tile color. Clicking it opens the standard Color Picker.

• **Tile Shape 1**: The Tile_Shape_1 pull-down menu defines the shape of the first tile. Your options are:
  - **Rectangle**: Selecting Rectangular will make the tiles rectangular.
  - **Ellipsoid**: Selecting Ellipsoid will make the tiles elliptical.

• **Tile 2**: This attribute defines the second tile color. Clicking it opens the standard Color Picker.

• **Tile Shape 2**: The Tile_Shape_2 pull-down menu defines the shape of the second tile. This menu has the same options as the Tile 1 Shape menu, described above.

• **Mortar Color**: The Mortar_Color attribute defines the mortar color. Clicking it opens the standard Color Picker.

• **Tile Width**: The Tile_Width attribute defines the tile’s width.

• **Tile Height**: The Tile_Height attribute defines the tile’s height in.

• **Mortar Thickness**: The Mortar_Thickness attribute determines the spacing between bricks.

• **Turbulence**: Defines the low-frequency randomness of the brick pattern.

• **Softness**: The Softness attribute defines how softly the brick blends into the mortar.

• **Noise**: The Noise attribute defines the high-frequency randomness of the brick pattern.

• **U Offset**: The U_Offset attribute defines the U position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection “screen” in grid units.

• **V Offset**: The V_Offset attribute defines the V position of the first texture tile in UV space. When using a projection map method (see below), this is one of two attributes used to define the position of the upper left corner of the projection “screen” in grid units.

• **Noise_Type**: The Noise_Type attribute allows you to select between the Original Perlin type and the Improved enhanced noise definitions.

### Wave2D

The Wave2D node implements a two-dimensional sin / cos trigonometric function, resulting in a two-dimensional wave effect.

![Wave2D node](image)
Weave

The Weave node creates woven textile effects. It has the following attributes:

- **u_pos**: Adjusts the horizontal position of the wave.
- **v_pos**: Adjusts the vertical position of the wave.
- **frequency**: Higher settings create more concentric circles in the texture.
- **phase**: Adjusts the light-dark positions in the rings of the concentric circles.

**Weave**

The Weave node creates woven textile effects. It has the following attributes:

- **Color 1**: The Color_1 attribute defines the first woven color. Clicking this attribute opens the standard Color Picker.
- **Color 2**: The Color_2 attribute defines the second woven color. Clicking this attribute opens the standard Color Picker.
- **Base Color**: The Base_Color attribute defines the underlying color behind the woven pattern. Clicking this attribute opens the standard Color Picker.
- **U Scale**: The U_Scale attribute defines the size of the weave in the U direction.
- **V Scale**: The V_Scale attribute defines the size of the weave in the V direction.
- **Height**: The Height attribute defines the height of the woven pattern.
- **Bias**: The Bias attribute adjusts the weave’s bias.
- **Gain**: The Gain attribute adjusts the weave’s gain.
Cycles Nodes

Color

BrightContrast

Inputs:

- **Color**: Input texture to be corrected.
- **Bright**: A multiplier. Positive values increase the overall brightness of the image. Negative values darken the image.
- **Contrast**: A scaling factor that makes brighter pixels brighter but keeps darker pixels dark. Higher values make details stand out. Negative numbers decrease the overall contrast in the image.

Outputs:

- **Color**: Adjusted color output.

Gamma

Correct lighting issues (such as light attenuation with distance, light falloff at terminators, and light and shadow superpositions). Gamma correction corrects similarly to how digital cameras correct photos. In other words, gamma correction is 0.45, not 2.2.
Cycles Gamma node.

Inputs:

- **Color**: Input texture to be corrected.
- **Gamma**: Enter an exponential brightness factor for correction.

Outputs:

- **Color**: Adjusted color output.

**HSV**

Changes the Hue, Saturation, and/or Value of a color or an image.

Cycles HSV node.

Inputs:

- **Hue**: Enter the desired adjustment factor for changing the Hue. The values of 0 to 1 represent a 360 degree rotational shift. A value of .5 produces no hue change. Entering 0 represents -180 degree rotation, and entering 1 represents 180 degree rotation, resulting in the same color shift.

- **Saturation**: Enter the desired adjustment factor for changing the Saturation. A value of 0 completely desaturates the image, turning it to grayscale. A value higher than 1 increases image saturation.
Outputs:

- **Color**: Adjusted color output.

---

**Invert**

Inverts every pixel. Most commonly used to invert grayscale images.

![Cycles Invert node.](image)

**Inputs:**

- **Fac**: The strength of the inversion from 0 (no inversion) to 1 (full inversion). A value of .5 outputs a gray color.

- **Color**: The color or texture to be inverted.

**Outputs:**

- **Color**: Adjusted color output.

---

**LightFalloff**

Manipulates how light intensity decreases over distance. Output is in grayscale information. Realistic lighting falls off quadratically.

*NOTE: Using Linear or Constant falloff may introduce more light with each global illumination bounce and make images very bright if many bounces are used.*
**Inputs:**

- **Strength**: Light strength before applying falloff modification.
- **Smooth**: Smooth intensity of light near light sources. This can avoid harsh highlights, and reduce global illumination noise. For no smoothing, enter 0. Higher values smooth more.

**Outputs:**

- **Quadratic**: Quadratic light falloff; leaves strength unmodified if smooth is 0.0 and corresponds to reality.
- **Linear**: Linear light falloff; gives slower decrease in intensity over distance.
- **Constant**: Constant light falloff, where the distance to the light has no influence on its intensity.

*Linear or Constant falloff may cause more light to be introduced with every global illumination bounce, making the resulting image extremely bright if many bounces are used.*

**Mix**

Mixes two inputs together. Mixing can be used for material layering.
Inputs:

- **Fac**: The amount of mixing between the two shaders. Low values increase the effect of Color1. High values increase the effect of Color2.
- **Color1**: Color or texture input #1
- **Color2**: Color or texture input #2
- **Clamp**: Restricts the output range to values between 0 and 1.

**Common Blend Types:**

- **Add**: Adding blue to blue keeps it blue, but adding blue to red makes purple. White already has a full amount of blue, so it stays white. Use this to shift a color of an image. Adding a blue tinge makes the image feel colder.

- **Burn**: Burn mode inverts the pixel value of the lower layer, multiplies it by 256, divides that by one plus the pixel value of the upper layer, then inverts the result. It tends to make the image darker, somewhat similar to “Multiply” mode.

- **Color**: 
  - **Darken**: With the colors set here, it’s like looking at the world through rose-colored glasses.
  - **Difference**: It takes out a color. The color needed to turn Yellow into White is Blue. Use this to compare two very similar images to see what had been done to one to make it the other; sort of like a change log for images. You can use this to see a watermark you have placed in an image for theft detection.
  - **Divide**: Divide mode multiplies each pixel value in the lower layer by 256 and then divides that by the corresponding pixel value of the upper layer plus one. (Adding one to the denominator avoids dividing by zero.) The resulting image is often lighter, and sometimes looks “burned out”.

*Cycles Mix node.*
• **Dodge**: Dodge mode multiplies the pixel value of the lower layer by 256, then divides that by the inverse of the pixel value of the top layer. The resulting image is usually lighter, but some colors may be inverted.

• **Hue**: Shows you how much of a color is in an image, ignoring all colors except what is selected: makes a monochrome picture (style ‘Black & Hue’).

• **Lighten**: Like bleach makes your whites whiter. Used with a mask to lighten up a little.

• **Linear Light**:

• **Mix**: Combines the two images, averaging the two.

• **Multiply**: Black (0.0) times anything leaves black. Anything times White (1.0) is itself. Use this to mask out garbage, or to colorize a black-and-white image.

• **Overlay**: Overlay mode inverts the pixel value of the lower layer, multiplies it by two times the pixel value of the upper layer, adds that to the original pixel value of the lower layer, divides by 255, and then multiplies by the pixel value of the original lower layer and divides by 255 again. It darkens the image, but not as much as with “Multiply” mode.

• **Saturation**: Low values desaturate the image, and make it more grayscale. Higher values oversaturate the colors in the image.

• **Screen**: Screen mode inverts the values of each of the visible pixels in the two layers of the image. (That is, it subtracts each of them from 255.) Then it multiplies them together, divides by 255 and inverts this value again.

• **Soft Light**: Soft light tends to make the edges softer and the colors not so bright. It is similar to “Overlay” mode.

• **Subtract**: Taking Blue away from white leaves Red and Green, which combined make Yellow. Taking Blue away from Purple leaves Red. Use this to desaturate an image. Taking away yellow makes an image bluer and more depressing.

• **Value**: Lower values darken the image, while higher values lighten the image.

• **Comparison Types**:

• **Sign**: Extracts the sign of Color1. All positive numbers will output 1.0. All negative numbers will output -1.0. And 0.0 will output 0.0

• **Function Types**:

• **Absolute**: Color1 is read with without regard to its sign. This turns negative values into positive values.

• **Exp**: Raises Euler’s number to the power of Color1

• **Logarithm**:

• **Power**:

• **Sqrt**: The square root of Color1

• **Rounding Types**:

• **Ceil**: Rounds Color1 up to the nearest integer
• **Floor**: Rounds Color1 down to the nearest integer

• **Modulo**: Outputs the remainder once Color1 is divided by Color2

• **Round**: Rounds Color1 to the nearest integer

• **Trigonometric Blend Types**:
  
  • **Cosine**: The Cosine of Color1
  
  • **Sine**: The Sine of Color1
  
  • **Tangent**: The Tangent of Color1

• **Poser-Specific Types**:
  
  • **Bias**: Takes two values, each between 0 and 1. Color1 is the input to be mapped (such as an image). Color2 is a bias factor that pushes the range of the input values toward 0 or 1. A bias of 0 is all black; .5 is no change; 1 is all white.

  • **Gain**: Gain: Similar to bias, but Color2 is applied as an exponent around the center value so that the center stays locked. Smaller values lighten the image, and values higher than .5 darken the image.

  • **Smoothstep**: Smoothstep: Takes a single value (Color1) and returns a mapped value as if the step function is smooth between 0 and 1. A value of .5 stays in place. Other values will smoothly transition using a hermite curve.
Cycles Mix examples.

**Outputs:**

- **Color:** Adjusted color output.

**Converter**

The Combine and Separate nodes split out an image into, or recombine from, its composite color channels. Each format supports the Alpha (transparency) channel. Several color spaces are supported.

**Blackbody**

Converts a blackbody temperature to RGB. Useful for materials that emit light at naturally occurring frequencies.
Cycles Blackbody node.

Inputs:
- **Temperature**: The temperature in Kelvin.

Outputs:
- **Color**: The adjusted RGB color

**CombineHSV**

Combines three values, often considered as more intuitive than the RGB system (nearly only used on computers)

Cycles CombineHSV node.

Inputs:
- **H**: the Hue of the color (in some way, choose a ‘color’ of the rainbow)
- **S**: the quantity of hue in the color (from desaturate - shade of gray - to saturate - brighter colors)
- **V**: (from ‘no light’ - black - to ‘full light’ - ‘full’ color, or white if Saturation is 0.0)

**Outputs:**
- **Color**: The adjusted color

**CombineRGB**

This node combines separate input images as each color channel, producing a composite image. Use this node to combine the channels after working on each color channel separately.

![Cycles CombineRGB node.](image)

**Inputs:**
- **R** (Red), **G** (Green) and **B** (Blue). Values between 0 and 1 are expected.

**Outputs:**
- **Image**: The combined R, G, and B image

**CombineXYZ**

Combines the X, Y, and Z values of a vertex.

![Cycles CombineXYZ node.](image)

**Inputs:**
- **X**, **Y**, and **Z** vertex coordinates.

**Outputs:**
- **Vector**: The combined vector values
**Math**

Performs mathematical calculations of between one and three inputs.

*Cycles Math node.*

**Inputs:**

- **Value1**: Input number 1
- **Value2**: Input number 2
- **Value3**: Input number 3.
- **Clamp**: Restricts the output range to values between 0 and 1.

**Function Types:**

- **Absolute**: Uses one value. The input value is read with without regard to its sign. This turns negative values into positive values.
- **Add**: The sum of two values.
- **Divide**: The product of two values.
- **Exponent**: Raises Euler’s number to the power of Value1.
- **Inverse Sqrt**: One divided by the square root of Value1.
- **Logarithm**: The log of Value1 with Value3 (Base) as its base.
- **Multiply**: The product of Value1 and Value2.
- **Multiply_Add**: Multiples Value1 and Value2, then adds Value3.
- **Power**: The Base (Value1) raised to the power of Exponent (Value3).
- **Subtract**: The difference between Value1 and Value2.
- **Sqr**: The square root of Value1.

**Comparison Types:**

- **Compare**: Outputs 1.0 if the difference between Value1 and Value2 is less than or equal to Value3.
- **Greater Than**: Outputs 1.0 if Value1 is larger than Value2. Otherwise the output is 0.0.
- **Less Than**: Outputs 1.0 if Value1 is smaller than Value2. Otherwise the output is 0.0.
- **Maximum**: Outputs the largest of Value1 or Value2.
• **Minimum**: Outputs the smallest of Value1 or Value2.

• **Sign**: Extracts the sign of Value1. All positive numbers will output 1.0. All negative numbers will output -1.0. And 0.0 will output 0.0.

• **Smoothmax**: Smooths the unions between Value1 and Value2 with a maximum distance specified in Value3.

• **Smoothmin**: Smooths the unions between Value1 and Value2 with a minimum distance specified in Value3.

### Rounding Types:

• **Ceil**: Rounds Value1 up to the nearest integer.

• **Floor**: Rounds Value1 down to the nearest integer.

• **Fraction**: Returns the fractional part of Value1. For example, if the value is 1.268, the fraction will be .268.

• **Modulo**: Outputs the remainder once Value1 is divided by Value2.

• **Pingpong**: The output value is moved between 0.0 and Value3 (the Scale) based on Value1.

• **Round**: Rounds Value1 to the nearest integer.

• **Snap**: Rounds Value1 down to the nearest integer multiple of Value3 (the Increment).

• **Trunc**: Outputs the integer part of Value1.

• **Wrap**: Outputs a value between Value2 (Min) and Value3 (Max) based on the absolute difference between Value1 and the nearest integer multiple of Value3 (Max) less than the value.

### Trigonometric Types:

• **Arccosine**: The Arccosine of Value1.

• **Arcsine**: The Arcsine of Value1.

• **Arctangent**: The Arctangent of Value1.

• **Arctan2**: Outputs the Inverse Tangent of Value1 divided by Value2 measured in radians.

• **Cosh**: The Hyperbolic Cosine of Value1.

• **Cosine**: The Cosine of Value1.

• **Sine**: The Sine of Value1.

• **Sinh**: The Hyperbolic Sine of Value1.

• **Tangent**: The Tangent of Value1.

• **Tanh**: The Hyperbolic Tangent of Value1.

### Conversion Types:

• **Degree**: Converts the input from radians to degrees.
• **Radians**: Converts the input from degrees to radians.

**Poser-Specific Types:**

• **Bias**: Takes two values, each between 0 and 1. Value1 is the input to be mapped (such as an image). Value2 is a bias factor that pushes the range of the input values toward 0 or 1. A bias of 0 is all black; .5 is no change; 1 is all white.

• **Gain**: Similar to bias, but Value2 is applied as an exponent around the center value so that the center stays locked. Smaller values lighten the image, and values higher than .5 darken the image.

• **Smoothstep**: Takes a single value (Value1) and returns a mapped value as if the step function is smooth between 0 and 1. A value of .5 stays in place. Other values will smoothly transition using a hermite curve.

• **Step**: Generates a curve based on two inputs. Value2 is used to control the curve. If Value1 is below Value2, the curve is 0. If Value1 is above Value2, the curve is 1.

**Outputs:**

• **Value**: The adjusted value

**SeparateHSV**

Separates the Hue, Saturation, and Value of a color or image.

![SeparateHSV](image)

*Cycles SeparateHSV node.*

**Inputs:**

• **Color**: The input image or color

**Outputs:**

• **H**: the Hue of the color (in some way, choose a ‘color’ of the rainbow)

• **S**: the quantity of hue in the color (from desaturate - shade of gray - to saturate - brighter colors)

• **V**: (from ‘no light’ - black - to ‘full light’ - ‘full’ color, or white if Saturation is 0.0)

**SeparateRGB**

This node separates an image into its red, green, blue and alpha channels.
Cycles SeparateRGB node.

**Inputs:**
- **Color:** The input image or color

**Outputs:**
- R (Red), G (Green) and B (Blue)

**SeparateXYZ**

Separates the X, Y, and Z values of a vector.

Cycles SeparateXYZ node.

**Inputs:**
- **Vector:** Standard vector input.

**Outputs:**
- The individual X, Y, and Z values of the vector

**VectorMath**

Performs mathematical calculations on two inputs of three dimensional vectors (or three numbers)

Cycles VectorMath node.
Inputs:

- **Vector1**: The first vector input.
- **Vector2**: The second vector input.
- **Vector3**: The third vector input.
- **Scale**: Input scale.
- **Type**: Choose one of the following types:
  - **Add**: The sum of Vector1 and Vector2.
  - **Subtract**: The difference between Vector1 and Vector2.
  - **Multiply**: The entrywise product of Vector1 and Vector2.
  - **Divide**: The entrywise division of Vector1 by Vector2. Division by zero returns zero.
  - **Cross Product**: The cross product of Vector1 and Vector2.
  - **Project**: The projection of Vector1 onto Vector2.
  - **Reflect**: The reflection of Vector1 around the normal Vector2. Vector2 need not be normalized.
  - **Dot Product**: The dot product of Vector1 and Vector2.
  - **Distance**: The distance between Vector1 and Vector2.
  - **Length**: The length of Vector1.
  - **Scale**: The result of multiplying Vector1 by the Scale value.
  - **Normalize**: The result of normalizing Vector1.
  - **Wrap**: Wrap.
  - **Snap**: The result of rounding Vector1 to the largest integer multiple of B less than or equal Vector1.
  - **Floor**: The entrywise floor of Vector1.
  - **Ceil**: The entrywise ceiling of Vector1.
  - **Modulo**: The entrywise modulo of Vector1 by Vector2.
  - **Fraction**: The fractional part of Vector1.
  - **Absolute**: The entrywise absolute value of Vector1.
  - **Minimum**: The entrywise minimum from Vector1 and Vector2.
  - **Maximum**: The entrywise maximum from Vector1 and Vector2.
  - **Sine**: The Sine of Vector1.
  - **Cosine**: The Cosine of Vector1.
  - **Tangent**: The Tangent of Vector1.
Outputs:

- **Value**: Output value.
- **Vector**: Output vector.

## Wavelength

Converts a light ray wavelength to RGB. Can be used to achieve a specific color on the light spectrum.

*Cycles Wavelength node.*

Inputs:

- **Wavelength**: The color wavelength from 380 to 780 nanometers.

Outputs:

- **Color**: RGB color output.

## Input

### Camera

Outputs are determined by the distance from or angle to the camera.

*Cycles Camera node.*

Inputs:

- none.

Outputs:

- **View Vector**: A Camera space vector from the camera to the shading point.
- **View Z Depth**: The Z coordinate of the object that the camera is viewing
- **View Distance**: Distance from the camera to the shading point.
**Color**

Outputs the specified color. Useful when you need the same color as inputs for several different nodes.

![Cycles Color node.](image)

**Inputs:**
- **Color:** The color to be output from the node.

**Outputs:**
- **Color:** The output color from the node.

**Fresnel**

The amount of light that is reflected off a layer. The rest is refracted through the layer.

Commonly used to mix or blend between two BSDF nodes, such as a glossy refraction and a glossy reflection, through a Mix shader node, which produces a simple glass material.

![Cycles Fresnel node.](image)

**Inputs:**
- **Normal:** Connection for a normal map. If nothing is connected, the default normal shader will be used.
- **IOR:** Index of refraction of the material being entered.

**Outputs:**
- **Fac:** A grayscale output indicating fresnel weight. Indicates the probability with which light reflects off the layer rather than passing through it.

**Geometry**

Returns information about the current shading point, using world space vector coordinates. For volume shaders, only the position and incoming vector are available.
Cycles Geometry node.

**Inputs:**
None.

**Outputs:**
- **Position**: Position of the shading point.
- **Normal**: Shading normal at the surface (includes smooth normals and bump mapping)
- **Tangent**: Tangent at the surface.
- **True Normal**: Geometry or flat normal of the surface (does not include smooth normals or bump mapping)
- **Incoming**: Vector pointing towards the camera.
- **Parametric**: Parametric coordinates of the shading point on the surface.
- **Backfacing**: Output of 0 if the face is viewed from the front side, or 1 if the face is viewed from the back side.
- **Random Per Island**: A random value for each connected component (island) in the mesh. Adds variations to meshes that are composed of separated units, like tree leaves, wood planks, or curves of multiple splines.

HairInfo

This node gives access to strand hair information.

Cycles HairInfo node.
Outputs:

- **Is Strand**: Returns 1 when the shader is acting on a strand, otherwise returns 0.
- **Intercept**: The point along the strand where the ray hits the hair strand. Output is between 0 (when the ray hits the root) and 1 (when the ray hits the tip).
- **Thickness**: The thickness of the strand at the point where the ray hits the strand.
- **Tangent Normal**: Tangent normal of the strand.
- **Random**: A random per-hair value ranging from 0 to 1. Can be used in combination with a color ramp to randomize the hair color.

**LayerWeight**

Output weights typically used for layering shaders with the Mix Shader node.

![LayerWeight node](image)

_Cycles LayerWeight node._

**Inputs:**

- **Normal**: Connection for a normal map. If nothing is connected, the default normal shader will be used.
- **Blend**: The amount of blend between the first and second shader (0 for black, 1 for white). Lower values increase contrast.

**Outputs:**

- **Fresnel**: Like the Fresnel node, except that the input of this node is between the 0.0 to 1.0 range.
- **Facing**: Weight that blends from the first to the second shader as the surface faces or grazes the camera.

**LightPath**

Determines the kind of incoming light ray being executed. Useful for tricks that are not physically-based.
Inputs:
None.

Outputs:

- **Is Camera Ray**: Output of 1.0 if shading is executed for a camera ray, otherwise output is 0.
- **Is Shadow Ray**: Output of 1.0 if shading is executed for a shadow ray, otherwise output is 0.
- **Is Diffuse Ray**: Output of 1.0 if shading is executed for a diffuse ray, otherwise output is 0.
- **Is Glossy Ray**: Output of 1.0 if shading is executed for a glossy ray, otherwise output is 0.
- **Is Singular Ray**: Output of 1.0 if shading is executed for a singular ray, otherwise output is 0.
- **Is Reflection Ray**: Output of 1.0 if shading is executed for a reflection ray, otherwise output is 0.
- **Is Transmission Ray**: Output of 1.0 if shading is executed for a transmission ray, otherwise output is 0.
- **Is Volume Scatter Ray**: Output of 1.0 if shading is executed for a volume scatter ray, otherwise output is 0.
- **Ray Length**: Distance traveled by the light ray from the last bounce or camera.
- **Ray Depth**: Returns the current light bounce.
- **Transparent Depth**: Returns the number of transparent surfaces passed through.
ObjectInfo

Outputs information about the object instance. This can be useful for creating variations of a single material that is assigned to multiple instances. A Noise texture can give random colors, or a Color Ramp can give a range of colors to be randomly picked from.

Outputs:

- **Location**: World space location of the object.
- **Color**: The color of the object.
- **Alpha**: Object alpha information.
- **Object Index**: Object pass index.
- **Material Index**: Material pass index for each object that uses this material.
- **Random**: Random number between 0 and 1. Unique to a single object instance.

Tangent

Generates a tangent direction for the Anisotropic BSDF shader.
**Inputs:**

- **Direction**: Radial projects the tangent in a cylindrical manner. UV Map allows you to choose any UV map that is compatible with the figure.

- **Axis**: For Radial direction only. Choose X (left to right), Y (up and down), or Z (back to front) axis.

**Outputs:**

- **Tangent**: The tangent direction vector.

**TextureCoordinate**

Commonly used texture coordinates, to be used as inputs for the Vector input for texture nodes.

![Cycles TextureCoordinate node](image)

**Inputs:**

None.

**Outputs:**

- **Generated**: Automatically-generated texture coordinates ranging from 0.0 to 1.0 over the bounding box of the undeformed mesh.

- **Normal**: Object space normal that stays fixed on the object as it transformed.

- **UV**: UV texture coordinates, with U corresponding to the X axis of 3D space and V corresponding to the Y axis in 3D space.

- **Object**: Position coordinate in object space.

- **Camera**: Position coordinate in camera space.

- **Window**: Location of shading point on the screen, ranging from 0.0 (for the left or bottom of the screen) to 1.0 (for the right or top side of the screen).

- **Reflection**: Vector in the direction of a sharp reflection, typically used for environment maps.

- **Poser Window**: Connect this output to a Vector input on the Cycles image node.
**UVMap**

Used to retrieve specific UV maps using the material.

*Inputs:*
- **From dupli:**

*Outputs:*
- **UV:** UV texture coordinates, with U corresponding to the X axis of 3D space and V corresponding to the Y axis in 3D space.

**Value**

Outputs a constant value as specified. Useful when you need the same number as inputs for several different nodes.

*Inputs:*
None.

*Outputs:*
- **Value:** Enter the desired numerical value to be output from the node.

**Wireframe**

Retrieve the edges of an object. Meshes are triangulated before being processed, so they will appear triangulated when viewed with the Wireframe node. Wires are white, everything else is black.
Inputs:

- **Size**: Thickness of edge lines.
- **Pixel Size**: Check this option to set the size of edge lines in screen space.

Outputs:

- **Fac**: A black and white mask showing white lines that represent edges according to the topology of the object.

**Shader**

**AbsorptionVolume**

This node allows light to be absorbed as it passes through the volume. Typically used for water and colored glass.

![Cycles AbsorptionVolume node.](image)

**Inputs:**

- **Color**: The color that is absorbed.
- **Density**: The amount of light that interacts with the volume (how much is absorbed and how much passes through). Values of 0 produce no volume. Values above 0 increase the amount of volume.

**Outputs:**

- **Volume**: Plug this output into the **Volume** input of the Cycles root node.

**AddClosure**

Add two shaders together. Mixing can be used for material layering.

![Cycles AddClosure node.](image)

**Inputs:**

- **Closure1**: First shader to add
**AmbientOcclusion**

Ambient occlusion darkens shadow effects in gaps and crevices. With this option it’s possible to let only some materials be affected by AO, or to let it influence some materials more or less than others. This can be used to add weathering effects to corners only.

This shader is resource intensive and can slow down rendering times significantly. Adding a Geometry node with Pointiness setting, or baking Ambient Occlusion will make rendering faster.

*The current implementation of OptiX does not support the use of the AmbientOcclusion node in shaders. If you need to use Ambient Occlusion you will need to use a different hardware rendering option.*

**Inputs:**

- **Color:** Defines the tint color of the AO output (areas that are not occluded).
- **Distance (Cycles only):** Maximum distance that other objects are considered to occlude the shading point.
- **Normal:** The normal used for ambient occlusion. If nothing is connected, the default shading normal is used.

**Outputs:**

- **Color:** Ambient occlusion with color tint.
- **AO:** Ambient occlusion factor without color tint.

**AnisotropicBsdf**

Used to add a glossy reflection, with separate controls over U (horizontal) and V (vertical) direction roughness. The tangents are derived from the active UV map. If no UV map is
available, the tangents are generated automatically using spherical mapping based on the mesh's bounding box.

![Cycles AnisotropicBsdf node]

**Inputs:**

- **Color:** Defines the color of the surface.
- **Normal:** Connection for a normal map. If nothing is connected, the default normal shader will be used.
- **Tangent:** Tangent used for reflections; The default tangent will be used if nothing is connected.
- **Roughness:** The sharpness of the reflection, with 0 being completely sharp and higher values being smoother.
- **Anisotropy:** A value of 0 gives a rounder highlight. Higher values make the highlight elongated along the tangent.
- **Rotation:** Rotation of the anisotropic tangent direction. Values from 0 to 1 represent 0 to 360 degrees. For example, a value of 0.0 is 0 degrees, .25 is 90 degrees, and so on). Used to texture the tangent direction.
- **Distribution:** The type of microfacet distribution to use. Choices are Beckmann, GGX and Ashikhmin-Shirley.

**Inputs:**

- **BSDF:** Standard shader output.

**DiffuseBsdf**

Adds Lambertian or Oren-Nayar diffuse reflection.

![Cycles DiffuseBsdf node.]

**Inputs:**
Outputs:

- **BSDF:** Standard shader output.

## Emission

Used for light that emits from meshes. Used to add Lambertian emission.

Light strength for point, spot, and area lights is specified in Watts.

![Cycles Emission node.](image)

**Inputs:**

- **Color:** Color of the emitted light

- **Strength:** Strength or intensity of the emitted light. Unit is in watts for point and area lights. For materials, a value of 1.0 will ensure that the object in the image has the exact same color as the Color input.

**Outputs:**

- **Emission:** Plug this output into either a **Surface** input or the **Volume Input** of a material output node.

## GlassBsdf

Glass-works similar to the transparent shader. Pure white makes it transparent. The glass shader tends to cause noise due to caustics. It helps to combine this with a transparent shader for shadows.
Cycles GlassBsdf node.

**Inputs:**

- **Color:** Defines the amount of transparency. White is fully transparent. Black is fully opaque.

- **Normal:** Connection for a normal map. If nothing is connected, the default normal shader will be used.

- **Roughness:** Influences sharpness of the refraction. A value of 0 is perfectly sharp. Higher values blur the reflections and transmissions.

- **IOR:** Index of refraction defining how much the ray changes direction. At 1.0 rays pass straight through like transparent; higher values increase the amount of refraction.

- **Distribution:** Microfacet distribution to use. Sharp results in perfectly sharp refractions like clear glass, while Beckmann and GGX can use the Roughness input for rough or frosted glass.

**Outputs:**

- **BSDF:** Standard shader output.

GlossyBsdf

Glossy reflection with microfacet distribution, used for materials such as metal or mirrors.

Cycles GlossyBsdf node.

**Inputs:**

- **Color:** Defines the color of the surface.

- **Normal:** Connection for a normal map. If nothing is connected, the default normal shader will be used.

- **Roughness:** Perfectly glossy at 0.0. Increase the settings to make reflections softer/blurrer.
- **Distribution**: Defines the type of microfacet distribution to use. **Sharp** results in perfectly sharp reflections like a mirror (roughness will not apply in this mode). **Beckmann**, **GGX** and **Ashikhmin-Shirley** (all Cycles Only) use the Roughness input to soften/blur reflections.

**Outputs**:

- **BSDF**: Standard shader output.

### HairBsdf

Used to add shading for Hair.

![Cycles HairBsdf node.](image)

**Inputs**:

- **Color**: The color of the hair.
- **Offset**: Affects the angle of the “gap” between the hairs.
- **RoughnessU**: Determines the amount of glossiness along the length of the hair.
- **RoughnessV**: Determines the amount of glossiness along the width of the hair.
- **Tangent**: Input tangent.
- **Component**: Choose **Reflection** to set attributes for the hair surface, or **Transmission** to control how light passes through the hair.

**Outputs**:

- **BSDF**: Standard shader output.

### Holdout

Holds the surface from being exposed to the camera. Creates a transparent “hole” with zero alpha transparency in the render. This is useful for compositing.

![Cycles Holdout node.](image)
**Inputs:**

none

**Outputs:**

- **Holdout**: Standard shader output.

---

**MixClosure**

Mix two shaders together. Mixing can be used for material layering.

![MixClosure](image)

*Cycles MixClosure node.*

**Inputs:**

- **Fac**: Blend weight to use for mixing two shaders. A value of 0 uses the first shader entirely. A value of 1 uses the second shader entirely. Input can be from a blend weight node.

- **Closure1**: First shader to mix

- **Closure2**: Second shader to mix.

**Outputs:**

- **Closure**: Standard shader output.

---

**PrincipledBsdf**

See [Using the PrincipledBsdf Node](#)

---

**PrincipledHairBsdf**

Used for rendering strand-based hair and fur, as created in Poser's Hair room.
**Inputs:**

- **Color:** The RGB color of the strand. Only used in Direct coloring.
- **Melanin:** The absolute quantity of pigment, with 0-1 values relating to 0-100%. A value of 0 (or 0%) = white hair. A value of .25 (25%) is for light blonde hair. A value of .5 (or 50%) results in reddish hair color. A value of .75 (or 75%) is brown hair. A value of 1 (or 100%) results in black hair. See also **Melanin Concentration**, below.
- **Melanin Redness:** Defines the ratio between pheomelanin (red or yellow hair pigments) to eumelanin (black or brown hair pigments). Values of 0-1 correspond to 0-100%.
- **Tint:** The color that tints (or dyes) the hair after melanin is applied. Set to white for no tint.
- **Absorption Coefficient:** Attenuation coefficient.
- **Offset:** Tilts the glint of the hair by increasing the angle of the scales of the hair’s cuticle with respect to the hair shaft. Human hair usually has low values.
- **Roughness:** How much the glints are smoothed in the direction of the hair shaft. Too low values will smoothen the hair to the point of looking almost metallic, making glints look like Fireflies; while setting it too high will result in a Lambertian look.
- **Radial Roughness:** How much the glints are smoothed in the direction of the hair tangent. Too low values will concentrate the glint; while setting it too high will spread the light across the width of the strand.
- **Coat:** Simulates a shiny coat of fur. Reduces the Roughness factor for the first light bounce by a percentage of the original roughness setting. Values of 0-1 correspond to 0-100%.
- **IOR:** Index of refraction defining how much the ray changes direction. At 1.0 rays pass straight through like in a transparent material; higher values give more refraction.
- **Random Roughness:** For each strand, randomizes both Roughness values. Settings of 0-1 correspond to 0-100% randomness.
- **Random Color:** For each strand, randomizes the melanin concentration. Settings of 0-1 correspond to 0-100% randomness.
- **Random:** Random number source used if no node is connected here.
- **Normal:** A tuple input representing X, Y, and Z values respectively.
- **Method:**
  - **Direct Coloring:** Choose the desired RGB color and the shader will approximate the necessary absorption coefficient (below)
• **Melanin Concentration**: (see also Melanin and Melanin Redness, above). Defines the quantity and ratio of pigments found in hair and fur. The Melanin input defines the quantity, and the Melanin Redness defines the ratio between light and dark hair colors.

• **Absorption Coefficient**: This mode is intended mainly for technical users who want to use coefficients from the literature without any sort of conversion.

**Outputs:**

• **BSDF**: Standard shader output

---

**RefractionBsdf**

Used for materials that transmit light. Adds glossy refraction with sharp or microfacet distribution, typically for materials that transmit light. For best results, mix this with a glossy node using a fresnel factor to reduce darkness at the edges.

![Cycles RefractionBsdf node](image)

**Inputs:**

• **Color**: Defines the color of the refraction.

• **Normal**: Connection for a normal map. If nothing is connected, the default normal shader will be used.

• **Roughness**: Influences sharpness of the refraction; perfectly sharp at 0.0 and smoother with higher values

• **IOR**: Index of refraction defining how much the ray changes direction. At 1.0 rays pass straight through like transparent; higher values increase the amount of refraction.

• **Distribution**: Defines the type of microfacet distribution to use. Sharp does not use roughness values. Beckmann, GGX and Ashikhmin-Shirley use the Roughness input to soften/blur reflections.

**Outputs:**

• **BSDF**: Standard shader output.
ScatterVolume

Lets light scatter in other directions as it hits particles in the volume. Typically used to add fog to a scene, or used in combination with the Volume Absorption node to create smoke.

![Cycles ScatterVolume node.]

**Inputs:**

- **Color:** The color that is reflected. Unlike surface lighting nodes, this is not a color that is applied on top of the finished scattering calculation. It determines what color gets scattered and what color does not get scattered. The light that is not scattered is passed through the volume. For example, if white light passes through a volume that scatters blue, it will appear blue-ish where the light enters and scatters back, and yellow at the end where the light leaves the volume at the other end. The following figure shows more detail.

- **Density:** The amount of light that interacts with the volume (how much is absorbed and how much passes through). Values of 0 produce no volume. Values above 0 increase the amount of volume.

- **Anisotropy:** Defines the direction that the light scatters. A value of 0 scatters light evenly in all directions. Negative values scatter light backwards, and positive values scatter mostly forward.

**Outputs:**

- **Volume:** Plug this output into the Volume input of the Cycles root node.

ScatterVolume can be made to render in Cycles when the Cycles Surface input connects to a TransparentBsdf node as shown below.
SubsurfaceScattering

Simple subsurface multiple scattering, for materials such as skin, wax, marble, milk and others. Light penetrates the surface and bounces around internally before getting absorbed or leaving the surface at a nearby point.

**Inputs:**

- **Color:** Defines the base color of the surface. Example for blood red color is R 102, G 0, B 0.
- **Normal:** Connection for a normal map. If nothing is connected, the default normal shader will be used.
- **Scale:** Scale factor for the scattering radius. Default value is .01.
• **Radius**: The maximum distance that light can scatter. The scatter radius can be configured per RGB Color channel. For skin, red colors scatter further. Three values are expected in the Radius input, representing Red, Green, and Blue scatter radius respectively (example: .482, .169, and .109 are typical values for Caucasian skin.)

• **IOR**: Index of Refraction for Subsurface Scattering.

• **Anisotropy**: Controls the directionality of subsurface scattering.

• **Scatter Group ID**: Can be used to prevent bleeding between two materials that have different scattering properties. For example, you might assign all skin materials to one scatter ID, and other areas like lips, eyes, or nails to other scatter group IDs.

• **Method**:
  - **Burley**: Is an approximation to physically-based volume scattering.
  - **Random Walk**: Provides the most accurate results for thin and curved objects. This comes at the cost of increased render time or noise for more dense media like skin, but also better geometry detail preservation. Random Walk uses true volumetric scattering inside the mesh, which means that it works best for closed mesh.

**Outputs**:

• **BSSRDF**: Standard shader output.

**ToonBsdf**

Creates Diffuse and Glossy Toon BSDF for creating cartoon light effects.

![Cycles ToonBsdf node](image)

**Inputs**:

• **Color**: Defines the color of the surface.

• **Normal**: Connection for a normal map. If nothing is connected, the default normal shader will be used.

• **Size**: Values between 0.0 and 1.0 give angles of reflection between 0 and 90.

• **Smooth**: This value specifies an angle over which a smooth transition from full to no reflection happens.
Outputs:

- **BSDF**: Standard shader output.

**TranslucentBsdf**

Adds Lambertian diffuse transmission to the surface.

**Inputs:**

- **Color**: Defines the color of the surface that is scattered outward.
- **Normal**: Connection for a normal map. If nothing is connected, the default normal shader will be used.

**TransparentBsdf**

Used to add transparency without refraction. Only pure white transparent shaders are completely transparent.

**Inputs:**

- **Color**: Defines the amount of transparency. Black is fully opaque. White is fully transparent.

**Outputs:**

- **BSDF**: Standard shader output.

**VelvetBsdf**

Reflection shader for velvet cloth materials. Generally used in combination with other shaders such as a Diffuse shader.
Using the PrincipledBsdf Node

Base Color

Inputs:

- **Color**: Defines the color of the surface.
- **Normal**: Connection for a normal map. If nothing is connected, the default normal shader will be used.
- **Sigma**: Controls the sharpness of the peak of normal distribution, somewhat like a roughness control. Increase the settings to decrease the level and size of darkness in the velvet.

Outputs:

- **BSDF**: Standard shader output.

*Using the Color chip for color input.*

*Using a Color Map for color input.*
**Metallic**

Metallic inputs can either be a fixed value between 0 and 1 (with 0 being non-metallic and 1 being metallic), or a black and white texture map that identifies non-metallic areas in black and metallic areas in white. For an example of metallic maps connected to the PrincipledBsdf node, see [Kitty2 Textures-Principled](#) or [Kitty3 Textures-Principled](#). Metallic texture maps should be set to a Custom Gamma Value of 1.0.

**Subsurface Settings**

The following screen shot shows how to connect subsurface scattering to the Principled Surface node. The first example shows SSS combined with specular and bump maps. Note that the Specular map is processed through a **Gloss/Spec Conversion** compound node. You can find this node in the [Poser 13 Content > Runtime > Libraries > Materials > SuperFly > SuperFly Tileable > !Guide](#) library.
When adding the Gloss-Spec Conversion node to your scene, use the double checkmark, which will add it to the nodes that area already in the Edit window. If you use the single check-mark or double-click the node, it will completely replace what is already there.

Connections for SSS using Roughness and Normal maps

The connections relating to Subsurface Scattering are as follows:

- **Subsurface Color**: You can either click the color chip to select the desired subsurface color, or plug in a texture map. In the previous examples I use an HSV2 node to lighten and slightly saturate the base color map, and then plug the output of the HSV2 node into the Subsurface Color input of the Principled BSDF node. This is a "one size fits all" solution that should work with most skin colors. Alternatively, you can use a blood red color (R 102, G 0 B 0).
- **Subsurface**: The strength of the SSS effect. A setting of 0 turns SSS off in the material.
- **Subsurface Radius**: A tuple value that specifies the Red, Green, and Blue scattering distances in millimeters. The chart below may be helpful in choosing settings that are appropriate for the type of material you are creating, relating to the Subsurface value entered above.
- **Subsurface IOR**: Index of refraction for subsurface scattering.
- **Subsurface Anisotropy**: Controls the directionality of subsurface scattering.

When converting Blender SSS Scale to Poser Surface Scale, a scale value of 2.62128019 in Blender is equal to a scale value of 1 in Poser.

When converting Poser Surface Scale to Blender SSS Scale, a scale value of 1 in Poser is equal to a scale value of 0.38149298 in Blender.
<table>
<thead>
<tr>
<th>Material</th>
<th>Subsurface Radius (R, G, and B values) at Subsurface of .01</th>
<th>Subsurface Radius (R, G, and B values) at Subsurface of 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apple</td>
<td>.696, .640, .190</td>
<td>.00696, .00640, .00190</td>
</tr>
<tr>
<td>Chicken1</td>
<td>1.161, .388, .175</td>
<td>.01161, .00388, .00175</td>
</tr>
<tr>
<td>Chicken2</td>
<td>.944, .335, .179</td>
<td>.00944, .00335, .00179</td>
</tr>
<tr>
<td>Cream</td>
<td>.1503, .466, .254</td>
<td>.01503, .00466, .00254</td>
</tr>
<tr>
<td>Ketchup</td>
<td>.476, .058, .039</td>
<td>.00476, .00058, .00039</td>
</tr>
<tr>
<td>Marble</td>
<td>.851, .557, .395</td>
<td>.00851, .00557, .00395</td>
</tr>
<tr>
<td>Potato</td>
<td>1.427, .723, .204</td>
<td>.01427, .00723, .00204</td>
</tr>
<tr>
<td>Skim Milk</td>
<td>1.842, 1.044, .350</td>
<td>.01842, .01044, .00350</td>
</tr>
<tr>
<td>Skin1 (Darker Skin)</td>
<td>.367, .137, .068</td>
<td>.00367, .00137, .00068</td>
</tr>
<tr>
<td>Skin2 (Lighter Skin)</td>
<td>.482, .169, .109</td>
<td>.00482, .00169, .00109</td>
</tr>
<tr>
<td>Whole Milk</td>
<td>1.090, .658, .251</td>
<td>.01090, .00658, .00251</td>
</tr>
</tbody>
</table>

- **SSS Method**: Located at the bottom of the Principled BSDF node. Selects the type of microfacet distribution to use for the material:
  - **Burley**: Is an approximation to physically-based volume scattering.
  - **Random Walk**: Provides the most accurate results for thin and curved objects. This comes at the cost of increased render time or noise for more dense media like skin, but also better geometry detail preservation. Random Walk uses true volumetric scattering inside the mesh, which means that it works best for closed mesh.

**Scatter Group ID**

The Scatter Group ID can be used to prevent bleeding between two materials that have different scattering properties. For example, you might assign all skin materials to one scatter ID, and other areas like lips, eyes, or nails to other scatter group IDs.

**Specular and Specular Tint**

The Specular value or image map determines the amount of reflection in non-metallic surfaces. Recommended setting for non-metallic materials is .5.

The Specular Tint value tints the specular reflection using the base color while glancing reflections remain white. The Specular Tint parameter is not physically correct because normally non-metallic materials have colorless reflection. However, it can be used to fake the appearance of materials that have a complex surface structure.
Roughness

Roughness inputs can either be a fixed value between 0 and 1 (with 0 being very glossy and 1 having a matte finish), or a grayscale texture map that identifies more glossy areas in darker shades and more matte areas in lighter shades. For an example of roughness maps connected to the PrincipledBsdf node, see Kitty2 Textures-Principled or Kitty3 Textures-Principled. Roughness texture maps should be set to a Custom Gamma Value of 1.0.

Anisotropic, Anisotropic Rotation, and Tangent

The Anisotropic affects specular reflections. Higher values give elongated highlights along the tangent direction. Negative values shape the highlights perpendicular to the tangent direction.

The Anisotropic Rotation setting rotates the direction of the elongation such that values of 0 to 1 correspond to angles of 0 to 360. Enter a value of .25 for 90 degree rotation, for example.

The Tangent setting controls the tangent for the Anisotropic layer. Enter a tuple that represents X, Y, and Z coordinates, each value separated by a comma.

Sheen and Sheen Tint

Use the Sheen and Sheen Tint inputs to add a soft reflection near the edges of fabrics. The Sheen setting controls the amount of reflection, and the Sheen Tint setting controls the amount that the base color is mixed with white for sheen reflection.

Clearcoat, Clearcoat Roughness, and Clearcoat Normal

Clearcoat provides an extra white specular layer on top of the other layers. It is typically used for car paint and similar materials. As an example, if you want to create a metallic surface that has a clearcoat layer, set Metallic to 1, set Roughness to around .4, and set Clearcoat to 1.

The Clearcoat Roughness input controls the roughness of the clearcoat layer. You can plug a Roughness texture into the Clearcoat Roughness input to add scratches to the clearcoat layer, for example.

The Clearcoat Normal setting controls the normals in the Clearcoat layer. You can use a normal map or a bump map to raise or lower surfaces in the clearcoat layer.
IOR

IOR is the Index of Refraction value for light transmission, typically used with glass and metallic surfaces. Refractive indexes for many common materials can be found on Wikipedia's List of Refractive Indices page.

Transmission and Transmission Roughness

A Transmission setting of 0 is used for a fully opaque surface. A Transmission setting of 1 is used for a fully glass surface.

Emission

High emission values produce more light emission from the material. An emission value of 0 makes a material non-emissive. You can also use a grayscale texture map that identifies non-emissive and emissive areas in a texture map. For an example of emissive maps connected to the PrincipledBsdf node, see Kitty3 Textures-Principled. Emissive texture maps should be set to a Custom Gamma Value of 1.0.

Alpha

The Alpha input setting controls the transparency of the surface. You can enter a numerical value of 0 for fully transparent, or 1 to fully opaque.

To use an image texture with the Alpha input, you can attach an image that has an alpha channel. However, this method only works when you use a Cycles image map texture node (New Node > Cycles > Texture > ImageTexture).
The following example shows a PNG of red dots. The background of the image is transparent, and the image is saved as a PNG with Transparency in Photoshop, giving it an alpha channel. In this example, you connect the **Color** output of the Cycles image texture to the **Base Color** input of the **PrincipledBSDF** node to create the red dots, and connect the **Alpha** output of the Cycles image texture to the **Alpha** input of the **PrincipledBSDF** node to create the transparent areas.

![Image](image_url)

*Use the Cycles image map node to connect images with Alpha channels to the Alpha input of the Principled node*

**Normal**

Normal inputs can either be a fixed tuple value representing X, Y and Z coordinates, or a tangent space OpenGL normal map. The normal map defines raised and lowered areas in the surface. For an example of normal maps connected to the PrincipledBsdf node, see [Kitty2 Textures-Principled](#) or [Kitty3 Textures-Principled](#). Normal texture maps should be set to a Custom Gamma Value of 1.0.

**Texture**

**BrickTexture**

Procedural texture producing Bricks
**Inputs:**

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

- **Color1**: Brick Color #1

- **Color2**: Brick Color #2

- **Mortar**: Mortar color

- **Scale**: Overall texture scale

- **Mortar Size**: The Mortar size; 0 means no Mortar

- **Bias**: The color variation between the brick colors. Values of -1 and 1 only use one of the two colors; values in between mix the colors.

- **Brick Width**: The width of the bricks

- **Row Height**: The height of the brick rows

- **Offset**: Brick offset of the various rows.

- **Offset Frequency**: Frequency of the offset. A value of 2 gives an even/uneven pattern of rows.

- **Squash**: Amount of brick squashing.
• **Squash Frequency**: Frequency of brick squashing.

**Outputs:**

• **Color**: Texture color output
• **Fac**: Mortar mask (1 = mortar)

**CheckerTexture**

Checkerboard texture.

![CheckerTexture node](image)

*Cycles CheckerTexture node.*

**Inputs:**

• **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.
• **Color1**: First checkerboard color.
• **Color2**: Second checkerboard color.
• **Scale**: Overall texture scale

**Outputs:**

• **Color**: Texture color output
• **Fac**: Checker 1 mask (1 = Checker 1)

**EnvironmentTexture**

Used to light your scene using an environment map image file as a texture.
Cycles EnvironmentTexture node.

Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.
- **Projection**: Choose the type of texture projection you want to use for the material.
  - **Equirectangular**: Uses XY coordinates.
  - **Mirror Ball**: Uses spherical mapping.
- **Image**: Click to choose the texture that you want to use.

Outputs:

- **Color**: RGB color from the image.
- **Alpha**: Alpha output from the image. If the image has no alpha channel, output is white.

**GradientTexture**

A gradient texture based on an input vector.

Cycles GradientTexture node.
Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

**Type**:

- **Point**: (TBD)
- **Normal**: (TBD)
- **Texture**: (TBD)
- **Vector**: (TBD)

Outputs:

- **Color**: Texture color output.
- **Fac**: Texture intensity output.

**ImageTexture**

The *Image Texture* is used to add an image file as a texture.

![ImageTexture node](image)

*Cycles ImageTexture node.*

Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

- **Color Space**: The type of data that the image contains
__builtin_srgb: (TBD)
__builtin_raw: (TBD)

**Projection**: Choose the type of texture projection you want to use for the material.
- **Flat**: Uses the XY coordinates for mapping.
- **Box**: Projects texture onto 6 sides of a virtual cube.
- **Tube**: Maps the tube to a sphere, using the Z axis as the center.
- **Sphere**: Uses spherical mapping using the Z axis as the center.

**Extension**: Extension defines how the image is extrapolated past the original bounds:
- **Periodic**: (TBD)
- **Clamp**: (TBD)
- **Black**: (TBD)

**Interpolation**:
- **Closest**: No interpolation, use only closest pixel for rendering pixel art.
- **Linear**: Regular quality interpolation.
- **Smart**: Only for Open Shading Language. Use cubic interpolation when scaling up and linear when scaling down, for a better performance and sharpness.
- **Cubic**: Smoother, better quality interpolation. For bump maps this should be used to get best results.

**Image**: Click to choose the texture that you want to use.

**Outputs**:
- **Color**: Texture color output.
- **Alpha**: Alpha output.

**MagicTexture**

Creates a psychedelic color texture.
Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.
- **Scale**: Number of iterations
- **Distortion**: Amount of distortion.
- **Depth**: Depth of the effect:

Outputs:

- **Color**: Texture color output
- **Fac**: Texture intensity output

**MusgraveTexture**

Advanced procedural noise texture. May need some adjustments (multiplication and addition) in order to see more detail.
Cycles MusgraveTexture node.

**Inputs:**

- **Vector:** Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

- **W:** Texture coordinate to evaluate the noise at.

- **Scale:** Overall texture scale.

- **Detail:** Amount of noise detail.

- **Dimension:** The difference between the magnitude of each two consecutive octaves. Larger values corresponds to smaller magnitudes for higher octaves.

- **Lacunarity:** The difference between the scale of each two consecutive octaves. Larger values corresponds to larger scale for higher octave.

- **Offset:** An added offset to each octave, determines the level where the highest octave will appear.

- **Gain:** An extra multiplier to tune the magnitude of octaves.

- **Type:**
  - **Point:** (TBD)
  - **Normal:** (TBD)
  - **Texture:** (TBD)
  - **Vector:** (TBD)
Outputs:
- **Fac**: Texture intensity output.

**NoiseTexture**

Procedural Perlin noise texture that produces a cloud pattern.

![Cycles NoiseTexture node](image)

**Inputs:**
- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.
- **W**: Texture coordinate to evaluate the noise at.
- **Scale**: Overall texture scale
- **Detail**: Number of noise octaves. The fractional part of the input is multiplied by the magnitude of the highest octave. Higher number of octaves corresponds to a higher render time.
- **Roughness**: Blend between a smoother noise pattern, and rougher with sharper peaks.
- **Distortion**: Amount of distortion.

**Outputs:**
- **Color**: Color with different fractal noise in each component.
- **Fac**: Value of fractal noise.
SkyTexture

Procedural Sky texture for backgrounds.

Cycles SkyTexture node.

Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

- **Sky Type**: Sky model to use. Preetham or Hosek / Wilkie

- **Turbidity**: A value that defines the amount of humidity in the atmosphere. Lower values result in clearer skies. Higher values make sky more hazy. A value of 2 produces a clear sky. A value of 10 produces a hazy sky.

- **Ground Albedo**: The amount of light reflected from the ground

- **Sun Direction**: The sun direction vector. Enter three values in X, Y, and Z positions respectively.

Outputs:

- **Color**: Texture color output.

VoronoiTexture

Procedural texture producing Voronoi cells
Cycles VoronoiTexture node.

Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.
- **W**: Texture coordinate to evaluate the noise at.
- **Scale**: Scale of the noise.
- **Smoothness**: The smoothness of the noise. Higher values blur the noise.
- **Exponent**: Exponent of the Minkowski distance metric. Lower values create more variance. Higher values reduce variance.
- **Randomness**: The randomness of the noise. Increase values to create more randomness.

**Dimensions**:

- **1D**: Evaluate the noise in 1D space at the input W.
- **2D**: Evaluate the noise in 2D space at the input Vector. The Z component is ignored.
- **3D**: Evaluate the noise in 3D space at the input Vector.
4D: Evaluate the noise in 4D space at the input Vector and the input W as the fourth dimension.

Distance Metric: The distance metric used to compute the texture. Options are Euclidean, Manhattan, Chebychev, and Minkowski.

Feature: The Voronoi feature that the node will compute and return.

- F1: Compute and return the distance to the closest feature point as well as its position and color.
- F2: Compute and return the distance to the second closest feature point as well as its position and color.
- Smooth F1: Compute and return a smooth version of F1.
- Distance to Edge: Compute and return the distance to the edges of the Voronoi cells.
- Z-Sphere Radius: Compute and return the radius of the n-sphere inscribed in the Voronoi cells. In other words, it is half the distance between the closest feature point and the feature point closest to it.

Outputs:

- Distance: Distance.
- Color: Cell color. The color is arbitrary.
- Position: Position of feature point.
- W: Position of feature point.
- Radius: N-Sphere radius.

WaveTexture

Procedural bands or rings texture with noise distortion
Inputs:

- **Vector**: Texture coordinate to sample texture at. If the socket is left unconnected, this defaults to Generated texture coordinates.

- **Scale**: Overall texture scale

- **Distortion**: Amount of distortion of the wave (similar to the Marble texture in Blender Internal)

- **Detail**: Amount of distortion noise detail

- **Detail Scale**: Scale of distortion noise

- **Detail Roughness**: Blend between a smoother noise pattern, and rougher with sharper peaks.

- **Phase Offset**: Position of the wave along the Bands Direction. This can be used as an input for more control over the distortion.

- **Type**: Point, Normal, Texture, or Vector

- **Bands Direction**: The axis the bands propagate from i.e. which axis they are perpendicular to. When using Bands a Diagonal axis is an option.

- **Rings Direction**: The axis the rings propagate from i.e. which axis they are perpendicular to. When using Rings the rings can propagate outwards from a single point by using Spherical direction

- **Profile**: Saw produces a sawtooth profile. Sine uses standard sine profile. Tri produces a blended gradient profile.
 Outputs:

- **Color**: Texture color output
- **Fac**: Texture intensity output

## Vector

## Bump

Generates a normal map from a height texture.

![Cycles Bump node.](image)

### Inputs:

- **Height**: Input image for the bump map.
- **Normal**: Method for mapping the bump map.
- **Strength**: Strength of the bump effect, interpolating between no bump mapping and full bump mapping
- **Distance**: Multiplier for the height value to control the overall distance for bump mapping
- **Invert**: Inverts the effect so that white pushes inward and black pushes outward.

### Outputs:

- **Normal**: Standard normal output.

## Mapping

Transforms a coordinate; typically used for modifying translation, rotating, and scaling texture coordinates.
Cycles Mapping node.

Inputs:

- **Vector**: Vector to be transformed
- **Location**: Moves a texture along the X, Y, or Z axis of the object.
- **Rotation**: Rotates a texture along the X, Y, or Z axis of the object.
- **Scale**: Scales a texture along the X, Y, or Z axis of the object.
- **Vector Type**: Choose one of the following types:
  - **Vector**: Transforms a point, but with zero translation.
  - **Point**: Translation moves the input along the local rotation axis. Rotation rotates the input around the origin of the space. Scaling scales the input along the global axis.
  - **Normal**: Use when transforming normals. Performs the inverse transpose of the transformation and normalizes the result.
- **Use Min/Max**: Check this option to clip textures to the area within the Minimum and Maximum values entered.
  - **Minimum**: Enter a minimum value for the transform.
  - **Maximum**: Enter a maximum value for the transform.

Outputs:

- **Vector**: The input vector after it is transformed.

Normal

Generates a normal vector.

Cycles Normal node.
Inputs:

- **Normal**: Input a normal vector here.

Outputs:

- **Normal**: Outputs one vector.
- **Dot**: Dot product is 1 if two normals are pointing in the same direction. Dot product is 0 if two normals are perpendicular. Dot product is -1 if two normals are facing directly away from each other.

**NormalMap**

This is usually chained with an RGB normal map Image Texture node in the color input. For tangent space normal maps, the UV coordinates for the image must match, and the image texture should be set to Non-Color mode to give correct results.

![Cycles NormalMap node.](image)

Inputs:

- **Strength**: Strength of the normal mapping effect
- **Color**: RGB color that encodes the normal in the specified space
- **Space**: Can be in one of 3 spaces: Tangent, Object or World space. Tangent space normal maps support object transformation and mesh deformations. Object space normal maps stick to the surface under object transformations, while World normal maps do not.

Outputs:

- **Normal**: Normal that can be used as an input to BSDF nodes.

**VectorTransform**

Converts a Vector, Point or Normal between World, Camera, or Object coordinate space.

![Cycles VectorTransform node.](image)
Inputs:

- **Vector**: The input vector
- **Vector Type**: A point, a direction, or a vector.
- **Convert From**: Choose World, Object, or Camera.
- **Convert To**: Choose World, Object, or Camera.

Outputs:

- **Vector**: The transformed output vector.
Compound Nodes

The Compound Node allows you to combine any Poser node type as an external input or output, providing a way to reduce clutter in the Advanced Material room. You can create modular blocks that expose essential settings to the user in the main Material room. If the user wants to expose the other settings for editing, they can open up the compound node in a separate window.

Creating a Compound Node

A Compound Node is created using the same methods as discussed in Creating Nodes. You will notice a new node type called Compound in the New Node menu. Initially, the new compound node will appear as shown at the bottom of the following figure. When you first create the compound node, there will be no input or output connections exposed. In order to add them, you will need to follow the steps that are outlined in Editing Compound Nodes.

![Creating a new Compound node.](image)

You can also select two or more nodes in the main Material room window and collapse them into a compound node. See Collapsing Existing Nodes into a Compound Node.

In the following figure, we start with a primitive cube that has no material settings. Then we create a new Compound node in the main Material room window. You’ll learn how to edit the compound node in the section that follows.
Start with a new compound node.

Editing Compound Nodes

After you create a new compound node (or collapse existing nodes into a compound node as described in the next section), click the first icon in the title bar to open the node in a separate editing window in the Material room.

When you enter the Compound Node editor, you’ll see the following features:

Return to Main Window: To return to the main window in the Advanced Material room, click the icon that appears at the upper left corner of the Compound Node editor.

Breadcrumb trail: Compound nodes can be nested (in other words, you can have compound nodes within compound nodes). If you are editing a nested compound node, you’ll be able to follow a breadcrumb trail to move forward and backward in the hierarchy.
External Outputs: The nodes that you connect here will be exposed on the compound node as output plugs that you can connect to other nodes in the main window.

External Inputs: The nodes that you connect here will be exposed on the compound as inputs plugs and settings that you can connect to other nodes in the main window.

When creating connections to the external inputs and outputs, you’ll use the same steps as you would in the main Material room Edit view. In the following figure, a Turbulence node has been attached to the External Outputs, and a second external output (Noise) is in the process of being added.

Next, we’ll connect one input each from the Turbulence and Noise nodes into the External Input connector in the compound node. What you have now is a very basic compound node that has two eternal outputs, and two external inputs.
Connecting external inputs.

Click the Eye icon in the upper right corner of the External Outputs node to expand the preview. When you highlight the name of one of the external outputs, the preview will update to display the results that will be output through the compound node.

Previewing external outputs.

After you are finished editing, click the icon in the upper-left corner of the Compound Node view (at the left of the breadcrumb trail) to return to the main Advanced Material room view. Your compound node will now display the external inputs and outputs that you created in the Compound Node editor window.

The compound node in the main window.

You can then connect your compound node into other nodes in the main Material room, just as you do with any other node.
Collapsing Existing Nodes into a Compound Node

You can select several nodes that already appear in the Advanced Material room window, and then collapse them into a single compound node. This helps reduce clutter in the main window, and allows you to later go back and work on one aspect of your texture at a time in a separate window.

To collapse two or more nodes into a compound node, follow these steps:

Select two or more nodes in the Edit material view. You can select nodes by shift-clicking them, or by drawing a rectangular selection around them as shown in the following figure.
Selecting nodes.

Right-click over one of the selected nodes and choose Collapse to Compound Node.

Collapsing a Compound node.

Renaming Nodes and Connections

When you return to the main window in the Advanced Material room, the compound node is initially assigned a name of compound, followed by a numerical value. You can double-click the name to enter a name that is more descriptive, as shown in the following figure.

Renaming a Compound node.

When you are editing nodes in Compound Node view, you can also rename the external inputs and outputs that you connect to the compound node, so that the user has a better understanding of how that input or output will affect the material.
Renaming an external output.

The connections in the compound node can also be rearranged by dragging the external input and output names up or down and arrange them in a logical manner. For example, you can place them in order from top to bottom to match up with the connections that you make to the PoserSurface node, so that the connections do not cross over each other.

Expanding Compound Nodes

You can use the Expand Compound Nodes command in the node menu to “uncollapse” the compound nodes into their individual components. This will place the individual nodes back into the main editor in the Advanced Material room so that they are accessible on an individual basis.

To expand a compound node, right-click on the node you want to expand, and choose Expand Compound Nodes from the context menu.

Expanding a Compound node.

Saving Compound Node Fragments to the Library

To save a compound node to the library, follow these steps:

1. Click to select the compound node that you want to save.
2. Switch to the Materials category in the library that you want to save the selected node into.

3. Navigate to or create the folder that you want to save the node into.

4. Click the Add to Library button in the Library window. The New Material Set dialog appears.

5. Enter a name for the library item in the Set Name field.

6. Check the Single Material option, and make sure that the Selected Nodes Only option is checked.

7. Click **OK** to save the compound node to the library.

A compound node fragment only saves the connections between the nodes that you selected when you saved the compound node fragment. If you later add that fragment to another material, you will need to connect the inputs or outputs from the compound node fragments to the appropriate nodes in your current material.

To merge a compound node with an existing material:

* In the Edit Material view of the material room, select the object material that you want to add the compound node to.
* Select the compound node in the library.
* Click the double-checkmark icon at the bottom of the library window. The compound node will be added to the current material, but will not be connected to anything.
* Connect the compound node inputs and outputs to the existing image maps and nodes in your material as required by the compound node.
PBR

Using PBR Maps with Poser

To get an overview of the various types of maps used in Poser, see Common PBR Texture Tools and Maps.

Connecting PBR Maps to the Physical Surface Root Node

The Physical Surface root allows you to create textures that can be rendered in FireFly and SuperFly, in both Poser 11 through Poser 13. The following image shows the Sanctum Arts Kitty (which you will be using in this tutorial) rendered in FireFly and SuperFly, using the Physical Surface Node as the primary root node.

While FireFly is not really a PBR renderer, the Physical Surface node does a reasonable job of creating materials that render fairly well in FireFly. The main difference is in metals, which FireFly needs a lot of reflective node tricks to render properly. The majority of the metallic effect that you see on the FireFly side of these renders is more than likely coming from the Roughness map, which controls the amount and sharpness of the shine in the metal areas. Note, however, that the results in FireFly aren't as physically accurate as the results in the SuperFly render, due to the differences in how they work.

Most PBR materials use three basic building blocks:

- **Color** maps define the color of the object. PBR color maps are basically flat colors, with no highlights or shadows baked in.
- **Roughness** maps control the sharpness of reflection, or the amount of glossiness in the object. Darker areas are more glossy, and lighter areas are more matted in appearance.
- **Normal** or **bump** maps define raised or lowered areas in the texture. Areas facing the camera render the effect, and areas that are perpendicular to the camera appear smooth.

You will need to download the textures from the Poser 13 downloads section. Navigate to [https://www.posersoftware.com/downloads/content](https://www.posersoftware.com/downloads/content) and download the SAKitty PBR Tutorial Files.zip file. Unzip this file to your Poser 13 content runtime.

The items that are used in this tutorial are furnished with Poser as follows:

- The Sanctum Arts Kitty is found in Figures > Included > Toys.
- The textures can be found in the Poser 13 library at Included > Runtime > Textures > SAKitty Tutorial
- Completed versions of the materials can be found in the Poser 13 library, at Included > Runtime > Materials > Toys > SAKitty Tutorial
You'll begin by assigning Color, Roughness, and Normal maps for all the materials. See the following pages for these steps:

- Kitty1 Base Textures-Physical
- Kitty2 Base Textures-Physical
- Kitty3 Base Textures-Physical

After you are done applying all of the base (color, roughness, and normal maps), you'll continue by attaching additional maps for the Kitty2 and Kitty3 textures:

- Kitty2 Metallic Map-Physical
- Kitty3 Metal, Emission and Opacity-Physical

Connecting PBR Maps to the Cycles Root and Principled BSDF Node

The Cycles root node and Principled BSDF node are like the Physical Root Node on steroids. In addition to being able to connect PBR shaders to the Principled BSDF node, there are all sorts of additional inputs and connections to control refraction, reflection, subsurface scattering, anisotropics, sheen, clearcoat, and more. It is basically Poser's built in version of a do-it-all Uber shader.

The main disadvantage is that this method currently only works in Poser 12 and 13 Cycles, so it will not be compatible with FireFly, or with Poser 11 SuperFly. The other disadvantage is that, at current writing, Cycles materials preview in gray in the preview renderer. So in the following tutorials, we start with the Physical Surface Root node materials (discussed above), and add additional nodes to use the same textures for the Principled BSDF node. This way you have the best of both worlds … you can use the Physical Surface nodes for the FireFly renderer and for preview purposes, and then when you want to create your final render, just render it with SuperFly.

See the following tutorials for how to connect PBR maps to the Cycles/Principled BSDF Nodes:

- Kitty1 Textures-Principled
- Kitty2 Textures-Principled
- Kitty3 Textures-Principled

Common PBR Texture Tools and Maps

While creating procedural materials using nodes can result in a wide variety of realistic materials, they are not everyone's cup of tea. In addition, they aren't easily transferable to other 3D software because typically, nodes are application-specific. However, there is a solution that is not only easier for texture artists to understand, but will also have the advantage of working in any application that uses physically-based renderers (or, PBR for short).
PBR Texturing Tools

There are several applications that allow you to create PBR textures that emulate real-world materials very accurately. While many of them allow you to create tileable PBR texture sets, the following three also allow you to create physically accurate textures for UV-mapped objects:

- **Substance Painter**: One of the most widely used PBR texture applications, this product is available by subscription at the Substance by Adobe website. You can download a 30-day trial at https://www.substance3d.com/download/.
  - Subscribing to Substance also gives you access to the full Substance suite, which includes Substance Painter, Substance Alchemist, Substance Designer, and Substance Source. Substance Designer is a node-based material authoring tool that you can use to create tileable PBR textures that you can export as bitmaps.
  - There are thousands of physically accurate materials available on Substance Source, with the subscription allowing 30 free downloads per month.
  - If you are a member of the Steam community you can also purchase Substance Painter on that site, but it does not include access to Substance Source.

- **3D Coat**: In addition to offering features such as digital sculpting, UV Mapping, and strong retopologizing tools, 3D Coat offers PBR painting tools that are easy and fun to use. You can download a 30-day trial at https://3dcoat.com/download/. Permanent licenses are available for purchase.

- **ArmorPaint**: A reasonably-priced alternative to PBR texture creation, with features that are similar to those of Substance Painter. You can download the application at https://armorpaint.org/.

Spec-Gloss vs. Metal-Rough Workflow

There are two basic PBR workflows available for most PBR authoring tools.

<table>
<thead>
<tr>
<th>Spec-Gloss</th>
<th>Map Type</th>
<th>Metal-Rough</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base color with no shadow or highlight information. Ambient occlusion can be baked into the map, however it is recommended that RGB values fall between 30 and 240.</td>
<td>Diffuse (aka Color or Albedo)</td>
<td>Base color with no shadow or highlight information. Ambient occlusion can be baked into the map, however it is recommended that RGB values fall between 30 and 240.</td>
</tr>
<tr>
<td>Not used. See Glossiness below.</td>
<td>Roughness</td>
<td>A grayscale image. Black (0) creates very smooth, shiny surfaces. White (1) creates rough and broad highlights. Typically used to create wear such as scratches, fingerprints, smudges, etc.</td>
</tr>
<tr>
<td>Not used. See Specular below.</td>
<td>Metallic</td>
<td>A grayscale image. Black (0) is non-metallic. White (1) is metallic. There can be transitional grayscale values</td>
</tr>
</tbody>
</table>
A grayscale image that defines the reflectance information for both metallic and non-metallic surfaces.

Specular
Set Gamma to 1.0

The Roughness map (described above) determines the amount of shininess. Specular (highlight) color is defined by the Specular input in the Physical Surface node, or the Specular Tint color in the Cycles Principled BSDF node.

A grayscale image. Black (0) values create rough and broad highlights, and white (1) values create smooth, shiny surfaces. Basically the inverse of a roughness map. Typically used to create wear such as scratches, fingerprints, smudges, etc.

Glossiness
Set Gamma to 1.0

Not used. See Roughness above.

**Other Common Maps used in PBR Materials**

<table>
<thead>
<tr>
<th>Map Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bump</td>
<td>A grayscale map that determines which areas in a material are raised or lowered. Darker areas are recessed. Lighter areas are raised. The effect is prominent in surfaces that directly face the camera, but faces that are perpendicular to the camera appear flat. Set Gamma to 1.0</td>
</tr>
<tr>
<td>Displacement</td>
<td>Similar to a bump map in that it is a grayscale map that determines which areas in a material are raised or lowered. Darker areas are recessed. However, unlike a Bump map, geometry is displaced according to the grayscale values in the map. At present, the FireFly renderer uses micropoly displacement properly. To use displacement maps in SuperFly, the geometry has to be subdivided by a sufficient amount to create a sufficient number of polygons to displace. Set Gamma to 1.0</td>
</tr>
<tr>
<td>Normal (Tangent Space)</td>
<td>A blue-toned image that works similarly to a bump map, except that it uses RGB information to correspond with XYZ axes in 3D space. The RGB information tells Poser how to orient the surface normal for each polygon in 3D space. Normal maps used in Poser should be OpenGL (not DirectX). If it appears that your normal maps are indenting areas that should be raised, you can take the normal map into an application such as Photoshop and invert the Green channel of the normal map. Set Gamma to 1.0</td>
</tr>
</tbody>
</table>
### Transparency/Opacity

**Set Gamma to 1.0**

A grayscale image that defines opaque and transparent areas. Black (0) is fully transparent, and white (1) is fully opaque.

### Emission

**Set Gamma to 1.0**

A grayscale image that defines areas that emit light or glow. Black (0) produces no emission. White (1) areas are fully emissive.

- **PoserSurface**: Plug Emissive map into Ambient Value, and set color in Ambient Color.
- **PhysicalSurface**: Plug Emissive map into EmissionStrength. Set Emission color in Emission.
- **PrincipledBSDF**: Plug Emissive map into Emission. Emission color can either be set in the Color map, or by mixing the Emissive map with the desired Emission color and connecting that to the Principled node.

## Kitty1 Base Textures-Physical

The material zones included in the "Kitty1" maps are as follows. These materials do not need any additional maps such as Opacity, Metallic, or Emission. The outline colors shown in these examples are not actually in the texture maps themselves, they are only used here to help identify the different materials that the maps affect.

- **BodyColor1** (Associated PolygonsOutlined in Blue for clarity): Hexagon Pattern
- **BodyColor2**: (Associated Polygons Outlined in Pink for clarity) - Soft Denim
- **BodyColor3**: (Associated Polygons Outlined in Green for clarity) - Matte Plastic

### Color Map | Normal Map | Roughness Map

Start by loading the Kitty from the Poser library:

1. Create a new scene in Poser. Delete the default La Femme figure.
2. Navigate to the Figures > Included > Toys character library and add SA Kitty Mass Production to your scene.
3. Adjust the camera so that you can view the character more closely.

4. From the Materials library, navigate to the Materials > Included > Toys > SAKitty Tutorial library. Click the single checkmark to apply the !All White material to the kitty. All of the materials in the kitty will change to white, giving you a good place to start adding your materials.

The textures for the kitty are arranged in three UV tiles, with texture names starting with SAKitty1, SAKitty2, and SAKitty3. To assign the first set of textures, follow these steps:

1. Switch to the Material Room. With the SAKitty object selected, choose the BodyColor1 material in the Edit tab.

2. Right-click in an empty area in the Edit pane, and choose New Node > Root > Physical Surface. This adds a Physical Surface node to the editor.

3. Check the FireFly Root and SuperFly Root checkboxes at the top of the Physical Surface node.

0. You can add three image map nodes in one of two ways:
   0. Open Windows Explorer or the Mac Finder to the Included > Runtime > Textures > SAKitty Tutorial folder, and drag and drop the SAKitty1_Color, SAKitty1_Normal, and SAKitty1_Roughness maps into the Edit window. This automatically creates three Image Map nodes with the textures loaded into them.
   0. Right-click in the Edit window, and choose New Node > 2D Textures > image_map, then choose one of the above-mentioned textures to load in the image node. Repeat for the other two textures.

0. Change the name of each of the image map nodes to reflect the type of image being used:
   0. Change the name of the Color map to Color
   0. Change the name of the Roughness map to Roughness
   0. Change the name of the Normal map to Normal

6. For the Color texture, set the Filtering option in the Image Map node to Crisp. Connect the output from the Color image map node to the Color input of the Physical Surface node. Then set the color chip input in the Physical Surface node to pure white (it is
slightly off-white by default). If desired, collapse the image map node so that only the texture preview shows.

**Connecting the Color Map**

7. For the Roughness texture, set the Filtering option in the Image Map node to Crisp. Click the Image_Source field to open the Texture Manager, and set the Custom Gamma value to 1.0. Connect the output of the Roughness map to the Roughness input of the Physical Surface node, and change the Roughness input value in the Physical Surface node to 1.

*Set Custom Gamma to 1 for Roughness image map.*
8. The changes that you need to make for the Normal map are similar to those you made for
the Roughness map. First, set the Filtering option in the Image Map node to Crisp. Click
the Image_Source field to open the Texture Manager, and set the Custom Gamma value to
1.0. Connect the output of the Normal map to the Normal input of the Physical Surface
node. The setting of the Normal map should remain at 1 (which is the default value).
Changing this value will cause the normal map to preview incorrectly.

9. Right-click an empty space in the Edit window and choose Select All to select all of
the nodes. Then right-click again and choose Copy to place them in your clipboard.

10. Select BodyColor2 from the Materials list above the Edit window. Right-click to select the
contents that are already there, and choose Replace to paste the contents from the
clipboard.

11. Repeat step 10 for BodyColor3. Now all of your connections for the first set of textures
are complete.

12. Continue to Kitty2 Base Textures-Physical.
Attaching Bump Maps to the Physical Surface Node

If you want to use bump maps instead of, or in addition to, normal maps the process is similar to the above.

1. Create an image map node, and assign the bump map texture to it.
2. In the Texture Manager, set the Gamma value to 1.
3. Set the Filtering option in the Image Map node to Crisp.
4. Connect the output of the Bump map to the Bump input of the Physical Surface node.
5. Set the Bump Strength to a value that is appropriate for your bump map. Moving in close to your object and doing frequent area renders of small areas will help you determine the best setting for your bump maps.

Connect the Bump map to the Bump input of the Physical Surface Node. Adjust strength value as needed.

Kitty2 Base Textures-Physical

The material zones included in the "Kitty2" maps are as follows.

- Logo: (Associated polygons outlined in yellow for clarity) - Polished Chrome
- Metal: (Associated polygons outlined in blue for clarity) - Polished Chrome
- Soft1: (Associated polygons outlined in green for clarity) - Carpet Velvet
- Soft2: (Associated polygons outlined in cyan for clarity) - Carpet Velvet
- Trim: (Associated polygons outlined in pink for clarity) - Scratchy Copper

| Color Map | Normal Map | Roughness Map |
Continuing from Kitty1 Base Textures-Physical, you can take what you've already built and modify it slightly so that it works with the Kitty2 maps. Proceed as follows:

1. Choose one of the BodyColor materials that you have already created.

2. Right-click an empty space in the Edit window and choose Select All to select all of the nodes. Then right-click again and choose Copy to place them in your clipboard.

3. Select the Logo material from the Materials list above the Edit window. Right-click to select the contents that are already there, and choose Replace to paste the contents from the clipboard.

Now you need to modify this material so that it uses the correct textures:

1. Click the Image Source field for the Color map, and change the texture reference to SAKitty2_Color. Leave the Gamma set to Use Gamma value from Render Settings.

2. Click the Image Source field for the Roughness map, and change the texture reference to SAKitty2_Roughness. When you reassign the texture, the Gamma value will change to Use Gamma value from Render Settings. Change this to Custom Gamma Value of 1.

3. Click the Image Source field for the Normal map, and change the texture reference to SAKitty2_Normal. When you reassign the texture, the Gamma value will change to Use Gamma value from Render Settings. Change this to Custom Gamma Value of 1.

4. Now that you have the correct base texture maps assigned for the Logo material, you'll need to copy the shader to the other materials that use Map 2. Right-click an empty space, and choose Select All to copy the nodes to your clipboard.

5. One at a time, select the following materials from the Materials list. Right-click and choose Select All to select the existing nodes, then right-click again and choose Replace to update them with the nodes in your clipboard:
   - Metal: Polished Chrome
   - Soft1: Carpet Velvet
   - Soft2: Carpet Velvet
   - Trim: Scratchy Copper

6. Continue to Kitty3 Base Textures-Physical
Kitty3 Base Textures-Physical

The material zones included in the "Kitty3" maps are as follows.

- Bolts: (Associated polygons outlined in beige for clarity) - Worn Steel
- DetalColor1: (Associated polygons outlined in dark purple for clarity) - Solar Panel Blue
- DetalColor2: (Associated polygons outlined in green for clarity) - Solar Panel Violet
- DetalColor3: (Associated polygons outlined in dark green for clarity) - Solar Panel Light Purple
- DetalColor4: (Associated polygons outlined in deep red for clarity) - Solar Panel Medium Purple
- Eye Frame: (Associated polygons outlined in medium pink for clarity) - Polished Chrome
- Eye Glass: (Associated polygons outlined in red for clarity) - Clear glass
- Eye Glow: (Associated polygons outlined in blue for clarity) - Yellow Emissive
- Eye Inner: (Associated polygons outlined in dark pink for clarity) - Yellow Emissive
- Eye Shield: (Associated polygons outlined in purple for clarity) - Gray Glass
- Face: (Associated polygons outlined in cyan for clarity) - Carpet Velvet
- Face Shield: (Associated polygons outlined in orange for clarity) - Gray Glass
- LED: (Associated polygons outlined in mustard yellow for clarity) - Red Emissive

<table>
<thead>
<tr>
<th>Color Map</th>
<th>Normal Map</th>
<th>Roughness Map</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Color Map" /></td>
<td><img src="image2" alt="Normal Map" /></td>
<td><img src="image3" alt="Roughness Map" /></td>
</tr>
</tbody>
</table>

If you still have textures in your clipboard from the previous section you can use those instead of performing the following three steps. Continuing from Kitty2 Base Textures-Physical:

1. Choose one of the materials that you created and copy the nodes into your clipboard.

2. Right-click an empty space in the Edit window and choose Select All to select all of the nodes. Then right-click again and choose Copy to place them in your clipboard.

3. Select the Bolts material from the Materials list above the Edit window. Right-click to select the contents that are already there, and choose Replace to paste the nodes from the clipboard.

After the nodes are in your clipboard you need to modify this material so that it uses the correct textures:

1. Click the Image Source field for the Color map, and change the texture reference to SAKitty3_Color. Leave the Gamma set to Use Gamma value from Render Settings.
2. Click the **Image Source** field for the Roughness map, and change the texture reference to **SAKitty3_Roughness**. When you reassign the texture, the Gamma value will change to **Use Gamma value from Render Settings**. Change this to **Custom Gamma Value** of 1.

3. Click the **Image Source** field for the Normal map, and change the texture reference to **SAKitty3_Normal**. When you reassign the texture, the Gamma value will change to **Use Gamma value from Render Settings**. Change this to **Custom Gamma Value** of 1.

4. Now that you have the correct base texture maps assigned for the Bolts material, you'll need to copy the shader to the other materials that use Map 3. Right-click an empty space, and choose **Select All** to copy the nodes to your clipboard.

5. One at a time, select the following materials from the Materials list. Right-click and choose **Select All** to select the existing nodes, then right-click again and choose **Replace** to update them with the nodes in your clipboard:
   - DetalColor1: Solar Panel Blue
   - DetalColor2: Solar Panel Violet
   - DetalColor3: Solar Panel Light Purple
   - DetalColor4: Solar Panel Medium Purple
   - Eye Frame: Polished Chrome
   - Eye Glass: Clear glass
   - Eye Glow: Yellow Emissive
   - Eye Inner: Yellow Emissive
   - Eye Shield: Gray Glass
   - Face: Carpet Velvet
   - Face Shield: Gray Glass
   - LED: Red Emissive

6. Continue to **Kitty2 Metallic Map-Physical**

**Kitty2 Metallic Map-Physical**

The Kitty2 metallic map identifies the metallic materials in white. Non-metallic materials are black.

Metallic materials in map 2 are used for the following materials:

- Logo: (Associated polygons outlined in yellow for clarity) - Polished Chrome
- Metal: (Associated polygons outlined in blue for clarity) - Polished Chrome
- Trim: (Associated polygons outlined in pink for clarity) - Scratchy Copper
There are three materials that use the Kitty2 set of textures that have metallic surfaces. You created these shaders in Kitty2 Base Textures-Physical, which currently have the color, roughness, and normal maps assigned to them. To add the metallic map, proceed as follows.

1. Choose the Logo material, which uses the Kitty2 bases.

2. Right-click in an empty space in the edit window and choose New Node > 2D Textures > image_map to add a new image map node.

3. Double-click the image map node header, and change the name to Metallic.

4. Click the Image Source field to open the Texture Manager. Browse to the Poser 13 Content > Included > Runtime > textures > SAKitty Tutorial folder and choose SAKitty2_Metallic for the metallic texture map.

5. When you return to the Texture Manager, assign a Custom Gamma value of 1 to the texture. Choose OK to exit the texture manager.

6. Connect the output of the metallic image map node to the Metallic input of the Physical Surface node, and set the Metallic value to 1.
Now you will need to copy the Logo material over to the other two surfaces that use the metallic map:

1. Right-click an empty space, and choose **Select All** and then right click again and choose **Copy** to copy the nodes to your clipboard.

2. One at a time, select the following materials from the Materials list. Right-click and choose **Select All** to select the existing nodes, then right-click again and choose **Replace** to update them with the nodes in your clipboard:
   - **Metal**: Polished Chrome
   - **Trim**: Scratchy Copper

3. All texture assignments for the Kitty2 set of textures are now complete. Continue to Kitty3 **Metal, Emission and Opacity-Physical** to finish.

### Kitty3 Metal, Emission and Opacity-Physical

The materials used in the Kitty3 textures have the most auxiliary maps to connect, but the process will be fairly straightforward. This page will show you how to connect Metallic, Emission, and Opacity maps to the Physical Surface node.

<table>
<thead>
<tr>
<th>Metallic Map</th>
<th>Emission Map</th>
<th>Opacity Map</th>
</tr>
</thead>
</table>

---

*Page 475*
**Materials Using Metallic map:**
(White areas are metallic, black areas are non-metallic)

- **Bolts:** (Associated polygons outlined in beige for clarity) - Worn Steel
- **DetalColor1:** (Associated polygons outlined in dark purple for clarity) - Solar Panel Blue
- **DetalColor2:** (Associated polygons outlined in green for clarity) - Solar Panel Violet
- **DetalColor3:** (Associated polygons outlined in dark green for clarity) - Solar Panel Light Purple
- **DetalColor4:** (Associated polygons outlined in deep red for clarity) - Solar Panel Medium Purple
- **Eye Frame:** (Associated polygons outlined in medium pink for clarity) - Polished Chrome

---

**Materials Using Emissive map:**
(White areas are emissive, black areas are not emissive)

- **Eye Glow:** (Associated polygons outlined in blue for clarity) - Yellow Emissive
- **Eye Inner:** (Associated polygons outlined in dark pink for clarity) - Yellow Emissive
- **LED:** (Associated polygons outlined in mustard yellow for clarity) - Red Emissive

---

**Materials Using Opacity map:**
(White areas are opaque, black areas are completely transparent)

- **Eye Glass:** (Associated polygons outlined in red for clarity) - Clear glass
- **Eye Shield:** (Associated polygons outlined in purple for clarity) - Gray Glass
- **Face Shield:** (Associated polygons outlined in orange for clarity) - Gray Glass

---

**Metallic Maps**

There are six materials that use the Kitty3 set of textures that have metallic surfaces. You created these shaders in Kitty3 Base Textures-Physical, which currently have the color, roughness, and normal maps assigned to them. To add the metallic map, proceed as follows.

1. Choose the **Bolts** material, which uses the Kitty3 bases.
2. Right-click in an empty space in the edit window and choose **New Node > 2D Textures > image_map** to add a new image map node.
3. Double-click the image map node header, and change the name to **Metallic**.
4. Click the Image Source field to open the Texture Manager. Browse to the **Poser 13 Content > Included > Runtime > textures > SAKitty Tutorial** folder and choose **SAKitty3_Metallic** for the metallic texture map.

5. When you return to the Texture Manager, assign a **Custom Gamma value** of 1 to the texture. Choose **OK** to exit the texture manager.

6. Connect the output of the metallic image map node to the **Metallic** input of the Physical Surface node, and set the **Metallic** value to 1.

Now you will need to copy the Logo material over to the other five surfaces that use the metallic map:

1. Right-click an empty space, and choose **Select All** and then right click again and choose **Copy** to copy the nodes to your clipboard.

0. One at a time, select the following materials from the Materials list. Right-click and choose **Select All** to select the existing nodes, then right-click again and choose **Replace** to update them with the nodes in your clipboard:
   - **DetalColor1**: Solar Panel Blue
   - **DetalColor2**: Solar Panel Violet
   - **DetalColor3**: Solar Panel Light Purple
   - **DetalColor4**: Solar Panel Medium Purple
   - **Eye Frame**: Polished Chrome

3. Continue to Emission maps, next.
Emission Maps

There are three materials that use the Kitty3 set of textures that have emissive surfaces. To add the emissive map, proceed as follows.

1. Choose the **Eye Glow** material, which uses the Kitty3 bases.
2. Right-click in an empty space in the edit window and choose **New Node > 2D Textures > image_map** to add a new image map node.
3. Double-click the image map node header, and change the name to **Emissive**.
4. Click the **Image Source** field to open the Texture Manager. Browse to the **Poser 13 Content > Included > Runtime > textures > SAKitty Tutorial** folder and choose **SAKitty3_Emissive** for the texture map.
5. When you return to the Texture Manager, assign a **Custom Gamma value** of 1 to the texture. Choose **OK** to exit the texture manager.
6. Connect the output of the emissive image map node to the **EmissionStrength** input of the Physical Surface node. The Emissive value defaults to a setting of 1, but you can make the emission dimmer by lowering the value, and brighter by raising the value.
7. For emission color, do one of the following:
   - Plug the **Color** map into the **Emission** connection in the Physical Surface node as shown below, or
   - Click the **Emission** color chip in the Physical Surface node to choose the desired emission color from a color picker.

---

8. Since we are trying to create a material that can render in both FireFly and SuperFly, you'll notice that if you switch to the FireFly renderer, the Emission areas in the eyes and the LED's don't "light up." What we can do for these Emissive materials is connect them to the PoserSurface node instead (which you'll notice we've left alone up until this point, but it's sitting up there in the corner in the screen shots). If you've deleted them, it's easy enough to just add one back in with the **New Node > Root >PoserSurface command**.
Poser Reference Manual

0. Expand the PoserSurface node, and check the option at the top to use it during FireFly renders. Then:
   - Either plug the Color map into the Ambient Color input on the PoserSurface node and set the Ambient Color chip to white, or
   - Set the desired emission color with the Ambient Color chip.

10. Plug the Emissive map into the Ambient Value input of the Poser Surface node. Set the Ambient Value to a value that gives the desired emissive glow.

Connecting Emissive to Physical Surface and PoserSurface Nodes

Now you will need to copy the Eye Glow material over to the other two surfaces that use the emissive map:

1. Right-click an empty space, and choose Select All, and then choose Copy to copy the nodes to your clipboard.

0. One at a time, select the following materials from the Materials list. Right-click and choose Select All to select the existing nodes, then right-click again and choose Replace to update them with the nodes in your clipboard:
   - EyeInner: Yellow Emissive
   - LED: Red Emissive

3. Continue to finish up the Kitty with its Opacity maps, which follow.

Opacity Maps

There are three materials that use the Kitty3 set of textures that use Opacity maps. These materials are glass and used in the Eye Glass, Eye Shield, and Face Shield materials. To add the opacity map, proceed as follows.
1. Choose the **Eye Glass** material, which uses the Kitty3 bases.

2. Right-click in an empty space in the edit window and choose **New Node > 2D Textures > image_map** to add a new image map node.

3. Double-click the image map node header, and change the name to **Opacity**.

4. Click the Image Source field to open the Texture Manager. Browse to the **Poser 13 Content > Included > Runtime > textures > SAKitty Tutorial** folder and choose **SAKitty3_Opacity** for the metallic texture map.

5. When you return to the Texture Manager, assign a **Custom Gamma value** of 1 to the texture. Choose **OK** to exit the texture manager.

6. Connect the output of the opacity image map node to the **Transparency** input of the Physical Surface node.

7. Set the **Transparency Mode** to **Opacity** (should be selected by default).

---

**Connecting a Metallic map to Physical Surface Node**

Now you will need to copy the Logo material over to the other two surfaces that use the metallic map:

1. Right-click an empty space, and choose **Select All** and then right click again and choose **Copy** to copy the nodes to your clipboard.

2. One at a time, select the following materials from the Materials list. Right-click and choose **Select All** to select the existing nodes, then right-click again and choose **Replace** to update them with the nodes in your clipboard:
   - **Eye Shield**: Gray glass
   - **Face Shield**: Gray glass

That's it! You're done with a complex multi-sub object material that uses PBR textures and which renders in both FireFly and SuperFly in Poser 11 through Poser 13. Don't forget to save your new material to the Library. An example of this material has been saved in the **Included > Runtime > Libraries > Materials > Toys > SAKitty Tutorial** folder as **SAKitty-Physical.mc6**.
Kitty1 Textures-Principled

The Cycles Principled BSDF node is introduced in Poser 12. It is a PBR "uber" shader that works in Poser 12 and later Cycles only. You can connect PBR textures to the Principled Surface node and then use the additional properties in the node to further enhance the textures with additional settings available in the Principled BSDF node.

The one drawback of Cycles materials in Poser is that they preview in gray and you don't see the results until after you render. As a result, you will probably need to test your materials with area renders as you design them, and then when posing your scene you might want to preview the results in FireFly and then switch to SuperFly for the final renders.

This latter point is why the sensible approach is to use the Cycles/Principled BSDF nodes in conjunction with shaders that already work with FireFly. To that end, if you have followed the tutorials starting with Using PBR Maps with Poser, you already have shaders that you can start with. If you haven't completed the tutorials, there is a material preset that will apply these materials for you to start with.

Adding the Cycles Root and Principled BSDF Nodes

To add the Cycles and Principled BSDF nodes to the Kitty1 Textures, follow these steps:

1. Create a new scene in Poser. Delete the default La Femme figure.

2. Navigate to the Figures > Included > Toys character library and add SA Kitty Mass Production to your scene.

3. Adjust the camera so that you can view the character more closely.

4. From the Materials library, navigate to the Materials > Included > Toys > SAKitty Tutorial library. Click the single checkmark to apply the SAKitty-Physical material to the kitty. This is the completed version of the tutorials relating to the Physical Root node.

5. Switch to the Edit view in the Material Room. Select the BodyColor1 material.

6. Collapse the physical surface node so that it's minimized as much as possible. This will give you room to add the Cycles Surface and Principled BSDF nodes.

7. Right-click in empty space and choose New Node > Root > Cycles Surface. Check the SuperFly Root box in the node.

Add the Cycles Surface and Principled BSDF nodes.

A reminder that the SAKitty1 maps are applied to the following materials:

- BodyColor1: Hexagon Pattern
- BodyColor2: Soft Denim
- BodyColor3: Matte Plastic

**Connecting the Nodes**

Connect the nodes together as follows:

1. Connect the BSDF output of the PrincipledBsdf node to the Surface input of the CyclesSurface node.
2. Set the Base Color chip of the PrincipledBsdf node to pure white.
3. Connect the output of the Color map to the Base Color input of the PrincipledBsdf node.
4. Changing the Specular value in the PrincipledBSDF node to .5 is recommended for textures that are created by Substance Painter. This will
5. Connect the output of the Roughness map to the Roughness input on the PrincipledBsdf node.
6. For the normal map:
   - Right-click in an empty area and choose New Node > Cycles > Vector > NormalMap to add a Normal Map node to the workspace.
   - Connect the output of the Normal texture map to the Color input of the NormalMap node.
   - Set the Space type in the NormalMap node to Tangent.
• Connect the **Normal** output of the **NormalMap** node to the **Normal** input of the **PrincipledBsdf** Node.

7. Right-click in an empty space in the Edit workspace, and choose **Select All** to select all the nodes. Then right-click and choose **Copy** to copy them to your clipboard.

8. Replace the **BodyColor2** and **BodyColor3** materials with the updated materials in your clipboard. (**Select All**, then **Replace**).

---

**Kitty1 maps connected to Cycles/Principled BSDF node.**

### Attaching Bump Maps to the Principled BSDF Node

If you are using a Bump map instead of a Normal map, connect the Bump map as follows:

1. Right-click in an empty area and choose **New Node > Cycles > Vector > Bump**.
2. Connect the output of the **Bump** image map node into the **Height** input of the **Bump** node.
3. Connect the **Normal** output of the **Bump** node into the **Normal** input of the **PrincipledBsdf** Node.
4. Set the **Bump** map strength using the **Strength** value in the **Bump** node.
Connect the Bump map to a Bump node, and then to Normal input of Principled Surface node.

Continue to Kitty2 Textures-Principled.

Kitty2 Textures-Principled

The material zones included in the "Kitty2" maps are as follows.

- Metallic Materials:
  - Logo: Polished Chrome
  - Metal: Polished Chrome
  - Trim: Scratchy Copper
- Fabric Materials:
  - Soft1: Carpet Velvet
  - Soft2: Carpet Velvet

Adding the Cycles Root and Principled BSDF Nodes

To add the Cycles, Principled BSDF, and NormalMap nodes to the Kitty2 Textures, follow these steps:

1. Choose one of the BodyColor materials you worked on in Kitty1 Textures-Principled.
2. Shift-click to select the CyclesSurface, PrincipledBsdf, and NormalMap nodes. Then right-click over one of the selected nodes and choose Copy.
3. Select the Logo material in the material room.
4. Collapse the physical surface node so that it's minimized as much as possible. This will give you room to add the Cycles Surface and Principled BSDF nodes.
5. Right-click in empty space and choose Paste. The three nodes should be added to the nodes that are already there.
6. Also paste the same three nodes into the Soft1 material.
Paste the Cycles Surface, Principled BSDF, and Normal Map nodes.

Connecting the Fabric Materials

Connect the nodes in the Soft1 material together as follows:

1. Connect the output of the Color map to the Base Color input of the PrincipledBsdf node.

2. Connect the output of the Roughness map to the Roughness input on the PrincipledBsdf node.

3. Connect the Normal image map output to the Color input of the NormalMap node.

4. Right-click in an empty space in the Edit workspace, and choose Select All to select all the nodes. Then right-click and choose Copy to copy them to your clipboard.

5. Replace the Soft2 materials with the updated materials in your clipboard. (Select All, then Replace).
Kitty2 non-metallic materials connected to Cycles/Principled BSDF node.

Connecting the Metallic Materials

Connect the nodes in the Logo material together as follows:

1. Connect the output of the Color map to the Base Color input of the PrincipledBsdf node.
2. Connect the output of the Roughness map to the Roughness input on the PrincipledBsdf node.
3. Connect the Normal image map output to the Color input of the NormalMap node.
4. Connect the Metallic image map output to the Metallic input of the PrincipledBsdf node.
5. Right-click in an empty space in the Edit workspace, and choose Select All to select all the nodes. Then right-click and choose Copy to copy them to your clipboard.
6. Replace the Metal and Trim materials with the updated materials in your clipboard. (Select All, then Replace).
Kitty2 metallic materials connected to Cycles/Principled BSDF node.

Continue to Kitty3 Textures-Principled.

Kitty3 Textures-Principled

The material zones included in the "Kitty3" maps are as follows.

- Fabric Materials:
  - Face: Carpet Velvet
- Metallic Materials:
  - Bolts: Worn Steel
  - DetalColor1: Solar Panel Blue
  - DetalColor2: Solar Panel Violet
  - DetalColor3: Solar Panel Light Purple
  - DetalColor4: Solar Panel Medium Purple
  - Eye Frame: Polished Chrome
- Emissive Materials:
  - Eye Glow: Yellow Emissive
  - Eye Inner: Yellow Emissive
  - LED: Red Emissive
- Transparent Materials:
  - Eye Glass: Clear glass
  - Eye Shield: Gray Glass
  - Face Shield: Gray Glass
Adding the Cycles Root, Principled BSDF, and Normal Map Nodes

To add the Cycles, Principled BSDF, and NormalMap nodes to the Kitty3 Textures, follow these steps:

1. Choose one of the BodyColor materials you worked on in Kitty1 Textures-Principled.
2. Shift-click to select the CyclesSurface, PrincipledBsdf, and NormalMap nodes. Then right-click over one of the selected nodes and choose Copy.
3. Select the Face material in the material room.
4. Collapse the physical surface node so that it's minimized as much as possible. This will give you room to add the Cycles Surface and Principled BSDF nodes.
5. Right-click in empty space and choose Paste. The three nodes should be added to the nodes that are already there.
6. Also paste the same three nodes into the Bolts, Eye Glow, and Eye Glass materials.

Connecting the Nodes for the Face

Connect the nodes in the Face material together as follows:

1. Connect the output of the Color map to the Base Color input of the PrincipledBsdf node.
2. Connect the output of the **Roughness** map to the **Roughness** input on the **PrincipledBsdf** node.

3. Connect the **Normal** image map output to the **Color** input of the **NormalMap** node.

---

**Connecting the Nodes for the Metallic Materials**

Connect the nodes for the metallic materials together as follows:

1. Select the **Bolts** material.

2. Connect the output of the **Color** map to the **Base Color** input of the **PrincipledBsdf** node.

3. Connect the output of the **Roughness** map to the **Roughness** input on the **PrincipledBsdf** node.

4. Connect the **Normal** image map output to the **Color** input of the **NormalMap** node.

5. Connect the **Metallic** image map output to the **Metallic** input of the PrincipledBsdf node.

6. Right-click in an empty space in the Edit workspace, and choose **Select All** to select all the nodes. Then right-click and choose **Copy** to copy them to your clipboard.

7. Replace the **DetalColor1, DetalColor2, DetalColor3, DetalColor4 and Eye Frame** materials with the updated materials in your clipboard. (**Select All, then Replace**).
Connecting the Nodes for the Emissive Materials

Connect the nodes for the emissive materials together as follows:

1. Select the **Eye Glow** material.

2. Connect the output of the **Color** map to the **Base Color** input of the **PrincipledBsdf** node.

3. Connect the output of the **Roughness** map to the **Roughness** input on the **PrincipledBsdf** node.

4. Connect the **Normal** image map output to the **Color** input of the **NormalMap** node.

0. For the Emissive map:
   - Right-click in an empty space in the Edit workspace and choose **New Node > Math > Color Math**.
   - Set the **Math Argument** to **Multiply**.
   - If you want to use a color other than the emissive color in the Color map, set the desired Emissive color in **Value 1** of the **Color Math** node. If you prefer using the color in the image map, set the **Value 1** color to white, and connect the output from the **Color** image map to **Value 1** in the **Color Math** node.
   - Connect the output from the **Emissive color** map to the Value 2 input of the **Color Math** node and set the **Value 2** color to white.
   - Connect the output from the **Color Math** node to the **Emission** input in the **PrincipledBSDF** node.

6. Right-click in an empty space in the Edit workspace, and choose Select All to select all the nodes. Then right-click and choose Copy to copy them to your clipboard.
7. Replace the **Eye Inner and LED** materials with the updated materials in your clipboard. ([Select All], then [Replace]).

![Kitty3 emissive materials connected to Cycles/Principled BSDF node.](image)

### Connecting the Nodes for the Transparent Materials

Connect the nodes in the transparencies material together as follows:

1. Select the **Eye Glass** material.
2. Connect the output of the **Color** map to the **Base Color** input of the **PrincipledBsdf** node.
3. Connect the output of the **Roughness** map to the **Roughness** input on the **PrincipledBsdf** node.
4. Connect the **Normal** image map output to the **Color** input of the **NormalMap** node.
5. To connect the Opacity map, do the following:
   - Right-click in an empty space and choose **New Node > Cycles > Shader > TransparentBsdf**
   - Right-click in an empty space and choose **New Node > Cycles > Shader > Mix Closure**
   - Connect the output of the Opacity texture map to the **Fac** input of the **Mix Closure** node.
   - Connect the output of the TransparentBsdf node to the **Closure1** input of the **Mix Closure** node.
   - Connect the **BSDF** output of the PrincipledBsdf node to the **Closure2** input of the **Mix Closure** node.
• Connect the **Closure** output of the MixClosure node to the **Surface** input of the **CyclesSurface** node.

6. Right-click in an empty space in the Edit workspace, and choose **Select All** to select all the nodes. Then right-click and choose **Copy** to copy them to your clipboard.

7. Replace the **Eye Shield and Face Shield** materials with the updated materials in your clipboard. ([Select All], then [Replace]).

---

**Kitty3 opacity materials connected to Cycles/Principled BSDF node.**

This completes the changes for all materials in the Kitty. You might want to save your material to the Materials library after you are done. You will find a completed version of this texture in the **Included > Runtime > Libraries > Materials > Toys > SAKitty Tutorial** folder, named **SAKitty-P12Cycles**.
Rendering
The Render Menu

The Render pull-down menu (in the top Poser menu bar) is where you render still images of your scene and access Poser’s render settings.

- **Render**: Selecting *Render > Render* renders your current scene using the currently selected renderer and that renderer’s current settings. Please refer to *Rendering* for more information about the Poser’s render engines and adjusting render settings.

- **Area Render**: see *Area Render*.

- **Render in Background**: see *Render in Background*

- **Render in Queue**: This command sends rendering jobs to the Queue Manager. For more information, see *Network_Render_Queue*.

- **Sketch Style Render**: Selecting *Render > Sketch Style Render* renders your scene using the current *Sketch Designer* settings. Please see *The Sketch Designer* for information on working with the *Sketch Designer*. Once you’ve set your options, you can use this menu command for rendering at any time while working in your scene.

- **Antialias Document**: see *Antialias Document*.

- **Motion Blur Document**: see *Motion Blur Document*.

- **Render Settings**: Selecting *Render > Render Settings* opens the *Render Settings* dialog. Please refer to *The Render Settings Dialog* for information about the *Render Settings* dialog.

- **Render Dimensions**: see

- **Materials**: Selecting *Render > Materials* opens the *Material* room. Please refer to *The Material Room* for information about the *Material* room.

- **Reload Textures**: Selecting *Render > Reload Textures* will reload into memory all textures for the current scene preview display. This allows you to easily update any changes you may have made in other applications to the currently loaded textures.

- **Reuse Shadow Maps**: If you do not make changes to lights or object positions between renders, there is no need to recalculate the shadow maps for your scene, as they will not have changed. Selecting *Render > Reuse Shadow Maps* allows you to save the shadow map computations from your previous render and reuse them, thereby saving time with each subsequent render.

- **Clear Shadow Maps**: Selecting *Render > Clear Shadow Maps* will cause Poser to recalculate the shadow maps for your scene during the next render. Use this option if you have made changes to lights or object positions, as such changes will affect the shadows in your scene.
Render and work at the same time! Using Poser’s background rendering capabilities you have the ability to render large, complex still frame scenes while you work. With the Render in Background command you can continue to work on your current scene while sending another project to render.

To Render in the background, from the Main Menu select **Render > Render in Background**.

Alternatively from the **Render Settings** dialog, and from either the FireFly Tab or Superfly Tab, you can also click on the Send Render To button and choose Background on the menu, to render a single image of the current state of the scene in the background.

After the Background Rendering has initialized, the Progress Bar on the Document Window will show your Background Rendering progress as you continue to work.

Clicking on the Preview Tab will allow you to continue to modify your current project while it’s rendering.

If you find you need to cancel the Background Rendering in progress, just click on the Cancel button in the upper right corner of the document window.
Antialias Document

Selecting Render > Antialias Document smooths rough edges in your Document view for preview purposes. Antialiasing is a process of oversampling image data to smooth object edges and avoid a jagged appearance along them. The following images show a test render both without (left) and with (right) antialiasing enabled.

Normal preview (left); Anti-aliased (right).

You can specify whether or not to apply antialiasing during renders when specifying render settings. Please refer to The Render Settings Dialog for more information about specifying render settings.

Motion Blur Document

As you probably know, fast-moving objects appear blurry. The blur is caused by the fact that our eyes cannot "refresh" quickly enough to see that the object is no longer in its previous location. The 2D Motion Blur feature lets you give your animations the illusion of motion, adding a whole new dynamic and level of realism to your renderings. You can also blur a single frame for test purposes by selecting Render > MotionBlur Document.
Using 3D Motion Blur

Poser also provides a 3D motion blur effect that uses render and camera settings to create motion blur. When you shoot a photo of a fast moving object, it appears blurry. The amount of blur is directly related to the length of time that the camera’s shutter remains open while taking the shot. In a similar manner, Poser’s Motion Blur feature lets you give your animations the illusion of motion, adding a whole new dynamic and level of realism to your renderings.

Checking the 3D motion blur checkbox in the FireFly Render Settings option section enables motion blurring for your scene when rendering. When this option is enabled, adjusting the shutter open and close times affects the amount of blurring.

Next, adjust the Shutter Open and Shutter Close settings in the Camera parameters dialog:

- **Shutter Open**: The Shutter Open value represents the shutter opening time in fractions of a frame, where 0.0 is the beginning of the frame and 1.0 is the end of the frame. Unlike a real camera shutter, this one opens and closes instantly with zero elapsed time. Regular
camera shutters, while extremely fast, require a small time interval to travel between the closed and open positions.

- **Shutter Close**: The Shutter Close value represents the shutter closing time in fractions of a frame, where 0.0 is the beginning of the frame and 1.0 is the end of the frame. Unlike a real camera shutter, this one opens and closes instantly with zero elapsed time. Regular camera shutters, while extremely fast, require a small time interval to travel between the closed and open positions. For example, setting a beginning time of 0.0 and an ending time of 0.5 means the shutter would be open for the first half of a frame.

As the amount of time between Shutter Open and Shutter Close increases, the motion blur effect increases. The shutters controls on the camera determine the time relative to the beginning of the frame the shutter will remain open. This is actually the way a real camera would work. The blur begins as soon as the shutter opens and continues until it closes.

When using motion blur the blur is created between the current frame and the next frame in the animation.

- If you need the blur to interact with a non-blur object (catching a ball for example) the scene should be composed with the subsequent frame in mind.

- If you need to produce the effect that a flash has, freezing object in the blur this can be achieved by setting the camera. This can be achieved by setting the Shutter Close time greater than one.

The image below is created by setting the Shutter Close value to 1.5. Note you will need to disable **Figure > Use limits** or adjust the properties of the shutter dial to allow for limits.
greater than 1. Higher Shutter Close values will produce a more pronounced effect. The useful range of values to achieve this is 1.1 to 5.

*A fast driving car*
The Render Settings Dialog

To open the Render Settings dialog, select Render > Render Settings. This window appears as follows.

![The Render Settings dialog.](image)

Note that the Render Settings and Movie Settings dialogs appear as tabs within a single dialog, thereby making it easy for you to toggle between them.

You can access the Movie Settings window by toggling the Movie Settings tab next to the Render Settings tab. Please refer to Rendering Animations for more information on movie settings.

Render Engines

Poser allows you to render still and animated scenes using three separate render engines. You can select which tool you wish to use by clicking on the relevant tab in the Render Settings dialog. The available Poser renderers are:

- **SuperFly rendering engine**: This rendering engine is a raytraced rendering engine that supports physically based materials. It is based on the Cycles rendering engine used in Blender. For more information about SuperFly rendering, see Using SuperFly.

- **FireFly rendering engine**: This rendering engine supports the use of procedural shaders, contains many controls that let you control exactly how you want your rendered images/movies to appear, and has the capability of generating truly breathtaking results. Please refer to Using The FireFly Render Engine for information on using the FireFly renderer.
- **Sketch Renderer**: The Sketch Renderer simulates a variety of fine art techniques, to render your scene as a drawing or painting. This tab also provides access to the Sketch Designer, discussed in The Sketch Designer.

- **Preview**: If you want to render quality high-resolution wireframe or silhouette (or any other display style) views of your scene, please choose the Preview rendering engine.

You can also select the **Preview** tab to configure your scene preview window options.

### Sketch Tab

The **Sketch Tab** provides thumbnail previews of ten standard Sketch preset styles. Simply click on the appropriate thumbnail to select the desired preset, and then click the Render Now button to render your image using those preset values. Alternately, you can use the Sketch Preset pop-up menu to select from a list of standard presets and any custom presets you may have saved using the Sketch Designer.

To easily access the Sketch Designer for fine tuning your sketch settings or creating new presets, simply click on the Sketch Designer button. Please see The Sketch Designer more information about using the Sketch Designer render engine,

![The Sketch Tab](image)

### Preview Tab

This tab allows you to customize the Scene Preview display in the Document, using the following settings: The settings in this tab apply to the document preview, and the use of Preview for actual output.

Preview and sketch renders will be output to either FireFly or SuperFly, based on the following criteria:

- Which root node is selected for either SuperFly or FireFly.
Display Engine Settings

Select the appropriate radio button to select your desired display options:

- **SreeD**: Poser’s built-in SreeD software rendering
- **OpenGL**: hardware rendering, for image previews. These settings apply to the document preview, and the use of Preview for actual output. Please refer to [OpenGL Hardware Acceleration](#) for more information about the OpenGL hardware rendering option for Poser.

Preview settings are discussed in the following sections.

![The Preview Render tab.](image)

*All options on the Render Settings Preview tab except for Offscreen Handling are now stored in the document. Please set a Preferred Scene on General Preferences Document tab if you want your settings to persist between sessions.*
Display Engine settings.

When using OpenGL for rendering, there are two additional options for offscreen handling. The default is Scene Window. When rendering a final output with the Preview renderer, if you encounter blank areas where other windows were overlapping the scene window, you should switch to PBuffer.

All options on the Render Settings Preview tab except for Offscreen Handling are stored in the document. Please set a Preferred Scene on General Preferences Document tab if you want your settings to persist between sessions.

Procedural Shader Preview

When using OpenGL hardware rendering, you can choose to see the effects of the procedural shaders you are using in your actual Scene Preview display, provided your system will support it.

Once you select OpenGL, Poser will automatically check whether or not your system will support the calculation of real-time procedural shader effects. Poser will then provide a message within the Preview tab, stating whether or not your system will support this feature. If you are not using OpenGL, Poser will provide a message that the status of this feature is undefined for your system; simply switch to OpenGL to have Poser confirm the support status.

Procedural shader preview is available for scenes using up to eight light sources.

Hardware Shading settings.
The performance of the procedural shader preview feature will be dependent upon your system’s hardware. Complex scenes with a large number of shaders may slow preview performance; if you are working with a large number of shaders, you may wish to disable this feature.

Scene Style Options

You can also specify various Style Options for your scene preview display, by entering your desired values in the appropriate fields. These options include the following:

- **Enable Hardware Antialiasing**: Check this option if your video card supports hardware assisted anti-aliasing. The option will be disabled if your video card does not support this feature.

- **Enable Hardware Shading**: You can enable procedural shader previews by clicking the checkbox. This feature is enabled (checked) by default.

  When Hardware Shading is enabled, the preview renderer will only display five lights, due to complexities of depth map shadows, AO, and normal mapping. When Hardware Shading is turned off, you can preview up to eight lights.

- **Optimize Simple Materials**: Enable shader optimization by checking the checkbox. When shader optimization is enabled, shaders will not be generated for simple materials. Optimization is enabled by default.

- **Enable Hardware Shadows**: Uncheck this option to disable enhanced real-time shadows when using hardware shading. The Depth Bias setting is dependent on the scene, the light placement, and the camera hither and yon settings. You want to find the smallest value that works well for your scene and hardware. An offset of 4 is generally a good starting point for NVIDIA cards, and an offset of 1 is a good starting point for ATI cards.

  The crisper your shadows are (that is, the larger your shadow map sizes are), and the more your light shines on a surface, the lower your hardware shadow Depth Bias setting should be.

- **Enable Hardware AO**: When checked, Ambient Occlusion is displayed according to the capabilities in the graphics hardware.

- **AO Strength**: Controls the extent at which the space ambient occlusion effect is applied.

The procedural shader preview feature does not support bump or displacement maps. Additionally, certain nodes are not supported, such as some raytracing effects, and some of the Variable nodes.
• **Silhouette Outline Width**: The Silhouette Outline Width option allows you to specify the width of the lines used in the Outline display style.

• **Wireframe Line Edge**: The Wireframe Line Edge option allows you to specify the width of the lines used in the Wireframe display style.

• **Toon Edge Line Width**: The Toon Edge Line Width option allows you to specify the width of the Toon Outline display option, as enabled via the FireFly render settings.

• **Remove Backfacing Polys**: Polygons facing away from the camera will not be rendered when this option is checked.

• **Antialias rendered image**: Check this option to smooth out rough “stairstep” edges that might appear in Preview mode, in diagonal or curve-shaped areas of high contrast. Set the number of samples in the Samples field to a value between 1 and 8.

Click the **OK** button to apply your settings.

### Transparency Display

You can set the **Transparency Display** to the actual transparency, or a specified limit, by clicking the appropriate radio button.

Selecting the **Actual** button will make any fully transparent surfaces invisible in your scene preview.

• If you wish to have some indication of where those items are in your scene preview, you can specify a limit to the transparency by selecting the **Limit to** button, and entering a maximum transparency percentage value. In the final render, transparent items are always rendered using the actual transparency settings.

• Objects with multi-layered transparency, such as hair, can sometimes appear to have inverted polygons in areas where the layers overlap. Check the **Enhance multi-layer transparency** option to improve the display of multi-layered transparent objects. The preview display runs slower when this option is enabled.
Texture Display Resolution

Adjust the **Preview Texture Resolution** slider to your liking. Lower settings provide less detail in your scene preview, but save on system resources. Higher settings provide more realism, but may result in slower performance while building your scene in preview mode.

![Texture Display options.](image)

Render Settings Buttons

The Render Settings window displays five buttons at the bottom of the window. These buttons appear in all views (SuperFly, FireFly, Sketch, Preview, and Movie Settings).

![Render Settings Buttons.](image)

- **Render Dimensions**: Click this button to open the Render Dimensions dialog, discussed in [Render Dimensions](#).

- **Cancel**: Exits the Render Settings dialog without saving changes.

- **Send Render To**: If you want to continue working while your images are rendering, there are two options. Choose Background to render your image in the Render window while you continue to work (see [Render in Background](#)). You can also send multiple images to the Render Queue, discussed in [Network_Render_Queue](#).

- **Save Settings**: Click this button to save your current render settings and return to the Poser document. When you later render a document, Poser will use the render engine that you last set properties for.

- **Render Now (Render Engine)**: Click this button to initiate a render while you are in the Render Settings dialog. Poser will render using the render engine currently being displayed in the Render Settings dialog.

Render Dimensions

Selecting **Render > Render Dimensions** brings up the Render Dimensions dialog, which contains settings that allow you to specify the dimensions of your render tab.

The main render window size is displayed in the upper left corner of the Render tab. Clicking this display brings up the Render Dimensions dialog, which contains the following settings:
Render Dimensions options.

- **Match Preview Window**: Clicking the **Match Preview Window** radio button sets the resulting render to match the existing render preview window size.

- **Fit in Preview Window**: Alternately, clicking the **Fit in Preview Window** radio button will fit the resulting render within the render preview window, while maintaining the specified aspect ratio.

- **Render to Exact Resolution**: Clicking the **Render to Exact Resolution** radio button will generate the render results according to the specific resolution specified in the following fields.

- **Width**: Enter the width in pixels for the render window in the **Width** field. Larger measurements take longer to render and require more disk space.

- **Height**: Enter the height in pixels for the render window in the **Height** field. Larger measurements take longer to render and require more disk space.

- **Resolution**: Enter the resolution in pixels per inch (PPI) in the **Resolution** field. 72PPI is normal for screen-resolution images and is suitable for images you intend to distribute online. 300PPI is appropriate for most print functions. Higher Pixel Per Inch settings (for example, 1200 PPI) are used to match the image resolution to the size and quality capabilities of the printer. Higher resolution images require more disk space and take longer to render.

Higher resolutions are normally intended for print purposes only. If you intend to print your images, the normal approach is to set the desired print size in inches, and then specify the desired resolution. Poser will multiply the desired print size by the resolution to determine the final image output size in pixels. For example, if you want to print out an image that is 8.5 by 11 inches at 600 PPI (pixels per inch), Poser will render an image that is 5100 x 6600 pixels.

When you open this image in Photoshop or another image editor, the resolution will show as 72 pixels per inch, which is typical for on-screen digital images. To adjust to the correct PPI for printing, choose Image > Image Size. Uncheck the Resample option in the Image Size dialog and change the
The production frame is determined by the aspect ratio resulting from the output width and height. You can set the production frame to be visible in the Document window’s scene preview area, by selecting Display > Production Frame from the menu bar.

**Tips & Tricks**

This section contains a few tips and tricks for improving still and animated renders:

- Experiment with low render settings and gradually increase them until you get the results you want. This will render your scene using the optimal balance between quality and speed. Small Web animations might need lower quality rendering while a piece of fine art might require very high settings.

- Still and animated renders use the currently selected camera. Be sure to select the proper camera before rendering, particularly if camera motion is part of your animation.

- By default, Poser renders using the Texture Shaded display style.

- Use the draft and production rendering options to save time while working and produce highly realistic results.

Use prop-based hair and figure-based clothing instead of strand-based hair and dynamic cloth where you do not need dynamic effects. This will conserve computing resources.
Using The FireFly Render Engine

This chapter describes the FireFly technology features and render settings:

The FireFly renderer includes a wealth of powerful features, all of which help to create beautiful, realistic renders in little time. Those aspects of FireFly that are configurable are described in the following section. The following features enhance FireFly’s performance and results:

- **High Dynamic Range (HDR) Image Support for IBL**: Poser supports both High Dynamic Range (HDR) and Low Dynamic Range (LDR) images. HDR images are comparable to analog photo film, with regards to the amount of information stored in the image. HDR light probes have a significantly higher amount of information, but are much harder to produce.

- You can use LDR images with Image Based Lighting (IBL). LDR light probes are relatively easy to create, using a mirrored ball to capture the light information in a given environment. However, the amount of information captured is much less than with an HDR image, and therefore the quality of the light probe is lower. For more information about Image Based Lighting and light probes, see [Diffuse Image-Based Lights (IBL)](http://www.photoshopcafe.com).

  There are a number of different ways to create HDR images. Several tutorials appear on the Internet for using Photoshop CS2 or later to create HDRI images. Some of them appear at [http://www.photoshopgurus.com](http://www.photoshopgurus.com) or [http://www.photoshopcafe.com](http://www.photoshopcafe.com), for example.

- **Occlusion Culling**: FireFly ignores invisible scene elements while rendering, in order to improve render performance. Occlusion culling determines which scene elements have visible impacts on the scene, and which may be culled (ignored). FireFly runs occlusion culling calculations for both the object and shadow render passes, to determine whether each scene element (a) is visible within the scene, and (b) casts any visible shadows. Occlusion culling cannot be used in conjunction with raytracing, as raytracing calculations include all scene elements, visible or not.

  A scene element’s visibility or invisibility with regards to occlusion culling is not the same as the Visibility setting the [Properties](http://www.photoshopgurus.com) palette for that element. When unchecked, the Visibility property setting actually hides an object within the scene, so that the object is not included in any render calculations regardless of its placement within the scene. Occlusion culling calculations apply to items that are set to be visible within the scene, but are obscured from the camera’s perspective by other scene elements.

- **Texture Filtering**: Texture filtering improves the appearance of surfaces rendered using 2D image maps, giving you better quality images, and avoiding aliasing and other artifacts. Tiled texture loading uses texture filtering to reduce the time required for processing. Texture filtering can be configured for individual textures on the Image Map node in the [Material](http://www.photoshopcafe.com) room (see [2D Texture Nodes](http://www.photoshopgurus.com) for more information).
Without Texture Filtering (top); With Texture Filtering (bottom).

- **Tiled Texture Loading**: Upon your first FireFly render Poser generates temporary files on the hard disk from the textures within the scene, and then selectively accesses them during render time. Poser also creates a cache in memory that contains the most recently used texture tiles. Tiled texture loading makes use of other features, such as texture filtering to reduce processing time. Depending upon your system’s resources, you may wish to increase the memory cache size to offset the amount of disk access required for tiled texture loading, as this feature may use a lot of hard disk space (potentially more than 1 GB). For information about increasing the memory cache size, see Render Preferences.

- **Multi-threaded Rendering**: The Multi-threaded Rendering feature takes advantage of the increased processing power of the multi-processor or multi-core computer systems that are now available. Using this feature, you can configure FireFly to render any number of separate threads simultaneously, which results in reduced render times for most renders. The number of threads can be specified in the General Preferences dialog (see Render Preferences for more information).

We recommend rendering your scene with as many threads (CPU cores) as your system possesses. This is the default preference after installing Poser. If you are unsatisfied with the resulting performance, or if the render fails to complete, then reduce the number of threads and/or maximum bucket size.
Firefly Tab: Quality Settings

The FireFly tab offers you a choice between specifying your render settings automatically or manually. Check the Auto Settings or Manual Settings radio button to display the appropriate render setting controls. Note that the Auto and Manual settings are stored independently, so making changes to one will not affect the state of the other. The Auto settings are useful when you first start using Poser’s FireFly render settings, because they allow you to quickly setup and render your scenes.

Auto Setting.

Manual Settings.

Auto Settings: Draft vs. Final Quality

The Auto Settings option contains a Render Quality slider, that ranges from Draft Quality (faster render times) to Final Quality (slower render times). Moving this slider will automatically adjust the values of the specific render settings, as shown on the graphs below the slider. The values of
the render settings (Min shading rate, Pixel samples, Raytrace bounces, and Irradiance caching) are depicted using a gradual shaded bar, with lighter color representing smaller values and darker representing larger values. Render settings such as Cast Shadows and Raytracing are either enabled for the render or not, so those settings are depicted using a solid color bar indicating the point at which they become enabled.

At the Draft Render Quality, the rendering settings will provide faster renders at lower quality. Use this option while creating your scene to get an idea what it will look like once it’s completed. At the Final Render Quality, the render settings yield high-quality renders, but with increased render times. Use this option for your final output. There are also options below, above, and between Draft and Final quality which will increase or decrease rendering time depending on your selection.

For a description of the settings that are found in the Auto Settings view, refer to Manual Settings.

Increase or decrease render quality with the Render Quality slider.

Manual Settings

- **Acquire From Auto**: Clicking the Acquire From Auto button applies the current Automatic Quality Settings to the individual Manual Quality Settings parameters.
• **Cast Shadows**: This option is set automatically in Auto Settings. Checking the **Cast Shadows** checkbox causes the rendering engine to calculate shadows when rendering. Individual settings will override this general setting. For example, if a figure in your scene is set to not cast shadows, then it will cast no shadows even if **Cast Shadows** is turned on for all other objects in the scene. However, if the **Cast Shadows** checkbox is not enabled, no shadows will be rendered regardless of individual object settings. Enabling this option adds realism to your renders but can affect render time.

• **Subsurface Scattering**: Enables subsurface scattering in the render engine. Materials that use subsurface scattering will not render properly if this option is disabled. For more information on some materials that use subsurface scattering properties, see **Subsurface Skin**, and **ks Microfacet (ks_microfacet)**.

• **Raytracing**: This option is set automatically in Auto Settings. Checking the **Raytracing** box enables raytracing, and vice versa. Enabling raytracing greatly enhances renderings, especially for curved surfaces, shadows, reflections, and refraction. However, it also greatly increases rendering times. Raytracing projects rays from the camera through every pixel visible in the render window, also called the View pane. Each pixel is then set to the color value returned by the ray projected through it, based on the ray’s point of intersection with an object in the scene. If the ray fails to intersect any objects, the pixel will be set to the background color. To determine whether the point of intersection is in shadow, a secondary ray is projected from the intersection point towards each light source. If the shadow rays intersect an object, the original intersection point lies in the shadow of that object. For reflections, when the ray intersects a reflective surface, a new ray is traced starting from the point of intersection and the color returned by that ray is incorporated into the color of the original intersection. This process is called **recursive raytracing** because reflected rays can spawn more reflected rays as long as they keep intersecting reflective objects. The images below show an example of raytracing. You can set the number of reflections (bounces) using the **Raytrace bounces** option (see below).

• **Raytrace Bounces**: This option is set automatically in Auto Settings. When raytracing is enabled, the **Raytrace bounces** option specifies how many “bounces” or recursions the renderer will use when raytracing. You should select the number of raytrace bounces based on the number of reflective or refractive surfaces that will interact in your scene. Higher numbers can add realism if the scene requires complex raytracing calculations. However, as higher numbers require longer render times, in a simple scenario increasing the number of raytrace bounces will just waste computation time.

---

*When using Indirect Lighting with transparent surfaces, set the Raytrace Bounces setting to at least 2 for proper IDL calculations.*

---

*One raytrace bounce (left); three raytrace bounces (right).*
• **Irradiance Caching**: This option is set automatically in **Auto Settings**. Irradiance Caching is used to accelerate Ambient Occlusion, Gather and Indirect Light effects. This is done by reusing and interpolating values instead of expensively calculating them separately for every shading point. This process speeds up calculations by tracing less rays. The irradiance caching quality can be adjusted using the Irradiance caching slider. A lower setting means lower quality: FireFly will use more estimations, resulting in shorter processing times but less accuracy. A higher setting equals higher quality: FireFly will run more new calculations, resulting in longer processing times but increased accuracy (see **Indirect Light**).

> If the quality of your render is unsatisfactory with irradiance caching on, you can disable it to calculate indirect lighting with a "brute force" method. To disable, uncheck the box that appears to the left of the Irradiance Caching slider.

• **Indirect Light**: Only enabled when Raytracing is enabled. See **Indirect Light**.

> When using Indirect Lighting with transparent surfaces, set the Raytrace Bounces setting to at least 2 for proper IDL calculations.

• **Indirect Light Quality**: See .

• **Pixel Samples**: This option is set automatically in **Auto Settings**. Select the XY pixel sample rate by moving the Pixel Samples slider. Alternatively, you can click the dots at either side of the slider to increase (right) or decrease (left) the sample size. **Pixel sampling** rates determine how many pixels are sampled when calculating antialiasing for a single pixel. For example, a setting of 3 creates a 3-pixel by 3-pixel grid with the pixel being sampled in the center. At render time, the renderer would examine the 3x3 area when determining the color and other values to assign to the pixel currently being rendered. Expanding this number can refine your renders but will greatly affect render times. 3x3 is considered a good default.

• **Minimum Shading Rate**: This option is set automatically in **Auto Settings**. The **Minimum Shading Rate** value determines the level to which object polygons will be subdivided (or diced) into micro-polygons. For example, a shading rate of 1 means that polygons will be divided into micro-polygons that each occupy approximately one pixel of the rendered image, and a value of 4 means that each micro-polygon will cover approximately 4 pixels of the rendered image. Values less than one (such as 0.2) cause each micro-polygon to be less than a pixel in size. Micro-polygons within a given polygon are as identical in size, shape, and area as possible. At render time, the renderer will subdivide each polygon, sample each micro-polygon, and assign the micro-polygons’ average color to the pixel being rendered. Enter your desired sampling rate in the Minimum Shading Rate field, or adjust the slider to the desired value. Decreasing this value can refine your renders but increases render time. You can set this value on a per-object basis using the desired object’s **Properties** palette. Setting this value in the **Render Settings** dialog applies it to the entire scene, and overrides all per-object settings that are lower than this global value. If an object has a higher shading rate, Poser will use the object’s shading rate when rendering that object.
High minimum shading rate (left), loss of detail; Low minimum shading rate (right), full detail visible.

- **Maximum Bucket Size**: The bucket is the area being rendered at any one time. Enter your desired value in the **Maximum Bucket Size** field. For example, entering a value of 10 creates a rendering bucket that is no greater than 10-pixels by 10-pixels in size. At render time, the renderer will render one such bucket area at once. Increasing the bucket size increases the area being rendered at once but requires greater system resources. Use caution when enlarging the bucket beyond its default size, and monitor your system resources. Note that Poser will automatically detect when the specified bucket size will consume excessive resources, and in such cases will override the specified bucket size and subdivide the buckets into smaller sizes. Smaller sized buckets require less RAM, but will take longer to render.

- **Minimum Displacement Bounds**: This feature is enabled only when **Use Displacement Maps** is checked in the Rendering Options window. The **Minimum Displacement Bounds** value is measured in Poser units (as specified in the **General Preferences** dialog), and determines the amount of displacement the render engine anticipates. Displacement mapping is a rendering technique that adds realistic bumps and indentations to surfaces. This is normally preferable to modeling deformations directly, since you can alter the displacement map (template used for calculating displacement) rather than editing the object. Further, adding such detail directly to an object could exponentially increase its polygon count and therefore greatly affect render time. When setting the **Minimum Displacement Bounds**, keep in mind that it is possible for displacement deformations to exceed the render bucket boundaries. In other words, even though the actual geometry of a given object may be entirely contained within the current render bucket, the object still may cross into adjacent buckets through the displacement of its surface. If a particular displacement exceeds the boundaries of the currently rendered bucket at any point, you will see a hole or patch crack at the affected location. To avoid this problem, the render engine takes into account a volume exceeding the actual geometry when determining whether or not an object is contained within a specific bucket. This volume is specified by the displacement bounds. Smaller bounds result in fewer objects within the current bucket and therefore faster rendering, but increase the risk of geometry cracks along the bucket boundaries. Larger bounds will prevent cracks but will increase render time. The above diagram illustrates this concept. In this case, the top of the pyramid exceeds the bucket bounds and will therefore be cut off, leaving a patch crack. Poser will automatically determine the displacement bounds value, by evaluating the shader trees defining the materials. If the shader tree is particularly complex, Poser might not be able to compute an appropriate value. In such a case, you should specify a higher value in the **Minimum Displacement Bounds** field. This will become the minimum value Poser is allowed to use for the displacement bounds when rendering.
• **Progressive Mode**: Check this option to get a very fast raytraced render. Several manual settings will be disabled when using progressive mode. Uncheck this option if you need more flexibility with manual render settings.

Indirect Light

Poser’s indirect light feature provides increased realism by adding light that naturally bounces off of objects to illuminate other surrounding objects. To use indirect light, create a scene that contains objects from which light will bounce onto your figure(s). For example, you can scale one or more primitive cubes to use as walls behind or near your figure. Point a directional light at the walls and the figure, and the light will bounce off the walls to illuminate the figure near it.

*Due to the number of interpolations and calculations required for this feature, the practical use of indirect light in animation will be dependent on the number of elements in your scene and the quality settings set in your renderer.*

Indirect lighting bounces light from surrounding objects.

Irradiance caching is used to calculate rays for locations where they can easily be determined. In-between locations are interpolated. The render engine determines whether to calculate or interpolate the rays based on the distance and direction of the current location to the locations previously calculated and the distance to other nearby objects.
Bounced light from IDL creates more realistic renders.

Related Settings in the **Render Settings** dialog include:

- **Indirect light**: Check this option to add indirect light for more realistic lighting
- **Irradiance Caching**: Determines the ratio of shading points where indirect light will be calculated by raytracing vs. those that will be interpolated.
  - Low values result in shorter render times, with more interpolation.
  - High values achieve more precise results at the expense of increased render times.
- **Indirect Light Quality**: Indirect Light Quality determines the number of rays used to calculate the indirect light. Higher values mean higher quality at the expense of longer render times.

The renderer will perform one pass as it samples the light rays. The pre-pass displays red dots in the places where indirect light is calculated explicitly. Following the pre-pass, the final render is completed using the indirect light calculated in the pre-pass.

**IDL Tips and Tricks**

- **Scene Considerations**: Indirect Light is designed to simulate real-world lighting where light bounces from one object to another in your scene. It works best when the main objects in your scene are surrounded by some type of environment such as a box, an environment sphere, or a room built with the PICK props which you will find in the Props library. Try to use props and materials that simulate a real-world scene when you build a scene that uses IDL.

- **Watch the Pre-pass**: During the IDL pre-pass, you’ll see red dots appear in the areas where indirect light is calculated. The Irradiance Caching setting controls how sparse or dense the calculations are. If the dots are too sparse, set the Irradiance Caching slightly higher and render again. Conversely, if the dots are too dense you can reduce the Irradiance Cache setting.

- **Smearing**: If you see smearing in your scene, it probably means there is not enough detail being picked up in the indirect light. Increase the irradiance cache setting to reduce the smearing.
• **Splotchiness:** Splotchiness occurs when there are too many samples taken. If you find that the dots are too dense during the IDL pre-pass, it may result in splotchiness. Turn down the Irradiance Caching setting, and increase the IDL Quality setting.

• **Watch the number of lights:** You won’t need as many lights in your scene when using IDL. Start with one or two lights, using the first one to light your main subject, and a second light at about 15% intensity to offset shadows if they are too dark. Also position your lights appropriately as they relate to the source of the light (such as sunlight in day scenes, moonlight or artificial light in night scenes, or light through windows or from lamps in interior scenes).

• **Shadows:** For more realistic shadows, use Ray Traced shadows. For your main light, start with a Blur Radius of around 10, Shadow Samples of around 40, and falloff set to constant. Also use a Shadow Min Bias setting that is appropriate for your display units setting. For example, if your display units are in inches (as set in the Interface tab of the General Preferences dialog), set the Shadow Min Bias to .1 inch. Adjust these settings as appropriate for your scene.

• **Normals:** Indirect light is always calculated in the direction of the normals. You will want to check the Normals Forward option (usually checked by default) in the Poser Surface root material node. This option is discussed in [Root Material (PoserSurface) Node](#).

• **Watch for Ambient glow:** There are times when you desire ambient glow from materials that are designed to be self-illuminating (LED’s, computer screens, candle light, an illuminated ceiling, and so on). There may be other times when content uses colors or values in the Ambient channel that cast undesirable light when IDL is enabled. This is particularly noticeable in skin textures and can leave the character looking “flat.” To check for objectionable ambient glow, keep IDL enabled but turn all lights off. Then render your scene. If you see light being cast from undesired places, you’ll need to adjust the ambience of the offending materials in the [Material](#) room. After you have fixed the objectionable materials, turn your lights back on and re-render.

• **Animation Considerations:** When rendering out an animation while using IDL, make sure that multi-threaded rendering is not being used (set Number of Threads to 1 in the Render tab of the General Preferences dialog). If you leave the setting at 2 or higher, your renders will come out jittery, as the shadows and lighting will not line up from frame to frame.

> To create a transparent object with an interesting glow, change the Transparency, Transparency Edge, and Transparency Falloff settings to .8 and mix with higher Ambient values and IDL features.
FireFly Options Settings

• **Render Over**: These options specify the background to be used when rendering images or movies. Check the appropriate radio button for the option you wish to select.

  • **Background Color**: Selecting Background Color renders the image/movie over the Document’s background color. Please refer to Colors for information about changing Document colors.

  • **Black**: Selecting Black renders the image/movie over a plain black background.

  • **Background Picture**: Selecting Background Picture renders the image/movie over the background image in your scene. Please refer to Using Background Pictures for information on importing background pictures.

  • **Current Background Shader**: Selecting Current BG Shader renders the image/movie over the specified background shader. Please refer to Root Background Node for information about using background shaders.

• **Shadow Only**: Checking the Shadow Only checkbox will cause only the shadows from your scene to be rendered; everything else in the scene will be completely white. This feature is most useful for production rendering, as it allows you to render just the shadows, thereby allowing you to edit them independently from the rest of the scene. You can then take the shadow only render into an image editing program, and composite it with the unshadowed scene. This setting overrides all other render settings.

• **Smooth Polygons**: Checking the Smooth Polygons checkbox enables polygon smoothing, and vice versa. When enabled, the FireFly rendering engine uses polygon subdivision to smooth hard corners on objects. If your scene contains hard edges that you don’t wish to have smoothed, you should define those hard edges either by specifying smoothing groups or by setting a crease angle threshold to determine which polygons are affected. Please see Smoothing Geometry for more information about smoothing groups and setting
the crease angle threshold. This option can be disabled for specific objects as needed, in the object’s Properties palette.

**Smooth Polygons is not supported in SuperFly.**

Without Polygon Smoothing (left); With Polygon Smoothing (right).

- **Remove Backfacing Polys**: Check the Remove Backfacing Polys option to turn off rendering of all polygons that do not face the camera. This option saves rendering time, but can affect realism when using raytracing. The polygons that are rendered depend upon the angle and position of the camera and objects in your scene.

- **Use Displacement Maps**: Checking the Use Displacement Maps checkbox enables (checked) or disables (cleared) using displacement maps in your rendered output. Please see The Material Room for information about the Material room.

Without Displacement (left); With Displacement (right).

- **Depth of Field**: Widening the lens aperture of the camera allows you to achieve a Depth of Field effect. The farther away items are from the focal plane, the more blurred they will appear. The Depth of Field checkbox allows you to enable or disable this effect when rendering your scene. Please refer to Camera Parameters for information on configuring Depth of Field settings.

- **3D Motion Blur**: Checking the 3D motion blur checkbox enables motion blurring for your scene when rendering. When this option is enabled, adjusting the shutter open and close times affects the amount of blurring. Please refer to Motion Blur Document for more information about using this feature.

- **Toon Outline**: The Toon Outline option uses post-processing during the rendering process to draw an outline around the edges of cartoon images. You can select from nine outline brush styles. We recommend applying a Toon shader node to your images, and
then complementing that shading with the Toon Outline option. Check the Toon Outline checkbox to enable this feature.

*Toon outlines are not supported in SuperFly.*

**Toon Outline.**

- **Post Filter Size:** The post filter supersamples pixels, that is, samples the colors at various points inside a pixel to arrive at the final pixel color. This is done in order to reduce or eliminate various forms of aliasing (jagged edges) that can occur under different circumstances. The final pixel color is a weighted average of the supersample. Increasing this value increases the area used for supersampling, but affects rendering time and resources. You can adjust this value by moving the Post Filter Size slider or by clicking the dots on either slide of the slider to increment (right) or decrement (left) the value.

- **Post Filter Type:** A post filter operates on an image and modifies its appearance by applying a specific weighting algorithm to the supersamples taken for each pixel. The specific algorithm used for determining relative sample weights depends upon which filter you select using the Post filter type pull-down menu. Your options are as follows:

  - **Box:** A Box filter gives equal weight to all samples within a sampling region with a diameter equal to the pixel filter size.
Box filtering example.

- **Gaussian**: A Gaussian filter gives a variably decreasing amount of weight to all samples within a radius equal to half the pixel filter size, with the maximum reduction in weight occurring farthest from the center of the sampling region.

\[
\text{Gaussian filtering example.}
\]

- **Sinc**: A Sinc filter uses a decreasing sine wave calculation to assign weight to samples within a radius roughly half the pixel filter size. The sine wave effect is similar to ripples radiating from the center point, where samples will be given weight according to their relative positions with regards to the “crests” and “troughs” of the ripples.

\[
\text{Sinc filtering example.}
\]

**Tone Mapping**: This feature is useful for scenes with a high dynamic range. Tone Mapping provides more control for brightness, saturation, and post-render processing to produce better images. It helps control overly bright areas in an image to produce better, less blown out final renderings with deeper contrast, helping to bring the brightest areas back into a reproducible range. It helps preserve as much information from a high dynamic range source as possible in an LDR image or display. Two modes of tone mapping are available.

- **Exponential**: Works like film. The more you expose film, the less sensitive it gets. This is a post rendering filter that uses an exponential curve to gently approach white. The brighter it gets, the less sensitive gets.

- **HSV (Hue, Saturation, Value) exponential**: Treats V exponentially, none on H, S. Brightness doesn’t desaturate or overbrighten color. It not physically accurate, but may be
Once you have finished entering your desired settings, click **OK** to store them. Render settings are saved when you save your scene. Clicking Cancel closes the **Render Settings** dialog without storing your changes.

To render your scene as a still image, select **Render > Render** or click the Render Now button in the **Render Settings** dialog.

To render animations, please refer to **Rendering Animations** for more information.

### Saving and Loading Presets

Although FireFly settings are not saved with your Poser scene, you can save and load FireFly Presets (including both Auto and Manual Quality settings, as well as FireFly Options settings). Simply click on the appropriate Preset button along the bottom of the FireFly tab for the function you wish to perform. The Load Preset and Delete Preset buttons will display pop-up menus listing the presets that shipped with your copy of Poser, as well as any additional presets you may have saved. Note that if you make changes to a loaded preset, your changes will not be saved unless you use the Save Preset button to record them. The Save Preset button will allow you to save the current FireFly render settings with a name of your own choosing. The Restore Defaults button will restore all FireFly render settings to their default locations.

### Smoothing Geometry

Poser provides some additional features that make geometry look smoother during render time, without having to add additional geometry. The smooth shading feature affects an object’s shading without changing the geometry of its edges. Smooth shading will render creased edges between polygons as rounded, continuous surfaces rather than as hard edges. In this way, smooth shading allows you to achieve a consistently smooth shading effect, without having to alter the geometry by subdividing polygons to minimize the creases.

By default, if there are no smoothing groups specified, smooth shading will be applied to all figures and objects within a scene, according to the Crease Angle specification in the
Properties palette for each given current actor. Additionally, you can customize smooth shading in one of two ways, as described in the following sections.

Geometry smoothing is affected by the following settings, as described in the sections that follow:

**Crease Angle**

*Crease angle* represents the angle between the normals of adjoining polygons. The *Crease Angle* property establishes a threshold up to which smooth shading will be applied. In other words, if the crease angle threshold is set to 70, smooth shading will be applied to all polygon creases with angles smaller than 70 degrees. Polygon creases with angles greater than 70 degrees will not be smoothed.

You can specify the *Crease Angle* threshold in the Properties palette for each individual actor within a figure or object. By default, *Crease Angle* is set to 80 degrees for all actors.

You can set crease angles for an element in the Properties dialog.

To change the crease angle globally, select **Edit > General Preferences**, and click on the Document tab.
Global scene crease angles can be set in the General Preferences dialog.

The following images provide examples of a sphere with crease angles set at 10 degrees and 80 degrees, respectively.

Different crease angle settings: 10 degrees (left) and 80 degrees (right).

**Smoothing Groups**

You can use the Group Editor palette to establish smoothing groups, which define the specific polygons to which smooth shading should be applied. This approach is useful in that it allows you to customize smooth shading at the polygon level, and gives you the ability to have hard edges intermixed with smooth creases. Smoothing group settings will override the crease angle setting for those specific polygons.

Select the Grouping tool from the Editing Tools palette, which will bring up the Group Editor palette. You can either assign all polygons in one or more of your figure’s existing object groups to smoothing groups, or you can create specific new smoothing groups, which will enable you to customize smooth shading at the polygon level. Please refer to The Group Editor for more information about creating new groups.
Assign Smoothing IDs in the Group Editor.

Once you have your groups established, simply click on the Assign Smoothing ID button to designate the currently selected group as a smoothing group. At render time, polygon creases between all adjoining polygons within the same smoothing group will be smoothed. Polygon creases between adjoining polygons in different smoothing groups will not be smoothed, and will therefore be rendered as hard edges. Thus you should take care as to which Smoothing ID you assign to each specific polygon group.

Different polygon groups can be assigned the same Smoothing ID, which will ensure smooth shading across the geometric breaks between groups. To do this, simply create a smoothing ID for the initial group, and then select that same ID from the pop-up list when assigning Smoothing ID’s to the other groups.

Poser will recognize and support existing smoothing groups in imported geometry. Thus, if you import figures or objects from another 3D application, Poser will apply smooth shading according to the imported smoothing group definitions, in the same manner as if the smoothing groups had been assigned within Poser.

**Smooth Polygons**

In the render settings, smooth polygons activates polygon subdivision to smooth hard edges at render time. If your image contains visible rough edges because your polygon mesh is sparse,
then the render time polygon smoothing can render those edges smooth. See FireFly Options Settings for more information about applying this option.

Smooth Polygons is not supported in SuperFly.

Enable or disable Smooth Polygons settings in the Render Settings dialog.

Note that the render time polygon smoothing will not override hard edges specified by either the crease angle or smoothing groups. Thus, you can specify hard edges definitively using either of those methods, and still apply render time polygon smoothing to all other edges.

The following figure illustrates the render time polygon smoothing effect. On the left is a sphere with a crease angle set to 80 degrees, with no polygon smoothing. On the right is the same sphere with polygon smoothing enabled.

Spheres shown without (left) and with (right) polygon smoothing.

Gamma Correction and Linear Rendering

By configuring the gamma correction you can specify the gamma that has been applied to textures, and the gamma that will be applied to exported images. This allows you to perform linear rendering for improved luminance accuracy.
When you create a new scene, the default setting for Linear Rendering is 2.2. You must use the FireFly Render Engine to set the gamma value. When you are opening a document from a previous version of Poser, you will need to enable the gamma correction if you want to perform linear rendering.

HDRI files will be read and written in a linear fashion with a Gamma value of 1.0, ignoring whatever gamma value might be specified in that location.

To enable Gamma Correction, choose **Render > Render Settings**, select the FireFly Tab and then check the Gamma Correction Box from the Options Panel. The default gamma value is 2.2 for most image formats. You have the option to specify a custom gamma value in the text field. The text field is only accessible only when the Gamma Correction Box is enabled.

---

**Gamma Correction Per Texture**

Poser’s Gamma correction on the Texture Manager allows you to specify gamma values per texture, giving you the ability to exclude certain textures from scene-wide gamma correction for maximum flexibility when dealing with displacement or normal maps.
Gamma correction for individual textures can be set in the Texture Manager.

Local gamma correction is important if you know that not all your incoming data has the same gamma value applied and you know you need to adjust the value for certain textures. Gamma correction on the Texture Manager allows correction per texture.

Most all applications read and write displacement maps linearly, even if the format used might specify a different gamma value. When you display a displacement map, it might look slightly different from the effect it will end up having on the geometry, therefore we recommend that you adjust the Gamma Value to 1.0 for Displacement Mapping, as well as for Normal Maps. Also use 1.0 for Transparency, or whenever a grayscale map is used to drive an effect.

For information on how to access the Texture Manager please refer to The Render Menu.

Once you are in the Texture Manager you can specify a custom gamma value in the text field for the selected texture.

Rendering Layered PSD Files

Poser features additional options in the Render Settings dialog that allow you to specify additional information that can be output to a layered PSD file for further compositing in Photoshop. After you create your scene in Poser, you open the Render Settings dialog and check or uncheck the auxiliary render data options that you want to include in the Photoshop file.

If you do not have an image editor that can open PSD files, you can choose another image format such as PNG or TIF. Poser will export the auxiliary renders as separate images that you can later compile as layers in your image editor.

The Render Options section of the FireFly Render Settings window includes an Auxiliary Render Data drop down menu that allows you to select from the following options:
Check or uncheck layers to be output to PSD files in the FireFly Render Options window.

You can also render Auxiliary Render Data from the SuperFly renderer, but options are limited to Normal, ZDepth, and Texture Coordinates.

Then, you render your image and save it as a Photoshop PSD file. When you open your image in Photoshop you will see the full render as the Background layer. Each additional data option that you checked will appear on its own individual Photoshop layer.

Poser saves its native renders in EXR format. Photoshop versions support EXR format differently, with plugins such as OpenEXR or other similar EXR plugins.

* Versions of Photoshop earlier than CS2 do not have 32-bit per channel support. Though there may be some EXR plugins that work for these earlier versions, they will only open or save 16-bit per channel images only.

* Photoshop CS2 does not support transparency in 32-bits per channel mode.

* Non-extended versions of CS3, CS4, CS5, and CS6 do not have as much 32-bit per channel support as the Extended versions do.

* The EXR Plugin that ships with Photoshop doesn't support all of the features of EXR, so a third party plugin may be required. Some recommendations are
Exr-IO (https://www.exr-io.com/) or ProEXR (https://www.fnordware.com/ProEXR/).

Background layer in Photoshop.

- **Normal**: The world space normal of the frontmost surface, encoded as RGB values with $x=\text{red}$, $y=\text{green}$, $z=\text{blue}$. Normal layers are identified by the letter N in Photoshop.

Normal layer in Photoshop.

- **Position**: The world space position of the frontmost surface, encoded as RGB values with $x=\text{red}$, $y=\text{green}$, $z=\text{blue}$. Position layers are identified by the letter P in Photoshop.

Position layer in Photoshop.

- **Toon ID**: The toon ID of the frontmost surface, where each ID gets its own RGB color. Toon ID layers are identified by the letters ID in Photoshop. See Entering Toon IDs below.
Toon ID layer in Photoshop.

- **ZDepth**: The distance of the frontmost surface from the camera, encoded as grayscale. ZDepth layers are identified by the letter Z in Photoshop.

  ZDepth layer in Photoshop.

- **Texture Coordinates**: The UV coordinates of the frontmost surface, with \( u = \text{red} \) and \( v = \text{green} \). Texture Coordinate layers are identified by the letters UV in Photoshop.

  Texture Coordinates layer in Photoshop.

The remaining three options correspond to three inputs on the bottom of the Poser Surface Node as shown below.
Custom Output connectors on the Poser Surface Node.

The render will export the nodes that are plugged into these inputs on the Poser Surface Node. If nothing is attached to the Poser surface node on these inputs, the output to PSD is as follows:

**Custom Outputs are not supported in SuperFly.**

- **Custom1**: If your scene contains any materials that have connections to the Custom_output_1 connector on the PoserSurface Node, they can be rendered to a Photoshop layer when you check this option. If there are no materials with connections to Custom_output_1, checking this option will create a layer that contains Diffuse only.

- **Custom2**: If your scene contains any materials that have connections to the Custom_output_2 connector on the PoserSurface Node, they can be rendered to a Photoshop layer when you check this option. If there are no materials with connections to Custom_output_2, checking this option will create a layer that contains Specular only.
Custom 2 layer in Photoshop showing custom adjustments to the two characters in the scene.

- **Custom3**: If your scene contains any materials that have connections to the Custom_output_3 connector on the PoserSurface Node, they can be rendered to a Photoshop layer when you check this option. If there are no materials with connections to Custom_output_3, checking this option will create a layer that contains Shadow only as shown below.

Custom 3 layer in Photoshop.

After rendering the desired layers, you can bring the saved PSD file into Photoshop, where you will be able to use blend styles in the Layers palette to composite the layers together to create interesting effects.

Various layers combined in Photoshop.
Entering Toon IDs

The Toon ID field in the PoserSurface node accepts values from 0 to 16777215, allowing you to specify any RGB color value. The values are direct Hexadecimal to Decimal conversions. The table below shows some common colors for examples. But you can use Poser's color picker or an image editing program to determine the RGB or Hexadecimal values for specific colors so that your Toon IDs are more predictable.

Here are values for some common colors:

<table>
<thead>
<tr>
<th>Color</th>
<th>RGB Value</th>
<th>Hex Value</th>
<th>Decimal (for Color ID)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Black</td>
<td>R0 G0 B0</td>
<td>000000</td>
<td>0*</td>
</tr>
<tr>
<td>Blue</td>
<td>R0 G0 B255</td>
<td>0000FF</td>
<td>255</td>
</tr>
<tr>
<td>Green</td>
<td>R0 G255 B0</td>
<td>00FF00</td>
<td>65280</td>
</tr>
<tr>
<td>Cyan</td>
<td>R0 G255 B255</td>
<td>00FFFF</td>
<td>65535</td>
</tr>
<tr>
<td>Red</td>
<td>R255 G0 B0</td>
<td>FF0000</td>
<td>16711680</td>
</tr>
<tr>
<td>Magenta</td>
<td>R255 G0 B255</td>
<td>FF00FF</td>
<td>16711935</td>
</tr>
<tr>
<td>Yellow</td>
<td>R255 G255 B0</td>
<td>FFFF00</td>
<td>16776960</td>
</tr>
<tr>
<td>White</td>
<td>R255 G255 B255</td>
<td>FFFFFF</td>
<td>16777215*</td>
</tr>
</tbody>
</table>

*Entering 16777216 (one number higher than the White value) will wrap back around to 0 (the black value).

To find converters online, enter search terms **RGB to Decimal** or **Hex to Decimal** in Google search.
Using SuperFly

SuperFly is a ray tracing renderer that is based on the Cycles render engine used in Blender. Ray tracing renderers more accurately reproduce how light rays bounce off of the objects in your scene.

In order to produce a render, SuperFly calculates through several passes. Each pass calculates how light interacts between the objects in your scene. The renderer looks at the lighting, the cameras, objects and material properties, where shadows fall, and so on, and examines how the light bounces between and around all of these elements. Eventually all of these passes are combined together to produce the final rendered image.

Thus, SuperFly does a lot of things that the FireFly render cannot do. Everything in the scene works with everything else. For example, motion blur can also apply to shadows. Depth of field works through reflections and refractions. And caustics will show up in volumetric objects.

SuperFly also doesn’t cache or interpolate. Everything is calculated through path tracing. As a result the render starts instantly without having to go through pre-processing. As a result, what may seem like moderate or conservative render settings can potentially lead to many light rays being traced.

SuperFly Render Settings

The SuperFly Render Settings dialog contains settings that control render properties and quality while using the Superfly render engine. In general, increasing the number of samples or the number of bounces that are taken during the rendering process increases the quality of the render; however higher settings also increase the amount of time required to complete the rendered image.
Render Settings: SuperFly tab.

With default settings, you may see areas that don’t appear as sharp as they should, or which show some artifacts and blurriness in reflections. The quality settings will help you control how the light passes to and between the objects in your scene.

Default render settings.

- **GPU Selection:** Select the desired video card for SuperFly rendering from the GPU selection menu that appears above the options in the right pane.
GPU Selection options with CPU and one GPU

- GeForce RTX 3090
- GeForce RTX 2080 Ti
- GeForce RTX 2080 Ti
- OptiX: GeForce RTX 3090
- OptiX: GeForce RTX 2080 Ti
- OptiX: GeForce RTX 2080 Ti
- AMD Ryzen 9 3900X 12-Core Processor
- Multi Device
- OptiX: Multi Device

GPU Selection options with CPU and multiple GPUs

Windows Task Manager may not report GPU usage statistics properly. For more accurate results, we recommend using a graphics processing utility such as TechPowerUp GPU-Z (Windows only) or similar.

GPU renders perform better with large bucket sizes or progressive rendering. Small bucket sizes are better for CPU rendering.

When you have more than one GPU in your system, choose one of the following two render options to make use of multiple GPUs while rendering, depending on whether or not your GPUs support OptiX rendering. As of this writing, only NVidia RTX 2000 and RTX 3000 cards support OptiX.

--- Choose Multi Device if at least one of your GPU cards does not support OptiX (for example, if you have a GTX1080, which does not support OptiX, and an RTX2080 which does support OptiX).

--- Choose OptiX: Multi Device if all of your GPU cards support OptiX. In the example shown above, the RTX2080Ti and RTX 3090 are all OptiX capable cards.
SuorFly requires a minimum compute capability of 2.0. Note that older NVIDIA GPU cards are more limited than current generations. For detailed information about NVIDIA CUDA support, see https://developer.NVIDIA.com/cuda-gpus.

Running SuperFly with a GPU has texture limits depending on model of card. On GTX4xx/5xx (Fermi-based) GPUs, the limit is 5 floating point textures (OpenEXR, HDR, 16-bit TIFF, etc) or 95 byte textures (JPG, PNG). On GTX 6xx (Kepler and Maxwell-based) GPUs, the limit is 145 textures.

**Quality Settings:**

- **Pixel Samples:** This setting is the one that determines the tradeoff between render quality and render speed. The pixel samples setting controls the number of paths to trace for each pixel. The value that you enter here will be squared to get the total number of primary rays. In other words if you enter a pixel sample value of 4, it will result in 16 primary ray traces, whereas a value of 24 will result in 576 ray traces. Higher values increase the overall quality of the render, but will also increase render times. Increasing the pixel samples reduces graininess in reflective and refractive light.
**Adaptive Sampling w/Threshold**: Adaptive sampling helps speed up render times by examining changes as each render sample is made. It will move to the next bucket when it detects that any additional bounces will produce little to no change in the render quality of the current bucket. A threshold of 0 is a "brute force" method that will cut down render times the most. Non-zero settings may take a little longer than the brute force method but will be better quality. You can use adaptive sampling with CPU or GPU graphics cards. For some examples of render settings that use Adaptive Sampling, choose any of the following presets from the Load Preset button in the SuperFly tab (listed from lowest to highest quality render):

- **CPU Fast, GPU Fast, OptiX Fast**: Threshold set to .100
- **CPU High, GPU High, OptiX High**: Threshold set to .001
- **CPU Medium, GPU Medium, OptiX Medium**: Threshold set to .050

- **CPU Timed 10 Second, GPU Timed 10 Second, OptiX Timed 10 Second**: Threshold set to .000 (Path Trace Time is set to 10 seconds)

- **CPU Ultra Caustics, GPU Ultra Caustics, OptiX Ultra Caustics**: Threshold set to .001

The useful range of values in the UI will be 0.1 to 0.001 with 0.1 producing a very noisy render and 0.001 just rendering all samples and never reaching the threshold.

For reference in a simple scene a setting of 0.1 stops at about 25 samples which is equivalent to a setting of 5 samples in the render settings. A setting of 0.001 goes over 10000 samples which would be about 100 pixel samples on the settings tab.

- **Min Pixel Samples**: Sets a minimum value for the number of pixel samples

- **Path Trace Time**: Sets a maximum value in seconds for ray trace calculations

- **Legacy Branched Path Tracing**: See Using Legacy Branched Path Tracing

- **Filter Glossy**: Widens highlights in secondary reflections to reduce bright spots. It broadens specular highlights in secondary reflections (reflections of reflections), which softens them without a loss of energy. A setting of 0 turns glossy filtering off.

Filter Glossy of 0 (top) and 100 (bottom).

- **Clamp direct samples**: Sets a limit on the contribution of an individual sample. A setting of 1 means that an individual sample cannot contribute more than RGB 1,1,1 to a pixel (with 0,0,0 equaling black and 1,1,1 equaling white). Lower settings can improve antialiasing of overly bright areas in the image, but may visibly darken those objects when their visibility is blurry. A setting of 0 produces an unlimited contribution of direct samples, and is essentially the same as “HDRI optimized” FireFly. With Clamp direct samples set to 1, it operates similarly to FireFly with HDRI unchecked. The default of 10 is a compromise between preserving enough dynamic range for depth of field, and reducing dynamic range far enough to get decent antialiasing.
• **Clamp indirect samples**: Indirect light is light that bounces off of other objects in the scene, verses light that comes from a direct light source. This setting specifies a maximum limit on the number of indirect light rays that can be contributed, which can reduce noise in indirect light situations but can also reduce brightness. A setting of 0 produces an unlimited contribution of indirect samples.

> The Filter Glossy, Clamp Direct Samples, and Claim Indirect Samples settings can be used to minimize hot pixels in the render. If they are set too low, the image will be visibly darker. If set too high, hot pixels may still persist.

Options:

• **Progressive Refinement**: When unchecked, SuperFly renders all passes of one tile at a time, and moves on to the next bucket after the current one is rendered at maximum quality. When the Progressive Refinement option is checked, SuperFly will render one pass of each bucket, one at a time. Each successive pass will increase the quality of the entire image. Generally, you check the Progressive Refinement option when you want a quick preview of how changes affect your scene. However, using Progressive Refinement for final renders will take longer to render than when leaving the option unchecked.

> When using Progressive Refinement to preview your render settings, uncheck the Branched Path Tracing option, and set the pixel samples to a high value (such as 128). You can press the Cancel button at any time during the preview.

> Progressive Refinement also works when using the Render in Background command.

• **Transparent Background**: Enable this option to force the background to be transparent. This will create an alpha layer in the image for compositing. If there is a background environment object such as the Construct or an envirosphere, you will need to make it invisible for transparent background rendering to work.

• **Min Bounces**: Controls the minimum number of total bounces. More bounces result in longer render times.

• **Max Bounces**: Controls the maximum number of total bounces. More bounces result in longer render times.

• **Diffuse Bounces**: The number of diffuse bounces controls the indirect diffuse light. A value of 0 means there is no indirect diffuse.

• **Glossy Bounces**: Controls the number of glossy bounces. More bounces result in longer render times.

• **Transmission Bounces**: Controls the number of transmissive bounces. More bounces result in longer render times.
- **Min Transparent Bounces**: Controls the minimum number of transparent bounces. More bounces result in longer render times.

- **Max Transparent Bounces**: Controls the maximum number of transparent bounces. More bounces result in longer render times.

  The Max Transparent Bounces setting will help reduce render times in scenes that contain many layers of transparent materials (hair, leaves on trees, etc). Since each transparent layer is calculated during ray tracing, there is a potential of hundreds or even thousands of bounces to occur. Set the Max Transparent Bounces amount to at least the minimum number of bounces required to obtain desired render quality for multi-layered transparencies. Higher settings of 64 or more will reduce fuzziness in hair renders.

- **Volume Bounces**: Controls the number of volumetric bounces. More bounces result in longer render times.

- **Bucket Size**: Smaller buckets use less memory. Larger buckets render the image faster.

  When using GPU rendering, the Bucket Size setting will help to achieve optimal performance. Start with a bucket size between 100 and 300. Some scenes may benefit with larger settings.

- **Motion Blur**: Enables motion blur effect. The quality of the motion blur effect is controlled by the Pixel Samples setting.

- **Depth of Field**: Enables depth of field effect. The quality of the depth of field is controlled by the Pixel Samples setting.

- **Refractive Caustics**: Enables caustics caused by specular refraction.

- **Reflective Caustics**: Enables caustics caused by specular reflection.

  Caustics are light rays that originate at a light source, and then are reflected or refracted off of a surface such as glass or reflective surfaces such as mirrors. Caustics are rendered in SuperFly only.

  Caustics are best achieved when using area lights that are placed very close to the object or objects that you want to reflect or refract.

- **Apply Post Effects to Render**: Click the Open PostFX button to open the Post Effects dialog, described next in Applying Post Effects to Renders.

- **Auxiliary Render Data**: Allows you to export Normal, ZDepth, and Texture Coordinates layers to PSD files. See Rendering Layered PSD Files.
Four buttons appear beneath the render options to work with render presets:

- **Load preset**: Click this button to use a factory default or custom render preset.

- **Delete preset**: Click this button to delete a preset that you have previously saved. This button will be disabled if no custom presets have been saved. Factory presets cannot be deleted.

- **Save preset**: Click this button to save the current render settings as a custom preset.

- **Restore defaults**: Click this button to revert render presets to default factory settings.

### Using Legacy Branched Path Tracing

When you check the Legacy Branched Path Tracing option, you will be warned that using Branched Path Tracing in conjunction with GPU rendering may cause instability with some drivers. The warning suggests that you instead increase Pixel Samples to 20 or higher when using a GPU Device.

After displaying the warning, you can enable branched path tracing by choosing OK to continue.

### Applying Post Effects to Renders

There’s often a trade-off between rendering speed and rendering quality. If you set render quality settings too low, the renders will finish more quickly, but they will contain a lot of noise. If you set your render quality settings very high, your renders will take a much longer time, but will be very sharp and clean.

There is a way to compromise. If you set your render settings in the middle range, and then use the denoising filter provided with PostFX, you can obtain very good render results in a more reasonable amount of time.

Access the PostFX settings as follows:

- To enable Post Effects in SuperFly, open the **Render Settings** dialog to the SuperFly tab. Check the **Apply Post Effects to Render** option, and then click the **Open PostFX** button to check the default post effects you want to apply to your render.
Post Effects option and button.

- A PostFX button also appears in the top center of the Render tab, as shown below. You can click this button to apply postfx to the render that is currently in the Render window (which is, by default, your most recent render). Click this button to open the Post Rendering Effects dialog.

PostFX icon.

**PostFX Settings**

When you open the PostFX window from the Render Settings dialog, the following screen appears. This allows you to choose which post effects options and settings to use by default. The settings are described below.

The settings you apply here can be applied when you render animations using the Movie Settings window in Render Settings, or when you use the Animation > Make Movie command. For example, to render an image sequence, choose Image Files format, and then select SuperFly for the renderer.

If your images are rendered against a transparent background, export PNG format to preserve transparency. Images will be exported with an alpha channel.
When you right-click on a thumbnail in the Recent Renders palette and choose **Edit Post Effects**, the Post Rendering Effects window appears. The PostFX settings (shown above) appear on the right side of the window, and a preview window appears on the left. As you make adjustments to your settings, the preview window updates to reflect them.

By default, the last render that you completed will appear in the preview. You can also click any render thumbnail in the Recent Renders palette, and click the PostFX button in the center of the options above the Render window to open the Post Rendering Effects window.
You can use this preview to view how the post rendering affects will affect your selected render. The following example shows the preview of a figure that was rendered with Medium Adaptive (GPU) render preset.

![Post Rendering Effects window (denoising not applied).](image)

**Denoising**

Check the **Apply Intel Denoise** option to apply denoising at the end of the render. Denoising generally improves the appearance of renders that are created with medium or low-quality render settings. The preview window will update with a preview of the denoised render. Use the **Denoise Intensity** slider to raise or lower the amount of denoising applied.
Image Adjustments

- **Exposure**: Increase or decrease the Exposure slider to adjust image exposure.

- **Saturation**: Use the Saturation slider to adjust the saturation of the image. Moving the slider or entering a value of -1 will generate a grayscale image.
Original (left) vs Post Effects Saturation adjustment (right).

**Gamma.**

Original (left) vs Gamma adjustment (right).

**Brightness.**
Contrast:

Original (left) vs Brightness adjustment (right).

Bloom

The Bloom filter makes lighting in your scene appear more realistic, by enhancing glows around lights.
Original (top) vs Bloom enabled (bottom).

- **Bloom.** Check this option to enable the bloom filter.

- **Bloom Intensity.** Adjusts the strength of the bloom effect.

- **Bloom Light Level.** Adjusts how bright an area needs to be before it's included in the bloom calculation.

- **Bloom Radius.** Adjusts the size of the bloom effect.

**Blur and Pixelate**

The Blur setting blurs the rendered image by the amount specified.
Original (left) vs Blur (right).

Pixelate

Original (left) vs Pixelate (right).

Other Post Rendering Effects Settings

- **Clear All**: Returns all post rendering effects settings to their default value.

- **Load Scene Settings**: When you restart Poser, the Post Rendering Effects window starts up with the default settings. If you open a scene that has had post effects settings saved (with the Save to Scene Settings button below) you can reset the post effects to those saved values with this button.
SuperFly Limitations

Limited Support

- Displacement maps are rendered at mesh resolution. You will need to increase the Render subdivision level to get more detail as needed for displacement maps.

- Lighting Nodes can only be plugged into Blender or Fresnel Blend nodes and Alt Diffuse, Specular Color, Reflection Color or Refraction Color inputs.

- Checking Reflection_Lite_Mult or Reflection_Kd_Mult will disable any lighting nodes plugged into the reflection channel.

Unsupported in SuperFly:

- Ambient occlusion on lights
- Smooth Polygons
- Custom output 1, 2 and 3
- Specular and Diffuse light shaders
- Background node Diffuse_Color, Specular_Color, and Bump input
- Depth Cue
- Atmosphere Strength parameter on lights
- Quality and ray bias parameters on ray traced nodes
- **Opaque in Shadow** checkbox on Hair node
- Shadow catchers
- Toon outlines
Real-time Raytrace Preview

Choose **Window > Raytrace Preview** to enable the real-time raytraced viewport, which provides a more accurate preview render without having to render your scene.

The Raytrace Preview window functions just like any other Poser palette, which can be docked or floated. It appears only in the room in which you initially opened it. For example, if you turn the Raytrace Preview window on in the Pose Room, but then switch to the Material room, you will not see the Raytrace Preview window unless you choose the **Window > Raytrace Preview** command in the Material room. When you return back to the Pose Room, the first Raytrace Preview window will still be open there.

*Do not use the Raytrace Preview feature if you are currently rendering a scene. The main render engine will take precedence over the Raytrace Preview process.*

**The Raytrace Preview.**

Click the **Refresh** button to manually refresh the raytrace preview after you make changes to your scene. Click **Save** to save the preview image to a location of your choice.
The Sketch Designer

Poser’s Sketch Designer renders scenes as sketch-like drawings using black-and-white or colored brush strokes that you can tailor to your liking. Simulate pen, pencil, pastel, charcoal, and even watercolors and paintings without ever having to pick up a pencil or brush!

You can save Sketch Designer renders and reload them later for further work. The Sketch Designer also lets you create amazing animations that look like hand-drawn movies. For best results, try rendering scenes using plenty of detail (hair, clothing, etc.) and dramatic lighting.

To access the Sketch Designer, select Window > Sketch Designer. Alternately, you can access the Sketch Designer via the Sketch tab in the Render Settings dialog, which also contains other render and movie settings.

Sketch Designer Tabs

The Sketch Designer has three tabs which allow you to adjust settings for three distinct areas of your sketch:

- **Objects**: The Objects tab allows you to determine the sketch style for objects and figures in your scene.
- **Background**: The Background tab allows you to determine the sketch style for your scene’s background.
- **Edges**: The Edges tab allows you to determine the sketch style for the edges of objects and figures in your scene.
Rendering Sketches

After setting up your sketch, you can render it to the Document. This is useful if you want to export a movie rendered using the Sketch Designer renderer. To render to the Document, select Render > Sketch Style Render.

Exporting Painter Scripts

Clicking the Export Painter Script button in the lower left corner of the Sketch Designer exports the current Sketch Designer settings to Corel Painter. This has been tested to work with Painter 6 and previous versions, and is not supported for later versions though it may work with them.

Sketch Parameters

The Sketch Designer includes the following parameters, controllable using sliders. Moving a slider to the right increases the selected value, and vice versa. These parameters customize many characteristics of the sketched lines. Your sketch redraws each time you adjust a value, allowing you to see the results of your changes.

Density: The Density slider controls the density of lines in the sketch.

Line Length: The Line Length slider defines the length of strokes.

Min Width: The Min Width slider defines the width of the edge of each stroke, which affects the brightness of the original image.

Max Width: The Max Width slider defines the width of the center of each stroke, which affects the brightness of the original image.

Lo Brightness: The Lo Brightness slider determines the band of tone. A low setting only draws lines in the darkest parts of your scene. If the Over Black option is disabled, setting this control to 0 produces the best results.

Hi Brightness: The Hi Brightness slider determines the band of tone. A lower setting only draws lines in the darkest parts of your scene. If the Over Black option is enabled, setting this control to 256 produces the best results.
• **Stroke Head**: The Stroke Head slider determines the amount of taper at the stroke’s head.

• **Stroke Tail**: The Stroke Tail slider determines the amount of taper at the stroke’s tail.

• **Line Random**: The Line Random slider controls line randomizations. Higher settings result in more randomly shaped lines.

• **Color Random**: The Color Random slider controls color randomizations. Higher settings result in more random colorization.

• **Opacity**: The Opacity slider determines the clarity of lines. Lower values create more transparent strokes.

• **Cross Hatch**: The Cross Hatch slider controls the frequency of cross-hatching in the strokes.

• **Total Angle**: The Total Angle slider determines the total amount of angle change that a stroke can have before it stops drawing. Higher values darken the image. Lower this value when you have lower Density settings.

• **Color Cutoff**: The Color Cutoff slider determines the threshold of color changes allowed for a stroke. Use this slider in conjunction with Total Angle.

• **Colored Strokes**: Checking the Colored Strokes checkbox causes sketches to be rendered in color. When disabled, sketches are rendered in black and white. The dropdown list at the right of this option allows you to specify a stroke type. For maximum effect, try using these brushes with both the Min Width and Max Width sliders set to higher values.

![Brush Options.](image-url)
Global sliders:

- **Light 1, 2, and 3**: The Light 1, Light 2, and Light 3 sliders determine the extent to which the first three lights in your scene contribute to the direction of strokes. Higher values make the strokes go in the direction of the selected light(s).

- **BG Direction**: The BG Direction slider defines the direction of the background strokes.

- **Auto Spacing**: The Auto Spacing slider controls the amount of space between strokes if the Auto Density option is enabled.

- **Color Blend**: The Color Blend slider determines how much color in the Document will be blended into the sketch.

- **Over Black**: Checking the Over Black checkbox renders your scene over a black background with white strokes. When disabled, the background is white with black strokes.

- **Auto Density**: Checking the Auto Density checkbox causes stroke density to reach an automatic density based on the current scene, ignoring the Density slider setting (see below). When disabled, the density is calculated based on the Density slider setting.

**Presets**

Four buttons at the bottom of the Sketch Designer window allow you to save and use presets.

Buttons at the bottom allow you to maintain your Sketch Designer presets.

- **Load Preset**: Use the Load Presets button at the bottom of the Sketch Designer to select one of the available preset sketch styles.

- **Delete Preset**: Click Delete Preset to display a list of presets, then select the preset you want to delete.
The Delete Preset option allows you to remove the sketch presets included with Poser. Once deleted, you must reinstall Poser to restore your factory default sketch presets.

- **Save Preset**: To create a preset, adjust the sketch style to your desired settings, then click Save Preset. Enter a name for your preset and click **OK**. Your new preset will appear in the Load Presets list.

- **Restore Defaults**: Resets all slider values to their default settings.

You can also use the sliders and other options to create an almost infinite variety of styles.
Queue Manager

Rendering large and complex scenes (jobs) can take a long time to process and monopolize your computer system. The Queue Manager distributes jobs between one or several nodes in a Network Render Queue. When you use the Queue Manager for remote tasks, the Network Render Queue will distribute jobs based on the systems that are available. You can send single-frame or multiple-frame jobs to the Queue Manager.

Installing Queue Manager

The Queue Manager can be installed as part of your initial Poser installation using the Full Installation (Windows) or Easy Install option (Mac). Your Poser license allows you to install the Queue Manager on up to three computers. The Queue Manager is installed with Poser, and the Poser license allows you to install Queue Manager separately on up to two additional computers. Refer to Licensing Queue Manager for steps on how to register Queue Manager on remote computers.

You can install just the Queue Manager on remote systems by following the instructions below:

When you install Poser, it will also install the necessary files for Queue Manager that you need on the installation computer. The separate Queue Manager installer is intended for remote nodes that you want to use for rendering. You will receive a warning message if you try to install the separate Queue Manager installer on the computer that has Poser installed.

When using Queue Manager, you will need to use matching versions on all computers. If you have multiple versions of Poser installed on your master computer, you should also install the related versions of Queue Manager on your remote computers. Versions will be considered to match if the Poser version and subversion number are the same. Different build numbers in a subversion are acceptable. For example, version 12.0 and 12.1 do not match. But versions 12.1.140 and 12.1.168 do match, because both are different builds of version 12.1.

Queue Manager works with licensed versions of Poser only. It will not run on a trial version.
Installing Queue Manager on a Remote System (Windows)

1. Click on the Queue Manager installer to start the installation.
2. When the Welcome screen appears, click **Next** to continue.
3. The Poser End User License Agreement (EULA) will appear. Accept the agreement and click **Next**.
4. Review the Readme text and click **Next**.
5. Select the destination location where you want to install the Queue Manager. You can use the default location or click the **Browse** button to specify another location. Click **Next** to continue.
6. Using the pull-down menu select Queue Manager and click **Next**.
7. **Select Additional Tasks** screen will appear. Enable the check boxes to create desktop icons for both Poser and the Queue Manager, click **Next**.
8. Click **Install** to install the Queue Manager. When the installation is done, click **Finished**.

Installing Queue Manager on a Remote System (Mac)

1. Click on the Poser installer to start the installation.
2. The Welcome screen will appear, click **Continue**.
3. The Poser End User License Agreement (EULA) will appear. Accept the agreement and click **Continue**.
4. Review the Readme text and click **Continue**.
5. Select the destination location where you want to install the Queue Manager. You can use the default location or click the **Browse** button to specify another location. Click **Continue**.
6. Using the pull-down menu select Queue Manager and click **Continue**.
7. Click Install to install the Queue Manager. When the installation is done, click **Quit**.

Licensing Queue Manager

When you install Poser 13, the Queue Manager is installed as part of the base installation. The registration screen for the Queue Manager will appear as shown in [Activating Poser](#).

Your Poser license allows you to render on two additional computers through the use of the Queue Manager. A separate Queue Manager installer (Install Queue Manager 13.exe for Windows, and Install Queue Manager 13.pkg for Mac) is available for installation on remote computers.
You can run up to 3 instances of the Queue Manager simultaneously. If you attempt to run Queue Manager on a fourth computer, you will be prompted to enter a new Queue Manager license number, or purchase additional Queue Manager seats.

When you start Queue Manager on a remote computer, a registration dialog will appear.

Enter your Poser serial number, or the serial number provided with your additional Queue Manager seat purchase, and choose OK to register the Queue Manager on your remote computer. If you are unable to proceed because the number of seats has been exceeded, click Cancel to exit the dialog.

Sending Jobs to the Queue Manager

Once the Queue Manager is running on your system and/or on another network node, you can send jobs to render in the Queue. Poser will launch the Queue Manager if it is not already running on your system. However, in order process a job in the Network Render Queue, the Queue Manager must be running on the remote system(s).

Using the Render Queue for a Single-Frame job

To send a single-frame job to the Render Queue, first select the FireFly tab in the Render Settings dialog. Then, you can do one of the following:

- From the Main Menu, select Render > Render In Queue.
- Click the Send Render To button in the The current frame with the current FireFly Render Engine settings will become the rendered job. Name the job, select a file format from the pull-down menu, and specify the output location. Click Save. This will submit the job to the Queue Manager and add the job to the job list. Sending a job to the Queue launches the Queue Manager if it is not already running.
When you send a single frame render to the Queue, the filename that you enter will be appended by the frame number that you are rendering. For example, if your project is on frame 30 when you render a still image, the image that is rendered in the Queue will be named (filename)_0030. Previous renders of the same frame will be overwritten.

The Render in Queue command creates a render job.

Using the Render Queue for a Multi-Frame Job

To send a multi-frame job to the render queue, from the Main Menu, select Animation > Make Movie. Choose your images path and filename as discussed in Rendering Animations.

Once the movie settings have been defined they cannot be changed, and the job will retain those properties when sent to the Render Queue.

Then choose one of the following options:

- To render images and encode the movie immediately:
  - Click the Send Render To button and choose Queue.
  - In the Make Movie Options section, check Auto Make Movie.
  - Then click the Encode Images button at the bottom of the make movie dialog.

- To render images only, and create the movie later:
  - Click the Send Render To button and choose Queue.
  - Click Save Settings to save the render settings in the Make Movie dialog. After you close the Make Movie dialog, choose File > Save to save your current project file before you close it.
  - Click the Render Images button in the Make Movie Options section. The images will be created in the location specified.
  - When you later reopen the Make Movie dialog, verify that the images path points to the image files that you previously rendered. Then click the Encode Images button.
Once you have submitted a job to the Queue, you can begin editing, start another project in Poser, or start working in another application.

**Using the Queue Manager**

The Queue Manager has three sections: The **Queue Menu**, the **Job List** and the Selected **Job Panel**.

**Queue Menu**

The Queue Menu allows you to configure how jobs are distributed for processing.
The Render Queue menu.

- **Suspended**: Selecting Queue > Suspended, suspends the operation of all jobs.

- **Process Jobs Locally**: Enabling or disabling Queue > Process Jobs Locally, specifies whether or not the Queue Manager will use your local system to render your jobs.

- **Send Jobs to Network**: Enabling or disabling Queue > Send Jobs to Network, specifies whether or not the Queue Manager will distribute jobs to other systems.

- **Accept Jobs from Network**: Enabling or disabling Queue > Accept Jobs from Network, specifies whether or not the Queue Manager will process tasks from other systems. Local jobs will always have priority.

- **Show Log Panel**: Enabling Show Log Panel lets you see a detailed log of the jobs being processed. The Log can be useful for troubleshooting and tracking how other machines are being utilized.

- **Verbose Logging**: Provides more detailed log events in the Log Panel at the bottom of the Queue Manager window.

- **Delete Temporary Files**: Check this option to delete temporary files after Queue Manager completes rendering the image(s)

- **Render Device**: Displays a list of the available graphics adapters on your system. Select the device that you want the Queue Manager to use for rendering. If you choose Use setting from Job, the Queue will use the device that was selected in the Render Settings dialog.

When choosing an OptiX render device in Queue Manager, be sure to disable Branched Path Tracing in Render Settings before selecting the device. Alternatively, set up your OptiX render and other options in the Render Settings dialog and choose "Use Settings from Job" as the Render Device.

- **Language**: Choose from English, German, or Japanese.

We recommend that you do not perform simultaneous renders on the computer that has Poser installed. Assume, for example, that the Queue Manager has a job list of images or movies that are still in progress. If you
job list

the job list shows a job’s properties including document, output file, start time, completed time, status, frame, start, end, increment, host and order. on the selected job panel sort the jobs by clicking on any of the property headers. this will not change the job order.

- **document**: the name of the document in poser.
- **output file**: the job name when submitted to the queue.
- **progress**: percentage of job completed.
- **start time**: the time the job was received by the queue manager.
- **completed time**: the time the job was completed.
- **status**:
  - **running**: the job is currently being processed.
  - **waiting**: the job is waiting to be processed.
  - **suspended**: the job is on hold.
  - **done**: the job is processed and is shown on the job list for reference.
- **frame**: indicates the frame that is currently being rendered.
- **start**: derived from the movie settings dialog.
- **end**: derived from the movie settings dialog
- **increment**: derived from the movie settings dialog
- **host**: indicates the node this job came from.
- **order**: displays the order in which jobs will be rendered.
- **render device**: displays the device used for the render. "use job" uses the device as selected in render settings.

selected job panel

select a job to access the following options.
The Selected Job panel, showing verbose logging.

- **Output Path**: Displays the output location of a selected job.

- **Go To Folder**: Find the output location of your job anytime by highlighting the job and clicking on the Go To Folder. This will bring you to the output location.

- **Order**: Once a job is sent to the Queue Manager the job will appear on the job list. You can change the order of the jobs by selecting <<Lower or Raise > > .

- **Actions**: Select a job from the Job List to change its status using the following actions:
  - **Cancel**: Click Cancel to abort a job (Running, Waiting or Suspended).
  - **Suspend**: Click Suspend to put a running or waiting job on hold.
  - **Purge Finished Jobs**: Click to remove finished jobs from the Queue list.

If you are experiencing difficulty with the Network Render Queue, verify the following:

- All network cables are plugged in and the network is functioning properly.

- Remote systems in the Network Render Queue are up and the Queue Manager application is installed and running.

- Your personal firewall is allowing communication between Poser and the Queue Manager, locally and remotely.

- If you are unable to resolve a network communication issue, contact your Network Administrator.
Animating
Poser Reference Manual

Animating with Poser

Poser allows you to animate figures and props, giving life to your scenes. You can use your work in multimedia projects, on the Web, and in videos by exporting rendered results to Windows AVI, or Macintosh QuickTime. AVI movies are rendered in 32-bit color, which by default includes an alpha channel (mask) for each frame. This can aid in compositing the animation with other movie footage. QuickTime movies can also contain an Alpha channel if set to render at millions of colors.

Once rendered, exported animations can be opened and edited in post-production tools such as Adobe Premiere and Adobe After Effects, where you can edit sequences and add special effects. While you can create long animations, we recommend creating a series of shorter animations and piecing your scenes together using an editing application. Real movies follow this guideline as well: Each time a camera angle changes, you’re seeing a new take of a scene or a different scene altogether. This includes cases such as conversations, where the camera is switching back and forth between the participants. Poser includes many powerful tools designed to help you create stunningly realistic animations. Animation is easy to learn but hard to master. Start with short simple movies and work up as your skills improve. The results may surprise you!

The Animation Menu

- Setting Animation > Make Movie opens the Make movie window. Please refer to Rendering Animations for more information on rendering animations in Poser.

- Recalculate Dynamics: Choose one of the options in the Animation > Recalculate sub-menu to recalculate all cloth dynamics, all hair dynamics, all physics dynamics, or all dynamics. For more information about dynamics, see The Hair Room, The Cloth Room, and Using Bullet Physics.

- Retime Animation: Selecting Animation > Retime Animation allows you to adjust the timing of your animations. Please refer to Retiming Keyframes for more information.

- Resample Key Frames: Selecting Animation > Resample Key Frames opens the Resample Keys window, which allows you to increase or decrease the number of keyframes in your animation: Please refer to Resampling Key Frames.

- Bake Transforms: For more information about the Bake Transforms command, see Bake Transforms.

- Loop Interpolation: If your animation contains looping cycles (such as a walk) that do not match evenly (causing jerky motions between the end of one loop and the start of the next), toggling Animation > Loop Interpolation on can smooth out your animation.

- Quaternion Interpolation: Quaternion interpolation is a mathematical formula that can smooth rough animations. If your animation remains jerky after editing keyframes and all
At its simplest, the animation process is as follows:

1. Decide how many frames you want in your animation. One way to do this is to decide how long your animation will be in seconds, then multiply that by the desired number of frames per second (frame rate).
2. Create a starting pose.
3. Select your next keyframe.
4. Create a new pose.
5. Repeat Steps 3 and 4 until your animation is complete.

Poser uses a technique called keyframe animation to simulate motion based on a series of still poses. You set up a series of poses at different points in time. These are the keyframes. Poser fills in the gaps, interpolating between keyframes to create the illusion of motion. This keeps you from having to move your figure each time you want to create a motion, such as is done in stop-frame animation, where each frame is individually positioned (many “Claymation” movies use stop-frame animation).

**What You Can Animate**

What can you animate using Poser? Just about everything! Here are some examples:

- **Figures** (humans, animals, clothing, etc.): If you can imagine a motion, you can create it using Poser! Please refer to [Posing Figures](#) for information about posing human figures, and to [Posing Animals](#) for some information about posing animals.

- **Hands**: Gestures and small motions add incredible realism to videos. Many amateur animators ignore hands when animating, which subtly detracts from your scene’s realism. Please refer to [Posing Hands](#) for information about posing hands.

- **Faces**: Animating faces can add emotion and power to your scene and can also mimic speech. Please refer to [Posing Faces with Morphs](#) and [Posing Faces with Bones](#).
• **Props**: You can animate props by moving them about the Poser workspace, parenting them to other actors, etc. Please refer to [About Props](#) for more information about props.

• **Lights and Cameras**: Change color and position of lights and zoom, pan, or bank cameras over time.

• **Deformers**: You can animate magnets, waves, morph targets, and parameters. Please refer to [Using Deformers](#) for more information about deformers.

• **Force Fields**: You can animate Force Fields to create realistic wind effects for strand-based hair and dynamic cloth. Please refer to [Wind Force Fields](#) for more information about force fields.

• **Materials**: You can animate material shaders as described in [Animating Nodes](#).

• **Walk Paths**: You can create paths that your figures walk along, as described in [Creating a Walk Path](#).

• **Background**: You can animate the background using the Material room. Please refer to [Materials](#) for more information about the Material room.

• **Movie nodes**: You can play movies on any object using movie nodes in the Material room.

By default, your animation moves over the Document’s background. You can have still or animated backgrounds in your scenes. Please refer to [Using Background Pictures](#) and [Importing Movies](#) for more information about backgrounds in Poser scenes.

### Animation Tools

Poser has five animation tools:

- **Animation controls**: The simple, single channel Animation controls allow you to create quick click-and-drag animations as well as preview your work. Access the Animation controls by clicking the handle at the bottom of your Poser workspace. See [Using the Animation Controls](#) for more information.

  If not displayed, choose **Window > Animation Controls** to show the Animation Controls. They will dock or float depending on how you last used them.

- **Animation Palette**: The Animation palette contains the advanced editing features, with which you can create more complex animations. Among other things, you can edit keyframes, animation layers and individual actors, and create Animation Sets. Access the Animation palette by selecting **Window > Animation Palette**. Please refer to [Using the Animation Palette](#) for more information about the Animation palette.

- **Graph**: Each actor in your scene has a Graph for each of its possible motions, allowing you to exercise minute control over your animations. Access the Graph for any parameter by using the desired parameter dial’s menu as described in [Parameters Palette](#). Please refer to [Using Graphs](#) for more information about the Graph.
Using the Animation Controls

The Animation controls are dockable and floatable. This palette contains the tools most commonly used when creating animations. They allow you to add and edit keyframes and preview your animation. If the Animation controls do not appear on your screen, choose Window > Animation Controls and place them where you find it most convenient (generally the top or bottom of your document window is the common location). The Animation controls appear as follows, and consists of the controls described in the following sections:

**Play Controls**

The Play controls appear on the left side of the Animation controls and allow you to preview your animation using VCR-like controls. From left to right, the Play controls are as follows:

- **First Frame**: Clicking the First Frame button moves to the first frame in your animation.
- **End Frame**: Clicking the End Frame button moves to the last frame in your animation.
- **Stop**: Clicking the Stop button stops animation playback at the current frame.
Using the Animation Controls

- **Play/Pause**: Clicking the Play button plays your animation at normal speed, including background movies and sounds (if any). While your animation is playing, this button becomes the Pause button. Clicking it freezes the animation at the current frame.

- **Step Backward**: Clicking the Step Backward button moves back to the previous frame (i.e., the frame before the current one).

- **Step Forward**: Clicking the Step Forward button moves forward one frame (i.e., the frame after the current one).

- **Loop**: Checking the Loop radio button causes your animation to repeat itself continuously when playing until you click the Stop button.

Animation previews run in the **Document**. Be sure to select the appropriate tracking mode (see **Tracking Mode**).

**Timeline/Frame Indicator**

The center portion of the Animation controls displays the **Timeline**, which represents the total time of your animation in Poser. This timeline contains a pointer (**Scrubber**) representing the location of the current frame relative to the entire animation, which is visible in the **Document**. The **Scrubber** is very commonly used to quickly find specific points within animations. Click and drag the **Scrubber** to quickly navigate your animation.

Just above the **Scrubber** is the **Frame Indicator**, which indicates both the total number of frames in your animation and your current position within that timeline, with the left field indicating position and the right indicating animation length. For example, if the two numbers read 60 and 120, that means that you are viewing the 60th frame of an animation that is 120 frames long.

You can jump to a specific frame by clicking the left number field and entering the frame number you wish to jump to. You can also add or remove frames by clicking the right number field and entering the number of frames you wish in your animation. Entering a larger number lengthens your animation and vice versa. Shortening animations will cut the excess frames from the end. For example, if you reduce an animation from 120 to 90 frames, you will lose the final 30 frames.

**Keyframe Controls**

In most cases, Poser’s automatic animation engine records keyframes as you create animations. Sometimes, however, you’ll want to manually add keyframes, such as when camera animation is disabled. It is important for you to track the status of camera animation, as you could create a series of keyframes without realizing that the animation is off. As mentioned above, if camera animation is disabled, you must manually add keyframes in order to record them. You may also need to fine-tune animations, which may necessitate recording additional keyframes. For
example, you could position the figure’s left foot at Frames 10 and 20, with Poser calculating its position for the tween frames. If you wanted to refine this, you could add a keyframe at Frame 15.

The **Keyframe** controls allow you to quickly and easily add, preview, and remove keyframes within your animation. From left to right, the Keyframe controls are:

- **Previous Keyframe**: The Previous Keyframe button returns to the previous keyframe.
- **Next Keyframe**: The Next Keyframe button advances to the next keyframe.
- **Edit Keyframes**: Clicking the Edit Keyframes button opens the Animation Palette, discussed next.
- **Add Key Frames**: Clicking the Add Key Frames button adds a keyframe at the current frame number. For example, if you have existing keyframes at Frames 15 and 30, you could drag the Scrubber to Frame 22 and insert a keyframe by clicking the Add Key Frames button. You can also insert a keyframe by moving to any frame in your animation and making a change in your scene. This change will automatically be recorded as a new keyframe.
- **Remove Key Frames**: Clicking the Remove Key Frames button removes the currently selected keyframe. For example, if your character’s arm is over his head in Frame 1, down at Frame 15 and out to the side in Frame 30 and you remove the keyframe in Frame 15, the figure’s arm will move out to the side position specified in Frame 30 without dropping to the figure’s side. To delete a keyframe, use the Next Keyframe or Previous Keyframe buttons to locate your desired keyframe, then click the Remove Keyframe button.
- **Skip Frames**: Check this radio button to skip frames during playback. This helps conserve system resources while previewing your animation before you render it.

**Keyframes View**

The Keyframe controls in the **Keyframes View** are almost identical to their counterparts in the **Animation controls**. The main difference is that the keyframe controls in the Keyframes palette feature a button that allows you to open the Graph palette.

- **Show Graph Display**: Clicking the Show Graph Display button opens the Graph, discussed in.
**Recording Keyframes**

Poser records changes made to figures, props, materials, etc. as keyframes. Create keyframes by moving the scrubber to a new point on the timeline and making your desired change(s) to your scene. Recorded keyframes store new body part positions, new prop positions, material settings, etc. for each figure and prop within your scene. You can only record one set of position parameter settings for any given keyframe. For example, if you select a frame and move a figure’s arm up then change your mind and move the arm down again, the downward position is what will be “remembered” and what will affect your animation. To make a figure’s arm wave up and down:

1. Select a starting pose.
2. Move the scrubber to the point in time/frame number you wish to edit.
3. Raise the arm using the Editing tools.
4. Move the scrubber to a later point in time/frame number.
5. Lower the arm, again using the Editing tools.
6. Continue creating keyframes until the motion sequence is complete.

*Camera animation must be enabled for the currently selected camera In order to automatically record keyframes. The Animating option can be found in the Properties palette for the selected camera. If animation is disabled, you can add keyframes manually.*

**Using the Animation Palette**

The Animation palette contains three tabs: the Keyframes tab, the Layers tab, and the Animation Sets tab. Each of these tabs will be described in detail in the following sections. To display the Animation palette, you can either select Window > Animation Palette, or click the Display Animation Palette button in the Animation controls as described above. To close the palette, either select Window > Animation Palette again, or click the small box in the upper left corner.

The upper section of the Animation palette contains several controls that appear on all three tabs. These are as follows:
Common Controls

Several controls and options are common to all of the tabs in the Animation Palette. These options are discussed below.

The Animation Palette.

You can resize the grid in the Animation Palette, making the keyframes wider or narrower, by clicking and dragging the resize button (below the text that reads Play Range as shown in the following figure). Drag left to make the grid narrower, or toward the right to make the grid wider.

Current Layer

The Current Layer pop-up menu appears at the very top of the Animation palette. This menu allows you to select a specific animation layer within the current animation. Please refer to Current Layer for more information about animation layers.
Frame Rate

The frame rate specifies the number of frames played per second. To change the scene frame rate, you can either click the current frame rate and enter your desired number in the text box that appears or click the arrow to the left of the current frame rate and make your selection from the Frame Rate pull-down menu. Choices are 12, 15, 18, 24, 25, 30, 50, and 60 frames per second.

Frame Rate options.

Some common frame rate settings are:

- **NTSC**: 30
- **PAL**: 25
- **Film**: 24

For Poser integration into other apps, the user will need to determine the frame rate to match that of the hosting software. The default frame rate in Poser is 30 fps, but other applications might use 24 fps. Users will need to create a file with the same frame rate. This needs to be handled specially for each app.

You can also set the output frame rate using the Movie Settings window (Rendering Animations). This setting is independent from your scene frame rate, as specified in the Animation palette (see above). Additionally, you can generate a quick preview render by specifying the Every N-th Frame setting in the Movie Settings window. Again, this setting is for output purposes only, and is independent of your scene frame rate.

Time

The Time control displays the amount of time in your animation between the first frame and the currently selected frame. Time is displayed in SMPTE format (Hours:Minutes:Seconds:Frame). You can jump to a specific point in time by entering your desired numbers in the fields. For example, if you jump to 1 minute in an animation using 24 frames per second, you’ll arrive at Frame 1440 (24 frames/second times 60 seconds).
Frame

The Frame Indicator is identical to its counterpart in the Animation controls. You can jump to a specified frame and add or remove frames from your animation as described in Timeline/Frame Indicator.

Play Controls

The Play controls are identical to their counterparts in the Animation controls. See Play Controls for more information.

Play Range

By default, the entire animation plays when previewing animations using the Play controls. You can, however, opt to view only a portion of your animation during preview. This feature is useful if you have a long animation and only want to focus on small portions at a time. The Play Range indicator appears at the bottom of all three tabs on the Animation palette. To adjust the play range, drag the beginning and/or end point to your desired starting and ending frames, respectively.
Animation Palette Options Menu

Clicking the Options arrow at the top right of the Animation Palette opens the Animation palette Options menu, which contains the following options:

- **Display Frames**: Selecting the Display Frames option toggles the Timeline columns to display using animation frames.
- **Display Time Code**: Selecting the Display Time Code option toggles the Timeline columns to display, representing your animation’s running time.
- **Loop Interpolation**: Selecting the Loop Interpolation option toggles loop interpolation on and off.
- **Quaternion Interpolation**: Selecting the Quaternion Interpolation option toggles quaternion interpolation on and off.
- **Display Key Counts**: Shows or hides alpha-numerical indications of the number of keyframes used in each actor.

Keyframes View

The Keyframes view is where you edit the keyframes in your animation. It shows the layout of the keyframes and allows you to set and move between them. You can also play animations directly from this palette. The **Keyframes** appears as follows:
When you first display this tab, it shows any keyframes you previously created using the Animation controls, for the currently selected animation layer. Please refer to for more information about animation layers. If you wish to see the keyframes contained within a different animation layer, select the name of the new layer from the Current Layer pop-up menu. In addition to the controls described above, the Keyframes contains the following elements:

**Keyframe Controls**

In most cases, Poser’s automatic animation engine records keyframes as you create animations. Sometimes, however, you’ll want to manually add keyframes, such as when camera animation is disabled. It is important for you to track the status of camera animation, as you could create a series of keyframes without realizing that the animation is off. As mentioned above, if camera animation is disabled, you must manually add keyframes in order to record them. You may also need to fine-tune animations, which may necessitate recording additional keyframes. For example, you could position the figure’s left foot at Frames 10 and 20, with Poser calculating its position for the tween frames. If you wanted to refine this, you could add a keyframe at Frame 15.

The Keyframe controls allow you to quickly and easily add, preview, and remove keyframes within your animation. From left to right, the Keyframe controls are:

- **Previous Keyframe**: The Previous Keyframe button returns to the previous keyframe.
The Keyframe controls in the are almost identical to their counterparts in the Animation controls. The main difference is that the keyframe controls in the Keyframes palette feature a button that allows you to open the Graph palette.

- **Next Keyframe**: The Next Keyframe button advances to the next keyframe.
- **Edit Keyframes**: Clicking the Edit Keyframes button opens the Animation Palette, discussed next.
- **Add Key Frames**: Clicking the Add Key Frames button adds a keyframe at the current frame number. For example, if you have existing keyframes at Frames 15 and 30, you could drag the Scrubber to Frame 22 and insert a keyframe by clicking the Add Key Frames button. You can also insert a keyframe by moving to any frame in your animation and making a change in your scene. This change will automatically be recorded as a new keyframe.
- **Remove Key Frames**: Clicking the Remove Key Frames button removes the currently selected keyframe. For example, if your character’s arm is over his head in Frame 1, down at Frame 15 and out to the side in Frame 30 and you remove the keyframe in Frame 15, the figure’s arm will move out to the side position specified in Frame 30 without dropping to the figure’s side. To delete a keyframe, use the Next Keyframe or Previous Keyframe buttons to locate your desired keyframe, then click the Remove Keyframe button.
- **Skip Frames**: Check this radio button to skip frames during playback. This helps conserve system resources while previewing your animation before you render it.

The Keyframe controls in the are almost identical to their counterparts in the Animation controls. The main difference is that the keyframe controls in the Keyframes palette feature a button that allows you to open the Graph palette.

- **Show Graph Display**: Clicking the Show Graph Display button opens the Graph, discussed in Using Graphs.

**Additional Controls**

**Interpolation Controls**

The process of filling in the blanks between keyframes (the area known as tween frames) is called interpolation, and the frames between keyframes are called tweens. Interpolation determines how intermediate poses are created.

Poser supports four types of interpolation, which allows you to make subtle changes to your animations. Interpolation settings apply to a range of frames, meaning that you can use different interpolation methods at different intervals in your animation. The Interpolation controls allow you to specify the interpolation method.

From left to right, the buttons are:
• **Spline**: Places tween poses and settings on a curve. Motion begins at one keyframe, accelerates to full velocity, and gradually slows down as it approaches the next keyframe. For example, if the first keyframe has an arm by a figure's side and the second one has it raised, the arm will begin moving slowly, accelerate to a constant velocity, and slow as it reaches the second keyframe. This is not to say that the movement will be fast; actual speed of motion depends on the amount of change between keyframes and the number of tween frames. In our above example, having the second keyframe 5 frames from the first would make a very rapid motion, while having 100 frames would make a very slow motion. The key thing to remember is that this type of animation resembles a smooth curve and is normally the most realistic.

\[ \text{Spline Interpolation.} \]

• **Linear**: Takes the two keyframes and divides the motion between them equally with no acceleration or deceleration of the moving items. In the above example, the arm would move at a constant velocity from keyframe to keyframe. If you created a third keyframe with the arm back down, the change direction at the second keyframe would be abrupt.

\[ \text{Linear Interpolation.} \]

• **Constant**: This has no intermediate poses. If you set a series of poses with different keyframes, the first pose will be maintained until the second keyframe, at which point it will instantly change to the second pose, which will be maintained until the third keyframe, and so on.

\[ \text{Constant Interpolation.} \]

• **Break Spline**: Stops interpolation at the selected point so you can begin a new interpolation style. This is useful for blending different interpolation styles. For example, a bouncing ball moves in a smooth arc until it hits the floor, at which point it undergoes an abrupt change in direction and speed. This is one scenario where changing interpolation styles can aid your animating work.

\[ \text{Breaking interpolation.} \]
Skip Frames

Clicking the **Skip Frames** radio button enabling this option drops frames when previewing your animation, speeding up playback. Click the button again to toggle its functionality off.

Loop

Clicking the **Loop** radio button causes your animation to repeat itself continuously when playing until you click the Stop button. Click the button again to toggle its functionality off.

This Element/All Elements

This option selects whether changes made using the **Keyframes** (interpolation type, keyframe changes, etc.) apply to the entire scene or just to the selected element. Click the This Element or All Elements radio button, as appropriate, to make your selection.

Elements List/Timeline

The **Elements List** displays a list of all elements in your scene. The **Timeline Area** displays your animation frames and all of the keyframes stored for each body part/prop/material/etc. Keyframes appear in red, with tween (interpolated) frames appearing in different colors according to their interpolation type (see **Selecting Interpolation Types**). You can expand and collapse element listings by clicking the triangles next to elements in the list. Each element can be further expanded to display its properties and parameters that can be animated. For example, you can view the Scale and Transition elements for a figure’s forearm. The following image displays a portion of the **Elements List** for a scene.

To select an element, click it in the Element List. This selects the desired element in the same manner as clicking it in the **Document**, using the **Current Actor** menu or selecting it using any of the other available selection methods. Poser highlights the currently selected element in the Elements List as well as that element’s row in the Timeline. Use the vertical scroll bar on the
right of the Elements List and expand and collapse branches to view all of the elements in your scene. Collapsing branches saves space in the display.

When you collapse an entire figure in the Elements List, the keyframes displayed will only be those pertaining to that figure’s location in the Poser workspace. You’ll need to expand the Elements List to show posing/parameter changes.

Double-clicking an element in the list, or selecting an element and clicking the **Show Graph** button, opens the **Graph** for the selected item. Please see .

**Working with Keyframes**

**Editing Keyframes on the Timeline**

You can use the **Timeline** to select, add, edit, or delete keyframes. The **Timeline** appears as a grid that displays keyframes for each element in your scene. Columns indicate time, with each column corresponding to a single animation frame or point in time (See **Elements List/Timeline**). The **Ruler** at the top of this area indicates whether the columns indicate frames or points in time. Each row corresponds to an element in your scene. As described above, the **Timeline** presents information using color codes. Use the horizontal and/or vertical scrollbars to navigate the **Timeline** if necessary.

**Selecting Keyframes**

By default, Poser selects the first frame in your animation (Frame 1) when you open the **Animation** palette. You can select any frame by clicking in or above its column. You can also enter a number in the **Frame** field. When you select a keyframe, Poser displays the current element’s row and time column, creating an intersection.

Selecting a different keyframe moves the intersection to the newly selected point. To select a keyframe, click any one of the light green squares on the Timeline grid.

![Selecting Keyframes](image)
Adding & Removing Keyframes

Adding keyframes stores a specific pose and/or saves a Poser-created interpolation (tween) frame. You can add keyframes for the entire scene or the selected element by checking either the This Element or All Elements radio button as described in This Element/All Elements. When This Element is selected, keyframes are only recorded for your currently selected element. When All Elements is selected, keyframes are recorded for every element in your scene. To add a keyframe:

1. Select This Element or All Elements, as appropriate.
2. Select the frame or point in time where you wish to add the keyframe.
3. Click the Add Keyframes button.

Removing Individual Keyframes

Removing keyframes can modify how your animation appears. You can clear a keyframe for a specific element or your entire scene by selecting This Element or All Elements, as appropriate. Removing a keyframe does not delete the frame, but removes the saved information. To remove a keyframe:

1. Select This Element or All Elements, as appropriate.
2. Select the frame or point in time where you wish to remove the keyframe.
3. Click the Delete Keyframes button.

Removing Multiple Keyframes

To remove an entire range of keyframes, click and drag over the keyframes you wish to delete in the Timeline and press [DEL]. To remove multiple specific keyframes, press and hold Shift while selecting individual keyframes, then press [DEL].

Moving Keyframes

While creating animations, you may decide to have one or more keyframes occur earlier or later than your present settings. You may also want to apply the settings in some keyframes to others. Poser allows you to move both individual and multiple keyframes. To do this, click the keyframe you wish to move and drag the colored cell horizontally to its new location. To move multiple keyframes, select them and drag your selection to its new location on the timeline.
Copying Keyframes

You can copy keyframes, figure parts, and parameters appearing in the Element List. By doing this, you can (for example) have several Poser figures marching in perfect step. Although Poser does not limit how you copy and paste keyframes, you should avoid mixing data (such as copying Scale parameter settings to a Rotation parameter). You can also obtain unexpected results by copying movements from one side of a body to another. If you do copy parameters from side to side, you will need to make the affected parameters negative on the side you copied to.

Choose Edit > Copy or press [COMMAND]/[CTRL]+[C] to copy frames to your clipboard. When you reach your destination, select Edit > Paste or press [COMMAND]/[CTRL]+[V].

Alternatively, you can click the desired keyframe then press and hold Opt/ALT while dragging the keyframe to its new location. You can move multiple keyframes by selecting them and Opt/ALT+dragging your selection to its new location.

Retiming Keyframes

Selecting Animation > Retime Animation opens the Retime Animation dialog, which allows you to adjust keyframe timing in your animation.

By specifying source and destination frame ranges, you can change the amount of time a motion or motions take to occur. This command does not destroy any keyframes, meaning that you can use it to repeat motions by copying them from one time to another. Selecting a motion in one area and selecting a non-overlapping destination re-maps the motion to another time without deleting the original motion.

To retime keyframes:

1. Open the Retime Animation dialog box.
2. You will be given a choice to retime keys for the currently selected figure or prop, or everything.
3. Enter the start and end frames for the section of animation you want to retime in the Source Frames fields.
4. Enter the range of frames to retime the animation to in the **Destination Frames** fields. If the destination range is longer than the source range, the animation is expanded or slows down, and vice versa.

5. Click **OK** when finished.

---

**Resampling Key Frames**

Selecting **Animation > Resample Key Frames** opens the **Resample Keys** window, which allows you to increase or decrease the number of keyframes in your animation.

This window has the following options:

- **Modify**: Check the appropriate radio button to sample keyframes for the Current Element (prop, body part, etc.), Current Figure (entire figure), or Everything (entire scene).

- **Resample Method**: You have two options for resampling keyframes:
  - **Analyze Curvature**: Causes Poser to examine the amount of curvature (change over time) in your animation and automatically assign new keyframes.
  - **Make key frame every X frames**: Check this radio button and enter a value in the Frames field to create a keyframe every X frames, where X is the value you entered in the field.

- **Frame Range**: If you want to resample key frames in a specific portion of your animation, enter the start frame and end frame in the Frame Range fields.

---

**Using Graphs**

The Graph Work Area consists of two axes and a graph. The horizontal axis represents time in frame numbers. The vertical axis’ values change depending on the selected attribute. If you choose a position attribute such as xTrans, the values represent positions in 3D space (Cartesian
coordinates). If you select an editing property such as Bend, the axis represents degrees. A morph parameter’s values are measured in percentages.

The Graph itself shows the actual change in the attribute over the course of your animation. Its shape indicates the type of interpolation being used. You can also use the Graph palette for synchronizing sound to motion, as described in.

You will be given the option to save graph palettes when you save content to the Library, or when you save projects.

When you double-click a keyframe, the Graph palette for that keyframe appears. An element’s Graph palette allows you to perform precise edits on keyframes and modify the interpolation methods used in your animation. The Graph palette contains the following functions:

- **Current Actor**: Displays the actor that was controlled by the keyframe that you double-clicked to open the graph. You can expand the menu to select any other figure or actor in your scene.

- **Animatable Properties**: The Animation Properties pull-down menu allows you to select one of the animatable properties for the currently selected element.

- **Selection Sync**: Graphs are no longer locked to a single actor. When Selection Sync is enabled, the graph palette will change to the actor/parameter that you select in the scene or the animation palette. When disabled, the graph palette will not change to another parameter when you select one.

  When Selection Sync is enabled, the actor/parameter popups in the graph palette will be disabled.

- **Interpolation Methods**: See Selecting Interpolation Types.

- **Keyframe Controls**: See Keyframe Controls.

- **Work Area**: See Using the Graph With the Animation Palette.
Selecting Interpolation Types

The Graph contains controls allowing you to specify interpolation methods, which can be specified on both the element and frame range levels. The Interpolation controls appear as follows:

Interpolation Controls.

To choose an interpolation method, select the elements and frame range to modify, then click your desired Interpolation button. The Animation palette uses color codes to depict varying interpolation methods.

- **Spline**: Green

  Splines can sometimes go beyond and exceed the maximum keyframed values depending on the slope created by tightly-spaced keyframes. Adding additional keyframes can constrain the slope into more pleasing levels.

- **Linear**: Red

- **Constant**: Grayed out

- **Break Spline**: A hash mark appears where Break Spline has been applied.

Editing the Graph

You can edit the graph to achieve varying degrees of interpolation. For example, to decrease the amount of Spline interpolation, straighten the curve. You can set the curve’s shape using preset interpolation methods or by dragging the curve’s points to obtain your desired shape. You can also apply different interpolation methods to different parts of the graph using the Break Spline function.

Be aware that changing the graph’s shape affects the selected element’s motion. To edit the graph, use the Animation Properties pull-down menu or select Graph from the Parameters palette (see Using Graphs) to select the attribute to be edited. Next, drag any point on the graph in the direction you want to move the curve. The curve will reshape itself based on your chosen interpolation method(s). Use the scrollbar to view parts of the graph that are not currently being displayed.
To change the type of interpolation applied to a portion of the graph, click and drag to select the frames you wish to change. Your selected area will become highlighted. Next, click one of the Interpolation buttons at the bottom of the palette. This can add keyframes to your animation.

Vertical lines on the graph denote keyframes. You can move these points to change when keyframes occur, and can also add keyframes by clicking the point on the line where you want to insert the keyframe.

The **Current Frame** indicator is a visual reminder of the frame you’re currently working on. To select a keyframe, click the **Next Keyframe** or **Previous Keyframe** button, as appropriate, click a keyframe indicator, or drag the **Current Frame** indicator to the frame you wish to edit.

Click and drag a rectangle to select a range of frames.

You can also perform the following functions using the Graph:

- Use the shortcut **CTRL/CMD+Shift+G** to show or hide graph palettes.
- Use the shortcut **ALT+CTRL/CMD+Shift+G** to create a new graph palette.
- To move keyframes, select the keyframe(s) you want to move, and drag forward or backward in the timeline to a new location.
- To add a keyframe, drag the Current Frame indicator to your desired location and click the **Add Key Frames** button.
- To delete a keyframe, move the Current Frame indicator to the desired keyframe and click the **Delete Key Frames** button.
- To cut, copy, and paste, use the editing hotkeys (\([COMMAND]/[CTRL]+[X]\), \([COMMAND]/[CTRL]+[C]\), and \([COMMAND]/[CTRL]+[V]\), respectively) or choose the appropriate command from the Edit menu.
- To close the Graph palette, click the small box in the upper left corner.
- Use the Graph range reset button in the lower-left corner of the graph palette to reset the graph bounds to fit the current animation.
Using the Graph With the Animation Palette

If you open the Animation palette, you can access the Graph palette for the currently selected scene element by clicking the Display Graph Palette button, or by double-clicking a keyframe in the Animation palette. With both palettes open, you have the following options:

- Double-click any element in the Animation palette’s Element list to switch the current Graph palette to the selected element.

    The element list will be disabled when the Selection Sync option is checked in the graph palette.

- Double-click any element in the Animation palette’s Element list to open a new Graph palette for the selected element. You can open as many Graph palettes as you like at one time, which can greatly speed up your animation work. You can even open more than one Graph palette for each element, allowing you to (for example) adjust the Right Forearm’s Twist and Bend at once to achieve smooth realistic movement.

    When you have more than one Graph palette open at once, changing elements by double-clicking them will update all Graph palettes that have those elements selected, or that have the Selection Sync option enabled. All other Graph palettes will retain their current settings. If you need to change more than one graph palette, close out all unneeded palettes, then re-open them by selecting your currently needed elements.

Layers Tab

Animation layers, also known as non-linear animation, provide you with the ability to separate different parts of an animation into independent pieces, which can be individually edited, moved, or even hidden, with respect to the entire animation. At render time, the various layers are composited together into a single animation, according to your specifications. The Layers tab on
the **Animation** palette contains the controls that allow you to create, configure, move and delete animation layers.

![Layers tab in the Animation Palette.](image)

If you switch from the **Layers** tab to the **Keyframes**, you will see any keyframes that exist in the currently selected animation layer. If you wish to see keyframes from another layer, use the Current Layer pop-up menu at the top of the Animation palette to select any existing layers, without having to return to the **Layers** tab.

**Base Layer**

When you first begin to create an animation, only one layer will exist; this is known as the Base layer. The Base layer is always present, and if you wish, you can create your entire animation just in this single layer. The frame count of the Base layer is equivalent to the length of the entire animation. The Start frame of the Base layer is always Frame 1, and the End frame is the last frame in the entire animation. Thus, changing the End frame of the Base layer changes the length of your animation, which will affect any other layers whose End frames coincide with the End frame of the Base layer.

You cannot change any properties of a Base Layer other than the End frame.
Creating, Deleting & Previewing Animation Layers

In addition to the shared controls common to all three tabs on the Animation palette (see Using the Animation Palette for a description of these controls), the upper section of the Layers tab also contains three buttons:

- **New**: Click the New button to create a new animation layer.
- **Delete**: Click the Delete button to delete the currently selected animation layer. This feature is disabled when the Base layer is selected.
- **Collapse Layers**: Click the Collapse Layers button to combine all layers with the base layer.
- **Current Layer Only**: Click the Current Layer Only radio button to temporarily exclude all other animation layers from the playback. Doing so allows you to isolate the specific animation contained within the current layer, which can be helpful in scenes with multiple layers.

![Current Layer Only option.](image)

Animation Layer Controls

The lower portion of the Layers tab contains additional controls that allow you to configure a selected layer, and the Timeline Area, which displays the various layers in editable segments, allowing you to see the hierarchy of the layers as well as where each layer is placed in the timeline of the entire animation. The Layer controls are as follows:

![Layer Controls.](image)

- **Layer Name**: Once you have created a new layer, you can change its default name to anything you want. Simply select the layer in the Timeline display, and type the new name in the text field.
• **Include in Playback**: Check or uncheck this option to include or exclude the selected clip when you preview your animation.

• **Start/End Frame**: The Start frame and End frame controls allow you to specify the Start and End frames for the selected layer. While the Base layer always equals the length of the entire animation, other layers can be of any length up to the entire animation length, and can start and end at any point within the duration of the animation. You can change the Start and End frames by clicking on the frame number and typing a new value into the field. Alternately, you can click on the layer segment in the Timeline Area and drag it to a new position; the segment length will remain constant, but the Start and End frames will change. Clicking and dragging on either the beginning or the end of the layer segment will change the Start or End frame respectively, without moving the position of the segment within the animation timeline. The length of the layer segment will adjust to accommodate the new Start or End frame number.

• **Blend In/Out Frames**: The Blend In/Out feature allows you to gradually blend an animation layer into, or out of, the full animation. This feature could be used, for example, to create the effect of wind gradually picking up or fading away. The Blend in frames and Blend out frames settings allow you to specify over how many frames the linear blend will occur. The Blend In/Out frame count is indicated on the layer segment display as an additional shaded segment attached to either the beginning or end of the layer segment.

> *If the animation contained within a specific layer is a gradual movement, then the Blend feature may not be effective, particularly if the Blend In/Out frame counts are set too low.*

• **Composite Method**: While compositing the full animation, Poser begins with the Base layer, and works upwards through the layer hierarchy incorporating each layer one by one. The Composite method setting allows you to specify the manner in which the individual layers will be composited. The two options for compositing animation layers are Replace and Add.

  • **Replace**: This is the default composite method for animation layers. Selecting Replace means that any action on a given parameter for a specific actor will replace any actions on the same parameter, on all layers below the selected layer. For example, let’s suppose that Layer1 is below Layer2 in the animation layer hierarchy. Let’s also suppose that in Layer1 James’ chest is twisted twenty degrees to the left, but in Layer2 his chest is twisted only ten degrees to the left. With the Replace option, the Layer2 setting will replace the setting from Layer1.

  • **Add**: Selecting Add means that the values for all rotation and translation parameters will be added to one another as Poser composites each layer into the animation. Using the above example, the twenty degrees of Twist from Layer1 would be added to the ten degrees from Layer2, resulting in a greater effect of thirty degrees of Twist. However, if Layer1 had included a twist of negative twenty degrees, while Layer2 had included a twist of positive ten degrees, then the Add option would result in a final twist effect of negative ten degrees.

• **Move Up/Down**: If you select the Replace composite method, the specific order of the layers within the layer hierarchy will be very important, as parameter settings in higher layers replace those in lower layers (see above for additional explanation). You can change the order of layers within the hierarchy by clicking the Move up or Move down button to
move the selected layer either up or down one level. Clicking the button a second time will repeat the action.

Animation Sets Tab

Animation sets allow you to store a series of animation clips that are frequently used in combination. For example, you could animate a figure raising its arm above its head and save the limb’s movements to a named animation set.

Creating & Editing Animation Sets

To work with animation sets, open the Animation palette by selecting Window > Animation Palette. Click the Animation Sets tab to open the Animation Sets palette, as shown.

The Frame Rate, Time control, Frame Indicator, Play controls, and Skip Frames button all function as described in previous sections of this chapter.

Creating an Animation Set.

- To create a new animation set, click the New button and name your new set. Doing so will populate the Animation Sets tab with additional editing controls.

- To delete an animation set, select the set from the pop-up menu to the right of the Attributes button, and click the Delete button.

- To add selected items and/or frames to your animation set, click and drag to make your selection and click the + button. You can select any combination of items/frames. The start and end frames will be made identical for all items in the animation set.

- To remove selected item(s) and/or frame(s), make your selection and click the – button.

Several buttons allow you to add, remove, and add items and frames to an animation set.
To save an animation set, you will need to save the pose to the Library. To save an animation set pose, first open the Pose library. Click the **Save to Library** button at the bottom of the Library palette to display the **New Set** dialog. Next, click the **Select Subset** button at the bottom of the dialog to open the **Select Objects** dialog. Click the **Select from Animation Set** button to display a list of the available animation sets. Choose one of the sets, and click **OK** to save the animation set to the library. Repeat for additional sets you want to save.

### Applying Animation Sets to Figures

You can also apply animation sets to figures. For example, if you create an animation set of an arm being raised, applying that set to your current figure will cause its arm to raise in the exact way specified by the animation set. This feature can help you save time by allowing you to reuse complex animations over and over.

### Using the Walk Designer

Of the wide range of human motions, walking is among the hardest to simulate with any degree of accuracy. Walking looks simple: just place one foot in front of the other. In reality, however, it is an incredibly complex motion involving a variety of muscles in the legs, torso, arms—practically the entire body. Thus, creating an accurate walk simulation entails a great deal of precision posing. Poser’s **Walk Designer** allows you to bypass most of this and create a realistic walk using just a few simple steps.
Creating the Walk

To open the Walk Designer, select the figure you’d like to animate in the Poser scene, then choose the Window > Walk Designer menu command.

Unless you want your figure to walk in place (without a walk path), create a walk as follows:

1. Create a walk path (your figure will follow this path when walking)
2. Create a walk using the Walk Designer.

The Walk Designer has two sections. The upper set of controls creates the walk’s larger motions, while the lower set lets you set up the walk’s secondary motions. To preview a walk, click the Walk button at any time while using the Walk Designer. The preview will loop indefinitely and the button will change to Stop.

Views

The Walk Designer includes a real-time preview of the walk being created. As you change the parameters, the walk changes to reflect your updates. You can specify the angle from which to preview your walk by checking the appropriate radio button underneath the Preview tab:
Figure Types

This step is optional, however it can address potential issues such as irregular or jerky motions in generated walks.

Click the figure type button and the bottom of the Walk Designer Palette and choose the figure that most closely matches the figure you want to create a walking animation for.

Blend & Tweak Styles

Once you’ve loaded your figure type, you can begin designing your walk. By default, the sliders are all in the middle of their ranges. This combination applies a workable default walk. Dragging a slide to the right increases its value and effect, and vice versa. To create a walk:

1. Drag the Blend sliders to create the large motions. Use the preview to view all of the available settings. Try using combinations of several settings, and remember that small changes can produce dramatic results.

2. Adjust the Tweak sliders to fine-tune the walk.

3. When your walk looks the way you want it to, click the Done button to open the Apply Walk dialog (see below).

Clicking the Defaults button restores all sliders to their default positions.
Loading & Saving Walks

You can load and save walk files using the **Walk Designer**. This is not the same as saving animated poses to the **Library** palette.

- To save a walk, create it, then click the **Save** button to open a standard dialog box allowing you to specify the name and location for the saved walk. Select your desired path, enter a name for the saved walk, and click **OK**.
- To load a walk, click the **Load** button to open a standard **Open** dialog, allowing you to specify a path and filename for the walk file to load.

*For greatest realism, load walks created using the same figure type.*

Creating a Walk Path

Creating a walking figure is a two-step process. The first step entails creating a walk path for your selected figure that defines where s/he is going to walk. The figure can walk in place or along a path.

Walk paths are designed to work with the **Walk Designer**. While the **Walk Designer** specifies how your figure walks, a walk path specifies where. The path is a curve drawn in the **Document** that sets the figure’s course as it moves about the Poser workspace. Create the path, design the walk, and the figure walks along the path from start to end, stopping at the end.

To create a walk path, Select **Figure > Create Walk Path**. A default path appears in the Poser workspace. We recommend shifting to the Top camera and zooming out to get the best view of your scene and walk path, but you can work using any camera you like. The following image shows a default walk path.

*Default walk path.*
Shaping Curves

The curve’s position is defined using control points. Click and drag control points to shape your path any way you like.

*Drag a control point to reshape the curve.*

You can position the beginning and end of the walk path by dragging the end control points. You can also re-position the entire walk path by selecting the ring that appears when your cursor is near the walk path, which functions like the Figure Circle discussed in Selecting Body Parts.

Adding and Removing Control Points

To add control points, simply click anywhere along the line. Your new control points appear. Adding control points can add detail and/or lengthen your walk path.

*You can add or remove points on the walk path.*

To delete control points, press and hold **Opt/ALT** while clicking the point you wish to remove.
Once you have completed your walk path, use the **Walk Designer** to design a walk for your figure.

![A reshaped walk path.](image)

*Because of the nature of the spline used for walk paths, it is impossible to create a hard right-angle turn. These and other abrupt direction changes can result in unnatural-looking walks.*

*Once you have created a walk using the Walk Designer, you can delete the walk path. The figure will still behave as though the walk path was present.*

**Applying Walks**

Once you've created your walk, you need to apply it to the figure’s walk path. The **Apply Walk** dialog allows you to specify various options for applying your newly created walk. If you want your figure to walk in place, you can use this dialog without having a walk path.

You have the following options when applying walks:
The Apply Walk dialog.

- **Figure**: If your scene has more than one figure in it, the Figure pull-down menu allows you to select the figure to apply the walk to.

- **Walk in Place/Follow Path**: Clicking the Walk in Place radio button causes the selected figure to walk in place without going anywhere. You can use this option to create a walk without a walk path. Alternately, if you wish your figure to follow a walk path, click the Follow Path radio button.

- **Path**: If your scene has more than one walk path, you can use the Path pull-down menu to specify the walk path to use.

- **Align Head to**: Checking the Align Head to box lets you control how the figure’s head acts as it moves along the walk path. One Step Ahead keeps the head aligned with the body and produces the most head movements. End of Path keeps the figure’s head looking at the end of the walk path no matter where it leads. Next Sharp Turn aligns the head to the turns in the walk path, the head only moving when the path curves.

- **Always Complete Last Step**: Checking the Always complete last step box forces the walk animation to complete within the allotted time. This is useful if the walk ends in mid-stride at the end.

- **Transition From/To Pose at Start/End Frames**: The Transition from pose at start and Transition from pose at end options allow your figure to smoothly transition into and out of the walk at the beginning and end of the walk cycle, respectively. When enabled, Poser interpolates between the figure’s pose at the start of the walk and the settings you specified in the Walk Designer, and vice versa at the end of the cycle. For example, you can use this feature to quickly set up a runner by posing the figure in the crouched starting position, designing a run, and specifying a realistic transition time. When you play your animation, the runner will come off the starting blocks and begin the run. Checking one or both boxes enables the specified option(s). Once enabled, enter the number of frames to be used for the transition. Longer time periods (more frames) allow more realistic movements and vice versa.

- **Start Frame**: Enter the frame in your animation where the walk will begin in the Start Frame field.
Sound

Poser allows you to import sounds, which play when your animation plays. This is a great way for you to add soundtracks, speech, etc. to your animations. To import a sound clip, select File > Import > Sound and use the standard Open dialog that appears to locate your desired sound file. If you wish to import a speech sound clip for use with the Talk Designer, select File > Import > Lip Sync Audio (see below for information on the Talk Designer). Imported sounds attach to your animations at the first frame and play whenever the animation is played. Also, you can only import one sound file. If your animation calls for more than one sound, edit your desired sounds together in an audio editing application and create a new sound file for importing into Poser.

Importing sounds files will add keyframes based on the current frame rate selected. For example a two second long sound file will expand the default animation to 60 frames if a frame rate of 30 frames per second has been selected for the animation.

Editing Sound

Sound duration appears in the Sound Range bar at the bottom of the Animation Palette. You can clip imported sounds by shortening the sound bar. However, if sound playback begins at any frame other than 1, the beginning of the sound will be clipped.
The sound range is displayed at the bottom of the Animation Palette.

To specify start and end frames for the sound, drag arrows on either side of the sound bar.

**Syncing Sound & Motion**

The *Graph* palette displays a graphic representation of the sound file called a waveform, which lets you see where changes in sound occur. You can use this information to position keyframes in your animation. Simulate speech by matching peaks in the waveform with changes in mouth position, as shown above. To display waveforms in the *Graph* palette, open it as described in *Using Graphs* and click the *Toggle Sound Display* button to toggle waveform display on and off.

* A sound appears as a waveform in the *Graph* palette.

**Using the Talk Designer**

Poser’s *Talk Designer* automates the task of animating facial features for speech. The *Talk Designer* synchronizes morph targets, Emotional Tweak controls, and powerful eye and head motion modelling algorithms with your sound file, making it much easier to animate realistic facial expressions for speech.

The Talk Designer is configured using the Talk Designer palette. Choose *Window > Talk Designer* to open the palette.

Select *File > Import > Lip Sync Audio* to import a sound file, as described above. At the end of the import process, the Talk Designer palette will automatically open with your imported audio file selected.
Select **Window > Talk Designer** to open the Talk Designer palette at any time.

**Configuring the Talk Designer**

The **Talk Designer** palette settings are described in the following sections. When you have configured the **Talk Designer** to your satisfaction, click the **Apply** button at the bottom of the palette to generate a lip-sync animation based upon the settings you specified.

**Input Files**

- **Sound file**: Clicking the “...” button next to the Sound file setting allows you to browse to the location of the sound file you wish to use for your lip-sync animation. Poser supports WAV file, as well as AIFF files on the Macintosh.
Sounds used in the Talk Designer must be uncompressed, single-channel (mono) audio files in WAV (Windows) or AIFF (Mac) format. 22050 and 44100 kHz files are supported.

- **Supplemental text**: For better accuracy, we recommend that you include the text of the spoken words in the **Supplemental text** field. Text entries in this field will be required if you need to specify an alternative language. You can click the “…” button to browse to a text document, or click on the “+” button to open a text box and enter the text directly.

- **Language**: If you add supplemental text, use the **Language** pull-down menu to specify the language used. In order to select another option from the Language menu, you must have text entered in the Supplemental Text field. After entering your text, you will have the option to select English, French, German, or Japanese.

- **Viseme map file**: A viseme map file provides information about which phonemes (speech sounds) are matched to which specific visemes, or facial expressions. These viseme map files are directly linked to the morph target setup of the individual figure. If you are working with any of the newer figures included with Poser, you can simply use the default viseme map file for the figure. If you wish to use a figure from a previous version of Poser, please make sure that a viseme map is provided in the associated pop-up menu. If you use a figure from a third-party source that was created with a different morph target setup, you will need to provide the viseme map file that accompanies the figure. We recommend that you place the viseme map file into the `\Runtime\LipSync\` folder that accompanies your Poser installation. Doing so will add the file to the pop-up menu in the Talk Designer palette. Alternately, you can click the “…” button to browse to the location of the viseme map file, if you wish to keep it in another location.

If you are unsure whether or not your custom figure was created following the morph target standards for included Poser figures, you can try your animation using the default viseme map file. Bondware, Inc. cannot support third-party figures. If you are dissatisfied with the results, you will need to contact the content creator.

**Configuration**

- **Figure**: Specify which figure in the scene you wish to use for the lip-sync animation, by selecting the name of the figure from the pop-up menu.

- **Start frame**: Specify the **Start Frame** number for the actual lip-sync animation. By default, the Start Frame setting is set to the Start Frame of the entire scene animation (frame 1).

- **End frame**: Specify the **End Frame** number for the actual lip-sync animation. By default, the End Frame setting is set to the End Frame of the entire scene animation (generally frame 30, unless you have specified a different scene End Frame). Once you load a sound file, the End Frame setting will default to match the length of the sound file.
If the End Frame number specified in the Talk Designer is greater than the End Frame for the entire scene animation (as specified on the Base Layer), then additional frames will be appended to the scene to accommodate the difference.

**Create Keyframes in:** The Create Keyframes in setting allows you to select either a new or existing animation layer for your lip-sync animation keyframes. Animation layers allow you to organize your animations, save and reuse specific aspects of a larger animation.

We recommend that you create the keyframes in a new animation layer; click the "New animation layer" radio button to select this option. You will be asked to name the new layer. Alternately, you can choose to use an existing animation layer by clicking the "Layer" radio button, and selecting the name of the layer from the pop-up menu. If you do not wish to use animation layers, you can simply write all keyframes to the Base Layer. For more information about animation layers, please see [Layers Tab](#).

**Enunciation:** The Enunciation slider allows you to configure the degree to which the Talk Designer will adjust a figure’s visemes, or facial morphs, in response to changes in the audio file’s perceived energy. Poser automatically adjusts visemes to correlate to the energy of the selected sound file. However, you can use the Enunciation slider to raise or lower the degree of reaction, to counteract or supplement the automatic viseme adjustment. Move the slider to the right to increase enunciation, or to the left to decrease.

**Head Motions**

**Eye Blink Rate:** The Talk Designer can add intermittent eye blinks that have been modeled on studies of actual human blink rates, in order to animate blinks realistically in relation to the animation of speech. The Eye Blink Rate slider allows you to specify an average blink rate, measured in blinks per minute (BPM). To change the average blink rate, simply click and drag the slider, or click on the numerical value in the text box and enter a number directly. The default value is 12.5 BPM. A setting of zero (0 BPM) disables the automatic blink feature, which means that with this setting you must animate all eye blinks manually.

**Create eye motion:** When people speak, their eyes generally look in different directions with relation to their subject matter and surroundings. Adding eye movements can result in a more realistic animation. Check the Create eye motion checkbox to have Poser add eye movements to your lip-sync animation.

**Create head motion:** People naturally move their heads during speech, which means that adding head motion to your animation can yield more realistic results. Check the Create head motion checkbox to have Poser add head motion to your lip-sync animation for you.
Emotional Tweaks

The Talk Designer includes six Emotional Tweaks, which are morph targets that can be used in conjunction with speech. These morph targets are based upon facial expressions associated with the following emotions:

- Anger
- Disgust
- Fear
- Joy
- Sadness
- Surprise

Each of these Emotional Tweaks is adjusted by a slider, which ranges between -100% and 100%. The values within this range represent the degree to which each particular emotion will manifest in the facial expressions of the figure during the lip-sync animation. Feel free to mix and match the Emotional Tweaks slider values to suit your specific animation needs. To adjust the values, you can either move the sliders to the right or left, or you can click on the numerical value to the right of the slider and enter a number directly.

Advanced Animation Techniques

This section is where we stop talking about technical details for a moment and focus on a few artistic considerations. Editing animations is pretty easy work in and of itself. Getting your animation to look just the way you want it and adding realism are the hard parts. A jerky movement can turn smooth and flowing or an unrealistic motion can become realistic if you keep a few simple techniques in mind.

Keyframes and Timing

How should you space keyframes? Begin by considering time and frame rate. Space keyframes so that the motion looks natural at the selected frame rate. For example, if you have a motion that requires 4/5 of a second, you’ll need 24 frames at 30fps, 20 frames at 24fps, 9 frames at 12fps, etc. The basic formula is frame rate (in frames per second) times motion duration in seconds = number of frames required.
Creating Realistic Motion

Now that you've gotten the number of frames required for a motion down, what’s next? Break down the motion into component parts. For example, look at a baseball player swinging a bat. At first glance, it may look like the arms are moving. Upon closer inspection, however, you see that the entire body is in motion. Some movements, like the arms and legs, are more pronounced than others. So, begin with the large movements then go back and work on the finer adjustments. Using our baseball player example, you could start with two keyframes: One at the beginning of the swing, the other at the end.

Previewing this animation with only two keyframes would probably give you a pretty good result, however the details are where your animations will shine.

Now that the major motions are roughed in, let's add some detail. For example, add the hip swings, shoulder tilts, etc. The subtle details may not be overly noticeable, but your viewers will pick up their presence or absence though they may not be able to tell you what's wrong with your animation if these elements are not present. Poser’s Animation palette and graph (described in the previous sections) are ideal for this fine-tuning. Smooth transitions don’t occur in all movements. For example, when a bat strikes a fast-moving baseball, there is an immediate change in direction. This is an animation where linear interpolation might be better suited. You can adjust splines in the Graph palette, or change interpolation types to create motions. You can adjust splines or change interpolation types in the Graph palette.

By working this way, you can create any kind of action and can make that animation look as realistic as possible.

Long/Complex Animations

If you are trying to make a long movie or one that incorporates changing cameras, you should create small clips and edit them together in a video editing application such as Adobe Premiere.

Bake Transforms

The Animation > Bake Transforms commands take positions and rotations that are automatically animated and converts the results to animation channel data. Generally, any animation that results in transforming an actor or which drives a morph target should be baked by these commands. For example, if you use the Object > Point At command to point one object to another object that moves around the scene, the Bake Transforms command will generate a keyframe on every frame to reproduce that automatic Point At motion.
As you animate the objects in the scene with Point Ats or other automatic movement capabilities, the **Bake Transforms** commands capture these movements to channel data and generate keyframes for each frame.

Before the command is applied, Poser will display a dialog that informs you that **Bake Transforms** will turn off conforming of figures and change keyframes, and that the action is not undo-able. Choose **Cancel** to exit without applying the command, or **OK** to complete the process.

### Saving Animations to the Library

You can save animations to the **Library** palette as still (single-frame) or animated (multiple frame) poses for use with other figures/props. See **Adding Items to the Library** for more information on saving still or animated poses to the Library.

---

The Bake Transforms commands do not extend to objects that are manipulated at the vertex level (such as soft body dynamics, dynamic hair, or dynamic cloth).

While some export functions automatically perform similar keyframe creation, the **Bake Transforms** commands are helpful when you want to ensure that the transformations are in a specific state before you export the animation.
Using Bullet Physics

The Physics Simulation palette allows you to incorporate Bullet physics into your Poser animations. To open the palette, choose Window > Bullet Physics Controls.

After you create a simulation, the objects in your simulation can be assigned one of three object types, which are detailed further in the sections that follow:

Creating a Simulation

The Physics Simulation palette allows you to create one or more physics simulations in your Poser project. Each simulation defines the following:

- The objects that will be included in that physics simulation.
- The frames in your animation project in which the physics calculations will be applied to the defined objects
- Settings that will be applied to all of the objects included in that simulation.

To create a new simulation, follow these steps:

1. From the Physics Simulation palette, click the New button to create a new simulation.
2. The Simulation Name dialog will prompt you to enter a name for the simulation. After you enter the name, click OK to create the simulation.
3. To limit your simulation to certain frames in your project, enter the starting and ending frames of the desired frame range in the Start Frame and End Frame fields.

Using Live Simulation

As you configure the settings and constraints that you apply to the physics objects in your scene, you can view the effects of those settings in real time. Check the Live Simulation option to preview how your simulation settings and weight painting affect the physics objects in your scene. The live previews are especially helpful while you paint constraint maps that control how the objects respond to gravity, motion, and collision with other objects.
Calculating Simulations

Click the Calculate Simulation button to calculate your simulation frame by frame for the currently selected simulation. Keyframes will be added to the Animation palette for each object in the current simulation.

Keyframes that are added to the Animation Palette after calculating a simulation will be removed when you click the Clear Simulation button.

Use the Animation > Recalculate Dynamics > All Physics menu command to calculate all of the physics simulations in your current project.

Object Types

After you create a new simulation, you need to set up the simulation objects in your scene. Click the Objects button to open the Select Objects dialog.

Click the Objects button to define your physics objects.

The Select Objects dialog displays three tabs: Choreographed, Rigid Dynamic, and Soft Dynamic. As you switch from one tab to the next, you place a check beside each of the objects in your scene that you want to designate as that object type.

- **Choreographed** is used to define stationary or animated objects in your scene that the dynamic objects will collide with. See Choreographed Objects.
The Select Objects dialog allows you to assign the objects in your scene to one of three types of objects.

When you assign physics objects in your scene, keep in mind that you don't have to assign every object in your scene as a physics object. For example, if your scene is composed of many walls and furnishings inside a room, the only objects that you need to assign to the current physics simulation are those that will directly come into contact with each other in the simulation that you are configuring.

**Rigid Dynamic** is used for hard-bodied objects that will have physics applied to them. These objects will maintain their shape when they interact with other objects in the scene. See [Rigid_Dynamic_Objects](#).

**Soft Dynamic** is used for soft-bodied objects that will have physics applied to them. The shape of these objects are affected by collision with other objects in the scene. See [Soft_Dynamic_Objects](#).

---

**Choreographed Objects**

Choreographed objects are those which either remain stationary or are animated manually with keyframes. When assigning choreographed objects, you only need to assign the objects that you expect the other physics objects to collide with.
A simple example is shown in the figure that follows. There are five objects in the scene: the ground, a large box, two balls, and a cloth plane. Only two objects in the scene are assigned as choreographed objects: the ground, and the large box in the center. These two items will not move, and the other objects in the scene will collide against them.

Choreographed objects are those that other physics objects collide against.

**Rigid Dynamic Objects**

Rigid dynamic objects are those which will interact with other objects, but which will maintain their shape when they collide with other objects in the scene. The figure shown below shows two balls that are selected as rigid body objects. They will maintain their shape when they collide against the other objects in the scene.

Rigid dynamic objects maintain their shape when they collide against other objects.
Soft Dynamic Objects

A soft dynamic object will change its shape or appearance when other objects collide against it. One obvious example is a cloth plane, as shown in the following figure. However, it’s also useful for other items such as a rubber ball that squashes and stretches in response to its collision with the ground; or jiggle that you can add to a heavy cartoon figure as he or she walks or runs across the scene.

*Soft dynamic objects change shape when they collide against other objects.*

Setting Object Properties

The Properties tab in the Physics palette allows you to assign properties to each of the physics objects in your scene. The properties that are available depend on the type of object you are configuring.

*Setting Object Properties.*
Select the object that you want to configure from the Object menu, and then click the Properties tab to display the following options:

If your scene includes several objects that need to share the same physics properties (for example, ten bowling pins), create the first object and set its physics properties. Then use the Edit > Duplicate Object command to duplicate the first object and its physics properties. The duplicated object will automatically be added to the current simulation. Alternatively, you can save the first object to the Library with its physics properties, and then add it from the Library to the current simulation.

You can duplicate objects to add a new object with the same physics settings.

- **Active**: Check this option to apply the physics simulation calculations to the currently selected object. You can uncheck the option to remove the object from the calculations without affecting the other settings that are applied to it.

- **Apply Velocity from First Frame**: If an object is animated up to the starting frame of a physics simulation, check this option to set the initial velocity of the object to be the same when the simulation starts. For example, if you want a bowling ball to move at a certain speed and direction, move the frame before you want the physics to take over. Advance to the next frame and move the ball to reflect the speed and direction that you want the ball to move. This will set the base velocity which will be taken into account when the simulation is calculated.

- **Use Animated Mesh**: When this option is checked, a new collision geometry will be created at every frame for the selected choreographed object, to support morphs, bending, magnets, etc. It generates a convex hull for each frame from the bent parts.

If you want the physics to take over at a frame other than 1, make sure that you set the appropriate start frame in the Physics Palette, as described in Creating a Simulation.

- **Collision Margin**: Defines the amount of distance that will be allowed between physics objects and the objects they collide with. Penetration can occur if the margin is set too low.
Click the **Settings** button in the upper section of the **Physics Palette** to configure general settings for the current simulation.

---

**Simulation Settings**

The Collision Margin setting is related to your preferred units, which are set in the Interface tab of the General Preferences dialog, described in Interface Preferences.

- **Friction**: Lower friction amounts cause objects to move more easily over other objects. A value of 1 will make the object very sticky, and a value of 0 will make the object more slippery.

- **Bounce**: Low values make the object less bouncy; higher values make the object more bouncy. When bounce is set to 0, the object will not bounce. A value of 1 makes the object bounce indefinitely.

- **Linear Damping**: (Hard and Soft Body objects only). The amount of energy that is lost during each iteration when an object moves linearly (such as from side to side). Without damping, the object will appear to vibrate in the scene. A value of 1 will absorb shock. A value of zero will remove damping from the object.

- **Rotational Damping**: (Hard Body objects only). Similar to linear damping, except that this setting controls the amount of energy that is lost during each iteration when an object is rotating or spinning.

- **Mass**: (Hard and Soft Body objects only). A relative measurement that affects how objects of a higher mass interact with objects of a lower mass. Items with a lower mass setting will accelerate more after a collision than items of a larger mass. Stronger forces will be needed to move objects that have a higher mass. When objects with a higher mass interact with objects of a lower mass, the objects of lower mass will move more easily. Using the example of a bowling ball and pins, the mass of the bowling ball (example: 16 units) should be set higher than that of the pins (example: 2 units) in order for the pins to react appropriately when the ball strikes them.

- **Internal Pressure**: (Soft Body objects only). Specifies the internal pressure of the object. Objects that have a greater internal pressure will collapse upon themselves less than objects that have a smaller amount of internal pressure.

- **Linear Stiffness**: (Soft Body objects only). Lower the linear stiffness to make the object more stretchy; increase the value to make it more stiff.

Choose Edit > Memorize > All after all of the objects in your scene are set up. This allows you to go return to the original placement of your objects after you experiment with settings during live simulation.
Click the Settings button to configure general settings for the simulation.

The Simulation Settings dialog opens, and you can configure the following properties for the simulation:

**Simulation Settings dialog.**

- **Gravity**: Controls the strength of the gravity in the scene. Values below zero pull objects downward, while values above zero act like “anti-gravity” and make objects rise.

- **Damping**: Controls the amount of resistance that your objects have to gravity. Lower values make the object less resistant, and higher values make the object more resistant.

- **Default Soft Collision Margin**: Controls the distance that soft body objects have to be before collisions are recognized. The Default Soft Collision margin is the default value assigned to soft-bodied objects when you add them to a simulation.

- **Default Rigid Collision Margin**: Controls the distance that hard body objects have to be before collisions are detected. The Default Rigid Collision Margin is the default value assigned to rigid-bodied objects when you add them to a simulation.

- **Steps Per Second**: Defines the number of small steps that the simulation will take per second. Increasing the Steps per Second setting will give more stable results and better penetration persistence in your simulations. Calculations will take longer with higher steps per second.

- **Better Soft Collisions with Clusters (Slower)**: Improves simulation of soft bodied objects when collisions take place, and can help prevent objects from penetrating through soft-bodied objects. Using clusters on detailed objects can slow calculations considerably.

### Object Constraints

The Constraints tab in the Physics palette allows you to configure one of three different types of constraints for your physics objects. It also features painting tools that allow you to paint vertex maps that determine how the object responds to physics.
To add a constraint to the currently selected physics object, click the **New** button in the Constraints tab. You’ll see a menu that allows you to choose one of several constraint types. These are:

**Creating a new constraint**

- **Self Constraint**: Defines how the object responds to physics calculations. Each object can have only one self-constraint. After you add a self-constraint, all vertices are initially set to fully dynamic. Use the vertex painting tools to constrain the vertices that you paint.

- **Animated Constraint**: Allows you to use a handle to animate an object. The handle can be assigned as a child of any other object in your scene, or animated in any way you choose. The handle serves as a transform that you can move things around with. The handle will pull on the vertices that you paint. To configure an animated constraint:
  
  - Position the animated handle where you want it to appear. Generally, the handle should be positioned near the object that you are adding the animated constraint to.
  - Press the **Set Handle Position** button.
  - Use the painting tools to constrain selected vertices to the animated handle.
Object Constraint: Constrains one object to another so that they move together. You use a handle to define the point at which the two objects are supposed to connect to each other, and tries to keep both objects connected at that point. For example, if you have two rigid boxes, named Box 1 and Box 2, that you want to connect together at a certain point:

- Select Box 2, and click the New button in the Constraint tab to create an Object Constraint for this object.
- For the Constrain To object, select Box 1.
- Position the handle at the point where you want to connect the two objects.
- Click the Set Handle Position button after you position the handle.
You can chain multiple items together in this manner. For example, you can add another object (such as a third box), and then create another Object Constraint that links Box 3 to Box 2.

Soft bodied objects may drift away from the handle during simulation. Adding a second Object Constraint between the same two objects may improve performance.

When you click the **Live Simulation** or **Calculate Simulation** button you should see your objects moving together. For example, you can drag Box 1 around, and Box 2 will automatically follow it.

- **Limited Object Constraint**: Constrains one rigid object to another so that they move together, and also allows you to limit rotation or translation in the X, Y, and/or Z direction. The Limited Object Constraint can only be applied to a Rigid Body object. Again, you have two rigid boxes, named Box 1, and Box 2. You want them to connect together at a certain point, but you want to limit the rotation of Box 2 to the Z axis:

  - Select Box 2, and click the **New** button in the **Constraint** tab to create a **Limited Object Constraint** for this object.
  - For the **Constrain To** object, select Box 1.
  - Position the handle at the point where you want to connect the two objects. (The result should look similar to the setup shown previously for the **Object Constraint**.)
  - Click the **Set Handle Position** button after you position the handle.
  - The lower section allows you to set the limits for the X, Y, or Z translations and rotations. In this example, we want to allow rotation only on the Z axis. The X and Y axis rotations are set to 0 minimum and maximum.
Limiting rotations to the Z axis only.

- When you click the **Live Simulation** or **Calculate Simulation** button you should see your objects moving together, with the translations or rotations set as you configured for the **Limited Object Constraint**. In our example, you can drag Box 1 around, and Box 2 will automatically follow it but the rotation will be limited to the Z axis.

Move Box 1 and Box 2 will follow it with limited rotations.

**Painting Constraints**

After you set up one of the constraint types mentioned in the previous section, you can use the paintbrush tool to paint a vertex map that defines how the object will respond to that constraint type.

After clicking the Paintbrush icon, the Dynamics Weights palette opens. This palette allows you to paint the vertices on the object to control how they will be affected by the physics engine. As you paint, the vertices are coded with various colors.
• Where no color appears, the object will be 100% affected by the dynamics in the physics calculations.

• Where color appears, darker colors define areas that will be affected by dynamics the most; brighter colors will define areas that will be less affected.

• Green areas define areas that will not be affected by the physics calculations.

Cloth plane with self constrained vertices fully (left) and partially (right) across the top.

The Dynamics Weights palette contains the following sections and settings:

Initially, all vertices of an object are set to fully dynamic unless you check the Invert Colors option mentioned below.

• Painting Modes section: Choose one of the following painting modes for your dynamic weights paintbrush:

  • More dynamic: Select this painting mode when you want to make the object more responsive to physics calculations. Vertices will appear with no color when they are fully dynamic.

  • More constrained: Select this painting mode when you want to paint areas on an object to reduce the amount of response to physics calculations. Vertices will appear as bright green when vertices are fully constrained, and the object will retain its base shape in those areas.

  • Smooth: Choose this painting mode when you want to smooth or blend transitions between areas that are more dynamic and areas that are more constrained.

  • Weight: Choose this painting mode when you want to paint with a predefined strength value. Enter the desired value in the Weight field that appears beneath the option.
Deleting Constraints

To delete a constraint, follow these steps:

1. From the Object menu in the Physics Simulation palette, select the object that contains the constraint you want to delete.

2. Switch to the Constraints tab, if necessary.

3. Select the constraint that you want to delete from the list of available constraints (which appears just above the paintbrush).

4. Press Delete to delete the selected constraint.

Deleting a Simulation

If more than one simulation exists in your scene, first click the simulation that you want to delete from the list in the Simulation Palette. Then click the **Delete** button in the upper section of the Physics Simulation palette.

Saving Objects with Bullet Physics

After you create objects that have Bullet Physics applied, you can save them to the Library with their settings intact. This allows you to save items that bounce, or jiggle, or use specific hard or soft-bodied settings.
After a Bullet Physics object is saved to the Library, you will need to re-simulate the object(s) when you load them into your scene. If an object is shared between two or more simulations, it will only save the current simulation that was selected when you saved the object to the Library.
Rendering Animations

You can access the Movie Settings window by selecting Animation > Make Movie. This window can also be accessed via the Render Settings dialog. The Movie Settings window appears as follows.

Initially, the Make Movie dialog renders individual image files for each frame in your animation. You can specify a folder and filename for your image sequence. The image sequence will be named based on the filename, followed by an underscore and a four-digit number (example: MyMovie_0001.png).

After the image sequence is complete, you can create a movie file based on the additional movie settings described below.

![The Movie Settings dialog.](image)

To use the Movie Settings window:

1. Select which renderer you wish to use for your animation using the Renderer pull-down menu. Your options are the FireFly, Sketch, Preview or SuperFly render engines.

2. Specify an Image Path. Click the Change button and specify the file folder and filename for your saved images.

3. Under the Preview Options section, check the appropriate checkboxes when available:
- **Antialias**: Antialiasing is available with the Preview render engine, to improve the quality of images in draft preview renders.
- **2D Motion Blur**: This option provides realistic 2D motion blurring effects to images and animations rendered with the FireFly or Preview render engines. Use the Blur Amount value to customize the results of this effect.

0. Specify your **Time Span** settings:

- **Range**: Enter the start and end frame numbers for the portion of your animation that you wish to render in the Start and End boxes. This feature is useful if you wish to save a subset of the total animation. For example, if you create a 60-frame animation, you could opt to save a 15-frame movie beginning 35 frames into the total animation.

- **Increment**: Click the appropriate Increment radio button to specify how many frames to render in your movie output. Your choices are as follows:
  - **All Frames**: Clicking the All Frames button will render all frames in the specified range, as defined by the movie’s frame rate.
  - **Frame Rate**: Click the Frame Rate (number of frames per second) radio button to use the movie’s current output frame rate (as opposed to the actual frame rate of the Poser keyframe data) or specify your own. Enter the desired frame rate in the box, if you wish to specify a frame rate other than the rate defined for the document, lower numbers result in choppier animations but take less time to render. Higher numbers give smoother animations but require longer rendering times and take up more room on your hard drive. Please refer to for a listing of common frame rates.
  - **Every Nth Frame**: Clicking this radio button allows you to render fewer frames, for fast preview purposes. For example, rendering every 2nd frame takes half the time as rendering every frame, and so on. Specify your desired “N” value in the box.

4. In the **Video Export Options** section, choose the desired video Format using the Format pull-down menu. Your available options (for Mac and Windows, unless as noted) are:

- **MP4 (H.264-AAC)**: The most commonly used format for distributing media online or by disc.
- **iPhone**: Three different resolutions, including iPhone Movie (480x320), iPhone 4 Movie (960x640) and iPhone 5 Movie (1136x640)
- **iPad**: Two different resolutions, including iPad Movie (1024x768) and iPad HD Movie (1280 x 1024), to save your files in M4V format.

  **H.264, iPhone, and iPad options may not be available on earlier versions of Windows.**

- **Android Movie**: Two different resolutions, including Android Movie (480x360) and Android HD Movie (1280x1024).
• **AVI (Windows Only)**: Three options are available in Windows for AVI format. Choose AVI (MJPEG) to produce an AVI file of any dimension, using a higher amount of compression (for streaming); choose AVI (DV) to produce a 720x480 pixel DV-quality AVI file. Choose AVI (Uncompressed) to produce an AVI file of any dimension, which will not be compressed.

> AVI DV format will produce a 720 x 480 pixel AVI file, regardless of your render settings. If your project render settings are not set to the same aspect ratio, the movie will be stretched to fit within the 720x480 movie file.

• **WMV/ASF (Windows Only)**: Three options appear for WMV/ASF format, for varying compression options: Medium Quality, High Quality, and Uncompressed.

> WMV/ASF options use Windows Media Audio 10 and Windows Media Video 9.

> WMV output presets are also available in Windows Vista, and Poser will write out valid WMV files if you choose the WMV/ASF preset. While Media Player for Windows Vista does not support WMV files, you will be able to play them in any third-party media player that runs under Windows Vista and has WMV support.

• **PNG HD Movie (1280x1024) (Mac Only)**: Creates a high-quality movie with lossless compression.

• **DV-NTSC (640x480) (Mac Only)**: Creates an NTSC-compatible video with 4:3 aspect ratio.

• **MOV - (H.264-AAC) (Mac Only)**: Creates a compressed video suitable for streaming online.

• **MOV - (pixlet-AAC) (Mac Only)**: Creates a high quality highly compressed video; however Apple Pixlet format is only playable on Macintosh systems running MacOS 10.3 or later.

5. In the **Video Export Options** section, choose your desired **Movie Size**. This offers quick access to four different render scale options, based on the render dimensions specified in the **Render Dimensions** dialog: Full Size, Half Size, Quarter Size, and Preview Size. To access the Render Dimensions dialog, click the **Render Dimensions** button, described below.

> As an example of what Movie Size presets do, assume that you specify custom render dimensions of 1200 pixels width and 1600 pixels height, which will render a portrait-style render.

> Full Size will render a 1200 x 1600 pixel image.
Half Size will render a 600 x 800 pixel image.  
Quarter Size will render a 300 x 400 pixel image.  
Preview Size will render the full scene, based on the size of your preview window.

If you specify a custom image size that renders to portrait or landscape resolutions, a production frame will highlight the area that will appear in your render. The production frame is determined by the aspect ratio resulting from the output width and height. You can set the production frame to be visible in the Document’s scene preview area, by selecting Display > Production Frame from the menu bar.

6. The Constraint option in the Video Export Options section allows you to specify video quality by a Quality value (a percentage value adjustable from 1 to 100%) or by Bitrate (adjustable from 1000 to 10000 bits per second).

7. Select an Audio Channels option, either Mono or Stereo.

8. Choose an Audio Sample Rate. Choices are 44100 or 48000.

9. Choose an Encoded Audio Rate. Choices are 96, 128, 160 or 192 Kbps.

10. In the Make Movie Options section, choose additional options as follows:
   - Auto make movie: Automatically creates the movie file after Poser completes rendering the image sequence. When unchecked, you will need to click the Make Movie button to manually create the movie file.
   - Auto delete frames: When checked, deletes the image file sequence after the movie is created.
   - Autoplay Movie: When checked, automatically plays the movie after it is created.
   - Encode Images: After rendering individual image files, you can click this button to turn the images into a movie file. The movie will be created based on all of the frames found in the location specified in Step 2, and will be compiled in the same order as the filenames. Gaps are allowed in the numbering. You can generate the image frames in any order, and in as many passes as you like, but the images must all be the same dimensions and file type, or they will be skipped.

11. The buttons at the bottom of the Movie Settings dialog are as follows:
   - Click the Render Dimensions button in the lower left corner of the Movie Settings tab to open the Render Dimensions dialog. Enter the desired dimensions for your movie. For more information about this dialog, see Render Dimensions.
   - Click Cancel to exit the Movie Settings dialog without saving your changes.
   - Click Send Render To to send your FireFly or SuperFly render to the Queue Manager.
   - Click Save Settings to save your render settings to the Movie Settings dialog. Note that you will still need to save the Poser scene, with File > Save.
• Click **Render Images** to render an image sequence to the image path specified in step 2. If the path is not valid, Poser will prompt you to verify and change your image path.

*Setting Render Dimensions.*
Customizing Content
The Hair Room

Poser’s Hair room allows you to create dynamic strand-based 3D hair for your figures or props. You can add hair wherever you like on any object in your scene and can add shaders in the Material room (see The Material Room) to give your hair almost any appearance from bleach blond to moss, lichens, grass, etc. (a shader tree is created for each hair group and is accessible in the Material room). You can even apply Force Fields (see Wind Force Fields) to create realistic wind effects for your animations!

*Hair contains many polygons that require hefty computing resources.*

*Beginning with Poser 11, hair and cloth dynamic files are saved with an .abc extension (Alembic format).*

The Hair room appears as follows.

*The number of palettes and options that you see in each room depends upon your screen resolution. At higher resolutions, the default workspaces display more palettes, while at lower resolutions you see fewer palettes:*

In addition to some standard tools, the Hair room has the following interface elements:

1. **Hair Growth Groups Controls**: The Hair Growth Groups controls allow you to create, edit, and delete hair growth groups.
2. **Growth Controls**: The Growth Controls allow you to specify how hair grows on growth groups.

3. **Styling Controls**: As the name implies, the Styling Controls allow you to control the appearance of hair.

4. **Dynamics Controls**: The Dynamics Controls allow you to control how your hair behaves during animations.

The following subsections will walk you through creating strand-based hair.

- **Step One: Defining Hair Groups**
- **Step Two: Growing Hair**
- **Step Three: Styling Hair**
- **Step Four: Setting Hair Dynamics**

You can find skull-cap props in the **Hair > Poser Content > People > Alyson > Hair Props and Hair** > **Poser Content > People > Ryan > Hair Props** categories within the **Library palette**.

---

**Step One: Defining Hair Groups**

Skullcap props for Ryan and Alyson and other figures have hair props pre-created. You can use the grouping tool to spawn props for this purpose too.

If you want to be able to use the hair you are creating for other figures, please refer to **Adding Strand-Based Hair to the Library Palette** for more information before proceeding.

The first step in creating strand-based hair is to define one or more group of polygons as a hair group. A hair group is a cluster of polygons that has been defined as an area on which hair will grow. A prop or skullcap can contain more than one hair group. For example, you can create multiple growth groups on a skull cap or hair prop to create a part in the hair; or small sections of a conforming hair prop, or a smart hair prop can be detailed with wisps of hair.

Please refer to **Using the Group Editor** for a general discussion about groups.
Step One: Defining Hair Groups

Hair Growth Group settings.

To do this:

1. Select the object you wish to grow hair on.

2. Click the **New Growth Group** button in Area 1 of the **Hair** room to create a new group called **Hair_1** by default. Subsequent hair groups are numbered sequentially (**Hair_2**, etc.). You can rename groups by entering a new name in the **New Growth Group Name** box that appears. Click **OK** to proceed or **Cancel** to abort.

3. Click the **Edit Growth Group** button to enable the **Grouping** tool and open the **Group Editor** palette. Be sure that you have the correct hair group selected before selecting polygons for the group. Please refer to **Creating/Editing Groups** for information about using the grouping tools.

4. Select the polygons you wish to include in the hair group you are creating.

You can create as many growth groups as you like, such as head hair, mustaches, beards, chest, back, etc.

Assigning polygons to a hair group.

Be sure that you have the correct hair group selected in the **Group Editor** palette before selecting polygons for the group!
Step Two: Growing Hair

Once you’ve created a hair growth group, the next step is to grow the guide hairs.

As the name implies, guide hairs influence how nearby hairs will grow. To do this, click the Grow Guide Hairs button. The currently selected hair group will sprout guide hairs.

Guide hairs both shape the hair group and increase performance by allowing you to toggle displaying the fully populated hair group on and off (see below). Either before or after growing the guide hairs, you can apply some general parameters to determine the overall hair shape. These are:

Hair Growth Controls.
Step Three: Styling Hair

Now that you’ve grown the guide hairs and set some basic parameters for how the hair will look, your next step is to style the hair the way you want it. You can do this by setting the included styling parameters and/or by using the Hair Edit tool.

You can use the Hair Edit tool at any time after growing hair, although we recommend that you complete the previous step. Please see the following subsection for information on using the Hair Edit tool.

Don’t confuse the Pull Back and Pull Down parameters as replacing gravity or other dynamics that you can set after styling the hair. These parameters merely set the hair’s starting positions.

The hair styling parameters are as follows:
**Styling Controls.**

- **Show Populated:** Checking the **Show Populated** checkbox displays both the guide hairs and the population hairs. This will show you exactly how the hair will look, but does increase display refresh time. The status of this box will not affect population of hair in the final render. Hair will always appear populated in a FireFly render.

  *In order to see Hair Density (below) you must enable Show Populated. If this option is not enabled, you will only be seeing the guide hairs.*

- **Hair Density:** The Hair Density parameter controls the total number of hairs in the group. The number of hairs are displayed next to the dial’s label. Increasing this number makes the hair fuller and more lush. The ability to control the total number of hairs is a powerful feature since it allows you to create custom effects, however the total number of hairs can impact rendering and redraw times. Experiment with this number to get optimum coverage without adding too many hairs.

  *Note that there is a fixed minimum density of 1 PNU (Poser Native Unit). If you reduce the Hair Density value to a setting that is below the fixed value, the number of hairs on the polygons will not change, even if the number of hairs in parentheses are showing 0 hairs. The fixed minimum density is overriding the Hair Density value that is entered in that case.*
But the number of populated hairs can vary, depending on the units that you display your scene in. For example, if your preferred units are set to feet, and the hair group is one square foot, setting the hair density to 144 will produce 144 hairs. But if you set your preferred units to inches, a value of 1 will give you that same 144 hairs per square foot.

When you use small preferred units (like mm or inches), the dial will appear to go to zero, but hairs will still be grown. When Preferences are set to Poser Native Units, the dial's minimum limit is 1.

The number displayed in parentheses should be the approximate number of additional hairs in the hair group that you have selected.

As a matter of trivia, there are roughly 100-150 hairs in eyelashes per lid, roughly 500-1,000 hairs on each brow, and roughly 100,000 to 150,000 hairs on the head.

- **Tip Width**: The Tip Width parameter controls the hairs’ widths (diameters) at their tips. Hair usually thins somewhat as it progresses from root to tip, so this number will typically be less than the Root Width parameter, below.

- **Root Width**: The Root Width parameter controls the hairs’ widths (diameters) at their roots. Hair usually thins somewhat as it progresses from root to tip, so this number will typically be larger than the Tip Width parameter, above.

- **Clumpiness**: The Clumpiness parameter determines the hairs’ tendency to form dreadlock-like bunches.

- **Kink Strength**: The Kink Strength parameter is the measure of how wavy/curly hair is. Increasing this value increase the hairs’ waviness, and vice versa.

- **Kink Scale**: The Kink Scale parameter determines the size of hair waves/curls. Increasing this value increase the hairs’ waviness, and vice versa.

- **Kink Delay**: The Kink Delay parameter specifies the distance from the root at which the hair begins to curl/wave. Increasing this value increase the distance from the root, and vice versa.

- **Verts Per Hair**: The Verts per hair parameter controls how many vertex points are in each strand of hair. Increasing this value results in smoother, more flowing hair but increases the system resources needed to render/redraw your scene.

- **Style Hairs**: Clicking the Style Hairs button selects the Hair Select tool and opens the Hair Style Tool palette (see below).
Using the Hair Edit Tool/Palette

The **Hair Select** tool is only available in the **Hair** room. It allows you to directly edit guide hairs and create a nearly infinite variety of hair styles (parts, tails, etc.). You can access it by either selecting it in the **Editing** tools or by clicking the Hair Select button as described above. The Hair Style Tool palette appears as follows:

![Hair Styling tools](image)

You have the following controls available for directly manipulating guide hairs:

1. **Add Hairs to Selection**: Select the **Select Hairs** tool, then click and drag a rectangle around the guide hairs you wish to select for further styling. Unselected guide hairs are not affected by the **Hair Edit** tools. Selected hairs are all affected equally. Selecting more guide hairs can be faster, however you can select as few as one hair for precise control over the style.

![You can style selected hairs in the hair group.](image)

For finer control over which hairs are selected, try switching cameras or using the Magnifier tool to zoom in close.
Hair growth is based on the parent object’s polygon count. If you wish to add detailed hair groups to a low-poly prop or to a portion of a figure with a low poly count, you can spawn a prop of the area you wish to grow hair on, subdivide that prop in your favorite 3D modeling application, then re-import the prop and apply it where needed. This is the same idea as skullcaps except that you are not limited to heads.

2. **Translate Hairs**: The **Translate Hairs** tool moves the selected hair vertically around or laterally around the camera’s X and Y axes depending how you drag. The translation may occur on the hair’s X, Y, and or Z-axes depending on the position of the camera relative to the hair.

3. **Curl Hairs**: The **Curl Hairs** tool bends a guide hair. Hair rotation works in three dimensions, allowing you to make a lot of progress very quickly. Dragging perpendicular to the hair rotates it up and down (relative to your point of view). Dragging parallel to the hair rotates it in and out, again relative to your point of view.

4. **Scale Hairs**: The **Scale Hairs** tool allows you to scale the selected hair along the camera’s X and Y axes. The hair’s affected axes will vary depending on the camera’s position relative to that item. Dragging in towards the root reduces the scale, and dragging away from the root increases the scale. Dragging laterally scales hair in two dimensions, and dragging vertically scales hair in the third dimension. The axes affected depend on your currently selected camera position. You can also press and hold Shift while using this tool to scale the selected hair(s) evenly in all three dimensions.

5. **Remove Hairs from Selection**: Select the **Deselect Hairs** tool, or simply hold down the [CTRL] key, then click and drag a rectangle around the guide hairs you wish to deselect from further styling. The Hair Edit tools do not affect unselected guide hairs.

6. **Translate In/Out**: The **Translate Hairs In-Out** tool moves the selected hair(s) along the Camera’s Z axis (in and out). This translation may take place along the hair’s X, Y, and/or Z axes. Dragging down pulls the hair towards you, and vice versa.

7. **Twist**: The **Twist Hairs** tool rotates selected hair(s) along their own axis.

In addition to the editing tools, the palette has the following controls:

- **Constrain Length**: Checking the **Constrain Length** checkbox forces all selected guide hairs to retain their current lengths no matter how you use the hair editing tools. Clearing this box allows the length to vary depending on how you use the hair editing tools (for example, you could use the Hair Translate tool to lengthen some guide hairs to create a ponytail.

- **Falloff**: The **Falloff** slider controls the portion of the hair affected by the styling. Moving the slider to the left causes the tools to only act near the tip of the hair. Moving the slider to the right causes the styling tools to affect more of the hair’s length. With the slider all the way to the right, the entire hair is affected from root to tip.

- **Lengthen**: Moving the **Lengthen** dial to the right lengthens the selected guide hairs and vice versa.

- **Clear Selection**: Clicking the **Clear Selection** button deselects all selected guide hairs.
To exit this tool, either click the Close box on the palette’s upper right-hand corner or select another Editing tool.

---

**Step Four: Setting Hair Dynamics**

You’ve got your hair grown and styled. Now let’s add some dynamics to control how the hair will behave during animations.

**Poser Legacy**

*Dynamics Controls.*

- **Do Collisions**: Checking the Do Collisions box enables collision detection for the current hair group, which will prevent hairs from penetrating other objects in the scene (for example, long hair will not penetrate a figure’s head). In order to ensure proper collision detection, make sure that all body parts with which you want the hair to collide have the Collision Detection checkbox set on the Properties palette.

- **Gravity**: The Gravity parameter controls the strength of gravitational force acting on the hair.

- **Spring Strength**: The Spring Strength parameter determines the hair’s springiness. Increasing this value increases the springiness. A rubber band is a good example of an object with a high amount of springiness.

- **Air Damping**: The Air Damping parameter specifies the hair’s air resistance that occurs whenever the hair is moving through the air. Short hair has a lower resistance than long...
hair. Set this parameter with care as excessive values could cause the hair to behave unpredictably.

- **Spring Damping**: The Spring Damping parameter controls the hair’s elasticity.

- **Bend Resistance**: The Bend Resistance parameter controls the hair’s resistance to bending or folding upon itself.

- **Position Force**: The Position Force parameter is a force that pulls the hair vertices towards their choreographed position. Increasing this value decreases hair dynamics, and vice versa.

- **Root Stiffness**: The Root Stiffness parameter determines how stiff the hair is at its root.

- **Root Stiffness Falloff**: The Root Stiffness Falloff parameter controls how quickly the hair’s root stiffness decreases from root to tip.

- **Calculate Dynamics**: Clicking the Calculate Dynamics button applies the current dynamic settings to the selected hair group. The number of frames in the keyframed animation determines the calculation length. Populated hairs do not display during calculation.

### Bullet Physics Solver

The Bullet Physics solver offers improved performance and appearance for dynamic hair. When using Bullet Physics for hair, you create growth groups, grow, and style hair as outlined in the previous sections in this chapter. Then you choose the Bullet Physics solver from the Dynamics Controls section in the Hair room.

![Dynamics Controls](image)

- **Do Collisions**: Checking the Do Collisions box enables collision detection for the current hair group, which will prevent hairs from penetrating other objects in the scene (for example, long hair will not penetrate a figure’s head). In order to ensure proper collision detection, make sure that all body parts with which you want the hair to collide have the Collision Detection checkbox set on the Properties palette.
Hair Properties & Parameters

To access a hair object’s parameters and properties, you must first select the desired hair object, which appears in the Current Actor menu under the Props category. Strand-based hair has the following properties and parameters:

- **Gravity**: Controls the strength of gravitational force acting on the hair. Decrease the setting to reduce the amount of gravitational force, or increase the setting to add more gravitational force.

- **Stretch Resistance**: Determines the stretchiness of the hair as it is pulled by gravity. Increase the setting to make the hair less stretchy (more resistant to stretching).

- **Bend Resistance**: The Bend Resistance parameter controls the hair’s resistance to bending or folding upon itself.

- **Root Stiffness**: The Root Stiffness parameter determines how stiff the hair is at its root (the end that comes from the head).

- **Tip Stiffness**: The Tip Stiffness parameter determines how stiff the hair is at its tip (the end of the strand).

- **Stiffness Falloff**: The Root Stiffness Falloff parameter controls how quickly the hair’s root stiffness decreases from root to tip.

- **Damping**: The Damping parameter specifies the hair’s air resistance that occurs whenever the hair is moving through the air. Short hair has a lower resistance than long hair. Set this parameter with care as excessive values could cause the hair to behave unpredictably.

- **Collision Margin**: Controls the amount of space that exists between the hair and the objects that it collides against, before a collision is detected. If the collision margin is set too low, hair can “disappear” inside the objects it collides against.

- **Friction**: Controls the amount of friction from the hair to the choreographed objects in the scene set to collide against. No hair self collision using Bullet.

- **Mass**: Mass will not have an effect using the Bullet Physics for hair.
Hair Properties & Parameters

**Hair Group Properties.**

**Hair Properties**

- **Name**: The Name field displays the hair object’s name. Enter a new name in this field if you desire.

- **Visible**: Checking the Visible checkbox makes the hair object visible and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene.

- **Visible in Raytracing**: Checking the Visible in Raytracing checkbox makes the hair object visible in raytraced reflections, such as if the figure is in front of a mirror. Clearing this checkbox makes the figure not appear in reflections.

- **Bend**: Checking the Bend checkbox enables bending for the selected hair object and vice versa. Bends are discussed in Bend Body Parts. Remember that selecting Display > Bend Body Parts bends all scene objects and this property only affects the currently selected body part.

- **Casts Shadows**: Checking the Casts Shadows checkbox forces the selected prop to cast a shadow, which will be visible in your scene. Clearing this box means the selected hair object casts no shadow.

- **Displacement Bounds**: The Displacement Bounds property determines the hair object’s displacement boundary. Please refer to Using The FireFly Render Engine for more information about displacement bounds.

- **Recalculate Dynamics**: The Recalculate Dynamics option recalculates the dynamics for the current hair object.

- **Shading Rate**: The Shading Rate allows you to specify the desired shading rate for the currently selected hair object. Please refer to Using The FireFly Render Engine for more information about shading rates.
Hair Parameters

Strand-based hair has the following parameters:

- **Dynamics**: The *Dynamics* parameter sets the amount by which the previously specified dynamics will be played during animations. A setting of 1 means the dynamics will play exactly as specified, a value of 2 means the dynamics will behave as though all values were set to 200% of their current settings, and so forth. Numbers below 1 reduce the amount by which dynamics are applied, and negative numbers apply the dynamics in reverse.

- **XYZRotate**: The *xRotate*, *yRotate*, and *zRotate* parameter dials rotate the hair object around the selected axis.

- **Scale**: Increases or decreases the size of the hair object in all axes.

- **XYZScale**: The *xScale*, *yScale*, and *zScale* parameter dials increase or decrease the size of the hair object in the selected axis.

- **XYZTran**: The *xTran*, *yTran*, and *zTran* parameter dials move the hair object along the selected axis.

Hair Colors and Materials

Each strand-based hair object in your scene has its own shader tree, which is accessible in the *Material* room, allowing you to color your hair and add interesting effects. Please refer to *The Material Room* for more information about the *Material* room. As with any other object, you can select strand-based hair by clicking it in the *Document*, using the *Current Actor* menu, etc.
Adding Strand-Based Hair to the Library Palette

Strand-based prop hair differs from geometry-based prop hair because it needs underlying geometry in order to “grow.” Strand-based hair grows in strands, much like real hair, rather than being made from textured polygons like geometry-based hair. You can’t add strand-based hair to figures/props in the same manner as prop-based hair. As a result, you can’t save strand-based hair to the Library palette unless it is growing from underlying geometry.

There are three ways to save strand-based hair for later use:

- Saving a PZ3 file with the hair object in it (you can do a merge function later, as explained in Importing Poser Documents or Props).

- Saving a prop/body part with a hair object on it. In this case, simply add the prop with the hair to your scene. For example, you could use the Group Editor to select polygons on a character’s head and create a skullcap prop, grow hair on that prop, and save the hair and prop to the Library palette.

- The Library palette includes skullcaps designed to fit the Don, Judy, James and Jessi figures. These skullcaps are available in the Hair category under their respective figures. To use a skullcap, add it to your scene, create and style hair, then save the skullcap with your new hair style back to the Library palette for use on other figures. Add skullcaps to figures just as you would prop-based hair. This is the preferred method for saving strand-based hair.

  
  Skullcaps are also useful because they have a higher polygon count than the underlying head, giving you more detailed control over hair surfaces. You can spawn props from any figure or prop, subdivide them in your favorite 3D modeling application, then apply them anywhere you like to obtain more detailed results.

To save strand-based hair to the Library palette:

1. Open the Hair category in the Library palette. Locate or create a folder in which to save your new hair.

2. Click to select the hair that you want to save.

3. Click the Add to Library button. A message informs you that you will need to save the hair group along with its parent prop. Click OK to continue.

4. Click Select Subset in the Set Name dialog. When you select your hair groups, make sure that you also choose the prop that the hair groups are attached to. For example, if you grew the hair groups directly on the figure’s head, make sure that you also include the Head in the props that you select.

  Strand-based hair is created on a per-object basis for each scene.
The Cloth Room

Poser’s Cloth room allows you to create realistic cloth that behaves like real fabric. Want to add custom clothing to a figure? Create a tablecloth? How about a flying carpet? Poser offers powerful tools that help you create dynamic cloth that responds realistically when animated. You can even apply a Force Field for realistic wind effects!

*Beginning with Poser 11, hair and cloth dynamic files are saved with an .abc extension (Alembic format).*

Using the Cloth Room

The Cloth room appears as follows.

The number of palettes and options that you see in each room depends upon your screen resolution. At higher resolutions, the default workspaces display more palettes, while at lower resolutions you see fewer palettes.

In addition to standard UI elements, the Cloth room contains the following UI elements:

1. **Cloth Simulations**: The Cloth Simulation area allows you to create, delete, and set up cloth simulators.
2. **Cloth Objects**: The Cloth area allows you to convert objects to and from dynamic cloth objects and to set up collision detection for your cloth.
Conforming vs. Dynamic Cloth

As mentioned in The Figures Category, conforming clothing is a Poser figure, while dynamic cloth consists of props with dynamic and other behaviors applied to simulate cloth. Poser supports both types of cloth.

Dynamic cloth adds incredible realism to your scenes by causing cloth objects to move as they would in real life. For example, you can use dynamic cloth to create the following types of items in your Poser scene:

- A tablecloth that drapes over a table
- A slip cover over furniture
- A flowing skirt that moves as a figure walks

Dynamic cloth objects require increased computing resources beyond those of conforming clothing. Items such as socks, bikinis, or tights don’t need to be dynamic since in real life these types of clothing tend to be close-fitting with little to no room for independent motion. You should generally use conforming clothing for these situations because it requires fewer computing resources.

Adding Dynamic Clothing

Dynamic clothing offers the most powerful means of clothing figures, allowing for realistic cloth draping and wrinkles. Additionally, it is very easy to create clothing props for use as dynamic clothing. Dynamic cloth retains its dynamics when saved to the Library palette, but you will need to create a new simulation whenever you add saved cloth objects. To add dynamic cloth to your current figure:

1. Select the item from the Library palette and add it to your scene, then switch to the Cloth room.
2. Create a new simulation group, and select Body as your desired collision object.
3. Recalculate the simulation.

Using Dynamic Clothing without a Figure

Dynamic cloth retains its dynamics when saved to the Library palette, but you will need to create a new simulation whenever you add saved cloth objects. To add dynamic cloth without a figure:
Using Dynamic Clothing with Morphs

Step 1: Create/Set Up a Cloth Simulator

The first step in creating dynamic cloth is creating and setting up a cloth simulator. You may have as many simulators as you wish in your scene, however each simulator requires system resources (RAM/CPU cycles) and increases rendering time.

1. Select the item from the Library palette and add it to your scene, then switch to the Cloth room.
2. Create a new simulation group, and select your desired collision object(s), if any.
3. Recalculate the simulation.

Creating the Simulation

To create a simulator, click the New Simulation button in the Cloth Simulation area of the screen to open the Simulator Settings dialog.
Step 1: Create/Set Up a Cloth Simulator

Creating the Simulation.

The Simulator Settings dialog box has the following options:

- **Simulation Name**: Enter your desired name for the new simulator in the Simulation Name field. By default, simulators are numbered in the order they are created, e.g. Sim_1, Sim_2, etc.

- **Simulation Range**: You can either set the simulator to run throughout your entire animation or pick a set of frames during which the simulator is active by entering your desired frame numbers in the Start Frame and End Frame fields, respectively. Increasing the number of frames that a simulator is active requires greater amounts of system resources. During the frames prior to the start of a simulation, the cloth object will remain in its starting state. After the simulation ends, the cloth object will remain in its ending state for the rest of your animation. Additionally, the Steps per frame parameter dial controls the number of calculation steps per frame in order to smooth the cloth simulation. Increasing this value improves the simulation results but requires additional computing resources.

- **Additional Cloth Collision Options**: These checkboxes allow you to toggle the following additional collision detection options on and off. By default, collisions are calculated using cloth vertices against object polygons.
  - **Object Vertex against cloth polygon**: Checking the Object Vertex against cloth polygon checkbox performs additional collision calculations using object vertices and cloth polygons, which helps eliminate tears or holes that may occur when an object collides with the cloth. Enabling this option slows the simulation.
  
  - **Object Polygon against cloth polygon**: Checking the Object Polygon against cloth polygon checkbox performs additional collision calculations using object polygons and cloth polygons, which helps eliminate tears or holes that may occur when an object collides with the cloth. Enabling this option slows the simulation.
  
  - **Cloth self-collision**: Checking the Cloth self collision checkbox allows a cloth to detect its own polygons during simulation, preventing (for example) a cape or a flag from passing through itself. Enabling this option slows the simulation.

- **Cloth Draping**: The Cloth Draping options are:
When you have finished setting up the simulator options, click **OK** to accept your choices and create the simulator or **Cancel** to exit without creating the simulator.

The Cloth Simulation area has two other buttons:

- **Delete Simulation**: Simulation results are cached in a file during simulation computation, which Poser automatically loads to save time and resources. Clicking the Delete Simulation button deletes the cache contents.

- **Simulation Settings**: Clicking the Simulation Settings button reopens the Simulation Settings window, allowing you to alter your cloth simulator settings.

Think of a cloth simulator as an envelope supplying basic behavioral properties. You can have multiple cloth objects in each simulation and/or multiple simulations in each Poser scene. Each cloth object, however, can only belong to one simulation at a time. Increasing the number of simulations in a scene can add complexity and interest, but also requires increased computing resources.

The arrow at the top right of the Cloth Simulation area displays the currently selected simulator. Clicking this arrow opens a pull-down menu allowing you to select any of the cloth simulators in your scene for modification.

### Step 2: Cloth Controls

Now that you’ve created a simulator, your next step is to add cloth objects. Do this using the Cloth controls (area 2 of your screen).
Clothifying Objects

To turn an object into a dynamic cloth object, select it and click the Clothify button to open the Clothify window, which displays a list of objects eligible to be turned into dynamic cloth. Use the Object to clothify pull-down menu to select your desired object, and click the Clothify button to make the cloth object, or Cancel to abort.

Choosing an object to clothify.

To turn a dynamic cloth object back into a normal prop, select it and click the Unclothify button. The prop will return to its pre-clothified shape, however it will retain its vertex groups and dynamic parameters, meaning you won’t have to start from scratch if you re-clothify the object later.

You can also create static props and morph targets from cloth objects as described in Creating Props and Morph Targets.

Specifying Collision Objects

Once the simulator is created and you’ve specified the basic parameters and created dynamic cloth, the next part of the simulator creation process is defining the objects that will use collision detection (collision objects) with the cloth. Each collision object will behave in accordance with the specified collision behaviors when contacting the cloth. Non collision objects will not use collision detection with the cloth object. To set up collision objects, click the Collide Against button to open the Cloth Collision Objects window.

Choosing collision objects.
The Cloth Collision Objects window has the following options:

- **Add/Remove Collision Objects**: Clicking the Add/Remove button opens the Select Objects window, which displays a hierarchical list of all the objects in your scene, including body parts on figures. By default, all scene objects are selected (selected objects are checked). Add and remove collision objects by checking/clearing the checkboxes next to each object listing in the window, then click the OK button to accept your choices or Cancel to abort. Added objects appear in the Current Collision Object pull-down menu in the Cloth Collision Objects window. You can set collision options for each collision object by selecting it using the pull-down menu and specifying the desired settings.

- **Collision Offset**: The Collision Offset parameter determines the distance between a cloth object and a collision object at which the collision detection calculations begin. Increasing this value can help avoid accidental collisions, especially during animations, because Poser requires a little time to calculate actual collisions. Increasing this value too high can consume extra computing resources. Experimentation will quickly yield the proper value for each simulation. Please see Collision_Offset & Depth for more information.

- **Collision Depth**: The Collision Depth parameter specifies how close the cloth object must be to a collision object in order for a collision to take place. Increasing this value increases the distance at which the cloth and collision object will collide. This is useful when creating clothing, because the cloth will be kept away from the figure. Increasing this distance makes the cloth appear more static but avoids having body parts penetrate the cloth (such as a leg poking through a skirt). Experimentation will quickly yield the proper value for each simulation. Please see Collision_Offset & Depth for more information.

- **Static Friction**: The Static Friction parameter sets the coefficient of friction for the collision object. This is similar to the Dynamic Friction parameter except that this is the force required to get a stationary cloth in contact with a solid to start moving. For example, nylon over smooth plastic will have a very low amount of static friction while denim over wood will have a high amount. You can use the Collision Friction checkbox (see below) to use the collision object’s value or the simulation’s value.

- **Dynamic Friction**: The Dynamic Friction parameter sets the coefficient of friction for the collision object when the object is in motion. Moving a piece of cloth across a surface causes friction. Silk moving over a steel surface has low resistance, while cotton moving
over skin or coarse sandpaper over rough wood has high resistance. You can use the **Collision Friction** checkbox (see below) to use the collision object’s value or the simulation’s value.

- **Figure Collision Options**: The **Figure Collision Options** allow you to specify how the current cloth object will behave when it drapes across/collides with a figure. Most clothes dressed on a figure are modeled in such a way so that they will fit on the target figure when the figure is in default pose. However, most simulations including figures and dresses will not use figure’s default pose at the start of simulation. In order for the simulation to work correctly, we need to simulate the cloth draping process: given certain frames, the underlying figure will interpolate from default pose to the start pose, and the draping simulation ensures the cloth fits the figure at the start frame.

  - **Start Draping From Zero Pose**: Checking the **Start draping from zero pose** checkbox is used when creating cloth to be used as clothing on a figure. For example, you can convert conforming clothing into dynamic cloth objects and drape them over a figure beginning from that figure’s default pose. This is useful when applying dynamic cloth to a posed figure.

  - **Ignore Head Collisions**: Checking the **Ignore head collisions** checkbox causes the collision detection not to apply when the cloth collides with a figure’s head. This is useful for cloth that will not normally touch the head, such as shirts, pants, etc.

  - **Ignore Hand Collisions**: Checking the **Ignore hand collisions** checkbox causes the collision detection not to apply when the cloth collides with a figure’s hands.

  - **Ignore Feet Collisions**: Checking the **Ignore feet collisions** checkbox causes the collision detection not to apply when the cloth collides with a figure’s feet.

Adding collision objects increases the computing resources required to calculate cloth behavior and dynamics. Thus, you should specify the minimum number of collision objects possible.

When you have finished setting up the collision objects, click **OK** to accept your choices or **Cancel** to exit without setting up collision objects.

The arrow at the top right of the **Cloth** area displays the currently selected cloth object. Clicking this arrow opens a pull-down menu allowing you to select any of the cloth objects in your scene for modification.

**Collision Offset & Depth**

The **Collision depth** and **Collision offset** dials are limited to minimum 0.1cm and maximum 10cm.
Before adjusting these settings, be sure to enable the Object vertex against cloth polygon and Object polygon against cloth polygon options in the Simulator Settings dialog.

A real piece of cloth has two sides (inside & outside) and thickness. A cloth mesh is composed of polygons, which mathematically have zero thickness. The Collision Depth and Collision Offset dials emulate thickness by “extruding” the cloth inwards by the amount of Collision depth units and outward by the amount of Collision offset units. Thus, the cloth now has a “thickness” of collision offset + collision depth. Any specified collision object intersecting this volume will be treated as a collision.

Step 3: Cloth Groups

Objects being converted to cloth must have single-sided, connected (welded) polygons without caps. Once you’ve created a cloth simulator and cloth object, the next step is to create cloth groups (groups of vertices) within each object, thus subdividing the cloth object into regions (in the same manner as, for example, dividing a body part into different material groups). The exception is decorative objects such as buttons, belt buckles, etc., which should be separate (non-welded) objects. Cloth groups use vertices instead of polygons, meaning that the Group Editor palette operates in vertex mode in the Cloth room (as opposed to polygons). You can convert polygon groups to vertex groups in the Cloth room by clicking the Add Group button to open a pop-up list of existing groups. Group names with the suffix [P] are polygon groups. Selecting polygon groups includes all vertices of the affected polygons.

Cloth Group objects.
There are four types of groups available for cloth objects:

- **Dynamic**: By default, cloth objects are created with one dynamic group (\_default\_) comprising the entire object. Dynamic cloth groups are simulated using the Dynamics Controls (see following step), which determine how the cloth moves, folds or drapes as it responds to gravity, wind force and how an underlying figure/prop moves. Examples of moving figures and props include a ball underneath a carpet, or a figure underneath clothing. You can create multiple dynamic groups for each clothing object, and each dynamic group can have different dynamics settings. You cannot directly animate dynamic groups with regular keyframing.

- **Choreographed**: Each cloth object can have one choreographed group. An empty choreographed group is automatically created when you clothify an object. Choreographed vertices can follow keyframed movement or be excluded from the cloth simulation.

- **Constrained**: Each cloth object can have one constrained group. An empty constrained group is automatically created when you clothify an object. Constrained vertices “stick” to corresponding polygon faces of the underlying figure and are useful for cloth areas that have to follow the movement of the underlying body part. They can be used to prevent straps on a dress from slipping down the shoulders, or to create a skirt’s belt that follows the waist’s movements. If you do not place these vertices in a constrained group, gravity can cause the cloth to fall until the skirt hits the body or the ground. Constraining the belt vertices keeps the belt at the waist and reduces simulation time. If the belt contains complex geometry, the simulation will slow down.

- **Decorations**: Each cloth object can have two decorations groups (one “soft” and one “rigid”). These groups are automatically created with empty contents when you clothify an object. The decoration groups animate, moving as underlying cloth moves while staying over the underlying body. Good candidates for decoration vertices include tiny or thin polygons such as pockets, belt loops, buttons, a knot in a tie, etc. These are usually items sitting on another cloth group and have only passive movement, either following underlying body movement or other parts of the cloth. Because of their small size and/or irregularity, these can cause issues if not placed into this group. The decorations group favors accessories that are geometrically separated from the cloth mesh object. There are two reasons for this:
  
  - If the decorations group shares vertices with the cloth mesh, the decorations vertices will not be simulated. This causes the simulator to treat these areas as boundaries, resulting in increased movement of these areas compared to neighboring regions of the cloth.
  
  - Welding accessories to the cloth mesh often creates a complex mesh where one edge is shared by more than two polygons.

The two types of decoration groups are:

- **Soft**: Objects in the soft decorated group move with the underlying cloth and can flex as the cloth flexes. A good example would be a belt loop.

- **Rigid**: Objects in the rigid decorated group move with the underlying cloth but do not bend or flex. Good examples of rigid decoration objects are buttons or the knot in a tie.

If you want the current cloth object to consist of a single dynamic group, you’re done. Continue on to Step 4 (below) to set your dynamics. If, however, you want to create multiple groups, you can do so using the following buttons:
Step 3: Cloth Groups

- **New Dynamic Group**: Clicking the **New Dynamic Group** button opens the **New Dynamic Vertex Group Name** box. Enter your desired name for the new dynamic group and click **OK** to proceed or **Cancel** to abort. By default, your entire cloth object consists of a dynamic group called **_default_**. Any vertices that are not part of other dynamic, constrained, choreographed, or decorated groups when you’re done creating/editing groups will remain in the **_default_** group.

  ![New Dynamic Vertex Group Name](image)

  *Assigning a name to a Dynamic Group.*

  *Since each cloth object can only have one choreographed, constrained, and/or one each soft & hard decorated groups, you can only assign names to dynamic groups.*

- **Delete Dynamic Group**: Clicking the **Delete Dynamic Group** button deletes the currently selected dynamic group.

- **Edit Dynamic Group**: Clicking the **Edit Dynamic Group** button opens the **Group Editor** palette, which allows you to add or remove vertices from the currently selected group. Please refer to Creating/Editing Groups for information on using the **Group Editor** palette.

- **Edit Choreographed Group**: Clicking the **Edit Choreographed Group** button opens the **Group Editor** palette, which allows you to add or remove vertices from the currently selected choreographed group (**_choreographed_**). Please refer to Creating/Editing Groups for information on using the **Group Editor** palette.

- **Edit Constrained Group**: Clicking the **Edit Constrained Group** button opens the **Group Editor** palette, which allows you to add or remove vertices from the currently selected constrained group (**_constrained_**). Please refer to Creating/Editing Groups for information on using the **Group Editor** palette.

- **Edit Soft Decorative Group**: Clicking the **Edit Soft Decorative Group** button opens the **Group Editor** palette, which allows you to add or remove vertices from the currently selected soft decoration group (**_softDecorated_**). Please refer to Creating/Editing Groups for information on using the **Group Editor** palette.

- **Edit Rigid Decorative Group**: Clicking the **Edit Rigid Decorative Group** button opens the **Group Editor** palette, which allows you to add or remove vertices from the currently selected rigid decoration group (**_rigidDecorated_**). Please refer to Creating/Editing Groups for information on using the **Group Editor** palette.

Keep the following in mind when working with cloth groups:

- Adding vertices to the current group removes them from other groups.

- Removing vertices from the default group adds them to the choreographed group.

- Removing vertices from any group adds them to the default group.
The arrow at the top right of the Cloth area displays the currently selected cloth group within the currently selected cloth object. Clicking this arrow opens a pull-down menu allowing you to select any of the cloth groups in the current cloth object for modification. To work on a different cloth object, use the pull-down menu available in the Cloth area (Step 2).

**Step 4: Cloth Dynamics Controls**

Once you’ve created and edited cloth groups, the next step is to define dynamic properties for each of the dynamic groups in the currently selected cloth object. Dynamic properties control how the dynamic groups will move and behave when the dynamics are calculated. The Cloth Dynamics Controls have the following buttons:

- **Calculate Simulation**: Clicking the Calculate Simulation button takes into account all of the simulation, object, group, and dynamics settings included in the current simulation and calculates the behavior of all of the cloth objects in the simulation for all of the specified frames. Please see above for information on specifying cloth simulation frame ranges.
If a clothified object contains morphs that are dialed in at frame 1, there may be occasions when the morphs are doubled after the cloth simulation is calculated. One way around this issue is to set the morph back to zero on frame 1, and on the end frame. Then set the morph back to 1 before you recalculate it.

- **Play Simulation**: Clicking the Play simulation button plays the currently selected simulation, allowing you to see how the cloth behaves over time. If you don’t like the current behavior, you can alter any of the Cloth room settings and try again.

- **Clear Simulation**: Clicking the Clear Simulation button empties all stored data in the current simulation (such as altering collision settings, adding/removing objects, editing groups, changing dynamics control settings, etc.), allowing you to specify new dynamics, thus modifying how the cloth object behaves. If you clear the simulation and play the animation, what you are seeing is simply keyframe animation with no simulation being calculated.

The Cloth room includes the following dynamics controls:

- **Fold Resistance**: The Fold Resistance parameter specifies the resistance to out-of-plane bending (folding). Increasing this value lessens the cloth’s ability to bend. Soft fabrics like silk fold very easily, so a low value (1.0) is appropriate. By contrast, hard leather tends not to fold, so a higher value would be appropriate.
**Step 4: Cloth Dynamics Controls**

- **Shear Resistance**: The Shear Resistance parameter controls the cloth’s resistance to in-plane shearing, or side-to-side bending. A low shearing resistance allows the cloth triangles (caused, for example, when the corner of a rectangular piece of cloth is draped over a surface) to collapse in on themselves, so a value of 50.0 or thereabouts is appropriate. Wool has a low shear resistance while leather has a very high amount.

- **Stretch Resistance**: The Stretch Resistance parameter specifies the cloth's resistance to in-plane bending (stretching). Most cloth is highly resistant to stretching, with some exceptions like spandex, which is more elastic. The default of 50.0 gives a fairly high resistance to stretching suitable for cotton-type materials. A lower value might be suitable for stretchy materials such as Lycra.

- **Stretch Damping**: The Stretch Damping parameter controls the internal energy loss caused by the motion of the cloth fibers against each other. Higher damping causes the cloth to lose its motion more quickly. Excessively high values can make the cloth look like it is moving in syrup, and extremely low values can cause the cloth to behave irregularly. A value of 0.01 is suitable for more uses.

- **Cloth Density**: The Cloth Density parameter specifies the mass-per-unit area density of the cloth in grams per square centimeter. If you take a 1cm x 1cm piece of cloth and weigh it, the weight in grams is what this parameter should be set to. For example, silk is very light while leather is very heavy by comparison.

- **Cloth Self Friction**: The Cloth Self Friction parameter sets the coefficient of friction between one part of the cloth and another, or how easily the cloth moves over itself. Higher values prevent the cloth from sliding over itself. For example, rayon has a very low amount of self-friction while denim has a fairly high amount.

- **Static Friction**: The Static Friction parameter sets the amount of friction between the cloth and solid objects. This is similar to the Dynamic Friction parameter except that this is the force required to get a stationary cloth in contact with a solid to start moving. For example, nylon over smooth plastic will have a very low amount of static friction while denim over wood will have a high amount.

- **Dynamic Friction**: The Dynamic Friction parameter sets the coefficient of friction between the cloth and solid objects when the cloth is in motion. Moving a piece of cloth across a surface causes friction. Silk moving over a steel surface has low resistance, while cotton moving over skin or coarse sandpaper over rough wood has high resistance.

- **Air Damping**: The Air Damping parameter specifies the cloth’s air resistance that occurs whenever the cloth is moving through the air. Tightly woven cloth has a higher resistance than loosely woven fabric. Set this parameter with care as excessive values could cause the cloth to behave unpredictably.

- **Collision Friction**: Checking the Collision Friction checkbox ignores the cloth object’s Static Friction and Dynamic Friction parameters, instead using those same parameters belonging to the collision objects themselves. Clearing this checkbox applies the cloth dynamic settings.

- **Reset**: Clicking the Reset button resets all cloth dynamics controls.

The label at the top right of the Cloth Dynamics Controls area displays the currently selected cloth object. To change the object, use the pull-down menu in the Cloth area (Step 2).
Cloth Parameters & Properties

To access a cloth object’s parameters and properties, you must first select the desired cloth object.

- Dynamic cloth objects have the same properties as props. Please refer to Prop Parameters for information about prop properties.

- Dynamic cloth has the same parameters as strand-based hair objects. Please refer to Hair Properties & Parameters for information about hair object parameters.

Creating Props and Morph Targets

You can convert cloth objects into static props or morph targets for use in scenes where a cloth-like look is desired without the need for a dynamic cloth object. For example, you could create a tablecloth using dynamic cloth and a table prop then convert the dynamic cloth object into a static prop for use in future scenes. If you did this, you would only need to include table legs where visible between the floor and the edge of the cloth, thereby giving you full realism while reducing your scene’s polygon count.

As another example, you could drape a sheet over a figure to create a ghost. Then you could convert the draped sheet to a static prop and use the Setup room to turn it into a poseable ghost.

To create a prop from your dynamic clothing object:

1. Clothify an object as described above.
2. Use the Animation controls to move to your desired frame (the cloth shape changes with each frame as the simulation plays).
3. Use the Grouping tool to spawn a new prop. Please refer to The Group Editor for information on using the Grouping tool and the Group Editor palette.

Creating a prop in this method preserves the shape of the original cloth object at the time you created the prop but removes all transformation (position, rotation, and scale). For example, if you stretch a square into a rectangle, the new prop will appear as a square deformed by the cloth simulation. In this case, reapplying the transformations applied to the original clothified object restores the original appearance to the static prop.

To create a morph target, follow steps 1 & 2 above, then spawn a morph target as you would for any other prop/body part as described in . You can then apply the morph target to a prop.

Morph targets created in this manner work in exactly the same manner as other morph targets, meaning that all dynamic motion is lost.
You can also export clothified props just like you would any other scene object. Exported cloth objects become static mesh objects in your chosen export format. To do this, follow steps 1 & 2 above, then export the object as described in Exporting Files.

**Adding Dynamic Cloth to the Library Palette**

Adding dynamic cloth to the Library palette is a special case that merits its own topic. To add dynamic cloth:

1. If not done yet, load your desired figure and be sure to disable Inverse Kinematics (see Inverse Kinematics (IK)). Next, open the Joint Editor palette (see Working with Joints and Weights) and click the Zero Figure button.

2. If not loaded yet, load or import your desired cloth object and ensure it fits the figure without obvious intersections. If importing a static prop, convert it into dynamic cloth using the Cloth room as described in this chapter.

3. Select the cloth, then open its Properties palette and click the Set Parent button (or select Object > Change Parent).

4. The Choose Parent window appears. Select Hip, being sure not to check the Inherit bends of parent checkbox.

5. Open the Library palette to the Props category and select your desired subcategory as described above. Save the cloth object.

6. You will be prompted to save the object as a smart prop. Click Yes.

*If your cloth object is not tied to a figure (such as a tablecloth), simply save it as a prop.*
The Fitting Room

The Fitting Room is designed to address the needs of those who want to use existing clothing to fit new characters. The concept is as follows ... you get a new figure, you find clothing that you like, and you use the Fitting Room to alter the fit of the clothing to fit the newly available figure. Along the way, the Fitting Room allows you to convert the new fit into a prop (for dynamic clothing) or figure (for conforming clothing), including adding groups, skeleton, and character morphs.

The fitting process is done semi-automatically, in that you can use one of five different fitting methods (**Prefit**, **Tighten**, **Smooth**, **Soft Features**, and **Rigid Features**) to control what areas of the clothing should move more or less than others: The calculations for each of these methods are done automatically in Poser, but you can use paintbrush tools to determine the strength at which each of these fitting methods are used. This gives you full control over the appearance and result of the fit.

Problems and Solutions

The Fitting Room may not convert every piece of clothing perfectly, and there are some known limitations in the types of geometry that are difficult for the fitting room to handle. The following are some issues that are currently known:

- Clothing that is modeled in sections, with unwelded seams, can become split apart at the seams when tightened. The Soft Features method cannot resolve this, as it is a result of smoothing. The smoothing algorithm moves vertices as they relate to their neighbors, and if a seam is not welded it moves the sides away from each other. To reduce the separation, use the Paint tools to subtract the smoothing down to zero on both sides of the seam.

- Clothing that has layered parts, such as a skirt and an overskirt, or two or more layers of overlapping geometry, can intersect and cause collisions.

- Setting all vertices to the Rigid Features method (examples: body armor, jewelry, jeweled Egyptian collars, etc.) can result in unexpected translations of the geometry.

- The Prefit method can cause conflicts with the Soft Features and Rigid Features methods. Prefit is run first, and it can balloon the geometry more than desirable in the areas that use Soft or Rigid Features.

- For clothing that incorporates more than one of the above issues you can, if desired, use Poser’s GoZ plugin, or a third-party 3D application to refit to your new character. Fit the clothing item as closely as you can. Then import the morph as a full body morph in the Pose Room. Dial the morph in before you enter the Fitting Room. When you set up the Fitting Room simulation, uncheck the Zero Figure option to apply your morph to the figure. Then set all Tighten method vertices to zero and paint in only the areas that you need to
Preparing Your Scene

Before you enter the Fitting Room, you need to load the character and the clothing that you want to refit into your scene. The following image shows Pauline and third party shirt created for Victoria 4.

![Load the character and clothing into your scene.](image)

Adjust Scale, Position, and Rotation

When you bring a figure and clothing into the fitting room, both objects are converted to Poser unimeshes. What this means is that any translation, rotation, or scaling will work on the entire object, rather than on individual body parts.

Because of this, you’ll need to consider how the default poses of characters differ, and whether or not you will need to rotate body parts to match up the default poses more closely.
Refitting Conforming Clothing

Default poses of Poser figures can be quite different from one character to another. Arms and legs can be bent differently, one character might lean more forward or backward at the waist, and so on. If the differences are substantial, it’s a good idea to use rotations on the clothing to more closely match the default pose of the character you want to fit.

For example, some characters are modeled with arms perfectly straight when they are in their default pose, while others have their arms and legs bent slightly differently. The steps that you take at this point differ slightly, depending on these differences.

For example, if you are fitting a shirt, compare the bending of the arms. To begin, scale and move the clothing item to roughly match the figure. You don’t have to account for all of the pokethrough when you do this. The idea is to just get the clothing item in roughly the right position so that you can adjust the arm bends.

- If the arms are straight on the character, and are also straight in the shirt, you can do the remainder of the fit in the Fitting Room.
- If the arms are straight in one case, but bent at the elbow in another (such as shown in the following figure), you’ll need to adjust the rotations of the clothing before you enter the Fitting Room.

In cases where the default pose is different, it helps to adjust the rotations on the clothing before entering the Fitting Room. For example, if the arms are bent differently on the shirt that you’re trying to fit, you can use the scale and rotation dials on the right arm to get the sleeve to match as closely as possible, and then use the Figure > Pose Symmetry commands to apply the settings to the other side.

Rotation adjustments of Victoria 4 shirt before (top) and after (bottom).
After you make your adjustments, you may still have pokethrough on the clothing in other areas. However, the controls in the Fitting Room will take care of this when you create your fitting simulation.

Victoria 4 shirt roughly scaled, rotated, and positioned to fit Pauline.

If you don’t need to change any rotations on individual body parts, you can enter the Fitting Room without doing so. You will be allowed to adjust the overall scale and position of the clothing in the Fitting Room.

If you do make scaling and rotation adjustments in the Pose Room, you will need to uncheck the Zero Figure option when you create your fitting simulation as described in the following section.

Uncheck the Zero Figure option on the clothing if it has been rotated to fit the orientation of the figure.

Refitting Dynamic Clothing

When you are refitting dynamic clothing to fit another character, you won’t be able to rotate the body parts of the clothing to match the figure. In the case of dynamic clothing you should begin by scaling and positioning the clothing as close as you can. Since dynamic clothing has no body parts that you can rotate to match the figure, you can use one of the following methods:
• Rotate the body parts on the character to match the clothing. In this case, when you create your fitting simulation as described in the following section, you will need to uncheck the Zero Figure option when you set up your simulation.

• Create magnets to rotate portions of the clothing as needed.

Creating a Fitting Simulation

After you add the clothing and figure to your scene, click the Fitting tab to enter the Fitting Room. At this point, the first step is to create a fitting session, which basically identifies the clothing item that you want to fit, and the character that you want to fit it to.

To create a new fitting session, follow these steps:

1. With the character and clothing loaded into your scene, click the Fitting tab to switch to the Fitting Room.
2. Click the **New** button at the top of the Fitting Sessions palette.

   ![New button](image)

   *Click the New button to create a fitting session.*

3. In the Session dialog, complete the following:

   • **Name**: Enter a name for the clothing fitting session.
   
   • **Object**: Expand the Object list to select the clothing item that you want to fit to the character.

   **Check the Keep Deformations option for the Object if you applied morph targets or other deformers to the clothing in the Pose Room.** For example, if you added magnets or applied a morph that raises or lowers the hem of a skirt, you can check the Preserve Deformations option to bring the skirt into the Fitting Room with that length.

   **Uncheck the Zero Figure option for the Object if you have made any rotation adjustments to the clothing to match the default pose of the character,** as discussed in *Adjust Scale, Position, and Rotation*. It is standard practice for content developers to zero their figures (scale, position, and rotation) and then memorize those settings before saving the item to the library. However, sometimes this step is omitted, which can result...
in a non-zeroed figure being saved to the library. Checking the **Zero Figure** option can address conformers that have not been zeroed before adding them to the library.

- **Goal**: Expand the Goal list to select the character that you want to fit the clothing to.

  Check the **Keep Deformations** option for the **Goal** if you applied morph targets or other deformers to the character in the Pose Room. For example, if you want to fit the clothing to a specific full body morph (such as Pregnant, or Body Builder) you can check this option to load the character into the Fitting Room with that body shape instead of the default body shape.

  Uncheck the **Zero Figure** option if you have made any rotation adjustments to the figure.

4. Click **OK**. The clothing and character will appear in the Fitting Room as Poser unimeshes.

**Fitting Simulation Methods**

After you create your new Fitting Session, you’ll see five different simulation methods associated with it: **Prefit**, **Tighten**, **Smooth**, **Soft Features**, and **Rigid Features**. You can use each of these fitting methods singly, or in combination with each other to alter the fit of the clothing to fit the target character.

There are many controls and options that you see in common to all these method types:
Common method controls and options.

- **Method menu**: Allows you to choose one of five fitting methods that move the clothing in different ways to fit the clothing. You can use any of these methods singularly, or in combination with each other, to generate the new fit for the clothing.

- **Enable Method**: Enables or disables the currently selected fitting method. Uncheck this option if you do not want to use the currently selected method in the fitting session.

- **Weight**: Controls the strength at which the currently selected method will be applied to the clothing.

- **Display Weights**: Enables or disables the display of colored vertices that show you how much or how little the currently selected method is applied to each vertex in the object.

The Display Weights option shows and hides the display of colored vertices that show how strong the current method is applied.

**Tighten**

When you initially create a new fitting simulation, you’ll automatically be directed to the **Tighten** method by default. If you immediately press the **Fit** button in the upper section of the Fitting Room, you’ll be able to get an idea of which areas need to be worked on further.

Tighten options.
• **Pokethrough Margin**: The pokethrough margin controls the amount of distance between the figure and the clothing item. The default setting creates a sufficient amount of space between the two to ensure that there is no pokethrough when the figure is posed. Decreasing the setting will bring the clothing closer to the figure, but may introduce pokethrough when posing the figure. Increasing the setting will create more space between the figure and the clothing.

• **Exclude Goal Group**: Check this option to select a group that you want to exclude from the **Tighten** fitting method. This will create a new group in the clothing called `_clothing name_exclude`, where `_clothing name_` is the name of the clothing item that is assigned in the fitting session. Click the Grouping Tool icon to open the Group Editor. This allows you to choose or create groups on the goal (the character you are fitting to).

![Excluding goal groups.](image)

• **Paintbrush**: Click the Paintbrush icon to enable the vertex painting tools. Initially, all of the vertices in the clothing object appear with green color, which indicates that the **Tighten** method is applied at full strength. You can use the Paintbrush to reduce the effect in areas that you do not want to tighten as much.

**Prefit**

When you run a fitting simulation, the areas that you include in the **Prefit** method will be pulled inward or outward before the other fitting methods are calculated.

When you initially create a fitting simulation, it initially opens with the **Tighten** method controls displayed. A good way to determine areas where prefit might be required is to click the **Fit** button before you assign areas to prefit. Often you can add **Prefit** to the areas where the figure pokes through the clothing.
If there are areas in your clothing model that are separated from the main body (such as cuffs, pockets, collars, buttons, and such) it might be beneficial to perform the Prefit after you assign these items to other methods.

Adding the Prefit method to areas that do not fit properly after clicking the Fit button.

In order to use the Prefit method, you will need to create a Prefit Adjustment. To do so, click the New button in the Adjustment section. A new adjustment will be created and automatically named for you.

Click the New button to create a Prefit Adjustment.

After you create the Prefit adjustment, the following controls appear in the Fitting Sessions palette for the Prefit method:
Prefit options.

- **Delete**: Click this button to delete the currently selected Prefit adjustment.

- **Set Weight**: Controls the weight at which the current Prefit adjustment will be applied to the clothing. A setting of 1 applies the method at its full strength.

- **Paintbrush**: Click the Paintbrush icon to enable the vertex painting tools.

- **Object Surface Normal**: Moves the clothing vertices that you add to the Prefit method inward or outward based on the direction of the normals in the clothing item.

- **Goal Surface Normal**: Moves the clothing vertices that you add to the Prefit method inward or outward based on the direction of the normals of the character that you are trying to fit.

- **Direction indicator**: Moves the clothing vertices that you add to the Prefit method inward or outward in a specific direction. Drag the circular indicator around the globe to specify the direction of the prefit.

---

The Weight setting in the Prefit method controls the amount that the clothing will be moved during the Prefit method. The Direction indicator gives you a visual indication of this setting as you adjust the Weight setting. Adjust the Weight setting until the Direction indicator displays the amount at which you want the clothing to move in that direction.
The Weight setting will resize the direction indicator to display how much the Prefit method will move the clothing.

- **Reverse directions**: By default, the Prefit method will pull clothing vertices away from the character during the Prefit calculations. Check Reverse Directions to pull clothing vertices toward the character instead.

**Smooth**

The Smooth method blends the vertices of the fitted clothing to reduce the amount of hard transitions. When you choose the Smooth method, you’ll notice that all vertices are smoothed at maximum value (all appear green). Therefore, if you need to make any changes to Smoothing, it will be to reduce the effect of smoothing where you paint.

**Smooth options.**

- **Paintbrush**: Click the Paintbrush icon to enable the vertex painting tools.

In cases where clothing is modeled in multiple parts, it may be necessary to reduce smoothing in those areas. For example, the shirt we are working on here has a cuff that is separated from the shirt. During smoothing, the cuff breaks away from the sleeve, creating a gap between the two parts. After enabling the paintbrush, the Subtract brush is used to paint the area between the sleeve and the cuff, which prevents the separation from occurring during the smoothing phase. Paint one side, and then use the Mirror feature to copy the weights to the opposite side.
If portions of your model are modeled separately, reduce smoothing between separated parts to prevent them from separating during the smoothing process.

Soft Features

The Soft Features method is used for areas that are flexible, but which you want to maintain the overall shape as it moves more closely to fit the figure. Examples of soft features are pockets, collars, seam lines, hem lines, folds, wrinkles, and so on.

When you switch to the Soft Features method, you’ll see vertices that are variously colored. Poser takes a “best guess” at the areas where the Soft Features method will be applied by analyzing charges in the polygonal density and changes in the surface normals.

**Soft Features options.**

- **Auto-Generate Weight Map**: Use the Auto-Generate Weight Map controls as follows to adjust the Soft Features map
  - **Threshold**: Poser initially generates a Soft Features map based on the default threshold setting of 20. Increase the threshold to add more vertices to the Soft Features vertex map.
  - **Generate**: After you adjust the threshold setting, click the Generate button to update the Soft Features vertex map based on the new threshold value. Auto-generating a Soft Features vertex map.

- **Paintbrush**: Click the Paintbrush icon to enable the vertex painting tools. When painting a Soft Features vertex map, focus on areas where you want the shape to be retained as the clothing is fit to the figure. The following figure shows additional Soft Feature method added to the collar, and the result after the Fit is run.
If you want to assign specific areas of the clothing to **Soft Features**, it will be much easier to do if your clothing object has different material zones in it. For example, if a shirt has separate collar and cuff materials, it will be easy to select them by material and add all vertices in those materials to the Soft Features method.

To do this, click the Paintbrush to open the Vertex Weights palette. Enable the **Restrict To** option, and then choose **Materials** > followed by the material name you want to assign to the Soft Features method.

After that you can either use the paintbrush to Add weight to the vertices in that group, or click the Set All button to ensure that all vertices in that selected material are set to 1.

You can set all vertices in a selected material to 1 to add them to the Soft Features group.

Repeat this for other material zones that you want to assign.

**Soft Features strength added to the shirt collar.**

**Rigid Features**

Use the Rigid Features method on areas where you want to retain the shape when the clothing is fitted to the character. Examples of Rigid Features would include buttons, buckles, clasps, and other similar items. There is only one option for Rigid Features:

- **Paintbrush**: Click the Paintbrush icon to enable the vertex painting tools.
Unlike the Soft Features method, initially there are no vertices assigned to the Rigid Features method. However, you can select vertices by material as described in the Soft Features section. In the case of this shirt, you would check the Restrict To option, and select the Button material to assign them to the Rigid Features method as shown in the following figure.

![Rigid Features options](image)

Then click the **Set All** button and click **Set All** to 1 to assign the buttons to the **Rigid Features** method.

![Buttons are set to the Rigid Features method](image)

### Painting Vertex Weights

When you click the **Paintbrush** icon in the Fitting Room, it opens the Vertex Weights palette shown in the following figure.
The settings and options in the top section of the Vertex Weights palette are as follows:

- **Subtract**: Use the Subtract brush to remove or reduce the weight of the vertices that you paint.
- **Add**: Use the Add brush to increase the weight of the vertices that you paint.
- **Smooth**: Use the Smooth brush to blend transitions between adjacent areas that have wide variations in the amount of weight applied to them.
- **Weight**: Use the Weight brush to paint with a specific weight value, as entered in the Weight field.

The middle section of the Vertex Weights palette contains five different brush styles, ranging from a very small brush designed to paint single vertices to other brushes that have varying degrees of softness around their edges. In addition, the following additional settings appear here:
Use the harder edge brushes to paint vertex weight on circular objects like round buttons, scale brush size to match the diameter of the button, then set a relatively high magnitude, center the brush over the button and click to quickly paint that button geometry.

- **Radius**: Controls the size of the brush. Move the slider left or right to adjust the size, or enter a specific value in the Radius text box.

  You can increase or decrease the radius of the brush by .0005 each time you press the Up or Down arrow key. Press the Shift key while using the Up or Down arrow key to increase/decrease by .005.

- **Magnitude**: Controls the strength at which the effect is applied while you paint. Move the slider left to decrease the strength, or right to increase it. You can also enter a specific value in the Magnitude text box.

  You can increase or decrease the magnitude of the brush by .0005 each time you press the Left or Right arrow key. Press the Shift key while using the Left or Right arrow key to increase/decrease by .005.

- **Group**: Check the Group option to isolate the effects of the painting to a specific group. Then select the group from the drop-down menu.

- **Invert Colors**: Check this option to reverse the color display of the vertices, so that vertices with low values will be displayed green, and vertices with high values will be displayed with darker colors.

The bottom section of the Vertex Weights palette contains controls that allow you to mirror, copy, paste, and set vertices to specific weights.

**Mirror, Set, and Copy/Paste weights.**
Completing the Fitting Simulation

You can run the fitting simulation any time during the fitting process to test how the various methods are working on the clothing item. You will also need to run the fitting simulation after you complete your fitting, in order to generate the clothing item that fits the character.

The controls to run the simulation and generate the final piece of clothing are at the top of the Fitting Simulation palette.

- **Mirror**: Allows you to copy weight painting from one side of a model to another. This helps save time, by allowing you to paint one side of a model and then mirroring the same values to the other side of the model.

- **Set All**: Allows you to set all vertices to 0, to 1, or to the value that you have entered in the Weight section in the top of the Vertex Weights palette.

- **Copy/Paste**: Provides commands that allow you to copy and paste weight values between objects.

### Controls for finalizing the fitting session.

- **Fit**: Click the Fit button to run the fitting simulation. You can do this at any time during the fitting process to check how each fitting method affects the clothing. You’ll also need to do it before you spawn a prop or create the clothing figure to fit your specific figure.

- **Reset**: Clears the results of the fitting simulation from the clothing. This returns the clothing back to its default shape and position.

- **Iterations**: The number of times that fitting calculations are repeated to achieve the fit. Higher values take longer but can provide a more accurate fit.

- **Spawn Prop**: Click this button to create a prop based on the current shape of the clothing. You will be prompted to enter a name for the new prop. The new prop will appear in the Pose Room, but will not be rigged to conform to the figure.

- **Create Figure**: Click this button to create a new conforming figure based on the current fit. The steps are as follows:
  - The New Figure dialog prompts you to enter a name for the new conforming figure.
  - The Transfer Figure dialog appears. Use the Hierarchy List to check or uncheck the body parts that you want to keep in the figure.
Check the **Keep Morphs** option to add character morphs to the clothing.

- If you want to transfer morphs from the character to the clothing, check the **Transfer Morphs** option.

- Check the **Auto Group** option if you want to regroup the clothing to match the groups in the figure. If you have already added the correct figure groups using another means, you can uncheck the option to preserve the existing groups.

- Check the Zero Rotations option to set all rotations for each body part to zero. The results will be the same as what you achieve when you zero a figure after conforming new clothing to a figure.

- Then click the **Select** button to choose the morphs that you want to transfer to the clothing.

---

When you return to the Pose Room, conform the clothing to the figure. Then with the Body actor selected on the clothing, switch to the **Properties** palette. Check the **Include Morphs** option in the When Conforming section of the **Properties** palette so that the clothing will automatically fit when you adjust the character’s morphs.

---

The fitted shirt.
• Check the **Auto Group** option to group the clothing based on the groups in the figure. Uncheck this option if you want to use other methods to add groups to the clothing.

• When you switch to the Pose Room you’ll see your new clothing item. Select it, and then choose the **Figure > Conform To** command to conform it to your character.

> The original version of the clothing will still appear in the scene. You can safely delete the original version without affecting the copy that is in the Fitting Room.
Content Creation Tools
Using Deformers

Poser’s deformers (magnets, force fields, waves, morphs) shape body parts, props, and figures into new and interesting forms. You can stretch a nose, make a belly bounce with a walk, make hair and clothing blow in the wind, and create almost any body shape you can imagine. You can animate deformer settings and positions, allowing you to create (for example) gusting winds (force field), bulging muscles (morph targets), etc. The Wave, Force Field, and Magnet deformers can also create custom morph targets.

Deformers can be linked to joint rotations or other parameters using the Dependent Parameters Editor. Refer to Using Dependent Parameters for more information.

As the name implies, deformers (morph targets, parameters, force fields, and magnets) affect the shape of figures and props within your scene.

Legacy Poser figures created prior to weight-mapped figures utilize deformers to improve bending and joint performance.

Each deformer type is discussed in its own section later in this manual. Selecting Display > Deformers allows you to:

- **Display > Deformers > Show All**: Show all deformers (magnets, waves, and force fields) in your scene (Display > Deformers > Show All).
- **Display > Deformers > Hide All**: Hides all deformers in your scene.
- **Display > Deformers > Show current selection only**: Only shows the currently selected deformer.

A check mark appears next to the currently selected deformer display mode. You can select hidden deformers using the Current Actor pull-down menu. Hiding some or all deformers can reduce clutter, particularly in complex scenes.
Magnets

Magnets distort objects by stretching them. You can use the Rotate, Twist, Translate, and Scale tools on magnets. Please see The Editing Tools for information on using the Editing tools. Here’s an example of a sphere deformed by a magnet:

When the magnet is translated and scaled, the head is reshaped accordingly.

Creating Magnet Deformers

To create a magnet, select the object you wish to deform then select Object > Create Magnet. This creates three Magnet objects, which together comprise the deformer.
Poser Reference Manual

Creating Magnet Deformers

The three parts are:

- **Magnet Object**: The Magnet Object defines the behavior of the actual magnet.
- **Magnet Base**: The Magnet Base defines the zero point of the area to be deformed. Moving the Magnet Base moves the Magnet Object as well.
- **Magnet Zone**: The Magnet Zone defines the area being deformed. You can move and shape the Magnet Zone to suit your needs.

Magnets work by deforming the area within the Magnet Zone along the axis defined by the Magnet Base and Magnet Object in an amount dependent on the distance between the Magnet Object and the Magnet Base.

**Using Editing Tools with Magnet Objects**

To use Editing tools on a Magnet Object, select the magnet in the **Current Actor** pull-down menu, then select your desired Editing tool.

- **Rotate**: The Rotate tool rotates the Magnet Object around its three axes.
- **Twist**: The Twist tool rotates the Magnet Object along its own axis.
- **Translate/Pull**: The Translate/Pull tool moves the Magnet Object horizontally or vertically.
- **Translate In/Out**: The Translate In/Out tool moves the Magnet Object in or out from the center of the Poser workspace.
- **Scale**: The Scale tool increases or decreases the size of the Magnet Object.

**Magnet Deformer Properties**

Magnet Objects, Magnet Bases, and Magnet Zones have properties that you can edit using the Properties palette.
Magnet Object Properties

Magnet Objects have the following properties:

- **Name**: The Name property allows you to rename the Magnet Object by entering your desired name in this field.

- **Visible**: The Visible checkbox toggles visibility on and off. Checking the box makes the object visible, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See [Figure Properties](#) for information on animating the Visible property.

- **Use Simple Transforms**: This property is off by default. When the setting is off,
  - This property corresponds to the `transformPerVertex` setting on the magnet. When this option is unchecked, Poser interpolates between the final vertex positions. When the option is checked, Poser interpolates transitions and rotations per vertex.

- **Add element to deform**: Checking the Add element to deform button opens a hierarchy list, allowing you to select added elements to be deformed by the Magnet. This only works if the selected element(s) are within the Magnet Zone.
Magnet Object Parameters

Magnet Objects have the following parameter dials in the Parameters palette:

![Magnet parameters](image)

- **Scale**: The Scale parameter dial increases or decreases the size of the Magnet Object in all axes.

- **XYZScale**: The xScale, yScale, and zScale parameter dials increase or decrease the size of the Magnet Object in the selected axis.

- **XYZRotate**: The xRotate, yRotate, and zRotate parameter dials rotate the Magnet Object around the selected axis.

- **XYZTran**: The xTran, yTran, and zTran parameter dials move the Magnet Object along the selected axis.

Magnet Base Properties

Magnet Bases have the following properties:
Magnet Base properties.

- **Name**: The Name property allows you to rename the Magnet Base by entering your desired name in this field.

- **Visible**: The Visible checkbox toggles visibility on and off. Checking the box makes the object visible, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See Figure Properties for information on animating the Visible property.

- **Display Origin**: The Display Origin checkbox displays the Magnet Base’s axes. This is useful because translations, rotations, etc. occur based on the Magnet Base’s axes, not the Poser workspace’s. See the Figure and Prop Editors for a discussion about local vs. global coordinates.

- **Casts Shadows**: Checking the Casts Shadows checkbox forces the selected body part to cast a shadow, which will be visible in your scene. Clearing this box means the selected body part casts no shadow.

- **Set Parent**: Clicking the Set Parent button allows you to make the Magnet Base a child of another element in your scene. Please refer to Poser File Types for a description of hierarchical relationships and to Changing a Parent for information on setting parents.

- **Load Morph Target**: Clicking the Load Morph Target button displays the Load Morph Target dialog, allowing you to load a custom morph target for the selected force field (which is then editable using the Morphing Tool as described in Creating Morphs with the Morphing Tool).

Magnet Zone Properties

Magnet Zones have the following properties:
Setting the Magnet Zone’s display style to Wireframe can help make it more visible in your Document.

Magnet Zone properties.

- **Name**: The **Name** property allows you to rename the Magnet Zone by entering your desired name in this field.

- **Visible**: The **Visibility** checkbox toggles visibility on and off. Checking the box makes the object visible, and vice versa.

- **Group**: Checking the **Group** checkbox enables grouping, allowing you to deform a grouped portion of the selected element(s). You can create groups to deform, and groups can consist of portions of one or more body parts, props, etc. Please see The Group Editor for information on using the Grouping tool. A group is selected when a checkbox appears next to the group listing.

- **Set Parent**: Clicking the **Set Parent** button allows you to make the Magnet Zone a child of another element in your scene. Please refer to Poser Figures Hierarchy for a description of hierarchical relationships and to Changing a Parent for information on setting parents.

- **Edit Falloff Graph**: Clicking the **Edit Falloff Graph** button allows you to edit the Magnet Zone’s Falloff graph, which determines where the deforming area ends or falls off. Please see Magnet_Zone_Falloff_Graph for information on using this graph.

- **Use Weight Map**: Check this option to use a weight map to control the amount that the vertices are affected. Click the Paintbrush icon to open the Vertex Weights palette so that you can edit the magnet zone weight map. Vertices in the weight map are initially set to 100% strength. The controls in the Vertex Weights palette are described in Painting Vertex Weights.

**Magnet Zone Falloff Graph**

Selecting **Edit Falloff Graph** in the Magnet Zone **Properties** palette opens the Magnet Zone Falloff window.
The left side of this graph depicts the center of the Magnet Zone, and the right side is its edge. By default, a smooth curve appears, meaning that the magnet’s influence gradually tapers off towards the edges of its zone. By adjusting this curve, you can alter the falloff properties.

The effects of a magnet zone can be shaped with a graph.

To move control points click and drag them up and down. Raising a control point increases the magnet zone’s influence at the location. To add control points, click any spot along the curve. You cannot remove added control points.

**Locking Magnets**

You can lock magnets to prevent accidental changes. Please refer to [Lock Object](#).

**Using Magnets with Weight Maps**

Poser provides features that allow you to paint weight maps on magnets. This feature allows you to define the areas that the magnet will affect with greater precision and flexibility than that offered with the graph editor.

Magnets are hidden by default in the Rex and Roxie CR2’s.

Weight mapped magnets can be used to improve bending when a joint, such as a shoulder, is raised or lowered. The falloff zone for the magnet can affect as few or as many vertices in the geometry as you choose, and you can control the strength at which the vertices are affected. This approach gives you more precise and specific results over using the graph editor that is discussed in [Magnet_Zone_Falloff_Graph](#).
The following figures demonstrate how a weight-mapped magnet works. In this example, a magnet has been added to Rex’s right shoulder to control the shape of the shoulder when it is rotated upward.

![Magnet added to right shoulder.](image1)

After adding the magnet, the magnet zone is set up to use weight maps. The Poser weight painting tools are used to paint specific vertices that the magnet will affect, and the strength at which they will be affected. The following figure, showing the body part in Hidden Line display mode, shows an example of the vertices that are painted on the upper and lower sections of the shoulder.

![Weight map for the magnet.](image2)

If the joint is rotated while painting the weight map, it helps the designer determine how the changes affect the body part as the joint is exercised. The following figure shows the shoulder rotated to the same angle as the previous Hidden Line view.
Adding Weight Maps to Magnets

Select the right collar, and choose **Object > Create Magnet**.

Choose the magnet base and move it into position.
Scale and move the magnet base into position beneath the breast.

Scale the magnet zone up and move it into position.

Select the magnet, and switch to the Properties palette. Click the Add Element to Deform button, and then add the Chest as an element to deform.
Select the magnet and add the Chest as an additional element to deform.

If you need to exclude groups that you have added to a magnet, select the magnet zone and switch to the Properties tab. The Group option allows you to check groups that will be affected by the magnet zone. Any unchecked group will not be affected. Choose a group once to place a checkmark, and a second time to remove an existing checkmark. For more information about magnet zone properties, see Magnet_Zone_Properties.

Next, select the magnet zone and check the **Use Weight Map** option in the Properties palette. Then click the Paintbrush icon to open the weight painting palette. Initially, all of the vertices on the right collar and the chest will display in green, indicating that the weight map values are all at full strength.
Enable the weight painting options for the magnet zone.

Use the **Subtract** brush to paint out the areas that you don’t want the magnet to affect. This allows you to define the affected area with great precision. It is helpful to view the figure in Hidden Line display mode while you paint the vertices. Also be sure to move the magnet across the range of motion that you want the magnet to affect. In other words, if you want the magnet to raise the breast, translate the magnet on the Y axis. You may find that some areas will need to be smoothed to create a nice blend between the affected and unaffected vertices.

**If you have multiple groups included in the items to deform, you can also use the Restrict To features in the Vertex Weights palette to paint on one or more of those groups at a time. Check the Restrict To option and choose By Group to select one or more groups to paint on.**

**If you are working with a magnet on a body part that contains multiple materials (for example, a head that also has lip, eye socket, teeth, and so on), you can click the Restrict To option in the Vertex Weights palette to restrict weight painting to only those materials that you add to the restriction list. Select one material at a time until all materials are added to the list.**
Paint and smooth the weight map to affect the areas that you want the magnet to affect.

The breast adjusted with the weight-mapped magnet.

Now select the left collar, and create a new magnet. Position and scale the magnet base and magnet zone using the same values as the right breast (except for the X translations, which should be negative values on the right breast and positive values on the left breast).

Create a magnet for the left collar, scaling and positioning them the same as the right collar (except X translation settings are positive).

Select the new magnet and add the Chest as an element to deform, just as you did for the right collar magnet.

Now select the magnet zone for the right collar (the first one you created). In the Properties palette, click the Paintbrush icon to open the Vertex Weights palette. Click the Copy/Paste
button at the bottom of the palette, and choose **Copy** to copy the weight map into your clipboard.

*Copy the weight map from the right collar into your clipboard.*

Use the Select Actor menu in the **Properties** palette to select Magnet Zone 2 (the zone for the left collar).

*Select the second magnet zone from the Properties tab menu.*

Click to activate the paintbrush for **Magnet Zone 2**, and then click the **Copy/Paste** button again. This time, choose **Paste Mirrored > X Axis** to mirror the weight map from the right breast over to the left breast.
Paste the weight map in the clipboard, mirrored on the X axis.

The final result.

**Animating Magnet Zones**

Select the right forearm and create a magnet using the Object > Create Magnet command.
Create a magnet on the right forearm.

Select the magnet base, and then scale and position the magnet over the right forearm. Then scale and position the magnet zone to surround an area along the top of the forearm.

Scale and position the magnet base and magnet zone.

Select the magnet, and raise it along the Y axis to create a bump in the forearm.

Scale and position the magnet base and magnet zone.

With the magnet selected, switch to the Properties palette. Click the Add Element to Deform button for each body part that you want the magnet to affect. Repeat this step to assign the Right Hand, Right Shoulder, Right Collar, and Chest.
For the magnet, add (one at a time) the Right Hand, Right Shoulder, Right Collar, and Chest as elements to deform.

Go to the first frame in your project. Select the magnet zone, and move it into position over the right hand. Then go to frame 30 (or the last frame in your animation), and move the magnet zone over the shoulder.

Position the magnet zone on the first and last frames of your animation.

As the animated joint zone passes over the affected body parts, you’ll see the bump affecting the actors that you assigned as affected actors. The bump will affect the hand, then the forearm, the shoulder, the right collar, and the chest over the course of the animation.

**Wind Force Fields**

Selecting **Object > Create Wind Force** creates a wind force field that ads realistic wind to your scenes. Force fields affect strand-based hair and dynamic cloth.
You can position force fields using the Editing tools just as you would any other prop.

**Force Field Properties**

Force fields have the following properties, available in the Properties palette:
• **Internal Name**: The *Internal Name* field displays the force field’s internal (hidden) name, which Poser uses to track that part. You cannot edit a force field’s internal name within Poser.

• **Name**: The *Name* field displays the force field name. Enter a new name in this field if you desire.

• **Visible**: Checking the *Visible* checkbox makes the force field visible and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See *Figure Properties* for information on animating the Visible property.

• **Visible in Raytracing**: Checking the *Visible in Raytracing* checkbox makes the force field visible in raytraced reflections, such as if the figure is in front of a mirror. Clearing this checkbox makes the force field not appear in reflections.

• **Casts Shadows**: Checking the *Casts Shadows* checkbox forces the selected force field to cast a shadow, which will be visible in your scene. Clearing this box means the selected force field casts no shadow.

• **Visible in Camera**: When checked, the object is visible in the camera and render. When unchecked, the object does not render. Used in conjunction with *Light Emitter*, described previously, to create light-casting objects.

• **Light Emitter**: When checked, allows the object to be included in indirect lighting calculations so that light will bounce off the object. When unchecked, indirect lighting calculations are skipped for the object. This allows you to create objects such as illuminated light domes, which can have high ambient values that will cast light, but that can also be turned off and not rendered.

• **Collision detection**: Checking the *Collision Detection* checkbox enables collision detection for the currently selected force field. Please refer to *Collisions* for more information about collision detection.

• **Apply Collision Setting to Children**: Clicking the *Apply Collision Setting to Children* button applies the currently selected force field’s collision detection setting to that part’s children parts (if any).

• **Load Morph Target**: Clicking the *Load Morph Target* button displays the Load Morph Target dialog, allowing you to load a custom morph target for the selected force field, which is then editable using the Morphing Tool. Please refer to *Creating Morphs with the Morphing Tool* for more information about loading morph targets.

• **Set Parent**: Clicking the *Set Parent* button allows you to make the force field a child of another element in your scene. Please refer to *Poser Figures Hierarchy* for a description of hierarchical relationships and to *Changing a Parent* for information on setting force field parents.

• **Displacement Bounds**: The *Displacement Bounds* property determines the force field’s displacement boundary. Please refer to *Using The FireFly Render Engine* for more information about displacement bounds.

• **Shading Rate**: The *Shading Rate* allows you to specify the desired shading rate for the currently selected force field. Please refer to *Using The FireFly Render Engine* for more information about shading rates.
• **Smooth Polygons**: Checking the **Smooth Polygons** checkbox causes Poser to smooth the object polygons at render time to eliminate or reduce a “faceted” appearance caused by flat polygons. This option can cause sharp corners to appear round. If the object has sharp edges that you wish to preserve while applying polygon smoothing to other angles, you should specify those sharp edges using smoothing groups or the crease angle threshold, as polygon smoothing will not override these settings. See **Smoothing Geometry** for more information on specifying hard versus smooth edges.

• **Display Origin**: Checking the **Display Origin** checkbox displays the force field’s origin. Please refer to **The Prop Origin** for more information about force field origins.

• **Subdivision Levels**: Allows you to subdivide the selected object. See **Working with Subdivision Surfaces** for more information.

• **Remove Backfacing Polygons**: Determines how back-facing polygons are displayed on the selected object:
  
  • **Obey Global Setting**: Uses the setting that is configured in the **Render Settings** dialog.

  • **Force Show Backfacing Polys**: Backfacing Polys will always be shown in the currently selected object.

  • **Force Hide Backfacing Polys**: Backfacing Polys will always be hidden in the currently selected object.

To animate the location of the wind force field, click to make it the current object. Open the Joint Editor to the Center attribute. Click the animation key beside the Center Point or the Orientation to animate those values. When the key is solid, animation is enabled for that property. The key is faded when disabled.

**Force Field Parameters**

Force fields have the following parameters, available in the **Parameters** palette:
Wave Deformers

Wave deformers distort objects by creating wave paths. You can use the Rotate, Twist, Translate, and Scale tools on wave deformers. Please see The Editing Tools for information on using the Editing tools. Here’s an example of a sphere deformed by a wave.
Creating Wave Deformers

To create a wave, select the object you wish to deform then select **Object > Create Wave**. This creates two Wave objects, which together comprise the deformer. The two parts are:

- **Wave Object**: The Wave Object defines the behavior of the actual wave.
- **Wave Zone**: The Wave Zone defines the area being deformed. You can move and shape the Wave Zone to suit your needs.

Using Editing Tools with Wave Deformers

To use **Editing** tools on a Wave Object, select the wave in the **Current Actor** pull-down menu, then select your desired Editing tool.

- **Rotate**: The **Rotate** tool rotates the Wave Object/Zone around its three axes.
- **Twist**: The **Twist** tool rotates the Wave Object/Zone along its own axis.
- **Translate/Pull**: The **Translate/Pull** tool moves the Wave Object/Zone horizontally or vertically. This does not affect the Radial wave.
- **Translate In/Out**: The **Translate In/Out** tool moves the Wave Object/Zone in or out from the center of the Poser workspace.
- **Scale**: The **Scale** tool increases or decreases the size of the Wave Object.
Wave Object Properties

Wave Objects and Zones have properties that you can edit using the Properties palette.

Wave Objects have the following properties:

- **Name**: The Name field allows you to rename the Wave Object by entering your desired name in this field.

- **Visible**: The Visible checkbox toggles visibility on and off. Checking the box makes the object visible, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See Figure Properties for information on animating the Visible property.

- **Radial Wave**: Checking the Radial Wave radio button causes the wave to spread from its origin like ripples in a pond.

- **Directional Wave**: Checking the Directional Wave radio button causes the wave to spread in a linear fashion. The following two properties control the direction.

- **Deformer Aligned**: Checking the Deformer Aligned radio button cause waves to propagate along the direction of the Wave Object.

- **Object Normals**: Checking the Object Normals radio button cause waves to propagate along the affected object’s normals.

- **Add element to deform**: Clicking the Add element to deform button opens a hierarchy list, allowing you to select added elements to be deformed by the wave. This only works if the selected element(s) are within the Wave Zone.

Wave Zone Properties

Wave Zones have the following properties:
Wave Zone properties.

- **Name**: The **Name** field allows you to rename the Wave Zone by entering your desired name in this field.

- **Visible**: The **Visible** checkbox toggles visibility on and off. Checking the box makes the object visible, and vice versa. Invisible objects are not included in any render calculations, and do not appear in the rendered scene. See Figure Properties for information on animating the Visible property.

- **Group**: Clicking the Group button allows you to deform a grouped portion of the selected element(s). You can create groups to deform, and groups can consist of portions of one or more body parts, props, etc. Please see The Group Editor for information on using the Grouping tool. A group is selected when a checkbox appears next to the group listing.

- **Set Parent**: Checking the **Set Parent** button allows you to set a parent object for the Wave Zone. Please refer to Changing a Parent for information about parenting objects.

- **Edit Falloff Graph**: Clicking the **Edit Falloff Graph** button allows you to edit the Wave Zone’s Falloff Graph, which determines where the deforming area ends or falls off. Please see the following topic for information on using this graph.

  Setting the Wave Zone’s Display Style to Wireframe can help make it more visible in your Document Window.

- **Use Weight Map**: Check this option to use a weight map to control the amount that the vertices are affected. Click the Paintbrush icon to open the Vertex Weights palette so that you can edit the wave zone weight map. Vertices in the weight map are initially set to 100% strength. The controls in the Vertex Weights palette are described in Painting Vertex Weights.

- **Wave Zone Falloff Graph**: Clicking the **Edit Falloff Graph** button in the Wave Zone Properties opens the Wave Zone Falloff window, which appears and functions in the same manner as the Magnet Falloff Graph depicted in Magnet_Zone_Falloff_Graph.
Wave Deformer Parameters

Wave deformers can use the following parameter dials in the Parameters palette:

Wave Deformer parameters.

First, there are certain parameter dials that are only available for waves:

- **Phase**: The Phase parameter dial defines the position of the wave in infinite time. Use this parameter when animating waves.

- **Amplitude**: The Amplitude parameter dial defines the wave’s height.
Using Deformers with Grouped Objects

You can create custom groups using the Group Editor palette as described in The Group Editor and apply deformers to these groups. Groups can contain parts of one or more body parts/props. You can select these groups by name using the Properties palette for selected magnets or waves. To apply a deformer to a group:

Select the body part/prop containing the group.

1. Create the deformer as described above.

2. Select the deformer’s Zone and access that zone’s properties as described above. Check the Group checkbox, then select one or more groups from the pop-up that appears. A group is selected when a checkbox appears next to it.

This procedure deforms on the grouped sections of body parts/props.

The following common parameters also apply to Wave objects:

- **Wavelength**: The Wavelength parameter dial defines the distance between wave crests (frequency).
- **Stretch**: The Stretch parameter dial controls the sharpness of each wave.
- **Amp Noise**: The Amp Noise parameter dial defines the randomness or noise of the wave’s amplitude.
- **Freq Noise**: The Freq Noise parameter dial defines the randomness or noise of the wave pattern’s frequency.
- **Sinusoidal**: The Sinusoidal parameter dial defines the size of the sine wave pattern.
- **Square**: The Square parameter dial defines the shape of the wave pattern. Increasing this value creates square-shaped waves.
- **Triangular**: The Triangular parameter dial defines the shape of the wave pattern. Increasing this value creates triangle-shaped waves.
- **Turbulence**: The Turbulence parameter dial defines the roughness of a wave pattern. Increasing this value creates jagged, turbulent waves, and vice versa.
- **Offset**: The Offset parameter dial defines if the wave’s pattern is above, on, or below the wave’s origin. Increasing this value brings the wave pattern above the origin. This is helpful if, for example, you want to keep clothing from deforming the underlying figure.

**Using Deformers with Grouped Objects**

- **Scale**: Increases or decreases the size of the Wave Object in all axes.
- **XYZScale**: The xScale, yScale, and zScale parameter dials increase or decrease the size of the Wave Zone in the selected axis. This is only available for the Wave Zone.
- **XYZRotate**: The xRotate, yRotate, and zRotate parameter dials rotate the Wave Object around the selected axis.
- **XYZTran**: The xTran, yTran, and zTran parameter dials move the Wave Object along the selected axis.
Modifying Figures & Props

This chapter explains how to create completely custom looks for your figures and props. For example, human bodies come in all shapes and sizes. You can modify proportions using various tools to achieve interesting effects.

A figure’s head reshaped by a magnet.

Poser includes a wide variety of tools for figure/prop shaping. Here are some tips, tricks, and important things to keep in mind when editing figures and/or props:

• All Poser figures come with morph targets and full body morphs, allowing you to reshape one or more body parts. You can find more information about creating morphs in Creating Morphs with the Morphing Tool and Creating Morphs in Other Applications.

• You can use the Grouping tool (see The Group Editor) to create cloth, hair, or other groups. You can also deform polygon groups as mentioned in Using Deformers with Grouped Objects. The Grouping tool is located in the Editing tools display.

• The Scale and Taper tools can change a body or element’s shape. The Scale and Taper tools are located in the Editing tools display.

• Deformers (magnets, force fields, and waves) can also alter shapes. See Using Deformers.

• You can replace body parts with props (see Replacing a Body Part with a Prop).

• You can save your work to the Library palette.

• You can modify entire figures or individual body parts. For example, enlarging the abdomen can create a beer belly. Widening the head broadens the face. Shaping figures is easiest when the figure is in its default pose where you can clearly see the results of each of your actions.

• You may want to hide the other figures and props in your scene for an uncluttered view.
Creating Morphs with the Morphing Tool

Morph targets are custom parameters added to body parts or props that allow you to reshape the affected part(s). Poser includes some built-in morph targets with the stock figures, and you can create your own. Morph targets allow you to easily resize and reshape items and are fully animatable.

![Faces reshaped with the Morphing Tool.](image)

As you finish shaping and posing each body part, you can lock it as described in Lock Object. And, once you’ve posed your figure, you can guard against accidental changes by locking the entire figure as described in Lock Figure.

Symmetry can be a huge time saver, allowing you to pose half your figure and apply the pose to the other side. Please refer to Pose Symmetry for information about using Symmetry. Also, try using cutting and pasting to apply poses across multiple figures.

If your computer can support it, we recommend enabling Full Tracking mode (see Tracking Mode) so you can view your work in real time. This does require extra computing resources, which can affect performance depending on your computer’s specifications and the complexity of your scene.

Creating Morphs with the Morphing Tool

Morph targets are custom parameters added to body parts or props that allow you to reshape the affected part(s). Poser includes some built-in morph targets with the stock figures, and you can create your own. Morph targets allow you to easily resize and reshape items and are fully animatable.
The Combine Tab

The Combine tab on the Morph Editor allows you to visually sculpt your figures’ morph targets by clicking on a body part such as the head, then dragging the mouse to change the shape of that body part. The changes that you see are all based on the morphs that are already present in the body part. You can do this with any scene object that has morph targets.

The Combine tab has the following functions:

- **Morphing**: Clicking the Morphing button re-enables the Morphing Tool. Click this button after pinning vertices to resume adjusting morphs.

- **Pin**: Clicking the Pin button disables the Morphing Tool and allows you to pin one or more vertices as discussed above.

- **Clear Morphs**: Clicking the Clear Morphs button resets all morphs. Use this option with care as it will undo all of your changes, even if you exit and resume using the Morphing Tool.

- **Clear Pins**: Clicking the Clear Pins button removes all pins previously applied to the current object.

Elements found in the Morphing Tool Combine tab.
The Combine Tab

- **Exaggeration min/max**: Exaggeration refers to the degree to which a morph target’s value will affect the vertices. The **Exaggeration Min** and **Exaggeration Max** values limit the extent of a morph target’s possible effect when the Morphing Tool is operating. No morph target can be modified beyond these limits (see Editing Parameter Dials for more information about parameter dial limits). Increasing these limits therefore increases the exaggeration effects of all morph targets. For a technical description of **Exaggeration Min/Max**, see the following note.

  Mathematically, each morph target defines a displacement vector \( v \) on each object vertex, and its exaggeration value defines a multiplier \( w \). Thus, a morph target’s net effect is \( p + wv \), where \( p \) is the original vertex position. If \( w=1 \), we add \( v+p \). \( W \) can be any value. The larger \( w \) is, the more exaggeration this morph target’s effect has. The **Exaggeration Min** and **Exaggeration Max** values globally define the limits for \( w \) across all morph target weights when the Morphing Tool operates.

- **Lock All**: Clicking the **Lock All** button locks all morph targets, which disables morph-based shape changes. This is handy when you’re satisfied with your overall shape and only want to fine-tune a few specific morphs. In that case, you could use this option then unlock only those morphs you want to adjust.

- **Unlock All**: Clicking the **Unlock All** button unlocks all morph targets, allowing you to modify them.

To use the Combine tab:

1. Select the body part you wish to sculpt, then select the Morphing Tool. The Morph Editor palette appears. The Combine tab displays all of the morph targets available for the selected body part.

2. The list of morph targets is hierarchical and displays branches containing the available morph targets. Clicking the – icon next to an expanded branch collapses that branch, and clicking the + icon next to a collapsed branch expands that branch. You can also use the scroll bars to navigate the list. The Morph Editor will allow you to manipulate all selected morph targets. A green dot next to a morph target includes the specified morph target when using the tool, and a Lock icon means the specified morph target will not be affected by the tool. Even if a morph target is enabled, it may or may not be affected by your use of the tool. For example, selecting a vertex in the forehead may affect the eyebrows but will not affect the mouth. Select your desired morph target(s), then click and drag any vertex on the selected body part.
The Edit Tab

The Edit tab of the Morph Editor allows you to select and modify the mesh vertices to create new morph targets on a single body part or across joint seams to adjacent body parts. As with the Combine tab, you can apply the Edit tab functionality to any scene object that has a mesh.

Deformations made to the mesh while using the Edit tab can apply to the currently selected actor or to the entire figure. A parameter dial will appear only on body parts that are affected by the morph brush.

In addition to creating morph targets for individual actors, Poser also allows you to create Full-Body Morphs (FBMs). For more information about Full-Body Morphs, see Creating Full-Body Morphs.

3. Once you have a portion of the body part the way you want it, you can click the Pin button then click one or more vertices to pin them, preventing further manipulation as you work on other areas of the object. Pinned vertices appear as red dots on the current object and may move as you keep adjusting other portions of the body part (depending on how many morph targets affect the pinned vertex), however they will retain their current settings. Also, pins are retained if you stop using the Morphing Tool and resume using it later. To stop pinning vertices, click the Morphing button (see below). You may notice some trembling if you adjust morphs that affect pinned vertices.

A face before and after using the Morphing Tool.
To use the Edit tab:

1. Switch to the Edit tab in the Morphing Tool if necessary.

2. The morph tools in Poser’s Edit tab will initially be disabled. You will be prompted to select an existing morph or to create a new morph, after which the tools will be enabled.

   - To select an existing morph, click the arrow beside **Select or Create Morph**, and choose the morph that you want to modify. In the case of characters, you can choose between body (full body) morphs, or on individual body parts.

   - To create a new morph, select New. You will be prompted to assign a name for the new morph. You will also be prompted to check or uncheck an option to apply the morph before joint rotation. For more information about this feature, see [Applying Pre-Transform Morphs](#).
Choose New from the Custom Morph menu to create a new original morph.

You can also use the morph menu in Poser’s Parameters Palette to edit an existing morph. Click the arrow that appears to the right of the morph that you want to edit, and choose Edit Morph from the context menu. The morph palette will open to the Edit tab, with the morph pre-selected for editing.

3. After you name your new morph or select an existing morph, the name of the morph will appear at the top of the Edit tab. Set the value of the morph to 1 to begin editing.

Set the value of the morph to 1 while you are editing.

4. Click the icon for the action you wish to use to modify the vertices: Push, Pull, Flatten, Smooth or Restore. You can also choose one of the modes from the Action menu that appears just above the icons.

Vertex modification options in the Edit tab.

- **Push**: Selecting Push will enable you to push the vertices in the impact region inward from the original surface of the mesh, to create a concavity such as a dimple or a dent.

- **Pull**: Selecting Pull will enable you to pull the vertices in the impact region outward from the original surface of the mesh. This task is very useful for cleaning up any inappropriate intersections between the figure and either conforming or dynamic clothing; you can select a region of the cloth, and simply pull it out past the point of intersection with the figure.
• **Rotate**: With the **Rotate** tool, you can rotate or “twist” underlying vertices.

![Using Rotate brush. Before (left) and After (right).](image)

• **Flatten**: Takes all of the affected points and averages the plane that best fits through all those points. It then pushes all of the points to match that plane.

The following image shows an irregularly shaped object in three stages: The top image shows the object before it is flattened with the morph tool. The middle image shows the object after a couple of areas have been flattened with the Morph tool. The brush shape used no falloff (the last brush option) and was set to a large size. The third image shows the object after changing the Morph brush to Smooth, and then passed through the rough areas in the center.

![An irregularly shaped object (top); after flattening (middle) and then smoothed (bottom).](image)

• **Smooth**: With the **Smooth** option you can gradually reduce the amount of variation in the surface mesh, to create a smoother surface. This is particularly useful for surfaces with high frequency variations. Keep in mind that this option generally reduces definition.
• **Restore**: The Restore option gradually reverts your recent changes back towards the original unmorphed geometry state. This feature can be extremely useful in fine-tuning your modifications, as it allows you to back up recent changes by gradual degrees.

  Restore is not the same as Undo. If you make a change, and then select Edit > Undo, your entire change will be erased, and the mesh will revert to the state it was in before you made the change. By using Restore, you can revert the effects of your change gradually, thus allowing you to edit your modification without losing it completely.

• **Tighten Fit, Loosen Fit, and Sag**: See Using the Fitting Tools.

• **Screen (In/Out)**: Deforms the mesh relative to the screen, moving the vertices toward or away from you.

6. Select your desired brush style from the five circular brush style icons. Poser’s morph target creation feature uses a brush paradigm, which allows for varying degrees of precision when applying your modifications to the mesh. The left most brush style impacts only the closest single vertex to your mouse pointer, thus allowing for a great deal of precise control. The remaining brush styles all affect a region of the mesh. These regional brush styles have varying degrees of falloff; the modification will affect vertices within the impacted region to differing degrees, as determined by the falloff. For example, the second brush style from the left has a large falloff region, which means that while vertices at the center of the region will be strongly impacted by your modifications, the impact will decrease gradually over most of the other vertices within the impact region. The falloff area decreases with the next two brush styles, and the right-most brush style has zero falloff, so that all vertices within the region are impacted equally.

**Enabling the Display Brush option in the lower portion of the Edit tab will display a visual preview of the impact region. This preview is color coded to show the falloff effect: red indicates the area most strongly affected, yellow indicates less effect, and areas shown in green are the least affected within the impact region.**
7. Adjust the **Radius** dial to increase or decrease the size of the impact region. If you have enabled the **Display Brush** option, the visual preview will adjust automatically to indicate the current impact region radius.

```
You can also use the Left or Right arrow keys to adjust the radius of the brush.
```

![Adjusting the size of the Morph Brush.](image)

8. You may want to adjust the **Magnitude** dial to specify how much effect the **Morphing Tool** will have within the impact region. A high **Magnitude** setting will allow you to make large-scale dramatic changes, for faster workflow. A low **Magnitude** setting will allow you to make more precise, focused changes.

```
You can also use the Up or Down arrow keys to adjust the magnitude of the brush.
```

![Radius and Magnitude settings control the size and strength of the Morph Brush.](image)

```
We recommend that you start with a relatively low **Magnitude** setting to allow you to become accustomed to the **Morphing Tool**, and then gradually increase the **Magnitude** as needed.
```

9. By default, the Morphing Tool allows you to morph across multiple body parts. You can also restrict painting by group(s) or material(s). To do so, check the **Restrict To** option and expand the menu to select the group or material that you want to include in the restriction. You can repeat this to include more than one item in the restriction.
You can limit changes to group(s) or material(s) with the Restrict To options.

10. Enable or disable the following options to suit your requirements:

- **Average normals**: Maintains more detail of the underlying surface when Relative to Surface is selected. It averages the normals of all the affected vertices, instead of moving each affected vertex along its own normal.

- **Accumulate**: When Accumulate is enabled (checked), your change will continue to accumulate so long as you continue a single click-and-drag movement. This option allows you to make a greater degree of change with a single motion, but with less precision. When the Accumulate option is disabled (unchecked), each modification requires a separate click-and-drag operation. Use this setting for greater control over your modifications.

- **Stroke**: When the Stroke option is enabled (checked), the Morphing Tool will implement your modifications along the trajectory of your mouse movement. This allows you to “paint” deformations onto the surface of the mesh as you move your mouse across it. When Stroke is disabled, your mouse movements will adjust the degree of the deformation, while the effect of the modification applies to the original impact region only.

11. Once you have configured the Morphing Tool to your specific needs via the Edit tab, click and drag directly on the current actor to deform the mesh.

12. The Edit tab also contains the following Display options:

- **Display Brush**: The Display Brush option displays a visual preview of the region you will be impacting with your deformation. This preview uses different colors to indicate the degree to which each area of the impact region will be affected by your selected action. Specifically, red indicates the area most strongly affected, yellow indicates that an area is less strongly affected, and green areas are the least affected within the impact region. The Display Brush option is enabled by default. If you have elected to work on a single group rather than the entire figure, the brush will display only when it is over the group that is selected for editing.
The Morph Brush appears as multicolored vertices that represent strongest and weakest areas.

- **Work With Current Morphs**: When enabled, the **Work With Current Morphs** option allows you to visualize the current adjusted state of all other morph targets while you deform the mesh. This option is useful for creating a morph target that acts on top of another morph target.

  This setting is useful for understanding how your new morph target will interact with other existing morph targets.

- When disabled, the **Work With Current Morphs** option allows you to temporarily hide the effects of all other morph targets while working within the **Edit** tab. Using this option allows you to work on the mesh geometry in its neutral state, without losing the settings of your other morph targets. If you leave the **Edit** tab, those morph targets will automatically revert to their specified states.

- **Bake down for subdivision**: When working on morphs on subdivided figures, this allows any changes made at higher subdivision levels to also work at lower subdivision levels if the lower resolutions support the morph. For more information about subdivided morphs, see [Creating Subdivision Level Morphs](#).

You can use the following functions to save or reset your morph targets:

- **Mirror**: The **Mirror** button at the bottom of the **Edit** tab brings up a pop-up menu offering six options of different axes and directions for creating symmetrical changes on the currently selected object, for example “-x to +x” or “z to -z”. Note that these axes refer to the local coordinate system of the currently selected object only, and are not related to the world space coordinates of your Poser scene. Selecting one of these options will mirror morph target changes from one half of the currently selected object to another half of the same object, as defined by the axis and direction you selected from the menu.

  When you morph a body part that spans across the center, the -x to +x and +x to -x options should copy the morph from one side to its opposite side. If you created a morph on a body part that does not span across the center of
the figure (such as a right shoulder), use the Right to Left or Left to Right options to copy the morph to the opposite body part.

If the mesh topology of the actor across which you are attempting to mirror is not symmetrical, the mirror feature may not be able to successfully translate your morph target changes.

- **Zero Morph**: The **Zero Morph** button will reset the surface mesh to its undeformed state. Zero Morph will also clear any morphing tool changes (stored in the Custom Morph channel) that will generate at each body part and the figure level. If the Zero Morph button has been pushed, the channel will still exist but the morph data is removed. When working on subdivided morphs, you can zero the morph at the current level, or all levels. For more information about subdivided morphs, see [Creating Subdivision Level Morphs](#).

  This Custom Morph channel is used as a receptacle for morphing edits with the morphing tool. Save a Copy As is the best way to preserve that Custom Morph data for Full Body or individual body part morphs.

  The Zero Morph button only applies to the effects of your new morph target; all other morph target states will remain unchanged. Be sure to save a copy of your modifications before clicking the Zero Morph button if you do not wish to lose your changes.

- **Save a Copy As**: The **Save a Copy As** button will allow you to save the current state of the Custom Morph target to a new, separate morph target. You can use **Save a Copy As** to save incremental modifications as you work with the mesh, or to propagate your final modifications to the figure for future use.

  Full Body Morphs created using the **Save a Copy As** and the **Custom Morph** functions are traditional Delta Add morphs with values that change linearly with the a master parameter value. You can edit them using the dependent parameters editor, as mentioned in [Using Dependent Parameters](#). The Save a Copy As morph saves a channel to each body part, and also adds a parameter dial to the Body that drives all of the individual body part channels.

  The Custom Morph target is cumulative, in that any modifications you make will be made on top of the previous state of the morph target. Therefore, if you do not save your changes to a separate morph target using the Save a Copy As button, they will become incorporated into any figure changes, and you may have difficulty recovering that previous state.
Applying Pre-Transform Morphs

When you create morphs for Poser content, the appearance of the morph can be affected by joint rotations during posing. Poser gives you the option to apply morphs before joints are rotated. These options appear when you create morphs in the Morph Palette, or when you return after exporting a figure or object to ZBrush using the **Figure > Export Figure Mesh to GoZ** or **Object > Export Object Mesh to GoZ** command.

Generally, full body morphs should be applied before a joint is bent (prepended), and joint controlled morphs applied after a joint is bent (appended). Prepending morphs allows for better processing of morphs before a joint is bent. The Morphing Tool and Export Figure/Object to GoZ commands now provide options to apply morphs before joint rotations.

In general, when you are creating full body morphs in a figure, you want to apply those full body morphs to the figure or to clothing before the figure is posed. The following two figures illustrate what happens to a full body clothing morph that is applied either before or after joint rotation. In the first example, a Heavy morph was created in ZBrush for Pauline’s panties. If the Heavy morph is not applied before joints are rotated, unexpected results occur. Before the figure is posed, the morph appears to fit the character perfectly. However, after posing, you will notice that the bends in the clothing aren't deforming the clothing as expected.

Conversely, when the Heavy morph is applied before the joints are rotated, the posed result is what you expect to see. First, Poser applies the Heavy full body morph to the clothing, and then it calculates the deformations needed to pose that shape correctly. The following figure shows the result using the same pose as the preceding figure.
The Morph Tool and Pre-Transform Morphs

The same Heavy morph works better if the full body morph is applied before joints are transformed.

See GoZ and Pre-Transform Morphs for information about creating pre-transform morphs with ZBrush and GoZ.

The Morph Tool and Pre-Transform Morphs

When you create a custom morph in the Edit tab of the Morphing tool, you will be given the option to create a pre-Transform morph as described in .

Custom morphs created in the Morph Palette can also be applied before joint rotations.

The Apply pre-Transform option should be checked if you are creating your morph when the figure is in its zeroed position. This is most common when you are creating a full body character morph (FBM for short) that is designed to change the overall shape of the character’s body.
Convert to Pre-Transform or Post-Transform Morphs

Poser allows you to apply morphs either before a joint is transformed (pre-transform morphs) or after a joint is transformed (post-transform morphs).

You can convert a morph to a pre-Transform or post-transform morph after the fact, using options in the Parameters Palette.

If you are creating a morph that smooths out the appearance of a joint after it is rotated (often referred to as a joint-controlled morph or JCM for short), you should uncheck the Apply pre-Transform option.

Morphs can be converted to pre-transform or post-transform morphs from the Parameters Palette menu.

- **Pre-transform morphs**: If you are painting a character morph, you generally want to paint the morph when the figure is in a non-transformed state (its zero pose). Character morphs are generally considered to be pre-transform morphs. If you paint a pre-transform morph while a figure is in a non-zero pose, you may notice problem areas around the joints of the figure. In that case, you will want to convert to a post-transform morph while you paint. After your painting is done, convert to a pre-transform morph for improved performance.

- **Post-transform morphs**: If you are painting a post transform morph, such as a joint correction morph that is meant to improve the appearance of a joint after it is transformed, you generally paint that morph when the figure is posed.
Saving Morph Injection Poses

Morph injection poses allow content developers to create unique character morphs and “inject” the morph data into a Poser figure. Poser includes a command that allows you to create morph injection poses from within Poser.

The steps to create and save a morph injection pose are as follows:

1. Create a morph target using the Morph palette, ZBrush, or other 3D modeling program.
2. Import the morph target into your figure and verify that the morph is working.

If you try to use the Morph Palette or ZBrush to edit a morph after it has been converted to a pre-Transform morph, you may see unexpected results. Click the arrow that appears to the right of the morph that you are editing, and choose Convert to post-transform morph. You can then choose Convert to pre-transform morph in a similar manner after you have finished editing your morph.
Poser Reference Manual

Copying Morphs Between Figures

3. Choose **File > Export > Morph Injection**. The Select Objects window appears.

4. Initially all of the morphs are selected in the dialog. Click the **Select None** dialog to deselect everything. Then check the morphs that you want to include in the Morph Injection pose.

   *If the morph you created includes a dial in the BODY actor (for a full body morph) it will automatically select the morph in the affected body parts when you check the morph in the BODY actor.*

5. Choose **OK**. The Save Morph to Injection File window prompts you to locate a folder and enter a filename for the injection pose.

   *Morph injection poses are not automatically saved to the library. If you want to save a morph injection pose to the library, use the Save Morph to Injection File window to navigate to a Runtime: Library: Poses folder in an internal or external library that is configured in Poser. Save the injection pose (PZ2) into that folder. If you add the injection pose to a runtime folder in this manner, you will need to refresh the folder in the Library to see it. You will also need to create a library thumbnail separately. Just save the thumbnail at the same location, using the same filename as the pose that you saved.*

6. To test the morph, create a new scene and load a version of the character that does not include your custom morph. Locate the morph injection pose in the library and apply it to the figure. Verify that the morph works as expected.

**Copying Morphs Between Figures**

The **Figure > Copy Morphs From** and **Object > Copy Morphs From** commands allow you to copy morphs between figures and clothing. This feature works more accurately with items that are sparser in density (such as clothing) than with items that are more finely detailed (such as a face to face morph transfer).

*When transferring morphs to clothing such as skirts, long coats, or other items that are long and flowing, it's usually best to select a similar item of clothing. For example, if you want to copy morphs from a character to a dress that the character will wear, load another dress that already has the morphs you want to copy. La Femme Pro (available for purchase at Renderosity) includes a dress dev rig that can be used to transfer JCMs and full body morphs to other dress items for La Femme.*

To copy all morphs from a character to the clothing:
Choosing the morph source for a figure.

1. Load the character and the clothing into your scene.
2. Click to select the clothing that will receive the morphs.
3. Choose **Figure > Copy Morphs From**. The Copy Morphs dialog appears.

Choosing the morph source for a body part.

4. Choose the character from which you want to copy the morphs.
5. Before morphs are copied to the target figure, Poser will internally subdivide the mesh by the number of subdivisions that you set in the Target Tessellations field. By default, this is set to a level of 2. (Note that this setting is independent of the number of subdivisions set in the source or target figures).
6. Click **OK** to continue.
7. Use the Select Objects dialog to check the morphs that you want to copy to the clothing.
8. Click **OK** to copy the morphs.

Similarly, the **Object > Copy Morphs From** command allows you to copy morphs between objects in several different ways. This command is recommended for use with dynamic clothing, which typically does not contain body part groups. Follow these steps:

Load the source and target objects into your scene (such as a character and the dynamic clothing).

1. Click to select the object that will receive the morphs (the dynamic clothing prop, or a body part on a conforming clothing piece).
2. Choose **Object > Copy Morphs From**. The Copy Morphs dialog appears. It displays options to choose morphs from the character, from the clothing, or from a prop:

Choosing the morph source for a body part.

- To copy morphs from an entire figure, select the source figure name from the bottom of the Copy From list.
• To copy morphs from a specific body part on the source character, expand the list that appears to the right of the character name at the top, and choose the body part from which you want to copy the morphs.

• To copy morphs from another prop clothing item, or from a specific body part on a different conforming clothing item, expand the list that appears to the right of the current clothing item. Choose the body part from which you want to copy the morphs and then click **OK** to continue.

• To copy morphs from a Control Prop (such as a magnet sphere or capsule), expand the list that appears to the right of the Props list, and select the item that you want to copy the morphs from. Then click **OK** to continue.

3. Click **OK** to continue.

4. Use the Select Objects dialog to check the morphs that you want to copy to the clothing.

5. Click **OK** to copy the morphs.

---

**Using the Fitting Tools**

The Edit tab in the Morph Palette includes fitting tools that allow you to create fitting morphs for clothing. These tools do not take existing grouping into account and work on the entire object geometry.

To use the fitting tools in the Morph Palette, follow these basic steps:

1. Load the character and the clothing that you want to fit.

2. Translate and scale the clothing as needed to position the clothing around the figure as closely as possible.

3. Choose the **Tighten Fit** or **Loosen Fit** tool. Either of these tools allow you to select the Target figure to use. The Target will be the character that you want to fit the clothing to.

4. Create a new morph and assign a name to it.

5. Use the fitting tools to adjust the clothing as necessary. Adjust Brush Radius and Magnitude to increase or decrease the areas and amount of effect.


Tighten Fit

Tighten Fit makes the clothing tighter in the areas that you paint, moving it closer toward the shape of the Goal figure. Options are as follows:

You can use the Tighten Fit tool to get rid of pokethrough in your clothing. Select the clothing object. For the Goal, choose the figure that the clothing collides against (either the character or the next clothing layer below the current clothing). Then set the pokethrough margin to a small value like .002. As you paint the clothing, the Tighten Fit brush will pull the clothing toward you and eliminate the pokethrough.

- **Goal**: The figure that you’re trying to fit to.
- **Attraction Points**: The maximum number of closest points on the target geometry that are taken into account when tightening.
- **Pokethrough Resistance**: The distance that determines how much the clothing resists pushing into the target figure.

Loosen Fit

- **Loosen Fit**: Makes the clothing looser in the areas that you paint, moving it away from the shape of the underlying figure. Options are as follows:
  - **Goal**: The figure that you’re trying to fit to.
  - **Attraction Points**: The maximum number of closest points on the target geometry that are taken into account when loosening.
Creating Morphs in Other Applications

Creating Custom Morph Targets

You can create morph targets using your favorite 3D modeling application so long as that application can import and export Wavefront OBJ (*.OBJ) files. To do this:

1. Export the body part for which you wish to create the morph target as explained in Exporting Files.
2. Import the body part into your favorite 3D modeling application.
3. Edit the geometry, being careful to only move vertices. Do not add or remove vertices, or your morph target will not work.
4. Export the edited geometry from the 3D modeling application in the Wavefront OBJ (*.OBJ) format.
5. Load the morph target.

Adding Custom Morph Targets

Selecting Object > Load Morph Target allows you to load a morph target for your currently selected element.

Sag

- **Sag**: Use in cases where you need to add a draping effect, such as the underside of an arm. It will affect polygons on the lower side of the painted area, but not on the upper side. Options are as follows:
  - **Gravity**: Configurable gravity vector determines the direction towards which the clothing will sag
  - **Falloff**: Slider determines how quickly vertices whose normals are very nearly orthogonal to the gravity vector are affected by the sag.
You can add morph targets that you created using a third-party application and apply them to your figures and props. You can also add third-party morphs obtained from online sources.

To add a custom morph target:

1. Select the body part/prop to which you want to apply the morph and open its properties in the Properties palette.
2. Click Load Morph Target to open the Load Morph Target dialog.
3. Enter the complete path and filename to your desired morph or use the Locate button to open a standard Browse dialog allowing you to locate the correct file. Your selected file must be in OBJ format, contain the same number of vertices as the original body part/prop, and must only contain the body part/prop being morphed.
4. Enter a name for the added file, then click OK to exit back to the Parameters palette. A new parameter dial appears with the name of the newly added morph.

In order for morph targets to work properly, they must have the same vertex order as the geometry mesh to which they are applied. Some applications have difficulty preserving the vertex order when editing or writing out morph targets. If you find that your imported morph targets behave unexpectedly, you may wish to check the Attempt Vertex Order Correction checkbox when loading them. This checkbox is located on the Load Morph Target dialog, which can be accessed by selecting Object > Load Morph Target, or clicking the Load Morph Target button on the Properties palette. Please note that significant changes to vertex order are not possible with automatic correction.

Combining Morphs in Poser

Poser provides a number of different ways that you can combine body morphs to create unique characters. For example, you can use the Object > Spawn Morph Target command to create a parameter dial for body parts and props that have been modified with deформers. The Figure > Create Full Body Morph command allows you to create a single master dial in the Body to drive morphs in several different body parts. Additionally, you can use Dependent Parameters to
create master parameter dials that, in turn, create more realistic interactions between body parts and rotations.

**Spawning Morph Targets on Figures**

The Figure > Spawn Full Body Morph command creates like-named morph targets on Poser Unimesh figures for all body parts, and then creates a matching master parameter. You can use this command to capture deformations that are created through simulations such as soft body dynamics or the Cloth Room.

The general steps are as follows:

1. Load in a Poser Unimesh figure, or use the Figure > Skinning Method > Poser Unimesh command to convert a traditional Poser figure to Unimesh.
2. Create a simulation (for example, soft body dynamics or cloth simulation).
3. Select the figure and choose Figure > Spawn Full Body Morph.

You can export this character from Poser to FBX format and use the morph as a blend shape in the Unity Inspector.

**Spawning Morph Targets per Object**

In addition to the Edit tab on the Morph Editor palette, you can also create morph targets in Poser directly from the Properties palette. Selecting Object > Spawn Morph Target creates a morph target from deformed objects (body parts, props) in your scene. You will be asked to name your new morph target, and a dial with your specified name will appear in the object’s Parameters palette.

Shape an element using any combination of deformers you like to get the results you want. Shaping multiple elements on a body part includes all changes in the shape in the morph target.

1. Select the body part/prop’s properties in the Properties palette, then select Spawn Morph Target. A dialog appears asking you to name your new target.
2. Enter your desired name and click OK. A parameter dial appears in the Parameters palette with the name of your new morph target. At this point, you can delete all deformers used to create the morph.

Assigning a name to a custom morph.
Numbers greater than 0 apply the morph to the selected element(s), and vice versa. A value of 1 means the morph target is fully applied, a value of -1 means the morph is completely inverted, and numbers greater than +/-1 create exaggerated effects. Using the **Bulging Bicep** example, a value of 1 applies the bulge fully, a value of -1 applies a full concavity (the reverse of the original morph), and so on.

## Creating Full-Body Morphs

You can save multiple body parts and then save the entire pose as a full-figure morph target, also known as a Full-Body Morph (FBM). The new morph target encompasses all of the parameters for that pose, meaning that everything morphs at the same time.

> Only morph channels combine into a full-body morph. Deformers are not automatically turned into morph targets for full-figure morphs, nor are scales, rotations, and translations.

> When you create a full body morph, the master parameter dial in the BODY will be set to a value of 1, and the dependent parameter dials in each individual body actor will be set to 0, which is more in line with how full body morphs are typically set up manually.

To create a full-body morph target:

1. Create morph targets for as many body parts as you wish. Refer to this section for assistance if needed.

2. Morph each body part using the new **Parameter** as discussed in **Parameters Palette**. Set them to the values you want to appear in the full-body morph. For example, setting the **Bulging Bicep** value to 0.5 means that the full body morph, when set to 1, will morph that part of the figure as if you had applied the original morph with a value of 0.5.

3. Select the entire figure, then select **Figure > Create Full Body Morph**. Enter a name for your new morph in the **Set Name** dialog that appears.

When you select the figure’s body again, a parameter dial with your new morph target will appear. This morph functions just like any other morph: Numbers greater than 0 apply the morph to the selected element(s), and vice versa. A value of 1 means the morph target is fully applied, a value of -1 means the morph is completely inverted, and numbers greater than +/-1 create exaggerated effects. Using the **Bulging Bicep** example, a value of 1 applies the bulge fully, a value of -1 applies a full concavity (the reverse of the original morph), and so forth.
Loading Full Body Morphs

You can use a third-party application to create a full body morph for a Poser figure, and then use the **Figure > Load Full Body Morph** command to apply the complete morph to your figure. The Load Full Body Morph command will then split the morphs across each individual body part and create a parameter dial in the Body actor to control all of the individual body part morphs.

In order for the Load Full Body Morph command to work properly, the OBJ file must be grouped the same as the original figure. If the morphed figure does not contain groups, you will only see a parameter dial in the Body actor, and you will not see any change occur when you adjust the dial.

To create a full body morph in a third-party application, import the unmodified OBJ file (usually found in the Geometries folder) into your modeling application. When you use the original OBJ you are assured that your OBJ file is not translated or modified in any way before you create your morph.

When creating your morph in your third-party application, make sure that you do not add or remove vertices or otherwise change the geometry in any way. You can only modify the shape of the original figure. When you export your geometry from your modeling application, you must also make sure that the grouping information is maintained.

Loading a Single Full Body Morph

To load the modified body shape into Poser, follow these steps:

1. Load the original figure from the library into your scene, and select it to make it active.
2. Choose **Figure > Load Full Body Morph**. The Load Morph Target dialog appears.
   
   ![Loading a Morph Target](image)

3. Click the button to the right of the Geometry file section to locate the morphed OBJ file that you exported from your modeling application.
4. Enter a name for your morph in the Label field. This is the name that will be assigned to the parameter dials in the Body and individual body actors in the Parameters window.
5. Choose **OK** to complete the process. You should see morph dials in the body and under each individual body part.
Loading Multiple Full Body Morphs

Before you load multiple body morphs, make sure that the OBJ files are named exactly as you want the parameter dial to be named. The same precautions mentioned above should be followed ... that is, all OBJ files should also contain the same groups as the original figure, and that the vertex count and winding order are the same as the original OBJ.

To load multiple full body morphs, follow these steps:

1. Load the original figure from the library into your scene, and select it to make it active.
2. Choose Figure > Load Full Body Morph. The Load Morph Target dialog appears.
3. Click the button to the right of the Geometry file section to locate the folder that contains the objects you want to import. Select the morphs you want to import.
4. The Label field in the Load Morph Target dialog will display Multiple Files. You will not be prompted to enter names for each parameter dial. Instead, the OBJ names will be used in the parameters palette. Choose OK to complete the process. You should see morph dials in the body and under each individual body part.

![Loading Multiple Morph Targets]

Testing Morphs

1. Test the morph(s) by adjusting the dial in the Body section of the Parameters palette.

   • If the morph does not work, it may mean that the OBJ you imported did not contain groups. Check to see if a dial appears in any of the individual body parts. If they are absent, your OBJ file did not contain groups. Consult the documentation for your modeling program to determine how to export the groups with your OBJ file.

   • If the morph works but it makes the figure “explode”, repeat the process. This time, check the Attempt Vertex Order Correction option in the Load Morph Target dialog. This might resolve the problem.

Deleting Full and Partial Body Morphs

You can delete full or partial body morphs in the Parameters palette.

Find the parameter dial for the morph you want to delete. You can delete a morph by selecting a parameter from the BODY actor, or from any other body part actor.
Click the arrow that appears at the right side of the parameter dial to display the morph context menu, and choose **Delete** (if the BODY actor is selected) or **Delete Morph** (if a body part actor is selected).

![Morph Context Menu]

*Click the arrow to the right of the morph you want to delete, then choose Delete Morph from the menu.*

The Select Objects dialog will open. A check mark will appear beside each body part from which the morph will be deleted. By default, all body parts in which the selected morph appears are checked. Uncheck any parts where you want the morph to remain. Poser will ask you to confirm the deletion before the full body morph is removed.

![Select Objects Dialog]

*By default, all body actors that contain the morph are selected by default. Uncheck any actors where you want the morph to remain.*

## Using Dependent Parameters

You can change any existing parameter dial or create new master parameter dials that can be used to control any number of dependent (or slave) parameters. This powerful feature lets you link morphs, deformers, transformations, bulge parameters, or just about any element in the scene to create complex interactions that are all driven by a master parameter.

Poser 8 through 10 figures include several magnet deformers that help joints bend more realistically. The dependent parameters feature was used in those versions to link these deformers to various joints in the figure. For an
In the example that follows, we are looking at Roxie’s head as an example. After you click on the arrow to display options for the Angry expression dependent parameter, choose **Edit Dependencies** from the menu that appears. This opens the Dependent Parameters window, which is used to view, edit or create new Master Parameters that drive other actors or morphs in your character.

The Dependent Parameters editor contains two tabs: The Keyed Dependencies tab (which configures inter-dependencies between other morphs and actor settings and deformers), and the ValueOperations tab which allows you to edit more complex interactions.

**Dependent Parameter values and icons.**

Example, you can see all of the magnet deformers used in Alyson if you choose **Display > Deformers > Show All**. You can choose **Display > Deformers > Hide All** to turn them back off after you’ve examined them.

*The Poser 13 figures (L’Homme and La Femme) use weight mapping and bulge maps to control deformations during bending.*

- A Master Parameter icon (#2 in the following figure) appears beside any parameter dial that serves as a Master Parameter. Click on the arrow (#3) to open the Dependent Parameters editor. This serves the same function as choosing the Edit Dependencies command from the Parameters Option Menu (as described next).

- When two values appear beside a parameter dial, one above the other, they indicate the following:
  - The upper number (#1) s the **driven value**, which is the sum of the natural value setting plus any values set by its master parameter.
  - The lower number (#4) is the **natural value**, which is the value as set by the parameter dial itself.

To open the Dependent Parameters window, choose **Edit Dependencies** for the parameter you want to edit.

```plaintext
To open the Dependent Parameters window, choose Edit Dependencies for the parameter you want to edit.
```
Keyed Dependencies

The Keyed Dependencies tab in Dependent Parameters window displays the following settings and options:

- **Master Parameter** (1): Lists the name of the Master Parameter dial that will control the other parameters listed in the Dependent Parameters list.

- **New Master** (2): Click this button to create a new Master Parameter dial. After you enter a name, the Dependent Parameters window will immediately switch to that master parameter so that you can assign which parameters are driven by the master dial.

- **Start Teaching** (3): Click this button to “record” the changes that you want to link to the currently selected dial and value.

- **Value slider and number** (4): Drag the slider left or right to increase or decrease the value. You can also click the value field and enter a number.

- **Dependent Parameters** (5): Provides a list of the other parameters in the figure that will be affected when you adjust the Master Parameter dial. For example, when you dial the Bend morph to -90 you want a change to occur in the Left Shoulder body part.

- **Remove Selected** (6): To remove dependent parameters, click to highlight one or more of the entries in the Dependent Parameters list, then click the Remove Selected button.

- **Type** (7): There are two types of Master Parameter:
  - **Keyed**: This master parameter type is the only type of dial that you can create in the Dependent Parameter palette. You can create linear links or curved links that have varying driven values at any value of the master parameter.
  - **Delta Add**: If you see this type listed, it means that the relationship between the master parameter dial and its dependent parameters were created externally (most often by content developers that created the relationships while editing the figure’s CR2 character file). A Delta Add type is also created when you use the Morphing Tool across body parts. Delta Add parameters are editable in the Dependent
When you look at the Angry parameter in Roxie’s head, you’ll notice that there are a number of facial expression morphs linked to the master parameter dial. These are linked to the master parameter dial as described in Creating Master Parameters.

The Dependent Parameter Editor Graph

The Graph in the Dependent Parameters window allows you to adjust how the parameter responds between keys. At a minimum you need two keys. But you can modify keys in the graph display as follows:

- Click on the graph display between two value keys and drag up or down to add a third value key.
- Drag the Master Parameter’s value in the graph by clicking on the vertical line and moving it forward or backward.
- Click on any value key and drag it up or down to increase/decrease its value.
- Click and drag in an open space of the graph to select multiple keys. You can move this selection to include other keys. Key navigation is controlled via the pop-up to the right of the graph.

Creating Master Parameters

You can create a new Master Parameter dial from the Parameters option menu in the Parameters Palette. Master and Dependent Parameters aren’t restricted for use in figures.

In this first example, we demonstrate how you can create a Brightness master parameter on the main light in your scene, and use it to raise or lower the brightness in all of the lights in your scene at the same time.
Using Poser’s default three-light setup as an example, you would create a master parameter for Light 2 (the front off-white light) as the Master Parameter, as follows:

1. Create a new scene that contains three lights. Label them Light 1, Light 2, and Light 3. Alternatively, you can start with the default scene and delete all but Light 1, 2, and 3.

2. Select the actor that will serve as the master parameter. In this case, we want to add a new Master Parameter to Poser’s default Light 2.

3. With Light 2 selected, click the Parameters Palette Options menu, and choose Create New Master Parameter. When prompted for a name, enter Master Light.

   ![Creating a new Master Parameter dial.](image)

1. Switch to the Keyed Dependencies tab if necessary. You need to add two keys for each dependent parameter that you want to add. Since Light 2 (the Master Light) is selected, we will adjust the brightness on that light first. First, click the Start Teaching button.

2. In the Dependent Parameters palette, set the Parameter dial to 1.000. This is the value we will use as the “Bright” setting for the Master 1 Parameter dial.

3. Now you adjust the brightness on all three lights in your scene. It doesn’t matter which order you complete them in, but since we have Light 2 selected already we’ll do that one first. If settings remain the same as they were, they are not added to the Dependent Parameters list. But when you enter a value the change will be recorded as shown in the following figure:

   • Set the Intensity for Light 2 to a high value, such as 800%.
   • Select Light 1 from the Actor selector in the Parameters palette. Set its Intensity value to 10%
   • Select Light 3 from the Actor selector in the Parameters palette. Set its Intensity value to 800%.
After the first key is created, click the Next Key button.

7. Click the **Next Key** button in the Dependent **Parameters** palette to create a key for the other end of the Master 1 parameter dial.

8. In the Dependent **Parameters** palette, set the Master 1 parameter to -1.00 (negative value). This is the setting that we will use to turn the lights off.

Set the Master Parameter dial to -1 to create the low setting for the master dial.

9. Use the **Parameters** palette to set the intensity of your current light to 0% (off). Then do the same for the other two lights. At a Master Parameter setting of -1, the lights in your scene will be completely off.

Set the intensities for the lights to 0%.

10. With all of your settings configured, click the **Stop Teaching** button in the Parameters Palette. You can also close the Dependent **Parameters** palette, if desired.
Click the Stop Teaching button when you complete the actions you want to perform.

Because you created the Master Light dial when you had Light 2 selected, you should now see a Master Light dial in its Parameters palette. Select Light 2, and then look for a dial named Master Light. Adjust the Master Light parameter dial up and down toward or beyond -1 and 1. You will notice that when the dial is set to -1 or lower all lights will be off; and when set to -1 or higher the lights will be set to the maximum values.

Test the new parameter dial to make sure it works as you expect.

Editing Master Parameters

The Dependent Parameters feature can be used to create or enhance Full Body Morphs. In this section, we’ll describe how you can use the dependent parameters feature to enhance the Pregnant full body morph.

Create a new Poser scene and add Alyson 2 to your scene (she has a good range of morphs to play with). Select her Body, and expand the FBM morph section. Scroll down, if necessary, until you see the Pregnant morph. Click the Master Parameter icon to open the Dependent Parameter editor.
For several Poser figures, you’ll notice that a number of dependent parameters already appear in the Dependent Parameters editor. If you highlight one of the Dependent Parameters, the selected parameter appears in the Parameters palette.

When you select one of the body parts that are affected by a Master Parameter, you’ll see two values. For example, when you select the Left Thigh: Pregnant entry in the Dependent Parameters list, the settings for the rButtock body part appear in the Parameters palette.

As mentioned earlier in Using Dependent Parameters, there are two numerical values listed to the right of each morph dial:

- The driven value (upper) designates the value as controlled by the master parameter. In this case, we are looking at a Master Parameter dial (Pregnant), so its Driven value in the Parameters palette is the same as that set in the Dependent Parameters window.

> Poser 13 allows you to set the driven value of the master parameter dial from any affected body part. For example, when you dial the Pregnant morph from Alyson 2’s left thigh, you will see the morph dial in to all other affected body parts (abdomen, hip, and so on) as if you were dialing in the full body morph.

- The natural value (lower) designates the value that is currently set for the morph dial in the Parameters palette.
Uncheck the Master Sync'd option for any driven parameter that you want to control independently of the master parameter dial.

The Dependent Parameters list displays a list of the morphs that are adjusted by the Pregnant morph. The figure shown on the previous page shows that the Pregnant morph dial in Alyson 2’s Body actor controls the Pregnant morph in the hip, waist, abdomen, chest, left thigh, and right thigh. If you are already familiar with previous versions of Poser, you might recognize this type of morph relationship as a "Full Body Morph." In earlier versions of Poser, you would have used the **Figure > Create Full Body Morph** command to create a master parameter dial in the figure's Body part.

While the older method of creating Full Body Morphs is still available, the Dependent Parameters feature provides you with even more power. For example, you can link additional partial body morphs or full body morphs to the Pregnant dial so that there are even more changes to the shape of Alyson's pregnant body. To demonstrate, we are going to make the Pregnant morph even more natural looking, by adding additional changes to the breasts and hips. The Dependent Parameters feature makes this a very simple process.

Since Alyson 2 is already in your scene, select **Body** as the current body part. Scroll down until you see the **Pregnant** full body morph, and dial in or enter a setting of 1 in the Dependent Parameters window.
The Pregnant morph is set on several body parts. Click Start Teaching to further enhance the shape.

In the Dependent Parameters window, click the Start Teaching button. This instructs Poser to create a link between the Master Parameter and the values that you select until you tell Poser to stop teaching the joint parameters.

Now, we’ll adjust some of the breast settings to make them look more like those of a pregnant woman. With Alyson 2’s Body actor selected in the Parameters window, scroll down in the Parameters palette and expand the morphs under the Breasts category. Then you can use the dials or enter values numerically. The following list shows the values that we set. Yours don’t have to be exactly the same, feel free to experiment with other settings if you desire:

- **Areola** Size: .548
- **Breast Diameter**: 1.072
- **Breast Droop**: 1
- **Breasts Large**: 1.216
- **Breasts Natural**: 1
- **Nipples**: .248
Breast morphs are adjusted for a fuller appearance.

Notice now that the shape of the breasts looks more natural and realistic. Now we’ll add a couple of other Full Body Morphs to the mix. We’ll add a touch of the Pear Figure and Rubenesque to adjust the overall body shape just a bit. Scroll back up to the Full Body morphs section in the Parameters Palette, and adjust the following values:

- **PearFigure**: .199
- **Rubenesque**: .199

Other Full Body Morphs add additional shape to the Pregnant morph.

Now return to the Dependent Parameters window, and click **Stop Teaching**. The settings that you dialed in while teaching the joint should all appear in the Dependent Parameters list. When you adjust the dial in the Dependent Parameters window, you should see the differences in the Pregnant morph respond accordingly. Before you close the Dependent Parameters window, set the value to zero.
Set the value of the Master Parameter dial to zero before you close the window.

Now, go back to the Pregnant full body morph in the Parameters window. Adjust the value up and down to see how the new morph responds to the changes in the dial settings. Your new Pregnant morph should respond exactly as it did in the Dependent Parameters window. Notice how you also see the values of the PearFigure and Rubenesque dials change when you adjust the Pregnant morph. The values in the second column reflect the settings that are inherited by the links that you created with the master parameter.

When you adjust the Pregnant morph dial, the dependent parameters adjust with it.

The following figure shows the original Pregnant morph on the left, and the new improved version on the right. As you can see, the enhancements have made the morph look more natural.
Before we move on to the next topic, there is one more thing to examine. The previous shot of the Parameters palette shows what happens to the PearFigure and Rubenesque morphs when you dial in the enhanced Pregnant morph. You’ll see that when the Pregnant master parameter dial is set to .692, it drives the PearFigure and Rubenesque morphs to .138. But what happens if we want the woman to be more pear-shaped?

The solution is simple enough. You can adjust the natural value (the lower value) of the Pear Figure morph just as you can with any morph dial that is not affected by a master parameter. The following figure shows what happens when the natural value dial for the Pear Figure morph is increased to .8. The driven value, which was previously set to .138 by the Pregnant morph, increases by .8 setting as well (to .938), and the resulting shape of the figure changes accordingly.

You can still adjust the Natural value of a dependent parameter without affecting the Driven value.

To summarize, Dependent Parameters can be used to create master parameter dials that drive other parameters in a figure: morph dials, magnets, light settings, material settings, rotations, and more. As you experiment with this feature you’ll realize how powerful and flexible it is.

**Value Operations**

The Value Operations tab in the Dependent Parameters Editor gives advanced content developers access to additional features that were previously addressed in third party CR2 editors or text editors. It allows interlinking of parameters for a variety of purposes and functions.

The ValueOperations tab displays the following options:
Value Operations parameters.

- **Selected Parameter**: Displays the name of the currently selected parameter dial that you are operating with.

- **Create New Value Op**: Click this button to create one of the following types of value operations which give you a high level of control over how dependent parameters interact:
  
  - **Delta Add**: Creates a conventional dependency. The value of the linked parameter is multiplied by the Scale factor, and then added to the current parameter. Almost all full body morphs are linked using a DeltaAdd operator.

  - **Add**: Adds the current parameter to the value of the linked dial. This has been superseded by the DeltaAdd function above, as they perform the same function.

  - **Subtract**: Subtracts the current parameter from the value of the linked dial. This has been superseded by the DeltaAdd function above, as they perform the same function.

  - **Multiply**: Multiples the current parameter by the value of the linked dial. For example, if the controlled parameter has a value of 1 and is linked to another parameter with a value of 5, then the resulting value in the controlled dial will be 5.

  - **DivideBy**: Divides the current parameter by the value of the linked dial. Great care must be taken when using this option. Divide by zero is an illegal operation so you must ensure that does not happen. We recommend that you set forced limits so that a zero state result cannot happen.

  - **DivideInto**: Reverses the logic of DivideBy, so that there is no danger of a divide by zero in this operation.

- **Delete**: To delete an item in the Value Operations list, highlight the entry that you want to delete and then press this button.

- **Actor**: After you create a Value Operations entry, the Actor dropdown will allow you to select the actor to apply the operation to. Expand the menu to select any item/actor/body part in your scene.
**Morph Dependent Joint Centers**

Assume that you have created a character morph that is so extreme that the original rig no longer works. In the following example, Andy has been morphed into an alien. You’ll notice that when you rotate his arm upward it cuts through the heavily modified shoulder.

![A drastically morphed character.](image)

When the upper arm on the morphed character is rotated, its joint center is no longer appropriate for the morphed body shape.

In older versions of Poser you had to move the joints manually and set up their dependencies in the Dependent **Parameters** palette, which took a considerable amount of time. With Poser’s morph dependent joint centers feature you can morph a figure into any extreme – a baby, a toddler, a child, a troll, a giant, or an alien - without worry of how it will be rigged. The joint centers and all dependencies required to make the figure pose and bend properly will be automatically calculated for you.

To set up morph dependent joint centers for a character morph:

- **Parameter**: After selecting the actor above, choose one of the parameters associated with that actor.

- **Scale Factor**: Enter a scaling factor for the desired value operation.
The Match Centers to Morph option configures morph dependent joint centers.

1. Select one of the body parts that is involved with the extreme morph that you want to follow. In this example, the chest is selected.

2. Expand the menu for the morph and choose Match Centers to Morph. The Select Objects dialog appears.

3. Check all body parts that are involved with the morph you want to follow.

4. Check or uncheck the Create Dependencies option as follows:
   - If you check the Create Dependencies option, Poser will automatically create the dependent parameters that will be required to track and move the joint centers when the morph or morphs are dialed in. Use this option if you want to use the full body morph as a morph target of the original figure.
   - Uncheck the Create Dependencies option to create a new rig that fits the full body morph that you used to create the morph dependent joint centers. For example, if you apply a giant morph to Paul or Pauline, and uncheck the Create Dependencies option, Poser will create a new rig that fits the giant. Save the new giant CR2 to the library, and then edit the CR2 so that it calls the giant OBJ that was used to create the rig, instead of to Paul or Pauline.

5. Choose OK to complete the adaptable rigging.

The joint centers will now be set up so that when you dial the extreme morph in, you will see the joint centers move with the morph.

You can also manually configure or edit animated centers and animated orientations, as described in Manually Adjusting Animated Centers and Orientations.
Manually Adjusting Animated Centers and Orientations

If you prefer to manually edit joint centers and orientations, or need to tweak them after creating morph dependent joint centers, you can find controls to enable or disable animated centers and orientations in the Joint Editor. Use animated centers to adjust the center position of a joint in relation to a morph; and use animated orientations to ensure that the start and end positions of the joint are properly aligned to each other.

When using animatable origins, you will get much better bending if you first merge your spherical and capsule zones into weight maps first, as outlined in Adding a Weight Map. At a minimum, convert the body parts where the mesh is most affected by the morph (the shoulders, forearms, head and neck in the case of this alien morph). Affected actors will also allow you to create joints that bend more naturally in respect to the joints around them.

After you convert your body parts into weight maps, you can use the Joint Editor to enable or disable animated joint centers or animated orientations for each body part you need to change. Select the joint that you want to configure, and then choose the Center properties in the Joint Editor. There, you will see two key icons that enable or disable animated centers and animated orientation.

Select the joint Center, and click the key icon to enable animated centers or animated orientations.

When you’re working on your centers in the Joint Editor, the start and end positions and angles of the selected joint will be displayed. When you select a body part either with the Current Actor menu, or in the Parameters/Properties palette, the information for its center, end point, and orientation will be displayed in the joint editor. The following figure shows the position and orientation of the original Andy’s right shoulder, compared to the outline of the Alien Andy shape. As you can see, the original origin (green crosshair) is not centered on the Alien’s shoulder, and its is
poser reference manual

manually adjusting animated centers and orientations

Original joint centers and orientations as they appear in relation to the morph.

When you want to animate the position of the center of the joint, first click the Key icon to enable animation on the joint center. Similarly, if you want to animate the orientation of the joint, click to enable the animated orientation key. The keys will turn green when enabled.

The Dependency Editor, discussed in Using Dependent Parameters, allows you to link the morph with the new positions of the joint centers. For example, after the “Alien Andy” morph is dialed in, you would select the right shoulder on the figure. Then click the arrow that appears to the right of the morph you are adjusting for (Alien Andy in this case) and choose Edit Dependencies to open the Dependent Parameters editor.

![Image of joint centers and orientations]

Before moving the joint centers and orientations, open the Dependent Parameters editor.

Click Start Teaching to record the new positions of the joint centers that you want to change.

- To record the new position of the joint center, simply move the green crosshair to the desired location while the animated center icon is enabled (green).
- To record the new orientation of the joint, click the Align button while the animated orientation icon is enabled (green).
- Any changes you make to the joint positions are changed in the Dependent Parameters editor as shown in the following figure.

![Dependent Parameters editor]

The Dependent Parameters editor will track positions of the Origin X, Y, and Z dials after "Start Teaching" is pressed.

After you adjust the X, Y, and Z origins and orientations of the current joint, click Stop Teaching. Select the next joint you want to edit, and Start Teaching again.

**DO NOT use Figure > Rig Symmetry to copy the new joint positions to the other side of the body. Doing so will copy the positions of all joints into the Dependent Parameters editor.**
Continue as such until all of your joints are adjusted. They will all be recorded in the Dependent Parameters editor. After you have them all set up, click Stop Teaching again. After all of your joints are positioned you will see the morphed character pose much more naturally, and the way it is supposed to.

The new positions of the joints.

Managing Morphed Figures

Saving Morph Targets

You can save morphed figures to the **Library** palette. Saved figures retain their custom parameter dials, meaning you can use them the next time you load that figure. To save a figure to the **Library** palette, please refer to **Adding Items to the Library**.

Poser saves morph targets to an external binary file format (.PMD), which contains only the morph targets for a particular figure or scene. This format allows for faster loading and greater flexibility, as the targets are no longer enmeshed with the rest of the data in the .PZ3 scene file. This storage method also requires less disk space, as all instances of the same figure reference the same .PMD file for morph target data. If you change the morph targets of one or more figures created from the Library and then save your scene, the morph target modifications will be saved in a single new .PMD file accompanying the scene file.

If you wish to save the modified morph targets for any one figure independently, you must select the **Use External Binary Morph Targets** option in the **General Preferences** palette (see **Setting Application Preferences**), and then add the modified figure back into the Library as a new figure. A new .PMD file will be created for that figure, containing the modified morph targets. You can then reuse that figure in other scenes. Additionally, you can easily redistribute the morph targets independently of the specific figure, thereby affording you options for greater flexibility and efficiency.

> It is the responsibility of the user to comply with the Bondware, Inc. End User License Agreement, as well as any third party License Agreements, before
When you open and resave a Poser scene file (.PZ3) from a previous version, Poser will create a new external .PMD file containing the morph targets for that scene. If you wish to save morph targets for the figures in that scene independently, simply add those figures to the Library as described above, and then replace them in your scene. Poser will generate individual .PMD files for each of the figures.

**Deleting Morph Targets**

You can use the Hierarchy Editor palette to delete morphs, as explained in [Working with Hierarchy Branches](#).
Figure and Prop Editors

The Group Editor

Selecting the Grouping tool from the Editing tools display opens the Group Editor palette. The Group Editor lets you select and group individual polygons.

The Group Editor is very powerful and can permanently alter your figures if you overwrite changed figures into the Library. Be sure you understand how the grouping tool works before editing critical content. It’s wise to practice on a simple object or prop to grasp the concepts first.

It helps to use Smooth Lined preview mode when using the Group Editor as polygons and vertices are clearly displayed.

The Group Editor is useful for various tasks within Poser such as:

- Creating material groups in the Material room. Please refer to The Material Room for information about the Material room.
- Creating hair groups in the Hair room. Please refer to The Hair Room for information about the Hair room.
- Creating cloth groups in the Cloth room. Please refer to The Cloth Room for information about the Cloth room.
- Creating body parts in the Setup room. Please refer to The Setup Room for more information about the Setup room.
- Creating props. You can also create new props and deform and morph selected portions of an element. For example, you could use the Group Editor to select polygons around a character’s eyes, nose, and forehead, and use those selected polygons to create a mask prop. See Creating/Editing Groups for information on how to select polygons in the Group Editor.

About Groups

This section describes how Poser differentiates between body part groups, material groups, and other group types on a figure or prop. This explanation is specific to Poser, however it will provide you with the background information you need in order to understand groups in general.
The following examples use the Alyson Casual figure (available in the Figures category). Add this figure to your scene by dragging from the Library to the document window, or by clicking the Change Figure or Create New Figure button at the bottom of the Library palette, as described in Loading and Managing Items using the Library Icons. When you display the figure in Outline display mode and hover your mouse over the various body parts, you’ll see an outline of the group underneath the mouse. We have color-coded the groups for clarity in the following figure.

Please remember that each figure/prop is different, having different body parts, materials, hair, and cloth groups. Further, the groups themselves may be arranged in different orders. However, the concepts explained here are the same for each figure/prop.

Poser figures consist of named body parts that can be selected and articulated (or posed). Props normally consist of a single part that cannot be articulated, although poseable props do exist. The following graphic depicts an example of Poser body parts:

A figure is made up of poseable body parts, called groups.

The example displays several body parts: head, left eyeball, right eyeball, neck, chest, left collar, right collar, left shoulder, right shoulder, and abdomen Each of these body parts can be articulated (posed).

Each body part (or group) consists of one or more polygons.

As hinted above, there are several different types of polygon groups: body part groups, material groups, hair groups, and cloth groups for example. A polygon can belong to more than one type of group (such as a body part group and a material group, or a cloth group and a material group). A polygon can only be in one group of each type at a time. Thus, the following group combinations are possible:

- One body part may have one material assigned to it. For example, the neck will probably have the “skin” material.
• Two or more body parts may use the same material. For example, the fingers may all use the “skin” material.

• One body part may use more than one material. For example, each eyeball may have separate materials for the eyeball, iris, and pupil.

• In addition to the above, a polygon may be part of a hair group and/or a cloth group.

Since body parts and materials are the most obvious forms of grouping, let’s use them to illustrate grouping as a whole since the same concepts apply to hair and cloth groups as well. The graphic displays the material assignments for the above-displayed body parts.

You can see that the head, neck, and portions of the chest use the skin material. The chest and collars use the shirt material. The eyes use eyeball, pupil, and iris materials. The head uses several materials including skin, lips, and eyebrows.

The important things to remember are:

• Poser groups polygons by body part, material, hair, and cloth, and these groups are independent of each other.
About Groups

The following table depicts a partial list of the relationships between body parts and materials in the Alyson Casual figure:

<table>
<thead>
<tr>
<th>Body Part</th>
<th>Assigned Material(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Head</td>
<td>Head, Nostrils, Lips, EyeSockets, Lacrimals, InnerMouth, TearLine, EyelashesBottom, EyelashesTop, Teeth, Gums, Tongue</td>
</tr>
<tr>
<td>Eyeballs (left and right)</td>
<td>EyeballLeft, IrisLeft, PupilLeft, CorneaLeft, EyeballRight, IrisRight, PupilRight, CorneaRight</td>
</tr>
<tr>
<td>Neck</td>
<td>Body</td>
</tr>
<tr>
<td>Collars (left and right)</td>
<td>Body, Shirt</td>
</tr>
<tr>
<td>Chest</td>
<td>Body, Shirt</td>
</tr>
</tbody>
</table>

Again, the only relationship between the body parts, materials, hair, and cloth is that defined by the figure’s creator. Poser does not mandate any such relationship.

Now that we have differentiated between body part and material groups and mentioned hair and cloth, let’s describe hair and cloth groups in more detail:

**Hair Groups**

Hair groups are groups of polygons that can also belong to any body part, prop, and material group. Polygons that are part of hair groups can have real 3D hair grown on them. Please refer to The Hair Room for more information about the Hair room.
Cloth Groups

Poser’s **Cloth** room allows you to create realistic cloth that you can use for almost any purpose in your scene. Cloth groups are actually *vertex groups*, meaning that they are groups of vertices instead of polygons, however this makes little difference in the overall discussion. Vertices belonging to a cloth group cannot belong to a body part group.

Here is an example of a figure wearing dynamic cloth, which consists of props with named groups. See how the cloth realistically drapes and moves as the figure moves.

Please refer to [The Cloth Room](#) for more information about the **Cloth** room.

Cloth groups are used in dynamic clothing, which moves realistically when animated.

Using the Group Editor

To create/edit a group, select the **Grouping** tool, which opens the **Group Editor** palette.

The Group Editor in the Editing Tools palette.

When this option is selected, all figures and objects in the Poser workspace turn gray. The **Group Editor** palette has the following sections and functions.
Creating and Deleting Groups

The top section of the group editor includes controls to navigate through, create, and delete groups from your current object.

![The top section of the Group Editor.](image)

- **Previous button** (1): Cycles backward through the currently existing groups.
- **Current Group pull-down menu** (2): Use the Current Group pull-down menu to jump directly to your desired group.
- **Next button** (3): Cycles backward through the currently existing groups.
- **New Group button** (4): Clicking the New Group button creates a new group with the currently selected polygons.
- **Delete Group button** (5): Clicking the Delete Group button deletes the currently selected group.

Adding, Removing, and Modifying Polygons

The Selection section of the Group Editor contains three menus that allow you to add or remove polygons to the currently selected group.

- **Selection Mode** (6): Click the icon to display a menu that allows you to choose one of the following selection modes:
  - **Marquee**: Allows you to add to or remove from the currently selected group by drawing a rectangle around the polygons that you want to include or exclude.
  - **Draw**: Allows you to add or remove from the currently selected group by drawing over the polygons that you want to include or exclude.

- **Select mode button** (7): Click the Select button to enable polygon selection, and then click within the current object to add polygons to the current group.
- **Deselect mode button** (8): Click the Deselect button to enable polygon deselection, and then click within the current object to remove polygons from the current group.
• **Add menu** (9): Expand the Add menu to add polygons to the currently selected group, using one of four different modes:
  - **All**: Adds all polygons in the currently selected group.
  - **Group**: Allows you to add polygons by group name.
  - **Material**: Allows you to add polygons by material name.
  - **Mirror**: Allows you to mirror selected polygons along the X, Y, or Z axis to the opposite side of the model.

• **Remove menu** (10): Expand the Remove menu to remove polygons from the currently selected group, using one of four different modes:
  - **All**: Removes all polygons in the currently selected group.
  - **Group**: Allows you to remove polygons by group name.
  - **Material**: Allows you to remove polygons by material name.
  - **Mirror**: Allows you to mirror deselected polygons along the X, Y, or Z axis to the opposite side of the model.

• **Modify menu** (11): Expand the Modify menu to add or remove from the selection using one of the following methods:
  - **Invert**: Inverts the polygons that are assigned to the selected group, so that unselected polygons become selected, and selected polygons become unselected.
  - **Grow**: Expands the selection by one polygon around all its edges. You can also use the plus sign on your keyboard [ + ] to grow the selection.
  - **Shrink**: Reduces the selection by one polygon around all its edges. You can also use the minus sign on your keyboard [ - ] to shrink the selection.
  - **Grow (Edge Loop)**: After selecting two or more polygons in a loop, click the Grow button or use the right parenthesis shortcut [ ) ] to expand the selection by one along both ends of the same loop.
  - **Shrink (Edge Loop)**: Click the Shrink button or use the left parenthesis shortcut [ ( ] to shrink the selection by one along both ends of the same loop.
  - **Mirror**: Mirrors the selection on one side of the model to the other side, along the X, Y, or Z axis.
Showing and Hiding Faces and Objects

Display options in the Group Editor.

- **Hide Other Objects box** (12): Checking the **Hide Other Objects** checkbox hides all objects in your scene other than the currently selected object, which can help if you have a complex scene and only want to see the object being worked on.

- **Show Multigrouped Faces box** (13): Checking the **Show multigrouped faces** checkbox displays all polygons that are assigned to more than one group. This can occur if you grouped your geometry in the 3D modeling application and accidentally assigned some polygons to more than one group.

- **Show Nongrouped Faces box** (14): Checking the **Show nongrouped faces** box displays all polygons that do not belong to a group. If you leave the **Setup** room with one or more polygons that are not attached to a bone, they will be maintained on a prop attached to the figure and will be available for grouping again when you return to the **Setup** room.

The above commands are necessary for creating a figure using the geometry and bone structure. The following commands are useful and can be performed in the **Setup** room; however, they are not necessary for figure creation. They may, however, be necessary for rendering and finishing scenes using the newly created figure.

Geometry Functions

Geometry Functions in the Group Editor.

- **Create Prop button** (15): Clicking the **Create Prop** button creates a new prop from the selected group or polygons. Enter a name for your new prop in the dialog that appears.
• **Spawn Props button** (16): Clicking the **Spawn Prop** button creates props for all groups that have been created. Two examples of this might be to create a suit of form-fitting armor or the basis for clothing props.

• **Assign Material button** (17): Clicking the **Assign Material** button creates a new material class for the selected polygon(s). A dialog box will appear asking you to name the new material class. A material class is a parameter that determines the polygons to which a material is applied. For example, if you are creating a figure with gloves on, you could select the polygons of both gloves as a material class. Later, you could use the Material command to assign a material, texture, bump maps, etc. to the gloves. You can think of material classes as groups that define areas where materials are applied.

• **Assign Smoothing ID button** (18): Clicking the **Assign Smoothing ID** button allows you to delineate smoothing groups for the application of smooth shading across adjoining polygon edges. A dialog will appear asking you to assign a new or existing Smoothing ID to the current group. Enter a new ID in the field provided. For more information about smoothing groups, see **Smoothing Geometry**.

• **Create Perspective UVs button** (19): Clicking the **Create Perspective UVs** button maps texture coordinates for a group. An example of using this command might be to map an imported background image of a face to a Poser group corresponding to the figure’s face. The face’s texture coordinates would map to the image.

• **Reverse Group Normals button** (20): Clicking the **Reverse Group Normals** button reverses the normals of the selected group. This allows you to turn environment-type objects or other imports inside out for interactive rendering as desired.

• **Delete Polygons** (21): Press the Delete Polygons button to delete all selected polygons from the object.

• **Auto Group button** (22): See **The Auto Group Command** below.

• **Weld Group button** (23): See **The Auto Group Command** below.

### Polygon & Vertex Modes

The **Grouping** tool operates in polygon or vertex mode, depending upon which room you are in when you use the Group Editor:

• In polygon mode, you can add/remove your currently selected polygon(s) to the current polygon group. While in this mode, you can only create/edit/delete polygon groups. Polygon groups are accessible from the **Group Editor** palette using certain commands, such as **Add Group**. Polygon groups will appear in the popup menu (#4 in the following image).

![The top section of the Group Editor.](image)
Poser automatically selects the correct mode depending on which room you are currently in. For example, in the Pose room, the Grouping tool only operates in polygon mode; in the Cloth room, it operates in vertex mode.

The Auto Group Command

When you are creating groups for a newly imported geometry (Setup room), you can save time and effort by clicking the Auto Group button near the bottom of the Group Editor palette. This option is particularly useful when you are creating custom Poser figures in the Setup room. If you choose to use the Auto Group feature, be sure to do so after creating, positioning, and naming the bone structure! This is because the Auto Group feature places polygons into groups based on their location in 3D space relative to the available bones. This can cause very unpredictable and disorganized results if the bone structure has not been properly created, positioned, and named.

The Auto Group feature is designed for one-time use when you first create a figure. You can use it as often as you wish; however, it completely regroups every polygon in the geometry or figure, which will cause the figure to lose all pre-existing group assignments that match bone names. If you must use the Auto Group feature again after creating your figure, do it with care.

The Auto Group feature causes Poser to take a “best guess” when grouping polygons and bones. You may find that you need to fine-tune the automatically created groups by manually selecting polygons and moving them to different groups. Do this by selecting the target group and then selecting the polygon(s) you wish to move to the target group.
The Weld Group Command

The Weld Group feature can be useful if, for example, you need to make alterations to your groups after you leave the Setup room or if you import a prop with groups that you want to change. In the Setup room, once your figure is created, Poser breaks the single geometry into pieces corresponding to the groups you created. If you reassign polygons to different groups, the original breaks remain, which can cause your figure to appear broken or disconnected at the point where the old group boundaries lie.

The best way to illustrate this is by using an example. Say you create a figure with, among others, groups for the head and neck. After leaving the Setup room, Poser breaks the single geometry into pieces whose edges correspond to the group boundaries you created. This is necessary in order to allow the figure to bend. Later, you decide to move the neck higher into the head by reassigning some of the polygons in the head group to the neck group. You can do this easily using the Grouping tool.

Poser creates a new break in the geometry at the new group boundary; however, the old break at the old group boundary still exists. This can cause your figure’s neck to appear broken or discontinuous as you pose and render it. To solve this problem, you would:

1. Select the Grouping tool.
2. Select the neck group.
3. Click the Weld Group button.

The Weld Group function alters and combines the vertices on either side of the break so as to create a smooth bridge across the gap. A good way to think of this is to imagine sealing a crack. The filler compound joins the two surfaces, but does minutely alter the surface topography where the crack used to be. The Weld Group function works this way as well, modifying the geometry slightly in order to eliminate the break. This should be unnoticeable in most cases.
Creating/Editing Groups

To create a group, select the Grouping tool. You can then click individual polygons or click and drag to select multiple polygons. If you accidentally select one or more wrong polygons, you can deselect them by using the Deselect tool (see above) or pressing [CTRL] while clicking or dragging. If you are in the Setup room, polygons that have been removed from a group will automatically be added to a group called NO_BONE so that you can see which polygons are unassigned and correct the problems before leaving the Setup room.

To select polygons that are currently out of view, you can use the Wireframe display style, the camera trackball to change the view of your figure, and/or multiple viewpanes to bring the desired polygons into view.

Path names in Poser-related library files and scripts use a colon to separate the folders in the path (ie: Runtime:Libraries:character:myfolder:myproduct.cr2). Using a colon in figure or group names will cause potential problems when parsing PoserPython scripts, as anything after the colon is ignored. Use of a colon in an actor name (such as tail:1 or tail:9) is discouraged. Instead, name the item something like tail01 or tail09.

While working with the Grouping tool, pressing [OPT]/[ALT] allows you to quickly access the camera trackball.

While you are selecting polygons, it is possible that you will select some polygons that have previously been assigned to a different group, either by accident or by design. If this happens, the Grouping tool will remove the subject polygons from their previous group and assign them to the new group in order to ensure that no polygons belong to more than one group at a time.

The Group Editor palette commands do not share this functionality.

When you are creating groups for figures (Setup room), it is important to remember that joint bending only occurs between an object and its parent. The bends do not progress to other children or above the parent in the hierarchy. Keep this in mind as you create your groups, and later when you fine-tune your joints.

The Group Editor palette appears whenever the Grouping tool is selected.
The Hierarchy Editor

The Hierarchy Editor shows every parent/child relationship and every scene element and their various parameters, from lights and cameras to morphs and deformers. You can also view the IK chain settings and external names of each item. The Hierarchy Editor also displays buttons that allow you to configure standard hierarchy, rotation order, IK chains, and new figure.

A scene’s hierarchy describes the parent-child relationships of all objects in your scenes.

Please refer to Poser Figures Hierarchy for more information about hierarchies in general.

Body parts or props that are physically located at a seam are generally contained in either a parent or child object. The scene’s hierarchy also defines data like joint rotation orders and IK relationships.

A Poser document’s hierarchy contains:

- The complete list of all objects in the scene’s universe, including figures, props, body parts, lights, and cameras.
- Hierarchical connections (parent/child relationships) between scene objects.
- Parameters, including rotation, translation, morph targets, and Point At (see Point At).
- IK chains.

See the following sections for additional information about the Hierarchy Editor.

Poser Figures Hierarchy

In order to make a figure bendable, it needs to be attached to a skeleton that moves the polygons in the geometry. In order to attach the polygons (or “skin”) to the bones, the polygons in the geometry must be named the same as the bones in the underlying skeleton.

To utilize as many of Poser’s posing and morphing capabilities as possible, there are specific naming conventions that should be followed. Most human Poser figures follow a hierarchical structure that uses the hip actor as its root. Internal body part groups must always begin with a lower-case letter, with right and left body parts always beginning with a lower-case r (for right) or l (for left) to work with Poser’s Symmetry commands properly.

The internal group names that are used by the Alyson and Ryan figures are shown below in their correct hierarchical structure. Alyson and Ryan have additional groups (shown in bold italics) which control the top and bottom teeth, several levels for the tongue, and an extra joint for each
of the fingers and toes to allow for better bending. Other Poser figures may have more or less
groups, but the basic arrangement of the bones will be similar to that shown below:

hip
waist
abdomen
chest
neck
lEye
rEye
TopTeeth
BttmTeeth
Tongue1
Tongue2
Tongue3
Tongue4
Tongue5
Tongue6
lCollar
lBreast
lShldr
lForeArm
lHand
lThumb1
lThumb2
lThumb3
lIndex0
lIndex1
lIndex2
lIndex3
lMid0
lMid1
lMid2
lMid3
lRing0
lRing1
lRing2
lRing3
lPinky0
lPinky1
lPinky2
lPinky3
rCollar
rBreast
rShldr
rForeArm
rHand
rThumb1
rThumb2
rThumb3
rIndex0
rIndex1
Using the Hierarchy Editor

To display the Hierarchy Editor palette, select **Window > Hierarchy Editor**.
The Hierarchy Editor palette allows you to:

- Select scene elements. Selecting an element in the Hierarchy Editor palette selects that item in the Document, Current Actor pull-down, and Graph palette.

- Access object properties. Double-clicking an object listing in the Hierarchy Editor palette opens the Properties palette for the selected item.

- Quickly hide or view scene elements.

- Rename or delete elements and parameters such as morph targets or Point At parameters. Use caution, as this is a very powerful and very permanent change.

- Set up or change parent-child relationships for props.

- Set up Inverse Kinematics (IK) chains.

- Change rotation orders for props or body parts.

- Create new figures using a legacy method (Poser 4 and earlier) of dragging objects into the scene and arranging them in a hierarchical order, after which the Create New Figure button was pressed. This method has since been replaced with the Poser Setup Room, discussed in The Setup Room.

- Expand or contract the hierarchy list to view parents and children or parents only. Click a right arrow to expand a portion of the tree, or a down arrow to collapse a branch.

- Clicking the down and right arrows in the upper-right corner of the hierarchy window will collapse or expand the entire tree in the hierarchy editor.
Filtering the Display

You can filter what appears in the Hierarchy Editor palette by selecting your desired display options at the top of the palette. Checking a box enables the selected option, and clearing it disables that option. The options are as follows:

- **Show Figures**: Checking the **Show Figures** checkbox displays all figures in the current Poser document.
- **Show Cameras**: Checking the **Show Cameras** checkbox displays all cameras in the current Poser document.
- **Show Parameters**: Checking the **Show Parameters** checkbox displays all object parameters in the current Poser document.
- **Show All Parameters**: Checking the **Show All Parameters** checkbox displays all parameters in the current Poser document.
- **Show Props**: Checking the **Show Props** checkbox displays all props in the current Poser document.
- **Show Deformers**: Checking the **Show Deformers** checkbox displays all magnets, waves, morph targets, and force fields in the current Poser document (scene).
- **Show Lights**: Checking the **Show Lights** checkbox displays all lights in the current Poser document.
- **Show Groupings**: Checking the **Show Groupings** checkbox displays all of the constraint grouping and object grouping objects in the current Poser document, along with objects that are children of them.

Working with Hierarchy Branches

You can perform the following basic actions using the hierarchy listing:

- To expand a hierarchy branch, click the right-pointing arrow next to the branch you wish to expand.
- To collapse a hierarchy branch, click the downward-pointing arrow next to the branch you wish to collapse.
- To expand or collapse items to their top level, use the Down and Right arrows in the upper right section of the Hierarchy Editor window.
- To select an object, click its listing.
• To make an object visible or invisible, click the eye next to the desired icon. The eye appears bright white when an object is visible and gray when invisible.

• To view the Properties palette for an object, double-click the selected object’s listing.

• To delete a figure, prop, or light from your scene, select the item to delete then press [DEL]. You cannot delete body parts, cameras, or the ground plane. You can also delete the selected item by right-clicking inside the Hierarchy Editor and choosing Delete Selected from the popup menu. If you choose to delete a figure, the confirmation dialog will present an option to delete attached figures (clothing that is conformed to the figure). After you make your choice, choose OK.

• To rename an object, click on its listing once to select it, and then a second time to open a text box. (Do not simply double-click on the listing, as this will open the Properties palette for that object.) Enter the object’s new name in the text box.

Reordering Scene Elements

You can reorder scene elements including props and deformers. Reordering deformers can be useful, especially when you have a long hierarchy listing. You can also reorder morph targets and parameters such as rotation orders (this is the same as using the Joint Editor palette). You can also reorder light, camera, and prop Point At parameters.

Be careful when changing rotation orders as this might cause unexpected behavior.

Establishing Hierarchal Relationships

This does the same thing as the Set Parent menu command (see Changing a Parent). To establish a hierarchical relationship using the Hierarchy Editor:

1. Load your desired prop(s) into the scene.
Applying the Standard Hierarchy

If a figure’s geometry was created using standard body group names for human/biped figures, you can use the Hierarchy Editor to automatically apply the Poser Standard Hierarchy to your figure, establishing parent-child relationships. Poser can apply the Standard Hierarchy to full or

Poser Reference Manual

2. Open the **Hierarchy Editor** palette and find the prop.

3. Drag the child object on top of the root (parent) object. A blue box highlights the target when the child object is on top of it.

4. Drop the object onto the highlighted object.

To reorder a child at the same hierarchical level:

1. Click the child object and drag to its new location. A green line appears just below the target location, indicating where the object will be placed once dropped.

2. Drop the object.

You can also create hierarchies spanning figures (such as a woman on horseback):

1. Select the child figure (the woman in this example).

2. Drag the child figure onto the desired parent (the horse in this example).

3. Drop the child.

You can also set up hierarchies between figures outside the Hierarchy Editor palette as follows:

1. Use the pop-up to select the child figure.

2. Select **Figure > Set Figure Parent** (see Set Figure Parent) to open the Set Parent dialog.

3. Select the parent body/body part in the dialog and click **OK**.

**Applying the Standard Hierarchy**

Dragging and Dropping to parent an object.
Creating IK Chains

To create an IK chain:

1. Scroll to the bottom of the hierarchy list using the scroll bar and click the **IK Chains** entry to enable the **Create IK Chain** button.
2. Enter a name for the chain you are creating in the dialog box that pops up and click **OK**. A blank IK chain appears in the list.
3. Plan each element in the IK chain from root to goal. For example, the IK chain for the right arm has the right hand as the goal.
4. From the hierarchy list, click and drag body part listings onto the new blank IK chain. They will be added to the IK chain in the order you drag them from root to goal. Proceed to add parts to the chain in the order of root to goal.
Creating an IK chain.

Be careful when creating IK chains as you could cause your figure to move in unexpected ways when the new IK chain is added.
The Setup Room

The Setup room is one of Poser’s most powerful features. It allows you to modify existing props or figures, or even create your own for use with Poser.

The Setup room allows you to fully rig new figures by creating and setting up joints, hierarchy groups and IK chains. It allows you to create these elements in a graphical environment, rather than having to manually edit a configuration file in a text-based environment.

When the Setup room opens, it displays many of the controls that you will need to create poseable figures. Depending on the size of your workspace, you may see the Camera controls, Joint Editor, Editing tools, Parameters/Properties palette, or Hierarchy Editor in this room. Of particular importance is the Bone Tool, which allows you to graphically create a skeleton for your figures.

The number of palettes and options that you see in each room depends upon your screen resolution. At higher resolutions, the default workspaces display more palettes, while at lower resolutions you see fewer palettes.

The Setup room is an extremely powerful tool that can permanently modify your figures, including those originally included with Poser. Always save your figures to the Library palette to prevent inadvertently damaging one of your existing figures and to enable you to return to a previous figure setup if you
Creating Figures for Poser

Figures do not have to be anthropomorphic (human-shaped). A figure’s mere appearance has no effect on how it functions within Poser. In reality, there are two things that determine how you can move and animate a figure:

- The figure’s underlying skeleton (called a bone structure), which determines the hierarchy and location of joints.
- The manner in which the figure’s polygons (the rough equivalent of skin and muscles) are grouped or attached to the bones.

Prior to the release of the Pro Pack add-in for Poser 4, figure creators pre-grouped OBJ models into specifically-named body parts, and then used a text-based method to convert them into poseable figures. While Poser still supports this method of figure creation, the graphical Setup room can eliminate 90% of your figure creation time. This room allows you to create/modify Poser figures in a completely graphical environment.

There are three ways to make figures for Poser:

- Using hierarchy files combined with an external model

  Figure creators wishing to create Poser figures using the text-based method should refer to the Creating and Converting Hierarchy Files, which covers the text-based figure creation method in detail.

- Using the hierarchy palette (discussed in The Hierarchy Editor) to combine props together to form a figure.

- Importing a geometry and using the Setup room as discussed in this chapter.

About the Setup Room

The actual process of creating a poseable figure involves a greater number of detailed steps, each of which is discussed in this chapter. Briefly, the Setup room figure creation/modification process is as follows:

1. Use props that are included with Poser, or create the geometry for your new figure in your favorite 3D modeling application.
2. Import your geometry as a prop using the **File > Import** command. Once the geometry is complete, enter the **Setup** room.

3. Create and/or modify your figure’s bone structure or skeleton. Like a real skeleton, your figure’s skeleton is the underlying framework that determines where bends occur. You can import a skeleton from a similar figure or create your figure’s skeleton from scratch.

4. Position the skeleton and joints to match your figure. This step is critical to ensure that your figure bends as accurately as possible.

5. “Put meat on the bones” by grouping the various portions of your figure and assigning bones to those groups.

6. Fine-tune the figure’s joints, and then exit the **Setup** room to test your new figure and complete the figure creation/modification process.

7. Assign IK chains using the **Hierarchy Editor**, set favored IK angles and joint limits, and memorize this information.

8. Readjust your figure’s joints if necessary, and then save your new figure to the **Library** palette.

---

**Exiting the Setup room during the figure creation process may cause you to lose some recent changes. A warning will appear if exiting the Setup room will cause data loss.**

---

### The Setup Room Interface

The **Setup** room interface is designed to be similar to the **Pose** room interface and functionality, with a few minor changes:

- You cannot pose the figure you are creating while in the **Setup** room. Instead, the figure’s bone structure (if any) appears in the **Document**, allowing you to position and adjust each bone.

- While in the **Setup** room, loading a figure from the **Library** palette loads the selected figure’s bone system and applies it to the current object. Geometry is altered when switching between the **Pose** and **Setup** rooms. While in the **Pose** room, each body part is treated as a separate geometry object. While in the **Setup** room, all of the body parts are combined into a single object for easier grouping and welding operations. Clicking the **Create New Figure** button in the **Library** palette loads the selected figure’s bone structure for modification and use on the figure you are creating or modifying. You can also double-click the figure to load its bones.

The **Setting Up an Original Figure** sections explain the figure setup process in detail.

---

### Setting Up an Original Figure

- **Step 1: Importing/Arranging Geometries**
- **Step 2: Loading and/or Creating Bone Structures**
Step 1: Importing/Arranging Geometries

Begin the figure creation process by inserting the prop(s) you wish to assemble into a figure. Do this by adding props to your scene using the Library palette and/or by importing geometry objects (static mesh objects or props). If using more than one prop, be sure to arrange your props in their final positions before beginning the figure conversion process.

Please refer to Importing Content for information on importing geometries into Poser.

In order to be rigged, you need to create your geometry properly and assign each body to a unique body part group (or actor); otherwise the geometry won’t be treated as a separate body part. Example group names for the Alyson and Ryan figures are listed in Poser Figures Hierarchy.

Step 2: Loading and/or Creating Bone Structures

This section describes what bone structures are, what they do, and how to create/modify a bone structure for your imported geometry or figure.
About Bone Structures

Each Poser figure includes hierarchy and joint information that together determine how the figure behaves when posed. The Setup room expresses this information as a bone structure or skeleton that is tailored to each figure. Skeletons are a critical part of your figures because they define where and how the figure bends, just as your own bones define how and where you bend. Skeletons provide the following information for each figure:

- **Defining the figure’s hierarchy**: The skeleton defines the parent/child relationships in your figure. Please refer to Poser Figures Hierarchy for information about hierarchies within Poser.

- **Locating joints**: Just as with your own skeleton, your figure will only bend at joints, which are the places where bone ends meet.

- **Limiting figure movement**: By now, you are keenly aware that each joint in your body has a limited range of motion under normal circumstances. For example, your elbow only bends in one direction and cannot flex beyond straightening your arm out, your wrist can move in any direction within a narrow cone, and so forth. You can define limits for each of your figure’s joints. These limits can prevent you from creating unnatural looking poses, one part of the figure crossing through another part, etc.

- **Figure resolution**: The more bones your figure’s skeleton has, the greater degree of flexibility (resolution) it will have. For example, the Andy figure allows you to bend the shoulder, elbow, and wrist, but not the palm or fingers. By contrast, the Ryan figure lets you adjust the precise position of each finger.

- This image shows Andy’s left hand and underlying bone structure on the left, and Ryan’s left hand and bone structure on the right. Note that Andy has only one bone to define his entire hand, while Ryan has a far more realistic bone structure complete with palm and fully articulated finger joints.

![](image)

**Bone structures of a simple hand and a more complex human hand.**

Bones appear as light gray pyramids with the bases pointing towards their parents and the tips pointing towards the children. Selected bones appear red.

About Creating a Bone System

There are two basic scenarios for creating or editing a bone system:
The Bone Tool.

The following sections discuss selecting a bone system for your geometry and using the Bone tool.

**Selecting the Proper Structure**

The quickest way to define a bone structure for your new figure is to load the bone structure of a figure that resembles your current object as closely as possible. For example, the simple geometry shown below does not require a high-resolution bone structure, since it does not have fingers or other detailed features. If you are creating an animal figure, you should probably load an animal figure’s bone structure. The basic idea is to minimize the amount of work you have to do.
Inserting & Deleting Bones

The Bone tool lets you create bones, either within a bone structure or from scratch. To create a bone, click at the point where you want the bone to begin (base) and drag to where you want the end (tip). You can fine-tune the bone’s position and parameters later, so you do not need to worry too much about being perfect.

Adding bones to a figure.

New bones are created as children of the most recently selected or created bone. You can select a previously created bone (or any bone in the skeleton) and add new child bones by single-clicking the bone you wish to use as a parent and then clicking and dragging to create a new bone as described above. The graphic shows a new bone inserted between the hip (parent) and thigh (child).

Bones can be selected as follows:

- In the Hierarchy or by clicking on the bone with the Bone tool selected
- Via the Actor selector in either the Properties palette or the Setup room Preview tab

To delete a bone, simply select it and press [DEL].

Positioning the Bones

Now that your bone structure is built to match your geometry, the next step is to align the bones with the geometry. Unless you have already built a bone structure for a figure and have simply tweaked the geometry slightly, the chances are that the default bone positions will not line up with the geometry, as shown in the graphic on the right. The figure on the left illustrates the effects of having a bone structure that is not positioned according to the geometry, while the figure on the right demonstrates proper figure behavior.
When bones are not positioned correctly, body parts can appear distorted.

You can position bones using any of three methods:

- Select one of the available Editing tools (Rotate, Twist, Translate/Pull, Translate In/Out, or Scale) and position the bones using the mouse.

- Use the Joint Editor palette to precisely position joints.

- Use the Rig Symmetry control (see Positioning_Bones_Using_Rig_Symmetry) to position the bones on the opposite side of the figure.

You will probably use a combination of all three methods as you work to position the bones on your geometry. The following sections discuss each of the three methods in detail.

### Positioning Bones With the Mouse

You can position bones with the mouse in one of two ways:

- Selecting the desired Editing tool followed by clicking in the middle of a bone uses the selected tool to modify the position of both the selected bone, all of its children, and all joint settings for both the current bone and all children (including falloff zones). This Selecting, clicking and dragging into position is the preferred method.

  Please refer to Creating and Using Falloff Zones for an explanation of falloff zones.

- Clicking near the beginning or end of a selected bone allows you to translate just the selected endpoint regardless of the selected Editing tool. The mouse pointer changes to a bull's eye when you select a bone and place the pointer near the beginning or end of the selected bone, as shown.
Adjusting bone placement.

When editing bone endpoints, joint settings such as falloff zones are not adjusted. This method is good for making minor adjustments once the bones have been placed near their final positions. After you have properly aligned the skeleton to the geometry, you can adjust the falloff zones further. Please refer to Creating and Using Falloff Zones for an explanation of the various types of falloff zones.

When positioning bones using the mouse, you should use one of the orthographic cameras (Left, Right, Top, Bottom, Front, Back) to ensure that you are only positioning them in one plane at a time. Alternatively, you can use the Document’s multiple pane view to position the bones in 3D space.

Positioning Bones With the Joint Editor Palette

In addition to (or instead of) using the mouse to position bones, you can use the Joint Editor palette by selecting the bone you wish to edit. Please refer to Working with Joints and Weights for complete information on using the Joint Editor palette.

Positioning Bones Using Rig Symmetry

Assuming your imported geometry is symmetrical, you can drastically reduce the amount of time it takes for you to position bones by positioning only those bones on half of the geometry and then using the Figure > Rig Symmetry commands to automatically position the rest of the bones.

The Symmetry functions involving arms, legs, and the torso only work when the bones in those regions have been named and grouped so as to belong to the selected areas of the geometry. If you have loaded an existing bone
There are several different options for Rig Symmetry:

- **Left to Right**: Copies rig settings from the entire left side to the right side.
- **Right to Left**: Copies rig settings from the entire right side to the left side.
- **Left Arm to Right Arm**: Copies rig settings from the left arm to the right arm.
- **Right Arm to Left Arm**: Copies rig settings from the right arm to the left arm.
- **Left Leg to Right Leg**: Copies rig settings from the left leg to the right leg.
- **Right Leg to Left Leg**: Copies rig settings from the right leg to the left leg.

Custom: Allows you to configure custom rig symmetry settings. Press Custom to open the Apply Custom Figure Symmetry dialog described in [Applying Custom Rig Symmetry](#).

### Applying Custom Rig Symmetry

The Custom Symmetry dialog allows you to selectively apply rig symmetry on any combination of body parts, and to apply symmetry across a specified number of frames in an animation.

Choose **Figure > Rig Symmetry > Custom** to open the **Apply Custom Figure Symmetry** dialog. This dialog allows you to select body parts on which rig symmetry can be applied. The options in the Apply Custom Figure Symmetry dialog are as follows:

*Apply Custom Figure Symmetry dialog.*

- **Left to Right**: Choose this option to apply the values from the left side of the figure to its right side.
- **Right to Left**: Choose this option to apply the values from the right side of the figure to its left side.
- **Apply Symmetry To**: Allows you to specify the type(s) of symmetry that you are applying.
  - **Limits**: Check this option if you want to copy limit settings from one side of the figure to the other.
  - **Joint Setup**: Check this option if you want to apply joint settings (translation or rotation, weights, etc.) from one side of the figure to the other.
- **Hierarchy Window**: Check or uncheck the body parts that you want to include in your Custom Symmetry action.
Step 3: Naming the Bones

The Properties palette allows you to modify the following settings:

- **Select All**: Selects all items in the hierarchy list.
- **Select None**: Deselects all items in the hierarchy list. Allows you to ensure that all items are deselected before you select specific items to include.
- **Cancel**: Exits the Apply Custom Figure Symmetry dialog without applying the settings.
- **OK**: Click to apply your choices to the selected figure.

This is a critical point. The only way to link a bone to a group of polygons is to have them share the same exact internal name. The only place to modify internal names within Poser is in the Setup room, and then, only in the Properties palette.

If you want your figure to support many of Poser’s features, you should respect the bone/body part internal naming conventions precisely. Group names for the Alyson and Ryan figures are listed in Poser Figures Hierarchy.

- **Name**: The Name field is where you input your desired external name, which you use for your own reference. You can use any name you wish. This can be helpful if, for example, you are working in different languages.

Any other displayed options do not affect bones and should be ignored.

Step 4: Attaching Bones to Geometry Parts

This is the part of the Setup room figure creation process where you associate (group) bones with portions of the geometry, giving your geometry the ability to bend and move. It is important that you take great care during this step to ensure that your new figure will be able to bend and, just as importantly, bend correctly.
Poser Reference Manual

Step 4: Attaching Bones to Geometry Parts

Your geometry consists of many polygons that together form its overall shape. At this point, Poser knows the skeleton, including its joints, parents, and children. It knows that moving one bone will affect its children and may affect the parent, and it knows how each joint should behave. However, Poser does not yet know which polygons need to move for any given movement of the skeleton. To enable your geometry to bend, you must combine logical subsets of the polygons that make up your geometry and group each subset with the appropriate bone.

Where you need to be careful is in being sure that the correct polygons are assigned to the correct bones, that is, the right arm should move when you move the right shoulder bone, and so forth. It is possible to assign any polygon to any bone. You could have polygons in the leg region grouped with a bone in the neck, for example. You could even have random polygons scattered around the geometry grouped with any bone in the skeleton. While you may wish to do this for experimental or artistic purposes, this manual will assume that you are trying to create a realistic figure from the geometry and skeleton.

Now that the skeleton is complete, it is appropriate to think of each bone as a body part. For each such body part, an identically named group of polygons on the geometry must exist. Each of the joints will cause the grouped polygons to bend where parent and child groups touch. Poser knows which polygons to bend by matching the internal name of the bone being moved with the internal name of a group of polygons.

**If you are adjusting an existing figure in the Setup room, the necessary body groups will already exist and may already be properly set up.**

To create groups, select the **Grouping** tool, which opens the **Group Editor** palette. The **Grouping** tool can select polygons to create a group. Then you can use the Assign Material button to assign a name for the body part for the selected polygons.

**Requirements**

As discussed in **Importing 3D Objects**, your imported geometry cannot have overlapping or duplicated polygons and, if you have created groups when you built the geometry, the polygons in the geometry cannot belong to more than one group at a time.

The **Setup** room allows you to create figures from a single geometry consisting of ungrouped polygons. This is the recommended method.

**Grouping**

There are a number of different ways that you can assign groups to your figures. For example, some assign groups in their modeling application or with other utilities. You can, however, use
Poser’s Group Editor to create and assign groups to the polygons in your model. The Group Editor allows you to select polygons manually and then assign them to groups. If your figure does not already have groups assigned, you can also use the Auto Group feature to automatically generate groups based on the bone structure of the skeleton. For further information, refer to The Group Editor for information about using the Grouping tool and the Group Editor palette.

**Step 5: Assigning Rotation Orders**

With your bones positioned and your groups created, you’re almost finished. Your once-static geometry has come alive! You can perform this step when you are first creating and defining joints; however, it appears here in the figure creation process so that you can leave the Setup room to see how changes to the rotation order affect your figure’s motion and appearance.

If your figure uses a standard T-position pose, and also is grouped similarly to the standard Poser figures, you can use the Hierarchy Editor to assign standard rotation orders to the joints in your figure. This can save time in setting up the joint rotations. You can learn more about configuring rotation orders manually in Setting Joint Orders.

To apply standard rotation to a figure:

1. Choose Window > Hierarchy Editor to display the Hierarchy Editor.
2. Select the Universe.
3. Click the Apply Std Rotation Order button to apply the standard rotation settings.

**Step 6: Fine-Tuning Joints**

At this point, you may want to go back and fine-tune some or all of your joints so as to make your figure behave exactly as you want it to. Do this using the Bone tool and/or Joint Editor palette as discussed in Working with Joints and Weights. Use spherical or capsule-shaped falloff zones, or weight painting, to add more realism to the appearance of the joints as they rotate, bend, and twist.

Remember that joint bending only occurs between an object and its parent. The bends do not progress to other children or above the parent in the hierarchy. Be sure to keep this in mind as you tweak the joints. Also, if you have body parts which are symmetrical left to right, and are named using the convention of starting with “r” for right-side body parts and “l” for left-side body parts, you can automatically copy joint zones by using one of the symmetry commands as discussed in Positioning_Bones_Using_Rig_Symmetry. This can save time and effort when tweaking joints, and ensures that one side of your figure will behave exactly like the other part.
Step 7: Testing Your Figure

This is the moment you have been working towards. At this point, return to the Pose room and put your new figure through its paces. You can use multiple view panes and the Camera controls to see your figure from all angles to ensure that it is performing as expected. If you need to make any adjustments, you can always return to the Setup room to further refine your figure. Congratulations: Your once-static geometry prop is now a movable Poser figure!

Step 8: Assigning IK Chains

In order for you to be able to use IK on your new figure, you need to create at least one inverse kinematics chain using the Hierarchy Editor, as discussed in The Hierarchy Editor.

You created the parent/child hierarchies in your figure when you created and edited the bone structure. The Hierarchy Editor will perform all of its functions on your new figure.

Step 9: Inverse Kinematics

If you wish to add IK capabilities to your figure, you need to add IK chains as discussed in Creating IK Chains.

Step 10: Setting & Memorizing Favored IK Angles

Poser’s inverse kinematics works based on the current rotations of a body part. Proper IK angles must be preset in the figure in order for IK to work predictably. The original joint rotation values help the IK logic know which way to bend some of the joints and will affect how the IK works as the figure moves. Setting and memorizing favored IK angles is therefore important.

Before memorizing the default positions for all of the body parts, you should bend the parts used in IK chains so that they favor their natural bending directions. For example, a standing person’s thighs bend slightly forward and out from vertical, and her or his shins bend slightly back and in.

These positions can be tested by lowering the hip joint in the Y (up/down) direction while IK is turned on for the legs. While doing this, the knees should bend smoothly, and not buckle or swing widely to either side.

Then, to test the arms, enable IK on the arms and move the chest side to side (X trans). The arms and shoulders should bend naturally. If they do not, add small amounts of rotation into the joint to correct the unnatural bending.
With IK off, return the hip to zero and the chest to zero. Preserve the rotations on the limbs. Make sure that they are symmetric from one side to the other. Then memorize figure to store the rotations.

To set favored IK angles:

1. Disable the affected IK chain(s).
2. Position each body part in the chain by slightly bending it in the direction it would bend under IK by a few degrees.
3. Save the angles by memorizing the body parts or the entire figure by selecting Edit > Memorize > Object or Edit > Memorize > Figure, respectively.
4. Enable the affected IK chain(s).

Please refer to Inverse Kinematics (IK) for more information about Poser's Inverse Kinematics features.

**Step 11: Setting Joint Limits**

In the “real world”, each of your body’s joints has limits on its motion. For example, you cannot extend your arm at the elbow beyond the point where your arm is straight. Further, it is not possible for one of your body parts to “collide” or intrude on another part. You cannot simply put your hand through your chest.

Poser allows you to set limits for each joint to mimic these natural limits and help prevent you from creating unnatural poses. Additionally, you can create limits on the amount that a body part can be scaled and tapered, and you may have other options available depending on the body part in question.

It’s good practice to set limits per parameter for your figures. The user can then choose to use or ignore your limits using the Figure pull-down menu by toggling the Use Limits command on or off.

To set limits for a body part, simply select the desired body part, then double-click any of the parameter dials in the Parameters palette to open an Edit Parameter dialog box, where you can set limits for the selected parameter. Please refer to Editing Parameter Dials for information on setting parameter limits.

**Step 12: Finalizing Your New Figure**

At this point, you have created and fine-tuned a new Poser figure. From a technical standpoint, the figure creation process is complete. If you wish, you can add materials and textures, make
additional adjustments, and do anything you need to do in order to consider the project complete.

You can also add morphs or use deformers that smooth areas like knee and elbow bends and link these morphs or deformers to the arm/leg bends as dependent parameters. For more information, see Using Dependent Parameters.

**Step 13: Memorizing and Saving Your New Figure**

You have hopefully been saving your figure throughout the creation process. Now that it is complete, be sure to memorize the figure by selecting Edit > Memorize > Figure. Also, be sure to save your figure in the Library palette. You can save your figure in an existing subcategory or create your own.

**Deleting Interim Figures**

If you have saved draft figures as recommended during the figure creation process, you may want to delete these draft figures to avoid wasting hard drive space. To delete an item, select it in the Library palette and click the Delete from Library icon (-) at the bottom of the palette.

**Troubleshooting**

When creating a new figure from an existing figure, there may be existing parameters that no longer function properly with the new geometry. For instance, morph targets that used to work on the old figure may do nothing if you change the geometry. You can delete these channels in the Hierarchy Editor by checking the Show Parameters box, selecting the parameters to delete, and pressing [DEL].
Working with Joints and Weights

What are Joints?

A joint is a location on a figure where two body parts meet at a point where they bend, twist, rotate, or bulge: for example, a human knee or an elbow is a joint. In Poser, these realistic figure movements are controlled by joint settings. These joint settings are applied through various options in the Joint Editor.

Poser's traditional joint system utilizes the following:

- **Spherical falloff zones** that use inner and outer spheres of influence to determine which vertices move when a joint is rotated, and the amount of movement the vertices move.

- **Capsule-shaped falloff** zones that work similarly to spherical zones, but which allow more flexibility in defining the shapes of the inner and outer zones of influence.

In addition to the traditional falloff zones, **weight-mapped bending** controls offer increased flexibility in how vertices respond to movement. By providing both traditional and weight-mapped methods, Poser offers a three-fold solution that allows you to use traditional falloff zones, weight maps, or a combination of both. You get the best of both worlds!

Using the Joint Editor

Poser makes a figure “poseable” through the use of transformers and transformation zones that control the way a figure bends and twists. These transformers and their zones skew, rotate, stretch, or scale polygons that fall within a transformation zone to produce the desired motion.

You can use the Joint Editor to manipulate joints and blend transformers directly, thereby modifying how a joint or bone works. The Joint Editor is used to accomplish the following:

Fine-tune the blending of existing figures to suit your needs.
Create new types of effects in how the polygons in the current part respond to transformations.

Customize joints and transformers when creating your own figures (such as using the Setup room, described in The Setup Room).

To open the palette, select Window > Joint Editor. This palette can be used in the Pose Room and in the Setup Room. When used in the Pose room, the Joint Editor allows you to adjust the currently selected joint. When used in the Setup room, the Joint Editor allows you to adjust the currently selected bone.

**Parts of the Joint Editor**

The Joint Editor displays the various components of the selected joint. For example, if you have the right shin selected, the Joint Editor will display the settings related to the knee (the point at which the right shin begins).

The Joint Editor displays the following options and controls, depending on the joint that you have selected:

- **Attribute selector** (1): Use the Attribute selection menu to display and edit the settings for a specific attribute. For example, when you have the right shin selected, you can use the menu to choose one of the following attributes: Center, Twist, Side-Side, or Bend. In addition, there will be a couple of additional settings that relate to the body part that is immediately below the current part (its child). In the case of the right shin, the child attributes would relate to the right foot. In most cases, the attributes for the "child" part are left alone when editing the current joint.

- **Display Options** (2). Allows you to show or hide various display options for the selected transform:
• **Deformer:** When checked, will display the deformers (if any) that are associated with the selected joint.

• **Verts:** Shows or hides the display of colored dots that give you a visual indication of how the vertices and polygons will be affected when you adjust the joint settings.

• **Shaded:** Enables shaded display mode for sphere or capsule zones of influence. Inner mat spheres or capsules are shaded green, and outer mat spheres or capsules are shaded red.

- **A chest joint with verts and shaded display.**

• **Falloff Zones** (3): There are three types of falloff zones: Spherical Zone, Capsule Zone, and Weight Map. Each of these will be described in Creating and Using Falloff Zones.

• **Parameter dial and value** (4): When you choose an attribute that has a Parameters dial associated with it, a dial will appear in the Joint Editor. You can use this dial to adjust the parameter through its minimum and maximum values to test how the current joint settings affect the mesh.

• **Joint Angles setting** (5): This section displays or edits the inclusion and exclusion angles, which determines which vertices and polygons are included or excluded in the current transform. Further information can be found in Setting Joint Angles.

• **Bulge Settings** (6): Allows you to add additional settings that specify how polygons bulge and flex while the joint is moved. See Editing Bulge Settings.

• **Joint Orders** (7): Allows you to set the order of the X, Y, and Z axes, and the types of rotation that they relate to. See Setting Joint Orders.

• **Zero Rotations button** (8): As you are working with all of the joints in your figure, you may have one or more rotations (bend, twist, side to side, and so on) set to values other than zero. Click this button to return all of the joint rotations back to their zero values, which returns the figure to its normal “default” position.

• **Affected Actors menu** (9): Use this menu to select additional body parts that you want to be affected by the parameter that you are editing. For more information about affected actors, see Adding Affected Actors.
How Joints are Displayed

When the Joint Editor is opened, there are several indicators that appear when a body part is selected. These indicators help you control how the joint works and responds when you pose the figure. Each of these indicators are described below.

Deformer Indicators

Depending on the type of attribute selected you will see a different type of indicators for the joint. The following figure shows the types of indicators that appear when Center, Twist, Side-Side, Bend, and neighboring joint indicators are selected. You can use the handles on these indicators to visually adjust the joint attributes, or you can use numerical fields in the Joint Editor to change them. Each of these attributes will be discussed in Joint Attribute Types.

Joint Strength Indicators

The Joint Editor allows you to control joints and blend zones. Blend zones define how the area that transitions from one joint to another react when they bend, twist, or rotate. As you work in the Joint Editor, you will notice that the selected body part is covered with different colored dots. The color of these dots represent where a joint parameter or falloff zone has the most amount of effect.

- **Create Smooth Trans**: Click this button to create smooth transition zones that blend between translated body parts. For more information see Smooth Translation Bending.
- **Edit Scale Zones (11)**: Click this button to create weight maps that smooth out the transitions between joints when the joints are scaled along a single axis. For more information, see Smoothing Scale Zones.
In the figure shown below, a figure’s right thigh is selected as the current body part, and the Bend parameter is the parameter that is being edited. The joint is placed at the right knee. Notice the multi-colored dots which show how the joint affects the selected body part:

- Bright green dots appear where the joint or zone has the greatest effect. In other words, when you bend the right shin, the entire area that is covered with green dots will be affected by the bend.
- Yellow dots appear where there is a blend between the moving part (the shin) and the stationary part (the thigh). In other words, when the right shin is bent, the polygons that are highlighted with yellow dots will stretch or squash or skew to make the transition as smooth as possible.
- Red and darker dots appear where little or no effect occurs. In other words, when you bend the right shin, the right thigh (which is above the shin) will not be affected.

*The strength of a joint is represented with multi-colored dots.*

**Editing Joint Parameters**

To edit a joint’s parameters:

1. Select the desired joint in the Pose Room.
2. Choose **Window > Joint Editor** to open the **Joint Editor**.
3. Use the Selection menu to choose the attribute that you want to edit. Each joint will have several parameters and will include some of the following: Center, Twist, Bend, Side to Side, Front to Back, or Up and Down. These attributes are further described in Joint Attribute Types.

4. Use the Falloff Zones section to add additional deformers that can affect the selected attribute. If no deformers exist, click the Add button to add one or more. You can add one of three types of transformers: Spherical, Capsule, or Weight Map. These will be described further in Creating and Using Falloff Zones.

5. The section beneath the Falloff Zones section shows numerical values for the currently selected joint attribute. You can either change these values manually, or by making adjustments to the deformers in the document window. For example, if you are displaying the Twist attribute, you can enter values for Twist Start and Twist End in the Joint Editor, or you can click and drag the ends of the Twist indicator in the document window to make adjustments visually.

6. If the joint attribute allows, optionally enter Bulge Settings that make the selected body part bulge more realistically when the parameter is adjusted. These are discussed in Editing Bulge Settings.

7. Set the Joint Order as described in Setting Joint Orders.

8. When you are finished setting all of the joints, you can use the Zero Figure button to return the character to its default position, and then save the figure to your library.

Joint Attribute Types

Each joint in a figure’s bone structure has some or all of the following attributes. The attributes available for each joint depend on the currently selected joint. You can think of the Joint Editor palette as working with body parts or bones, since the end result is the same. For the sake of discussion, it is appropriate to think of the Joint Editor palette as acting on body parts when in the Pose room and bones within the Setup room.

This section explains how to adjust each available joint parameter. Note that not all parameters will be applicable to every joint. Only those parameters applicable to the selected joint will appear in the joint editor.

Center

The Center attribute sets the center of rotation for the selected bone. It is available for all bones, body parts, and props.

Hold your arm out with the palm up, bend it at the elbow, and notice that the center of the rotation is about halfway between your inner and outer elbow. Notice how your skin contracts above the center of rotation and expands beneath it. Imagine if the center of rotation was in a different location and how that would affect the appearance of your arm as you bend it. Move
some other joints and imagine the changes that might occur if you shifted those centers. The **Center** attribute controls this aspect of joint motion.

![Center attribute and settings.](image)

The following options are available when adjusting the Center joint parameter:

- **Center Point**: The Center Point attribute defines the XYZ position of the joint (center of the body part). 0,0,0 is located in the center of the bone structure on the floor. Click the Key icon to create animated centers, as described in [Manually Adjusting Animated Centers and Orientations](#).

- **End Point**: The End Point attribute is discussed in [End Points](#), which follows.

- **Orientation**: The Orientation attribute defines the XYZ rotation of the joint and its axis. Click and drag the dials to set a value. Pressing and holding [OPT]/[ALT] while clicking a dial resets its value to 0. Click the Key icon to create animated orientations as described in [Manually Adjusting Animated Centers and Orientations](#).

- **Align**: Clicking the Align button aligns the joint with its underlying body part or group, and will automatically adjust the values in the Orientation fields (above). This option can be useful once you have created groups and attached the bones to the geometry. Prior to that point in the process, however, there is nothing to align the joint to.

- **Joint Order**: See [Setting Joint Orders](#).

- **Zero Figure**: See [Parts of the Joint Editor](#).

### End Points

If a joint has a single child joint, the endpoint will always be the origin of the child. If there are multiple children (as in a hand) the endpoint can be set manually. This feature is used for some of the interaction tools, such as the Rotate tool for orientation from the origin. If there is no child joint (as with the head, typically) the endpoint is also editable.
End Point attributes.

**Twist**

The Twist attribute changes the location of the twist deformer for the selected bone.

There is no Twist attribute for the hip bone or its equivalent, since the hip is the parent for the entire figure and twisting the hip twists the entire figure in unison.

When IK is enabled, child bones rotate when the parent is twisted. Twisting the hip normally moves the entire body since the hip is usually the parent for the entire figure, meaning that the hip does not have this parameter.

Hold your arm out with the palm down, and twist it so your palm is facing up. Notice how most of your arm does not change, except for a region in your upper arm where the skin and muscles twist as you move. Imagine if the twisting began and/or ended in a different location. The Twist attribute controls this aspect of joint motion.

By default, the Twist axis runs lengthwise down the center of each body part. For example, the arm twist axis is X, while legs twist along the Y axis. When this parameter is selected, a line with two handles appears on the figure. The red handle represents the starting point of the twist transformation area, and the green handle represents the end. Dragging these handles increases or decreases the Twist area.

Twist attribute and indicators.

The Twist parameter has the following settings and options:
Joint Attribute Types

- **Display Options**: See [Parts of the Joint Editor](#).
- **Falloff Zones**: See [Creating and Using Falloff Zones](#).
- **Twist Start** and **Twist End**: Define the beginning and ending points of a bone’s twist area. Enter your desired values in the appropriate boxes, or drag the red handle of the indicator to adjust the Start value, and the green handle of the indicator to adjust the End value.

You can make twist areas larger than the selected bone, which can make a twisting motion appear more natural. In many cases, the bone’s parent should be included in the twist zone.

You can use the **Editing** tools to adjust the Twist parameter. This parameter exists in three dimensions, meaning you can rotate the figure to see the joint from any angle. You may, however, want to leave the figure in its default position and use the orthographic cameras (Top, Bottom, Left, Right, Front, Back) to constrain movement to two axes, possibly avoiding much confusion.

- **Joint Order**: See [Setting Joint Orders](#).
- **Zero Figure**: See [Parts of the Joint Editor](#).

**Side-Side, Bend, Front-Back, and Up-Down**

The joint settings for **Side-Side**, **Bend**, **Front-Back**, and **Up-Down** are very similar. The main difference between them is the axis on which they rotate:

- The **Bend** attribute controls the angles of the Bend transformers, and defines how bulges are created. To illustrate this, bend and flex various joints (such as your elbow or knee). You’ll notice limits of your flexibility, and how the skin and muscles bulge as you move. The Bend attribute lets you control how this occurs in your figure.

- The **Side-Side**, **Front-Back**, and **Up-Down** attributes control the angles of their respective transformers and also define how bulges are created. These attributes are suited for omnidirectional joints such as your wrists, shoulders, hips, ankles, etc. The various parameters are shown in the following table.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Body Part(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bend</td>
<td>All but Hip, Collars, and Shoulders</td>
</tr>
<tr>
<td>Front-Back</td>
<td>L &amp; R Collar, L &amp; R Shoulder</td>
</tr>
<tr>
<td>Joint Attribute Types</td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Up-Down</strong></td>
<td></td>
</tr>
<tr>
<td>L &amp; R Collar, L &amp; R Shoulder</td>
<td></td>
</tr>
</tbody>
</table>

**Bend attribute settings.**

The following settings appear in the **Joint Editor** for **Bend**, **Side-Side**, **Front-Back**, and **Up-Down** parameters. Each of these three parameters is functionally identical when editing these joint attributes in the **Joint Editor** palette. The settings in the **Joint Editor** allow you to change their angles and transformers. Poser can also create bulges that emulate muscle movement.

- **Display Options**: See Parts of the Joint Editor.
- **Falloff Zones**: See Creating and Using Falloff Zones.
- **Joint Angles**: Defines the polygons that are included or excluded from the Bend parameter. You can either use the Inclusion and Exclusion handles to adjust these values visually, or enter values in the Joint Angles fields. The area between the two red handles define the polygons that are excluded and will remain stationery. The area between the green handles defines the polygons that will move completely. The area in between a green handle and a red handle will "deform." For more information, see Setting Joint Angles.

You can use the **Editing** tools to adjust the Bend, Side-Side, Front-Back, and Up-Down parameters. These parameters exist in three dimensions, meaning you can rotate the figure to see the joint from any angle. You may, however, want to leave the figure in its default position and use the orthographic cameras (Top, Bottom, Left, Right, Front, Back) to constrain movement to two axes, possibly avoiding much confusion.

- **Bulge Settings**: See Editing Bulge Settings.
- **Joint Order**: See Setting Joint Orders.
- **Zero Figure**: See Parts of the Joint Editor.
Scaling

Each body part has parameters allowing you to scale the parent and child body parts. These settings are similar to the Twist parameters and follow the Twist axis of the child or parent body part. For example, Ryan’s Right Collar body part has scaling controls for the chest (parent) along the Y axis and the Right Shoulder (child) along the X axis.

The High End/Start and Low Start/End parameters define a blending area. For example, when scaling the head, you may also want to scale the top of the neck to achieve a smooth fit. When setting these parameters, only one setting (high or low) is relevant. The unused parameter pair gets automatically set to some unrealistic number (such as 99,000 or 100,000), thus indicating that it is not relevant to the area you’re working on. Do not edit these out-of-limit settings.

Each blending zone’s end is represented in red, with its beginning in green. Effects can be either uniform or can use spherical falloff zones, discussed below.

Creating and Using Falloff Zones

Falloff Zones are Poser’s fundamental method of creating smooth bending figures by blending between two bones or body parts. You can use falloff zones on any type of rotation (such as Bend, Side-Side, Front-Back, or Up-Down). A Falloff Zone section appears in the Joint Editor where it is appropriate to use falloff zones on a joint. When a joint property can utilize Falloff Zones, the Joint Editor displays a Falloff Zones area that appears as shown in the following figure.
There are three types of falloff zones: Spherical, Capsule, and Weight Map (the latter being editable only in Poser Pro 2012 and later), described in the sections that follow. Multiple Falloff Zones can be combined, regardless of type. You can blend multiple falloff zones together in a single joint. The type of blending can be set as Multiply, Add, or Replace in the Joint Editor. You can learn more about blending in Blending_Multiple_Falloff_Zones.

**Spherical Falloff Zones**

When you use a spherical falloff zone, two spheres, a green inner sphere and a red outer sphere, represent the falloff zones.

The green sphere defines the area that is 100% affected by the transformation (motion), and the red sphere defines the limit of the transformer’s effect. The area between the spheres is the blending area, and the transformer’s effect gradually decreases from 100% at the boundary of the inner sphere to 0% at the boundary of the outer sphere.

In the figure shown below, the zones of the innerMat and outerMat spheres have been colored in for demonstration purposes. When vertices are displayed in Poser you can see how the positioning of the spheres affect the strength of the deformations in various areas.

You can edit spherical falloff zones just as you would any bone or body part using the Editing tools.

- Click the green sphere to edit the affected area. The Parameters/Properties palette displays its properties as the innerMatSphere, where you can make adjustments to its size, position and rotation.

- Click the red sphere to edit the unaffected area. The Parameters/Properties palette displays its properties as the outerMatSphere, and you can make adjustments to its size, position and rotation.
Spherical Falloff Zone parameters in the Parameters Palette.

The following properties can be edited for the inner and outer MatSpheres of a spherical falloff zone:

- **Rotation**: To change the rotation of the inner or outer MatSphere, change the yRotate, xRotate, or zRotate values to change the rotation along the y, x, or z axis (respectively).

- **Scale**: Use the Scale setting to uniformly adjust the scale along the x, y, and z axes. To change an axis as needed to create an ellipse, adjust the xScale, yScale, or zScale setting appropriately.

- **Translation**: To move the sphere, adjust the xTran, yTran, or zTran setting appropriately.

You can also use the Direct Manipulation Tool to adjust the rotation, scale, or translation of the falloff zone. For more information about this tool, see Direct Manipulation.

Capsule Falloff Zones

Capsule falloff zones provide a great deal more flexibility in controlling the shape of the zones of influence. The green and red capsules work similarly to the spherical falloff zones mentioned in the previous section. The green capsule defines the area that is 100% affected by the transformation, and the red capsule defines the limit of the transformation’s effect. The area in between the capsules defines the blending area.

Capsule Falloff Zone with Verts turned on.
If you choose to create a capsule zone, there are six unique parameters in the Parameters Palette to change the shape and size of capsules and how they affect the current joint. You will also see the Translate, Rotate, and Scale parameters which work similar to those described for the Spherical falloff zones.

- Click the green capsule to edit the affected area. The Parameters/Properties palette displays its properties as the innerMatCapsule.
- Click the red capsule to edit the unaffected area. The Parameters/Properties palette displays its properties as the outerMatCapsule.

With the inner or outer MatCapsule selected, you will see the following parameters in the Parameters palette:

- **Right Length**: Sets the length of the right half of the cylinder portion of the capsule.
- **Right Radius**: Sets the radius of the right end of the cylinder portion of the capsule.
- **Right Cap**: Sets the length of the cap at the right end of the capsule. Increases or decreases the distance from the Right Length.
- **Left Length**: Sets the length of the left half of the cylinder portion of the capsule.
- **Left Radius**: Sets the radius of the left end of the cylinder portion of the capsule.
- **Left Cap**: Sets the length of the cap at the left end of the capsule. Increases or decreases the distance from the Left Length.

The following diagram shows the parts of the capsule:

![A diagram of a capsule falloff zone.](image)
Working with Falloff Zones

The sections that follow describe other ways that you can work with falloff zones.

You learned how to create a weight map in Poser in the section Weight Maps. If you want to create a spherical or capsule falloff zone, the steps are similar. Follow these steps:

1. Select the joint that you want to work on.
2. Open the Joint Editor, and select the appropriate rotation (Side-Side, Front-Back, Up-Down, or other).
3. In the Falloff Zones section, click the + (plus) sign to create a new falloff zone. Choose one of the following options:
   - Add Sphere Zone: Choose this option to create a spherical falloff zone.
   - Add Capsule Zone: Choose this option to create a capsule-shaped falloff zone.
4. Use the Editing Tools or the parameter dials to adjust the scale, rotation, and translation of the inner and outer MatSpheres (see Spherical Falloff Zones) or MatCapsules (see Capsule Falloff Zones).
5. Repeat steps 1-4 to add additional falloff zones if desired.

Blending Multiple Falloff Zones

In addition to offering three types of falloff zones, you can also use more than one falloff zone for a joint. The Joint Editor provides a drop-down menu that lists the falloff zones that have been created for each joint. You can add one or more spherical, capsule, or weight map falloff zones to any joint.

For an example of using multiple falloff zones, open the Library and select the Figure category. From the People folder, add Alyson or Ryan (version 1) into your scene. In the Joint Editor, select the Side-Side property of the right or left Buttock. Click the Down arrow to display the list of zones for the currently selected joint. When you expand the list of falloff zones, you’ll see several as shown below.
Blending falloff zones.

The CR2 will display a list of zones that affect each joint. Figures that use multiple falloff zones or capsule zones will not be compatible with older versions of Poser. To create a figure that is backwards compatible with earlier versions of Poser, use only a single Spherical Zone on the joints that use falloff zones.

To change the blending method for a falloff zone, follow these steps:

1. Select the joint that you want to modify.
2. Expand the Falloff Zones selection menu, and select the sphere or capsule falloff zone that you want to change.
3. Select **Multiply**, **Add**, or **Replace** from the blend mode selection menu.

Choosing a blending type.

Deleting a Falloff Zone

To delete a falloff zone, follow these steps:

1. Select the joint that you want to modify.
2. Expand the Falloff Zones selection menu, and select the falloff zone that you want to delete.
3. Click the **Delete** button in the Falloff Zones area of the **Joint Editor** and choose **Delete Current Zone** from the menu that appears.
Enabling or Disabling a Falloff Zone

When a joint rotation uses multiple falloff zones, you can enable or disable the influence of a specific falloff zone to determine how that particular falloff zone affects the joint rotation. This can help you make adjustments to the areas that are affected by the selected falloff zone.

To enable or disable a falloff zone:

1. Select the joint that you want to examine, and rotate the joint as necessary to determine the effects of the falloff zones.
2. Expand the Falloff Zones selection menu, and select the desired falloff zone.
3. Check the **Active** checkbox to enable the falloff zone, or uncheck to disable it.

Changing Falloff Zone Display Mode

The default display mode for spherical and capsule falloff zones is Outline mode. However, you can display falloff zones in any available mode. To change how a falloff zone is displayed:

1. Select the falloff zone that you want to change.
2. Select **Display > Object Style**.
3. Select your desired display mode. For example, **Wireframe** mode allows you to see the spheres’ areas of effect while still being able to see the underlying bones/geometry.
Wireframe modes are recommended, as solid shaded modes will make it difficult to pick underlying Fall Zone geometries.

The following figure shows a capsule zone displayed in its default display mode (top), and with the innerMat capsule changed to Wireframe display style (bottom).

**Setting Joint Angles**

If you move any part of your body (for example bending your elbow), you will note that the skin on your upper and lower arms remains still except for the region near your elbow. Around your elbow, skin stretches or contracts depending on its location and the direction of motion. Slightly removed from the actual motion area, your skin and muscles move to adjust to the motion and preserve a smooth transition. The area between the inclusion and exclusion angles is called the blend zone, where Poser stretches, bends, and shrinks polygons to achieve a smooth transition between figure elements. This is the same as when you flex your leg and the skin in the area of your hip contracts or stretches as needed to accommodate the move.

Poser accomplishes similar movement transitions with inclusion and exclusion angles. The **Bend**, **Side-Side**, **Front-Back**, and **Up-Down** parameters allow you to define the inclusion and exclusion angles for the selected joint. The **Inclusion** and **Exclusion** angles control which polygons move as a result of a joint bending and how the body parts on either side of the joint blend to accommodate the move.

- The inclusion angle defines which polygons are affected by moving the selected joint. Using the previous example of bending your arm at the elbow, your entire arm below your elbow moves. The inclusion angle appears as two green lines that form an angle. In the Joint Editor, the **Dynamic B** and **Dynamic C** angles determine the inclusion angle.
• By contrast, the exclusion angle defines those polygons not affected by moving the current joint. Notice that your upper arm does not move if you simply bend your elbow. The exclusion angle appears as two red lines that form an angle. In the Joint Editor, the Static A and Static D values determine the exclusion angle.

Joint inclusion and exclusion angle settings.

The above graphic shows the exclusion angle above the knee, the inclusion angle below, and the blend area in the vicinity of the joint itself. To edit inclusion and exclusion angles:

1. Move the cursor to an end point of the inclusion or exclusion angles until the cursor changes to a target symbol.
2. Drag the angle. It is recommended that you use Full Tracking mode to view the effects of your changes as you drag. You can also enter your desired values in the text boxes.

You can use the Editing tools to adjust this parameter. This parameter exists in three dimensions, meaning you can rotate the figure to see the joint from any angle. You may, however, want to leave the figure in its default position and use the orthographic cameras (Top, Bottom, Left, Right, Front, Back) to constrain movement to two axes, possibly avoiding much confusion.

Editing Bulge Settings

Checking the Apply Bulge checkbox causes the polygons to flex and bulge as the joint moves, emulating the muscle bulging when real bodies move. If the box is checked, the polygons in the blend zone will be stretched or pinched to create bulges or wrinkles. Left and Right refers to the skeleton’s right and left. The positive dials control how much bulging out will occur when the joint moves, and the negative dials control the amount of wrinkling and pinching.

You can use Poser’s weight painting features to make bulges more realistic. See Painting Bulge Maps.
Applying bulges.

Setting Joint Orders

The Joint Editor palette includes the Joint Order pull-down menu that defines the joint’s axes of rotation. The joint order is expressed as three letters corresponding to the X, Y, and Z axes.

Using the Front camera position, the X axis runs from left to right, the Y axis runs from bottom to top, and the Z axis runs from the back to the front. This is called a right-handed coordinate system.

It is important to determine the best rotation order for each joint. This is an important part of getting your figure to move exactly how you want it to. When you create new bones with the bone tool, Poser takes its best guess at determining the best rotation order for the bone.

You can select rotation orders by bringing up the Joint Editor palette and selecting the desired order from the Joint Order pull-down menu.

If you change joint order, you will probably need to readjust the joint zones on the currently selected bone.

Each joint consists of three separate joint primitives, one twist and two joints. You determine the joint rotation order as follows:

- The twist primitive is always placed first in the joint order.
- Because of ordered rotation problems, it is then best to place the rotation axis through which the joint is most likely to move last in the order.
For an example, consider the shin of a figure:

- A shin is vertical and twists about the Y-axis. This Y axis is placed first in the rotation order for the shin.
- When the shin bends, it is most likely to bend around the X-axis. This axis is placed last in the rotation order.
- The remaining axis is the Z axis, which is placed in the middle. Thus, the best rotation joint order for the shin is YZX.

This may seem a little confusing at first. A good way to visualize the correct rotation order is to picture the figure facing directly towards the front of the Poser workspace. For each possible motion of a given joint imagine a line running through the center of the joint. For example, the shin twists along a line running straight up and down and rotates along a line running from left to right. The vertical line corresponds to the Y axis, and the left-to-right line corresponds to the X axis. It is now easy to determine the proper joint order of YZX based on this visualization and the requirements outlined above.

You can also use curve bends instead of the normal twist/joint/ joint bends. When you set up a joint using curves, the joint will have one twist and one curve primitive. The curve primitive will automatically bend the body part as if that part were part of a curved chain of objects. This feature is very handy for body parts such as tails or antennae.

**Adding Affected Actors**

By default, a falloff zone only affects the body part that it is directly associated with. You can add additional body parts or objects in your scene with the Affected Actors button that appears at the upper right corner of the Joint Editor. For example, affected actors can be very useful when applied to a character that has wings that would affect the shoulder, but also the chest and the abdomen.

Affected actors allow bends to occur beyond the range of the current body part. For example, if you have the character’s right shoulder selected, you could click the Affected Actors button and add the right forearm to the parts that are affected by the currently selected zones or weight map.

If a joint’s falloff cones or spherical/capsule falloff zones enclose vertices of a figure that is not a part of the current actor or its parent, you should set that part as an affected actor before you use Merge Zones to Weight Map to convert the falloff regions to a new weight map. This will apply appropriate
To add additional parts, click the **Affected Actors** button to open the **Select Objects** dialog. Check any additional body parts or objects that you want to be affected by the falloff zone.

![Adding Affected Actors](image)

After you add a body part as an affected actor, you’ll want to modify the falloff zones so that they also include the vertices in the affected actor. To illustrate why, observe in the following figure how the falloff zones originally look for the right shoulder:

![Original falloff zones for the shoulder](image)

In the following figure, the right forearm has been added as an affected actor to the right shoulder. When the shoulder is bent, you see that the vertices in the right forearm are not affected. This is because they are not yet included in the falloff zone for the shoulder. The hand and fingers rotate as they normally would, because they are not set up as affected actors to the shoulder:
The right forearm is added as an affected actor to the shoulder, but falloff zones have not yet been adjusted.

The falloff zones for the right shoulder are then adjusted to encompass all of the vertices in the right forearm, as shown below. Make sure that the zones are adjusted in all camera views.

Adjust the falloff zones of the selected actor (the right shoulder) to add the vertices of the affected actor (the right forearm).

Copying and Saving Joint Settings

To copy joint settings from one side of your figure to the other, use symmetry as described in Positioning Bones Using Rig Symmetry. This saves time for figure creators by allowing them to rig only one side and then duplicate the zone settings to the opposite side.

To save your Joint Editor palette settings, you must either save your scene or save the affected figure to the Library palette. Please refer to Saving a Scene for information on saving Poser scenes, and to The Poser Library for information on working with the Library palette.

Weight Maps

Weight maps allow you to paint varying strengths on vertices to control how they respond to a joint rotation. You can either create an entirely new weight map, or combine existing deformers into a new weight map that completely replaces the spherical or capsule falloff zones.

When you choose to merge existing falloff zones into a Weight Map, existing falloff zones will remain, but will be ineffective unless or until the blending mode of the weight map is changed from Replace to Add or Multiply.
If you are going to be rigging a character from scratch, the easiest workflow is to rig it first the “old fashioned” way ... by using spherical and capsule falloff zones as described in the previous sections in this chapter. After you get that done, you can collapse the falloff zones down into weight maps.

The recommended workflow is as follows:

- Set up your spherical and capsule falloff zones in the joint, and test them to make sure they move the joint as expected. See Creating and Using Falloff Zones.

- Add affected actors in areas where the rotation of a joint could extend to more than one body part, and adjust the falloff zones to include the affected actors. See Adding Affected Actors.

- Collapse the falloff zones into a weight map. See Adding a Weight Map.

- Refine the weight map further with weight map painting. See Painting Weights.

The File > Merge All Zones to Weight Maps command is provided in Poser to automatically convert all existing falloff zones to weight maps in a single operation. All existing falloff zones will remain, and the new weight map will be set to Replace. You will then be able to use the Joint Editor to refine the weight maps using the weight painting tools.

Adding a Weight Map

After you finish setting up the spherical or capsule falloff zones, you can collapse them down into a Weight Map for the selected joint. When you click the Add button, you will see two options for Weight Maps:
There are two options for creating weight maps.

- **Add Weight Map**: Choose this option to add a new weight map in addition to any existing falloff zones that may already appear for the selected body part. It will work similarly to any other falloff zone.

- **Merge Zones to Weight Map**: Choose this option to merge existing falloff zones, including joint angles, into a new weight map. This is probably the most useful way to begin with your weight map. You will see a new weight map in the Zones list, but the original falloff zones will still appear in the list as well. The blend type for the weight map will be set to **Replace**.

You don’t have to have spherical or capsule falloff zones to create a weight map. You can just create one by selecting a body part, and then choosing **Merge Zones to Weight Map**. This will create a new weight map based on the existing inclusion and exclusion angles set for the body part. Then you can begin painting the weight map as needed.
Adding a Weight Map

Merging existing zones into a weight map.

Falloff zones are processed in the order in which they appear in the Falloff Zones list. Therefore, if you have a Spherical falloff zone at the top, a Capsule Zone second, and a Weight Map third, the Capsule zone will override the effect of the Spherical zone. Then the Weight Map, if set to Replace, will combine the effect of both the Spherical and Capsule weight maps, making the first two falloff zones ineffective. In addition the weight map will also replace the Joint Angle settings, making them ineffective as well. The joint angles will still be visible as a visual guide only.

In practice, you can configure a weight map to work with existing falloff zones by setting the blend mode to Add or Replace. However, there is no advantage to doing so. Falloff zones that have been collapsed down into weight maps work equally as well as the falloff zones that were initially used to create them.

If the previous falloff zones utilized bulge settings, they will still be active and you will still be able to adjust them in the Joint Editor.

In the Joint Editor, click the Add button, and choose Merge Zones to Weight Map. The weight map will be set to Replace, which will make the spherical and capsule falloff zones ineffective.
Deleting Weight Maps

If you don’t like the way that the joint is bending after you create a weight map, you can go back and delete the weight maps if you have to. For example, you might learn that in some views the center point of the joint is not set correctly, or the inclusion and exclusion angles aren’t working as well as they should and you need to make an adjustment.

When you delete a weight map that was created from existing falloff zones, the original zones will work as they were originally designed to work. You can go back and adjust the falloff zones as needed, and then create a new weight map that incorporates the new changes.

Activating and Deactivating Weight Maps

The weight map is always active, unless you manually deactivate it. If you want to see how the weight map differs from the falloff zones from which it was created, just uncheck the Active option in the joint editor. The example shown below shows how a weight map smooths the vertices around the ankle when the foot is bent downward.

You can Activate or Deactivate a weight map to observe how it affects a rotated joint.

Painting Weights

After you collapse your weight maps down, you can start to paint. Click the Paint palette icon in the Joint Editor to display the painting controls. As you paint, the changes reflect changes to the actual edge flow and surface normals in the model, and not relative to the screen.

After you create a Weight Map, the Weight Painting tool is enabled in the Joint Editor.

When weight painting, consider the following general workflow:
To paint weights:

1. Click the paintbrush icon to enable the painting tools. The Joint Editor shows the brush controls.

2. Select a brush type from the available choices.

3. The first brush is a hard brush with a very small radius, suitable for working with targeted vertices.

4. The other brushes provide varying levels of hardness around the edges. The default brush has a softer edge which provides the most effect in the center and then gradually falls off to little or no effect on the outer edges. The last brush has no falloff at all, and applies strength evenly across the width of the brush. There are five brushes in the section.

   The fourth brush will give you the best results, as it has a very slight feathering to the edge. If you use brushes that are more feathered you may throw off the weight balance.

4. A wireframe preview of the brush appears in the Document. You can toggle this preview on or off by checking or unchecking the Display Brush option in the Joint Editor.
• The inner ring of the preview shows the area that will have the most effect.

• The outer ring of the preview shows the overall width of the brush. You can use the Radius setting in the Joint Editor to increase or decrease the brush width.

5. Adjust the Magnitude setting in the Joint Editor to increase or decrease the strength of the brush. Decrease the setting to produce less of a change while you paint, and increase the setting to produce more of a change.

When you have the paintbrush set to Add or Subtract mode, pay attention to the Magnitude setting of the brush. Setting this too high (such as 1) will affect the vertices more than you want them to. It is recommended that you start with a low magnitude (around .007). Then slowly go back and forth over the areas you want to change.

6. Use the Parameter dial in the Joint Editor palette to pose the body part in something other than the default position (at or near one of the limits is a good place to start).

 Pose your body part while you paint across vertices to add, remove, or smooth the amount of effect on the vertices.

7. Choose a method for painting. As you paint, observe how the changes affect the body part in that pose. The shape of the mesh will respond to the brush as you make changes:

You can also use single-key shortcuts during weight painting:
1=Add, 2=Subtract, 3=Smooth, 4=Weight, and 5=Brush Size

• Add will increase the effect of the polygons you paint, moving the painted vertices more toward the “green” (fully effected) color. This adds more effect to the areas painted.

• Remove will decrease the effect of the polygons you paint, moving the painted vertices more toward the red (little to no effect) color. This removes the effect from the areas painted.

• Smooth will blend the sharp contrasts between polygons that are affected least against those affected the most.
Poser Reference Manual

Painting Weights

- **Weight**: The Weight brush allows you to paint weight vertices while targeting a specific weight value. Click the Eyedropper to select a vertex. The weight of that vertex will appear in the text field and will be used as a target. When you paint with the **Add** brush, it will increase the weight values that are below the target setting until the target threshold is met. When you paint with the **Subtract** brush, it will decrease weight values that are above the setting until the target threshold is met.

> The Smooth mode is extremely helpful. You can work at higher magnitudes, and it is beneficial to begin your weight painting with a smoothing brush to smooth out the mesh.

- Vertices move as you paint them.

8. As you are painting, use the Parameter dial to test various positions of the joint to make sure that the weight painting produces desirable results. Continue to adjust the weights until you are satisfied with the results as the joint is exercised through its limits.

9. Click the Paintbrush icon to turn weight painting off. You will return to the normal **Joint Editor** palette.

**Mirroring Weights**

Tips on mirroring weight maps:

- To mirror weights on body parts that have a center line (such as head, neck, chest, abdomen, waist, or hip), paint the weights on one side of the figure (left side recommended). Then click the Mirror button at the bottom of the Vertex Weights palette. To mirror left to right, select the **+x to -x** option.

- When mirroring bulge maps for center line actors, paint the bulge map on one side (left side recommended). Click the **Copy/Paste** button at the bottom of the Vertex Weights palette, and choose **Copy**. Click the button again and choose **Paste/Mirrored** and select the **X** axis.

- To mirror weights and bulge maps on body parts that do not have a center line (such as collars, shoulders, hand parts, thighs, shins, and feet parts), first paint weights on one side (such as the left leg). Then use the appropriate **Figure > Rig Symmetry > subcommand** to mirror the weights to the opposite body part.
Restricting Painting by Groups or Materials

The Restrict to option in the Vertex Weights palette allows you to isolate a group or a material for weight painting.

To restrict weight painting to groups or materials, follow these steps:

1. Select the joint and rotation that you want to paint (example shown is Neck Side-Side).
2. Click the Weight Painting icon to open the Vertex Weight palette.
3. Check Restrict To. This enables the following restrict to options:

   - **None**: Choose this option to paint normally (turns off painting restrictions).
   - **Group**: To restrict painting to a specific group, expand the Group flyout. Groups listed here will only be those that are defined as affected actors of the currently selected body part. For example, when Roxie’s neck is selected, you will be able to select Chest, Neck, Head, lCollar, or rCollar.
   - **Materials**: To restrict painting to a specific material, expand the Materials flyout. All materials in the current object will be displayed. This option is handy so that you can isolate items such as buttons or zippers on clothing, or other items that are hard to separate from the main parts of the figure.

4. All of the vertices in the selected body part will still be displayed while you paint. However, when you move the brush over the selected body part, you will notice that the brush will only affect the vertices in the group or material that you selected in the previous steps.
Painting Bulge Maps

You’ll notice that there are also paint palette icons near the right and left bulges. For certain body parts, you’ll have to paint both to get the correct feel for how bulges affect the joints.

As you work with a joint, you may need to switch between the weight map on the joint, and the weight map on its bulges.

If your weight painting gets to a point where the joint weight map starts to look unnatural, try adding or removing from the bulge weight map. Then, if the bulge weight map starts to look unnatural, return to the joint weight map. Switch back and forth between them until the joint looks natural when it is rotated.

- When working on bulge weights, the brush affects the weight map a little bit differently. A setting of .01 on a bulge map has a similar effect to a setting of .001 on a weight map. Use a setting of .01 on a bulge map for a nice, smooth workflow.

- Bulge settings must be set to a value other than 0 in order to use a bulge map. For any bulges that you want to use (Right Neg, Right Pos, Left Pos, or Left Neg), set to a value less than or greater than 0. The Right Neg and Right Pos share the same map, and the Left Neg and Left Pos share the same map.

- Be sure to rotate the dial to its positive and negative positions, and check the bulge weights in both. For example, if you use a bulge on the right collar when the Up/Down dial is at a positive setting, make sure that the joint still looks realistic when the dial is at a negative value.

Smoothing Scale Zones

Scale zones should be part of your character or conforming clothing development. The Scale Zones button, located in the lower portion of the Joint Editor Window, helps content creators improve the appearance of joint transitions when a body part is scaled along one or more axes. For proper operation when scaling weight mapped figures along a single axis, it is necessary to
check the scale zones on each scaling axis (X, Y, and Z as they apply) for each adjacent body part.

For example, let’s say you have an adult male figure (here James, a G2 legacy figure, is being used as an example). You want to change him into a dwarf character, which means that you’ll want to substantially change the proportions of his thighs and shins.

Users of legacy figures know that body parts can only be scaled “so far” before they begin to crumble where they join adjacent body parts. For an example, compare this figure’s “normal” thigh (his left thigh) to the right thigh, which is scaled to 65%. You’ll notice that the thigh is bunching in the locations where it joins the hip and the shin.

The **Scale Zones** button in the joint editor allows you to set scaling zones that improves performance when characters and conforming clothing are scaled. You can then add weight maps to the blending areas to smooth the transitions when a body part is scaled.

*Joint seams can bunch together when a body part is scaled along a single axis.*

Using the same legacy figure as an example, the right thigh has been scaled along the Y axis. When you open the Joint Editor, you’ll see the normal center and rotation parameters (Twist, Side-Side, and Bend). But you’ll also notice scaling zones for the adjacent body parts ... one named rShin_ScaleY and another named hip_scaleY. The names of these scaling zones might vary from figure to figure, but they will always be preceded by the name an adjacent body part plus an underscore. These are the joint parameters that relate to the Scale Zones feature.

*Paint the smooth scale zones to improve how parts scale together.*

The **Scale Zones** button at the bottom of the joint editor allows you to add or remove scaling zones to the currently selected body part. At a minimum, adjacent body parts should be selected. But if it is possible that the scaling can “spill over” into other body parts, you can add them as scaling zones as well.
To assign the scaling zones, click the **Edit Scale Zones** button. The Select Objects dialog prompts you to choose body parts that will scale blend with the currently selected actor (the right thigh, in this case). Check any parts that you want to assign, making sure that the adjacent actors (the hip and shin) are included.

![Select Objects dialog](image)

*Click the Scale Zones button to select body parts to blend when the current part is scaled.*

To smooth a scaling zone, scale the body part (the right thigh in this example) to the desired scale. Try to anticipate the maximum range that you would like the scaling to work. For example, it’s unlikely that you will want to scale a thigh to any less than 65% as shown in our example.

After you scale the part, open the menu in the Joint Editor to select the first scaling zone that you want to work on. In the following figure, the rShin_scaleY joint parameter is selected. This is the scaling zone, as it was named for that particular joint.

![Joint Editor](image)

*Painting scale zones.*

When you select the scale zone, you may see No Zones in the Falloff Zones area (which will be the case when you are weight mapping a new or legacy figure that has not previously been weight mapped). If a weight map does not exist, you’ll need to create one for the scale zone. Simply use the menu in the Falloff Zones area of the Editor to choose **Add Weight Map**. Then make sure that the mode of the new weight map is set to **Replace**.

*Scale zone maps have to be created for each body part that is connected to the currently selected actor. For example, if you have the right thigh of a figure selected, you’ll need to create scale zone maps for the hip and the shin.*

Page 827
Of you have a chest selected, you’ll need to create scale zone maps for the right and left collar, and for waist or abdomen (depending on the group name that is adjacent to the chest).

When you copy weight maps from a character to conforming clothing, the scale zones should already be set up for you, but you will need to check the scale zones of each body part in the clothing to make sure they work as expected. Before you edit the scale zone weight maps on conforming clothing, select the BODY actor of the conforming clothing, and make sure that Include Scales when Conforming is checked in the Properties palette. Sometimes the easiest way to start a scale zone weight map is to collapse existing zones (spherical and capsule zones, if they exist) into a weight map and then start to smooth them with the weight painting tools.

Add a weight map to the scale zone if needed.

Make sure the weight map is set to Replace.

With the appropriate scale zone weight map selected, you can begin to use the Weight Painting tools to smooth out the scale zone. The process is similar to that mentioned in Painting Weights.
Use the weight painting tools to improve the appearance of the smooth zone (here, in progress)

As you smooth out the current body part, you might notice that there are areas near the adjacent body part that you can’t get as smooth as you like. This is probably because it falls in an area that is affected by both body parts. For example, as you work toward the top of the thigh, you might see that you can’t smooth it out all the way. In that case, you’ll want to check the smoothing zones in the hip, and make sure that you have the correct smoothing zone selected (rThigh_ScaleY). Add a Replace weight map to it if necessary, and then use the weight painting tools to smooth out that area.

You will need to cross over to the adjacent body part and work on its corresponding scale zone. Select that part and verify that it has a corresponding weight map before you paint it. When you paint close to the seam lines, be careful not to overblend because it might create a ridge at the seam. Go back and forth between the two areas until you get an acceptable blend.

Adjacent body parts may also affect a scale zone. Here, the scale zone for the hip also affects the right thigh and should be smoothed.

To summarize:

- Scale zones should be checked for each body part in the figure that you are rigging.
Smooth Translation Bending

In previous versions of Poser, translations of body parts would result in irregularities in the areas between the joints. When you add smooth translations to a joint, the area between the two body parts blends more smoothly when you translate a body part. Smooth translation bending will be effective for facial parts such as jaw or facial animation.

Smooth translations rely on smoothing zones to work properly. Content creators will need to make sure that smoothing zones are working properly in clothing. See Smoothing Scale Zones.

Smooth translations are not enabled by default. You will need to add them in the Joint Editor as follows:

1. Click the body part to which you want to add the smooth translation.
2. Open the Joint Editor.
3. Expand the joint list and choose Create Smooth Translations. This adds smooth translation to the selected joint only. This command will not appear if smooth translations have already been applied.
4. To translate the selected joint, press the Esc or / (forward slash) key while dragging the body part with your mouse. The area between the current joint and its parent should blend smoothly. You will be able to see the results more clearly if you are using one of the lined display modes, such as Smooth Lined or Texture Shaded Lined.
5. By default, the adjacent body part blends with the selected part by default. To add other parts for blending, click the **Edit Smooth Trans** button in the joint editor palette to open the Select Objects hierarchy list. Use this list to choose the body parts that will blend with the selected actor. For example, if you have selected the right collar of a figure, it will blend with the right shoulder.

![Image showing the Edit Smooth Translations button](image)

*The Edit Smooth Translations button allows you to choose other actors to include in the blend.*

**Weight Painting Tips**

- There may be times when you need to pull one vertex at a time. For this, set the radius of the brush very small.

- There are times that the area between an inclusion and an exclusion angle is very narrow when a joint is rotated to its maximum limit. It is very difficult to get into that area with the weight painting tool to smooth it out. The trick is to widen the distance between the inclusion and exclusion angle so that the body part “plateaus.” Then you can use the Weight Painting tool to shape the body part appropriately.

![Image showing tight and widened angles](image)

*Adjust inclusion angles when weight painting a joint in its maximum limits.*

- Another thing that will help as you use the weight painting tools is to select your camera, and then go into the **Parameters** palette. Set the Hither setting to 0. This will allow you to zoom in as close as you have to without making the object “disappear” in the camera view.

- The **Frame_Selected** and **Orbit_Selected** controls will also be helpful when weight painting. Click to select the joint you are working on, and then click the Frame Selected control to frame the camera around the selected body part. Then turn Orbit Selected so that the camera will orbit around that part.
Fixing Mismatched Scales

If you are working with a character that makes heavy use of scaling zones, you may sometimes encounter situations where there appears to be something wrong with the scaling in one or more body parts. For example, scaling the chest and could cause the shoulders to scale so that they cause a faulty joint between the shoulders and collars.

This can be due to a scaling mismatch, and it can be corrected with the Fix Mismatched Scale Zones button at the bottom of the Joint Editor.

When you fix mismatched scaling zones, the order that you select the body parts and smoothing zones is important. The following example shows how you can correct the scaling zones of the right and left shoulders in relation to the chest.

To fix mismatched scale zones in the shoulders, for example:

- Open the Joint Editor.
- Click to select the character's chest.
- From the parameter list at the top left of the Joint Editor, choose the smoothing zone that you want to fix (such as the right collar zone as shown in the following figure).

Choose the first smoothing zone that you want to fix.

- The Fix Mismatched Scale Zones button at the bottom of the Joint Editor palette will be enabled if there is a problem with the scaling zones. Click the button to correct the problem in the selected smoothing zone.
If enabled, click the Fix Mismatched Scale button.

- Now, click on the figure to select the opposite body part (the left collar in the figure).
- Go to the menu at the upper left corner of the Joint Editor again, and select the smoothing zone for the Chest.
- Click the Fix Mismatched Scale Zones button at the bottom of the Joint Editor palette to correct the smoothing zone between the left collar and the chest.

**Copying Joints from Another Figure**

If you are creating a character that has similar size and proportion to another figure, you can copy joint settings from one figure to another. In most cases, this is only necessary when you are developing an original figure, and have made changes in the rigging of one version of the model (a low resolution version, for example) and want to apply the same changes to another version of the model (a high resolution version).

1. Load two figures into the scene:
   - The source figure (ie: the figure you want to copy joints from), such as a low-resolution human character.
   - The target figure (the figure that you want to copy joints to, such as a high-resolution version of the same human character).
2. Select the target figure.
3. Choose Figure > Copy Joint Zones From. The Copy Joint Zones dialog appears.
4. Choose the figure from which you want to copy the zones (the source figure), and then click OK. The joint zone settings will be applied to the target figure.

**Transferring Zones and Weight Maps to Clothing**

In earlier versions of Poser, content developers used information from the CR2 of an existing figure as a start point for their clothing. If an existing character has only spherical or falloff zones this method can still be used.
However, when weight maps are used to determine how a joint bends (either solely, or in addition to falloff zones), the weight map information is baked into the figure’s geometry. Weight maps are based off of vertices and index arrays that usually will not have a geometry counterpart in the clothing.

The Setup Room allows you to apply the rigging of a character to a grouped or ungrouped clothing OBJ. In the process, it will also transfer any spherical or capsule falloff zones. It will also analyze the vertices and index arrays in the character, and use that information to generate similar weight maps for the clothing geometry.

The steps to do this are fairly simple:

1. Choose **File > Import > Wavefront OBJ**. Select the clothing object that you want to rig. This object can be pre-grouped in your modeling application, or it can be ungrouped.

2. The Import Options dialog appears. In most cases, clothing is modeled around a character that is in its default position, and exported at or converted to the proper scale for Poser. If this is the case, you should uncheck all of the import options as shown below. Then press **OK** to continue.

   ![Import Options dialog](image)

   *Uncheck all options in the Import Options dialog if your model is scaled and positioned properly.*

3. A dialog prompts you to locate the OBJ file that you want to import. After you select the object, click Open. The OBJ file will appear in your scene.

   ![An imported clothing OBJ](image)
4. With the object selected as the current item, click the Setup room tab to enter the Setup room.

5. Open the Poser library, and click the **Figures** category. Locate the library folder that contains the original figure for which your clothing was designed. In the case of the example shown here, the **Figures > Poser Content > People > Alyson** folder is selected, since the suit is made for Alyson.

6. Drag and drop the thumbnail for the original figure from the Library to the OBJ file in the Setup Room. A dialog asks you if you want to automatically group the setup geometry based on the groups of the new skeleton.

   • Choose **No** if your clothing geometry has already been grouped.

   • Choose **Yes** if your clothing geometry does not already have groups, or if you want to regroup the object. Poser will create the groups for you automatically.

7. The skeleton is applied to the OBJ in the Setup room. You can then open the Group Editor to examine the groups in the OBJ and edit as necessary.

![Examining groups with the Group Editor.](image)

_While examining the groups in the Setup Room, you may notice one or more groups that have all polygons assigned to them. For example, when you apply the Alyson skeleton to a clothing object, two groups (one named Figure, and the other named 1) have all polygons assigned to them. Select each of these groups in the Group Editor, and then click the Delete Group button to delete them._
Review each group that has been created and edit polygons assigned to them if necessary.

8. After you inspect all of the groups and have edited them to your satisfaction, you can return to the Pose Room. You should now have a poseable figure.

9. Before conforming the clothing to your figure, or before saving the clothing to your library, choose **Figure > Zero Figure** to zero all joint rotations. Also use the **Edit > Memorize > Figure** command to memorize the conforming clothing. You may also want to assign a new name for the object in the **Properties** palette.

**When Clothing Groups Change**

If you change the grouping in your clothing OBJ after copying joint zones from the figure, you will notice that the clothing will spike or pose incorrectly when you pose the figure. The usual solution for this is to save the regrouped OBJ under a new name, create a new figure in the setup room, and then copy the weight maps from the old version of the clothing to the new version of the clothing.
Unpredictable results happen if you change OBJ grouping after weight mapping.

The following workflow assumes the following:

- You have already created an OBJ named Boots1.
- You rigged Boots1 in the Setup room and transferred weight maps and joint zones from the figure using the Figure > Copy Joint Zones From command.
- A copy of Boots1.CR2 is saved in the Figures library.

Now you make changes to the Boots1 OBJ, and the grouping ends up changing. If you simply point the existing Boots1 CR2 to the new Boots2 OBJ, you will get spikes as shown above when the boots are posed.

To fix this, proceed as follows:

1. Check that your new Boots2.OBJ file is welded and grouped properly. Save it to a subfolder in your Geometries runtime folder.
2. Import Boots2.OBJ into Poser.
3. Switch to the Setup Room. Use the original Boots1.CR2 as the donor rig for the new boots. Since the Boots2.OBJ is already grouped and welded, uncheck the option to perform autogrouping and also uncheck the option to transfer morphs.
4. After returning to the Pose Room, save the new Boots2.CR2 to the library. Open the CR2 in a text or CR2 editor and change the OBJ path to point to the Boots 2 OBJ in your Geometries folder (the one that is welded and grouped).
5. Delete the Boots2.obj/CR2 that is currently in your scene.
6. Load both versions of the boots (Boots1.CR2 and Boots2.CR2) from the library into the scene.
7. Select Boots2.CR2. Use the Figure > Copy Joint Zones From and the Figure > Copy Morphs From commands to copy weight maps and morphs from Boots1.CR2 to Boots2.CR2.
8. Resave Boots2.CR2 to the library again. When you conform this new version to the figure, the weight maps and morphs should work correctly when the figure is posed.
Skinning and Subdivision Surfaces

Skinning Methods

The **Figure > Skinning Method** commands determine how Poser treats a character mesh in regards to grouping:

Choose **Figure > Skinning Method > Poser Traditional** if you want to display or create a figure that uses Poser’s traditional model of breaking the mesh into individual body parts.

Choose **Figure > Skinning Method > Poser Unimesh** if you want your model to be used with subdivision surfaces (see ). Poser Unimeshes can still be posed manually or with preset poses that are saved to the Library. The mesh is unified, but body part groups are still recognized in Poser.

*The Poser 2 Male (roughly 2500 polygons) converted to Poser Unimesh and subdivided to level 2.*

Choose **Figure > Skinning Method > Simple Bones Single Skin - Interoperable** ... if you want to work on or create a figure that has a single skin mesh, but in which the Poser grouping is removed. Figure setup is very simple in this mode. You can specify joint origins and one vertex weight map. After you convert the model to Simple Bones Single Skin, test each joint and use the Simple Bone Weights painting mode to correct any problem areas.

Traditionally-rigged Poser figures use a mesh that is broken into body parts, and has spherical or capsule-shaped zones of influence and weight maps. To export these types of figures from Poser to COLLADA, you should switch to **Simple Bones Single Skin - Interoperable** first. That way, you can preview how
La Femme converted to Simple Bones Single Skin.

In Poser 13, choose **Figure > Skinning Method > Regenerate Simple Bones Single Skin Weights** if you want to start over with a new simple bones single skin mesh.

## Working with Subdivision Surfaces

Subdivision is a process that refines the appearance of a mesh during preview or rendering. It is typically used to smooth the appearance of a low-resolution mesh to make it appear as though it has been created with a higher number of polygons. In this section you’ll learn how subdivision works, what to consider before you create or use models that will be subdivided, and how to use subdivision surfaces in Poser.

### How Subdivision Works

Subdivision can be applied to polygons that are made of 3 or more sides. Most content developers keep all or most of the polygons in their model to four sided polygons for optimum results in subdivision.

To explain how subdivision works, let’s start with a picture of three polygons: one with 3 sides, one with 4 sides, and one with 5 sides. With no subdivision, you see the polygons exactly how they have been created.

3, 4, and 5-sided polygons with no subdivision.
When you set the subdivision level to 1, subdivision smooths the model and gives the appearance as though it is made of more polygons. What basically happens is that a vertex is placed in the center of each polygon, and then that vertex connects at the center of each of the edges in the original polygon: Notice the following in the image that appears below:

The 3-sided polygon now looks like three four-sided polygons.
The 4-sided polygon now looks like four four-sided polygons.
The 5-sided polygon now looks like five four-sided polygons.

3, 4, and 5-sided polygons with subdivision setting of 1.

If you increase the level of subdivision one more time (to a setting of 2), another vertex is placed in the center of each polygon that was created at level 1. Because a level 1 subdivision created all four-sided polygons, what this will result in is that your model will appear to have four times the number of polygons as the preceding level.

Your original 3-sided polygon now looks like it has 12 polygons.
Your original 4-sided polygon now looks like it has 16 polygons.
Your original 5-sided polygon now looks like it has 20 polygons.

You’ll also notice that at a subdivision level of two, the outer edges of the polygon appear much smoother and rounder. This is most noticeable in the four-sided polygon. Where it originally appeared as a rectangular shape, it is now more like a circle.

3, 4, and 5-sided polygons with subdivision setting of 2.

Finding the Optimum Setting

As you continue to increase the subdivision levels, you will get to the point where you won’t really notice much of a change in the appearance of the polygons. Depending on the edge loops in the model, this most often happens between a subdivision level of 2 or 3. To illustrate this, compare the figure below with the preceding example. You won’t notice a lot of difference in the shape of the outer edge of the polygon. The only thing that you notice now is that it appears as though there are four times the number of polygons. Your 3, 4, and 5-sided polygons now look
like 48, 60, and 80 polygons (respectively), but the appearance hasn’t changed much along the outer edge.

3, 4, and 5-sided polygons with subdivision setting of 3.

What this means, is at some point it won’t make a lot of difference in your preview or final render to increase the subdivision beyond an optimum point. To do so will only increase the load on your system resources as you increase the number of subdivision levels beyond what you actually need.

Now that you’ve seen how subdivision affects a single polygon, consider the effects on a figure such as the Poser 2 male, which consists of 2572 polygons. You can find this figure in the Figures > Included > People > Poser Originals > Poser 2 Lo Library category.

The Poser 2 Male is made of polygons that have 3 or more sides: With no subdivision, it appears as shown in the following figure. Pay attention to the crown of the head, which appears to have some hard edges.

*Poser 2 Male with no subdivision.*

When you set the subdivision level to 1, you’ll notice that the hard edges are softened somewhat. The hard edges at the crown of the head are much improved, but still don’t appear quite as smooth as you would like. You’ll also notice that the chest muscles retain their shape because the edge flow in that area follows the shape of the muscular detail. The facial features are less angular, giving a softer appearance to the eyes, nose, mouth, and ears. With one level of subdivision, you’ll get the equivalent of a model that has about 10,000 polygons.
Subdividing Figures in Poser

Increasing the subdivision level to 2 (about 40,000 polygons) doesn’t seem to change the appearance of the chest and arms very much; however, you’ll notice that the crown of the head appears very smooth now. However, the facial features might be softened a bit too much at this level. The primary reason for this is because there isn’t enough edge flow in those areas to retain the detail in those areas, because the model wasn’t built with subdivision in mind.

As you can see from the preceding examples, content creators should pay attention to areas that will require more detail. A 20,000 polygon figure can easily contain enough edge loops to make a subdivision setting of 1 sufficient enough to produce sufficient detail and a great render, as long as it’s modeled with subdivision in mind. To maintain detail, edge loops have to be placed near areas where you want creases, sharp transitions, and folds to appear, otherwise the subdivision will smooth those details away.

**Subdividing Figures in Poser**

To turn subdivision surfaces on for Poser figures:

Load the desired figure or prop into Poser.

If you are subdividing a poseable figure, choose **Figure > Skinning Method > Poser Unimesh**. This will combine the model into one mesh.

Select the BODY actor of the figure.
Switch to the Properties tab, where you will see two settings in the Subdivision Levels section:

Preview: Indicates the subdivision level that will be used in the Preview render.

Render: Indicates the subdivision level that will be used in the final render.

When you initially turn subdivision surfaces on, both the Preview and Render values are initially set to zero (no subdivision).

Adjust the Preview setting first. If the Preview setting is increased higher than the Render setting, the Render setting will automatically increase to match the Preview setting.

After you reach the desired Render subdivision level, you can reduce the Preview setting as needed to improve performance while composing your scene.

If you turn body parts off, subdivision will be recomputed accordingly.

If you have a body part that is not subdividing properly, you can set a different subdivision level for that part. Select the body part that you want to change, and set a different subdivision level in the Properties palette. Note that you may see creases at the seams when your model uses different subdivision levels. Additionally, you will not be able to smooth across body parts that have different subdivision levels.

Increasing the subdivision levels on cloth simulated objects can reduce shading artifacts.

Modeling Considerations

When using subdivision surfaces, your model must be clean. There is a lot of content in the Poser world that was not modeled with subdivision surfaces in mind, and you won't always get the results you expect. This is often due to vertices that are at or close to the same position in 3D space.

In some cases you can select a body part that is causing the issue. Then go into the Properties palette, and check the Subdivide separately from figure option. Set the subdivision setting to zero for that body part. Note, however, that the seam will be more visible where one body part is subdivided to different level than an adjacent body part.
Body parts can also be subdivided individually.

The following conditions will cause subdivision to work improperly, and Poser will notify you when it will be unable to subdivide the model at all.

Edges that are shared by more than two polygons.

Vertices that show up twice in one polygon.

Duplicate polygons that share the same space.

To illustrate what happens when more than two polygons share an edge, the following figure shows an object that is made up of three sections of polygons. Sections 1 and 2 appear along the top of the “T” shape, and are welded along the center length. The third section is perpendicular to sections 1 and 2, and also joins them at the center. Thus, each edge along the middle of the T shares three connecting polygons.

The top section of the following figure shows what this T-shape looks like before subdivision surfaces are activated.

Three sections of polygons sharing the same edge.

The bottom section of the figure shows what happens to these polygons after subdivision surfaces are applied. Poser gives a warning when geometry contains problematic areas. As you can see, the top two sections remain joined together; but the third section, which was
Creating Subdivision Level Morphs

The Morph Palette includes a new feature that allows you to sculpt morphs at higher subdivisions. The easiest way to illustrate the principles of subdivision level morphs is to start with a simple square prop, which you can find in the Content Library. Follow these steps:

Start a new Poser scene and delete the default figure.

Choose the Props category in the Poser Library, and select the Square prop (not the Square Hi-Res prop) from the Props > Poser 13 Content > Primitives library. Click the Add to Scene icon.

Scale the square prop up to 1000% so that you can see it more easily in the scene.

Switch to Texture Shaded with Lines display style.

This square has only four vertices, one in each corner of the square. If you try to paint a morph in the middle of the square, nothing will happen because there are no vertices to move. You’ll need to subdivide the square so that you have more vertices to morph. In the Properties palette, set the Subdivision Levels for the square to 6.

Set subdivision levels of the square to 6.

At the bottom of the morph palette you’ll notice a new setting called Bake down for subdivision. Check this option if you want the morph that you paint on level 6 to affect the vertices at lower subdivision levels. If the lower subdivision levels have vertices in the same areas that you paint on, they will also be affected by the morph.

For purposes of this example, make sure that the Bake down for subdivision setting is checked.

The subdivision level settings for high resolution morphs will vary depending on the geometry of the figure that you are morphing. In the case of this square we are starting with an object that is only a single polygon, so in order
Uncheck the option if you only want the morph to affect the current or higher level(s) of subdivision.

![Bake down for subdivision option.](image)

Switch to the Morphing Tool, and select the Pull morphing tool. Change the Relative to painting mode to Screen. Click near the middle of the square and start pulling vertices out toward you.

![Adding a Level 5 morph.](image)

After you pull enough vertices out, go back to the Properties palette and dial the Preview subdivision level down through each lower level (5 through 0) to observe how your painting affects the square at the lower subdivision levels. You’ll probably notice that the effect of the high resolution morph is barely noticeable at levels 2 and below, because there aren’t enough vertices in the square to have any effect at the lower levels.
Dialing the Preview subdivision level down to see the morph at lower levels.

Now dial both the Preview and Render subdivision levels up to 7. We’ll make a quick change at this higher level. The first thing that you will notice is that the morph you painted at Level 6 is still intact and has been smoothed out a little more at the higher level.

Uncheck the Bake down for subdivision option so that you only create a morph on this level. Paint in another area on the square so that the new morph is noticeable. In the screen shot below, four spikes are added to the square.

Some spikes added on Level 7.
After you finish your Level 7 changes, dial the Preview subdivision level down to 6. You’ll notice that your spikes (or whatever you painted) disappear, because you had the Bake down for subdivision setting turned off when you painted the Level 7 morph.

The Level 7 spikes (left) disappear at Level 6 (right) because you didn’t bake the Level 7 morph down to the lower levels.

Morph deltas are added sequentially. In other words, if you paint something at subdivision level 2, you will also see the morph working at level 3 and higher. Morphs painted at lower levels will affect higher levels. Higher levels, on the other hand, are independent. For example, if you add detail at Level 5 when the Bake down for subdivision setting is off, and then dial subdivision down to Level 4 or lower, you will not see the Level 5 morph affecting the lower levels.

If you need to undo the morph that you have created, the Zero Morph function has been enhanced to work on all levels, or on the current level: Try these steps:

Dial the Preview subdivision level back to 7, and click the Zero Morph button at the bottom of the morph palette. Choose Zero this level only.

You can zero a morph on the current subdivision level, or on all levels.

The first morph that you painted was on Level 6. Go one level lower than that (Level 5), and choose Zero this level only. What you’ll notice is that the morph doesn’t completely go away, because the morph was created one level higher. Instead, what you are taking away on Level 5 is the blend between Level 6 and Level 4. Deleting the blended morph at level 5 doesn’t completely remove the morph from Level 5 and below, but the influence of that intermediate level is gone and the morph at that level and below are not as strong as they originally were.
To remove the morph completely, go back to Level 6, where you created the original morph. Then click the Zero Morph button and choose Zero All Levels. The morph will be completely removed.
Developing with PoserPython

PoserPython exposes many of Poser's internal functions so that Python developers can automate tedious or repetitive processes. Python scripts (apps) packaged as described here can be sold on PoserSoftware.com, sold on Renderosity.com, or shared as simple ZIP files. Purchased apps are easily installed via Content Library's Purchases tab.

- Using PoserPython
- PoserPython Concepts
- PoserPython Scripts
- Poser Python Addons
Using PoserPython

This section explains a few Python basics and lists each of the customized PoserPython methods, including explaining functionality and providing syntax and use examples. It provides a certain level of background and behind-the-scenes explanations that will put the PoserPython types and methods involved into context.

Note that this chapter assumes that you have at least a basic level of understanding about the Python scripting language. While it does explain a few basic Python concepts in order to add clarity and context, this chapter is not intended to teach you Python. There are numerous excellent sources of information for learning Python, many of which are available for free.

Python (named after Monty Python’s Flying Circus) is a high-level, interpreted, object-oriented scripting language first developed in 1989 by Mr. Guido van Rossum and first released as free software in 1991 after extensive testing. It is an extremely powerful and easy-to-learn language that runs on virtually all platforms and that can be extensively customized and modified to run with other applications (such as Poser) and programming languages. Because it is free software, Python is freely usable and can be distributed free of charge. Python’s inclusion of a number of high-level data types as well as dynamic typing makes it easy for users to get their job done without the implementation hassle common to lower-level languages.

PoserPython is a customized implementation of the Python interpreter that includes many commands not found in the standard Python releases. This customization integrates Python with Poser and provides you with an extensive list of easy-to-use commands that can greatly reduce the time you spend performing repetitive tasks in Poser.

One of PoserPython’s best features is that you do not need to be a programmer to begin enjoying its benefits. Poser includes a number of useful sample scripts that can be executed by clicking a button. You never have to see a line of code, and none of your friends will ever label you as a programmer! That said, another of PoserPython’s best features is that you can “get under the hood” to write scripts that will do just about anything. PoserPython gives you virtually full control over your Poser documents including figures, props, lights, cameras, scenes, etc. and their building blocks and parameters. As you can see, PoserPython benefits both novice and expert alike!

PoserPython also includes the Numerical Python extension, which loads automatically when Poser starts up. Many geometry methods use this extension for fast manipulation of vertex, set, and polygon information. Please refer to http://www.numpy.org/ for more information.
Why Python?

Adding support for a scripting language to Poser gives users unprecedented power and flexibility to automate and customize their Poser experience and liberate creativity and productivity. The combination of simplicity, power, extensibility, and free distribution rights is making Python an increasingly popular programming language and has made it the obvious choice for integration with Poser. The PoserPython additions provide advanced Poser users with virtually infinite control and flexibility: A few lines of Python code can quickly automate processes that might take hours if done manually. And, with Poser’s internal structures exposed in the Python environment, you can write importers or exporters that interact with obscure or proprietary data formats. Because Python runs entirely within Poser, the only external application you’ll need for creating Python scripts is your favorite text editor.

A Word of Warning

Unlimited control is a double-edged sword. On one hand, users have direct access to their creations and underlying data. On the other hand, it is impossible to anticipate every conceivable PoserPython script. Because of the inherent power that scripting provides, it is possible to accidentally or intentionally destroy data, possibly beyond Poser itself. We at Bondware, Inc. have made every attempt to provide “safe” methods for manipulating Poser internals, and in most cases a Python mistake simply means that the interpreter throws an exception and halts the script execution. Nevertheless, Python is an entire programming language designed with far more than Poser in mind. It is a powerful tool and, like all tools, should be used with care. If you are not familiar with Python basics, we strongly recommend that you obtain training and begin your Python experience slowly and carefully so as to enjoy a smooth and trouble free learning curve.

PoserPython Modules and Classes Listing

PoserPython consists of hundreds of custom methods, and Bondware, Inc. is continually updating the list of available methods. The Python documentation is accessible through the Poser application, using the Python Shell.

To open the Python shell documentation:

2. At the >>> prompt, enter `import pydoc` and press Enter.
3. At the next >>> prompt, enter `pydoc.browse (1521)` and press Enter.
Python Shell Entries

Your browser window will open a page that lists all of the Python modules. From the Built-In Modules category, click poser. This will list all Poser-related modules, classes, functions, and data.
PoserPython Concepts

This section describes some of PoserPython’s basic concepts in order to provide context.

How Python Integrates with Poser

There are two basic types of programming languages:

- **Compiled**: A special program called a compiler reads the code written by the programmer, translates it into a form directly readable by a computer, and creates an executable program that can run on its own on any supported computer platform. Languages such as C++ fit into this category.

- **Interpreted**: Interpreted programming languages require a special program called an interpreter to run the code written by the programmer. The interpreter reads the commands found in the code and executes them from beginning to end without translating the original code. The drawback to interpreted languages is that they must use the interpreter, and the code can never run as a standalone program. The advantage, however, is that a programmer can change the code and see the results very quickly without having to wait for the code to compile. Additions, edits, and deletions become fast and simple.

PoserPython consists of a standard Python interpreter that has been extended to recognize and execute commands that are not included with the standard Python language. You can, however, pass data back and forth between Poser and other Python scripts, programming languages, and applications.

The standard Poser application contains volumes of data about each item (figure, scene, light, camera, prop, etc.) found within a given scene. You control these parameters via the mouse and interface elements such as menus, buttons, dials, etc. However, you cannot directly manipulate the data itself. This helps make Poser easy to use, but does create limitations. For example, you have no way to automate repetitive tasks or record a complex series of actions for further use. PoserPython circumvents these limitations.

PoserPython exposes much of the raw Poser data. Using Python scripts, you can extract data from Poser, manipulate it, and pass it back into Poser. Essentially, you can program Poser to do what you want, and you are no longer confined to the Poser interface and Poser’s built-in functionality.

---

*Python scripts are add-ons to Poser, and are supposed to be installed into the application installation folder (ex: C:\Program Files\Poser Software\Poser 13 for Windows, and Applications: Poser 13 for Macintosh systems.*
Basic Python Structure

Python is an object-oriented language. An object is a virtual entity combining structured data and the methods in which the data can be manipulated. A method is a procedure for manipulating data, and an argument defines how the method is carried out. A simplistic but effective analogy is that of basic grammar: An object can be equated with a noun, a method with a verb, and an argument with an adjective or adverb. For example, consider the following:

```python
car = Factory.Produce(vehicleXL)
```

In this case, the variable car is the result of the object factory being acted upon by the method produce as modified by the argument vehicleXL (the make and model). To put it in lay terms, the car’s existence and everything about the car depends on the factory being told to produce a car of a specified make and model. Consider how the value of the variable car can differ based on the following examples:

```python
car = Mechanic.Repair(car, transmission)
car = Junkyard.Salvage(vehicleXL)
car = CarThief.Steal()
```

In the first example the car argument is passed in, modified by the Mechanic’s Repair method, and returned as a working car. The last example contains no argument. In this case, the car thief may not take external input to decide which car to steal. Again, the object defines a structured set of data, the method is what the object does, and any arguments describe how the method is performed.

The data can be virtually anything including letters, numbers, files, etc. As you begin to think of data in terms of objects and manipulating objects, you will find it far easier and faster to write Python scripts.

Writing Python Scripts

Write your Python scripts using your favorite text editor.

`Poser expects strings to be encoded in Unicode. Scripts utilizing non-Unicode string methods might not work properly.`

`Avoid multithreading, most especially operations that call the PoserPython API from secondary threads.`
wxPython

wxPython allows you to create add-ons that integrate very well with Poser. You can also add your own palettes to the Poser GUI.


The most important rule: Retrieve managed window from Poser, don’t create your own main event loop.

Sample Python Script

This section provides a brief example of how a Python script might look. For this example, let’s say that you have an open Poser scene consisting of a figure with its left forearm already selected. The forearm is called an actor. An actor is any element of a Poser scene (body part, prop, etc.) and this manual uses the two terms interchangeably. Let’s say you want to set the x scale to 88 percent.

```python
scene = Poser.Scene()
actor = Scene.CurrentActor()
parm = actor.ParameterByCode(Poser.ParmCodeXSCALE)
parm.SetValue(88)
```

Let’s look at the above script in detail:

The script begins by obtaining a variable called `scene`, which is a reference to the current Poser scene. That scene contains numerous actors. Recall that the left forearm is already selected, so all the script needs to do is request the scene’s current actor to define the variable `actor`. Next, the variable `parm` consists of a reference to the left forearm’s specified parameter, in this case the parameter `XSCALE`. A parameter code (`ParmCode`) designates an easy to remember word to signify the desired parameter. Lastly, the value of the parameter to which `parm` refers is reset to 88, which will cause the left forearm to shrink to 88% of its normal size along the X-axis.

Folder Syntax

Python, among other languages, designates certain special characters as symbols beginning with a Windows-style backslash. Two common examples are `\t` ([TAB]) and `\n` (new line). Thus, in Windows, the notation

```
C:\folder\test.txt
```

is interpreted by Python as

```
C:[TAB]folder[TAB]text.txt
```
To work around this issue, you should use a double backslash (\) to signify folders. The above example would then become:

C:\folder\test.txt

which would be properly interpreted to mean a specific file path.

Alternatively, you can use Macintosh format, which uses colons to signify folders as follows:

C:folder:test.txt

### Packaging Your Script

The goal here is to allow Python scripts to have special installations so they will be properly setup and ready for users to use after unzipping them. This system should work no matter where the ZIP file was obtained from, or if it was installed through the Content Library or via the "Install from ZIP Archive..." menu option. An ongoing goal is to provide security features so commercial Python scripts can verify the user actually purchased them through a store front and protect the script from easily being copied.

Python ZIP files must contain a unique top level folder, and all files must be inside this folder so it can be totally self contained for installing/uninstalling. This includes any README or LICENSE files, no exceptions! Example looking inside a ZIP file, there is only one folder:

![Folder structure](image)

Inside the folder, there must be one file called: install_python.json.

![File list](image)

Inside it will be JSON data that looks something like:

```
{
  // REMOVE all comments from this JSON before packaging
  "name": "Poser Hello",  // product
  name for python product
  "scripts": [  // an array of
```
menus to add for this product
{
    "md5": "f57b7259b9b2d4c70dcb90991418f56d", // future security measure
    "menu": "Poser Hello:Hello", // menu path
    where user will find the script
    "script": "hello_poser.pyc" // name of the script to execute
}

"version": "1.0.3" // version of python script product

Other than those requirements, the ZIP can contain any other files of an type and/or subfolders it needs to function.

### Installation Folders

Python products are all installed into a store front runtime specific folder {store front}/Runtime/Python/{product folder} from each store front from where it was obtained, or the generic "Downloads" runtime for any installed via "Install from ZIP Archive..." menu.

### Commercial Script Security

A Python function is provided to confirm the user has purchased the scripts from a store front. Scripts can optionally call this to confirm a purchase. It takes two arguments, a store front id constant, and a store specific product id.

```python
if not poser.VerifyPurchase(poser.kStoreRenderosity, 135457) and
    not poser.VerifyPurchase(poser.kStorePoserSoftware, 1003):
    raise Exception("Purchase verification failure!")
```

### Addon Menu

The Window > Addon menu command is provided to allow for the addition of scripts by third-party developers. Developers can find base classes and example add-ons in the Runtime/Python/addons folder.
For Further Information

The preceding information was a very brief glimpse into Python and the PoserPython extensions. If you do not currently know Python, you may want to read and learn more. With the power and flexibility this interface offers, developing Python expertise would be well worth it.

Links to additional references can be found at When You Have Questions in the Poser Reference Manual.
PoserPython Scripts

The Scripts menu provides a hierarchical list of PoserPython scripts available for use within Poser. When you first launch Poser, this menu will list all of the PoserPython scripts that were included with your Poser installation. You have the option of placing additional Python scripts into the :Runtime:Python:PoserScripts: ScriptsMenu directory within your Poser installation; all scripts placed into this folder will be accessible within Poser from the Scripts menu.

For more information about writing Python scripts and the codes and methods used in PoserPython, see the PoserPython Methods Manual.

Running PoserPython Scripts

Poser includes a simple graphical user interface that allows you to execute Python scripts by pressing a button. You can customize the Python Scripts palette and, in addition, you can run Python scripts directly.

Running Your Script

You can run your script directly or via the Poser Scripts menu or palette, all of which are described in Using PoserPython in your Poser Reference Manual.

Running Python Scripts Directly

The Poser Python Scripts palette keeps your frequently used scripts close by for easy use. However, you can run any script you wish by selecting File > Run Python Script to open the standard operating system navigation dialog. Locate the script you wish to run by browsing your folders and directories, then press Open to run the script.

Running Python Scripts from Pose (PZ2) Files

You can also add commands in pose files that will call scripts to be run. For example, pose files have been able to call a Python script by adding the following line in the pose (PZ2) file:

runPythonScript "runtime:path:to:script.py"
runPythonScript has no arguments that can be passed to script.py, meaning that if you have five poses doing the same thing with only one difference, the developer has to make five copies of that script where only one line is different in each.

However, the runPythonScriptEx variant allows you to pass an argument to the script. For example, in script.py, the variable sys.argv[1] will be equal to “apples” as it would be if script.py were run from a command line. The syntax is as follows:

runPythonScriptEx "runtime:path:to:script.py" apples

Alternately, you can access your script directly from the Poser Scripts menu.

The Python Scripts Palette

Launch the Python Scripts palette within Poser by selecting Window > Python Scripts.

Using the Script Buttons

To run a script, simply press the desired button and the script will execute automatically.

Assigning Buttons Within the Console

Unassigned buttons do not have a label. An ellipsis (...) appears in unassigned buttons to mark their availability. To assign a script to a button, simply press the mouse on the button and locate
the desired script (.py file) using the standard operating system file picker. Once you have located the desired script, select it and press Open.

**Editing Scripts Within the Console**

You can edit scripts assigned to a Poser Python Scripts palette button by pressing and holding [CTRL] while clicking the button assigned to the script you wish to edit. This opens the script within your operating system’s default text editor for easy modification. Save your changes as appropriate for the editor you are using. You may also select your own editor via the General Preferences dialog, which can be obtained by choosing **Edit > General Preferences** as described in .

**Unassigning/Reassigning Buttons Within the Console**

To reassign a button to a different Python script, you must first delete its current assignment and then assign the new script to it. Do this by pressing and holding [OPT]/[ALT] while clicking the button you wish to unassign. If you wish to assign the newly freed up button to a different script, do so as outlined above.
Poser Python Addons

By default Python scripts are run from the Scripts menu whenever the user requests it. However, more advanced tools written in Python might want a tighter integration with Poser. A Python poseraddons module exists for this, and developers can make their own modules loaded at startup. This will allow additional functionality including, but not limited too, methods called at Poser startup/shutdown, methods called at scene creation/deletion, wx panels incorporated into Poser, ability to load/save user preferences, ability to load/save extra information in Poser scene files, and more.

Addon Packaging

To flag a Python ZIP installation as being an addon, add an element in it's install_python.json for addon: 1. After that you must follow Python conventions for creating a package/module, like including __init__.py

Example install_python.json:

```json
{
    "addon": 1,
    "name": "Poser Hello",
    "version": "1.0.7"
}
```

Note: The optional scripts section really only needs to list scripts you want to have a Python menu entry for. All scripts included in the ZIP are installed no matter what. Addons will always get a menu under Window > Addons. A single Python ZIP may install itself as an addon, add script menu entries, or do both.

Poser Startup

When Poser is launched, it runs poserStartup.py, this will load any standard Python Addons included with Poser (like the Python Shell window) and any extra Addons installed via ZIPs. Any Addons found have their folder added to the Python sys.path and they are then loaded with __import__() as a Python package. Addons are expected to create a class inheriting from poseraddon, create an instance, and call poser.RegisterAddon(). Then the methods on this object will be called as needed as Poser continues to load. It should go without saying, as this code is always executed at startup, it shouldn't do anything too time/cpu intensive or the user will have a poor experience.
Example Python Addon package \_init\_\_py:

```python
import poser

import wx

import wx.py

import wx.aui

import poseraddon

class PoserHello(poseraddon.Addon):
    def \_init\_(self):
        self.addonInfo['id'] = 'com.bondware.poserHello'
        self.addonInfo['author'] = 'Bondware, Inc'
        self.addonInfo['copyright'] = '(c) 2020-2021 Bondware, Inc'
        self.addonInfo['name'] = 'Poser Hello'
        self.addonInfo['version'] = '1.0.7'
        self.addonInfo['observer'] = 0
        self.addonInfo['scenedata'] = 0
        self.win = None
    def load(self):
        man = poser.WxAuiManager()
        root = man.GetManagedWindow()
        self.win = wx.py.shell.Shell(root, introText="Hello !")
        man.AddPane(self.win, wx.aui.AuiPaneInfo().DefaultPane().Name("com.bondware.poserHello").Caption("Poser Hello").Show().FloatingSize(wx.Size(450, 300)))
    def unload(self):
        pass
poser.RegisterAddon("com.bondware.poserHello", PoserHello())
```

**Poseraddons Module**

Refer to the classes in Runtime/Python/addons/poseraddon.py for the full API of methods you can override in your own subclasses to implement advanced behaviors. Note, you must use multiple inheritance if you want to take advantage of the extra classes and set the appropriate flags in the addonInfo dictionary.

# This is the primary base class for Poser addons
# Your addon should inherit from this class.

# API Revision history:
# 
# 1.2 Added cameraChanged and lightsChanged callback.
# To use these callbacks, your addon must set its version field to 1.2.
# Released with Poser 10.0.2
# 
# 1.1 Added objectsInternalRenamed callback.
# To use that callback, your addon must set its version field to 1.1.
# Released with Poser 10.0.0
# 1.0 Initial release with Poser 9.0.3

class Addon:
    # The constructor. Fill in the addonInfo structure, but do not do
    # much beyond that. This may be called at a point in time where
    # Poser is not fully initialized yet and calls to the Poser Python
    API
    # may fail or crash Poser.
    def __init__(self):
        pass

    # Poser is fully initialized and your plugin is being loaded.
    # Fill in your data structures, build a GUI, do what your plugin
does.
    def load(self):
        pass

    # Your plugin is unloaded from Poser, clean up your data, close
open files,
    # close your custom GUI. Please leave no trace.
    def unload(self):
        pass

    # addons must fill this dictionary
    addonInfo = { 'id' : 'com.bondware.addon', # set this to a unique
ID
        'author' : 'Bondware, Inc', # author info
        'copyright' : '(c) 2019 Bondware, Inc',
        'name' : 'AddOn', # this is the name of your plugin that will be
visible in the GUI
        'version' : '1.1',
        'observer' : 0, # set to 1 if your addon implements the methods
from SceneObserver
        'scenedata' : 0, # set to 1 if your addon implements the methods
from SceneDataSaver
        'prefsdata' : 0, # set to 1 if your addon implements the methods
from PrefsSaver
        # 'apiversion' : '1.0' # set this to the version of the addon API
your addon is built for
        # this defaults to 1.0 so that older scripts that did not set
this field will run in 1.0 mode
        # make sure to set this to the current version in your addon!
    }

    # These methods will not get called immediately when things happen
    # They get called when the program flow is finished with its work and
    # returns to regular event processing
    class SceneObserver:
        def objectsAdded(self, objects):
pass
def objectsDeleted(self, objects):
    pass
def objectsRenamed(self, objectsOldNames):
    pass
def objectsInternalRenamed(self, objectsOldInternalNames):  # API V1.1 or higher
    pass
def objectSelected(self, selection):
    pass
def sceneDeleting(self, scene):
    pass
def sceneCreated(self, scene):
    pass
def frameChanged(self):
    pass
def materialsChanged(self, materials):
    pass
def cameraChanged(self):  # API V1.2 or higher
    pass
def lightsChanged(self):  # API V1.2 or higher
    pass

class SceneDataSaver:
    # This method will be called when a Poser scene is saved.
    # Your addon should return a dictionary that can be serialized.
    # Do not make any assumptions about how and where your dictionary is stored.
    # It may be in the PZ3, it may be outside of the PZ3,
    # it may be as ASCII text or as binary. Under no circumstances try to read, write or modify the addon data stored in a PZ3 directly.
    def saveData(self):
        return None

    # This method will be called when a Poser scene is loaded
    # that contains data saved by your addon. You will receive
    # the dictionary that your addon passed into saveData() when
    # the scene was saved.
    def loadData(self, data):
        pass

class PrefsSaver:
    # This method is called when Poser asks your addon to save its preferences.
    # Typically this happens when Poser exits or when an addon explicitly asked
    # for the preferences to be saved.
    # Return a dictionary that can be serialized.
    def savePrefs(self):
        return None

    # This method will be called after Poser has launched and the
addons are loaded.

# You will receive the dictionary that your addon passed to
savePrefs() when
# your addon was asked to save the prefs.
def loadPrefs(self, data):
    pass

**Sample Addon Script**

For an example of an addon script, download PoserHello.zip
Linking Extra Modules to PoserPython

Windows users can install modules externally to Poser using `pip -m`, since the entire Python framework is external.

Historically, macOS Poser has parts of the Python framework bundled within the Poser application, meaning command line pip has no visibility of it.

Importing Modules

On either Windows or macOS, Poser’s Python Shell knows where everything lives. You can use the following code to import modules using pip:

```python
import pip
pip.main(['install', '--target', '<the path to the sitepackages folder', '1st package name'])
```

Multiple packages can be installed simultaneously by listing them after the first.

Upgrading pip

Pip can be upgraded via:

```python
pip.main(['install', '--upgrade', 'pip'])
```

Reloading pip

If you upgrade pip, you’ll then need to reload it, so:

```python
from importlib import reload
reload(pip)
```

NOTE: Reload was a builtin method in Python 2.7 (used in earlier Poser versions), but needs to be imported in Python 3.7 (used in Poser 12 and later)

Listing Known Packages

The packages pip knows about can be listed:

```python
pip.main(['list'])
```

If you want their installation paths, add the `-v` option.
Finding Later Versions

If you want to know what later versions are available, use the ‘-o’ option, e.g.:

```python
pip.main(['list', '-vo'])
```
Sharing Data with Other Applications
Importing Content

Poser allows you to import and export various types of content such as background images, movies, and 3D objects. This allows you to use third-party applications to create textures, background scenes, and clothing that you can use to enhance your scenes.

Selecting **File > Import** allows you to bring both Poser and non-Poser files into your scenes. These could be images, movies, or props (which you can convert into Poser figures as described in [The Setup Room](#)).

---

**Poser 13 supports drag and drop import of supported geometry file formats. Simply open Windows Explorer (Windows) or the Finder (Mac) and drag a supported geometry file format (OBJ, FBX, etc) into your document window. The applicable Import Options dialog will appear so that you can specify import options.**

---

Using Background Pictures

You can import static images as backgrounds. For example, if you are creating a scene with Poser characters in a room with a window, you could use a background image to simulate the view from the window. Selecting **File > Import > Background Picture** opens a standard Open dialog, allowing you to select your image’s format and location. As with movie imports, you are asked if you wish to resize your **Document** to match the imported image, and the results are the same as described above. Changing the aspect ratio of imported images can introduce unwanted artifacts into your scene when rendered and can result in blank areas on the sides of the **Document** (see above). We therefore recommend resizing your **Document** or importing correctly sized images. Poser supports importing background images in a wide variety of formats.

<table>
<thead>
<tr>
<th>Extension(s)</th>
<th>Description</th>
<th>Import</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td>bmp</td>
<td>Windows bitmaps</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>dds</td>
<td>DirectDraw Surface</td>
<td></td>
<td></td>
</tr>
<tr>
<td>exr</td>
<td>OpenEXR image format</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>gif</td>
<td>Graphics Interchange Format</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>hdr</td>
<td>Radiance Image</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>jpeg/jpg</td>
<td>Joint Photographic Experts Group image</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>pbm/pgm/ppm</td>
<td>Portable bitmap, graymap, and pixmap image formats</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>pcd</td>
<td>Kodak Photo CD</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>png</td>
<td>Portable Network Graphics format</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>pict</td>
<td>Macintosh PICT files</td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>
When importing images, we recommend that you import them while the document window is in its docked state. You should try to light your scene in a manner consistent with the background so as to blend them together. Please see Lighting for information about lights in Poser.

**Showing and Clearing Background Pictures**

If you have a background image in your scene that was placed there using either the File menu or by pasting the current figure/prop into the background, then selecting Display > Show Background Picture toggles displaying this image on and off.

Selecting Display > Clear Background Picture deletes the currently displayed background image (if any).

**Use Background Shader Node**

There are two ways of specifying the background of a scene – by loading an image in the BG Picture node, or by attaching a shader tree to the Background root node:

- If you want to use the BG Picture node as the background of your rendered image, choose Render over > Background picture in the Render Settings dialog, as described in FireFly Options Settings.

- If you want to use the shader attached to the Background root node as the background of your rendered image, choose Render over > Current BG shader as described in FireFly Options Settings. Please refer to Root Background Node for information about using background shaders.

**Importing Movies**

To import movies, select File > Import > Background Footage. You can use imported movies to add background action to your Poser animations. For example, you could have a scene with two Poser characters sitting on a train with an imported movie showing the scenery rolling past as if the train was in motion.

If your imported movie’s size or aspect ratio (width/height) is different than your current Document settings, you will be informed that the background width and height are different, and will be asked if you want to change the window to match the background.
Importing Poser Documents or Props

Selecting Yes resizes your Document to fit the imported movie. It is recommended that you only use this option while the Document is docked.

Selecting No “stretches” the Document to accommodate the movie. You may see areas of the Document not covered by the imported movie.

Changing the aspect ratio of imported movies can introduce unwanted artifacts and distortions into your scene when rendered. We recommend that you resize your Document or import correctly sized animations.

Imported movies will begin at the first frame of your Poser animation. If your animation is longer than the movie, the movie will remain in the background paused at its last frame. If your animation is shorter than the movie, you will see Frames 1-X of the imported movie, where x is the number of frames in your Poser animation.

When importing movies, you should try to light your scene in a manner consistent with the background so as to blend them together. Please see Lighting for information about lights in Poser.

Importing Poser Documents or Props

Selecting File > Import > Poser Document/Prop loads either an entire Poser scene or a Poser prop into your scene. This can be useful for inserting props that are not part of your Library palette’s Props category. Imported scenes/props become part of your current scene complete with animations, morphs, poses, etc. This option opens a standard dialog box allowing you to browse for the desired file. Use the Files of type pull-down menu to select one of the following types of Poser files:

- **Poser document files (*.PZ3 and *.PZZ)**: This option imports Poser 3.0 and later scenes, both uncompressed and compressed.

- **Poser Prop Files (*.PP2 and *.PPZ)**: This option imports uncompressed or compressed Poser prop files.

See Miscellaneous Preferences for more information about compressed file support within Poser.
Importing LipSync Audio

Choose `File > Import > LipSync Audio` to locate an audio source in Windows Explorer or the Mac Finder. After you select a file, the Talk Designer window will automatically open with the file selected as its input. For more information on the Talk Designer, see Using the Talk Designer.

Importing Sound

Choose `File > Import > Sound` to import WAV, MP3, and other audio format sound clips that you can use as a soundtrack for your animations. Imported speech or sounds are added to the beginning of your animation and play every time you play your animation. Supported file formats are listed in Media Support.

Upon selecting this option, a standard Open dialog appears, allowing you to select the filename and location of the sound file you wish to import. Please refer to Syncing Sound & Motion for information on working with imported sounds.

Importing BVH Motion Capture Files

Selecting `File > Import > BVH Motion` allows you to import motion-capture files in the popular BVH format. A standard Import dialog appears, allowing you to select your desired path and filename.

Select the Body actor on the figure that you want to animate. Then choose `File > Import > BVH Motion`. After you select your BVH file, the BVH Export/Import Options dialog appears with the following options:

- **Scale the motion capture data automatically?**: To determine the correct scale for the BVH files consult the developer’s readme or documentation.
  - **Scale automatically**: This is the default option. The BVH motion file will be scaled to match the scale of the Poser figure.
  - **Don’t scale figures**: The imported BVH file will not be scaled to match the current figure. If the BVH file was created in other software that uses different scaling units,
Some actors like eyes or hair may not be recognized, but the BVH file will still load. If you make a mistake, return to Frame 1 and re-import the file. Imported BVH keyframes are applied to the currently selected figure and can be edited like any other keyframe (see Editing Keyframes on the Timeline).

**Importing 3D Objects**

**Tips & Tricks**

When using your favorite 3D modeling application for creating new geometries for conversion into Poser figures/props, it is a good idea to follow these guidelines in order to speed up the figure creation process and provide a better end result:

- Make sure that you do not have duplicate or overlapping polygons. Duplicate polygons occur when you have two identical parts of the geometry occupying the same location, for example if you accidentally paste an item twice. The following graphic depicts an instance of duplicated polygons within a 3D modeling application.

In some cases, figures can float above the surface of the floor after you import BVH data. Choose the Scripts > Utility > dropFigToFloorAllFrames command for a useful Python utility that drops the figure to the floor across all keyframes.

Two spheres that overlap each other.
Eliminate overlapping polygons, which can occur if pieces of the geometry are embedded within each other. The following graphic shows an example of overlapping polygons on the left (the smaller pipe embedded within the larger one), and the correct way to create the geometry on the right (without overlapping polygons).

Remove overlapping polygons.

Poser allows you to import geometries as a single file with groups within the file, as separate files, or as a single file with no groups. We recommend that you create your geometries as single files with no groups, since Poser includes powerful grouping tools and since some geometry formats (such as Wavefront OBJ) allow you to assign polygons to more than one group at a time. Importing geometries with polygons assigned to more than one group will cause Poser to duplicate those polygons, resulting in additional unwanted figure parts.

Use the following procedure to import geometries into Poser:

1. Begin the process by creating a polygonal mesh object in your favorite 3D modeling application. Once you have finished, import it into Poser by selecting File > Import > format, where format is the format you wish to import (such as OBJ). A Standard Open dialog appears, allowing you to select your desired filename and path.

2. Once you have selected the desired geometry, the Prop Import Options dialog appears. It contains the following options:

   - Centered: Checking the Centered checkbox positions the imported geometry in the center of the Poser workspace.

   - Place on floor: When enabled, the Place on Floor option places the bottom of the prop at “ground level” on the floor of the workspace.

   - Percent of standard figure size: The Percent of standard figure size option scales the geometry relative to the height of a standard Poser figure. For example, setting the scale to 50% imports the geometry at 50% of the height of a standard Poser figure. The rest of the geometry scales to maintain the correct proportions relative to the selected height. When importing DXF geometries, Poser considers one DXF unit as being equal to the height of a standard Poser figure, or about six feet.

   - Offset: Entering numeric values in one or more of the Offset fields positions the geometry at the selected position within the Poser workspace.

   - Weld identical vertices: When enabled, the Weld identical vertices option unites identical vertices within the geometry.
• **Make polygon normals consistent**: If the geometry file contains vertex normals, checking the **Make polygon normals consistent** checkbox makes the polygon normals consistent with the vertex normals.

• **Flip normals**: The **Flip Normals** option reverses all of the geometry’s normals.

• **Flip U Texture Coordinates**: The **Flip U Texture Coordinates** option reverses the geometry’s U texture coordinates.

• **Flip V Texture Coordinates**: The **Flip V Texture Coordinates** option reverses the geometry’s V texture coordinates.

3. Once you have finished selecting your desired options, click the **OK** button.

4. The geometry file imports into Poser. The amount of time required to import a geometry file depends on factors such as the size of the file, number of polygons or groups, speed of your computer, etc. A progress indicator tracks the import process. When the process is complete, the imported geometry appears in your Poser **Document**.

An object after it is imported into your scene.

Imported geometries are treated as static props. You can add props to the **Library** palette as described in **Maintaining Your Library Palette** and/or can convert props into poseable Poser figures using either the graphical Setup room (see **The Setup Room** for instructions on using the Setup room) or the legacy text-based method (refer to **Creating and Converting Hierarchy Files**).

### Importing 3D File Formats

Most 3D modeling applications support at least one of the formats that is supported by Poser, which allows you to import geometries in the following formats:

- **3D Studio Max** *(File > Import > 3D Studio)*
- **DXF** *(File > Import > DXF)*
- **LightWave LWO files** *(File > Import > LightWave...)*
- **Wavefront OBJ** *(File > Import > Wavefront OBJ)*
- **COLLADA**: See **COLLADA Import**.
- **FBX**: See **Importing FBX Files**.
When choosing 3DS, DXF, LightWave, or Wavefront OBJ format, the Import Options dialog appears, and presents the following options:

- **ZBrush**: See Using Poser with ZBrush.

Some formats, such as Wavefront OBJ, allow you to save geometries as either polygons or NURBS surfaces. Poser will only accept geometries saved as polygons.

Poser will import smoothing groups in Wavefront OBJ format, as defined in the source file. If no smoothing groups are specified in the source file, none will be imported. Please refer to Smoothing Geometry for more information about smoothing groups.

Note that while Poser does not support the 3ds Max style of defining smoothing groups, Poser does take into account the vertex normals when determining creases. As a result, OBJ files exported from 3ds Max will usually appear as expected, despite the fact that the 3ds Max smoothing groups are not read.

When choosing 3DS, DXF, LightWave, or Wavefront OBJ format, the Import Options dialog appears, and presents the following options:

- **Scale**: Allows you to choose whether to scale the model at percentage of original size, or of standard figure size.
  
  - **Of original size**: Choose this option if you want to scale the model based on the actual size of the geometry that you are importing. The default is 100% of original size, which will import your model in exactly the same size that it was exported from your modeler. If your model was exported at a larger scale, enter a different value in the Scale field.

  - **Of standard figure**: Choose this option to use the legacy method of figure import. Poser’s standard figure size is approximately six feet tall.
Poser’s model scaling is considerably smaller than “real world” scaling typically used in 3D modelers. Many content creators export from Poser at about 100 times Poser scale (10000%), and then import back into Poser at 1/100 scale (1%).

To export from Blender and import into Poser’s native scale, set the OBJ export scale in Blender to 0.38149298. Then import into Poser at 100% scale.

To export from Poser and import into Blender at native scale, set Poser export scale at 262.128019%. Then import into Blender at 1.

A figure imported at 100% figure size is six feet tall.

- **Centered**: Check this option to center the model at zero X, Y, and Z coordinates. This will cause half of the model to be beneath ground level unless you select **Place on Floor** below. If you want your model to be imported in exactly the same position at which it was modeled, uncheck this option.

- **Place on Floor**: Check this option to place the bottom-most portion of the imported object at ground level. Uncheck this option to import the object in its default modeled position.

- **Offset (X,Y,Z)**: Check this option and enter specific X, Y, and Z coordinates if you want your model to be offset by a specific amount from the zero coordinates. Uncheck this option to import the object in its default modeled position.

- **Weld Identical Vertices**: Check this option to remove vertices that exist in exactly the same position.
Collada Import

Poser offers data exchange with the industry-standard COLLADA format. Gain maximum flexibility by transporting Poser content to applications such as Softimage XSI or nVIDIA FX Composer without having to rely on hosting plug-ins.

Collada Import Options dialog.

- **Make Polygon Normals Consistent**: Check this option to ensure that polygon normals are imported facing in the same direction. Uncheck the option if you want to maintain normals as they are presently modeled.

- **Flip Normals**: Check this option to import a model with its normals facing in the opposite direction. Uncheck the option to import the model with normals facing in the direction in which they are modeled.

- **Flip U Texture Coordinates**: Check this option to flip the UV texture coordinates on the horizontal (U) axis.

- **Flip V Texture Coordinates**: Check this option to flip the UV texture coordinates on the vertical (V) axis.

Collada Import

Poser currently supports import and export of COLLADA 1.4. COLLADA 1.5 is not yet supported.

Importing COLLADA files allows you to import geometry with standard surface materials, cameras and lights. COLLADA import in Poser does not currently support Cg shaders, morph targets, bones or animation.

To import a COLLADA file, from the **Main Menu** select **File > Import > COLLADA|RWY**. Enable the appropriate import options and click **OK**.

• **Import Lights**: With this option enabled, Poser will add lights stored in the COLLADA file to the current scene. For more information about lights, see **Lighting**.

• **Import Cameras**: With this option enabled, Poser will add cameras stored in the COLLADA file to the current scene. For more information about cameras, see **Cameras**.

Importing FBX Files

Choose **File > Import > FBX** to import an FBX file into Poser. The FBX Import Options dialog will prompt you to enter a scale (default is 100%). Press **OK** to import the FBX file.
Working with Imported FBX Content

You can import FBX content from other sites and then export as FBX with other Poser content.

1. After obtaining or creating FBX content from another application, create a new scene in Poser and delete the default figure.

2. Choose File > Import > FBX. The Import FBX window prompts you to locate an FBX file on your system.

3. After you select the file, click Open. The content appears in your Poser project in its default position.

After you import FBX content into Poser, you should verify the following:

- Mesh (make sure that geometry imported without parts that are missing)
- Ensure that textures are imported correctly, including transparencies on eyes, hair, lashes, and clothing if applicable. Also do test renders to make sure that bump maps work as expected.
- Test joint bending to make sure that the figure bends as expected. Check for weld breaks and mesh distortion. If improvement is needed for bending, use Poser’s Joint Editor to adjust joint centers and weight mapping.
- Verify animation keyframes in the Animation Palette.

You can use other tools in Poser to make changes and improvements. For example:

- Use the Group Editor to add or remove groups that improve how the face and body of the character are animated.
- Use the Joint Editor to improve how the character bends.
- Use the Morph tool to change the appearance of the character, or to create phoneme morphs that are compatible with Poser’s Talk Designer
- Use the Talk Designer to make your character speak
- Use the Walk Designer, Animation controls and Animation Palette to create or tweak walk cycles and other movements.

If you make changes, you can then export the character as a new FBX file.
Exporting Files

In addition to supporting a wide range of import formats, Poser supports many formats for export, allowing you to use your Poser output with your favorite 2D and 3D applications.

Exporting Partial Scenes

Poser allows you to export partial scenes that include selected content. Some typical examples could include rooms with furniture, landscapes with plants, or figures with clothing and props. Saving these types of scenes as partial scenes allows you to reuse them in other Poser scenes without the worry of importing additional elements that you do not want to duplicate (such as lights or cameras, or other characters that were also present in the original scene).

To export a partial scene, follow these steps:

1. Choose File > Export > Partial Scene. The Select Objects dialog appears. Initially no items are selected.
2. Check the items that you want to include in the partially saved scene.
3. Click OK. The Save Poser Scene window prompts you to locate a folder in which to save the scene, and to enter a filename.
4. Click Save.
5. To merge previously saved partial scenes into your current scene, use the File > Import > Poser Document/Prop command.

Exporting Files for Sharing

Save for sharing copies all assets for the saved document into a zip file. Where possible the Zip will contain the scene assets in the same directory structure as they originated from.

The Save for Sharing export is primarily designed to share files for testing. It does not create a Runtime structure that is ready for product submission to the store.

You should not distribute content created by other vendors without their permission.

To create a save for Sharing export:

1. Choose File > Export > Save for Sharing.
2. Poser notifies you that this will export all selected resources to a path that you specify, and place them under a Runtime folder at the location you specify. A Poser scene file (PZ3) will also be created in the selected folder at the root. Press **OK** to continue.

3. The Select Objects dialog appears. Click **Select All** to include all items in the scene. To select specific items, choose **Select None**, and then check the items you want to include. Then click **OK** to continue.

4. You will be prompted to choose a folder for your files. It is recommended that you select or create a new empty folder for the collection. For example, a new folder named "My Export Files" is created on the desktop, and the scene is assigned a name of "My Files to Share.pz3". After you select the folder and assign a name for the file, click **Save**.

5. Poser notifies you that the shared scene file is complete, and creates a ZIP file in the location you specified. The path to the ZIP file is displayed in the notification window.

To use a scene exported with Save for Sharing you will need to extract the content of the Zip to an empty folder. Make sure to preserve the folder structure inside the zip. Once extracted open the Poser scene file included in the zip.

---

**Files for Sharing ZIP file shown in 7-Zip.**

To use a scene exported with Save for Sharing you will need to extract the content of the Zip to an empty folder. Make sure to preserve the folder structure inside the zip. Once extracted open the Poser scene file included in the zip.

---

**Exporting Images**

To export an image, select **File > Export > Image**. A standard Save As dialog appears, allowing you to specify your desired filename and save location. In addition, you may be able to select various image-specific attributes (such as quality for JPG exports).

If you want Poser to write an alpha channel to preserve transparency in your exported image, you should export to either the PNG, TIFF, or PSD formats. An alpha channel causes the foreground to be transparent wherever it is empty, in order to allow the background to show through. This feature is essential for compositing in image editing applications.
You can also use any of the following methods to export rendered images from Poser:

- From the **Render Tab** in the document window, click the arrow in the upper right corner and choose Export Image.
- Right-click a thumbnail in the Recent Renders palette, and choose Export Image. See **Displaying Recent Renders**.
- Open the Post Rendering Effects window and click the Export Image button. See **Applying Post Effects to Rendesrs**.

Exporting an image saves a snapshot of your current scene as seen in the active tab of your **Document**. Therefore, if you are in the **Preview** tab of the **Document**, your exported image will be a snapshot of the scene exactly as it appears in the **Preview** tab. If you are in the **Render** tab, your exported image will be the rendered image that is currently selected in the **Main Render** menu at the bottom left of the **Document**.

**High Dynamic Range Image (HDRI) Export**

With Poser’s FireFly renderer you can render and export files that are optimized for HDRI output. Files can be exported as Radiance files or OpenEXR files. HDRI optimized files accurately represent the wide range of exposure found in real scenes, including the details, shadows, and high-contrast lighting.

- To optimize images for HDRI export, from the **Main Menu** select **Render > Render Settings** and enable the **HDRI Optimized Output** check box in the FireFly settings tab.
- To Export an HDRI image, from the **Main Menu** select **File > Export > Image**, and choose either Radiance (.HDR) or OpenEXR (.EXR) as the image format.
- To make a movie optimized for HDRI output, from the **Main Menu**, select **Render > Render Settings**. Click the **Movie Settings** tab, and select **Image Files** from the Format pull-down menu. Choose one of the above-mentioned formats.

While more precise, files optimized for HDRI output can lead to perceived loss of anti-aliasing and banding in very subtle gradients. Optimizing for HDRI output omits dithering that would otherwise be applied to eliminate banding.

Optimizing images for HDRI output provides maximum flexibility in post-production, performing color correction or adjusting exposure without having to re-render the image.

*Same HDR image at varying exposures in Adobe Photoshop CS.*
Exporting BVH Motion Files

To export a BVH motion capture file:

1. Select the figure you wish to export.
2. Select File > Export > BVH Motion.
3. Select Scale Automatically. If the exported file looks incorrect, re-export it and disable automatic scaling.
4. A standard Save dialog appears, allowing you to specify your desired filename and save location.

Exporting Alembic Files

1. Select File > Export > Alembic.
2. In the dialog that appears, check the appropriate radio button to export either a still (at the current frame of your animation) or an animation. If you select to export an animation, enter the frame starting and ending numbers in the appropriate text boxes and click OK.
3. In the Select Objects list, choose the actor(s) you want to export in the following dialog and click OK.
4. A standard Save As dialog appears, allowing you to select your desired filename and path.

Exporting Painter Scripts

Clicking the Export Painter Script button in the Sketch Designer exports the current Sketch Designer settings to Corel Painter (see The Sketch Designer). This has been tested to work with Painter 6 and previous versions, and is not supported for later versions though it may work with them.

Exporting 3D Objects

Poser allows you to export 3D objects in RIB, 3DS, DXF, OBJ, VRML, LWO, OBJ, and COLLADA formats by selecting File > Export > format, where format is one of the supported export formats. To export to a 3D format:

1. Select File > Export > format.
2. In the dialog that appears, check the appropriate radio button to export either a still (at the current frame of your animation) or an animation. If you select to export an animation, enter the frame starting and ending numbers in the appropriate text boxes and click OK.
3. Select the actor(s) you want to export in the following dialog and click OK.
4. A standard Save As dialog appears, allowing you to select your desired filename and path.
Export Options

When you export a 3D object in 3DS, DXF, Lightwave, Alembic, OBJ, or VRML format, the Export Options dialog presents several options as follows:

- **Export object groups for each body part**: Exports group names for each body part included in the exported object. (This option is disabled for OBJ format, but enabled for 3DS, DXF, Lightwave, and VRML export).

- **Weld body part seams**: (OBJ Export only) When checked, welds groups together where one body part meets another, and discards the duplicate set of vertices. The vertex order of the exported OBJ will be different than the one that was originally loaded into the scene.

- **As Morph Target (no world transformations)**: (OBJ Export only). When checked, this option automatically selects the following two options. Check this option to ensure that the OBJ is exported in its default pose and position.

- **Include body part names in polygon groups**: (OBJ export only). Exports an OBJ file that is unwelded at group seams. Group and material assignments are also exported.

- **Use exact internal names except spaces**: (3DS, DXF, Lightwave, OBJ, and VRML formats). When this option is checked, each group in the figure will be appended by its figure number (example: instead of abdomen, the group is listed as abdomen:4).

- **Include figure names in polygon groups**: (OBJ export only). Prepends group names with Figure x (where x is the figure number assigned by Poser when the figure was loaded into the scene).

- **Include existing groups in polygon groups**: (OBJ export only). If this option is checked, space names are removed from group names when the OBJ is exported. If this option is not checked, spaces and colons are removed from the group names.

- **Preserve existing material names**: (OBJ export only). If this option is checked, a figure number will be appended to material names to avoid conflicts in cases where more than one figure is exported at the same time.
Exporting COLLADA Files

COLLADA offers increased flexibility by allowing you to export a more comprehensive representation of your Poser scene. For example, as a game designer, you might want to import your scene exported from Poser as a COLLADA file into 3ds Max or Softimage. You can work on your scene in those applications, and then transfer it to your game engine with COLLADA. Your scene remains editable at any position in the pipeline. COLLADA is a feature-rich format that can store various aspects of your scene, thereby preserving a maximum of information upon export. Provided that the application you are exporting for supports those features, you can choose to transfer data such as static figures, props, baked morph targets, cameras, and lights.

To Export a COLLADA file:

1. From the Main Menu select File > Export > COLLADA|RWY.

2. The Export Range dialog appears. If you want to export only the current frame, choose Single Frame. To export multiple frames in an animation, choose Multi frame export, and then enter the range of frames to be exported.

3. The Select Objects dialog appears. By default, the lights, main camera, and all figures and props in your scene are selected for export. You can uncheck objects you don’t want to
include, and check other objects that you do want to include. After you make your selections, click **OK** to continue.

Choose the objects to export from your scene.

If subdivision is set on any of the objects in your scene, Poser will warn you that subdivision will be turned off for the COLLADA export. Click **Cancel** to return to Poser, or **OK** to continue.

4. Click **OK** to continue. The Export Options dialog appears. Enable the appropriate Export Options and click **OK**. These options include:

Export Options dialog.
• **Export Standard Units vs. Custom Units**: Select one of the standard Poser units. If none of the standard units meet your needs, then you can define your own Custom Units in meters.

• **Scale**: This allows the adjustment of the scale of a scene upon export. Adjust the scale if you want to adjust the size of the scene.

• **Triangles only**: Forces triangulation of polygons upon export.

• **Include normals**: Allows you to specify whether polygon normals are exported explicitly. Discarding the normals will require the target application to recompute them. Toggling this option may help resolve shading issues.

• **Include rigging (preserves posability and animation)**: Figures are exported as poseable and animatable objects.

• **Export every frame as keyframe**: When checked, will export an animation keyframe for every frame in the selected range. When unchecked, exports already existing keyframes only. This can help increase accuracy in a complex setup (e.g. conforming clothing) or if the importing application has difficulties interpolating between keyframes.

• **Bake all Morphs**: COLLADA files with a lot of morphs can be large and resource consuming. **Bake Morphs** allows the export of morph targets so you get the essence of the morphs without the file size and resource expense. You will not be able to animate those morph targets any more, which sacrifices some flexibility. However, you’ll receive the same end result if you are only interested in the particular shape variation that was present in your scene upon export.

• **Bake Diffuse Color into Diffuse Texture**: Blend diffuse texture with diffuse color. If you enable this option Poser will write a new texture map that is shader baked into a texture map.

• **Bake transparency to diffuse texture alpha**: When checked, Poser will not generate a transparency map. Instead, transparencies will be applied in the alpha channel of the diffuse texture. When unchecked, Poser will include a transparency map with the exported COLLADA file.

• **Transparency texture storage**: Check this option to bake transparency maps to a channel. By default, transparencies are baked to the RGB_ZERO channel. You can alternatively bake to the A_ONE channel by selecting that option from the channel selection menu.

• **Invert Transparency Map**: Choose this option to output a “negative” transparency map. For example, in Poser black areas indicate transparent areas and white areas indicate opaque areas in the transparency map. An inverted transparency map would be the opposite (black is opaque and white is transparent).

• **Compile texture atlas**: When checked, the Texture Atlas Options dialog (described in [Texture Atlas Options](#)) will appear so that you can choose which texture maps are combined and saved with your file. When unchecked, Poser will export all texture maps that are included in the object(s) you are exporting in their original size.

• **Maximum Texture Size**: Textures in Poser content are often very large. Some applications experience difficulties upon importing COLLADA files with large textures. Maximum Texture Size allows you to automatically reduce texture size upon export, thereby maximizing compatibility. Your original textures remain untouched.
FBX Export Settings and Steps

The File > Export > FBX command allows you to export FBX files to third party applications that support this format. Various options allow you include rigging, morphs, animation, and textures.

To export an FBX file, follow these steps:

1. Choose File > Export > FBX. The Export Range dialog appears.

2. Do one of the following:
   - To export only the current frame, choose Single Frame.
   - To export more than one frame, choose Multi Frame Export, and then enter the desired frame range in the number fields.

3. Click OK to continue. The Select Objects dialog prompts you to select the items that you want to export. By default, the main camera and all scene objects are selected. To choose specific items, uncheck the Universe item at the top of the list, or click the Select None button. This will deselect all objects. Then check each individual item that you want to include.
Select Objects dialog.

4. Click **OK** to continue. The **FBX Export Options** dialog appears with the following options:

   *If subdivision is set on any of the objects in your scene, Poser will warn you that subdivision will be turned off for the FBX export. Click Cancel to return to Poser, or **OK** to continue.*
**Load Preset**: The **Load Preset** button, located at the bottom of the FBX Export Options dialog, provides a **Default** preset, as well as preset configurations for export to other popular applications. If you are exporting to one of these specific applications, we recommend that you select the applicable preset first, and then use additional settings as described below.

**Export standard units**: Use the drop down list to choose the standard unit measurement that you want to use when you export the FBX file. Choices are **Poser native units**, **Inches**, **Feet**, **Millimeters**, **Centimeters**, or **Meters**.

**Custom units**: Use this section to set up a custom unit for your FBX export. Assign a name for the unit of measurement in the **Name** field, and then enter the equivalent number of meters in the **Meters** field.

**Scale**: By default, Poser exports the FBX file at 100% scale (based on whatever unit of measurement you select). You can use the Scale field to export the FBX file based on a different percentage value.

**Triangles Only**: Check this option to export an FBX file that consists of triangles. Any polygons have more than three sides will be converted to two or more triangles. Leave the option unchecked to export the geometry in its default state.

**Include Normals**: Check this option to export normal information in the FBX file.

**Include Rigging (preserves posability and animation)**: When this option is checked, Poser will export rigging (such as bones and groups) so that the character can be animated in the target application. Uncheck this option if you do not want to include the skeleton and other rigging information.

**Export every frame as keyframe**: If you are exporting an animated FBX file, check this option to create a keyframe for each frame in your animation.

**Bake all morphs**: Leave this option checked to export a character based on all morphs that are currently set to a value other than zero. Uncheck this option if you want to export morphs that can be animated in your third-party software.

**Bake diffuse color into diffuse texture**: When checked, Poser will tint the exported diffuse texture map based on base diffuse color settings in the **Material** room. The exported geometry will be set so that all base diffuse colors are white. When this option is unchecked, the diffuse texture will be exported in its original colors, and the materials in the geometry will use the base diffuse colors as set in Poser’s **Material** room.

**Bake transparency to diffuse texture alpha**: When checked, Poser will not generate a transparency map. Instead, transparencies will be applied in the alpha channel of the diffuse texture. When unchecked, Poser will include a transparency map with the exported FBX file.

**Transparency texture storage**: Check this option to bake transparency maps to a channel. By default, transparencies are baked to the **RGB_ZERO** channel. You can alternatively bake to the **A_ONE** channel by selecting that option from the channel selection menu.

**Invert transparency map**: Transparency maps in Poser use black areas as fully transparent, and white areas as fully opaque. Check this option if your external application uses the reverse (white areas as transparent and black areas as opaque).
Texture Atlas Options

When the Compile Texture Atlas option is checked during FBX export (as described in FBX Export Settings and Steps), Poser will combine individual texture maps into as few images as possible, based on the settings that you specify in the Texture Atlas Options dialog. Multiple images may be generated, such as when multiple textures are bound to the same UV space (for example, when diffuse, transparency, and bump maps are used in the same UV space). The following image shows thumbnails for a texture atlas that is created for La Femme. Notice that two images are created, with the bump maps for the skin textures being placed on a second texture.

Texture Atlas images created for La Femme.

The Texture Atlas Options dialog will appear before the file is exported. This dialog displays the following options:

- **Compile texture atlas**: When checked, the Texture Atlas Options dialog (described in Texture Atlas Options) will appear so that you can choose which texture maps are combined and saved with your FBX file. When unchecked, Poser will export all texture maps that are included in the object(s) you are exporting in their original size.

- **Maximum texture size**: Enter a value for the maximum height or width for the texture(s) that are generated for the FBX file. To restrict the texture to a power of 2 (such as 1024, 2048, or 4096 pixels), check the Power of 2 option.

- **Embed Media**: When checked, Poser will embed texture information into the FBX file so that external textures are not necessary. This option is recommended if files will be distributed to others. When unchecked, textures will be exported.

- **Include Geometry**: Check this option to include geometry with your exported FBX file. Uncheck the option to create an animation-only FBX file.

- **FBX File Type**: By default, the FBX export will be written in **Binary** format. **ASCII** format is available as an option.


5. After selecting all of your export options, choose **OK**. The **Export as FBX** window prompts you to choose a folder and assign a filename.

6. Click **Save** to save the FBX file.
Texture Atlas Options dialog.

- **List of textures**: Displays a list of the texture maps that are associated with the selected item(s).

- **Select All**: Click this button to select all textures in the texture list. You can then click individual items to deselect them.

- **Select None**: Click this button to deselect all textures in the texture list. You can then click individual items to select them.

  *If two textures occupy the same UV space (such as a diffuse texture, bump texture, or transparency map) they will be selected/deselected together when one of the associated textures are selected or deselected. For example, if you click to select a face texture, the associated bump and transparency maps will also become selected.*

- **Atlas Max Size**: Displays the maximum allowable height or width that will be allowed for the texture atlas.

- **Force Square**: Check the Force Square button to generate a texture that is equal in height and width.

- **Border Pixel Size**: By default, the generated textures will extend beyond seam lines by 10 pixels to prevent obvious seam lines. You can increase or decrease this setting with the Border pixel size field.

  *Higher settings prevent obvious seam lines. If you find later that there are visible seams in your external application, you can increase the Border Pixel Size setting and export the FBX file again.*
Exporting Characters with Morphs

In this example, you’ll load Dregon from the Poser character library. You will be provided with an option to select all or some of the morphs that are already included in Dregon. This example will also demonstrate how to select options for exporting to the Unity game engine.

1. Choose File > New to create a new Poser scene.
2. Delete the default character (Andy) from the scene.
3. Load Dregon from the Figures > included > Animals > Dregon library folder.

Load Dregon from the Characters library folder.

5. Click OK to accept the default option of Single Frame. The Select Objects dialog appears.
Accept the defaults in the Select Objects dialog.

6. Click OK to accept the objects that are selected by default. The Export Options dialog appears.

7. Click the Load preset button at the bottom of the dialog to select the Unity5 preset. The following options will be set with this preset (see FBX Export Settings and Steps for descriptions):

- **Export standard units**: Centimeters
- **Include Normals**
- **Include Rigging** (preserves posability and animation)
- **Export every frame as keyframe**
- **Bake All Morphs**
- **Bake transparency to diffuse texture alpha** (uses A_ONE transparency texture storage)
- **FBX File Type**: Binary
- **FBX Format Version**: FBX 2019

For more information about the options in the FBX Export Options dialog, see FBX Export Settings and Steps.
8. Uncheck the **Bake All Morphs** option (circled in the previous figure). By doing so, any morphs that you select will be included in the character so that you will be able to animate them in your target application.

9. Optionally, check the **Compile texture atlas** option if you want to create a texture atlas.

10. Click **OK**. The **Select Morphs** dialog appears. This dialog lists all morphs in the character, based on their body parts. Check each morph that you want to include in the character.

- **Select Morphs dialog.**

  - To include all morphs, click the **Select All** button at the bottom of the dialog.

  - To include specific morphs, click **Select None** to make sure all morphs are deselected. Then check each individual morph that you want to include.

11. After you select your morphs, click **OK** to continue. If you checked the option to create a texture atlas, the **Texture Atlas Options** dialog (described in [Texture Atlas Options](#)) appears after a short time. All textures are selected by default. For our example we will leave the default selection as is.
12. Verify that 4096 is entered for the desired resolution for the texture(s) in the Atlas Max Size field.

13. Click OK to continue. The Export as FBX window prompts you to locate a folder and assign a filename.

14. Click Save to save the FBX file.

**Exporting Animated FBX Files**

Poser offers a number of different tools that help you create animated poses. For example:

- You can use Poses in the Pose Library to pose your characters in intermediate poses over time. Poser will interpolate between those key poses to animate the in-between states.

- You can use tools such as the Walk Designer and Talk Designer to generate walk cycles for your figures or animate speech.

- You can use parameter dials or move body parts to transform, rotate, or scale body parts to animate them over time.

- You can use Poser’s Editing tools, or use parameter dials to animate morphs that change expressions or shapes of a character.

  For more information about how to animate in Poser, refer to Animating.

Poser’s COLLADA and FBX export supports the use of Animation Sets in Poser. For example, you can create sets that include animation for specific body parts (such as facial expressions, eye blinks, or other specific or repetitive body movements). Animation Sets will be exported as multi-take FBX or animation_clips in COLLADA, setting them up for interactive use in a game.

  For more information about animation sets, refer to Animating.

  If your project includes animation layers, they will be exported automatically.
After you complete your animations in Poser, you can include this animation when you export your object(s) to FBX format. In the following example you’ll learn how to apply a pose to a figure and export the animated pose as an FBX file.

1. Create a new Poser scene, and delete the La Femme character that loads in by default.
2. Load **BrainStem** from the **Figures > Included > Robots** folder in your main Poser runtime.

3. Make sure you’re on Frame 1, and choose **Figure > Zero Figure** to place **Brainstem** in its default position.

4. From the Poses library, apply the **Pose > included > People > SimonG2 > Animations > The Robot** pose.
Apply the Included > People > SimonG2 > Animations > The Robot pose.

5. When Poser asks if you want to add additional frames to the project, choose Yes.

6. Press the Play button to preview the animation if desired. Next, choose File > Export > FBX. The Export Range dialog appears.

7. Choose Multi frame export, and verify that the entire frame range is selected.

8. Click OK to continue. The Select Objects dialog appears. Verify that BrainStem is selected (it is named Figure by default), and that the UNIVERSE, GROUND, and CenterOfMass objects are deselected.
Make sure that UNIVERSE, GROUND, and Center of Mass objects are unchecked.

9. Choose OK to continue. The Export Options dialog appears.

10. In the Export Options dialog, first click the Select Preset button to choose the Unity5 preset.

Load the Unity5 preset before choosing other options.
11. Since Brainstem only uses one texture for reflection, you don’t need to generate a texture atlas. Uncheck the Compile texture atlas option for this example to copy the original texture with the FBX file.

12. Click OK to display the Export as FBX dialog, which prompts you to locate a folder and assign a filename. Then click Save to save the FBX file.
Using Poser with ZBrush

Using Poser with ZBrush and GoZ

**Poser 13** and an updated ZBrush are required for GoZ compatibility.

Users of ZBrush 4 can use GoZ to export a complete figure mesh, or a selected actor or body part into GoZ. Then use ZBrush’s powerful tools to create your morphs and reimport them back into Poser. The GoZ plugin makes morph creation - including reverse deformation joint controlled morphs -- easy, and painless.

Setting Your Poser Path in ZBrush

When you install Poser, the required GoZ files are installed in your ZBrush installation folder. You’ll find the GoZ interface files in the following ZBrush-related folders:

- Poser (Windows) will place the interface files in `C:\Users\Public\Pixologic\GoZApps\Poser`.
- Poser (Macintosh) will place the interface files in `Users:Shared:Pixologic:GoZApps:Poser`.

Once the files are installed you will need to start ZBrush to make sure that you have the path set to Poser. To do this, choose the **Preferences > GoZ** command, and hover over the Path to Poser button. If your path is set, it will appear on the screen as shown below.

Make sure that your path to Poser is set in ZBrush GoZ Preferences.

If you hover over the Path to Poser button in ZBrush and get a message that reads **Poser application was not found**, then you will need to set it up manually. To do this, click on the **Path to Poser** button. This will initiate a search for your Poser application.
If Poser is installed to the default installation path, ZBrush should find the application after a brief time. A screen will display the path (or paths, if you have multiple versions of Poser installed).

If one or more paths to Poser are reported in the dialog, click to select the path that you want to use as the default. This will set the preference.

After searching for your path, it will appear in a dialog if one or more versions of Poser are found on your system.

- If you instead get a message that states that no version of Poser was found (which may be possible if you installed Poser to a non-standard path), then you will have to locate it manually. Click the Browse button to navigate to the folder that contains the Poser.exe file.

- Clicking the Not Installed button will remove the preference that was previously set, and cause the GoZ link to Poser to not work properly. If ZBrush does report your path to Poser properly, make sure that you click the line that displays the correct path to exit the dialog properly.

Using GoZ to Create Morphs and Texture Maps

The GoZ plugin for Poser allows you to create full body morphs, partial body morphs, and joint-controlled morphs with ease. In addition, you can also add additional detail to a model with normal or displacement maps. The following sections describe how to initiate the steps to send your models to and from ZBrush with the GoZ plugin.

When using the Figure > Export Figure to GoZ or Object > Export Object to GoZ commands, it is important to remember that they apply to a single round-trip session between the scene you exported the object from, and the ZBrush document that you sent it to. You cannot send a figure or object to ZBrush from one Poser project, and then send it back to another Poser project.

Exporting Objects to ZBrush

When you use the GoZ plugin as a bridge between Poser and ZBrush, you are presented with a couple of choices in how you want the polygon grouping to work. These options are to assist in making it easier to show and hide polygons in ZBrush while you are editing your object. ZBrush
allows you to show or hide polygon groups by pressing **CTRL+SHIFT+Click** (Windows) or **COMMAND+SHIFT+Click** (Mac). When you click on an area of the mesh in ZBrush, this key sequence will cycle between “Select only this polygon group”, “Select everything but this polygon group” and “Show all polygon groups.”

When you choose to export a character or actor to ZBrush, you are presented with the following options:

- **Export Posed**: This option appears when the figure is set to base resolution, and is unchecked by default. When unchecked, Poser will zero a figure pose and shape before it exports the figure to Poser. When checked, the figure will be export to ZBrush in its posed and morphed state, which is desirable for creating joint-controlled morphs. For additional information, see Creating Joint-Controlled Morphs with GoZ.

- **Bake Results**: This option appears when the figure’s Preview subdivision is set higher than zero and is unchecked by default. When unchecked, Poser will zero the figure pose and shape before it exports the figure to Poser in the subdivided resolution. When checked, the figure will be export to ZBrush in its posed and morphed state.

- **Material**: When you choose this option, the polygon order of the object that is exported to ZBrush will be grouped by Material. This will allow you to show or hide polygons in ZBrush based on their material assignments. For example, if you export a head, you will be able to hide the face texture while you work on morphs or textures for the parts inside the head (teeth, tongue, etc).

- **Body Part**: When you choose this option, the polygon order of the object that is exported to ZBrush will be grouped by body part. This will allow you to show or hide polygons in ZBrush based on body part. For example, you can hide all parts except the head if you are working on face morphs, allowing you to frame only the head in the ZBrush window.

### Creating Full Body Morphs with GoZ

The **Figure > Export Figure Mesh to GoZ** command allows you to export a complete figure from Poser into ZBrush. When you export a complete figure through GoZ and then return it back to Poser using the GoZ plugin for ZBrush, a full body morph dial will automatically be created for you when the morph is sent back to Poser. In addition, corresponding dials will only appear on the body parts that were directly affected by the morph (in other words, there will be no need to delete redundant morph dials from unaffected body parts).

To create a full body morph using GoZ:

1. Load the figure that you want to morph into your Poser scene, and select it as the current figure.

2. Choose **Figure > Export Figure Mesh to GoZ**. A dialog displays some options for the export. The options are different depending on whether you are exporting a Poser Traditional mesh or a Poser Unimesh.
• When exporting a figure that is assigned the skinning method of Poser Traditional (Figure > Skinning Method > Poser Traditional), check the Export Posed option if you want to export the figure as it currently appears in Poser. This includes any translations or morphs that are applied to the figure. When you export a posed figure into ZBrush, Poser will save a differential morph (that is, the morph that returns from ZBrush will not include the morphs and translations that were already applied to the figure; it will only include the changes that you made inside ZBrush). Therefore, checking the Export Posed option is beneficial if you want to create a joint controlled morph.

• When you check the Export Posed option, Poser automatically creates a pre-transform morph when you return to Poser via GoZ.

• The option to create a pre-transform morph will be disabled when you return to assign a name for the morph in Poser.

• When you export a posed figure into ZBrush, Poser will save a differential morph (that is, the morph that returns from ZBrush will not include the morphs and translations that were already applied to the figure; it will only include the changes that you made inside ZBrush). Therefore, checking the Export Posed option is beneficial if you want to create a joint controlled morph.

• If you uncheck the Export Posed option, you will be allowed to choose whether or not the new morph is a pre-Transform morph or not when you return the morph back to Poser.

• For high resolution morphs, export a subdivided figure that is assigned the skinning method of Poser Unimesh (Figure > Skinning Method > Poser Unimesh). The dialog will present different options if the Preview subdivision level is set to 1 or higher in the Properties palette. Check the Bake Results option if you want to export the figure with translations and morphs applied. The subdivided model will then open in ZBrush and you can create a high resolution morph target that can be imported back into Poser. Only changes made inside ZBrush will be imported back to Poser.
3. In the **Polygon Grouping** section, you have two choices for how you can group polygons when you export them to ZBrush. The method that you choose determines how you will be able to show and hide parts within ZBrush (either by material, or by body part) and are primarily for ease of editing in that application. For more information, see [Exporting Objects to ZBrush](#).

4. Click **Yes** to continue. Your model will open in ZBrush as a subtool. Drag the tool onto the scene and create your morph as you normally do.

5. After your morph is complete, click the **GoZ** button in the Tool palette (in the upper right section of your screen by default) to send the OBJ file back to Poser.

6. When you return to Poser, a dialog asks if you want to import the modified geometry as a full body morph. Choose one of the following options:
GoZ and Pre-Transform Morphs

When creating morphs in ZBrush, the following steps are commonly used to create a full body morph:

- Load the character that your clothing is created for.
- Zero the figure’s pose, and dial in the full body morph that you want to match in the clothing.
- Export the character to ZBrush, using the **Figure > Export Figure Mesh to GoZ** command. To ensure that the morphed figure is passed to ZBrush, make sure that the **Export Posed** option is checked.
Check Export Posed to export a morphed character to ZBrush.

- After the figure is loaded into ZBrush, return to Poser and select the clothing that you want to morph. When exporting the clothing, you want to export it in its default state, so you want to export it with the Export Posed option unchecked.

Uncheck Export Posed to export clothing in its default state.

- In ZBrush, use the Append feature to merge the character and the clothing in ZBrush, as described in Morphing Multiple Items.

- After you finish your clothing morph, press the GoZ button to return the morphed clothing back to Poser. Poser prompts you to assign a name for the morph.

- When you create morphs in this manner in ZBrush, you will notice that the Apply new morphs pre-Transform option is disabled. This is because morphs created in ZBrush are automatically applied pre-Transform. This causes Poser to morph the clothing to the body shape before it calculates the changes to the clothing that will be necessary to rotate the joints when it is posed.

Morphing Multiple Items

There are times when you need to have a piece of clothing over a character to make sure that the morphs you create will properly fit a character. You can use the GoZ plugin to export one item at a time.

For example, select the figure in the first GoZ session and export it into GoZ using the Figure > Export Figure Mesh to GoZ command, and Body Part polygon grouping. Drag the figure into your ZBrush document.

Then go back to Poser and export a clothing item (like pants), using the same steps (Export Figure Mesh to GoZ, with Body Part polygon grouping.) Initially it will appear in the document window by itself.
Go back to Poser and use the **Figure > Export Figure Mesh to GoZ** to export a third item if desired, using the same steps as you did with the previous clothing item.

Now you have three Poser OBJ files in ZBrush - the character, and two pieces of clothing. Each appears as a separate tool. The last item that you loaded appears in the scene.

Expand the Subtool palette in ZBrush, and press the **Append** button. Click to select the figure mesh in the selection area. It will load into the same document as a subtool. Repeat this process for the second (or additional) clothing items.

*Click the Append button in the Subtool palette to append an object into your current window.*

When you need to morph the clothing item, select the piece of clothing from the Subtool palette.
Select the clothing item that you want to morph from the Subtool palette.

To return the morphed items back to Poser, select the item you want to return from the Subtool palette, and press the GoZ button. The item will update in Poser and you will be prompted to enter a name for the new morph.

Return back to ZBrush and select the next item from the Subtool palette. Again, press the GoZ button to import that item back into Poser and assign the morph name.

Creating Individual Actor Morphs with GoZ

Sometimes you only need to morph an individual body part. For example, if you want to create a morph that changes the shape of a character’s nose, you only need to export the head. The steps to do this are similar to those discussed previously in Creating Full Body Morphs with GoZ, except that you initiate the GoZ command from the Object menu instead of the Figure menu.

To create a morph for a single body part, follow these steps:
1. Load the figure that you want to morph into your Poser scene, and select it as the current figure.

2. Click to select the body part that you want to export (for example, the Head).

3. Choose **Object > Export Object to GoZ**. A dialog displays some options for the export.

   ![GoZ options dialog.](image)

4. In the **Polygon Grouping** section, you have two choices for how you can group polygons when you export them to ZBrush. The method that you choose determines how you will be able to show and hide parts within ZBrush (either by material, or by body part) and are primarily for ease of editing in that application. For more information, see [Exporting Objects to ZBrush](#).

5. Click **Yes** to continue. Your body part will open in ZBrush as a tool. Drag the tool onto the scene and create your morph as you normally do.

6. After your morph is complete, click the **GoZ** button in the Tool palette (in the upper right section of your screen by default) to send the OBJ file back to Poser.

7. When you return to Poser, a dialog asks if you want to import the modified body part. Check or uncheck the option to **Apply new morphs before joint rotation**. For an explanation of this feature, see [Applying Pre-Transform Morphs](#).

8. Enter a name for the new morph and press **OK** to continue.

   ![Enter a name for the new body part morph in Poser.](image)

9. Initially, the dial will be set to zero. To test the morph, choose the actor that you morphed, and dial the morph to test it.

   *When you use the **Object > Export Object Mesh to GoZ** command to create morphs, a corresponding Full Body Morph dial will not be created in the BODY actor.*
Creating Joint-Controlled Morphs with GoZ

Joint controlled morphs, in the past, have been difficult to create for Poser, because all morphs had to be loaded when a figure was in its default T-Pose. Eventually, third party Python scripts allowed you to load a “reverse deformation” morph that would track the difference between a posed object, and a “corrected” version of that posed object.

Basically, “reverse deformation” allows you to export a figure in a posed position. Then you can morph out any distortion in the body or piece of clothing, and when you reload that morph back into Poser it only keeps track of the differences between the posed version and the corrected version. This allows you to create morphs that improve the appearance of a joint when it is rotated, and is useful for use in legacy figures that do not utilize weight mapping for improved joint bending.

To create a Joint Controlled Morph (JCM) use the following steps:

1. Load the figure that you want to morph into your Poser scene, and select it as the current figure.
2. Pose the figure in the pose that you want to correct. For example, if you want to fix an underarm bulge that appears when an arm is raised, then pose the arm in the raised position.
3. Do one of the following:
   - If your joint controlled morph will span more than one body part, choose Figure > Export Figure Mesh to GoZ.
   - If your joint controlled morph will affect only one body part, choose Object > Export Object Mesh to GoZ. A dialog displays some options for the export.

   ![GoZ options dialog]

4. To export the model in its posed state, do one of the following:
   - Check the Export Posed option if exporting a Poser Traditional mesh or a Poser Unimesh that is not subdivided.
   - Check the Bake Results option if exporting a Poser Unimesh that has the Preview subdivision level set to 1 or higher.

5. In the Polygon Grouping section, you have two choices for how you can group polygons when you export them to ZBrush. The method that you choose determines how you will be able to show and hide parts within ZBrush (either by material, or by body part) and are
Creating Normal and Displacement Maps with GoZ

If you want to use ZBrush to create Normal or Displacement maps, the process is similar to that discussed in the previous sections. Normal and displacement map creation involves subdividing the mesh in ZBrush before painting, and then comparing that higher resolution mesh to the original resolution when your maps are generated. Please reference your ZBrush documentation for more detail in how to create normal and displacement maps.
As long as you are working on a content item that has everything on a single texture, the import and export between Poser and GoZ should work the same as discussed under the morph creation sections. You select the item you want to export, use GoZ to transfer the OBJ to ZBrush, make your changes in ZBrush, and then click the GoZ button to bring it back into Poser.

However, it is important to note that most Poser characters use multiple texture maps with overlapping UV sets. A workaround for multi-map characters is to choose Material polygon grouping when you export from Poser.

Once in ZBrush, you can hide the groups that do not belong to a particular UV set. Hold down the CTRL and SHIFT key while you left-click a material group. Then you can generate a map from the remaining groups. ZBrush will pretend that the hidden groups don’t even exist when it creates your map.

After you have the desired material groups displayed, you will need to export the maps from within ZBrush, rather than exporting them back into Poser with the GoZ command.

**Importing Hair from GoZ**

1. Load a character into your Poser scene, and select the figure.
2. Choose **Figure > Export Figure Mesh to GoZ** as discussed in Exporting Objects to ZBrush. Your figure will load into ZBrush as a tool.
3. Drag the figure into the ZBrush document and switch to Edit mode. Use the Move, Scale, and Rotate tools to zoom in to the head. Optionally, select a white material for the head.
4. The Standard brush will be selected by default. Press the CTRL/CMD key while you paint a mask on the head to specify where the hair will be grown.

   *In ZBrush, mask the polygons where you want the hair to grow.*

5. Select the **Fibermesh** panel from the right side of the interface, and turn **Preview** on.
6. Expand the Modifiers tab and adjust the settings as instructed in your ZBrush user manual. After the settings are to your liking, click Preview again as necessary, and then click Accept to create a new subtool from the mesh fibers.

You may be asked if you want to use Fast Preview mode for faster interaction.

7. Switch to the Subtools palette, and select the Fibermesh as the current subtool. Use the ZBrush styling tools to style the hair as instructed in your ZBrush user manual.

Select the Fibermesh subtool to style the hair:

8. After the hair is styled to your liking, make sure that you have the Fibermesh subtool selected, as shown in the previous figure. Then click the GoZ button to export the Fibermesh hair back into Poser.
Poser will ask if you want to import the Fiber geometry as a hair prop. Choose **OK** to continue.

10. The **Select Objects** dialog appears, so that you can select the actor to attach the hair to. Choose the characters **Head** actor and click **OK**. The fibermesh hair appears in your scene.

Choose the character’s Head as the parent to the fibermesh hair.

After the hair appears in your scene, you can select the hair and open the **Material** room to change the hair colors. Note that you will not be able to restyle the hair in the **Hair** room.
Poser Reference Manual

Importing/Exporting a GoZ File

Importing/Exporting a GoZ File

If ZBrush is not available on your current machine, you can use the File > Import > ZBrush and File > Export > ZBrush commands to work with Poser figures/objects on another machine that does have it available. This command will import or export a ZBrush binary object format file. When you use this command to export a ZBrush binary object, Poser will prompt you to select a folder and assign a file name to the object you save. The object will be saved with a .GoZ extension.
Technical Support

We’ve worked hard to ensure that Poser’s powerful features are both easy to use and available to users running a wide variety of computers. However, there may be times when you need technical support. Bondware, Inc. is pleased to offer free technical support to registered users of our products. To receive technical support, please visit our Web site at https://support.posersoftware.com and browse through our extensive product FAQs.

Please use the following checklist before contacting Technical Support:

- **Poser Reference Manual**: This Reference Manual answers most Poser questions. Before contacting Technical Support, please read the pertinent section(s) of this manual thoroughly.

- **FAQ**: Please visit the FAQs at https://support.posersoftware.com/kb/faq.php?cid=1.

- **Third-party forums**: If your question is more artistic than technical, check out some of the great online Poser forums where artists come together.

Still don’t see your question answered? Please contact Technical Support by clicking the link to https://support.posersoftware.com and completing our online support form. When contacting Technical Support, please fill out the form as completely as possible and include as much information as possible. This will help us resolve your issue faster. Once the form is complete, a Technical Support representative will contact you directly as soon as possible. Support requests are answered via e-mail in the order they are received. Online support is free to all registered Poser users.

Telephone support is also free to registered users. Before using telephone support, please check the resources listed above. Phone support is intended to solve critical technical issues. We are unable to answer project-based questions. Our Technical Support phone number is listed on our website at https://support.posersoftware.com. Telephone support hours are 10 am to 4 PM (U.S. Eastern time). If you call during other hours, or if a representative is not able to answer your call immediately, you will be asked to leave a message, and we will return your call as soon as possible (generally within two business days). When calling, please be in front of your computer with Poser running.

In order to receive support, we require the following information:

- Your name
- E-mail address
- Telephone number (including international dialing information, if applicable)
- Your current operating system
- Your computer specifications (CPU, RAM, hard drive, video card, etc.)
• Poser serial number
• Detailed description of the problem

This information will help us isolate and resolve your issue. We require this information in order to provide support services and are unable to respond to incomplete requests in a timely fashion.

For international support, please contact your local distributor. Bondware, Inc. maintains a list of our international distributors at https://www.posersoftware.com.

Bondware, Inc. reserves the right to alter our technical support policies at any time without advance notice.
Poser File Structure

This Appendix describes some basics about the Poser file system.

About Poser Files

Some advanced Poser users obtain added control over their work by editing the source files directly instead of, or in addition to, using the Poser application. This manual provides a detailed description of the Poser file formats, including syntax, layout, and commands/parameters contained within each file type.

Poser uses separate files for each character, prop, light, and camera, as well as other files for particular character details (face, hands, etc.). These files typically reside in Poser’s Runtime folder. The Poser installer automatically creates folders and inserts files into their correct locations. While each type of Poser file has a separate extension and purpose, each of the file types discussed in this manual (with the exception of OBJ and non-native Poser formats) follows the same general format and uses one or more subsets of the overall Poser command/parameter structure.

A Word of Warning

Editing files directly can give you ultimate control over your Poser creations and help provide spectacular results. However, editing files directly could cause problems up to and including crashing the Poser application file, corrupting your edited file, and causing data loss.

Bondware, Inc. provides this information as an aid to advanced Poser users for reference purposes only. Direct editing of Poser files is specifically not recommended and is not supported. Please do not contact Bondware, Inc. tech support regarding file-editing problems. Any work you do within Poser files is done solely at your own risk. You are on your own.

This appendix provides some guidance with regard to valid values and error handling, however it is impossible to cover the nearly infinite ways in which you may edit files and how those edits may affect the Poser application or data.

Editing Files

You can edit all native Poser files using a plain text editor such as Notepad (Windows) or TextEdit (Macintosh). In addition, some users have created helpful applications to aid you in editing Poser data. Please refer to the online 3D community at large for help locating and reviewing these third-party applications.
Poser Reference Manual  Poser File Types

Poser files contain formalized descriptions and instructions written in a code that Poser can read. As with any computer program, each element of a Poser file must be in the correct format, using valid values, and located in the correct portion of the file. Poser files can be large and complex, and it is not advisable to modify them unless you have a good idea how to go about it.

All native Poser files follow a similar structure, however each file type has a separate filename extension and library location (discussed below). The simplest Poser files control props, lights, and cameras, while the most complex (CR2 and PZ3) describe Poser characters and scenes, respectively.

It should rarely be necessary to modify native Poser files outside of Poser, with the notable exception of CR2 files. When editing any Poser files, be sure to back up the original file and work on a copy. This will prevent data loss if something goes wrong. You may also wish to save iterations of files as you work, allowing you to easily revert to a previous state without losing all of your work.

**Poser File Types**

There are several native file types associated with Poser:

- **Prop**: This file type contains information about a prop including source geometry, materials, texture and other maps, etc. Prop files have the extension PP2. Magnet files are prop files with a pre-positioned magnet as the prop. Props are often supplied as PP2 files with embedded OBJ information. They may also include texture and bump map files.

- **Camera**: Camera files contain camera information including location, direction, focal length, etc. They have the extension CM2.

- **Light**: These files contain information on lights, including type, position, color, and other attributes. Light files have the extension LT2.

- **Hair**: Hair files contain information on hair props and are similar to prop files. This file type has the extension HR2. Hair files may have the geometry embedded within them (as opposed to in a separate OBJ file).

- **Face**: Face files contain information required to articulate and/or deform a face to the desired expression and have the extension FC2.

- **Hands**: Like face files, hand files contain information required to articulate hands into the desired positions or gestures. Hand files have the extension HD2.

- **Pose**: Pose files contain information required to articulate an entire figure into the desired position, which can include face and hand information. Pose files have the extension PZ2.

- **Character**: A character file contains all information required for a Poser character including reference geometry, Joint Editor palette morph targets, materials, default pose, etc. These files have the extension CR2.

- **Scene**: This file type is what is created when you create a Poser scene and select **File > Save** within the Poser animation. This file type contains all of the information found in the above-mention files plus details on movie, background, rendering, animation set, lights,
For purely conceptual purposes, it is useful to think of various Poser file formats as falling into a loose hierarchy, with some files containing subsets of information stored within other file types. Also, while each Poser file type contains information unique to that format, several file types are virtually identical in structure. For example, hand and face information is part of a pose, which along with hair forms part of a character, which combined with other information is part of a scene.

**File Families**

It is also useful to think of Poser files in terms of the types of information they contain. For conceptual purposes only, you can think of Poser files as being grouped into the following families:

- Face, Hands, Pose
- Hair, Prop
- Camera, Light
- Character
- Pose

**Poser Default File Locations**

In the list below, note that the following list provides the default locations of the Poser file types. If you are downloading any Poser files, be sure to place them in their correct locations. File placement is most critical for files that belong in the Runtime: Geometries folder. Library files have more flexibility. In the following list, an expression in parentheses means that the sub-directory or name depends upon the figure. You may create your own sub-folders and relocate files within the Libraries sub-folder. In this case, file locations will be reflected in Poser’s Library palette. You may place graphic (texture, bump, etc.) files wherever you like, since Poser allows
you to specify their locations. The following list gives all file locations relative to the Poser:

**Runtime folder:**

<table>
<thead>
<tr>
<th>Extension (uncompressed)</th>
<th>Extension (compressed)</th>
<th>Type</th>
<th>Typical Runtime location</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUM**</td>
<td>n/a</td>
<td>Legacy bump map</td>
<td></td>
</tr>
<tr>
<td>CM2</td>
<td>CMZ</td>
<td>Camera</td>
<td>libraries\camera\Camera Sets</td>
</tr>
<tr>
<td>CR2</td>
<td>CRZ</td>
<td>Character</td>
<td>libraries\character(category)(character name)</td>
</tr>
<tr>
<td>FC2</td>
<td>FCZ</td>
<td>Face</td>
<td>libraries\faces(category)</td>
</tr>
<tr>
<td>HD2</td>
<td>HDZ</td>
<td>Hand</td>
<td>libraries\hand(category)</td>
</tr>
<tr>
<td>HR2</td>
<td>HRZ</td>
<td>Hair</td>
<td>libraries\hair(category)</td>
</tr>
<tr>
<td>LT2</td>
<td></td>
<td>Light</td>
<td>libraries\light\Light Sets</td>
</tr>
<tr>
<td>MC6</td>
<td>MCZ</td>
<td>Material Collections</td>
<td>libraries\material(category)</td>
</tr>
<tr>
<td>MT5</td>
<td>MZ5</td>
<td>Single material shader</td>
<td>libraries\material(category)</td>
</tr>
<tr>
<td>OBJ</td>
<td>OBZ</td>
<td>Figure Geometry</td>
<td>Geometries(figure name)</td>
</tr>
<tr>
<td>PMD</td>
<td></td>
<td>Binary Morph Targets</td>
<td>PMD files are binary morph target files that are a redistributable means to deliver morph targets. If you have Use External Binary Morph Targets enabled in the Misc tab of the General Preferences dialog, PMD files are created next to a CR2 (when a figure is added to the Library), next to a PP2 (when a prop is added), or next to a PZ3 (when a scene file with morph targets was created in an earlier version of Poser, or when the morph set of figures and/or props has been changed since they were added to the scene).</td>
</tr>
<tr>
<td>PP2</td>
<td>PPZ</td>
<td>Prop</td>
<td>libraries\props(category)</td>
</tr>
<tr>
<td>PZ2</td>
<td>P2Z</td>
<td>Pose</td>
<td>libraries\pose(category)</td>
</tr>
<tr>
<td>PZ3</td>
<td>PZZ</td>
<td>Poser scene</td>
<td>any (user-selected location)</td>
</tr>
<tr>
<td>PZS</td>
<td></td>
<td>Web links</td>
<td>Web links(category)</td>
</tr>
<tr>
<td>RSR*</td>
<td>n/a</td>
<td>Small file, Windows-only thumbnail graphic</td>
<td>libraries\character\ (category)(character name)</td>
</tr>
<tr>
<td>RSR*</td>
<td>n/a</td>
<td>large file, both Mac and Windows – Binary OBJ)</td>
<td>Same location as associated geometry file</td>
</tr>
</tbody>
</table>
Commonly Used Poser Objects

| TIF, BMP, JPG, PNG | n/a | textures, bump maps, etc. | textures\ (category)\ (subcategory). You may store additional images in any folder you wish. |

*RSR format thumbnails are deprecated, and have been replaced with PNG format thumbnails.

**BUM format bump maps are deprecated. Common image formats such as JPG or PNG are used instead.

Users who download characters or other Poser files may need to manually place some or all of the files in their correct locations. Please use the above list to ensure correct file placement.

Poser stores files containing preference information in the user’s home directory. This preference information includes Memory dots, Library preferences, Poser UI preferences, and the Poser.ini/Poser Prefs file. These preference files are stored in the following locations:

Windows 7 and later example: C: \Users\<PoserUser>\AppData\Roaming\Poser\12\n
Mac OS X 10.9 or later example: /Users/<PoserUser>/Library/Application Support/Poser/12/

**Poser Downloaded File Locations**

By default, Poser places downloaded content in the Download library. Please refer to The Poser Library for more information about Poser libraries.

**Other Poser File Types**

Some users may encounter PHI and PCF files. Previous versions of Poser used PHI to perform functions that are now carried out in the hierarchy editor/Setup room (Pro Pack & later). PHI files were directly contained within OBJ files, and were located with the OBJ file. PCF files are used by an application called Objaction Mover and are beyond the scope of this document.

**Commonly Used Poser Objects**

Morph targets and characters are commonly used and traded/sold by and among users and third-party vendors. This section provides a brief explanation of each.
Morph Targets

Morph targets are supplied as OBJ files that you import into Poser for application to part of a figure. The figure’s CR2 file controls morph targets, and a dial appears for each morph target when an applicable body part is selected. For example, a head morph target dial will appear when you select the figure’s head. This Reference Manual defines and discusses OBJ morph targets in Creating Morphs in Other Applications.

Characters & Clothing

Characters can be modifications of meshes that come with Poser or can include entirely new OBJ meshes (models). Characters based on pre-existing meshes typically come as CR2, texture, and bump files. Also, each piece of conforming clothing uses CR2 files to make it poseable, making clothing downloads similar to characters; thus, the download is similar to that of a character.

Basic File Syntax

As you will see by examining this document, each Poser file type uses the same general syntax.

Tabs

Tabs within Poser files are mostly insignificant, however they serve to show file structure, such as:

```
section 1
  child 1
    grandchild
    grandchild n
  child n
section n
```

Brackets & File Sections

Each Poser file opens and closes with brackets ({}), as does each section within a Poser file. Major file sections describe the file version, location and name of the underlying OBJ file (if any), and file properties. One of the major file sections (Channels) contains position, size, texture, morph target, and other properties. Poser automatically modifies values and adds entries as needed.

As described above, brackets denote the beginning and end of file sections. A left bracket begins each section, while a right bracket ends a section:

```
{begins
```
For example,

{  
  section A
}

**Nested Brackets**

As implied above, one can nest file sections using brackets to denote each section and subsection, as follows:

{  
  section A
    {  
      section B
    }
}

**Parameters**

Parameters and other items within a section do not need brackets. For example:

{  
  section A
    parameter 1
    parameter n
    {  
      section B
      command 1
      parameter 1
      parameter n
      command 2
      parameter 1
      parameter n
    }
}

**Comments**

You can insert comments into Poser files, as follows:

{  
  number 4.01
  This text is a comment added to the CR2 file.
}
**Dependent Parameters**

With Poser you can set up meta-level parameters, called dependent parameters, which allow you to modify other parameters and morph targets with a single parameter dial. An example of this type of dependent parameter would be a full range of belly types, with the following values along the dependent parameter dial:

The Dependent Parameters editor can help you do this and more. Refer to for additional information about this feature.

- -1.0 underweight belly
- -0.5 sixpack belly
- 0.0 regular belly mesh
- 0.5 slightly protruding belly
- 1.0 large protruding belly
- 2.0 hanging beer belly

This range of belly types would incorporate various morph targets and parameter values at each of the key points along the dependent parameter dial. Thus, dependent parameters are far more powerful in the scope of modifications they can encompass than a single morph target or parameter dial.

The following sample code illustrates how to set up a dependent parameter. This code is an example of a targetGeom channel in a CR2 file. The resulting dependent parameter will appear as a morph target parameter dial named “bump3”.

```plaintext
targetGeom bump3
{
  name bump3
  initValue 0
  hidden 0
  forceLimits 1
  min -100000
  max 100000
  trackingScale 0.02
  keys
  { static 0
    k 0 0
  }
  interpStyleLocked 0
  numbDeltas 261
  useBinaryMorph 1
  blendType 0
  valueOpKey
```
The end of this sample defines some interesting interactions with regards to the “bump3” dependent parameter. The “valueOpKey” keyword identifies a section that defines that this parameter can be driven by the Custom_Morph dial on the bone_1 actor of the specified figure. The “ValueKeys” section defines how exactly the “bump3” dependent parameter will be affected:

- If Custom_Morph equals 0.5, the value of bump3 will increase by 0.
- Once Custom_Morph reaches 0.75, the value of bump3 will increase by 1.
- By the time Custom_Morph equals 1, the value of bump3 will increase by 0 again.
- Values in between these points are determined by spline interpolation.

In the next example, we are looking at the rotateX parameter of an actor (in this case bone_2:1, which is not apparent from the code sample below). The resulting dependent parameter dial is called “xRotate”.

```plaintext
rotateX xRotate
{
    name xrot
    initValue 0
    hidden 0
    forceLimits 0
    min -100000
    max 100000
    trackingScale 1
    keys
    { static 0
      k 0 0
    }
    interpStyleLocked 0
    valueOpKey
    Figure 1
    bone_1:1
    Custom_Morph
    beginValueKeys
    valueKey 0.25 0
    valueKey 0.75 45
    valueKey 1 0
    valueKey 1.25 -45
    valueKey 1.5 0
    endValueKeys
}```
As in the previous example, the "valueOpKey" section defines that the Custom_Morph parameter
dial on bone_1:1 of the specified figure can take control of this parameter. The "valueKey"
value pairs add rotation in degrees of xRotate to certain values of the Custom_Morph parameter.

**Poser & OBJ Files**

The Geometries folder contains several dozen sub-folders with names corresponding to Poser figures. Each of these sub-folders contains OBJ files, each of which is a mesh object, e.g. a set of polygons arranged so as to form the desired shape. These polygons are placed into different groups that define important subdivisions within the mesh (such as body parts, also known as actors). In order to work with Poser, these groups must have specific names, such as hip, abdomen, etc. Poser groups do not require such specific naming conventions; figures created using the Setup room could have groups named, for example, Bone_1.

The OBJ file itself does not contain enough information to allow Poser to produce all of the mesh object’s properties, hence the presence of CR2 and other files that provide supplemental information. Poser files can contain embedded information that would normally reside within the OBJ file. This is why many prop downloads do not include an OBJ file.

Some native Poser files normally refer to an underlying OBJ geometry file, which is also in text format. Native Poser files describe parameters controllable within Poser, such as size, position, textures, etc. One OBJ file can have more than one Poser file pointing to it. This happens, for example, if a modified prop, character, etc. is saved to the Library under a different name and/or location.

Character (CR2) files contain Poser-specific details such as size, position, pose, textures, proportions, etc. and also control the dials that change the figure. Normally, one CR2 file governs a single figure. By combining the OBJ mesh information with the CR2 details, Poser can create customized poseable figures.

Some Poser files (pose, face, hands, etc.) work by modifying the CR2 itself. Poses, faces, and hands are already described within the CR2, however applying the data contained in one of these files changes the corresponding values within the CR2 file itself. These applied CR2 changes are then saved to the Poser scene (PZ3) file. If the user saves the modified character in the Library, the modified information gets written to a new CR2 file.

PZ3 files are similar enough to CR2 files to allow changing a PZ3 extension for a given scene file to CR2, thereby creating a new character complete with its associated props, hair, etc.
Converting Hierarchy Files

Selecting File > Convert Hier File opens a standard Open dialog box prompting to you locate and open a Poser 3 Hierarchy file (*.phi). If this file contains no errors, this function creates a Poser Figure (*.CR2) file. Please refer to About Poser Files for more information about Poser files and their functions.

Hierarchy files are used when creating custom figures using the text-based method. Since the introduction of the graphical Setup room, this older method, while still supported, is far longer and more tedious as it forces you to do everything manually while in a text-based environment. Once the Hierarchy file is completed in the text editor, you can import it into Poser by converting it into a geometry resource (called a CR2 file). This geometry resource is then used by Poser, in conjunction with OBJ 3D data to create a new figure file with rotation order, and Inverse Kinematic relationships as defined by the hierarchy text file.

If you make changes to the hierarchy file and then convert it again, the conversion won’t re-create the geometry resource if it already exists in the OBJ file. So, if you are trying to make geometry changes, you need to either delete the resource, or start with a new blank text file that contains only the text portion of the OBJ file.

To convert a Hierarchy file:

1. Choose File menu > Convert Hier File. The Open dialog appears.
2. Locate the Hierarchy file you created in the text editor and click Open.
3. If there are no errors, you will be prompted to save an OBJ file to your desired location.
4. Poser will ask for a name for your new figure. Enter a name and choose OK.
5. The hierarchy conversion may take several minutes if there is a large geometry file.
6. The figure file that gets created references the geometry file whenever used. Its location should be established and not moved later or the figure file cannot find the geometry.
7. If the location is changed you need to edit the figure file with a text editor to designate the new location (specified relative to the Poser application in Mac format).

Creating and Converting Hierarchy Files

The Hierarchy file describes how the groups in a figure are arranged. It outlines the parent-child relationships between groups. Once created it can be imported into Poser where it is converted to create a new figure CR2 file as shown in Converting Hierarchy Files, below.
Hierarchy File Structure

The hierarchy file specifies four important things:

- The geometry (.OBJ) file to use.
- The hierarchical connections (parent-child relationships) of the body parts.
- The desired rotation order of each body part.
- A specification of each Inverse Kinematics chain to be included in the figure.

Hierarchy files can be created in any text editor that can save documents in a text-only format.

The following is an example hierarchy file: It represents the full hierarchy for a horse -- including curve channels for the tails.

```
objFile:Runtime:Geometries:horseHi:horseHiP3.obj
1 hip zxy
  2 abdomen zyx
    3 chest zyx
      4 lShldr yzx
       5 lUpArm yzx
        6 lForeArm yzx
         7 lWrist yzx
          8 lHand yxz
    4 rShldr yzx
       5 rUpArm yzx
        6 rForeArm yzx
         7 rWrist yzx
          8 rHand yxz
  4 lowNeck zyx
    5 upNeck zyx
      6 head yxz
  2 lThigh yzx
    3 lLeg yzx
      4 lShin yzx
        5 lAnkle yzx
          6 lFoot yxz
  2 rThigh yzx
    3 rLeg yzx
      4 rShin yzx
        5 rAnkle yzx
          6 rFoot yxz
 2 tail1 zyx curve
    3 tail2 zyx curve
      4 tail3 zyx curve
        5 tail4 zyx curve
ikChain LeftLeg lThigh lLeg lShin lAnkle
ikChain RightLeg rThigh rLeg rShin rAnkle
ikChain LeftHand lShldr lUpArm lForeArm lWrist lHand
ikChain RightHand rShldr rUpArm rForeArm rWrist rHand
```
Here is another example of a typical human character hierarchy file:

```
objFile :Runtime:Geometries:Emily:Emily.obj
1 hip xyz
   2 waist yzx
      3 abdomen yzx
        4 chest yzx
      5 rCollar xzy
         6 rShldr xzy
            7 rForeArm xzy
               8 rHand xyx
                  9 rThumb1 xyz
                     10 rThumb2 xyz
                        11 rThumb3 xyz
                   9 rIndex0 xyz
                      10 rIndex1 xyz
                         11 rIndex2 xyz
                            12 rIndex3 xyz
              9 rMid0 xyz
                 10 rMid1 xyz
                    11 rMid2 xyz
                       12 rMid3 xyz
             9 rRing0 xyz
                10 rRing1 xyz
                   11 rRing2 xyz
                      12 rRing3 xyz
               9 rPinky0 xyz
                  10 rPinky1 xyz
                     11 rPinky2 xyz
                        12 rPinky3 xyz
5 lCollar xzy
   6 lShldr xzy
      7 lForeArm xzy
         8 lHand xyx
            9 lThumb1 xyz
               10 lThumb2 xyz
                  11 lThumb3 xyz
             9 lIndex0 xyz
                10 lIndex1 xyz
                   11 lIndex2 xyz
                      12 lIndex3 xyz
             9 lMid0 xyz
                10 lMid1 xyz
                   11 lMid2 xyz
                      12 lMid3 xyz
             9 lRing0 xyz
                10 lRing1 xyz
                   11 lRing2 xyz
                      12 lRing3 xyz
             9 lPinky0 xyz
                10 lPinky1 xyz
```
11 lPinky2 xyz
12 lPinky3 xyz

5 neck yzx
6 head yzx
7 tongue1 xyz
8 tongue2 xyz
9 tongue3 xyz
10 tongue4 xyz
11 tongue5 xyz
12 tongue6 xyz
7 rEye xyz
7 lEye xyz
7 bttmTeeth xyz
7 topTeeth xyz

1 lButtock yzx
2 lThigh yzx
3 lShin yzx
4 lFoot yzx
5 lToe zyx
6 lBigToe1 xyz
7 lBigToe2 xyz
6 lIndexToe1 xyz
7 lIndexToe2 xyz
6 lMidToe1 xyz
7 lMidToe2 xyz
6 lPinkyToe1 xyz
7 lPinkyToe2 xyz
6 lRingToe1 xyz
7 lRingToe2 xyz

1 rButtock yzx
2 rThigh yzx
3 rShin yzx
4 rFoot yzx
5 rToe zyx
6 rIndexToe1 xyz
7 rIndexToe2 xyz
6 rRingToe1 xyz
7 rRingToe2 xyz
6 rPinkyToe1 xyz
7 rPinkyToe2 xyz
6 rMidToe1 xyz
7 rMidToe2 xyz
6 rBigToe1 xyz
7 rBigToe2 xyz

ikChain RightHand rShldr rForeArm rHand
ikChain LeftHand lShldr lForeArm lHand
ikChain LeftLeg lThigh lShin lFoot
ikChain RightLeg rThigh rShin rFoot
Converting a Hierarchy File

To convert a hierarchy file to a CR2 figure, follow these steps:

1. The first line of the PHI file specifies the location of the OBJ file, and you will need to place the OBJ file in that location before continuing.

2. Choose File > Convert Hier File.

3. Use Explorer or Finder to locate the PHI file that you want to convert, and press Enter or click Open.

4. Poser will prompt you to locate the OBJ file that corresponds with the hierarchy file. The OBJ file must contain groups that match those listed in the PHI file. After you locate the OBJ file, click Open to continue.

5. Poser will prompt you to enter a name for the new figure. Enter the name and choose OK.

6. By default, a folder named New Figures will be added to your Poser 13 Content characters library, and the new figure will be placed there.

If you want to relocate the OBJ and CR2 to a specific runtime, you will need to relocate both the OBJ file and the CR2 file into that runtime folder. Create a subfolder in the Geometries runtime folder to store your OBJ file, and create a subfolder in the Figures library to store your CR2 file. Then edit the path in the CR2 to point to the new location of the OBJ file. The OBJ file location is listed twice in the CR2 file.

Hierarchy File Explained

The following section explains the various parts of the Hierarchy file.

Hierarchy File Header

The first line of the hierarchy file contains the “OBJ File” command which specifies the location of the OBJ file associated with the new figure.

```
objFile:Runtime:Geometries:horseHi:horseTex.obj
```

The file location should be defined using a Macintosh format file specification (i.e. using colons). The file location is specified relative to the Poser application folder.

When the hierarchy file is converted, the text of the OBJ file is read into Poser where a geometry resource is created and linked to the OBJ file. This process results in a new figure file.
From then on, when Poser uses this figure file, the geometry resource is used to defined the figure hierarchy relationships rather than the text stored in the OBJ file. Reading from the geometry resource is dramatically faster.

**Hierarchy File Body**

The bulk of the hierarchy file contains lines similar to the one shown below:

```
2 abdomen zyx
```

*A typical Hierarchy file line.*

The first part of the line indicates Hierarchy level, or the parent-child relationship, of the body part. In this case, the abdomen body part is a child of the body part of the part on the next level up. Hierarchy levels are numbered in depending order, so the next level up from this part is 1.

In the example below, the lShin object is located on the 3rd level of the hierarchy. The closest level 2 line above would be the lThigh, so the lShin is a child of the lThigh.

```
2 lThigh yzx
3 lSIan yzx
4 lAnkle yzx
```

*Parent-child relationships indicated in the Hierarchy file.*

The indenting of the lines is not processed but is helpful visually to denote the hierarchy levels.

The second part of the line specifies the name of the body part. In the example the part is called abdomen. This name must match the group name in the OBJ file.

```
2 abdomen zyx
```

*The body part name in a Hierarchy file line.*

The 3-character string at the end of the line represents the rotation (or gimbal) order of the body part. A rotation order defined as “zxy” means that a Z axis rotation occurs first, followed by the X, then Y axis rotations.
The rotation order in a Hierarchy file line.

Poser uses the following XY and Z axis orientations:

The X, Y, and Z planes that make up 3D space.

Assigning a rotation order is a three step process:

- Always place the “twist” axis first. This axis should be placed lengthwise through the object. If the object, like a leg, is built down the Y-axis, specify the Y first since that is the axis along which the leg would twist.

- Of the two remaining rotations, place the one most likely to become 90 degrees last. This helps reduce rotation lock problems that occur when the middle rotation approaches 90 degrees.

- Place the remaining rotation channel second.

- Some objects are built non-aligned to the major axes. In this case, you are able to “align” the coordinate system of the body part later, while adjusting the joint parameters. For the hierarchy file, pick the rotation order that seems closest to what would be desired. When you align the part later, the twist axis you choose becomes aligned down the length of the body part.

### Linking Body Parts Stored in Separate OBJ Files

If each body part were stored in a separate file, rather than all body parts being groups in a single file, you would specify the full path name for the file at the end of each line. This path is relative to the Poser folder.

Here is an example of three links using this method:

```plaintext
1 link1 yzx:Runtime:Geometries:examples:l1.obj
  2 link2 yzx:Runtime:Geometries:examples:l2.obj
  3 link3 yzx:Runtime:Geometries:examples:l3.obj
```
Using Curved Transformations

The Curved flag tells Poser that this link should use curve transformations. This is a method of bending designed for the tails of the animal figures in Poser. Here is an example used in the Horse figure:

```plaintext
2 tail1 zyx curve
   3 tail2 zyx curve
       4 tail3 zyx curve
           5 tail4 zyx curve
```

Inverse Kinematic Chains

The last commands in the hierarchy file specify the links that compose the individual inverse kinematic chains. Inverse Kinematic chains are defined in the following format:

```
ikChain chainName firstLink nextLink nextLink... endGoal
```

In the example above the ikChain is defines as follows:

```
An ikChain line in a Hierarchy file.
```

The name of an ikChain cannot contain spaces.

Verifying Hierarchy Files

Once you begin adjusting the joints you are not able to regenerate the figure file a second time and have all your joint changes in place. Make sure that all Parent-Child relationships are correct before editing joint parameters. You can make geometry corrections later, but you cannot change the hierarchy without creating different joints from scratch again.
## Media Support

<table>
<thead>
<tr>
<th>Format</th>
<th>Preset</th>
<th>Video Codec</th>
<th>Audio Codec</th>
<th>Resolution Limitation</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image Sequence</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>JPEG</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>BMP</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Targa</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>PNG</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>PSD</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>iOS</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>iPhone Movie</td>
<td>(480 x 320)</td>
<td></td>
<td></td>
<td>480 x 320</td>
<td></td>
</tr>
<tr>
<td>iPhone 4 Movie</td>
<td>(960 x 640)</td>
<td></td>
<td></td>
<td>960 x 640</td>
<td></td>
</tr>
<tr>
<td>iPhone 5 Movie</td>
<td>(1136 x 640)</td>
<td></td>
<td></td>
<td>1136 x 640</td>
<td></td>
</tr>
<tr>
<td>iPhone 6 Movie</td>
<td>(1334 x 750)</td>
<td></td>
<td></td>
<td>1334 x 750</td>
<td></td>
</tr>
<tr>
<td>iPhone 6+ Movie</td>
<td>(1920 x 1080)</td>
<td></td>
<td></td>
<td>1920 x 1080</td>
<td></td>
</tr>
<tr>
<td>iPad Movie</td>
<td>(1024 x 768)</td>
<td></td>
<td></td>
<td>1024 x 768</td>
<td></td>
</tr>
<tr>
<td>iPad HD Movie</td>
<td>(1280 x 1024)</td>
<td></td>
<td></td>
<td>1280 x 1024</td>
<td></td>
</tr>
<tr>
<td>M4V</td>
<td>Apple M4V (H-264-AAC)</td>
<td>H.264</td>
<td>AAC</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MP4</td>
<td>MP4 (H.264-AAC)</td>
<td>H.264</td>
<td>AAC</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI (Windows Only)</td>
<td>AVI (MJPEG)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI Movie (DV)</td>
<td></td>
<td></td>
<td></td>
<td>720x480</td>
<td></td>
</tr>
<tr>
<td>AVI Movie (Uncompressed)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI (Video for Windows) (Windows Only)</td>
<td>AVI Movie</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (Macintosh Only)</td>
<td>QuickTime (H.264-AAC)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>QuickTime (H.264-PCM)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>QuickTime (JPEG-AAC)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Poser Reference Manual</td>
<td>Media Support</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (ProRes 422- AAC)</td>
<td>Supports exporting of frames that have Alpha channels</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (ProRes 4444- AAC)</td>
<td>Supports exporting of frames that have Alpha channels</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (ProRes 4444- ALAC)</td>
<td>Supports exporting of frames that have Alpha channels</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (PNG- AAC)</td>
<td>Supports exporting of frames that have Alpha channels</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Legacy QuickTime</td>
<td>QuickTime Movie</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Media Support

<table>
<thead>
<tr>
<th>Format</th>
<th>Preset</th>
<th>Video Codec</th>
<th>Audio Codec</th>
<th>Resolution Limitation</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image Sequence</td>
<td>JPEG</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>BMP</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Targa</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PNG</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PSD</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>iOS</td>
<td>iPhone Movie (480 x 320)</td>
<td></td>
<td></td>
<td>480 x 320</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPhone 4 Movie (960 x 640)</td>
<td></td>
<td></td>
<td>960 x 640</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPhone 5 Movie (1136 x 640)</td>
<td></td>
<td></td>
<td>1136 x 640</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPhone 6 Movie (1334 x 750)</td>
<td></td>
<td></td>
<td>1334 x 750</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPhone 6+ Movie (1920 x 1080)</td>
<td></td>
<td></td>
<td>1920 x 1080</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPad Movie (1024 x 768)</td>
<td></td>
<td></td>
<td>1024 x 768</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPad HD Movie (1280 x 1024)</td>
<td></td>
<td></td>
<td>1280 x 1024</td>
<td></td>
</tr>
<tr>
<td>M4V</td>
<td>Apple M4V (H-264-AAC)</td>
<td>H.264</td>
<td>AAC</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MP4</td>
<td>MP4 (H.264-AAC)</td>
<td>H.264</td>
<td>AAC</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI (Windows Only)</td>
<td>AVI (MJPEG)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>AVI Movie (DV)</td>
<td></td>
<td></td>
<td>720x 480</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AVI Movie (Uncompressed)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AVI (Video for Windows) (Windows Only)</td>
<td>AVI Movie</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QuickTime (Macintosh Only)</td>
<td>QuickTime (H.264-AAC)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Writing Your Own Presets

Some third-party video editing and playing software installs codecs that are not furnished with Windows. Poser does not prompt you to choose a third-party codec when you choose AVI as an output format.

In Windows systems, the default presets for AVI export are located in the `Runtime\plugins\P2_MPDirectShow\avi.xml` file in your Poser installation folder. We recommend that you create your custom presets in a new file that uses a similar format but a different filename (such as `avinew.xml`), and locate your custom file in the same file folder as the `avi.xml` file.

The attributes for the MediaPlugin element in the XML file are as follows:

- **name**: The name of the preset as you want it to appear on the Format menu in the Movie Settings dialog (as shown in the following figure).

- **extensions**: The file extension(s) that are used with the preset.

- **showUI**: Displays the UI available for the codec.

- **video element**: Describes the parameters that will apply to the output video. It has the following optional attributes.

  - **codec**: The name of the video codec that will be used to compress the video
To create your own media presets, you will need to use a text or web page editor to create a file with an XML extension. The format of the XML file should be similar to the following:

```xml
<?xml version="1.0" encoding="utf-8"?>
<Presets>
  <MediaPreset name="AVI (LAGS)" extensions="avi"
    showUI="true">
    <video codec="Lagarith Lossless Codec" framerate="30"/>
    <audio codec="pcm" samplerate="44100" channels="2"/>
  </MediaPreset>
  <MediaPreset name="AVI (MS Video1)" extensions="avi">
    <video codec="MSVC" framerate="30"/>
    <audio codec="pcm" samplerate="44100" channels="2"/>
  </MediaPreset>
  <MediaPreset name="AVI (XVID)" extensions="avi">
    <video codec="XVID" framerate="30"/>
    <audio codec="pcm" samplerate="44100" channels="2"/>
  </MediaPreset>
</Presets>
```

Additional presets added in the Movie Settings dialog.
# Menu Commands and Shortcut Reference

## Animation Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make Movie</td>
<td>CTRL+J</td>
<td>CMD+J</td>
</tr>
<tr>
<td>Recalculate Dynamics &gt; All Cloth</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Recalculate Dynamics &gt; All Hair</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Recalculate Dynamics &gt; All Bullet Physics</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Recalculate Dynamics &gt; All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Retime Animation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resample Key Frames</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bake Transforms &gt; Current Object</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bake Transforms &gt; Current Figure</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bake Transforms &gt; Entire Scene</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Loop Interpolation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quaternion Interpolation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skip Frames</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mute Sound</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Clear Sound</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Play Movie File</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

## Display Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera View &gt; Main Camera</td>
<td>CTRL+M</td>
<td>CMD+M</td>
</tr>
<tr>
<td>Camera View &gt; AuxCamera</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera View &gt; From Left</td>
<td>CTRL+; (semicolon)</td>
<td>CMD+; (semicolon)</td>
</tr>
<tr>
<td>Camera View &gt; From Right</td>
<td>CTRL+’ (apostrophe)</td>
<td>CMD+’ (apostrophe)</td>
</tr>
<tr>
<td>Camera View &gt; From Top</td>
<td>CTRL+T</td>
<td>CMD+T</td>
</tr>
<tr>
<td>Camera View &gt; From Bottom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera View &gt; From Front</td>
<td>CTRL+F</td>
<td>CMD+F</td>
</tr>
<tr>
<td>Camera View &gt; From Back</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera View &gt; FaceCamera</td>
<td>CTRL+= (equal)</td>
<td>CMD+= (equal)</td>
</tr>
<tr>
<td>Camera View &gt; Posing Camera</td>
<td>CTRL+, (comma)</td>
<td>CMD+, (comma)</td>
</tr>
<tr>
<td>Camera View &gt; Right Hand Camera</td>
<td>CTRL+[ (left bracket)</td>
<td>CMD+[ (left bracket)</td>
</tr>
<tr>
<td>Camera View &gt; Left Hand Camera</td>
<td>CTRL+] (right bracket)</td>
<td>CMD+] (right bracket)</td>
</tr>
<tr>
<td>Camera View &gt; Dolly Camera</td>
<td>CTRL+/ (forward slash)</td>
<td>CMD+/ (forward slash)</td>
</tr>
<tr>
<td>Camera Layout &gt; Full Port</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Four Ports</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Three Ports - Big Top</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Three Ports - Big Bottom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Three Ports - Big Left</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Three Ports - Big Right</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Two Ports - Left/Right</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Layout &gt; Two Ports - Top/Bottom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fly Around</td>
<td>CTRL+L</td>
<td>CMD+L</td>
</tr>
<tr>
<td>Frame Selected</td>
<td>CTRL+Shift+= (equal)</td>
<td>CMD+Shift+= (equal)</td>
</tr>
<tr>
<td>Orbit Selected Mode</td>
<td>CTRL+0 (zero)</td>
<td>CMD+0 (zero)</td>
</tr>
<tr>
<td>Show Camera Names</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Production Frame</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Style &gt; Silhouette</td>
<td>CTRL+1</td>
<td>CMD+1</td>
</tr>
<tr>
<td>Document Style &gt; Outline</td>
<td>CTRL+2</td>
<td>CMD+2</td>
</tr>
<tr>
<td>Document Style &gt; Wireframe</td>
<td>CTRL+3</td>
<td>CMD+3</td>
</tr>
<tr>
<td>Document Style &gt; Hidden Line</td>
<td>CTRL+4</td>
<td>CMD+4</td>
</tr>
<tr>
<td>Document Style &gt; Lit Wireframe</td>
<td>CTRL+5</td>
<td>CMD+5</td>
</tr>
<tr>
<td>Document Style &gt; Flat Shaded</td>
<td>CTRL+6</td>
<td>CMD+6</td>
</tr>
<tr>
<td>Document Style &gt; Flat Shaded Lined</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Style &gt; Cartoon</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Style &gt; Cartoon w/Lines</td>
<td>CTRL+7</td>
<td>CMD+7</td>
</tr>
<tr>
<td>Document Style &gt; Smooth Shaded</td>
<td>CTRL+8</td>
<td>CMD+8</td>
</tr>
<tr>
<td>Document Style &gt; Smooth Shaded Lined</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Style &gt; Texture Shaded</td>
<td>CTRL+9</td>
<td>CMD+9</td>
</tr>
<tr>
<td>Figure Style &gt; Use Document Style</td>
<td>CTRL+ALT+0 (zero)</td>
<td>CMD+ALT+0 (zero)</td>
</tr>
<tr>
<td>Figure Style &gt; Silhouette</td>
<td>CTRL+ALT+1</td>
<td>CMD+ALT+1</td>
</tr>
<tr>
<td>Figure Style &gt; Outline</td>
<td>CTRL+ALT+2</td>
<td>CMD+ALT+2</td>
</tr>
<tr>
<td>Figure Style &gt; Wireframe</td>
<td>CTRL+ALT+3</td>
<td>CMD+ALT+3</td>
</tr>
<tr>
<td>Figure Style &gt; Hidden Line</td>
<td>CTRL+ALT+4</td>
<td>CMD+ALT+4</td>
</tr>
<tr>
<td>Figure Style &gt; Lit Wireframe</td>
<td>CTRL+ALT+5</td>
<td>CMD+ALT+5</td>
</tr>
<tr>
<td>Figure Style &gt; Flat Shaded</td>
<td>CTRL+ALT+6</td>
<td>CMD+ALT+6</td>
</tr>
<tr>
<td>Figure Style &gt; Flat Shaded Lined</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Figure Style &gt; Cartoon</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Figure Style &gt; Cartoon w/Lines</td>
<td>CTRL+ALT+7</td>
<td>CMD+ALT+7</td>
</tr>
<tr>
<td>Figure Style &gt; Smooth Shaded</td>
<td>CTRL+ALT+8</td>
<td>CMD+ALT+8</td>
</tr>
<tr>
<td>Figure Style &gt; Smooth Shaded Lined</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Display Menu Commands and Shortcuts</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Figure Style &gt; Texture Shaded</strong></td>
<td>CTRL+ALT+9</td>
<td>CMD+ALT+9</td>
</tr>
<tr>
<td><strong>Object Style &gt; Use Figure Style</strong></td>
<td>CTRL+Shift+0 (zero)</td>
<td>CMD+Shift+0 (zero)</td>
</tr>
<tr>
<td><strong>Object Style &gt; Silhouette</strong></td>
<td>CTRL+Shift+1</td>
<td>CMD+Shift+1</td>
</tr>
<tr>
<td><strong>Object Style &gt; Outline</strong></td>
<td>CTRL+Shift+2</td>
<td>CMD+Shift+2</td>
</tr>
<tr>
<td><strong>Object Style &gt; Wireframe</strong></td>
<td>CTRL+Shift+3</td>
<td>CMD+Shift+3</td>
</tr>
<tr>
<td><strong>Object Style &gt; Hidden Line</strong></td>
<td>CTRL+Shift+4</td>
<td>CMD+Shift+4</td>
</tr>
<tr>
<td><strong>Object Style &gt; Lit Wireframe</strong></td>
<td>CTRL+Shift+5</td>
<td>CMD+Shift+5</td>
</tr>
<tr>
<td><strong>Object Style &gt; Flat Shaded</strong></td>
<td>CTRL+Shift+6</td>
<td>CMD+Shift+6</td>
</tr>
<tr>
<td><strong>Object Style &gt; Flat Shaded Lined</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Object Style &gt; Cartoon</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Object Style &gt; Cartoon w/Lines</strong></td>
<td>CTRL+Shift+7</td>
<td>CMD+Shift+7</td>
</tr>
<tr>
<td><strong>Object Style &gt; Smooth Shaded</strong></td>
<td>CTRL+Shift+8</td>
<td>CMD+Shift+8</td>
</tr>
<tr>
<td><strong>Object Style &gt; Smooth Shaded Lined</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Object Style &gt; Texture Shaded</strong></td>
<td>CTRL+Shift+9</td>
<td>CMD+Shift+9</td>
</tr>
<tr>
<td><strong>Depth Cued</strong></td>
<td>CTRL+Shift+D</td>
<td>CMD+Shift+D</td>
</tr>
<tr>
<td><strong>Tracking &gt; Bounding Boxes Only</strong></td>
<td>CTRL+Shift+A</td>
<td>CMD+Shift+A</td>
</tr>
<tr>
<td><strong>Tracking &gt; Fast Tracking</strong></td>
<td>CTRL+Shift+X</td>
<td>CMD+Shift+X</td>
</tr>
<tr>
<td><strong>Tracking &gt; Full Tracking</strong></td>
<td>CTRL+Shift+C</td>
<td>CMD+Shift+C&lt;</td>
</tr>
<tr>
<td><strong>Deformers &gt; Show All</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Deformers &gt; Hide All</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Deformers &gt; Show Current Selection Only</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Ground Shadows</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Figure Circle</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Bend Body Parts</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Foreground Color</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Background Color</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Show Background Picture</strong></td>
<td>CTRL+B</td>
<td>CMD+B</td>
</tr>
<tr>
<td><strong>Clear Background Picture</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Paste Onto Background</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Show Background Footage</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Clear Background Footage</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Use Background Shader Node</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Guides &gt; Ground Plane</strong></td>
<td>CTRL+G</td>
<td>CMD+G</td>
</tr>
<tr>
<td><strong>Guides &gt; Head Lengths</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Guides &gt; Hip-Shoulder Relationship</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Guides &gt; Horizon Line</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Guides &gt; Vanishing Lines</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Guides &gt; Focus Distance Guide</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Cartoon Settings &gt; One Tone</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Cartoon Settings &gt; Two Tones</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Cartoon Settings &gt; Three Tones</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Cartoon Settings > Three Tones + Highlight
Cartoon Settings > Smooth Toned
Cartoon Settings > Comic Book
Cartoon Settings > Comic Book (Color)
Cartoon Settings > Geometric Edge Lines
Measurement Mode > Off
Measurement Mode > Display
Measurement Mode > Edit  

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>CTRL+Z</td>
<td>CMD+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>CTRL+Shift+Z</td>
<td>CMD+Shift+Z</td>
</tr>
<tr>
<td>Cut</td>
<td>CTRL+X</td>
<td>CMD+X</td>
</tr>
<tr>
<td>Copy</td>
<td>CTRL+C</td>
<td>CMD+C</td>
</tr>
<tr>
<td>Paste</td>
<td>CTRL+V</td>
<td>CMD+V</td>
</tr>
<tr>
<td>Replace</td>
<td>CTRL+Alt+V</td>
<td>CMD+Alt+V</td>
</tr>
<tr>
<td>Copy Picture</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Duplicate</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Previous Selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Next Selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Memorize &gt; Object</td>
<td>CTRL+ALT+E</td>
<td>CMD+ALT+E</td>
</tr>
<tr>
<td>Memorize &gt; Figure</td>
<td>CTRL+ALT+F</td>
<td>CMD+ALT+F</td>
</tr>
<tr>
<td>Memorize &gt; Lights</td>
<td>CTRL+ALT+L</td>
<td>CMD+ALT+L</td>
</tr>
<tr>
<td>Memorize &gt; Camera</td>
<td>CTRL+ALT+H</td>
<td>CMD+ALT+H</td>
</tr>
<tr>
<td>Memorize &gt; All</td>
<td>CTRL+ALT+A</td>
<td>CMD+ALT+A</td>
</tr>
<tr>
<td>Restore &gt; Object</td>
<td>CTRL+E</td>
<td>CMD+E</td>
</tr>
<tr>
<td>Restore &gt; Figure</td>
<td>CTRL+Shift+F</td>
<td>CMD+Shift+F</td>
</tr>
<tr>
<td>Restore &gt; Lights</td>
<td>CTRL+Shift+L</td>
<td>CMD+Shift+L</td>
</tr>
<tr>
<td>Restore &gt; Camera</td>
<td>CTRL+Shift+H</td>
<td>CMD+Shift+H</td>
</tr>
<tr>
<td>Restore &gt; All</td>
<td>CTRL+A</td>
<td>CMD+A</td>
</tr>
<tr>
<td>Special Characters</td>
<td></td>
<td>CMD+ALT+T</td>
</tr>
<tr>
<td>General Preferences</td>
<td>CTRL+K</td>
<td>CMD+K</td>
</tr>
</tbody>
</table>

* Preferences command is found in the application menu in Mac systems
# Figure Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skinning Method &gt; Poser Traditional</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skinning Method &gt; Poser Unimesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skinning Method &gt; Simple Bones Single Skin - Interoperable</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skinning Method &gt; Regenerate Simple Bones Single Skin Weights</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set Figure Parent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Conform To</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Inverse Kinematics &gt; Right Foot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Inverse Kinematics &gt; Left Foot</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Inverse Kinematics &gt; Right Hand</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Inverse Kinematics &gt; Left Hand</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Limits</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Auto Balance</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock Figure</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock Hand Parts</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Create Full Body Morph</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spawn Full Body Morph</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load Full Body Morph</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy Morphs From</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy Measurements From</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy Joint Zones From</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Merge All Zones to Weight Maps</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop to Floor</td>
<td>CTRL+D</td>
<td>CMD+D</td>
</tr>
<tr>
<td>Pose Symmetry &gt; Left to Right</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Right to Left</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Swap Right and Left</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Left Arm to Right Arm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Right Arm to Left Arm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Swap Right and Left Arms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Left Leg to Right Leg</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Right Leg to Left Leg</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Swap Right and Left Legs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Straighten Torso</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pose Symmetry &gt; Custom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rig Symmetry &gt; Left to Right</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rig Symmetry &gt; Right to Left</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rig Symmetry &gt; Left Arm to Right Arm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rig Symmetry &gt; Right Arm to Left Arm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rig Symmetry &gt; Left Leg to Right Leg</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### File Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>CTRL+N</td>
<td>CMD+N</td>
</tr>
<tr>
<td>Open</td>
<td>CTRL+O</td>
<td>CMD+O</td>
</tr>
<tr>
<td>Recent Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td>CTRL+W</td>
<td>CMD+W</td>
</tr>
<tr>
<td>Save</td>
<td>CTRL+S</td>
<td>CMD+S</td>
</tr>
<tr>
<td>Save As</td>
<td>CTRL+Shift+S</td>
<td>CMD+Shift+S</td>
</tr>
<tr>
<td>Revert</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; Background Picture</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; Background Footage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; Poser Document/Prop</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; LipSync Audio</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; Sound</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; BVH Motion</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; 3D Studio</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; DXF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; LightWave</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; Wavefront OBJ</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; COLLADA</td>
<td>RWY</td>
<td></td>
</tr>
<tr>
<td>Import &gt; FBX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import &gt; ZBrush</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; Partial Scene</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; Morph Injection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; Image</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; RIB</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; BVH Motion</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; Alembic</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Windows</td>
<td>Mac</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------</td>
<td>------</td>
</tr>
<tr>
<td>Export &gt; 3D Studio</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; DXF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; LightWave</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; Wavefront OBJ</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; VRML</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; COLLADA</td>
<td>RWY</td>
<td></td>
</tr>
<tr>
<td>Export &gt; FBX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export &gt; ZBrush</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Run Python Script</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Convert Hier File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Install from ZIP Archive</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Setup</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td>CTRL+P</td>
<td>CMD+P</td>
</tr>
<tr>
<td>Exit</td>
<td>CTRL+Q</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Windows</td>
<td>Mac</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Render</td>
<td>CTRL+R</td>
<td>CMD+R</td>
</tr>
<tr>
<td>Area Render</td>
<td>CTRL+ALT+N</td>
<td>CMD+ALT+N</td>
</tr>
<tr>
<td>Render in Background</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Render in Queue</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sketch Style Render</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Antialias Document</td>
<td>CTRL+ALT+R</td>
<td>CMD+ALT+R</td>
</tr>
<tr>
<td>MotionBlur Document</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Render Settings</td>
<td>CTRL+Y</td>
<td>CMD+Y</td>
</tr>
<tr>
<td>Render Dimensions</td>
<td>CTRL+Shift+Y</td>
<td>CMD+Shift+Y</td>
</tr>
<tr>
<td>Materials</td>
<td>CTRL+U</td>
<td>CMD+U</td>
</tr>
<tr>
<td>Reload Textures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reuse Shadow Maps</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Scripts Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scripts &gt; Create Props &gt; fractalTerrain</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Create Props &gt; geom_bucky</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Create Props &gt; geom_genmesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Create Props &gt; geom_tetra</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; bulgeFigsNormal</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; CheckPaths</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; randomExpression</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; RandomizeFigures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; randomizeMorphs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; GeomMods &gt; shrinkFigsNormal</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; MaterialMods &gt; changeGamma</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; MaterialMods &gt; Change Image Filter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; checkFigureMagnets</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; inventory</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; listFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; Poser Runtime Info</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; printFigAndActorInfo</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; printFigureWDStats</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; PrintInfo &gt; printGeomStats</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; RenderControl &gt; RenderPasses</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; SampleCallbacks &gt; eventCallback</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; SampleCallbacks &gt; muscleMag</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; collectSceneInventory</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; compressPoserFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; copyParms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; deleteLights</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; dropActToFloorAllFrames</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; dropFigToFloorAllFrames</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; gravity</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; Link Previous Runtimes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; pmdDiff</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; uncompressPoserFiles</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Utility &gt; wxInspect</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scripts &gt; Metadata Builder</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Window Menu Command and Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animation Palette</td>
<td>CTRL+Shift+V</td>
<td>CMD+Shift+V</td>
</tr>
<tr>
<td>Graph &gt; New</td>
<td>ALT+CTRL+Shift+G</td>
<td>ALT+CMD+Shift+G</td>
</tr>
<tr>
<td>Graph &gt; Remove All</td>
<td>CTRL+Shift+G</td>
<td>CMD+Shift+G</td>
</tr>
<tr>
<td>Libraries</td>
<td>CTRL+Shift+B</td>
<td>CMD+Shift+B</td>
</tr>
<tr>
<td>Hierarchy Editor</td>
<td>CTRL+Shift+E</td>
<td>CMD+Shift+E</td>
</tr>
<tr>
<td>Joint Editor</td>
<td>CTRL+Shift+J</td>
<td>CMD+Shift+J</td>
</tr>
<tr>
<td>Sketch Designer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Walk Designer</td>
<td>CTRL+Shift+W</td>
<td>CMD+Shift+W</td>
</tr>
<tr>
<td>Talk Designer</td>
<td>CTRL+Shift+K</td>
<td>CMD+Shift+K</td>
</tr>
<tr>
<td>Python Scripts</td>
<td>CTRL+Shift+O</td>
<td>CMD+Shift+O</td>
</tr>
<tr>
<td>Recent Renders</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bullet Physics Controls</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Camera Controls</td>
<td>CTRL+Shift+R</td>
<td>CMD+Shift+R</td>
</tr>
<tr>
<td>Preview Styles</td>
<td>CTRL+Shift+U</td>
<td>CMD+Shift+U</td>
</tr>
<tr>
<td>Editing Tools</td>
<td>CTRL+Shift+T</td>
<td>CMD+Shift+T</td>
</tr>
<tr>
<td>Light Controls</td>
<td>CTRL+Shift+I</td>
<td>CMD+Shift+I</td>
</tr>
<tr>
<td>Memory Dots</td>
<td>CTRL+Shift+M</td>
<td>CMD+Shift+M</td>
</tr>
<tr>
<td>Parameter Dials</td>
<td>CTRL+Shift+N</td>
<td>CMD+Shift+N</td>
</tr>
<tr>
<td>Animation Controls</td>
<td>CTRL+Shift+P</td>
<td>CMD+Shift+P</td>
</tr>
<tr>
<td>Log</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Notifications</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Custom Parameters Palette &gt; New</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Custom Parameters Palette &gt; Remove All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Room Tools</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Document Window Size</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Addons &gt; Python Shell</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

## Editing Tools Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Tool</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Rotate Tool</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Tool</td>
<td>Windows</td>
<td>Mac</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Translate Tool</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Translate In-Out Tool</td>
<td>Z</td>
<td>Z</td>
</tr>
<tr>
<td>Scale Tool</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Direct Manipulation Tool</td>
<td>M</td>
<td>M</td>
</tr>
<tr>
<td>Twist Tool</td>
<td>W</td>
<td>W</td>
</tr>
<tr>
<td>Taper Tool</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Chain Break Tool</td>
<td>L</td>
<td>L</td>
</tr>
<tr>
<td>Color Tool</td>
<td>C</td>
<td>C</td>
</tr>
<tr>
<td>Grouping Tool</td>
<td>See Other Tools Shortcut Reference below</td>
<td>See Other Tools Shortcut Reference below</td>
</tr>
<tr>
<td>View Magnifier Tool</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Morphing Tool</td>
<td>H</td>
<td>H</td>
</tr>
</tbody>
</table>

### Other Tools Shortcut Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Tool Grow</td>
<td>=,+</td>
<td>=,+</td>
</tr>
<tr>
<td>Group Tool Grow Edge</td>
<td>0,)</td>
<td>0,)</td>
</tr>
<tr>
<td>Group Tool Shrink</td>
<td>~,'-</td>
<td>~,'-</td>
</tr>
<tr>
<td>Group Tool Shrink Edge</td>
<td>9,(</td>
<td>9,(</td>
</tr>
<tr>
<td>Nudge Weight Paint Up</td>
<td>=,+</td>
<td>=,+</td>
</tr>
<tr>
<td>Nudge Weight Paint Down</td>
<td>~,'-</td>
<td>~,'-</td>
</tr>
<tr>
<td>Weight Paint Mode Add</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Weight Paint Mode Subtract</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Weight Paint Mode Smooth</td>
<td>D</td>
<td>D</td>
</tr>
<tr>
<td>Weight Paint Mode Weight</td>
<td>W</td>
<td>W</td>
</tr>
<tr>
<td>Weight Paint Brush Size 1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Weight Paint Brush Size 2</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>Weight Paint Brush Size 3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Weight Paint Brush Size 4</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Weight Paint Brush Size 5</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>Graph Reset Bounds</td>
<td>HOME</td>
<td>HOME</td>
</tr>
<tr>
<td>End Fly Around</td>
<td>SPACE</td>
<td>SPACE</td>
</tr>
<tr>
<td>Set Range To Spline</td>
<td>Shift+S</td>
<td>ALT+S</td>
</tr>
<tr>
<td>Set Range to Linear</td>
<td>Shift+L</td>
<td>ALT+L</td>
</tr>
<tr>
<td>Set Range to Constant</td>
<td>Shift+C</td>
<td>ALT+C</td>
</tr>
<tr>
<td>Delete Current Actor</td>
<td>DEL, Shift+DEL, BACK, Shift+BACK</td>
<td>DEL, Shift+DEL, BACK, Shift+BACK</td>
</tr>
<tr>
<td>Select Actor</td>
<td>1, KP_1</td>
<td>1, KP_1</td>
</tr>
<tr>
<td>Select Body</td>
<td>2, KP_2</td>
<td>2, KP_2</td>
</tr>
<tr>
<td>Select Camera</td>
<td>3, KP_3</td>
<td>3, KP_3</td>
</tr>
<tr>
<td>Tool</td>
<td>Shortcut</td>
<td>Tool</td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Select Light</td>
<td>4, KP_4</td>
<td>Select Light</td>
</tr>
<tr>
<td>Cycle Multi View</td>
<td>F</td>
<td>Cycle Multi View</td>
</tr>
<tr>
<td>Toggle Multi View</td>
<td>D</td>
<td>Toggle Multi View</td>
</tr>
</tbody>
</table>
Index

3

3D Mouse Settings 40

A

Activating 30
Ambient_Occlusion 382
Angle Measurements 242
Animation Controls 581, 61, 572
Animation Menu 569
Animation Palette 575
Layer Measurements 575
Layers 576
Options 579
Resizing grid 576
Animation Sets 595
Animations 569, 570
Saving 610
Techniques 608
Tools 571
Area Render 84
Auto Balance 213
Auto-save 37

B

Background Color 99
Background Shader Node 100
Bend Body Parts 100, 99
Body Parts 226, 226
Replacing 226
Break Spline Interpolation 582

C

Camera Layout 98
Camera View 98
Cameras 138
Changing 85
Multiple Views 86
Cartoon 97
Cartoon Settings 106, 100
Cartoon with Lines 97
Chain Break 179
Changing Parents 227
Circle Measurements 244
Clear Background Footage 100
Clear Background Picture 99
Clothing 220

Conforming 220
Dynamic 220
Collisions 71
Color 180
Color Blind Accessible 39
Color_Math 348
ColorRamp 349
Colors 88
Comp 349
Conforming Clothing 124
Constant Interpolation 582
Constraint Channels 233
Context Menu 74
Actor 75
Background 83
Camera 81
Figure 76
Light 80
Prop 79
Control Props 247
Copying Pictures 67
Copying to Clipboard 66
Copyright Notice 14
Default 37
Credits 0
Current Actor 73, 173
Custom Parameters 199
Custom Symmetry 216
Custom_Scatter 358
Customer Service 26
Cutting to Clipboard 66
CyclesSurface 337

D

Deformers 99
Delete Figure 217
Depth Cued 99
Direct Manipulation 177
Display 94
Vanishing Lines 105
Display Controls 56
Display Units 39
Options 70
Preview 69
Window Size 72

Document Style 99
Document Window 57
Documentation 18
Drop to Floor 214
Duplicating 67

E
Edge_Blend 350
Editing Tools 55, 174, 172
  Chain Break 179
  Color 180
  Direct Manipulation 177
  Grouping 180
  Morphing 181
  Rotate 176
  Scale 177
  Select 175, 171
  Shortcuts 955
  Taper 179
  Translate In/Out 176
  Translate/Pull 176
  Twist 178
  View Magnifier 181

Elements List 583
Expressions 131
External Binary Morphs 44

F
Faces 131
  Bones 205
  Morphs 201
  Parameters 202
  Phonemes 203
  Posing 201

Figure Circle 99
Figure Style 99
  Conforming Clothing 124, 126
  Deleting 217
  Figure Poses 127
  Hiding 217
  Locking 214
  Parent 229
  Replaced Geometry 227
  Replacing 123
  Showing 217

File Compression 44
  Flat Lined 96
Fly Around 98
  Focus Distance Guide 106
Foreground Color 99
Fractal_Sum 377
Frame Selected 98
frame_number 372
fresnel 383
Fresnel_Blend 350

G
Google Translate 18

Graph 587
  Editing 589
Ground Plane 101
Ground Shadows 98, 99
Grouping 180
Grouping Objects 229
  Using with Figures 233
Guides 101, 100
  Ground Plane 101
  Head Lengths 102
  Hip-Shoulder Relationship 101

H
Hair 133
  Prop 133
Hands 136
  Locking 214
  Posing 208
Hardware Acceleration 73
Head Lengths 102
Hide Figure 217
Hip-Shoulder Relationship 103
Horizon Line 104

I
IK (Inverse Kinematics) 167, 168
Image_Map 387
  Exporting 71
  Mac 29
  Windows 27
Interpolation 581, 589
Inverse Kinematics (IK) 167, 167, 168, 168

K
Keyframe Controls 573
Keyframes 580, 579, 584
  Adding 585
  Copying 586
  Editing 584
  Moving 585
  Recording 575
  Removing 585, 585
  Resampling 587
  Retiming 586
  Selecting 584
  ks_microfacet 369

L
Language 38
Launch Behavior 36, 38
Layers 591
  Base 592
  Controls 593
  Adding 151
  Favorites 161
  Metadata Builder 157
  Purchases 162
  Removing 155
  Searching 158
  Switching 155

Library 112
  Accessing Content 151
  Adding Actors 146
  Adding Items 143
  Adding items to workspace 150
  Camera Category 138
  Categories 121
  Deleting Items 147
  Details Options 118
  Display Options 118
  Displaying 116
  Double-click Behavior 40
  Extended Details 156
  Faces Category 131
  Favorites Tab 112
  File Search 40
  File Structure 147
  Hair Category 133
  Hands Category 136
  Icons 149
  Indexing 40
  Installing from ZIP 148
  Library Tab 112
  Lights Category 138
  List Options 118
  Materials Category 139
  Poses Category 127
  Props Category 137
  Purchases Tab 112
  Scenes Category 141
  Search Options 118
  Search Tab 112
  Subfolders 143
  Tree Options 118

Light Controls 55
Lights 138
Limits 170
Line Measurements 240
Linear Interpolation 582
Lock Figure 214
Lock Hand Parts 214
Locking Objects 211
Log Window 49
Loop 583

M
  Mac Requirements 21
  Manual 24
  Material Poses 129
  Materials 139
    Collections 141
  Materials;Adding to Library 140
  Math_Functions 352
  Measurement Mode 110, 98
  Measurement Objects 239
    Angle 242
    Circle 244
    Line 240
    Polyline 245
  Memorizing 63
  Memory Dots 56, 56, 49
  Menu Bar 54
  Metadata Builder 157
  Morphing Tool 181
  Mouse Input 38
  Multithreaded Bending 36

N
  Notifications 51

O
  Object Style 98
    Duplicating 63
    Grouping 229
    Locking 211
    Memorizing 63
    Pointing At 212
    Restoring 63
  Online Help 18
  OpenGL 73
  Orbit Selected 98
  Outline 95

P
  Closing 46
  Displaying 46
  Docking 46
  Enable/Disable Docking 46
  Floating 46
  Moving 46
  Parameters 189, 182
  Properties 183, 182
  Repositioning 46
  Resizing 46
  Custom 199
  Dial Groups 191
  Dials 193
Adding from Library 142
Closing 63
Compressed 63
Creating 63
Opening 63
Recent 63
Reverting 63
Saving 63
Saving to Library 142
Select 175
Select Figure 73
Select Tool 171
Set Figure Parent 229
Clearing 70
Reusing 70
Ground 98
Preview 87
Shortcuts 38, 946
Shortcuts Editor 61, 61
Show All Figures 217
Show Background Footage 98
Show Background Picture 98
Show Camera Names 98
Silhouette 95
Simple_Color 354
Simulation Proxies 237
Skip Frames 583
Smooth Lined 95
Smooth Shaded 95
Sound 603
Sphere_Map 357
Spline Interpolation 582
SreeD 73
  Custom 216
  Pose 214
System Requirements 21, 21
T
Tablet Mode 38
Talk Designer 604
  Configuring 605, 606
  Emotional tweaks 608
  Head Motions 607
  Input files 605
Taper 179
Technical Support 26
Text Props 238
Texture Shaded 95
Texture Shaded Lined 95
  Reloading 70
Timeline 573
Tracking Mode 98, 86
Trademark 14
Translate In/Out 176
Translate/Pull 176
Translation 167
Twist 178
U
u 373
UI Dots 49
UI Scale 38
Undo/Redo Prefs 36
Undoing Changes 63
Updating 33
Upgrading 32
User_DEFINED 354
V
v 373
Vanishing Lines 101
View Magnifier 181
W
Walk Designer 596
  Applying Walks 601
  Blends and Tweaks 598
  Creating 597
  Figure Types 598
  Loading 599
  Saving 599
  Views 597
  Walk Path 599
Welcome 16
What’s New 16
Windows Requirements 21
Wireframe 95
  Arranging 36
  Removing Items 151